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Introduction

By default, commands and tools used in LibreOffice Draw are grouped in a user interface 
consisting of cascading menus and toolbars. The functions and use of these cascading menus 
and toolbars are described in previous chapters of this user guide.

This chapter describes the user interface variants that are available for LibreOffice Draw. A user 
then has the option to select the user interface that suits their requirements and methods of 
creating drawings in LibreOffice Draw.

Note

When changing the user interface, the variant can be applied only to LibreOffice 
Draw, or applied to all the modules in LibreOffice.

Selecting user interface

To select a user interface variant or switching between the user interface variants:

1) Go to View > User Interface on the Menu bar to open the Select Your Preferred User 
Interface dialog (Figure 1).

2) In UI variants, select one of the variants. An example of the selected variant is shown in 
the Preview box, along with a short description.

3) Click on Apply to Draw to apply the variant selection to LibreOffice Draw only, or click on 
Apply to All to apply the variant to all the LibreOffice modules. The LibreOffice window 
changes to match the selected variant.

4) Click Close to close the dialog.

Figure 1: Select Your Preferred User Interface dialog

Note

If the option Enable experimental features has been selected in the Tools > 
Options > Advanced dialog (macOS LibreOffice > Preferences > LibreOffice 
> Advanced), several more variants appear in UI variants. Being experimental, 
these variants are not described in this user guide.
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Figure 2: Standard Toolbar user interface

Standard Toolbar UI

The Standard Toolbar user interface is the default view when LibreOffice is installed and the 
Workspace opened for the first time. Figure 2 shows an example of the Standard Toolbar user 
interface in LibreOffice Draw, which normally consists of the following. For more information, see 
Chapter 1, Introducing Draw.

• Menu bar at the top of the Workspace.

• Standard toolbar positioned below the Menu bar.

• Line and Filling toolbar positioned below the Standard toolbar.

• Drawing toolbar positioned vertically on the left of the Workspace.

• Sidebar positioned on the right of the Workspace.

Tabbed UI

The Tabbed user interface (Figure 3) provides a familiar interface for users coming from 
proprietary office suites, for example Microsoft Office. This user interface is divided into tabs, 
where each tab displays a set of tools grouped by context. The context changes depending on 
the object selected and the LibreOffice module being used.

It includes a Menu bar, a Tab bar, and tool icons grouped in context that would be normally used 
in LibreOffice Draw. If the tool icons on a tab page do not fit into the width of the Draw window, a 
double chevron >> appears at the right end of the row. Click the double chevron >> to display 
more commands.

On Windows and Linux operating systems, the Menu bar can be hidden or displayed by clicking 
on Menubar at the left end of the Tab bar.
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Figure 3: Tabbed user interface

Figure 4: Tabbed UI Quick Menu

Figure 5: Icon bar

On the right of the Tab bar, a Quick menu (≡) (Figure 4) is available giving access to some 
commonly used commands and links. Some of the Quick menu items have submenus, indicated
by a triangle ► on the right. The Quick menu is the same for all tabs.

On the left of the Tab bar, an icon bar (Figure 5) is available giving access to some commonly 
used tools – Menu bar; Open (Ctrl+O); Save (Ctrl+S);Undo (Ctrl+Z); Redo (Ctrl+Y).

The Tabbed user interface can be customized using the Notebookbar page of the Customize 
dialog (Figure 6) to show or hide the individual tools on the various tabs. For more information on
customization of LibreOffice, see the Getting Started Guide and the Writer Guide.
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Figure 6: Customize dialog — Notebookbar page

Note

When using the Tabbed user interface, the toolbars are removed from view. If it is 
necessary, toolbars can be opened and used by going to View > Toolbars on the 
Menu bar or Quick menu > Toolbars.

Fixed tabs

File tab
The File tab (Figure 7) is a fixed tab providing commands to create new documents; open, save, 
print, and close documents; manage templates; export to PDF and EPUB; display document 
properties; add a digital signature; and sign an existing PDF. 

Figure 7: Tabbed user interface — File tab
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Figure 8: File tab — File menu Figure 9: File tab — Help menu

The File tab has two menus at the right end of the tab. The File menu (Figure 8) contains the 
same commands as the tools available on the tab. The Help menu (Figure 9) provides links to a 
variety of resources.

Home tab
The Home tab (Figure 10) is a fixed tab providing commands to cut, copy, paste, and format text;
insert common items (for example images, tables, charts); apply, update, and edit drawing styles;
and so on.

The Home menu (Figure 11) at the right end of the Home tab provides additional commands that
are not on the tab.

Figure 10: Tabbed user interface — Home tab
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Figure 11: Home tab — Home menu

Insert tab
The Insert tab (Figure 12) is a fixed tab providing tools to insert many commonly used items. The
Insert menu (Figure 13) at the right end of the Insert tab provides some of the same tools.

Figure 12: Tabbed user interface — Insert tab

Figure 13: Insert tab — Insert menu
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Layout tab
The Layout tab (Figure 14) is a fixed tab providing tools to create a drawing layout. The Layout 
menu (Figure 15) at the right end of the Layout tab provides some of the same tools.

Figure 14: Tabbed user interface — Layout tab

Figure 15: Layout tab — Layout menu

Review tab
The Review tab (Figure 16) is a fixed tab providing tools for spell checking text; inserting and 
deleting review comments; and redaction. The Review menu (Figure 17) at the right end of the 
Review tab provides additional text editing commands. Some of these commands appear only if 
Asian or Complex Text Layout are selected in Tools > Options > Language Settings > 
Languages (macOS LibreOffice > Preferences > Language Settings > Languages).

Figure 16: Tabbed user interface — Review tab
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Figure 17: Review tab — Review menu

View tab
The View tab (Figure 18) is a fixed tab providing tools to display a drawing on screen. The View 
menu (Figure 19) at the right end of the View tab provides additional tools relating to the display 
on a drawing on screen.

Figure 18: Tabbed user interface — View tab

Figure 19: View tab — View menu
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Extension tab
The Extension tab (Figure 20) is a fixed tab containing only the command to access the 
Extension Manager allowing the installation of extensions that are compatible for use in 
LibreOffice.

Figure 20: Tabbed user interface — Extension tab and menu

Tools tab
The Tools tab (Figure 21) is a fixed tab providing several tools for macros; color replacer; media 
player. The Tools tab menu (Figure 22) at the right end of the Tools tab provides some of the 
same commands, plus extra tools for organizing macros and dialogs; image map; data sources; 
filter settings; extension manager; and options.

Figure 21: Tabbed user interface — Tools tab

Figure 22: Tools tab — Tools menu
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Additional tabs
Additional tabs appear when an object in Draw is selected and are displayed between the View 
and Extension tabs.

Draw tab
The Draw tab (Figure 23) is only available when a draw object is selected in a drawing. It 
provides commands for editing, transforming, grouping, aligning, and distributing draw objects. 
The Draw tab menu (Figure 24) at the right end of the Draw tab provides a similar set of 
commands for editing, transforming and converting draw objects.

Figure 23: Tabbed user interface — Draw tab

Figure 24: Draw tab — Draw menu

Image tab
The Image tab (Figure 25) only becomes available when an image is selected in a drawing such 
as a photograph, Fontwork, OLE object, or QR code. It provides tools for working with these 
images, including captions, cropping, borders and area styles and colors, anchors, wrapping, 
positioning, and filtering. The Image tab menu (Figure 26) at the right end of the Image tab 
provides links to dialogs for working with images.
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Figure 25: Tabbed user interface — Image

Figure 26: Image tab — Image menu

Object tab
The Object tab (Figure 27) only becomes available when an object, such as a chart, is selected. 
It provides tools to position, resize, choose colors and borders for the selected object. The 
Object tab menu (Figure 28) at the right end of the Object tab provides extra tools to match the 
type of object selected.

Figure 27: Tabbed user interface — Object tab

Figure 28: Object tab — Object menu
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Table tab
The Table tab (Figure 29) only becomes available when a table is selected in a drawing. It 
provides tools to format a table to the drawing requirements. The Table tab menu (Figure 30) at 
the right end of the Table tab provides extra tools for editing a table.

Figure 29: Tabbed user interface — Table tab

Figure 30: Table tab — Table menu

Media tab
The Media tab (Figure 31) only becomes available when a media object is selected in a drawing. 
It provides tools for positioning and running an audio or video file. The Media tab menu 
(Figure 32) at the right end of the Media tab provides extra tools for editing a media object.

Figure 31: Tabbed user interface — Media tab

Figure 32: Media tab — Media menu
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Figure 33: Single Toolbar & Sidebar user interfaces

Single Toolbar UI & Sidebar UI

When selected, the Single Toolbar and Sidebar user interfaces (Figure 33) only show the Menu
bar with no toolbars. However, toolbars can be added to either of these user interfaces by going 
to View > Toolbars on the Menu bar and selecting the required toolbar from the options 
available. For more information on toolbars, see Appendix B, Toolbars in this guide and the 
Getting Started Guide.

Tabbed Compact UI

The Tabbed Compact user interface has the same tabs as the Tabbed user interface, but the 
commands on each tab are arranged as a single row of tools. Some of these tools have 
drop-down menus with extra options. Figure 34 shows an example of the File tab in the Tabbed 
Compact user interface. Clicking on the double chevron >> on the right of the tab bar displays 
more tools for editing an object.

The tab menu on the right of the Tabbed Compact user interface provides the same options as 
the tab menus in the Tabbed user interface, see “Tabbed UI” on page 5 for more information.

Groupedbar Compact UI

The Groupedbar Compact user interface provides access to functions in groups with icons for 
frequently used tools and drop-down menus for other tools. Figure 35 shows an example of a 
Compact Groupedbar user interface with a text object selected in a Draw document and is 
organized as sets of tools and menus. The tools and menus that are available change to suit the 
type of object selected. Clicking on the double chevron >> displays more tools for editing an 
object.
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Figure 34: Tabbed Compact user interface

Figure 35: Groupedbar Compact user interface
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Figure 36: Contextual Single user interface

Contextual Single UI

The Contextual Single user interface displays a single toolbar to suit the type of object that has 
been selected. Figure 36 shows an example of Contextual Single user interface when a draw 
object is selected. Clicking on the double chevron >> displays more tools for editing an object.
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