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Introduction

LibreOffice Draw is a vector graphics drawing program, although it can also perform some 
operations on raster graphics (pixels). Using Draw, you can quickly create a wide variety of 
graphical images.

Vector graphics store and display an image as an assembly of simple geometric elements such as 
lines, circles, and polygons, rather than a collection of pixels (points on the screen). Vector 
graphics allow for easier storage and scaling of the image.

Draw is fully integrated into the LibreOffice suite, and this simplifies exchanging graphics with all 
components of the suite. For example, if you create an image in Draw, reusing it in a Writer 
document is as simple as copying and pasting the image. You can also work with drawings directly 
from within Writer or Impress, using a subset of the functions and tools from Draw.

The functionality of LibreOffice Draw is extensive and, even though it was not designed to rival 
high-end graphics applications, it possesses more functionality than the drawing tools that are 
generally integrated with most office productivity suites.

A few examples of the drawing functions are: layer management, magnetic grid-point system, 
dimensions and measurement display, connectors for making organization charts, 3D functions 
that enable small three-dimensional drawings to be created (with texture and lighting effects), 
drawing and page-style integration, and Bézier curves.

This Draw Guide is not a course book to be worked through from beginning to end. Rather, it is a 
reference work in which you can browse for guidance on particular topics.

This document describes only the functions associated with Draw. Some concepts, such as file 
management or the way the LibreOffice environment works, are mentioned only briefly and are 
covered in more detail in the Getting Started Guide.

Draw main window

The main components of the Draw main window are shown in Figure 1.

Workspace
The large area in the center of the Draw main window (Workspace) is where you create your 
drawings. This drawing area can be surrounded with toolbars and information areas. The number 
and position of the visible tools vary with the task in hand and user preferences, therefore your 
setup may look different from Figure 1.

The maximum size of a drawing page in LibreOffice Draw is limited by your computer setup and 
the page size that you can set and use in your printer.

By default, the Workspace consists of three layers (Layout, Controls and Dimension Lines) and 
the tabs for these default layers appear in the bottom left corner of the Workspace. The default 
layers cannot be deleted or renamed, but you can add layers as and when necessary.

Pages pane
You can split drawings in Draw over several pages. Multi-page drawings are used mainly for 
presentations. The Pages pane, on the left side of the Draw main window, gives an overview of the
pages that you create in your drawing. If the Pages pane is not visible, go to View on the Menu bar
and select Page Pane. To make changes to the page order, drag and drop one or more pages.
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Figure 1: Draw main Window

Layers bar
A layer is a workspace where you insert your drawings elements and objects. The Layers bar is 
located on the bottom of the workplace and contains the guides for layer selection and layer 
command. For more information on layers, see Chapter 11 Advanced Draw Techniques.

Sidebar
The Sidebar has five main decks in Draw. To expand a deck, click on its icon or click on the small 
triangle at the top of the icons and select a deck from the drop-down list. If the Sidebar is not 
visible, go to View on the Menu bar and select Sidebar from the submenu.

Properties
Contains panes for object properties: Page, Character, Paragraph, Lists, Area, Shadow, 
Line, and Position and Size. The visible panes change depending on the object selected.

Shapes
Provides quick selection of most items on the Drawing toolbar: Lines & Arrows, Curves, 
Connectors, Basic Shapes, Symbols, Block Arrows, Flowchart symbols, Callouts, Stars, and 
3D Objects.

Styles
Here you can edit and apply Drawing styles to objects within your drawing. When you edit a 
style, the changes are automatically applied to all of the elements formatted with this style in 
your drawing. (In Draw, Presentation styles are not available.)
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Gallery
Opens the Drawing gallery where you can insert an object into your drawing either as a copy 
or as a link. A copy of an object is independent of the original object. Changes to the original 
object have no effect on the copy. A link remains dependent on the original object. Changes 
to the original object are also reflected in the link.

Navigator
Opens the Draw Navigator, in which you can quickly move between pages in your drawing or
select an object on the drawing. It is recommended to give pages and objects in your 
drawing meaningful names so that you can easily identify them when using the Navigator.

Rulers
You should see rulers (bars with numbers) on the upper and left-hand sides of the workspace. If 
they are not visible, you can enable them by selecting View > Rulers in the Menu bar. The rulers 
show the size of a selected object on the page using double lines (highlighted in Figure 2). When 
no object is selected, they show the location of the mouse pointer, which helps to position drawing 
objects more accurately.

You can also use the rulers to manage object handles and guide lines when positioning objects.

The page margins in the drawing area are also represented on the rulers. You can change the 
margins directly on the rulers by dragging them with the mouse. The margin area is indicated by 
the grayed out area on the rulers as shown in Figure 2.

Figure 2: Rulers showing size of a selected object

Figure 3: Ruler units

To change the measurement units of the rulers, which can be defined independently, right-click on 
a ruler and select the measurement unit from the drop down list, as illustrated for the horizontal 
ruler in Figure 3.
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Status bar
The Status Bar (Figure 4) is located at the bottom of the Draw window and includes several Draw 
specific fields. You can hide the Status Bar by going to View on the Menu bar and deselecting 
Status Bar.

Figure 4: Status bar

Note

The sizes are given in the current measurement unit. They might not be the same as 
the ruler units. The measurement unit on the Status bar is defined in Tools > Options 
> LibreOffice Draw > General, where you can also change the scale of the page.

• Slide number – shows the number of the drawing pane that is selected.

• Information area – shows which action is being carried out, or which object type is 
selected.

• Cursor position and Object size – show different information depending on whether 
objects are selected or not.

• When no object is selected, the position numbers show the current position (X and Y 
coordinates) of the mouse cursor.

• When an object is selected and being resized with the mouse, the object size numbers 
show the size of the object (width and height).

• If an object is selected, the position numbers shows the X and Y coordinates of the 
upper-left corner and the object size number pair displays the size of the object. These 
numbers do not relate to the object itself, but to the selection outline, which is the 
smallest possible rectangle that can contain the visible part or parts of the object; see 
Chapter 3 Working with Objects and Object Points for more information.

• When an object is selected, clicking in either of these areas opens the Position and Size
dialog; see Chapter 4 Changing Object Attributes for more information.

• Unsaved changes – a flag indicating that the file needs saving. Clicking on this flag opens 
the Save as dialog if the file is new and has not been saved before. If the file has been 
saved before any changes, then clicking on this flag after any changes automatically saves 
the file.

• Digital signature – a flag indicating whether the document is digitally signed. After the file 
has been saved, double-clicking on this flag opens the digital signatures dialog.

• Fit drawing – resizes the drawing so that you can see the whole drawing in the 
Workspace.

• Zoom slider and Zoom percentage – adjusts and indicates the zoom percentage of the 
Workspace displayed. Double-clicking on zoom percentage opens the Zoom & View 
Layout dialog.
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Figure 5: Selection of visible toolbar icons

Toolbars
To display or hide the various Draw toolbars, go to View > Toolbars on the main menu bar and 
select from the drop down menu that appears which toolbars you want to display. For example, the
Standard and Drawing toolbars are shown by default, but the Line and Filling, Text Formatting, 
and Options toolbars are not shown.

The appearance of the toolbar icons may vary depending on your operating system and the 
selection of icon size and style in Tools > Options > LibreOffice > View. For more information 
about working with toolbars, see the Getting Started Guide.

You can also select the icons or buttons that you want to appear on toolbars. To change the visible 
icons or buttons on any toolbar, right-click in an empty area on the toolbar and select Visible 
Buttons from the context menu. Visible icons or buttons are indicated by a shaded outline around 
the icon as shown by the icons in Figure 5. Click on an icon to hide or show it in the toolbar.

The tools available in Draw toolbars are described as follows:

Standard toolbar
The Standard toolbar (Figure 6) is the same for all LibreOffice components and is not 
described in detail in this chapter. By default, it is located just under the Main menu bar.

Figure 6: Standard toolbar

Drawing toolbar
The Drawing toolbar (Figure 7) is the most important toolbar in Draw. It contains all the 
necessary functions for drawing various geometric and freehand shapes, and for organizing 
them in the drawing. It is described in detail in Chapter 2 Drawing Basic Shapes.

Figure 7: Drawing toolbar

Line and Filling toolbar
The Line and Filling toolbar (Figure 8) lets you modify the main properties of a drawing 
object. The icons and pull-down lists vary according to the type of object selected. For 
example, to change the style of a line, click on the up and down arrows for Line Style and 
select the required style.
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Figure 8: Line and Filling toolbar

Figure 9: Text Formatting toolbar

The functions on the Line and Filling toolbar let you change the color, style, and width of the
line drawn, the fill color and style, and other properties of an object. The object must first be 
selected with a mouse click. If the selected object is a text frame, the Line and Filling 
toolbar changes to the Text Formatting toolbar (Figure 9).

Text Formatting toolbar
The Text Formatting toolbar (Figure 9) is similar to the Formatting toolbar in Writer and only 
appears when a text object has been selected in your drawing. For an explanation of the 
functions on this toolbar, see Chapter 4 Changing Object Attributes. For information on 
adding and formatting text, see Chapter 9 Adding and Formatting Text.

Options toolbar
Use the Options toolbar (Figure 10) to activate or deactivate various drawing aids. The 
Options toolbar is not displayed by default. To display it, go to View > Toolbars > Options 
on the main menu bar. The tools available on this toolbar are described in greater detail in 
other chapters of this Draw Guide.

Figure 10: Options toolbar

Floating and moving toolbars

Available toolsets
Many icons have a small triangle pointing downward to the right side of the icon. This triangle 
indicates that the icon has additional tools available. Click on the triangle to display the full set of 
tools (Figure 11).

You can “tear off” this toolset so it becomes a floating toolbar. Click the area at the top of the 
toolset as shown in Figure 11, drag it across the screen to a location you want and then release the
mouse button. To close a floating toolbar, click on the X on the right of the toolbar title.

Figure 11: Additional tools and floating 
toolbar
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Note

When a toolset is made into a floating toolbar, the icon on the existing toolbar remains 
in the toolbar and always shows the last tool you used. This means that the icon you 
see on your screen may differ from the icon shown in this guide.

Tip

When you double-click on an icon in a toolbar, the command corresponding to that 
icon will become active and remain active. You can then repeat this action as often as 
you like. To exit from this mode, press the Esc key or click on another icon. Please 
note that this may not work for every icon on every toolbar.

Default toolbars
When you open Draw, the default set of toolbars are already docked or fixed in their positions at 
the top and bottom of the workspace. This default set of toolbars normally consist of the Standard 
and Drawing toolbars. These toolbars can be undocked and become floating toolbars.

• To undock a toolbar, move the mouse cursor to the far left of the toolbar and over the 
toolbar handle (Figure 12). The cursor will change shape, normally a grabbing hand, but 
this is dependent on computer setup and operating system. Click and drag on the toolbar 
handle to move the toolbar until it becomes a floating toolbar. This floating toolbar capability
is common to all components of LibreOffice.

• To dock a floating toolbar at the top of the Draw workspace, press and hold the Ctrl  key 
then double click on the title of the toolbar. The toolbar will move into available space at the 
top of the Draw workspace.

• An alternative method of docking a toolbar is to click in the toolbar title and drag the toolbar 
to the docked position that you require. This can be the top, bottom or one of the sides of 
the Draw workspace.

Figure 12: Toolbar handles

Customizing toolbars
You can customize toolbars in several ways to show or hide icons defined for a toolbar, see 
“Toolbars” and Figure 5 on page 8 for more information.

To add functions to a toolbar, move tools between toolbars, or create new toolbars:

 1) Select View > Toolbars > Customize on the main menu bar, or right click in an empty area
on a toolbar and select Customize Toolbar from the context menu to open the Customize 
dialog (Figure 13).

 2) Select the Toolbars tab, then select the toolbar you want to change from the Target drop-
down list.

 3) Select the desired function from the Assigned Commands list and that function will be 
added to the selected toolbar.

 4) If you want to add a new function to the selected toolbar, click on the new function in the 
Available Commands list and then click on the right facing arrow ➜ to add the new 
function to your selected toolbar.
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Figure 13: Customize dialog

 5) Click on the Settings icon next to the Target drop down list and select how you want the 
toolbar to appear in Draw from the context menu – Icon and text, Icon only, or Text only.

 6) To create a new toolbar, click on the Settings icon next to the Target drop down list and 
select Add. A dialog opens so you can give your new toolbar a name and where you want 
to save the new toolbar.

 7) To change the selected toolbar back to the default set of tools, click on the Defaults button.
Any additional functions that had been added will be removed and the default functions 
added back to the selected toolbar.

 8) Click OK to save your changes and close the dialog.

For more information when adding a new function, or modifying a toolbar, see the Getting Started 
Guide.

Choosing and defining colors

To display the Color Palette currently in use (Figure 14), select View > Color Bar on the main 
menu bar. To close the Color Palette, go to View on the main menu bar and deselect Color Bar. 
Using the Color Palette, you can rapidly choose the color of objects in your drawing (lines, areas, 
and 3D effects). The box with the X at the bottom left of the Color Palette corresponds to none (no
color).

You can also access several specialized color palettes in Draw, as well as change individual colors 
to your own taste. To do this, go to Format > Area on the main menu bar to open the Area dialog 
and click on Color to open the Color page (Figure 15). In the Colors option, click on the Palette 
drop down list and select one of the palettes available in LibreOffice.
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Figure 14: Color Palette

Figure 15: Area dialog - Color page

Alternatively, when an object in your drawing is selected, you change the area or line color of your 
object as follows:

• For the object area color, click on Area in the Properties deck on the Sidebar and select 
Color from the Fill drop down list to change the area color of your object (Figure 16).

• For the object line color, click on Line in the Properties deck on the Sidebar and select 
your color from the Line Color pop up dialog. This is similar to the color palette displayed in
the Area dialog.

For a more detailed description of color palettes and their options, as well as more on the 
difference between the CMYK and RGB color schemes, refer to Chapter 11, Advanced Draw 
Techniques.
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Figure 16: Area and Line sections in 
Sidebar Properties

Grid, snap, and help lines

Draw provides a grid and snap lines as drawing aids and these can be turned on or off by clicking 
on the Display Grid or Display Snap Guides icons on the Line and Filling or Options toolbars. 
The grid and snap lines are displayed only on the screen and are not shown on a printed drawing 
or when the drawing is used in another LibreOffice module. The color, spacing and resolution of 
the grid points can be individually chosen for each axis.

Help lines when moving objects can be displayed and these are turned on or off by clicking on the 
Helplines While Moving icon on the Line and Filling or Options toolbars. Showing the position 
of the object while moving makes positioning the object much easier. If this function is activated, 
pairs of vertical and horizontal lines enclosing the object are shown while moving the object. These
lines extend to the edges of the drawing area.

Draw also offers several snap functions to help you can position objects exactly in a drawing.

For more information on the grid, snap lines, snap functions, and help lines, see Chapter 3 
Working with Objects and Object Points.
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