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Printing

Quick printing

To quickly print a document or drawing, click on Print Directly on the Standard toolbar (Figure 1)
to send the entire document to the default printer that is defined for the computer.

Printdirectly
Standard
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Figure 1: Standard toolbar

Note

The action of Print Directly can be changed by sending a document to the printer
defined for the document instead of the default printer defined for the computer. Go
to Tools > Options > Load/Save > General and select the option Load printer
settings with the document.

Note

If Print Directly is not visible on the Standard toolbar, right-click in an empty area on
the Standard toolbar and select Visible Buttons from the context menu. Select Print
Directly from the displayed list of tools and the tool is added to the Standard toolbar.

Controlled printing

For mare control over printing, open and use the Print dialog (Figure 2 and 3) using one of the
following methods:

¢ Go to File > Print on the Menu bar.
* Use the keyboard shortcut Ctrl+P.
¢ Click on Print on the Standard toolbar.

Note

The options selected in the Print dialog only apply to the printing of the current
document that is open in Draw. To specify default print settings for LibreOffice, go to
Tools > Options > LibreOffice > Print on the main menu bar to open the Options

LibreOffice Print dialog.

Note

Due to different computer setups and different operating systems, the print dialog
that opens on a computer monitor may differ from the dialogs shown in Figure 2
and 3. However, the printing options available for LibreOffice remain the same.
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Print 0

General

Printer

Canon_TS6100 _series -
297 mm (A4) Status: Properties...
Range and Copies
© AllPages
|
. Pages:
E 3
E | WY Selection
= I
~ Include: Odd and Even Pages -
» More
Page Layout
Paper size: A4 210mm x 297mm v
Orientation: | Automatic v
» More
Preview f
Help Cancel Prink

Figure 2: Print dialog - General page

Note

Any print options selected with the Draw Print dialog when printing from Draw will
override the default printer settings that have been set using Tools > Options >
LibreOffice > Print and Tools > Options > LibreOffice Draw > Print.

General options

The following general options are an example of what may be available on the General page of
the Print dialog (Figure 2).

* Printer — select the printer to use from the printers available in the drop-down list.
* Range and Copies — select from the following options:

— All Pages — prints all the pages in the document.

— Pages — select the page number(s) to print. For multiple pages, use the format 1, 3. 7
or1l-5,7,9 for page number selection.

— Selection — select from the drop-down list Odd and Even pages, Odd pages, or Even
pages.

— Paper sides — select from the drop-down list Print on one side (simplex), Print on both
sides (duplex long edge binding), or Print on both sides (duplex short edge binding).

— Number of copies — enter number of printed copies required for document.

— Collate — collates multiple printed copies into separate documents.
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— Order — select from Create separate print jobs for collated output or Print reverse
order.

Print O

LibreOFffice Draw

Contents
Page name

Date and time
297 mm (A4)

Color
© Original colors

Grayscale

Black & white

Size

(—\. © Original size
- Fit to printable page

Distribute on multiple sheets of paper

210 mm

Tile sheet of paper with repeated pages

Preview &
Help Cancel Print

Figure 3: Print dialog - LibreOffice Draw page
* Page Layout — select from the following options:

— Paper size — select the paper size to use from drop-down list
— Oirientation — select from the drop-down list Automatic, Portrait or Landscape.

— Pages per sheet — select from the drop-down list how many pages are printed on one
sheet of paper.

— Order — select from the drop-down list the printing order of multiple pages on one
sheet of paper.

— Draw a border around each page — when multiple pages are printed on one sheet of
paper, a border is drawn around each page.

— Brochure — prints the document so the pages can be folded into a booklet.
LibreOffice Draw options

The following options are available on the LibreOffice Draw page of the Print dialog (Figure 3)
where settings are defined specific to the current document type:

* Contents — prints the Page name and/or Date and time on the drawing.
* Colors — prints the drawing in Original colors, Grayscale, or Black & white.
* Size — print the drawing using one of the following options:

— Original size — prints the drawing using its original size.

— Fit to printable page — the drawing size is changed so that it fits on the paper size
used for printing.
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— Distribute on multiple sheets of paper — used if the drawing is too large for the paper
size being used.

— Tile sheet of paper with repeated pages — used to print multiple copies of a drawing
on a page.

Note

The following printing instructions are examples only. Actual method of printing may
differ from the examples as this depends on computer operating system, computer
setup, and the printer being used.

Single sheet printing of multiple pages
To print multiple pages of a drawing on single sheet of paper:
1) Open the Print dialog, see “Controlled printing” on page 4.
2) Select the printer to use if more than one printer is connected to the computer.

3) In Page Layout, select the number of pages to print per sheet of paper from the Pages
per sheet drop-down list. The preview panel on the right shows how the pages will look on
a printed sheet of paper.

4) In Page Layout, select how the multiple pages are printed on the sheet of paper from the
Order drop-down list.

5) If necessary, select Draw a border around each page to distinguish each page printed on
a sheet of paper.

6) Click OK to print the document and close the Print dialog.

Selecting pages to print

Individual page
1) Open the Print dialog, see “Controlled printing” on page 4.
2) Select the printer to use if more than one printer is connected to the computer.
3) In Ranges and Copies, select Pages and enter the page number of the page to print.

4) Click OK to print the individual pages and close the Print dialog.

Range of pages
1) Open the Print dialog, see “Controlled printing” on page 4.
2) Select the printer to use if more than one printer is connected to the computer.

3) In Ranges and Copies, select Pages and enter the page numbers of the pages to print
using the format, for example, 1,3,7 or 2-5,7,9 for page number selection

4) Click OK to print the pages and close the Print dialog.

Selection printing
1) Open the Print dialog, see “Controlled printing” on page 4.
2) Select the printer to use if more than one printer is connected to the computer.

3) In Ranges and Copies, select Selection and then select Odd and Even pages, Even
pages, or Odd pages from the drop-down list.

4) Click OK to print the pages and close the Print dialog.
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Brochure printing

In Writer, Impress, and Draw, a document can be printed as a brochure (also known as booklet
printing). The pages are arranged so that when the printed pages are folded in half, the pages

are in

the correct order to form a brochure or booklet.

OTip

Plan the document to make it look good when printed as a brochure. Choose
appropriate margins, font sizes, and so on as the pages are normally printed at half
size on a sheet of paper. Experiment to get the best document format to match the
capabilities of the printer being used.

Simplex printer

To print a brochure or booklet on a printer only capable of simplex or single-sided printing:

1) Open the Print dialog, see “Controlled printing” on page 4.

2) Select the printer to use if more than one printer is connected to the computer.

3) In Printer, click Properties to open the properties dialog for the selected printer.

4) Make sure the printer is set to the same orientation (portrait or landscape) as specified in
the page setup for the document. Usually the orientation does not matter, but it does for
brochures.

5) Click OK to close the properties dialog and return to the Print dialog.

6) In Page Layout, select More, then select the Brochure option.

7) In Range and Copies, select Even pages or Odd pages from the Selection drop-down
list.

8) Click OK to print the even or odd pages.

9) Take the printed pages out of the printer and put back into the printer in the correct
orientation to print on the blank side. This may require some testing to find out what the
correct arrangement is for the selected printer.

10) If Even Pages was selected, now select Odd Pages in Range and Copies. If Odd Pages
was selected, now select Even Pages in Range and Copies.
11) Click OK to finish printing the document as a brochure and close the Print dialog.
Duplex printer

To print a brochure or booklet on a printer that is capable of duplex or double-sided printing:

1)
2)
3)
4)

5)
6)

7)

Open the Print dialog, see “Controlled printing” on page 4.
Select the printer to use if more than one printer is connected to the computer.
In Printer, click Properties to open the properties dialog for the selected printer.

Make sure the printer is set to the same orientation (portrait or landscape) as specified in
the page setup for the document. Usually the orientation does not matter, but it does for
brochures.

Click OK to close the properties dialog and return to the Print dialog.

In Range and Copies, select More, then select Print on both sides (duplex long edge)
from the Paper sides drop-down list. Actual options available for duplex printing depend
on the printer model and the computer system being used.

In Page Layout, Select More, then select the Brochure option.
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8) In Range and Copies, select the All Pages option.
9) Click OK to print the document as a brochure and close the Print dialog..

Black and white or grayscale printing

Printer settings
To print documents in black and white or grayscale on a color printer:
1) Open the Print dialog, see “Controlled printing” on page 4.
2) Select the printer to use if more than one printer is connected to the computer.
3) Click on LibreOffice Draw to open the printing options page for LibreOffice Draw.
4) In Color, select Grayscale or Black & white.
5) Click OK to print the document and close the Print dialog.

O Note

Some color printers may only allow printing in color regardless of the settings
selected. More details can be found in the information that came with the selected
printer.

ﬂTip

Grayscale is the best option for printing any colored text or graphics in a document
on a monochrome printer. Colors printed in shades of gray give more detail. When
printing color in black and white some of this detail maybe lost.

LibreOffice settings
To change the LibreOffice settings to print all colored text and graphics as grayscale:

1) Go to Tools > Options > LibreOffice Draw > Print on the Menu bar to open the Options
LibreOffice Draw Print dialog (Figure 4).

Options - LibreOffice Draw - Print

b LibreOffice Page Options Print

b Load/Save © Default Page name

b Language Settings Fit to page Date

+ LibreOffice Draw
General Tile pages fime
View Brochure Hidden pages
Grid

b LibreOffice Base . .
Paper tray from printer settings

b Charts
b Internet Quality
@ Default
Grayscale

Black & white

Figure 4: Options LibreOffice Draw Print dialog
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2) In Quality, select either the option Grayscale or Black & white.
3) Click OK to save the change and close the Options LibreOffice Draw Print dialog.

4) Print the document using one of the above procedures and the document is printed as
grayscale or black and white.

Exporting

LibreOffice can export documents to PDF (Portable Document Format). This industry wide
standard of file format is ideal for sending a file for someone else to view using PDF viewing
software.

Directly as PDF
To export the entire document using default PDF settings is as follows:

1) Click on Export Directly as PDF on the Standard toolbar, or got to File > Export As >
Export Directly as PDF on the Menu bar.

2) Enter a file name and location for the PDF file and click on Save to export the file as PDF.

Note

Note that page range, image compression, or other printing options are not available
when creating a PDF file using this method.

PDF Options 0
General
Range General
O Al Hybrid PDF (embed ODF file)
Pages: Archive (PDF/A, I1SO 19005)
selection PDF/A version:

Universal Accessibility (PDF/UA)
Tagged PDF (add document structure)

View PDF after export

Images
: % Create PDF form
Lossless compression
: ; Submit formakt: =~ FDF hd
o JPEG compression Quality: | 20% =
Allow duplicate field names
Reduce image resolution 300 DPI A
Structure

Watermark Export outlines

Sign with watermark Comments as PDF annotations

Use reference XObjects

Help Cancel Export

Figure 5: PDF Options dialog - General page

10 | Chapter 10, Printing, Exporting and Emailing



Controlling PDF content and quality

For more control over the content and quality of the resulting PDF, use the options available in
the PDF Options dialog (Figure 5). For more information on available options, see the Getting
Started Guide.

1) Goto File > Export As > Export as PDF on the Menu bar to open the PDF Options
dialog.

2) Select the required options available in the General, Initial View, User Interface, Links,
Security and Digital Signatures pages.

3) Click on Export and a file browser window opens.
4) Navigate to the location and enter a file name for the PDF being created.

5) Click on Save to export the file as PDF. The file browser window and the PDF Options
dialog close.

Other formats

LibreOffice can export files in various formats, which are listed in the drop-down list of the file
browser window. For more information on exporting graphics, see Chapter 6, Editing Pictures.

To export a file in another format:
1) Go to File > Export on the Menu bar to open a file browser window.
2) Navigate to the directory where the drawing is going to be saved.
3) Specify a file name for the exported drawing in the Name text box.
4) Select the required file format from the drop-down list.

5) Click on Save to save the file and close the file browser window.

Note

The content of the exported file depends on the elements selected on the drawing. If
no elements are selected, the entire drawing is exported.

HTML Export &

Assign Design
© New design

Select an existing design or create a new one
Help Create Next = Cancel

Figure 6: HTML Export dialog
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Web pages
To export a multi-page Draw document as a series of web pages:
1) Go to File > Export on the Menu bar to open a file browser window.

2) Select HTML Document as the file format and click on Save to open the HTML Export
dialog (Figure 6).

3) Create a New Design or select an Existing design and click on Next.

4) Follow the prompts to create the web pages and save the drawing as an HTML file. For
more information on how to create HTMI file, see the Getting Started Guide.

Emailing documents

LibreOffice provides several ways to send documents quickly and easily as an email attachment
in ODF format (LibreOffice default format), or as a PDF. For more information, see the Getting
Started Guide.

Note

Documents can only be sent from the LibreOffice menu if an email profile has been
set up.

Open Document format
To email the current document in ODF format:

1) Go to File > Send > Email Document on the Menu bar. LibreOffice opens the default
email program with the document attached to a new email.

2) Inthe email program, enter the recipient, subject, and message, then send the email.

PDF format

To email the current document as a PDF file:

1) Go to File > Send > E-mail as PDF on the Menu bar. LibreOffice creates a PDF using the
default PDF settings and then opens the email program with the PDF file attached to a
new email.

2) Inthe email program, enter the recipient, subject, and message, then send the email.

Digital signhatures

A digital signature is a mathematical scheme for verifying the authenticity of digital versions of
drawings or documents.

To sign a drawing digitally, a personal key, also known as a certificate, is required. This personal
key is stored on the computer being used as a combination of a private key, which must be kept
secret, and a public key. These keys are added to a drawing when a digital signature is applied.
A certificate is obtained from a certification authority, which may be a private company or a
government institution.

When a digital signature is applied to a drawing, a checksum is computed from the drawing
content plus the personal key being used. The checksum and public key are stored together with
the drawing.
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When the drawing is opened on another computer with a recent version of LibreOffice, the
program computes the checksum again and compares it with the stored checksum. If both
checksums are the same, the program opens the original, unchanged drawing.

In addition, the program can display the public key information from the certificate. This
information can then be compared with the public key that is published on the web site of the
certificate authority. Whenever the drawing is changed, this change breaks the digital signature.

For a more detailed description of how to obtain, use and manage a certificate and signature
validation, see the Getting Started Guide and “Applying Digital Signatures” in the LibreOffice Help
(https://help.libreoffice.org/7.1/en-US/text/shared/guide/digitalsign_send.html?
&DbPAR=WRITER&System=UNIX).

Removing personal data

It maybe necessary to remove any personal data, versions, notes, hidden information, or
recorded change from drawings before they are sent to other people or PDFs files created from
the drawings.

Setting security and warning options

1) In Tools > Options > LibreOffice > Security, to open Options LibreOffice Security dialog
(Figure 7).

2) Click on Options to open the Security Options and Warnings dialog (Figure 8).

3) Select the required options to allow LibreOffice to warn when drawings contain certain
information and/or automatically remove personal information on saving.

4) Click OK to close the Security Options and Warnings dialog and save the option

selection.
Options - LibreOffice - Security 0

+ LibreOffice Security Options and Warnings

User Data Adjust security related options and define warnings for hidden options

General information in documents. 2

View Passwords For Web Connections
[ Print Persistently save passwords for web connections

- Paths

Fonts

[ searity ]

- Personalization
Application Colors

Macro Securit
Accessibility Y

Adjust the security level for executing macros and specify trusted

Advanced macro developers. Macro Security...
Online Update
| Certificate Path
e Select the Network Security Servi tificate directory to use f
elect the Network Security Services certificate directory to use for =
» Load/save digital signatures. Y y Certificate...
» Language Settings
2 - g‘ 3 TSAs
e Maintain a list of Ti b ing Authority (TSA) URLs to b d F
5 ) aintain a list of Time Stamping Authority s to be used for
» LibreOffice Base digital signatures in PDF export. SAsT
» Charts
b Internet
Help Revert Apply Cancel OK

Figure 7: Options LibreOffice Security dialog
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Security Options and Warnings 0

Security Warnings
Warn if document contains recorded changes, versions, hiddeninformation or notes:
When saving or sending When signing

When printing When creating PDF files
Security Options
Remove personal information on saving
Recommend password protection on saving
Ctrl-click required to open hyperlinks

Block any links from documents not among the trusted locations (see Macro Security)

Help Cancel oK

Figure 8: Security Options and Warnings dialog

Properties of "working drawing” [ ]
General Description Custom Properties Security Font
Change Password

Type: OpenDocument Drawing
Location: /home/peewee/Desktop
Size: 17KB (17,156 Bytes)
Created: 31/05/2021, 13:01:25, Peter Schofield
Modified: 15/06/2021, 15:29:05, Peter Schofield
Template:
Digitally signed: Digital Signatures...
Lask printed:
Total editing time: 25:43:35
Revision number: 13

Apply user data

Reset Properties
Save preview image with this document

Help Reset Cancel oK
Figure 9: Properties dialog

Removing personal data and drawing information

1) Go to File > Properties on the Menu bar to open the Properties dialog (Figure 9) for the
open drawing.

2) Inthe General page uncheck Apply user data.
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3) Click on Reset Properties removing any information in the created and modified fields,
deleting the modification and printing dates, resetting the editing time to zero, resetting
the creation date to the current date and time, and resetting the version number to 1.

4) Click OK to save the changes and close the Properties dialog.

Removing version information
To remove version information from a drawing, use one of the following methods:

* Goto File > Versions on the Menu bar to open a dialog for the drawing, then select the
versions from the list for deletion and click Delete. The dialog automatically closes.

* Goto File > Save As on the Menu bar and save the drawing with a different name.

Redaction

Documents can be redacted to remove or hide any sensitive information allowing the selective
disclosure of information in a document while keeping other parts of the document secret.

When a redacted document is exported to a new document, any redacted portions are removed
and replaced by redaction blocks of pixels. This prevents any attempt to restore or copy the
original contents. A redacted document is often exported in PDF format for publication or sharing.

Any documents that are redacted in LibreOffice Writer, Calc, or Impress are automatically
transferred as a copy to LibreOffice Draw where the redaction is carried out.

Documents, spreadsheets, or presentations

1) Open the document to be redacted in LibreOffice Writer, Calc or Impress, then go to
Tools > Redact on the Menu bar and the following happens:
— A copy of the document is prepared and transferred to LibreOffice Draw as an untitled
file.
— LibreOffice Draw opens with the untitled document document displayed.
— The Redaction toolbar (Figure 10) automatically opens. If the Redaction toolbar is not

displayed, go to View > Toolbars on the Menu bar in LibreOffice Draw and select
Redaction.

Redaction v X

OV BERQ
Figure 10: Redaction
toolbar

2) Goto Tools > Redact on the Menu bar and select either Rectangle or Freeform, or click
on Rectangle Redaction or Freeform Redaction in the Redaction toolbar.

3) Draw the required shapes to redact the sensitive areas in the document. The redaction
shape is gray allowing the sensitive areas in the document to be visible before they are
redacted.

4) If necessary, click on Export Directly as PDF to make an in-redaction copy of the
document as a PDF file. The sensitive information in the redacted areas can then be
reviewed that it is correct before redaction is finalized.

5) Go to Tools > Redact on the Menu bar and select either Redacted Export (White) or
Redacted Export (Black), or click on Redacted Export (White) or Redacted Export
(Black) in the Redaction toolbar. This opens a file browser window.
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6) Navigate to the folder where the redact document is going to be saved and enter a name
for the document, then click on Save to create the redacted PDF file.

— The gray redaction shapes are converted to white or black shapes and the document
is exported as a PDF.

— There is no selectable text in the PDF file and any redacted content is hon-existent.

Drawings

Open a drawing in LibreOffice Draw, then use Steps 2) thru 6) in “Documents, spreadsheets, or
presentations” to create a redacted PDF copy of the drawing file.

Note

When a redacted document is exported as a new PDF file, any redacted portions are
removed from the new document and replaced by redaction blocks of pixels. This
prevents any attempt to restore or copy the original contents.
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