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Alt \_ (Option) or Alt, depending on Used with other keys
keyboard

F11 #+T Open Styles deck in Sidebar

Documentation for LibreOffice is available at https://documentation.libreoffice.org/en/


https://documentation.libreoffice.org/en/
mailto:documentation@global.libreoffice.org
https://creativecommons.org/licenses/by/4.0/
https://www.gnu.org/licenses/gpl.html

Contents

L 0 0 ) 5 o | | 2
(0] 01 1] o101 0] ¢TSRS 2
== 0 | o = Lo PP 2
Publication date and SOftWAIE VEISION...........coiiiiiiiiiiiii it e e e e e e eeeeeennnes 2
Using LibreOffice 0N MaCOS..........ooiiiiiiiii et araaas 2

L 0T LB o 4 o o O 4

Customizing MeNU CONLENT.......cccciiiiiiiirnii s s s e s e mmna s s s e e nnnnnns 4
MOodifying an €XIStING MENU......uuuiiiiiiiii e e e e e e e e e e e e e e et e s e e e e e e eaaaeeearanas 5
Creating @ NEW IMENU......iiieieiiiiie ettt ettt et e e e e e e e e s e s s s bbb e e e ettt et e e e aeeeeaaaaaaaan e e eeeeennnnes 5
Creating @n GCCEIBTATON . .......uuiii ittt e e e e e e e e e e s s r e e et e e e e e e eeeeennna 6

CuStomMizing tOOIDArS......cciiiiiiiieiir e ——————————————— 7
Modifying eXiStiNg TOOIDAIS. .......coiiie e 8
Creating @ NEW LOOIDAY ...t 8
Choosing icons for toolbar COMMENTS...........oiiiiiiiiii e 9

Customizing user interface variants..........cooveemmmmrmmms s 9

Assigning ShortCut KeYs.......ccciii s sssssssssssssssssens 10
Saving Changes 10 @ filE......uuuiii e 11
Loading a saved keyboard configuration...................uuuiiiiiiiiiii e 12
Resetting the SNOMCUL KEYS.... ..ottt e e e e e e e e e ennes 12

ASSIgNING MACKOS 1O EVENLS......uuuuuunnnnnnnnnnnnnnnnnnnnnnnnsnsnsssnnssnsssssssnsssnsssssssssmmsnssssssssssnnnnnns 12

Adding functionality with eXteNSIONS.......ccccceriiiiiiniirss i ——— 12
TS oL T o =2 =] 1] o] TP 12
0] oTo b= L g To J=Y A (=] 15 (o] o TSP 12
Removing and disabling EXtENSIONS. .........uuuiiiiiiiii e e aaans 13

Adding CUSTOM COIOrS......cciemiiiriir i 14

AddiNg fONES.....ueeiiiii i ————————— 15
FINING fre€-lICENSEA fONTS. .. ..eiiiiiiieiiie et e e e e eenes 15

User iNnterface VariantS.......coccceemrrriiniiiissssssnnsssnnssssssssssss s sssssssssssssssss s snsssssssssssssssssssnnns 15
Selecting the USEr INTEITACE. ... s 16
Y = L0 Fo T o BT (=T = Vo= 16
L= 0] o 1To N 01 =] o = Vo = 17

ToTo] o T o > T 17
L@ 11 1 Td Q1 .41 1 1 PPN 18
Example: File tah in WL ..o 18
Tabbed Compact INEITACE...........ui i e e e e an s 19
Groupedbar CompPact INTEITACE. ........oi i i i e e e e e e e e e eans 20
Contextual SINGIE INTEITACE..........oii it e e 20

Chapter 14, Customizing LibreOffice | 3



Introduction

This chapter describes some common customizations that you may wish to carry out.

You can customize menus, toolbars, keyboard shortcuts, and the tabbed interface in LibreOffice,
add new menus and toolbars, assign macros to events, and choose among several user
interface variants.

Other customizations are made easy by extensions that you can install from the LibreOffice
website or from other providers; see “Adding functionality with extensions” on page 12.

O Note

Customized menus and toolbars can be saved in a template. To do so, first save
them in a document and then save the document as a template as described in
Chapter 3, Using Styles and Templates.

Customizing menu content

You can add and rearrange menus on the Menu bar or context (right-click) menus; add,
rearrange, and remove commands on menus, and make other changes.

To customize menus, choose Tools > Customize on the Menu bar. On the Customize dialog, go
to the Menus tab (Figure 1) or the Context Menus tab.

Customize X

Menus Toolbars Notebookbar Context Menus Keyboard Events

Search Scope
Type ‘Libreﬂfﬁce Writer e ‘
Category Target
‘AII commands i | File i | =
Available Commands Assigned Commands
5 vew 5
150% Open...
200%% 157 Open Remote...
Q 3D Color I:T_-) Recent Documents
W E Close
”»ne | =
[[3 About LibreOffice » # Wizards
P Absolute Record rh Templates 4
E‘-} Accept | ey | -
@ Accept All 70 Reload
J‘Zj) Accept and Move to Next Versions...
Eﬁ, ActivationOrder | | e
[E Add Field Save
ab Add Text Box = save As...
Fn_: Add to List v ﬂ Save Remote...
< e - > [% Save a Copy... W
Description Customize
Label: 100%
Command: .uno:Zoom100Percent Insert ™ Modify Defaul
Tooltip: 100%

Figure 1: The Menus tab of the Customize dialog
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Modifying an existing menu

In this example, we are customizing a menu in the Calc component of LibreOffice.

1)

2)

3)

4)

5)

6)

7

In the Scope drop-down list in the upper right of the Customize dialog, choose whether to
save this changed menu for Calc or for a selected document.

In the Target drop-down list, select the menu that you want to customize. The list includes
all the submenus as well as the main menus. The commands on the selected menu are
shown in the Assigned Commands list.

To add a command to the selected menu, click on a command in the Available
Commands list and then click the large right arrow. You can narrow the search by using
the Search box on the top left or selecting the Category in the drop-down list. Use the up
and down arrows on the far right-hand side to move the command into the position where
you want it in the list.

To remove a command from the selected menu, click on it in the Assigned Commands list
and then click the large left arrow.

To insert a separator or submenu, select the item directly before where you want the
inserted item to appear, and use the commands in the Insert drop-down list.

Customize

Insert - Modify Defaults

Insert Separator

Insert Submenu

Figure 2: Insert drop-down

To rename a menu item, select it in the Assigned Commands list and choose Rename in
the Modify drop-down list.

Customize

Insert ™ Modify ™ Defaults

Rename...

Figure 3: Modify drop-down
When you have finished making all your changes, click OK to save them.

Creating a new menu

On the Menus tab of the Customize dialog, click the button next to Target and select Add in the
drop-down list (Figure 4), to display the New Menu dialog (Figure 5).

1)
2)

3)

Type a name for the new menu in the Menu name box.

Use the up and down arrow buttons to move the new menu into the required position on
the Menu bar.

Click OK to save and return to the Customize dialog.

The new menu now appears on the list of menus in the Customize dialog. It will appear on the
Menu bar itself after you save your customizations.

After creating a new menu, you need to add some commands to it, as described above for
modifying a menu.
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Target

File it

Assigned Commands

DNE‘W

Open...

Figure 4: Location of command to add a new menu

Mew Menu >

Menu name:

Mew Menu 1

Menu position:

File ()
Edit

View

Insert

Format

Styles f
Sheet

Data

Tools

Window

Help

Mew Menu 1 A

Help. QK Cancel

Figure 5: Adding a new menu

Creating an accelerator

You can allocate a letter in a custom menu’s hame to be used as a keyboard shortcut. That letter
will become underlined. When you press Alt+that letter, the corresponding menu or command will
be invoked. Existing submenus can also be edited to change the letter which is used to select
them using the keyboard when the menu is open.

To create an accelerator:
1) Select a menu item in the Assigned Commands list on the Customize dialog.
2) Click the Modify button and select Rename.
3) Add a tilde (~) in front of the letter to use as an accelerator.
4) Click OK to save the change.

If for example you put a tilde before the “A” in a menu item Art, the “A” would now be underlined.
Press Alt+A and either the Art submenu will open or the Art menu item will be actioned (as
appropriate).
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Caution

When assigning an accelerator, be careful not to use a letter that is already assigned
to a menu or command associated with a menu item. The same letter-key
combinations can be used for commands associated with different menu items but

not for those associated with the same menu or menu item.

Customizing toolbars

You can customize toolbars in several ways, including choosing which icons are visible and
locking the position of a docked toolbar (as described in Chapter 1, Introducing LibreOffice), and
adding or deleting icons (commands) in the list of those available on a toolbar. You can also
create new toolbars. This section describes how to create new toolbars and add or delete icons

on existing toolbars.

To get to the Toolbars tab of the Customize dialog (Figure 6), do any of the following:

* On the toolbar, right-click on the toolbar and choose Customize Toolbar.
* Choose View > Toolbars > Customize on the Menu bar.
* Choose Tools > Customize on the Menu bar and click on the Toolbars tab.

Customize

Search

Category

‘Allcommands V‘

Available Commands
150%
2008
B 3pcolor
50%
75%
[ About LibreOffice
P+ Absolute Record
@ Accept
@ Accept All
@ Accept and Move to Next
F‘], Activation Order
[ Add Field
ab Add Text Box
I AddtoList
— ... -

< >

Description
Label: 100%

Command: .uno:Zoom100Percent
Tooltip: 100%

Help

Menus Toolbars Notebookbar Context Menus Keyboard Events

Scope

‘Libreﬂ‘f‘ﬁce Writer

Target

‘Standard

£
I

Assigned Commands

[ Load URL

D New

[ Templates
Open

177 Open Remote
Save

OE save as
[C1E Email

[ Edit Mode
[]  Read Only Mode

D Export Directly as PDF
[ epus

& Print

[C]&% Print Directly

Customize

Insert ™ Modify

I

Defaults

Figure 6: The Toolbars tab of the Calc Customize dialog
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Modifying existing toolbars

The procedures for creating and modifying a toolbar are similar to those for menus. In this
example, we are customizing a toolbar in the Calc component of LibreOffice.

To modify an existing toolbar:

1)
2)

3)

4)

5)
6)
7
8)

9)

In the Scope drop-down list on the upper right of the Customize dialog, choose whether
to save this changed toolbar for Calc or for a selected document.

In the Target drop-down list, select the toolbar that you want to customize. The current
toolbar content is displayed in the Assigned Commands list.

Select a command in the Available Commands list on the left. You can narrow your
search by using the Search box on the top left or choosing a category in the drop-down
list just below.

Click on the large right arrow to add the selected command to the Assigned Commands
list for the toolbar (on the right). Use the up and down arrows in the far right to position
the command in the toolbar.

To remove a command from a toolbar, select it in the Assigned Commands list on the
right and click the large left arrow.

To show or hide a command assigned to a toolbar, mark or clear the checkbox by its icon
in the Assigned Commands list on the right.

To insert a separator, select the item directly before where you want the separator to
appear, and use the command in the Insert drop-down list.

To rename a toolbar item, select it in the Assigned Commands list and choose Rename in
the Modify drop-down list.

When you have finished making all your changes, click OK to save them.

Creating a new toolbar

To create a new toolbar:

1)
2)

3)

Choose Tools > Customize on the Menu bar.

On the Toolbars page of the Customize dialog, click the button next to Target and select
Add in the list, to display the Name dialog (Figure 7).

On the Name dialog, type the new toolbar's name and choose in the Save In drop-down
list where to save this new toolbar: for the component (for example, Writer) or for a
selected document.

The new toolbar now appears on the list of toolbars in the Customize dialog. After creating a new
toolbar, you need to add some commands to it, as described above.

@ @ Name
Toolbar name:

New Toolbar 1]

Save in:

LibreOffice Writer .‘]

Help oK Cancel

Figure 7: Naming a new toolbar
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Choosing icons for toolbar commands

Toolbar buttons usually have icons, not words, on them, but not all of the commands have
associated icons.

To choose an icon for a command, select the command and click Modify > Change Icon. On the

Change Icon dialog (Figure 8), scroll through the available icons, select one, and click OK to
assign it to the command.

To use a custom icon, create it in a graphics program and import it into LibreOffice by clicking the
Import button on the Change Icon dialog. For best quality, custom icons should be 24 x 24 pixels
in size; other sizes will be scaled automatically.

Change Icon X
Jer s Import..
U0 BBl ¥ B O e EE e
S AN D) A By =G (U)] =] [ AL
Y RGENTICINIC I IES
e [fx > (0O = © 8] ] =
Ad || = [ A [ o5 0 1S &) v
?hnn:i:ize of an icon should be 24x24 pixel to achieve best quality.
Different sized icons will be scaled automatically.
Help oK Cancel

Figure 8: Change Icon dialog

Customizing user interface variants

By default, LibreOffice’s commands are grouped in cascading menus and in toolbars filled with
icons. In addition, LibreOffice provides other user interface variants, displaying contextual groups
of commands and contents. (See “User interface variants” on page 15.)

In three variants (Tabbed, Tabbed Compact, and Groupedbar Compact), the area at the top of
the workspace is divided into tabs, where each tab displays a set of icons grouped by context.
The context can change depending on the object selected in the document, for example a table
or an image.

After one of these variants has been selected (using View > User Interface), you can use the
checkboxes on the Notebookbar tab of the Customize dialog (Figure 9) to show and hide the
individual options on the various tabs that are provided in the selected user interface.

Use the Reset button to reset the selected configuration to the default settings.
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Custornize *

Menus Toolbars Motebookbar Context Menus Keyboard Events

Target
All Commands =
Assigned Commands

File Tab | File A
£ [ New

D Templates

E Save as Template
Open

® Recent Documents
[~1l" Open Remote
Save

% Save As

@ Save Remote

E} Export

E_.j Export Directly as PDF
| D Export as PDF

[2 eruB

CI[% erus

Figure 9: The Notebookbar tab of the Customize dialog

Assigning shortcut keys

In addition to using the built-in keyboard shortcuts (listed in Appendix A), you can define your
own. You can assign shortcuts to standard LibreOffice functions or your own macros and save
them for use with the entire LibreOffice suite.

Caution

Avoid reassigning your operating system’s predefined shortcut keys.

To adapt shortcut keys to your needs, use the Customize dialog, as described below.
1) Select Tools > Customize and then click the Keyboard tab (Figure 10).

2) To have the shortcut key assignment available in all components of LibreOffice, select
LibreOffice in the upper right section of the dialog.

3) Next select the required function in the Category and Function lists.
4) Now select the desired shortcut keys in the Shortcut Keys list and click the Modify button.

5) Click OK to accept the change. Now the chosen shortcut keys will execute the function
chosen in step 3 above whenever they are pressed.
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Note

All existing shortcut keys for the currently selected function are listed in the Keys
selection box. If the Keys list is empty, it indicates that the chosen key combination is
free for use. If it were not, and you wanted to reassign a shortcut key combination
that is already in use, you must first delete the existing key.

Shortcut keys that are grayed-out in the listing on the Customize dialog, such as F1,
F6, and F10 in Figure 10, are not available for reassignment.

Menus Toolbars Context Menus Keyboard Events

Shortcut Keys @] LibreOffice
F1 ~| ® Calc
F2 Cell Edit Mode
3 Modify
F4 Cycle Cell Reference Types
F5 MNavigator Delete
Fé
F7 Spelling
F8 Status Extended Selection
Fg Recalculate
F10

Load...
F11 Styles =0
F12 Group
F13 §E‘JE...
F14
F15 o Reset
Functions

Type to search

Category Eunction Keys
- cormrand " A

Internal 150%

Application 200%

Ternplates 3D Color

Options 50%

BASIC 5%

Special Functions About LibreOffice

View Absolute Record

Insert

Activation Order

Documents Add

Format Add Decirmal Place

Edit Add Field

MNavigate Address Book Source

Drawing v | |Adjust Scale v

Figure 10: Customizing a keyboard shortcut

Saving changes to a file

Changes to the shortcut key assignments can be saved in a keyboard configuration file for use at
a later time, thus permitting you to create and apply different configurations as the need arises, or
to create a standard keyboard configuration file to be distributed among many users. To save
keyboard shortcuts to a file:

1) After making your keyboard shortcut assignments, click the Save button at the right side
of the Customize dialog (Figure 10).

2) Inthe Save Keyboard Configuration dialog, enter a name for the keyboard configuration
file in the File name box, or select an existing file in the list. If you need to, browse to find
a file from another location (the file extension is . cfg for Configuration).

3) Click Save. A confirmation dialog appears if you are about to overwrite an existing file,
otherwise there will be no feedback and the file will be saved.
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Loading a saved keyboard configuration

To load a saved keyboard configuration file and replace your existing configuration, click the
Load button at the right side of the Customize dialog, and then select the configuration file in the
Load Keyboard Configuration dialog.

Resetting the shortcut keys

To reset all of the keyboard shortcuts to their default values, click the Reset button near the
bottom right of the Customize dialog. Use this feature carefully; no confirmation dialog will be
displayed.

Assigning macros to events

In LibreOffice, when something happens, we say that an event occurred. For example, a
document was opened, a key was pressed, or the mouse moved. You can associate a macro
with an event, so the macro is run when the event occurs. A common use is to assign the “open
document” event to run a macro that performs certain setup tasks for the document.

To associate a macro with an event, use the Events tab of the Customize dialog. For more
information, see Chapter 13, Getting Started with Macros.

Adding functionality with extensions

An extension is a program that can be installed into LibreOffice to add new functionality and
improve your productivity. Template sets, spelling dictionaries, clipart galleries, macros, and
dialog libraries can be packaged as LibreOffice extensions.

Several extensions are bundled with LibreOffice and are installed with the program. These can

only be removed by changing the installation options. Others can be downloaded from various

websites. The official extension repository is located at https://extensions.libreoffice.org/. These
extensions are free of charge.

Some extensions from other sources are free of charge; others are available for a fee. Check the
descriptions to see what licenses and fees apply to the ones that interest you.

Installing extensions
To install an extension that is listed in the repository, follow these steps:

1) In LibreOffice, select Tools > Extension Manager on the Menu bar. In the Extension
Manager dialog (Figure 11), click the Get more extensions online link.

2) A browser window will open. Find the extension you want and download it to your
computer.

3) After the extension is downloaded and saved, return to the Extension Manager dialog and
click Add. Find and select the extension you want to install and click Open. The
extension begins installing. You may be asked to accept a license agreement.

4) When the installation is complete, the extension is listed in the Extension Manager dialog.
To install an extension that is not listed in the repository, download the extension, then continue

with step 3 above.
Updating extensions

Click the Check for Updates button on the Extension Manager dialog to check for updates to
installed extensions.
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Removing and disabling extensions

To remove (uninstall) an extension that you installed, select the extension in the main window of
the Extension Manager dialog and click the Remove button.

To disable an extension without removing (uninstalling) it, select the extension in the Extension
Manager dialog and click the Disable button, which then changes to Enable.

[ 7 Extension Manager — O x

Display Extensions
[ Bundled with LibreOffice! Installed for all users Installed for current user

' English spelling dictionaries, hyphenation... 2020.11.01 Marco A.G.Pinto
! English dictionaries for OpenOffice/LibreOffice 4.0+, It includes: - en_AU [Austr...

French spelling dictionary, hyphenation rules, and thes... 6.3 Dicollecte
fr Dictionnaire «Classique= 6.3 » Synonymes 2.4 » Césures 3.0 Pour signaler une er...

T Solver for Nonlinear Programming 0.9 The Document Foundation

This extension integrates into Calc and offers new Solver engines to use for opti..

Spanish s... _ VERSION__ Open language resources for Spanish (RLA-ES)
Ortografia: _ CORRECTOR_ Separacign: _ SEPARACION_ Sindnimos: _ SINONL...

B

Wiki Publisher 1.2.0 The Document Foundation
ﬁ The Wiki Publisher enables you to create Wiki articles on MediaWiki servers with...

|z
o
0
o
Irm
i
o

Check for Updates Add

Get more extensions onling...

Help Cloze

Figure 11: Extension Manager dialog

OTip

Extensions can be installed from some other places in LibreOffice, such as the
Gallery on the Sidebar, the Templates dialog, the Language Settings > Writing Aids
page of the Tools > Options dialog and the Icon Style section in the View page of
the Tools > Options dialog. In each of these places you will find a small button
leading to a filtered view of the items in the Extensions dialog.

Note

In some cases, the Remove and Disable buttons may be unavailable, for example
when you have selected one of the extensions that was bundled with your
LibreOffice installation.
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Adding custom colors

To add custom colors to a color palette, for example to exactly match a corporate color scheme,
follow this procedure:

1) Insert any drawing object, such as a square, into any document.
2) Right-click on the object and choose Area in the context menu.

3) Click on the Color button to display the page shown in Figure 12. In the Palette drop-
down list in the Colors area, choose which palette you wish to add the new color to.
Under New, define the new color using RGB or Hex notation, or click the Pick button to
select the color on the Pick a Color dialog (Figure 13).

4) Click Add in the lower left corner, enter a name for the new color in the pop-up dialog,
and click OK to save.

5) Delete the drawing object from the document, if it is not needed.

~Alea B

Area Shadow Transparency

None Gradient Bitmap Pattern Hatch

Colors Active New

Palette: |standard e |

ERRERERECICILIL]

[N EEEEEEED

0 O O R [ R e E
LOEREEEEREmC]

] [ [ [ C0 ] [ G [159 G |158 z
(ONEEEEEEERC — _
[N EEEEEEED B |20 B |207 -
SESEEEEEEEEE Hex |729fcf Hex |729fcf
SEEEEEEEEEER - =
ENEEEEEEEEER

Pick

Recent Colors

[ Mame *
Custom Palette Please enter a name for the new color:

Add Delete
Help Reset QK Cancel

Figure 12: Defining a new color
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Pick a Color ot

i U RGB
O Red: h1a :
O Green: 139 =
O Blue: 207 =
Hex & 7295
HSB

® Hue: 211° :

L3

4

L3

L3

L3

() Saturation: | 45% o
' (O Brightness:  |81% :

4

CMYK
Cyan: 45% =
I Magenta: 23% >

Yellow: 0% =

Figure 13: Defining a color by picking it from a color chart

L3

Adding fonts

LibreOffice supports PostScript (. pfb), TrueType (. ttf), and OpenType (.otf) font file formats.
Other font formats exist, and may be supported by your operating system, but these formats may
be limited in selection and quality.

If you have administration privileges, you can install additional fonts through your operating
system; they will then be available for use by all components of LibreOffice.

Finding free-licensed fonts

In addition to proprietary fonts from sources like Adobe, hundreds of free-licensed fonts are
available. You can use, share, and edit free-licensed fonts as you please. Most are available at
no cost. Many are clones or near-variations of classic fonts, but some are original fonts.

Many Linux distributions include a few free-licensed fonts in their package repositories. Other
places where you can find free-licensed fonts include The League of Movable Type
(theleagueofmoveabletype.com), Open Font Library (fontlibrary.org).

User interface variants

By default, commands in LibreOffice are grouped in cascading menus and in toolbars filled with
icons—the standard user interface described in Chapter 1. These menus and toolbars are
described in the chapters that discuss the related tasks and functions.

In addition, LibreOffice Writer, Calc, Draw, and Impress provide other user interface variants,
displaying contextual groups of commands and contents. This section describes these user
interface variants and provides a quick reference to the location of the tools and functions when
using each of the variants. For details, see the user guides for the LibreOffice components.
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Selecting the user interface

When you set up LibreOffice, you can choose one of the user interfaces, and you can switch
between them and the standard interface at any time.

1) Choose View > User Interface on the Menu bar.

2) On the Select Your Preferred User Interface dialog (Figure 14), choose one of the
variants on the left. An example of the variant is shown in the Preview box on the right,
along with a short description.

3) Choose the relevant button to apply your selection to all components of LibreOffice, or
only to the open component. The window changes to match your selection.

4) Click Close to close the dialog.

[ ] Select Your Preferred User Interface

Ul variants Preview
© Standard Toolbar
Tabbed File Edit Insert
| - | .J'r. (] =
Single Toolbar
Sidebar v Slyles B I u &

Tabbed Compact

Groupedbar Compact Standard user interface with menu, toolbar, and collapsed sidebar.
Intended for users who are familiar with the classic interface.

Contextual Single

/ Apply to Writer Close

Figure 14: Selecting a user interface

If you have activated experimental features (Tools > Options > Advanced), several more
choices may appear on the left-hand side. These choices are not described here.

Standard interfaces

Three of the user interface choices in Figure 14 are described in Chapter 1, Introducing
LibreOffice.

Standard toolbar
Classic mode with two visible toolbars: standard and formatting. The sidebar shows only its
tabs.

Single toolbar
Only one toolbar with frequently used features. The sidebar shows only its Show button.

Sidebar
The sidebar is fully opened and only one toolbar (Formatting) is showing.

The elements on each of these standards user interfaces can be modified using the View menu
on the Menu bar.
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Tabbed interface

The Tabbed interface (Figure 15) provides a familiar interface for users coming from proprietary
office suites such as Microsoft Office. It includes a Menu bar, an Icon bar, a Tab bar, icons for the
active tab, one or more tab-specific menus, and a Quick Menu. On Windows and Linux, the
Menu bar can be hidden or displayed by clicking on the Menu Bar icon in the Icon bar (Figure
17).
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Figure 15: Tabbed Interface with Menu bar hidden

The Tabbed interface includes fixed tabs and additional tabs that vary depending on the item
selected (for example, a table or image).

Each tab displays a set of icons grouped by context. The context can change depending on the
location of the cursor or the item selected. Each tab also includes one or more tab-specific drop-
down menus at the right-hand end. The Quick Menu is the same for all tabs.

The Tabbed interface can be customized using the Notebookbar tab of the Customize dialog to
show and hide the individual icons on the various tabs. See “Customizing user interface variants”
on page 9 for more information.

If the icons on a tab do not fit into the width of the LibreOffice window, >> appears at the end of
the row. Click it to display the other commands (Figure 16).

Home ¥ Home
) Find O Table = '::LZoom

@BHQ- IDE@

Figure 16: Displaying more commands on a tab

Icon bar

The icon bar (Figure 17) is located at the top left of the tabs. The sixth icon varies between
components; the illustration shows it for Writer.
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Figure 17: Tabs — Icon bar
1 Menu bar — Show / Hide the menu bar. 4 Undo (Ctrl+Z) — Undo the last action.

2 Open (Ctrl+O) — Open a file browser. 5 Redo (Ctrl+Y) — Redo the last undone action.
3 Save (Ctrl+S) — Save the open file. 6 Print (Ctrl+P) — Open the Print dialog.
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Quick menu

At the right-hand end of the tab bar is a Quick menu (Figure 18) containing some commonly used
commands and links. Some of the Quick menu items have submenus, indicated by arrows on the
right.
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Figure 18: Quick menu

Example: File tab in Writer

The File tab (Figure 19) includes commands to create new documents; open, save, print, and
close documents; manage templates; export to PDF and EPUB; display document properties;
add a digital signature; and sign an existing PDF.

The illustration shows the left and right ends of the tabs separately so they are large enough to
more easily see the commands.
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Figure 19: Tabbed Interface — File tab in Writer

The File tab has two menus (Figure 20): File and Help. The File menu contains the same
commands as the icons on the tab. The Help menu provides links to a variety of resources.
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Figure 20: File tab menus

Tabbed Compact interface

The Tabbed Compact interface has the same tabs as the Tabbed interface, but the commands on
each tab are arranged in a single row of icons, many with drop-down menus of choices.

The Tabbed Compact interface can be customized using the Notebookbar tab of the Customize
dialog to show and hide the individual icons on the various tabs. See “Customizing user interface
variants” on page 9 for more information.
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Figure 21: Tabbed Compact interface example: Insert tab in Writer
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Groupedbar Compact interface

The Groupedbar Compact interface (Figure 22) is divided into groups that contain commands
organized as sets of icons and menus.

The Groupedbar Compact interface can be customized using the Notebookbar tab of the
Customize dialog to show and hide the individual icons on the various tabs. See “Customizing
user interface variants” on page 9 for more information.
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Figure 22: Groupedbar Compact interface example in Writer

The Groupedbar menu (Figure 23) on the right-hand end of this interface provides a subset of
commands, including a convenient way to change the user interface.
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Figure 23: Groupedbar menu in Writer

Contextual Single interface

The Contextual Single interface displays a standard Menu bar and a single toolbar with context-
dependent content.
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