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Introduction

There are two basic ways to format text and other elements. Understanding these two
alternatives is essential for unlocking the power of LibreOffice:

Direct (or manual) formatting
Applies formatting directly to specific paragraphs, characters, pages, frames, lists, tables,
cells, and other elements. For example, you can select a word, then click on a button on
the Formatting toolbar to format the text as bold or italic.

Styles
Bundles formatting options under one name. For example, a paragraph style defines
numerous settings for options such as font type and size, whether paragraphs should be
indented, the space between lines, how paragraphs should be aligned on the page, and
many others.

Using styles is highly recommended

LibreOffice is a styles-based program. It may work somewhat differently from other programs you
are familiar with. Using styles effectively requires some planning, but the time spent in planning
can save time and effort over the longer term.

Because styles apply whole groups of formats at the same time, you can easily format a
document consistently and change the formatting of an entire document with minimal effort.
Styles are used by LibreOffice for many processes, even if you are not aware of them. For
example, Writer relies on heading styles (or other styles you specify) when it compiles a table of
contents. Some common uses of styles are given in “Examples of style use” on page 22.

What are styles?

A style is a set of formats that you can apply to selected elements such as pages, text, frames,
cells, and others in a document to quickly set or change their appearance. Applying a style often
means applying a group of formats at the same time.

Many people manually format paragraphs, words, tables, page layouts, and other parts of their
documents without paying any attention to styles. They are accustomed to manually applying
attributes such as the font family, font size, and any formatting such as bold or italic.

Using styles means that instead of applying “font size 14pt, Times New Roman, bold, centered”
you can apply (for example) a “Title” style, because you have defined the “Title” style to have
those characteristics. In other words, using styles means that you shift the emphasis from what
the text (or page, or other element) looks like, to what the text is.

Note

Direct formatting overrides styles. You cannot remove manual formatting by applying
a style to it. To remove direct formatting, select the text, right-click, and choose Clear
Direct Formatting from the context menu. Alternatively you can clear direct
formatting from selected text by pressing Ctrl+M (Ctrl+Shift+M in Impress), by
selecting Format > Clear Direct Formatting on the Menu bar, by selecting the
Clear Direct Formatting icon on Writer's Formatting toolbar, or by selecting the
Clear Direct Formatting icon on Calc’s Standard toolbar.
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Types of styles in LibreOffice
LibreOffice supports the following types of styles:

Page styles include margins, headers and footers, borders and backgrounds. In Calc,
page styles also define the sequence for printing sheets.

Paragraph styles control all aspects of a paragraph’s appearance, such as text
alignment, tab stops, line spacing, and borders, and can include character formatting.

Character styles affect selected text within a paragraph, such as the font and size of
text, or bold and italic formats.

Table styles apply predefined formats to tables and table elements in a text document.

Frame styles are used to format graphic and text frames, including text wrap, borders,
backgrounds, and columns.

List styles allow you to select, format, and position numbers or bullets in lists.

Cell styles include fonts, alignment, borders, background, number formats (for example,
currency, date, number), and cell protection.

Drawing styles in drawings and presentations include line, area, shadowing,
transparency, font, connectors, dimensioning, and other attributes.

Presentation styles include attributes for font, indents, spacing, alignment, and tabs.

Different styles are available in the various components of LibreOffice, as listed in Table 1.

Details

are given in the user guide for each component.

LibreOffice comes with many predefined styles. You can use the styles as provided, modify them,
or create new ones, as described in this chapter.

Table 1. Styles available in LibreOffice components

Style Type Writer Calc Draw Impress

Page

X

Paragraph

Character

Frame

List

Table

XX | X|X|X|X

Cell

Presentation X X

Drawing X X

Applying styles

LibreOffice provides several ways for you to select and apply styles:

Styles deck in the Sidebar

Fill Format Mode

Styles menu (Writer and Calc)

Set Paragraph Style list (Writer) and Apply Style list (Calc) on the Formatting toolbar
Keyboard shortcuts
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Styles deck in the Sidebar

The Styles deck includes the most complete set of tools for styles. To use it for applying styles:

1) Select View > Styles or Styles > Manage Styles on the Menu bar, or press F11 (38+T on
a Mac), or click the Styles tab on the Sidebar (View > Sidebar to open it).

The Styles deck optionally shows previews of the styles available. Figure 1 shows the
panel for Writer, with Paragraph Styles visible and with previews off.

2) Select one of the buttons at the top left of the Styles deck to display a list of styles in that
category.

3) To apply an existing style, position the insertion point in the paragraph, frame, page, or
word, and then double-click the name of the style in one of these lists. To apply a
character style to more than one word, select the characters first.

ﬂTip

At the bottom of the Styles deck is a drop-down list where you can select what styles
will be listed in the Styles panel. In Figure 1 the list shows All Styles defined for the
document. It could show Applied Styles (only the styles used in the document) or
other groups of styles, for example Custom Styles.

= : Mew Stye from Selection
Paragraph Styles ==& ¢ § § 4 § : Update Selected style
Character Styles w Load Styles

Erednote
First Line

Frame Styles s
Page Styles

List Styles _afams
Table Styes

Fill Format Mode

Header
Shiva Prennsws
Al seyles 1= |

Hizrarchical

Chapter Styles
Lisd 5 tyfes

Indes Styles
Sperial Soyles
HTML Styles
Condibonal Siyles

Figure 1: The Styles deck for Writer, showing paragraph styles and filter

Fill Format mode

Use Fill Format mode to apply a style to many different areas quickly without having to go back to
the Styles deck and double-click every time. This method is quite useful when you need to format
many scattered paragraphs, cells, or other items with the same style:

1) Open the Styles deck and select the style you want to apply.
2) Click the Fill Format Mode button at the top of the Styles deck.

3) To apply a paragraph, page, or frame style, hover the mouse over the paragraph, page,
or frame and click.
To apply a character style, hold down the mouse button while selecting the characters.
Clicking a word applies the character style for that word.
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4) Repeat step 3 until you have applied that style everywhere you desire.
5) To quit Fill Format mode, click the Fill Format Mode button again or press the Esc key.

Styles menu (Writer and Calc)

In Writer, the Styles menu has the most commonly used paragraph, character, and list styles for
text documents, as well as entries for style management. The Styles menu does not have styles
for frames, pages, or tables.

To apply a paragraph style, position the cursor anywhere in the paragraph, and then select one of
the paragraph styles in the Styles menu. To apply a character style to several characters or more
than one word, select the characters first and apply the character style from the menu.

In Calc, the Styles menu has cell styles and style management entries. To apply a cell style,
select the cell or group of cells to be formatted, and then select the required style.

Set Paragraph Style list (Writer) and Apply Style list (Calc)

In Writer, after you have used a paragraph style at least once in a document, the style name
appears in the Set Paragraph Style list at the left-hand end of the Formatting toolbar.

In Calc, after you have used a cell style at least once in a spreadsheet, the style name appears in
the Apply Style list at the left-hand end of the Formatting toolbar. If the Apply Style list is not
visible, you can enable it using one of the methods given in “Customizing toolbars” in Chapter 1,
Introducing LibreOffice.

You can open this list and click the style you want, or you can use the up and down arrow keys to
move through the list and then press Enter to apply the highlighted style.

eTip

Select More Styles at the bottom of the list to open the Styles deck on the Sidebar.

E-B-EH- 1488 = -
| Text Body Bl (% (-1 || Liberation ¢
. Text Body A
J Quotations

- Title

1 Subtitle

Heading 1

Heading 2

Heading 3

22

23

Contents 1

4 Contents 2

Figure 2: The Set Paragraph
Style list in Writer

Keyboard shortcuts

Some keyboard shortcuts for applying styles are predefined. For example, in Writer Ctrl+0
applies the Text Body style, Ctrl+1 applies the Heading 1 style, and Ctrl+2 applies the Heading 2
style. You can modify these shortcuts and create your own; see Chapter 14, Customizing
LibreOffice, for more details.
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Creating and modifying styles

LibreOffice includes some predefined styles, but you can also create custom styles. You can
modify both predefined and custom styles in several ways:

* Change a style using the Styles deck

* Update a style from a selection

* Use AutoUpdate (paragraph and frame styles only)
* Load styles from another document or template

Note

Any changes you make to a style are effective only in the current document. To
change styles in more than one document, you need to change the template.

Changing a style using the Styles deck

To change an existing style using the Styles deck on the Sidebar, right-click on the required style
and select Modify in the context menu.

A Style dialog is displayed with title, content, and layout dependent on the type of style selected.
Each variant of the dialog has several tabs. See the chapters on styles in the component user
guides for more information.

@ ip
You can also access the relevant Style dialogs through the Set Paragraph Style
(Writer) and Apply Style (Calc) lists. Click the arrow at the right of the entry for the
style to be modified and select Edit Style in the context menu. You can access the

appropriate Style dialog for the style of the current selection by going to Styles >
Edit Style on the Menu bar.

Updating a style from a selection
To update a style from a selection:

1) Open the Styles deck on the Sidebar.
2) In the document, select an item that has the format you want to adopt as a style.

Caution

When updating a paragraph style, make sure that the selected paragraph contains
unique properties. If it mixes font sizes or font styles, those mixed properties will
remain the same as before.

3) On the Styles deck, select the style to update, then click on the arrow next to the Styles
actions icon and select Update Selected Style (Figure 3).
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i Styles x| L
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Contents 1 ﬁj
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Figure 3: Updating a style from a selection

0Tip

Other ways to modify the current style include pressing Ctrl+Shift+F11 (Writer),
selecting Styles > Update Selected Style on the Menu bar (Writer and Calc), or
pressing the Update Selected Style icon on the Formatting toolbar (Writer).

You can also modify a style through the Set Paragraph Style (Writer) and Apply
Style (Calc) lists. Click the arrow at the right of the entry for the style to be modified
and select Update to Match Selection from the drop-down menu (see Figure 4).

B-E-H- a3 [N
D2 Ay Liberation Sans 12 pt

|Figure
L Clear formatting

Default Paragraph Style
- Text Body

Title
Subtitle

- e _ &

Figure 4: Modifying a style from the Set Paragraph Style list

L

Update to Match Selection |
Edit Style...

Using AutoUpdate (Writer)

AutoUpdate applies to paragraph and frame styles only. If the AutoUpdate option is selected on
the Organizer page of the Paragraph Style or Frame Style dialog, applying direct formatting to a
paragraph or frame using this style in the document automatically updates the style itself.

eTip

If you are in the habit of manually overriding styles in your document, be sure that
AutoUpdate is not enabled.
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Creating new (custom) styles

You may want to add some new styles. You can do this by using the Style dialog, or the New
Style from Selection tool, or by dragging and dropping, as explained below.

Creating a new style using the Style dialog

To create a new style using the Style dialog, open the Sidebar Styles deck and select the
category of the style you wish to create by clicking one of the icons at the top of the deck. Then
right-click on any style name and select New in the context menu.

The new style will inherit characteristics from the style that you selected. If you later change the
base style (for example, by changing the font from Times to Helvetica), all the linked styles will
change as well. Sometimes this is exactly what you want; other times you do not want the
changes to apply to all the linked styles. You can change any of those characteristics using the
Style dialog.

The dialogs and choices are the same for defining new styles and for modifying existing styles.
See the chapters on styles in the user guides for details.

Creating a new style from a selection

You can create a new style by copying an existing manual format. This new style applies only to
this document; it will not be saved in the template.

1) Open the Styles deck on the Sidebar and choose the category of style you want to
create.

2) In the document, select the item you want to save as a style.

3) On the Styles deck, click on the Styles actions icon and click the New Style from
Selection menu item in Writer or the New Style from Selection icon in Calc, Draw, and
Impress.

4) In the Create Style dialog, type a hame for the new style. The list shows the names of
existing custom styles of the selected category. Click OK to save the new style.

@ [ ] Create Style
Style Name

New Chapter
Guide Name
Heading Note
Text Note
Heading Tip
Heading Caution
Figure

Mo itime T e

Help Cancel

Figure 5: Naming a new style created from a selection

OTip

You can also create a new style from a selection by pressing Shift+F11 (Writer), by
selecting Styles > New Style from Selection (Writer, Calc), or by clicking the New
Style from Selection icon on the Formatting toolbar (Writer).
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Dragging and dropping to create a style

You can drag and drop a selection into the Styles deck to create a new style. The element to drag
depends upon the LibreOffice application.

Writer
Select some text and drag it to the Styles deck to open the Create Style dialog. If
Paragraph Styles are active, the paragraph style will be added to the list. If Character
Styles are active, the character style will be added to the list.

Calc
Drag a cell selection to the Styles deck to open the Create Style dialog and create a cell
style. (Click and then Shift+Click to select the cell.)

Adding table styles in Writer

Table styles are stored in the LibreOffice user profile, and are available to all Writer documents.
You can define new table styles following these steps:

1) Create a table and apply formatting for cells, backgrounds, borders, and more.

2) Select the whole table.

3) Drag the table and drop it in the Table Styles category of the Styles deck in the Sidebar.
Alternatively:

1) Create a table and apply formatting for cells, backgrounds, borders, and more.

2) Click in the table and select Table > AutoFormat Styles on the Menu bar. On the
AutoFormat dialog (Figure 6), click the Add button.

3) Inthe pop-up dialog, enter a name for the new table style, and then click OK.

4) The new table style is now listed in the left pane of the AutoFormat dialog. Click OK again
to close the dialog.

The new table style can be applied to tables as described in “Applying styles” on page 6.

[

[ ) AutoFormat

Defauii Style T | Add
Academic Jan Feb Mar Sum
Box List Blue Noth |6 7 8 21 Delete
Box List Green Mid T 2 |z =
Box List Red PETFR P P T . Rename
Box List Yellow i N
Elegant

Financial

Sum 3 36 33 108

Formatting
Number format Font Alignment

Borders Pattern

Help Cancel _
Figure 6: Table AutoFormat dialog

Copying styles from a template or document (Writer)

In LibreOffice Writer, you can copy styles into a document by loading them from a template or
from another document:

1) Open the document you want to copy styles into.
2) On the Styles deck, click the Style actions icon, and then select Load Styles.
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3) On the Load Styles dialog (Figure 7), find either a template or an ordinary document from
which to copy styles. To select the required document. click the From File button to open
a file selection dialog.

4) Select the categories of styles to copy from the checkboxes at the bottom of the Load
Styles dialog.

5) Select Overwrite if you want to replace styles in the original document that have the
same name as styles in the document from which you are importing styles. If this box is
not selected, you will only copy styles whose nhames are not used in the original
document.

6) Click OK to copy the styles.

®C® Load Styles

Categories Templates
My Templates designing-with-libreoffice
Books drawing sample
Business Correspondence LO 4.4 Chapter Template
Mediawiki LO 5.0 Chapter Template
Other Business Documents LO_3_4_book_template
Personal Correspondence and Documents LO_3_4_chapter_template
Presentation Backgrounds LO_3_ 4 printed_book_template
Presentations Lyn-quartet-6x9

2 Text Frame Pages

Numbering Overwrite

From File... . oK | Cancel Help

Figure 7: Copying styles from a template into the open document

t’rﬁp

You can also access the Load Styles dialog by selecting Styles > Load Styles on
the Menu bar.

Deleting styles

You cannot delete any of LibreOffice’s predefined styles from a document or template, even if
they are not in use.

You can delete any user-defined (custom) styles; but before you do, you should make sure the
styles are not in use in the current document.

To delete any unwanted styles, on the Styles deck select each one to be deleted (hold down the
Control key while selecting multiple styles), and then right-click on a selected style and select
Delete in the context menu.

If the style is not in use, it is deleted immediately without confirmation. If the style is in use, you
receive a warning message asking you to confirm deletion. Select Yes to continue with the
deletion.

Caution

If you delete a style that is in use, all objects with that style will return to the default
style.
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What are templates? Why use them?

Atemplate is a model document that you use to create other documents. For example, you can
create a template for business reports that has your company’s logo on the first page. New
documents created from this template will always have your company’s logo on the first page.

Templates can contain anything that regular documents can contain, such as text, graphics, a set
of styles, and user-specific setup information such as measurement units, language, the default
printer, and toolbar and menu customization.

All documents in LibreOffice are based on templates. You can create, or download and install, as
many templates as you wish, and you can specify a template as the default for each type of
document (text, spreadsheet, drawing, presentation). If you do not choose a template when you
start a new document, then the new document is based on the default template for that type of
document. If you have not specified a default template, LibreOffice uses the blank template for
that type of document that is installed with LibreOffice. See “Setting a default template” on page
19 for more information.

In Writer, you can create templates for master documents as well as for ordinary documents.

Creating a document from a template

A new installation of LibreOffice may not include many templates, but you can create your own
(see “Creating a template” on page 15) or install templates obtained from other sources (see
“Adding templates from other sources” on page 17).

To create a document from a template:

1) Select File > New > Templates on the Menu bar, or select File > Templates > Manage
Templates on the Menu bar, or press Ctrl+Shift+N, or click on the small arrow next to the
New icon on the Standard toolbar and select Templates from the drop-down menu, or
select Templates > Manage Templates in the Start Center. The Templates dialog opens.

2) From the Filter lists at the top of the Templates dialog, you can select the type and
category of template you want to use. All the templates contained in that folder are listed
on the page (as shown in Figure 8).

3) Select the required template and click Open, or double-click on the selected template. A
new document based on the template opens in LibreOffice.

OTip

You can also open a template by double-clicking it in the system's file explorer
window.

The template the document is based upon is listed in File > Properties > General. The
connection between the template and the document remains until the template is modified and,
the next time that the document is opened, you choose not to update it to match the template.

OTip

In the Start Center, click on the Templates button to view the available templates
without opening the Templates dialog. Click on the required template to create a new
document.
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| |search... Filter |Documents All Categaries B

Open

Modern business Edit -9-ebooks bpmn
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Rename
Delete e
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s L8 [2 Move [3 Export [ Import
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Figure 8: Templates dialog, showing context menu for a selected template

Creating a template

You can create templates by saving a document as a template or (in Writer) by using a wizard.

Creating a template from a document

In addition to formatting, any settings that can be added to or modified in a document can be
saved within a template. For example, you can also save printer settings, and general behaviors
set from Tools > Options, such as paths and colors.

Templates can also contain predefined text, saving you from having to type it every time you
create a new document. For example, a letter template may contain your name, address, and
salutation.

You can also save menu and toolbar customization in templates; see Chapter 14, Customizing
LibreOffice, for more information.

To create a template from a document:

1) Open a new or existing document of the type you want to make into a template (text
document, spreadsheet, drawing, or presentation).

2) Add any content that you want to appear in any document you create from the new
template, for example company logo, copyright statement, and so on.

3) Create or modify any styles that you want to use in the new template.

4) On the Menu bar, choose File > Templates > Save as Template. The Save As Template
dialog (Figure 9) opens, displaying the existing categories and a name box.

5) Optionally select a Template category, such as My Templates or Business
Correspondence. You can also set this template as a default template at this time or do it
later.

6) Click Save. The template is saved and the dialog closes.
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[ NON Save As Template

Template Name

., Template Category

None

My Templates

Business Correspondence

Other Business Documents

Personal Correspondence and Documents

Presentations
Styles
Set as default template
Help Cancel Save

FigL}re 9: Save As Template dialog

Creating a template using a wizard
You can use wizards to create templates for letters, faxes, and agendas.

For example, the Fax Wizard guides you through the following choices:

* Type of fax (business or personal)

* Document elements like the date, subject line (business fax), salutation, and
complimentary close

» Options for sender and recipient information (business fax)
« Text to include in the footer (business fax)
To create a template using a wizard:
1) On the Menu bar, choose File > Wizards > [type of template required] (see Figure 10).

2) Follow the instructions on the pages of the wizard. This process is slightly different for
each type of template, but the format is very similar.

Edit View |nsert Format Styles Table Form Tools
L] New % G- &
(% open.. O Liionserit =] [12 = B
2 Open Remote...
! Recent Documents » '
(& Close
E: Wizards » Letter...
Templates b Fax...
Agenda...
Reload
et Document Converter...
B Euro Converter...
ve ctrl+s
H = Address Data Source...
IEl saye Remote... I

Figure 10: Creating a template using a wizard

3) Inthe last section of the wizard, you can specify the template name that will show in the
Templates dialog, and also the name and location for saving the template. The two
names can be different but this may later cause confusion. The default location is your
user templates directory, but you can choose a different location.
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4) To set the file name or change the directory, select the Path button (the three dots to the
right of the location). The Save As dialog opens. Make your selections and click Save to
close the dialog.

5) Finally, you can choose whether to create a new document from the template
immediately, or manually change the template, and then click Finish to save the
template. For future documents, you can re-use the template created by the wizard, just
like any other template.

Adding templates from other sources

LibreOffice refers to sources for templates as repositories. A repository can be local (a directory
on your computer to which you have downloaded templates) or remote (a URL from which you
can download templates).

To get to the official template repository, click the Browse online templates button in the lower
left of the Templates dialog, as shown in Figure 11, or type https://extensions.libreoffice.org/ in
your browser’s address bar.

| |
[EJ [ Move [0 Export [ Import

Browse online templates

| Help Cancel Open

Figure 11: Getting more templates for LibreOffice

On the Extensions web page, in the Search section (Figure 12), click the Templates tag filter.
You can narrow your search by also choosing other tag filters. such as Writer. After setting the
filters, click the Search button. In the search results, find the required template and click on its
name to display a page with details; click the Download button to put the template anywhere on
your computer. Proceed to “Installing templates” below.

Extensions

LibreOffice Extensions, Documentation and Templates repository Extensions

What are you looking for?

SEARCH

Add tag filters: Impress (32)  Writer (140)  Draw (32)  Calc (116)  Gallery (32)  Dictionary (108)  Color Palette (13)
Documentation (30)  Base (9) Math (5)  Extensions (205)  Education (97)  Business (102)  Presentations (50)  lcons (6)
Fun (47)  Documents (140)  Spreadsheets (137)  Drawings (26}  Database (11)  Templates (418)  PDF (1)  Macro (10)

Figure 12: Searching for templates in the repository

On other websites, you may find collections of templates that have been packaged into extension
(.OXT) files.

Installing templates
You can install templates using either the Templates dialog or the Extension Manager dialog.

To install templates using the Templates dialog:
1) Download the template or package and save it anywhere on your computer.
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2) Inthe Templates dialog, click the Import button on the bottom right (see Figure 11). The
Select Category dialog appears.

3) Select the category where you want to import the template and click OK. A standard file
browser window opens.

4) Find and select the template that you want to import and click Open. The file browser
window closes and the template is imported and appears in the selected category.

To install templates using the Extension Manager:

1) Download the template or package and save it anywhere on your computer.

2) In LibreOffice, select Tools > Extension Manager on the Menu bar. In the Extension
Manager dialog, click Add to open a file browser window.

3) Find and select the template or package of templates you want to install and click Open.
The package begins installing. You may be asked to accept a license agreement.

4) When the package installation is complete, restart LibreOffice. The templates are
available for use through the Templates dialog and the extension is listed in the Extension
Manager.

See Chapter 14, Customizing LibreOffice, for more information about the Extension Manager.

OTip

You can manually copy new templates into the template folders. The location varies
with your computer’s operating system. To learn where the template folders are
stored on your computer, go to Tools > Options > LibreOffice > Paths.

Editing a template

You can edit a template’s styles and content, and then, if you wish, you can reapply the
template’s styles to documents that were created from that template. You cannot reapply content.

To edit a template:

1) Open the Templates dialog, as described in step 1 of “Creating a document from a
template” on page 14.

2) In the Templates dialog, find the template that you want to edit. Right-click on it and then
click Edit in the context menu (see Figure 8). The template opens in LibreOffice.

3) Edit the template and save your changes as you would for any other document.

Updating a document from a changed template

If you make any changes to a template and its styles, the next time you open a document that
was created from the template before the changes, a confirmation message is displayed.

To update the document:

1) Click Update Styles to apply the changed styles in the template to the document.

2) Select Keep Old Styles if you do not want to apply the changed styles in the template to
the document (but see the Caution notice below).

Caution

If you choose Keep Old Styles, the document is no longer connected to the
template, even though the template is still listed under File > Properties > General.
To connect the document to the template again, use the procedure described in
“Changing the template assigned to a document” below.
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Changing the template assighed to a document

You can change the template assigned to a document, or reconnect a document to a template, in
two ways: manually or using the Template Changer extension to LibreOffice.

To change or reassign a template manually, first create a new, blank document from the required
template, as described on page 14. Then copy the contents of the old document into the new
document.

To use the Template Changer extension, first you need to download and install it, then restart
LibreOffice to activate it. After that, you can open the document and use File > Templates >
Change template (current document) from the Menu bar.

The Template Changer extension works with Writer, Calc, Draw, and Impress.

Setting a default template

If you create a Writer, Calc, Impress, or Draw document by choosing File > New > [Type of
Document] on the Menu bar, or by selecting one of the buttons in the Create area of the Start
Center, LibreOffice creates the document from the default template for that type of document.
You can, however, change the default whenever you choose.

Setting a template as the default

Most default settings, such as page size and page margins, can be changed in Tools > Options,
but those changes apply only to the document you are working on. To make those changes the
default settings for that document type, you need to replace the default template with a new one.

You can set any template displayed in the Templates dialog to be the default for that document
type:

1) Open the Templates dialog, as described in step 1 of “Creating a document from a
template” on page 14.

2) Inthe Templates dialog, open the category containing the template that you want to set
as the default, then select the template.

3) Right-click on the selected template and click Set as Default in the context menu (see
Figure 8).

The default template is indicated by a green tick mark. The next time that you create a document
of that type by choosing File > New (or equivalent), the document will be created from this
template.

Resetting the default template
To re-enable LibreOffice’s original default template for a document type as the default for that
type:

1) Inthe Templates dialog, click the Settings icon on the bottom left (Figure 13).

2) Point to Reset Default Template in the drop-down menu, and click Text Document (or
other required template type).

These choices do not appear unless a custom template has been set as the default, as described
in the previous section.

You can also reset the default template as follows:

1) Go to the Templates dialog and open the category containing the template you set as
default. It is indicated by a green check mark.

2) Right-click on this template and select Reset Default in the context menu.
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The next time that you create a document by choosing File > New (or equivalent), the document
will be created from the original default template for the document type.

I
|

New Category
Delete Category

Refresh !_ T

[ Reset Default Template > B Text Document

T
Figure 13: Resetting the default template for text documents

Organizing templates

LibreOffice can manage only those templates that are in its template folders (categories),
although you can create a document from a template that is not in one of these folders. You can
create new template categories and use them to organize your templates. For example, you
might have one template category for report templates and another for letter templates. You can
also import and export templates.

To begin, open the Templates dialog as described in step 1 of “Creating a document from a
template” on page 14.

Creating a template category

To create a template category:
1) Click the Settings button in the lower left of the Templates dialog.
2) Click New Category on the context menu (see Figure 14).

3) Inthe pop-up dialog, type a name for the new category and click OK. The new category
now appears in the list of categories.

Mew Category
Delete Category

Refresh F

Figure 14: Creating a new
template category

Deleting a template category

You cannot delete template categories supplied with LibreOffice. Nor can you delete any
categories added by the Extension Manager unless you first remove the extension that installed
them.

However, you can delete a category that you created. Open the Templates dialog, click the
Settings button and select Delete Category in the pop-up menu (see Figure 14). On the Delete
Category dialog, select the category to be deleted and press the OK button. When a message
box appears asking you to confirm the deletion, click Yes.
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Moving a template

To move a template from one template category to another, select it in the Templates dialog, and
click the Move button near the bottom of the dialog. In the Select Category dialog (Figure 15),
select the destination category and click OK. The selected template is moved to the folder. You
can also create a new category into which to move the template.

[ =N ) Select Category
Select from Existing Category

iNone

My Templates
Business Correspondence
Modern business Byfield
letter serif draw
LiibreOffice

Other Business Documents

e or Create a New Category

LibreOffice_6.x_Tem
plate

Help Cancel OK

[ Move [3 Export [ Import

Cancel Open

Figure 15: Moving templates to another category

Renaming a template

You can also rename a template if the current name does not match its purpose. To rename a
template, right click a template and select Rename in the pop up menu. The Enter New Name
dialog opens. Type a name in the Enter New Name text box and click OK.

Deleting a template

You cannot delete templates supplied with LibreOffice. Nor can you delete any templates
installed by the Extension Manager except by removing the extension that installed them.

However, you can delete templates that you have created or imported:

1) In the Filter drop-down lists at the top of the Templates dialog, select the category that
contains the template you want to delete.

2) Select the template to delete.
3) Right-click on the template to open the context menu and click Delete (Figure 8).
4) A message box appears and asks you to confirm the deletion. Click Yes.

Oip
You can also press the Delete button on the keyboard to delete the selected
template on the Templates dialog.

Exporting a template

To export a template from a template category to another location in your computer or network:

1) Inthe Templates dialog, locate the category that contains the template to export.
2) Select the template that you want to export.
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3) Click the Export button in the bottom right of the dialog. The Select Folder or Select Path
dialog opens.

4) Find the folder into which you want to export the template and select Select Folder or
OK.

5) Click OK on the displayed information dialog.

Note

Exporting a template does not remove it from the Templates dialog. The action
places a copy of the template in the location you specify.

Examples of style use

The following examples of common use of page and paragraph styles are taken from Writer.
There are many other ways to use styles; see the guides for the various components for details.

Defining a different first page for a document

Many documents, such as letters and reports, have a first page that is different from the other
pages in the document. For example, the first page of a letterhead typically has a different
header, or the first page of a report might have no header or footer, while the other pages do.
With LibreOffice, you can define the page style for the first page and specify the style for the
following pages to be applied automatically.

As an example, we can use the First Page and Default Style page styles that come with
LibreOffice. Figure 16 shows what we want to happen: the first page is to be followed by the
default page, and all the following pages are to be in the default page style. Details are in
Chapter 5, Formatting Pages: Basics, in the Writer Guide.

First Default
Page

Figure 16: Flow of page styles

Dividing a document into chapters

In a similar way, you can divide a document into chapters. Each chapter might start with the First
Page style, with the following pages using the Default Style page style, as above. At the end of
the chapter, insert a manual page break and specify the next page to have the First Page style to
start the next chapter, as shown in Figure 17.
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Figure 17: Dividing a document into chapters using page styles
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Changing page orientation within a document

A Writer document can contain pages in more than one orientation. A common scenario is to
have a landscape page in the middle of a document, where the other pages are in a portrait
orientation. This setup can also be created with page breaks and page styles.

To insert a landscape page in the middle of your document, position the cursor at the point where
you want to start the new (landscape) page. Click Insert > More Breaks > Manual Break on the
Menu bar. In the Insert Break dialog, select Page Break under Type, and select a page style with
landscape orientation in the Page Style list. Click OK to insert the page. To go back to the portrait
page style, insert another page break and select the portrait page style you are using (which may
be Default Page Style, if you haven’t selected or created a different one). See the Writer Guide
for more information.

Controlling page breaks automatically

Writer automatically flows text from one page to the next. If you do not like the default settings,
you can change them. For example, you can require a paragraph to start on a new page or
column and specify the style of the new page. A typical use is for chapter titles to always start on
a new right-hand (odd-numbered) page.

Compiling an automatic table of contents

To compile an automatic table of contents, first apply styles to the headings you want to appear in
the contents list, then use Tools > Chapter Numbering to tell Writer which styles go with which
level in the table of contents. By default, tables of contents use Heading styles, but you can use
whatever combination of styles you prefer. See Chapter 4 in this guide for more information.

Defining a sequence of paragraph styles

You can set up one paragraph style so that when you press Enter at the end of that paragraph,
the following paragraph automatically has the style you wish applied to it. For example, you could
define a Heading 1 paragraph to be followed by a Text Body paragraph. A more complex
example would be: Title followed by Author followed by Abstract followed by Heading 1 followed
by Text Body. By setting up these sequences, you can usually avoid having to apply styles
manually.
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