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Saving slide shows

Slide shows created in Impress are, by default, saved in the Open Document Presentation (ODP)
format. However, Impress can open and save a slide show in other widely used and recognized 
presentation formats.

New slide show

1) Create a new slide show. For more information, see Chapter 1, Introducing Impress and 
Chapter 9, Slide Shows and Photo Albums.

2) Save the new slide show using one of the following methods to open the Save as dialog 
(Figure 1).

– Click on Save on the Standard toolbar.

– Go to File > Save on the Menu bar.

– Use the keyboard shortcut Ctrl+S.

3) Navigate to where you want to save the slide show.

4) Enter a filename in the File name text box.

5) Select a file format from the File type drop down list. By default, the file format is Open 
Document Presentation (.odp).

6) Click on Save to save the slide show and close the Save as dialog.

Figure 1: Save As dialog
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Figure 2: Confirm File Format dialog

Note

If you are NOT saving the slide show in the ODP presentation format, a Confirm File 
Format dialog (Figure 2) opens asking you to confirm the file format you have 
selected.

ODP format

1) Open a slide show in Impress and make all the required changes. Impress will open slide 
shows that have been saved in a presentation format that Impress recognizes.

2) Save the slide show in ODP format using one of the following methods:

– Click on Save on the Standard toolbar.

– Go to File > Save on the Menu bar.

– Use the keyboard shortcut Ctrl+S.

Other presentation formats

1) Open a slide show in Impress and make all the required changes. Impress will open slide 
shows that have been saved in a presentation format that Impress recognizes.

2) Save the slide show in a presentation format that Impress recognizes, use one of the 
following methods:

– Click the small triangle ▼ to the right of the Save icon on the Standard toolbar and 
select Save As from the drop down menu.

– Go to File > Save As on the Menu bar.

– Use the keyboard shortcut Ctrl+Shift+S.

3) In the Save as file browser that opens, navigate to where you want to save the slide 
show.

4) Enter a filename in the File name text box.

5) Select a presentation file format from the File type drop down list. By default, the file 
format is Open Document Presentation (.odp).

6) Click on Save to save the slide show and close the Save as dialog.
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Figure 3: Print dialog - General page

Figure 4: Print dialog - LibreOffice Impress page

Printing

Impress provides many options for printing slides or a complete presentation. For example 
multiple slides on one page, single slide per page, slides with notes, as an outline, with date and 
time, with page name, and so on. For more information on printing LibreOffice documents, see 
the Getting Started Guide.
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Any printing options selected in Impress using the Print dialog (Figure 3 and Figure 4) only apply 
to the printing of the current document. To specify default printing settings for Impress, go to 
Tools > Options > LibreOffice > Print and Tools > Options > LibreOffice Impress > Print.

Note

Any print options selected with the Print dialog when printing from Impress will 
override the default printer settings that have been set using Tools > Options > 
LibreOffice > Print and Tools > Options > LibreOffice Impress > Print.

Printing slides

1) Open the Print dialog using one of the following methods:

– Go to File > Print on the Menu bar.

– Use the keyboard shortcut Ctrl+P.

– Click on Print on the Standard toolbar.

2) Click on the General tab to open the page for general print options (Figure 3).

a) If necessary, select a printer from the Printer drop down list of printers available.

b) If necessary, in Printer click on Properties to display a properties dialog for the 
selected printer and select the options required. Click OK to save your Properties 
selection and close the dialog. Actual printer properties available depend on the 
printer selected and computer operating system being used.

c) Select the slides to print, the paper side to print on (simplex or duplex), number of 
copies, and the print order from the options available in Range and Copies.

d) Select the paper size, orientation, pages per sheet, and, if necessary, brochure 
printing from the options available in Page Layout.

3) Click on the LibreOffice Impress tab to open the page for LibreOffice Impress print 
options (Figure 4).

a) Select the document type, slides per page and the printing order from the drop down 
lists in Document.

b) Select whether to print slide name, date and time, or hidden pages from the options 
available in Contents.

c) Select the type of color to print from the options available in Color.

d) Select the printed size from the options available in Size.

4) On the General or LibreOffice Impress page, click on More Options and select if you 
want to Create separate print jobs for a collated output when printing multiple copies of 
your slides.

5) Click OK to print your slides and close the Print dialog.

Brochure printing

You can print your slides arranged so that, when printed, the slides are in the correct order to 
form a booklet or brochure.
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Note

The procedures given below are only examples. The actual procedure may differ as 
this depends on the computer operating system and type of printer being used. You 
may have to experiment to find the correct method for brochure printing.

Single sided printing

The following procedure is an example of how to create a brochure or booklet using a printer that
is only capable of printing single sided.

1) Open the Print dialog using one of the following methods:

– Go to File > Print on the Menu bar.

– Use the keyboard shortcut Ctrl+P.

– Click on Print on the Standard toolbar.

2) Click on the General tab to open the page for general print options.

3) Click on Properties and check the printer is set to the same page orientation as specified
for the page setup for your slides. Usually page orientation does not matter, but it is 
important for brochures.

4) Click OK to close the properties dialog return to the Print dialog.

5) In Range and Copies section, select the All Slides option. A minimum of four slides is 
required to create a brochure.

6) In the Range and Copies section, select the Number of copies required to match the 
required number of brochures.

7) In the Layout section, select the Brochure option.

8) In the Range and Copies section, select Even slides option.

9) Click OK to print the Even slides.

10) Take the printed slides out of the printer and put them back into the printer in the correct 
orientation to print on the other side of the paper. You may need to experiment a bit to find
out what the correct arrangement is for your printer.

11) In the Range and Copies section, select Odd slides option.

12) In the Range and Copies section, select the same Number of copies used for printing the
Even slides.

13) Click OK to print the Odd slides and close the Print dialog.

14) Assemble your brochures and bind them, if necessary.

Double sided or duplex printing

Printing a brochure on a printer that is capable of double sided or duplex printing makes the task 
of creating brochures a lot simpler.

1) Open the Print dialog using one of the following methods:

– Go to File > Print on the Menu bar.

– Use the keyboard shortcut Ctrl+P.

– Click on Print on the Standard toolbar.

2) Click on the General tab to open the page for general print options.

8 | Chapter 10, Printing, E-mailing, Exporting, and Saving Slide Shows



3) Click on Properties and check the printer is set to the same page orientation as specified
for the page setup for your slides. Usually page orientation does not matter, but it is 
important for brochures.

4) In Range and Copies section, select the All Slides option. A minimum of four slides is 
required to create a brochure.

5) In Range and Copies section, select Print on both sides (duplex long edge) or Print on 
both sides (duplex short edge) option. Normally, long edge binding is used for portrait 
printing and short edge binding is used for landscape printing.

6) In the Range and Copies section, select the Number of copies required to match the 
required number of brochures.

7) In the Range and Copies section, select the Collate option. This option is only active 
when printing multiple copies of the same document.

8) In the Layout section, select the Brochure option.

9) Click OK to close to the Print dialog and print the required number of pages for your 
brochures.

10) If necessary, bind the brochures to match either long edge or short edge binding.

Emailing

LibreOffice provides two methods of emailing an Impress slide show as an attachment in ODP 
format or PDF format directly from the Impress module. For more information on emailing 
LibreOffice documents, see the Getting Started Guide.

ODP format

1) Make sure the slide show you want to send as an email attachment is open in Impress.

2) Go to Format > Send > Email Document on the Menu bar and your default email 
program opens with the slide show already attached to the email.

3) Enter the recipient’s name, subject title, and message then send the email.

PDF format

1) Make sure the slide show you want to send as an email attachment is open in Impress.

2) Go to Format > Send > Email as PDF on the Menu bar and the PDF Options dialog 
(Figure 5) opens.

3) If necessary, select the required PDF options to create a PDF version of the slide show. 
Normally, the default options already selected are sufficient to create a PDF file that the 
email recipient will be able to open.

4) Click on Send to close the PDF Options dialog and your default email program opens 
with the PDF file already attached to the email.

5) Enter the recipient’s name, subject title, and message then send the email.
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Figure 5: PDF Options dialog - General page

Exporting

Impress can export slide shows in the PDF format as well as other file formats. The PDF format 
is a standard file format for file viewing and is ideal for sending the file to someone who can only 
view a slide show file using a PDF viewer.

For more information on exporting LibreOffice documents, see the Getting Started Guide.

Quick PDF export

1) Make sure the slide show you want to convert to PDF format is open in Impress.

2) Use one of the following methods to export the file as a PDF and open a file browser 
window.

– Click on Export Directly as PDF on the Standard toolbar.

– Go to File > Export As > Export Directly as PDF on the Menu bar.

3) In the file browser window that opens, navigate to where you want to save the PDF file 
version of your slide show.

4) In the Name text box, enter a filename for the PDF file or use the filename that is 
displayed in this text box. The file format is fixed as PDF and cannot be changed.

5) Click on Save to save your slide show as a PDF file and close the file browser window.

PDF export

For more control over the content and quality of a PDF file, it is recommended to use the PDF 
Options dialog (Figure 5). For more information on the options available when exporting a slide 
show as a PDF file, see the Getting Started Guide.

10 | Chapter 10, Printing, E-mailing, Exporting, and Saving Slide Shows



1) Go to File > Export as PDF on the menu bar to open the PDF Options dialog.

2) Select the options required for your PDF file using the options available on the tabbed 
pages of the PDF Options dialog. For more information, see the Getting Started Guide.

3) Click on Export to open a file browser window.

4) Navigate to where you want to save the PDF file version of your slide show. 

5) Enter a file name for the PDF in the Name text box. The file format is fixed as PDF and 
cannot be changed.

6) Click on Export to save and export the file to the location you have selected.

Web pages (HTML) export

Slide shows can be exported as a series of web pages (HTML format) that can be viewed in any 
browser.

1) Go to File > Export on the menu bar to open a file browser window.

2) In the file format box, select HTML format from the drop down list.

3) Navigate to where you want to save the HTML version of your slide show.

4) Create a folder to contain the HTML pages that will be generated and select the folder as 
the destination for the HTML pages.

5)  Click on Save and the HTML Export dialog (Figure 6) opens.

Note

Exporting slide shows as web pages (HTML) does not retain any animation effects or
slide transitions.

6) Select a design for all of the HTML pages, either from an existing design or by creating a 
new one. If you have not previously saved a design, the Existing Design option is not 
available.

Figure 6: HTML Export dialog - Assign Design page
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Figure 7: HTML Export dialog - Publication Type page

Figure 8: HTML Export dialog - Save Images As page

7) Click on Next to select the publication type to use for creating the web pages (Figure 7). 
The available options will change depending on publication type selected.

– Standard HTML – one page for each slide with navigation links to move from slide to 
slide.

– Standard HTML with frames – one page with a navigation bar on the left-hand side; 
uses slide title as navigation links. Click on links to display pages in right-hand side.

– Single-document HTML – creates one HTML document from the slide show.

– Automatic – one page for each slide, with each page set with the refresh meta tag so
a browser automatically cycles from one page to the next.

– WebCast – generates an ASP or Perl application to display the slides. Unfortunately 
LibreOffice has no direct support for PHP yet.
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Figure 9: HTML Export dialog - Title page

Figure 10: HTML Export dialog - Select Button Style page

8) Click on Next to select the format for saving images (PNG, GIF or JPG) and the 
resolution used (Figure 8). When selecting a resolution, consider what the type of display 
users may have. For example, if a high resolution is selected, then a user with a medium-
resolution display will have to scroll sideways to see the entire slide.

9) Click on Next and enter the details for a title page (Figure 9), such as name of the author, 
e-mail address and home page, along with any additional information you want to include.
This page does not display if the Create title page option was not selected when selecting
Publication Type.

10) Click on Next to select the style of navigation buttons to use when moving from one page 
to another (Figure 10). If you do not want to use buttons, make sure Text only is selected.

11) Click on Next to select the color scheme for the web pages (Figure 11). Available 
schemes include the existing scheme for the presentation, one based upon browser 
colors, and a user-defined scheme. You can save a new scheme so that it will appear on 
the first page of the HTML export wizard.

12) Click on Create to generate the HTML files. If this is a new design, a dialog opens so you 
can save the design for future use.
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Figure 11: HTML Export dialog - Select Color Scheme

Export in other formats

1) Go to File > Export on the Menu bar to open a file browser window.

2) Navigate to where you want to save the PDF file version of your slide show. 

3) Enter a file name for the exported file in the File name text box.

4) In the file format box, select the file format that you require.

5) Click on Save to export the file to your selected location. This will open an options dialog 
allowing you to select further options for the file format selected.

6) Click on OK to save your exported file and close the options dialog. For more information 
on exporting files, see the Getting Started Guide.
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