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Formatting lines

In LibreOffice the term line indicates both a freestanding segment (line), the outer edge of a shape 
(border), or an arrow. In most cases the properties of the line you can modify are its style (solid, 
dashed, invisible, and so on), its width, its color and the type of arrowhead.

Note

When you hover the mouse cursor over an icon or tool on a toolbar or in the Sidebar, a
pop up will indicate the purpose of the icon or tool.

Line and Filling toolbar
To format a line using the Line and Filling toolbar (Figure 1):

 1) Make sure the line is selected in your drawing.

 2) On the Line and Filling toolbar, select the line style you want to use from the Line Style 
drop-down list.

 3) On the Line and Filling toolbar, either type the line width in the Line Width text box, or use
the up and down arrows to change the line width.

 4) On the Line and Filling toolbar, click on the small triangle to the right of the Line Color 
icon and select a color from the dialog that opens.

Figure 1: Line and Filling toolbar

Sidebar
To format a line using the Line section in the Properties deck on the Sidebar (Figure 2):

 1) Make sure the line is selected in your drawing.

 2) Click on the Properties icon on the Sidebar to open the Properties deck

 3) Click on the down arrowhead ˅ on the left of the Line title bar to open the Line section.

 4) Select from the drop-down lists the type of arrowhead for each end of the line and change 
the line into an arrow. The left drop-down list adds an arrow head to the beginning of the 
line. The right drop-down list adds an arrow head to the end of the line.

 5) Select from the middle drop down list the type of line from the options available.

 6) Select the line width from the options in the Width drop down list or enter a width in the text
box.

 7) Select the line color from the Line Color dialog that opens when you click on the small 
triangle to the right of the Color box.

 8) Deselect the line to save your changes to the line.
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Figure 2: Line section In Properties 
on Sidebar

Figure 3: Line dialog - Line page

Line dialog
If you want to fully change the appearance of a line, then you need to use the Line dialog.

 1) Select the line in your drawing.

 2) Go to Format > Line on the main menu bar, or right-click on the line and select Line from 
the context menu to open the Line dialog (Figure 3). This dialog consists of four pages: 
Line, Shadow, Line Styles and Arrow Styles and are explained in the following sections.

 3) When you have made all your changes to the selected line, click OK to close the dialog and
save your changes. The preview box at the bottom of the dialog shows the effect of your 
changes on a line.

Line page
The Line page in the Line dialog (Figure 3) is where you can set the basic parameters of the line 
and is divided into three sections as follows.
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Line properties
Use Line Properties to set the following parameters:

• Style – select a line style from the drop-down list.

• Color – select a predefined color from the drop-down list or create a custom color.

• Width – specifies the thickness of the line.

• Transparency – sets the transparency of a line. Figure 4 shows the effects of different 
percentages in transparency levels to lines when placed over an object.

Figure 4: Line transparency (0%, 
25%, 50%, 75% left to right)

Arrow styles
Arrow Styles page on the Line dialog are only applicable to individual lines and are not used for 
lines that form the borders of a shape.

• Start style and End style– sets the arrow style or arrowhead for the start and end of a line 
from the drop down list.

• Width – specifies the thickness of the arrow endings

• Center – moves the center of the arrow endings to the end point of the line. Figure 5 shows
the effects of selecting this option.

• Synchronize ends – makes the two line ends identical.

A quick way to set the arrowheads for a selected line is to click on the Arrow Style icon in the Line
and Filling toolbar to open the Arrowheads menu (Figure 6). Here you can select one of the 
many predefined arrowhead styles for the start and ending of a selected line.

Note

Arrowheads are only applicable to lines. They have no effect on the border of an 
object.

Figure 5: Default arrow top;
centered arrow bottom

Formatting lines | 7



Figure 6: 
Arrowheads 
drop down menu

Corner and cap styles
Corner and Cap Styles (Figure 3 on page 6) determine how the connection between two 
segments looks. To appreciate the difference between these styles, choose a thick line style and 
observe how the preview changes.

• Corner style – select the shape to be used at the corners of the line. In case of a small 
angle between lines, a mitered shape is replaced with a beveled shape.

• Cap style – select the style of the line end caps. The caps are added to inner dashes as 
well.

Line shadows
Use the Shadow page (Figure 7) of the Line dialog to add and format a shadow to a selected line. 
The settings on this page are the same as those for shadows applied to other objects and are 
described in “Shadows” on page 29.

A quicker way to apply a shadow to a line is using the Shadow icon on the Line and Filling 
toolbar. The main disadvantage of using the Shadow icon is that the shadow appearance will be 
constrained by the shadow settings of the default graphics style.

Figure 7: Line dialog - Shadow page
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Figure 8: Line dialog - Line Styles page

Line styles
Use the Line Styles page (Figure 8) of the Line dialog to change the line style from the options 
available from the drop menu in Properties or create a new line style. An example of the line style 
selected or created is displayed at the bottom of the dialog page.

Creating line styles
To create a new line style:

 1) Choose Format > Line on the main menu bar, or right-click on the line and select Line 
from the context menu, or select the Line icon on the Line and Filling toolbar to open the 
Line dialog.

 2) Click on the Line Styles tab to open the Line Styles page (Figure 8).

 3) Select from the Line style drop-down menu a style similar to the style you want to create.

 4) Click Add and type a name for the new line style in the dialog that opens, then click OK.

 5) Now define the new style by selecting the line type for the new style. To alternate two line 
types (for example, dashes and dots) within a single line, select different types in the two 
Type boxes.

 6) Specify the Number and Length (not available for dot style) of each Type of line selected.

 7) Set the Spacing between the various elements

 8) If necessary, select Fit to line width so that the new style fits the width of the selected line.

 9) The new line style created is available only in the current document. If you want to use the 
line style in other documents, click the Save Line Styles icon and type a unique filename in
the Save as dialog that opens. Saved line styles have the file extension of .sod.

 10) To use previously saved line style, click the Load Line Styles icon and select a style from 
the list of saved styles. Click Open to load the style into your document.

 11) If necessary, click on the Modify button to change the name of the style.

 12) Click OK to close the dialog and save any changes you have made.
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Deleting line styles
To delete a line style:

 1) Choose Format > Line on the main menu bar, or right-click on the line and select Line 
from the context menu, or select the Line icon on the Line and Filling toolbar to open the 
Line dialog.

 2) Click on the Line Styles tab to open the Line Styles page (Figure 8).

 3) Select the line style you want to delete from the Line style drop-down list.

 4) Click on the Delete button, then confirm the deletion by clicking on the Yes button in the 
confirmation dialog that opens.

 5) Click OK to close the Line dialog and save any changes you have made.

Note

When deleting line styles, make sure that the line style is not used in another drawing 
or document.

Arrow styles
Use the Arrow Styles page (Figure 9) in the Line dialog to create new arrow styles, or modify 
existing arrow styles, or load previously saved arrow styles.

Creating arrow styles
To create a new arrow style:

 1) First draw a curve in the shape you want to use for the arrowhead, or create a shape and 
convert to a curve. The top of the shape must face upward (as shown in Figure 10) 
because this becomes the point of the arrow.

Figure 9: Line dialog - Line Styles page
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Figure 10: Using shapes 
for arrow styles

 2) Select the shape and, if necessary, right-click and choose Convert > To Curve from the 
context menu to convert the shape to a curve. If the shape is already a curve, To Curve will
not be available.

 3) With the selection handles showing, select Format > Line from the main menu bar, or right-
click and choose Line from the context menu.

 4) Go to the Arrow Styles page, click the Add button, type a name for the new arrow style, 
and click OK. The new arrowhead style will be shown in the preview.

 5) Now you can select the new style from the Arrow style list. The new style is shown at the 
bottom of the drop down list.

 6) The new arrowhead style created is available only in the current document. If you want to 
use this arrowhead style in other documents, click the Save Line Styles icon and type a 
unique filename in the Save as dialog that opens. Saved styles have the file extension 
of .sod.

 7) To use previously saved arrowhead styles, click the Load Line Styles icon and select the 
style from the saved list of styles. Click Open to load the style into your document.

 8) If necessary. click on the Modify button to change the name of the style.

 9) Click OK to close the dialog and save any changes you have made.

Note

The arrowhead must be a curve, which is something you can draw without lifting a 
pencil from the paper. For example, a star can be a curve, but a smiley face cannot be
a curve because you have to reposition the pencil on the paper to draw eyes and a 
mouth on the face.

Deleting arrow styles
To delete an arrow style:

 1) Choose Format > Line on the main menu bar, or right-click on the line and select Line 
from the context menu, or select the Line icon on the Line and Filling toolbar to open the 
Line dialog.

 2) Click on the Arrow Styles tab to open the Arrow Styles page (Figure 9 on page 10).

 3) Select the arrow style you want to delete from the Arrow style drop-down list.

 4) Click on the Delete button, then confirm the deletion by clicking on the Yes button in the 
confirmation dialog that opens.

 5) Click OK to close the Line dialog and save any changes you have made.
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Note

When deleting arrow styles, make sure that the arrow style is not used in another 
drawing or document.

Formatting fill areas

The term area fill refers to the inside of an object, which can be a uniform color, gradient, hatching, 
bitmap or pattern as shown in Figure 11. An area fill can be made partly or wholly transparent and 
can throw a shadow.

Line and Filling toolbar
Tools on the Line and Filling toolbar (Figure 1 on page 5) provide a wide number of default fillings
readily available to quickly format graphic objects. If this toolbar is not showing, go to View > 
Toolbars > Line and Filling on the main menu bar. To format the area of an object:

 1) Select an object so that the selection handles are displayed.

 2) Click on Area Style/Filling on the Line and Filling toolbar and, from the drop-down list, 
select the type of fill required (None, Color, Gradient, Hatching, Bitmap, Pattern) (Figure
12).

 3) Click on the right Area Style/Filling drop-down list and select one of the available options 
for the selected type of area. For more information on area fills, see “Area dialog” on Page
14.

• Color options in Figure 13.

• Gradient options in Figure 14.

• Hatching options in Figure 15.

• Bitmap options in Figure 16.

• Pattern options, see Fill and Transparency in the Area section on the Sidebar (Figure
17) or the Pattern section in Area page of the Area dialog (Figure 22 on page 17).

 4) Deselect the object to save your changes to the object.

Figure 11: Examples of area fill types
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Figure 12: Area fill types

Figure 13: Color area fill Figure 14: Gradient area fill

Figure 15: Hatching area fill Figure 16: Bitmap area fill

Sidebar
To quickly format the area of an object using the Sidebar (Figure 17):

 1) Make sure the object is selected in your drawing.

 2) Click on the Properties icon on the Sidebar, then click on the down arrowhead ˅ on the left
of the Area titlebar to open the Area section.

 3) Use the various options in the Fill and Transparency drop-down lists of the Area section to 
format the fill and transparency of an object. For more information on area fills, see “Area 
dialog” on Page 14.

 4) Deselect the object to save your changes.
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Figure 17: Area section in Properties 
on Sidebar

Area dialog
Use the Area dialog (Figure 18) to change existing area fills with greater control or create your own
area fill.

 1) Select the object you wish to edit.

 2) Next format the area using one of the following methods:

• Go to Format > Area on the main menu bar.

• Click on the Area icon on the Line and Filling toolbar.

• Right-click on the object and select Area from the context menu to open the Area 
dialog.

 3) Click on the Area tab to open the Area page and to apply an area fill. LibreOffice includes 
several area fills already defined, but you can create area fills yourself. See “Working with 
area fills” on page 18 for more information.

 4) Select the type of area fill from the drop-down list: None, Color, Bitmap, Gradient, Pattern, 
or Hatch. The types of area fill are explained below.

 5) Select the style of area fill from the options that become available. The number of available 
options will depend on the type of area fill selected above.

 6) Click OK to close the dialog and save your changes. The area fill will then appear in the 
selected object.

Types of area fill

Color fill
 1) Open the Area dialog and click on the Area tab to open the Area page.
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Figure 18: Area dialog - Color page

Figure 19: Pick a Color dialog

 2) Click on Color (Figure 18) to open the options available for a color fill.

 3) In Palette, select your required palette from the drop down list and your required color from 
the available colors shown. All color fills available are solid colors.

 4) Active shows the present color fill of your selected object. After selecting a new color, a 
preview of the selected color appears in New in the dialog.

 5) Alternatively, enter the RGB or Hex values of a color in the appropriate text box.

 6) Alternatively, click on Pick to open the Pick a Color dialog (Figure 19). Here you can pick a
color from the color box or enter the RGB, Hex, HSB or CMYK values for your color.

 7) If you have used a color before and would like to use it again, then select your color from 
those available in Recent Colors.

 8) Click OK to close the dialog and save your changes. The area fill will then appear in the 
selected object.
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Figure 20: Area dialog - Gradient page

Gradient fill
 1) Open the Area dialog and click on the Area tab to open the Area page.

 2) Click on Gradient (Figure 20) to open the options available for a gradient fill.

 3) In Gradient, select your required gradient from the list of available gradients and it will 
appear in Preview.

 4) To override the default gradient transition in your selection, deselect Automatic in Options 
and then enter the values for Type, Increment, Angle, Border, From Color and To Color in 
the available boxes.

 5) Click OK to close the dialog and save your changes. The area fill will then appear in the 
selected object.

Bitmap fill
 1) Open the Area dialog and click on the Area tab to open the Area page.

 2) Click on Bitmap (Figure 21) to open the options available for a bitmap fill.

 3) In Bitmap, select your required bitmap from the list of available bitmaps and it will appear in
Preview.

 4) To override the settings for the bitmap in your selection, enter the values for Style, Size, 
Position, Tiling Position, and Tiling Offset in the available boxes under Options.

 5) Alternatively, click on Add/Import and select an image from the file selection box that opens 
to use as a bitmap fill.

 6) Click OK to close the dialog and save your changes. The area fill will then appear in the 
selected object.

Pattern fill
 1) Open the Area dialog and click on the Area tab to open the Area page.

 2) Click on Pattern (Figure 22) to open the options available for a pattern fill.

 3) In Pattern, select your required pattern from the list of available pattern and it will appear in
Preview.
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Figure 21: Area dialog - Bitmap page

Figure 22: Area dialog - Pattern page

 4) To override the settings for the pattern in your selection, enter a new pattern in Pattern 
Editor, then a new Foreground Color and Background Color in the available boxes under 
Options.

 5) Click OK to close the dialog and save your changes. The area fill will then appear in the 
selected object.

Hatch fill
 1) Open the Area dialog and click on the Area tab to open the Area page.

 2) Click on Hatch (Figure 23) to open the options available for a hatch fill.

 3) In Hatch, select your required hatching from the list of available hatchings and it will appear
in Preview.
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Figure 23: Area dialog - Hatch page

 4) To override the settings for the hatching in your selection, enter a new values for Spacing, 
Angle, Line color and Background Color in the available text boxes under Options.

 5) Click OK to close the dialog and save your changes. The area fill will then appear in the 
selected object.

Working with area fills

Color fills

Creating colors using Area dialog
Using the Area dialog (Figure 18 on page 15), you can create a new color as a combination of the 
three primary colors Red, Green, and Blue, (RGB notation) as follows:

 1) Select the object you wish to edit.

 2) Format the area using one of the following methods:

• Go to Format > Area on the main menu bar.

• Click on the Area icon on the Line and Filling toolbar (Figure 1 on page 5).

• Right-click on the object and select Area from the context menu to open the Area 
dialog.

 3) Click on the Colors button to open the Colors page.

 4) Specify the red (R), green (G) and blue (B) values on a 0 to 255 scale to create a new 
color.

 5) Click the Add button to open the Name box (Figure 24) and enter a name for the new color.

 6) Click OK to close the Name box and add the new color to the Custom palette.

 7) Click OK to save your changes and close the Area dialog. The new color will appear as a 
fill in the selected object.
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Figure 24: Color name box

Creating colors using Pick a Color dialog
You can create a new color using the Pick a Color dialog as follows:

 1) Select the object you wish to edit.

 2) Format the area using one of the following methods:

• Go to Format > Area on the main menu bar.

• Click on the Area icon on the Line and Filling toolbar (Figure 1 on page 5).

• Right-click on the object and select Area from the context menu to open the Area 
dialog.

 3) Click on the Colors button to open the Colors page (Figure 18 on page 15).

 4) Click on the Pick button to open the Pick a Color dialog (Figure 19 on page 15).

 5) Create a new color using one of the following methods. A preview of the color created is 
shown in the colored box next to the original color in the bottom left corner of the dialog.

• Select a color range from the colored bar, then, using the mouse, move the target in the
colored box until you are satisfied with the color selected.

• Enter values for red (R), green (G) and blue (B) in the RGB text boxes.

• Enter values for cyan (C), magenta (M), yellow (Y), and key (K) (black) in the CMYK 
text boxes.

• Enter values for hue (H), saturation (S) and brightness (B) in the HSB text boxes. HSB 
values do not change the color, but how a color looks.

 6) Click OK to close the Pick a Color dialog.

 7) Click the Add button to open the Name box (Figure 24) and enter a name for the new color.

 8) Click OK to close the Name box and add the new color to the Custom palette.

 9) Click OK to save your changes and close the Area dialog. The new color will appear as a 
fill in the selected object.

Deleting custom colors
 1) Select a filled object that uses the color fill you want to delete.

 2) Format the area using one of the following methods:

• Go to Format >  Area on the main menu bar.

• Click on the Area icon on the Line and Filling toolbar (Figure 1 on page 5).

• Right-click on the object and select Area from the context menu to open the Area 
dialog.

 3) Click on the Colors button to open the Colors page (Figure 18 on page 15).

 4) Select Custom from the Palette drop-down list.
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Figure 25: Deleting custom 
colors

 5) Select the color you want to delete and click on the Delete button (Figure 25). There is no 
confirmation given when deleting a color.

 6) Click OK to save your changes and close the Area dialog.

Note

It is recommended to only delete colors that you have created from the custom palette.
Deleting colors from the standard palettes that are available in LibreOffice, may cause 
problems in documents that use one of the standard colors.

Gradient fills
To create a new gradient or to modify an existing one, select the Gradients tab from the Area 
dialog. Several types of gradients are predefined and, in most cases, changing the colors will be 
sufficient to obtain the desired result.

Note

It is recommended, even if you just want to change the two colors, that you create a 
new gradient rather than modifying the predefined ones. Predefined gradients should 
only be used as starting points. Also predefined gradients may have been used in 
other objects in your drawing or in other documents.

Creating new gradients
 1) Select the filled object you want to edit.

 2) Format the area using one of the following methods:

• Go to Format > Area on the main menu bar.

• Click on the Area icon on the Line and Filling toolbar (Figure 1 on page 5).

• Right-click on the object and select Area to open the Area dialog.

 3) Click on the Gradients tab to open the Gradients page (Figure 20 on page 16).

 4) In Options, select the From Color and To Color from the drop-down lists.
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Figure 26: Adding gradients

 5) In Options, select the gradient type from the drop-down list: Linear, Axial, Radial, Ellipsoid, 
Quadratic or Square. A preview of the gradient type is shown in the dialog.

 6) Set all the properties as desired. The properties used to create a gradient are summarized 
in Table 1. Depending on the type of gradient selected, some properties may be grayed out.

 7) Click the Add button to open the Name box (Figure 26). Enter a name for the new gradient,
then click OK to close the Name box.

 8) Click OK to close the Area dialog and save the changes.

Table 1: Gradient properties.

Gradient property Meaning

Center X
For Radial, Ellipsoid, Square and Rectangular gradients, modify these 
values to set the horizontal offset of the gradient center.

Center Y
For Radial, Ellipsoid, Square and Rectangular gradients, modify these 
values to set the vertical offset of the gradient center.

Angle For all the gradient types, specifies the angle of the gradient axis.

Border
Increase this value to make the gradient start further away from the border 
of the shape.

From Color
The start color for the gradient. In the edit box below enter the intensity of 
the color: 0% corresponds to black, 100% to the full color.

To Color
The end color for the gradient. In the edit box below enter the intensity of 
the color: 0% corresponds to black, 100% to the full color.

Modifying gradients
 1) Select an object that contains the gradient as a fill and format the area using one of the 

following methods:

• Go to Format > Area on the main menu bar.

• Click on the Area icon on the Line and Filling toolbar (Figure 1 on page 5).

• Right-click on the object and select Area to open the Area dialog.

 2) Click on the Gradients tab to open the Gradients page (Figure 20 on page 16).

 3) Select the gradient you have previously created and added to the Gradients displayed in 
the Area dialog.

 4) Enter the new values for the gradient properties that you want to change. See Table 1 for 
more information on gradient properties. Depending on the type of gradient selected, some 
properties may be grayed out.

 5) Click Modify to save your changes. There is no confirmation given when modifying a 
gradient.

 6) Click OK to close the Area dialog and save the changes.
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Deleting gradients
 1) Select a filled object that uses the gradient fill you want to delete.

 2) Format the area using one of the following methods:

• Go to Format >  Area on the main menu bar.

• Click on the Area icon on the Line and Filling toolbar (Figure 1 on page 5).

• Right-click on the object and select Area from the context menu to open the Area 
dialog.

 3) Click on the Gradients tab to open the Gradients page (Figure 20 on page 16).

 4) Select the gradient you want to delete.

 5) Right click on the gradient and select Delete from the pop-up menu. Click on Yes to 
confirm the deletion.

 6) Click OK to save your changes and close the Area dialog.

Note

It is recommended to only delete gradients that you have created. Deleting gradients 
that are installed with LibreOffice may cause problems in documents that use one of 
these gradients.

Advanced gradient controls
LibreOffice provides advanced controls for gradients as follows.

 1) Select an object that contains the gradient as a fill.

 2) Format the area using one of the following methods:

• Go to Format > Area on the main menu bar.

• Click on the Area icon on the Line and Filling toolbar (Figure 1 on page 5).

• Right-click on the object and select Area to open the Area dialog.

 3) Click on the Gradients tab to open the Gradients page in the Area dialog (Figure 20 on 
page 16).

 4) Go to View > Toolbars > Transformations on the main menu bar or click on the 
Transformations icon on the Line and Filling toolbar to open the Transformations 
toolbar.

Figure 27: Interactive 
gradient tool on 
Transformations toolbar
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 5) Click on the Interactive gradient tool icon in the Transformations toolbar. This displays a 
dashed line connecting two colored squares. The colors show the From Color and To Color 
that are used for the selected gradient (Figure 27).

 6) Select the type of gradient you want to use for the object from the Type drop-down list in 
Options on the Gradients page in the Area dialog. Properties you can adjust will depend 
on the gradient type you have selected and these are explained below.

• Linear gradients – move the square corresponding to the From Color to change where
the gradient starts (border value). Move the square corresponding to the To Color to 
change the orientation (angle value).

• Axial gradients – move the To Color to change both the angle and border properties of
the gradient. Only the square corresponding to the To Color can be moved.

• Radial gradients – move the From Color to modify the border property to set the width 
of the gradient circle. Move the To Color to change the point where the gradient ends 
(Center X and Center Y values).

• Ellipsoid gradients – move the From Color to modify the border property to set the 
size of the gradient ellipsoid. Move the To Color to change the angle of the ellipsoid axis
and the axis itself.

• Square and rectangular gradients – move the From Color to modify the border to set 
the size of the gradient square or rectangle and the angle of the gradient shape. Move 
the To Color to change the center of the gradient.

 7) Click OK to save your changes and close the Area dialog.

Note

Moving the squares will have different effects depending on the type of gradient. For 
example, for a linear gradient, the start and end squares of the gradient will always be 
situated to either side of the center point of the object.

Bitmap fills

Editing bitmaps
 1) Select an object that contains a bitmap as a fill or insert a bitmap into a selected object (see

“Pattern fill” on page 16 for more information).

 2) Go to Format > Area on the main menu bar, or click on the Area icon on the Line and 
Filling toolbar (Figure 1 on page 5), or right-click on the object and select Area to open the 
Area dialog.

 3) Click on the Bitmap tab to open the Bitmap page (Figure 21 on page 17).

 4) Select a bitmap from Bitmap that you want use and edit as a fill. Note that any imported 
bitmaps will also be available.

 5) In Options, select the properties for Style, Size, Position, Tiling Position and Tiling Offset. 
See Table 2 for more information on bitmap properties. The best way to understand bitmap 
properties is to use them. Figure 28 shows examples of bitmap fills and the properties 
used.

 6) Click OK to save your changes and close the Area dialog.
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Figure 28: Examples of bitmap fill

Table 2: Bitmap options.

Bitmap option Meaning

Style – Custom 
position/size

When this option is selected, the position of the bitmap in the object and 
the size of the bitmap can be determined.

Style – Tiled
When this option is selected, the bitmap will be tiled to fill the area. The 
size of the bitmap used for the tiling is determined by the Size settings

Style – Stretched When this option is selected, a bitmap will be stretched to fill object area.

Size – Width
Sets the width of the bitmap. For example, 100% means that the bitmap 
original width will be resized to occupy the whole fill area width, 50% 
means that the width of the bitmap will be half that of the fill area.

Size – Height
Sets the height of the bitmap. For example, 100% means that the bitmap
original height will be resized to occupy the whole fill area height, 50% 
means that the height of the bitmap will be half that of the fill area.

Size – Scale
When selected, bitmap size is given as a percentage for Width and 
Height. When deselected, the actual size of the bitmap is given for Width
and Height.

Position
When this option is selected, the anchoring point of the bitmap is 
determined.

Tiling Position – X-Offset
Sets the offset for the width of the bitmap in percentage values. 50% 
offset means that Draw will place the middle part of the bitmap at the 
anchor point and start tiling from there.

Tiling Position – Y-Offset
Sets the offset for the height of the bitmap in percentage values. 50% 
offset means that Draw will place the middle part of the bitmap at the 
anchor point and start tiling from there.

Tiling Offset
Offsets the columns of tiled bitmaps by the percentage entered in the 
box so that two subsequent columns of bitmaps are not aligned.

Importing bitmaps
To import a bitmap created in another program:

 1) Select an object where you want to import a bitmap into.
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Figure 29: Importing bitmaps

 2) Format the area using one of the following methods:

• Go to Format > Area on the main menu bar.

• Click on the Area icon on the Line and Filling toolbar (Figure 1 on page 5).

• Right-click on the object and select Area to open the Area dialog.

 3) Click on the Bitmap tab to open the Bitmap page (Figure 21 on page 17).

 4) Click on Add/Import and a file browser dialog opens.

 5) Browse to the directory containing the bitmap file and select it, then click Open.

 6) Enter a name for the new bitmap in the Name box (Figure 29), then click OK to close the 
Name box.

 7) Click OK to save your changes and close the Area dialog.

Deleting bitmaps
 1) Select a filled object that uses the bitmap fill you want to delete.

 2) Format the area using one of the following methods:

• Go to Format >  Area on the main menu bar.

• Click on the Area icon on the Line and Filling toolbar.

• Right-click on the object and select Area from the context menu to open the Area 
dialog.

 3) Click on the Bitmap tab to open the Bitmap page (Figure 21 on page 17).

 4) Right click on the bitmap and select Delete from the pop-up menu. Click on Yes to confirm 
the deletion.

 5) Click OK to save your changes and close the Area dialog.

Note

It is recommended to only delete bitmaps that you have created or imported. Deleting 
bitmaps that are installed with LibreOffice may cause problems in documents that use 
one of these bitmaps.

Pattern fills

Creating or editing patterns
 1) Select an object that contains a pattern as a fill or insert a pattern into a selected object 

(see “Pattern fill” on page 16 for more information).
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Figure 30: Creating or editing patterns

Figure 31: Naming new patterns

 2) Format the area using one of the following methods:

• Go to Format > Area on the main menu bar.

• Click on the Area icon on the Line and Filling toolbar (Figure 1 on page 5).

• Right-click on the object and select Area to open the Area dialog.

 3) Click on the Pattern tab to open the Pattern page (Figure 22 on page 17).

 4) Select a pattern from the options available in Pattern. Note that any imported patterns will 
also be available.

 5) In Options, select the color you want to use from the drop down lists for Foreground Color 
and Background Color (Figure 30).

 6) In Options – Pattern Editor, start creating or editing the pattern by clicking with the left 
mouse button in the squares (pixels) that you want to fill with Foreground Color. Check the 
Preview window to see if the desired effect is being achieved.

 7) If you have created a new pattern, click the Add button to open the Name box (Figure 31). 
Enter a name for the new pattern, then click OK to close the Name box.

 8) If you have edited a pattern, click Modify to save your changes. There is no confirmation 
given when saving an edited pattern.

 9) Click OK to save your changes and close the Area dialog.

Deleting patterns
 1) Select a filled object that uses the pattern fill you want to delete.

 2) Format the area using one of the following methods:

• Go to Format >  Area on the main menu bar.

• Click on the Area icon on the Line and Filling toolbar (Figure 1 on page 5).

26 | Changing Object Attributes



• Right-click on the object and select Area from the context menu to open the Area 
dialog.

 3) Click on the Pattern tab to open the Pattern page (Figure 22 on page 17).

 4) Right click on the pattern and select Delete from the pop-up menu. Click on Yes to confirm 
the deletion.

 5) Click OK to save your changes and close the Area dialog.

Note

It is recommended to only delete patterns that you have created. Deleting patterns that
are installed with LibreOffice may cause problems in documents that use one of these 
patterns.

Hatching fills
To create a new hatching fill or to modify an existing one, select the Hatch tab from the Area 
dialog. As with gradients and colors, it is better to create a new hatching fill rather than modify a 
predefined one. The properties that can be set for a hatching pattern are shown in Table 3.

Table 3: Hatching options.

Hatching option Meaning

Spacing
Determines the spacing between two lines of the hatching fill. As the value 
is changed the preview window is updated.

Angle
Use the mini map below the numerical value to quickly set the angle formed
by the line to multiples of 45 degrees. If the required angle is not a multiple 
of 45 degrees, just enter the desired value in the edit box.

Line type Set single, double or triple line for the style of the hatching fill.

Line color Use the list to select the color of the lines that will form the hatching fill.

Background color When selected, adds a color fill behind the lines used for the hatching fill.

Creating new hatching fills
 1) Select the filled object you want to edit and format the area using one of the following 

methods:

• Go to Format > Area on the main menu bar.

• Click on the Area icon on the Line and Filling toolbar (Figure 1 on page 5).

• Right-click on the object and select Area to open the Area dialog.

 2) Click on the Hatch tab to open the Hatch page (Figure 23 on page 18).

 3) As a starting point, select a hatching fill similar to the one that you want to create.

 4) Modify the options of the lines forming the hatching fill. A preview is displayed in the window
below the available patterns. See Table 3 for information on hatching options.

 5) Click the Add button to open the Name box (Figure 32). Enter a name for the new hatching
fill, then click OK to close the Name box. The new hatching appears at the bottom of the 
hatching fills displayed in Hatch.

 6) Click OK to close the Area dialog and save the changes.
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Figure 32: Adding hatching fills

Modifying hatching fills
 1) Select an object that contains the hatching as a fill.

 2) Format the area using one of the following methods:

• Go to Format > Area on the main menu bar.

• Click on the Area icon on the Line and Filling toolbar (Figure 1 on page 5).

• Right-click on the object and select Area to open the Area dialog.

 3) Click on the Hatch tab to open the Hatch page (Figure 23 on page 18).

 4) Select a hatching you have previously created and added to the Hatch displayed in the 
Area dialog.

 5) Enter the new values for the Options that become available for change. See Table 3 for 
more information on hatch options.

 6) Click Modify to save your changes. There is no confirmation given when modifying a 
hatching.

 7) Click OK to close the Area dialog and save the changes.

Deleting hatch fills
 1) Select a filled object that uses the hatching fill you want to delete.

 2) Format the area using one of the following methods:

• Go to Format >  Area on the main menu bar.

• Click on the Area icon on the Line and Filling toolbar (Figure 1 on page 5).

• Right-click on the object and select Area from the context menu to open the Area 
dialog.

 3) Click on the Hatch tab to open the Hatch page (Figure 23 on page 18).

 4) Select the hatching you want to delete.

 5) Right click on the hatching and select Delete from the pop-up menu. Click on Yes to 
confirm the deletion.

 6) Click OK to save your changes and close the Area dialog.

Note

It is recommended to only delete hatchings that you have created. Deleting hatchings 
that are installed with LibreOffice may cause problems in documents that use one of 
these hatchings.
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Figure 33: Area dialog - Shadow page

Shadows

Default shadows
To quickly apply a shadow to an object, select the object and click on the Shadow icon in the Line 
and Filling toolbar (Figure 1 on page 5). The shadow applied to an object using this method is set 
to default settings.

Formatting shadows
For a more control when adding shadows to an object, you have to use the Shadow page on the 
Area dialog as follows:

 1) Select an object where you want to apply a shadow.

 2) Format the area using one of the following methods:

• Go to Format > Area on the main menu bar.

• Click on the Area icon on the Line and Filling toolbar (Figure 1 on page 5).

• Right-click on the object and select Area to open the Area dialog.

 3) Click on the Shadow tab to open the Shadow page (Figure 33).

 4) Select Use shadow in Properties for the shadow options to become active.

 5) Select the anchor point for the direction of the shadow cast in relation to the object.

 6) In Color, select the color palette and the color you require for the shadow.

 7) In Distance, enter a distance in the text box to set spacing between the object and the 
shadow.

 8) In Transparency, enter the percentage in the text box for the shadow transparency.

 9) Click OK to close the Area dialog and save the changes.

Transparencies
Transparency can be applied to filled objects as well as shadows and lines.

• To apply transparency to lines, refer to “Formatting lines” on page 5.

• To apply a transparency to shadows, refer to “Formatting shadows” on page 29.

To apply transparency to filled objects using the Transparency page on the Area dialog:

 1) Select an object where you want to apply a transparency.
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Figure 34: Area dialog - Transparency page

 2) Format the area using one of the following methods:

• Go to Format > Area on the main menu bar.

• Click on the Area icon on the Line and Filling toolbar (Figure 1 on page 5).

• Right-click on the object and select Area to open the Area dialog.

 3) Click on the Transparency tab to open the Transparency page (Figure 34).

 4) To create a uniform transparency, select Transparency and enter a percentage in the text 
box.

 5) To create a gradient transparency so that the area becomes gradually transparent, select 
Gradient and select the type of gradient transparency from the drop-down list: Linear, Axial,
Radial, Ellipsoid, Quadratic or Square.

 6) Set the parameters for the type of the gradient transparency you selected above. Refer to 
Table 4 for a description of the properties. The available parameters will depend on the type
of gradient transparency selected above.

 7) Click OK to close the Area dialog and save the changes.

Table 4: Transparency parameters.

Transparency parameters Meaning

Centre X
For Radial, Ellipsoid, Quadratic and Square gradients. The values to 
set the horizontal offset of the gradient center.

Center Y
For Radial, Ellipsoid, Quadratic and Square gradients. The values to 
set the vertical offset of the gradient center.

Angle
For Linear, Axial, Ellipsoid, Quadratic and Square gradients. Specifies 
the angle of the gradient axis.

Border
Increase this value to make the gradient start further away from the 
border of the object.

Start value
Value for the starting transparency gradient. 0% is fully opaque, 100% 
means fully transparent.

End value
Value for the ending transparency gradient. 0% is fully opaque, 100% 
means fully transparent.
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Using drawing object styles

Note

In LibreOffice Draw, only drawing object styles are available in the Graphic Styles 
dialog and the Styles deck on the Sidebar.

Suppose that you want to apply the same area fill, line thickness, and border to a set of objects. 
This repetitive process can be greatly simplified by the use of styles. Styles allow you to define a 
formatting template (a style) and then to apply that style to multiple objects. For more information 
on styles, see the Chapter 6 Introduction to Styles in the Writer Guide.

Linked styles
Drawing object styles support inheritance. This means that a style can be linked to another 
(parent) style so that it inherits all the formatting settings of the parent. You can use this property to
create families of styles.

For example, if you need multiple boxes that differ in color, but are otherwise identically formatted, 
it is recommended to create a generic style for the box including borders, area fill, font, and so on. 
You then create a number of hierarchically dependent styles which differ only in the fill color 
attribute. If you then need to change the font size or the thickness of the border, it is sufficient to 
change the parent style and all the other linked styles will change accordingly.

Note

When styles are linked, changing a color will change the color in all linked styles. 
Sometimes this is exactly what you want; at other times you do not want the changes 
to apply to all linked styles. It pays to plan ahead.

Creating new styles
After creating a new style, it will be placed in All Styles and Custom Styles in the Styles deck of the
Sidebar. When the your new style is applied to an object, the new style will also appear in Applied 
Styles.

Using Styles deck
 1)  Click on the Styles icon on the Sidebar to open the Styles deck (Figure 35).

 2) Right click on a style and select New from the context menu to open the Graphic Styles 
dialog (Figure36).

 3) Click on the Organizer tab to open the Organizer page in the Graphic Styles dialog.

 4) In the Name text box, type a memorable style name.

 5) In Inherit from, select a style from the drop down list a style if you want your new style to 
inherit settings from a LibreOffice style.
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Figure 35: Styles deck in Sidebar

Figure 36: Graphic Styles dialog - Organizer page

 6) Use the various pages and available options in the Graphic Styles dialog to format and 
categorize your new style.

• Organizer – contains a summary of the style and its hierarchical position.

• Font, Font Effects, Indents & Spacing, Alignment, and Tabs – set the properties of the 
text inserted in a text box or in a graphic object.

• Dimensioning – used to set the style of dimension lines.

• Text, Text Animation, Connector, Line, Area, Shadowing, Highlighting and Transparency
– determine the formatting of an object.

 7) Click OK when finished to save your new style and close the Graphic Styles dialog.

New style from selection
 1) Select the object you want to use to create your new style, or create a new object in your 

drawing.

 2) Use the various options in the pages of the Graphic Styles dialog (Figure 36), or the 
various tools on the Line and Filling toolbar (Figure 1 on page 5) to make your changes to 
the object.
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Figure 37: Create Style dialog

 3) Go Format > Styles > New Style from Selection on the main menu bar or click on the 
New Style from Selection icon in the Styles deck on the Sidebar.

 4) In the Create Style dialog (Figure 37) that opens, type a name for the new style. This 
dialog also shows existing custom styles that are available.

 5) Click OK to save the new style and close the dialog.

Modifying or editing styles
It is recommended to only modify or edit styles that you have created. Modifying or editing styles 
that are installed with LibreOffice may cause problems in other documents that use one of these 
styles.

 1) Select an object in your drawing.

 2) Open the Graphic Styles dialog (Figure 36) using one of the following methods:

• Go to Format > Styles > Edit Style on the main menu bar.

• Right click on the object and select Edit Style from the context menu.

• Right click on the object style in the Styles deck on the Sidebar and select Modify from
the context menu.

 3) Use the various pages and available options in the Graphic Styles dialog to modify and 
edit the object style.

• Organizer – contains a summary of the style and its hierarchical position.

• Font, Font Effects, Indents & Spacing, Alignment, and Tabs – set the properties of the 
text inserted in a text box or in a graphic object.

• Dimensioning – used to set the style of dimension lines.

• Text, Text Animation, Connector, Line, Area, Shadowing, Highlighting and Transparency
– determine the formatting of an object.

 4) Click OK when finished to save your changes and close the Graphic Styles dialog.

Editing linked styles
If you have an object in your document that uses linked styles then it is possible to edit the linked 
styles that have been applied to the object. This done using the Graphic Styles dialog as follows:

 1) Select an object in your drawing that uses linked styles.
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 2) Go to Format > Styles > Edit Style on the main menu bar or right click on the object and 
select Edit Style from the context menu to open the Graphic Styles dialog (Figure 36 on 
page 32).

 3) Click on the Organizer tab to open the Organizer page in the Graphic Styles dialog.

 4) Check that the style name in the Inherit from text box is the linked style you want to edit.

a) If the linked style is the one you want to edit, use the various pages in the Graphic 
Styles dialog to edit the style.

b) If the linked style is NOT the one you want to edit, click on Edit Style to the right of the 
Inherit from text box until the name of the linked is displayed. Use the various pages in 
the Graphic Styles dialog to edit the style.

 5) Click OK when finished to save your changes and close the Graphic Styles dialog.

Note

Updating linked styles that are part of the default installation of LibreOffice could cause
problems in other documents that use LibreOffice default styles.

Updating styles
To update a style from changes made to an object:

 1) Select the object where you want to make changes to the style.

 2) Use the various options in the pages of the Graphic Styles dialog (Figure 36 on page 32), 
or the various tools on the Line and Filling toolbar (Figure 1 on page 5) to make your 
changes to the object.

 3) Use one of the following methods to update the style that has been applied to the object.

• Click on the Update Style icon in the Styles deck on the Sidebar.

• Click on Format > Styles > Update Selected Style on the main menu bar

Note

There is no confirmation when you update a style. Make sure that you only update 
styles that you have created. Updating styles that are part of the default installation of 
LibreOffice could cause problems in other documents that use LibreOffice default 
styles.

Applying styles
You can apply a drawing object style using the Styles deck on the Sidebar as follows:

 1) Select the object where you want to apply a style.

 2) To open a list of available styles, click on the Styles icon on the Line and Filling toolbar 
(Figure 1 on page 5), or click on the Styles icon on the Sidebar (Figure 35 on page 32).

 3) Double click on the style name to apply the style to the selected object.

Tip

At the bottom of the Styles deck on the Sidebar there is a drop-down list. Here you 
can choose to show all styles or groups of styles such as Applied Styles or Custom 
Styles.
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Deleting styles
You cannot delete any of the predefined styles in LibreOffice, even if you are not using them. You 
can only delete user-defined (custom) styles. However, before you delete a custom style, make 
sure the style is not in use. To see which styles are in use, choose Applied Styles from the drop-
down list at the bottom of the Styles deck on the Sidebar (Figure 35 on page 32).

Delete a custom style as follows:

 1) To open a list of available styles, click on the Styles icon on the Line and Filling toolbar 
(Figure 1 on page 5), or click on the Styles icon on the Sidebar (Figure 35 on page 32).

 2) Select Applied Styles or Custom Styles from the drop down list at the bottom of the Styles 
deck on the Sidebar to display the styles in use.

 3) Right click on the style name in the styles list and select Delete from the context menu.

 4) If the style is in use, a warning message will appear. Click Yes to delete the style. If the 
style is not in use, no confirmation message appears.

Applying special effects

As well as the basic actions of moving and resizing an object, a number of special effects can also 
be applied to objects in Draw. Several of these effects are readily available in the Transformations
toolbar (Figure 38). If the Transformations toolbar is not showing, select it from View > Toolbars 
> Transformations on the main menu bar.

The tools available on the Transformations toolbar are described in the following sections with the
exception of the 3D rotation tool, which is described in Chapter 7 Working with 3D Objects.

Figure 38: Transformations 
toolbar

Figure 39: Manually rotating an object
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Rotating objects
Rotation of an object can be carried out manually or using a dedicated dialog. This is similar to 
changing the position or size of an object.

Manual rotation
 1) Click on an object you want to rotate and the selection handles will show.

 2) To put the selected object into rotation mode, use one of the following methods. The 
selection handles will change shape and color when in rotation mode (Figure 39).

• Click again on the selected object.

• Click on the down arrow to the right the Transformations icon in the Line and Filling 
and select the Rotate icon from the context menu.

• If the Transformations toolbar is displayed (Figure 38) click on the Rotate icon.

 3) If necessary, click and drag the rotation pivot point to change the way the object is rotated. 
The pivot point is a circle and appears, by default, in the middle of the selected object. 
Normally the center of an object will be just fine, but on some occasions you may wish to 
rotate around a corner or even around a point outside the object.

 4) Move the mouse cursor over one of the corner handles and the cursor changes shape.

 5) Click and move the mouse in the direction in which you want to rotate the object. Only the 
corner selection handles are active for rotation.

 6) To restrict the rotation angles to multiples of 15 degrees, press and hold the Shift key while 
rotating the object. This is very handy for rotating objects through a right angle, for example
from portrait to landscape.

 7) When satisfied release the mouse button.

Sidebar rotation
To rotate an object using the Position and Size section in the Properties deck on the Sidebar 
(Figure 40):

 1) Click on an object you want to rotate and the selection handles will show.

 2) Click on the Properties icon on the Sidebar to open the Properties deck, then click on the 
down arrowhead (˅) next to the Position and Size section to open this section.

 3) Click on and then rotate the rotation indicator in Rotation or enter the rotation angle in the 
text box or select a predetermined rotation angle from the drop-down list. The object rotates
as you move the rotation indicator or enter an angle in the text box.

 4) When satisfied with the rotation of the object, click outside the object to fix rotation in place.

Rotation dialog
Instead of rotating an object manually or using the Sidebar, you can use the Rotation page in the 
Position and Size dialog (Figure 41) for a more precise control when rotating an object.

 1) Click on an object you want to rotate and the selection handles will show.

 2) Press the F4 key, or select Format > Position and Size on the main menu bar, or right-
click on the object and select Position and Size from the context menu to open the 
Position and Size dialog.

 3) Click the Rotation tab to open the Rotation page.

 4) In the Pivot Point, enter a figure in Position X and/or Position Y text boxes to reposition the
pivot point relative to the top left corner of the drawing, or select a position for the pivot 
point in Default settings. The default position for the pivot point is the center of the object.
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Figure 40: Position and Size section in
Properties on Sidebar

Figure 41: Position and Size dialog - Rotation page

 5) In the Rotation Angle, enter an angle in the Angle text box by which to rotate the object, or
click and drag the rotation indicator in Default settings until you reach the required angle. As
you click and drag, the angle is shown in the Angle text box.

 6) Click OK to save your changes, rotate the object and close the Position and Size dialog.

Flipping objects

Quick flipping
The quickest and easiest method to flip an object horizontally or vertically is as follows:

 1) Select the object you want to flip and the selection handles will be displayed.
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 2) Use one of the following methods to flip the object vertically or horizontally:

• Right click on the object and select Flip > Horizontally or Flip > Vertically from the 
context menu.

• In the Position and Size section of the Properties deck on the Sidebar, click on one of 
the icons Flip the selected object vertically or Flip the selected object horizontally.

• Click on the Vertical or Horizontal icon on the Line and Filling toolbar (Figure 1 on 
page 5).

Flip tool
Using the Flip tool on the Transformations toolbar (Figure 38 on page 35), you can also change 
the position and angle that the object flips over.

 1) Select the object you want to flip and the selection handles will be displayed.

 2) Click the Flip tool on the Transformations toolbar and the axis of symmetry appears as a 
dashed line through the middle of the object. The object will be flipped about this axis of 
symmetry (Figure 42).

 3) Click and drag one or both ends of the axis of symmetry to set the orientation of the axis.

 4) Place the cursor over one of the object selection handles until it changes shape.

 5) Click and drag the object across to the other side of the axis of symmetry until the object 
appears flipped over. The angle and position of the flip will depend on the angle and 
position of the axis of symmetry.

 6) Release the mouse button and the object is flipped.

Figure 42: Using Flip tool on Transformations 
toolbar
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Note

If you press the Shift key while moving the axis of symmetry, it will rotate in 45 degree 
increments.

Mirror copies
At the moment there is no mirror command existing in Draw. However, mirroring an object can be 
emulated by using the Flip tool as follows:

 1) Select the object you want to make a mirror copy of and copy the object to the clipboard.

 2) Select the Flip tool on the Transformations or Line and Filling toolbars.

 3) Move the axis of symmetry to the desired location of the mirror axis, then flip the object.

 4) Click on an empty area of the page to deselect the object.

 5) Paste from the clipboard to put a copy of the object back into its original location and now 
you have a mirror copy.

 6) If necessary, select both objects and realign them by going to Shape > Align on the main 
menu bar, or right click and select Align from the context menu and then select the type of 
alignment.

Distorting images
Three tools on the Transformations toolbar let you drag the corners and edges of an object to 
distort the image.

• Distort distorts an object in perspective.

• Set to Circle (slant) creates a pseudo three-dimensional effect.

• Set in Circle (perspective) creates a pseudo three-dimensional effect.

In all three cases you are initially asked if you want to transform the object to a curve. This is a 
necessary first step, so click Yes. Then you can move the object handles to produce the desired 
effect. Examples of using these tools are shown in the following figures.

Distorting
Select an object and click on the Distort icon on the Transformations toolbar (Figure 38 on page
35). After converting to a curve as requested, move the handles to stretch the object. The corner 
handles distort the corners, the vertical midpoint handles distort the figure horizontally and the 
horizontal ones distort it vertically (Figure 43).

Setting in circle (perspective)
Select an object and click on the Set in Circle (perspective) icon in the Transformations toolbar 
(Figure 38 on page 35). After converting to a curve as requested, click and move one of the 
selection handles to give a pseudo three dimensional perspective) (Figure 44).

Setting to circle (slant)
Select an object and click on the Set to Circle (slant) icon in the Transformations toolbar (Figure
38 on page 35). After converting to a curve as requested, click and move one of the selection 
handles to give a pseudo three dimensional slant perspective (Figure 45).
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Figure 43: Distorting an object

Figure 44: Setting an object to a circle with 
perspective

Figure 45: Setting an object to a circle with 
slant
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Note

Transforming an object into a curve is a safe operation, but it cannot be reversed other
than by clicking Format > Undo on the main menu bar.

Dynamic gradients
You can control transparency gradients in the same manner as color gradients and both types of 
gradient can be used together. With a transparency gradient, the direction and degree of object fill 
color changes from opaque to transparent. In a color gradient, the fill changes from one color to 
another, but the degree of transparency remains the same.

Two icons are present on the Transformations toolbar (Figure 38 on page 35) to dynamically 
control transparency and color gradients. Even if you have not assigned transparency to an object 
with a color fill, you can control the transparency by clicking on the Interactive transparency tool 
icon. This defines a transparency gradient and a dashed line connecting two squares appears on 
the object. Move the two squares to modify the gradient. You can define the direction of the 
gradient (vertical, horizontal, or at any angle) and the spot at which the transparency begins.

A regular color gradient is defined in the same manner. Select an object, then select a gradient fill 
from the Gradients page of the Area dialog (Figure 20 on page 16). The Interactive gradient tool
icon is now active on the Transformations toolbar. When you click on the Interactive gradient 
tool, a dashed line connecting two squares appears on the object, just as it does for a 
transparency gradient.

In both transparency gradient and gradient fill, click outside the object to set the gradient.

In the example shown in Figure 46 there is a single color object and a transparency gradient, 
covering part of the underlying object. This gradient transparency can be dynamically adjusted. 
Direction of transparency is changed by moving the white square and the distance over which it is 
applied by moving the green square.

Note

Moving the squares will have different effects, depending on the type of gradient. For 
example, for a linear gradient, the start and end squares of the gradient will always be 
situated to either side of the center point of the object.

Figure 46: Example of a dynamic 
gradient
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