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Introduction

By default, commands and tools used in LibreOffice Impress are grouped in a user interface 
consisting of cascading menus and toolbars. The functions and use of these cascading menus 
and toolbars are described in previous chapters of this user guide.

This chapter describes the user interface variants that are available for LibreOffice Impress. A 
user then has the option to select the user interface that suits their requirements and methods of 
creating presentations in LibreOffice Impress.

Note

When changing the user interface, the variant can be applied only to LibreOffice 
Impress, or applied to all the modules in LibreOffice.

Selecting a user interface

To select a user interface variant or switch between the user interface variants:

1) Go to View > User Interface on the Menu bar to open the Select Your Preferred User 
Interface dialog (Figure 1).

2) In UI variants, select one of the variants. An example of the selected variant is shown in 
the Preview box, along with a short description.

3) Click on Apply to Impress to immediately apply the variant selection to LibreOffice 
Impress only, or click on Apply to All to immediately apply the user interface variant to all
the LibreOffice modules. The LibreOffice window changes to match the selected variant.

4) Click on Close to close the dialog.

Note

If the option Enable experimental features has been selected in the Tools > 
Options > Advanced dialog (macOS LibreOffice > Preferences > LibreOffice 
> Advanced), several more variants appear in UI variants. Being experimental, 
these variants are not described in this user guide.

Figure 1: Select Your Preferred User Interface dialog
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Figure 2: Standard Toolbar UI for LibreOffice Impress

Standard Toolbar

The Standard Toolbar user interface is the default view when LibreOffice is installed and the 
Workspace opened for the first time. For more information on the Impress Workspace, see 
Chapter 1, Introducing Impress. Figure 2 shows an example of the default Workspace view in 
LibreOffice Impress consisting of the following:

• Menu bar at the top of the Workspace.

• Standard and Line and Filling toolbars positioned below the Menu bar.

• Drawing toolbar positioned vertically on the left of the Workspace.

• Sidebar on the right of the Workspace.

Tabbed

The Tabbed user interface provides a familiar interface for users coming from proprietary office 
suites, for example, Microsoft Office. Every tab within this user interface consists of a set of tools 
grouped by context. The context changes automatically depending on the LibreOffice module 
and the object selected.

It includes a Menu bar, a Tab bar, and tool icons grouped in context that would be normally used 
in LibreOffice Impress. If the tool icons on a tab page do not fit into the width of the Impress 
window, a double chevron >> appears at the right end of the row. Click on the double chevron >> 
to display more commands.

Figure 3: Icon bar on Menu bar
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At the left end of the Tab bar, an Icon bar (Figure 3) is available giving access to some commonly
used tools — Menubar; Open (Ctrl+O); Save (Ctrl+S);Undo (Ctrl+Z); Redo (Ctrl+Y); Start 
from First Slide (F5). In Windows and Linux operating systems, the Menu bar can be hidden or 
displayed by clicking on Menubar at the left end of the Tab bar.

On the right of the Tab bar, a quick menu (Figure 4), indicated by 3 horizontal lines (≡), is 
available giving access to some commonly used commands and links. Some of the quick menu 
items have submenus, indicated by a triangle ► or a single chevron > on the right. The quick 
menu is the same for all tabs.

Figure 4: Quick menu for Tabbed UI

Figure 5: Customize dialog - Notebookbar page
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The Tabbed user interface can be customized using the Notebookbar page of the Customize 
dialog (Figure 5) to show or hide the individual tools on the various tabs. For more information on
customization of LibreOffice, see the Getting Started Guide and the Writer Guide.

Note

When using the Tabbed user interface, the Impress toolbars are no longer visible.
If necessary, it is possible to open toolbars by going to View > Toolbars on the 
Menu bar or select Toolbars on the quick menu.

Fixed tabs

File tab
The File tab (Figure 6) is a fixed tab providing commands to create new documents; open, save, 
print, and close documents; manage templates; export to PDF and EPUB; display document 
properties; add a digital signature; and sign an existing PDF. The File tab has two menus 
(Figures 7 and 8): File and Help. The File tab menu contains the same commands as the tools 
available on the tab. The Help tab menu provides links to a variety of resources.

Figure 6: Tabbed user interface - File tab

Figure 7: File tab - File menu Figure 8: File tab - Help menu
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Home tab
The Home tab (Figure 9) is a fixed tab providing commands to cut, copy, paste, and format text; 
insert common items (for example images, tables, charts); apply, update, and edit drawing styles;
and so on. The Home tab menu (Figure 10) at the right end of the Home tab bar provides 
additional tools that are not on the tab.

Figure 9: Tabbed user interface - Home tab

Figure 10: Home tab - Home menu

Insert tab
The Insert tab (Figure 11) is a fixed tab providing tools to insert many commonly used items. The
Insert menu (Figure 12) at the right end of the Insert tab bar provides some of the same tools.

Figure 11: Tabbed user interface - Insert tab
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Figure 12: Insert tab - Insert menu

Layout tab
The Layout tab (Figure 13) is a fixed tab providing tools to create a slide layout. The Layout 
menu (Figure ) at the right end of the Layout tab bar provides some of the same tools.

Figure 13: Tabbed user interface - Layout tab

Figure 14: Layout tab - Layout menu

Tabbed | 9



Slide Show tab
The Slide Show tab (Figure 15) is a fixed tab providing tools for creating a slide show. The Slide 
Show menu (Figure 16) at the right end of the Slide Show tab bar provides some of the same 
tools.

Figure 15: Tabbed user interface - Slide Show tab

Figure 16: Slide Show tab - Slide Show menu

Review tab
The Review tab (Figure 17) is a fixed tab providing tools for reviewing a slide show. The Review 
menu (Figure 18) provides additional text editing tools. Some of these tools appear only if Asian 
or Complex Text Layout are selected in LibreOffice options.

Figure 17: Tabbed user interface - Review tab
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Figure 18: Review tab - Review menu

View tab
The View tab (Figure 19) is a fixed tab providing tools to control the display of slides on a screen.
The View menu (Figure 20) provides additional tools relating to the display of slides on a screen.

Figure 19: Tabbed user interface - View tab

Figure 20: View tab - View menu

Extension tab
The Extension tab is a fixed tab containing only the Extension Manager tool. When selected, this
tool opens the Extension Manager dialog allowing for installation and deletion of extensions that 
are compatible with LibreOffice.
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Tools tab
The Tools tab (Figure 21) is a fixed tab providing several tools for macros; color replacer; media 
player; and so on. The Tools menu (Figure 22) provides some of the same tools, plus extra tools 
for organizing, for example, macros and dialogs; image map; data sources; and so on.

Figure 21: Tabbed user interface - Tools tab

Figure 22: Tools tab - Tools menu

Additional tabs
Additional tabs appear between the View and Extension tabs when an applicable object in 
Impress is selected.

Draw tab
The Draw tab (Figure 23) becomes available when a drawing object is selected in a slide. It 
provides tools for editing, transforming, grouping, aligning, and distributing draw objects. The 
Draw tab menu (Figure 24) provides some of the tools required for editing, transforming and 
converting drawing objects.

Figure 23: Tabbed user interface - Draw tab

Figure 24: Draw tab - Draw menu

12 | Chapter 12, User Interface Variants



Image tab
The Image tab (Figure 25) becomes available when an image is selected in a slide, for example 
a photograph. It provides tools for working with images, such as cropping, borders, area styles, 
colors, and so on. The Image tab menu (Figure 26) provides links to dialogs for working with 
images.

Figure 25: Tabbed user interface - Image tab

Figure 26: Image tab - Image menu

Object tab
The Object tab (Figure 27) becomes available when an object, such as a chart, is selected. It 
provides tools to position, resize, choose colors, and so on for the selected object. The Object 
tab menu provides two extra tools to name and describe the object.

Figure 27: Tabbed user interface - Object tab

Table tab
The Table tab (Figure 28) becomes available when a table is selected in a slide. It provides tools 
to format a table to the presentation requirements. The Table tab menu (Figure 29) includes 
extra tools for editing a table.
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Figure 29: Table tab - Table menu

Media tab
The Media tab (Figure 30) only becomes available when a media object is selected in a slide. It 
provides tools for positioning and running an audio or video file. The Media tab menu (Figure 31) 
includes extra tools for editing a media object.

Figure 30: Tabbed user interface - Media tab

Figure 31: Media tab - Media menu

Single Toolbar

When selected, the Single Toolbar user interface only shows the Menu bar and the Standard 
(Single Mode) toolbar, as shown in Figure 32. However, toolbars can be added to the user 
interface by going to View > Toolbars on the Menu bar and selecting the required toolbar from 
the options available. For more information on toolbars, see Appendix B, Toolbars in this guide 
and the Getting Started Guide.
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Sidebar

When selected, the Sidebar user interface only show the Menu bar with no toolbars. However, 
toolbars can be added to the user interface by going to View > Toolbars on the Menu bar and 
selecting the required toolbar from the options available. For more information on toolbars, see 
Appendix B, Toolbars in this guide and the Getting Started Guide.

Tabbed Compact

The Tabbed Compact user interface has the same tabs as the Tabbed user interface, but the 
tools on each tab are arranged as a single row of tools. Some of these tools have drop-down 
menus with extra options. The tab menu on the right of the Tabbed Compact user interface 
provides the same options as the tab menus in the Tabbed user interface, see “Tabbed” on 
page 5 for more information.

Groupedbar Compact

The Groupedbar Compact user interface is divided into groups that contain commands 
organized as sets of tools and menus. The tools and menus that are available change to suit the 
type of object selected. Clicking on the double chevron >> displays more tools for editing an 
object. Figure 33 shows an example of Groupedbar Compact user interface when a basic 
shape object is selected.

The Menu (Figure 34) on the right-hand end of the Groupedbar Compact interface provides 
extra tools for working with LibreOffice Impress, including convenient ways to change the user 
interface and access toolbars.

Figure 33: Example of Groupedbar Compact user interface with basic shape object selected
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Figure 32: Single Toolbar user interface



Figure 34: Menu for Groupedbar Compact

Contextual Single

The Contextual Single user interface displays a single toolbar to suit the type of object that has 
been selected. Clicking on the double chevron >> displays more tools for editing an object. 
Figure 35 shows an example of a Contextual Single user interface when a basic shape object is
selected.

Figure 35: Example of a Contextual Single user interface
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