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What is LibreOffice?

LibreOffice is a freely available, fully-featured office productivity suite. Its native file format is 
Open Document Format (ODF), an open standard format that is being adopted by governments 
worldwide as a required file format for publishing and accepting documents. LibreOffice can also 
open and save documents in many other formats, including those used by several versions of 
Microsoft Office.

LibreOffice includes the following components.

Writer (word processor)
Writer is a feature-rich tool for creating letters, books, reports, newsletters, brochures, and other 
documents. You can insert graphics and objects from other components into Writer documents. 
Writer can export files to HTML, XHTML, XML, Adobe Portable Document Format (PDF), EPUB, 
and several versions of Microsoft Word files. It also connects to your email client.

Calc (spreadsheet)
Calc has all of the advanced analysis, charting, and decision making features expected from a 
high-end spreadsheet. It includes over 500 functions for financial, statistical, and mathematical 
operations, among others. The Scenario Manager provides “what if” analysis. Calc generates 2D 
and 3D charts, which can be integrated into other LibreOffice documents. You can also open and 
work with Microsoft Excel workbooks and save them in Excel format. Calc can also export 
spreadsheets in several formats, including for example Comma Separated Value (CSV), Adobe 
PDF and HTML formats.

Impress (presentations)
Impress provides all the common multimedia presentation tools, such as special effects, 
animation, and drawing tools. It is integrated with the advanced graphics capabilities of 
LibreOffice Draw and Math components. Slideshows can be further enhanced using Fontwork 
special effects text, as well as sound and video clips. Impress can open, edit and save Microsoft 
PowerPoint presentations and can also save your work in numerous graphics formats.

Draw (vector graphics)
Draw is a vector drawing tool that can produce everything from simple diagrams or flowcharts to 
3D artwork. Its Smart Connectors feature allows you to define your own connection points. You 
can use Draw to create drawings for use in any of the LibreOffice components, and you can 
create your own clip art and then add it to the Gallery. Draw can import graphics from many 
common formats and save them in many formats, including PNG, GIF, JPEG, BMP, TIFF, SVG, 
HTML and PDF.

Base (database)
Base provides tools for day-to-day database work within a simple interface. It can create and edit
forms, reports, queries, tables, views, and relations, so that managing a relational database is 
much the same as in other popular database applications. Base provides many new features, 
such as the ability to analyze and edit relationships from a diagram view. Base incorporates two 
relational database engines, HSQLDB and Firebird. It can also use PostgreSQL, dBASE, 
Microsoft Access, MySQL, Oracle, or any ODBC compliant or JDBC compliant database. Base 
also provides support for a subset of ANSI-92 SQL.
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Math (formula editor)
Math is the LibreOffice formula or equation editor. You can use it to create complex equations 
that include symbols or characters not available in standard font sets. While it is most commonly 
used to create formulas in other documents, such as Writer and Impress files, Math can also 
work as a standalone tool. You can save formulas in the standard Mathematical Markup 
Language (MathML) format for inclusion in web pages and other documents not created by 
LibreOffice.

Advantages of LibreOffice

Here are some of the advantages of LibreOffice over other office suites:

• No licensing fees. LibreOffice is free for anyone to use and distribute at no cost. Many 
features that are available as extra cost add-ins in other office suites (like PDF export) 
are free with LibreOffice. There are no hidden charges now or in the future.

• Open source. You can distribute, copy, and modify the software as much as you wish, in 
accordance with the LibreOffice Open Source licenses.

• Cross-platform. LibreOffice runs on several hardware architectures and under multiple 
operating systems, such as Microsoft Windows, macOS, and Linux.

• Extensive language support. The LibreOffice user interface, including spelling, 
hyphenation, and thesaurus dictionaries, is available in over 100 languages and dialects.
LibreOffice also provides support for both Complex Text Layout (CTL) and Right to Left 
(RTL) layout languages (such as Urdu, Hebrew, and Arabic).

• Consistent user interface. All the components have a similar “look and feel”, making 
them easy to use and master.

• Integration. The components of LibreOffice are well integrated with one another.

– All the components share a common spelling checker and other tools, which are used 
consistently across the suite. For example, the drawing tools available in Writer are 
also found in Calc, with similar but enhanced versions in Impress and Draw.

– You do not need to know which application was used to create a particular file. For 
example, you can open a Draw file from Writer; it will open automatically in Draw.

• Granularity. Usually, if you change an option, it affects all components. However, 
LibreOffice options can be set at a component level or even at document level.

• File compatibility. In addition to its native OpenDocument formats, LibreOffice includes 
support for opening and saving files in many common formats including Microsoft Office, 
HTML, XML, WordPerfect, Lotus 1-2-3, and PDF.

• No vendor lock-in. LibreOffice uses OpenDocument, an XML (eXtensible Markup 
Language) file format developed as an industry standard by OASIS (Organization for the 
Advancement of Structured Information Standards). These files can easily be unzipped 
and read by any text editor, and their framework is open and published.

• You have a voice. Enhancements, software fixes, and release dates are community-
driven. You can join the community and affect the course of the product you use.

You can read more about LibreOffice and The Document Foundation on their websites at 
https://www.libreoffice.org/ and https://www.documentfoundation.org/.
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Minimum requirements

LibreOffice 7.0 requires one of the following operating systems:

• Microsoft Windows: Windows 7 SP1, Windows 8, Windows Server 2012, or Windows 10; 
Administrator rights are needed for the installation process.

• GNU/Linux: Kernel version 3.10 or higher and glibc2 v2.17 or higher.

• macOS 10.10 (Yosemite) or higher; however, support for macOS 10.10 and 10.11 is 
deprecated.

Some LibreOffice features (wizards and the HSQLDB database engine) require that the Java 
Runtime Environment (JRE) (or, for macOS, the Java Development Kit (JDK)) is installed on your
computer. Although LibreOffice will work without Java support, some features will not be 
available.

Java is available at no cost. More information and download links to the appropriate edition for 
your operating system can be found at: https://java.com/en/download/manual.jsp

Note

If you want to use LibreOffice features that require Java, it is important that the 
correct 32-bit or 64-bit edition matches the installed version of LibreOffice. See the 
Advanced Options in Chapter 2 of this guide.

For a more detailed listing of hardware and software requirements, see the LibreOffice website,
https://www.libreoffice.org/get-help/system-requirements/.

How to get the software

Versions of LibreOffice for Windows, Linux, and macOS can be downloaded free from 
https://www.libreoffice.org/download. You can also download the software by using a Peer-to-
Peer client, such as BitTorrent, at the same address.

Linux users will also find LibreOffice included in many of the latest Linux distributions; Ubuntu is 
just one example.

macOS users can also get two versions of LibreOffice from the App Store for a small fee: 
LibreOffice Vanilla and Collabora Office (an enterprise-ready version).

Windows users can also get LibreOffice Vanilla from the Microsoft Store for a small fee.

How to install the software

Information on installing and setting up LibreOffice on the various supported operating systems is
given here: https://www.libreoffice.org/get-help/install-howto/.

Extensions and add-ons

Extensions and add-ons are available to enhance LibreOffice. Several extensions are installed 
with the program and you can get others from the official extensions repository, 
https://extensions.libreoffice.org/. See Chapter 14, Customizing LibreOffice, for more information 
on installing extensions and add-ons.
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Starting LibreOffice

In general, you start LibreOffice the same way you start any other program on your computer.

On Windows and Linux, entries for LibreOffice and each of its components appear in the system 
menu of your computer. On macOS, only an entry for LibreOffice is added to the Applications 
menu. You can make a desktop icon for LibreOffice or a component in the same way you can 
make a desktop icon for any other program; see your operating system’s help for how to do this.

Clicking on the LibreOffice menu entry, desktop icon, or tile opens the LibreOffice Start Center 
(Figure 1) from where you can select the individual components of LibreOffice. You can also 
choose to open an existing file or use a template. The thumbnails in the Start Center include an 
icon showing the type of file (text, spreadsheet, drawing, presentation).

Figure 1: LibreOffice Start Center

Opening an existing document before starting LibreOffice
You can start LibreOffice by double-clicking the filename of an ODF document on the desktop, or 
in a file manager such as Windows Explorer or macOS Finder. The appropriate component of 
LibreOffice will start and the document will be loaded.

You can also open files stored in remote servers running Content Management Interoperability 
Services (CMIS). CMIS, like OpenDocument Format, is an OASIS standard. When using CMIS 
servers, the service will ask you for the necessary credentials for file access.

If you do not have Microsoft Office installed on your computer, or if Microsoft Office is installed 
but you have associated Microsoft Office file types with LibreOffice, then when you double-click 
on the following files, they open in LibreOffice:

• A Word file (*.doc or *.docx) opens in Writer.

• An Excel file (*.xls or *.xlsx) opens in Calc.

• A PowerPoint file (*.ppt or *.pptx) opens in Impress.

If you did not associate the file types and Microsoft Office is installed on your computer, then 
when you double-click on a Microsoft Office file, it opens using the appropriate Microsoft Office 
component.

For more information on opening files, see “Opening existing documents” on page 15.
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Parts of the main window

The main window is similar for each component of LibreOffice, although some details vary. See 
the relevant chapters in this guide about Writer, Calc, Draw, Impress, Base, and Math for 
descriptions of those details.

Common features include the Menu bar, standard toolbar, and formatting toolbar (Writer and Calc
only) at the top of the window and the status bar at the bottom.

Menu bar
The Menu bar is located across the top of the LibreOffice window, just below the title bar. When 
you select one of the menus listed below, a sub-menu drops down to show commands. Below is 
the case for Writer:

• File – commands that apply to the entire document such as Open, Save, and Export as 
PDF.

• Edit – commands for editing the document such as Undo, Find & Replace, Cut, Copy, 
Paste, and Track Changes.

• View – commands for controlling the display of the document such as Toolbars, Text 
Boundaries, and Zoom.

• Insert – commands for inserting elements into your document such as Header, Footer, 
and Image.

• Format – commands for formatting the layout of your document.

• Styles – commands for quickly applying common styles; for editing, loading, and creating
new styles; and for accessing the Styles deck in the Sidebar.

• Table – commands to insert and edit a table in a text document.

• Form – commands to create fill-in forms.

• Tools – functions such as Spelling, AutoCorrect, and Customize, and Options.

• Window – commands for the display window.

• Help – links to the LibreOffice Help file, What’s This?, and information about the program.

Toolbars
LibreOffice has two types of toolbars: docked (fixed in place) and floating. Docked toolbars can 
be moved to different locations or made to float, and floating toolbars can be docked.

In a default LibreOffice installation, the top docked toolbar, just under the Menu bar, is called the 
Standard toolbar. It is consistent across the LibreOffice applications.

The second toolbar at the top for Writer and Calc, in a default LibreOffice installation, is the 
Formatting bar. It is context-sensitive; that is, it shows the tools relevant to the current position of 
the cursor or the object selected. For example, when the cursor is on a graphic, the Formatting 
bar provides tools for formatting graphics; when the cursor is in text, the tools are for formatting 
text.

In some cases it is convenient to reduce the number of toolbars displayed and get more space 
for the document. LibreOffice provides a single-toolbar alternative to the default double-toolbar 
setup. It contains the most-used commands. To activate it, enable View > User Interface > Single
Toolbar.

Other variations include Tabbed and Groupedbar Compact, both accessed from View > User 
Interface. These provide a collection of tools at the top of the workspace, grouped in various 
ways that may be familiar to users of Microsoft Office (the “ribbon”).
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Displaying or hiding toolbars
To display or hide toolbars in a standard setup, go to View > Toolbars on the Menu bar, then 
click on the name of a toolbar from the submenu. An active toolbar shows a checkmark beside its
name. Toolbars created from tool palettes are not listed in the View menu.

To close a toolbar, go to View > Toolbars on the Menu bar and deselect the toolbar, or right-click
in an empty space between the icons on a toolbar and select Close Toolbar in the context menu.

Sub-menus and tool palettes
Toolbar icons with a small triangle to the right will display sub-menus, tool palettes, and 
alternative methods of selecting items, depending on the icon.

Tool palettes can be made into a floating toolbar. Figure 2 shows an example of a tool palette 
from the Drawing toolbar made into a floating toolbar. See “Moving toolbars” and “Floating 
toolbars” below for more information on moving and floating these toolbars created from tool 
palettes.

Figure 2: Example of tearing off a tool palette

Moving toolbars
Docked toolbars can be undocked and moved to a new docked position or left as a floating 
toolbar.

1) Move the mouse cursor over the toolbar handle, which is the small vertical bar to the left 
of a docked toolbar and highlighted in Figure 3.

2) Hold down the left mouse button and drag the toolbar to the new location. The toolbar can
be docked in a new position at the top, sides or bottom of the main window, or left as a 
floating toolbar.

3) Release the mouse button.

To move a floating toolbar, click on its title bar and drag it to a new floating location or dock the 
toolbar at the top or bottom of the main window.

Figure 3: Toolbar handles

Floating toolbars
LibreOffice includes several additional toolbars, whose default settings have them appear as 
floating toolbars in response to the current position of the cursor or selection. You can dock these
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toolbars to the top or bottom of the main window, or reposition them on your computer display 
(see “Moving toolbars” above).

Some of these additional toolbars are context sensitive and will automatically appear depending 
on the position of the cursor. For example, when the cursor is in a table, a Table toolbar appears, 
and when the cursor is in a numbered or bullet list, the Bullets and Numbering toolbar appears.

Customizing toolbars
You can customize toolbars in several ways, including choosing which icons are visible and 
locking the position of a docked toolbar. You can also add icons and create new toolbars, as 
described in Chapter 14, Customizing LibreOffice. To access the customization options for a 
toolbar, right-click in an empty space between the icons on a toolbar to open a context menu as 
follows:

• To show or hide icons defined for the selected toolbar, point to Visible Buttons. Visible 
icons on a toolbar are indicated by an outline around the icon (Figure 4) or by a check 
mark beside the icon, depending on your operating system. Select or deselect icons to 
hide or show them on the toolbar.

Figure 4: Selection of visible toolbar icons

• Click Customize Toolbar to open the Customize dialog; See Chapter 14, Customizing 
LibreOffice, for more information.

• Click Dock Toolbar to dock the selected floating toolbar. You can reposition the toolbar to
a different docked position. See “Moving toolbars” on page 10.

• Click Dock All Toolbars to dock all floating toolbars. You can reposition the toolbars to 
different docked positions. See “Moving toolbars” on page 10.

• Click Lock Toolbar Position to lock a docked toolbar into its docked position.

• Click Close Toolbar to close the selected toolbar.
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Context menus
Context menus provide quick access to many menu functions. They are opened by right-clicking 
on a paragraph, graphic, or other object. When a context menu opens, the functions or options 
available will depend on the object that has been selected. A context menu can be the easiest 
way to reach a function, especially if you are not sure where the function is located in the menus 
or toolbars. Context menus may display an applicable keyboard shortcut if one has been set; you
can toggle this visibility off or on in Tools > Options > LibreOffice > View > Visibility.

Figure 5: Keyboard shortcuts in context menus

Status bar
The status bar is located at the bottom of the workspace. It provides information about the 
document and convenient ways to change some features quickly. It is similar in Writer, Calc, 
Impress, and Draw, but each LibreOffice component includes some component-specific items. An
example of the Writer status bar is shown in Figure 6.

Figure 6: Example status bar from Writer

Page, sheet, or slide number and page count
Shows the current page, sheet, or slide number and the total number of pages, sheets, or 
slides in the document. Click on this field to open the Go to Page dialog. Other uses of this 
field depend on the LibreOffice component.

Word & character count
Shows the total number of words and characters in the document or in the selection.

Page style or slide design
Shows the current page style or slide design. To edit the current page style or slide design, 
double-click on this field. To choose a different page style or slide design, right-click on this 
field and select from the list that pops up.

Language
Shows the current language of the text at the current cursor position.
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Insert mode
Shows the type of insert mode the program is in. This field is blank if the program is in 
Insert mode. Each time the Ins key is pressed, or this field is clicked, the mode toggles 
between Insert and Overwrite.

Selection mode
Click to choose different selection modes. The icon does not change, but when you hover 
the mouse pointer over this field, a tooltip indicates which mode is active.

Unsaved changes
The icon shown here is different when changes to the document have not been saved.

Digital signature
If the document has been digitally signed, an icon shows here. You can click the icon to 
sign the document, or to view the existing certificate.

Object information
Displays information relevant to the position of the cursor or the selected element of the 
document.

View layout
Select between Single-page view, Multiple-page view, and Book view to change how your 
document is displayed.

Zoom slider
Drag the Zoom slider, or click on the + and – signs to change the view magnification of your
document.

Zoom percentage
Indicates the magnification level of the document. Right-click on the percentage figure to 
open a list of magnification values from which to choose. Clicking on this percentage figure 
opens the Zoom & View Layout dialog.

Sidebar
To activate the Sidebar, select View > Sidebar on the Menu bar. The Sidebar (Figure 7) is 
located on the right side of the edit views of Writer, Calc, Impress, and Draw. It contains one or 
more decks, based on the current document context. Decks are organized into panels. A tab bar 
on the right side of the sidebar allows you to switch between different decks.

All four components contain the Properties, Styles, Gallery, and Navigator decks. Some 
components have additional decks, such as Page for Writer; Master Slides, Animation, and Slide 
Transition for Impress; Shapes for Draw; and Functions for Calc.

A panel is like a combination of a toolbar and a dialog. For example, you can freely mix working 
in the main edit window to enter text and use the Properties panel in the sidebar to change text 
attributes.

Toolbars and Sidebar panels share many functions. For example, the buttons for making text 
bold or italic exist in both the Formatting toolbar and the Properties panel.

For more detail, see the Sidebar explanation in the relevant LibreOffice component’s user guide.

To hide the Sidebar, click on the gray Hide button on the left. Click on the same button to show 
the Sidebar again.

To undock the Sidebar and make it floating, and to dock a floating Sidebar, use the Sidebar 
settings drop-down list at the top of the tab bar (see Figure 8). From the same list you can 
choose which items to show in the Sidebar.
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Figure 7: Properties panel of Sidebar in Writer

Figure 8: Floating (undocking) or docking the Sidebar

Starting new documents

You can start a new, blank document in LibreOffice in several ways.

When LibreOffice is running but no document is open, the Start Center (Figure 1 on page 8) is 
shown. Click one of the icons to open a new document of that type, or click the Templates icon 
to start a new document using a template.

You can also start a new document in one of the following ways:

• Use File > New on the Menu bar and select the type of document in the context menu.

• Use the keyboard shortcut Ctrl+N to create a new document. The type of document 
created depends on which LibreOffice component is open and active. For example, if 
Calc is open and active, a new spreadsheet is created.
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• Use File > Wizards on the Menu bar and select the type of document in the context 
menu.

• If a document is already open in LibreOffice, click the New icon on the Standard toolbar 
and a new document of the same type is created in a new window. For example, if Calc 
is open and active, a new spreadsheet is created. The New icon changes depending on 
which component of LibreOffice is open.

• If a document is already open in LibreOffice, click on the small triangle to the right of the 
New icon on the Standard toolbar and select the type of document from the context 
menu that opens.

Note

If all documents are closed without exiting from LibreOffice, then the Start Center will
be displayed.

Opening existing documents

You can also open an existing document in one of the following ways:

• When no document is open, click Open File or Remote Files in the Start Center to reach
the corresponding open dialog.

• Go to File > Open or File > Open Remote on the Menu bar to reach the corresponding 
open dialog.

• Use the keyboard shortcut Ctrl+O to reach the Open dialog.

• If a document is already open, click the Open icon on the Standard toolbar and select 
from a list of available documents from the Open dialog.

• Click the small triangle to the right of the Open icon and select from a list of recently 
opened documents, click Open Template to select a template, or click Open Remote 
File to open a remote file.

• When no document is open, click on a thumbnail of recently opened documents 
displayed in the Start Center. You can scroll up or down in the Start Center to locate a 
recently opened document.

When using the Open dialog, navigate to the folder you want, select the file you want, and then 
click Open. If a document is already open in LibreOffice, the second document opens in a new 
window.

In the Open dialog, you can reduce the list of files by selecting the type of file you are looking for. 
For example, if you choose Text documents as the file type, you will only see documents Writer 
can open (including .odt, .doc, .txt); if you choose Spreadsheets, you will see .ods, .xls, and other
files that Calc opens.

You can also open an existing document that is in a format that LibreOffice recognizes by double-
clicking on the file icon on the desktop or in a file manager such as Windows Explorer. 
LibreOffice has to be associated with file types that are not ODF files for the appropriate 
LibreOffice component to open.

Note

When opening files stored in a remote server, you may be asked to enter your user 
name and password to log in the server.
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Saving documents

You can save documents as follows:

• Save – use if you are keeping the document, its current filename and location.

• Save As – use to create a new document, or change the filename and/or file format, or 
save the file in a different location on your computer.

• Save Remote – use if your document is already stored in a remote server or will be 
stored in a remote server.

• Save a Copy – use to save a copy of your current document and keep it open for more 
editing.

• Save All – use to save all the files open in your current session.

Save command
To save a document if you are keeping the document’s current filename and location, do one of 
the following:

• Use the menu option File > Save.

• Use the keyboard shortcut Ctrl+S.

• Click the Save icon on the Standard toolbar.

• Use the menu option File > Save All.

• Use the menu option File > Save Remote.

• Use the menu option File > Save a Copy (similar to the Save As command).

Using the Save command will immediately overwrite the last saved version of the file.

Save As command

Figure 9: Example of LibreOffice Save As dialog

If you want to create a new document file, change the filename and/or file format, or save the file 
in a different location on your computer:

• Use the keyboard shortcut Ctrl+Shift+S.
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• Use the menu option File > Save As.

When the Save As dialog (Figure 9) or Save dialog opens, enter the file name, change the file 
type (if applicable), navigate to a new location (if applicable), and click Save.

Password protection

To restrict who can open and read a document, or open and edit the document, use password 
protection.

1) Using the Save As command above, select the Save with password option in the Save 
As dialog or Save dialog.

2) Click Save and the Set Password dialog opens (Figure 10).

3) In the File Encryption Password section, enter a password to open the document and 
then enter the same password as confirmation.

4) To restrict who can edit the document, click Options.

5) In the File Sharing Password section, select Open file read-only, enter a password to 
allow editing, and then enter the same password as confirmation.

6) Click OK and the dialog closes. If the passwords match, the document is saved 
password-protected. If the passwords do not match, you receive an error message.

Figure 10: Set Password dialog

Caution

LibreOffice uses a very strong encryption mechanism that makes it almost 
impossible to recover the contents of a document if you lose or forget the password.

Changing the password
When a document is password-protected, you can change the password while the document is 
open. Go to File > Properties > General on the Menu bar and click the Change Password 
button. This opens the Set Password dialog where you can enter a new password.
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Saving documents automatically
LibreOffice can save files automatically as part of the AutoRecovery feature. Automatic saving, 
like manual saving, overwrites the last saved state of the file. 

To set up automatic file saving:

1) Go to Tools > Options > Load/Save > General on the Menu bar.

2) Select Save AutoRecovery information every and set the time interval.

3) Click OK.

Opening and saving files on remote servers

LibreOffice can open and save files stored on remote servers. Keeping files on remote servers 
allows you to work with the documents using different computers. For example, you can work on 
a document in the office during the day and edit it at home for last-minute changes. Storing files 
on a remote server also backs up documents from computer loss or hard disk failure. Some 
servers are also able to check-in and check-out files, thus controlling their usage and access.

LibreOffice supports many document servers that use well known network protocols such as FTP,
WebDav, Windows share, and SSH. It also supports popular services like Google Drive and 
Microsoft OneNote, as well as commercial and open source servers that implement the OASIS 
CMIS standard.

To enable a remote server connection, use one of these methods:

• Click on the Remote Files button in the Start Center.

• Select File > Open Remote in any open document.

• Select File > Save Remote in any open document.

On the Remote Files dialog (Figure 12), click Manage Services / Add Service button in the 
upper right to open the File Services dialog (Figure 11). Depending on the type of file service you 
choose in the Type listbox, different parameters are necessary to fully qualify the connection to 
the remote server.

Figure 11: Remote server configuration

Once the connection is defined, click OK to connect. The dialog will dim until the connection is 
established with the server. A dialog asking for the user name and the password may pop up to 
let you log in the server. Proceed entering your credentials.
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The Remote Files dialog (Figure 12) which then appears has many parts. The upper list box 
contains the list of remote servers you have previously defined. The line below the list box shows
the path to access the folder. On the left is the folder structure of the user space in the server. 
The main pane displays the files in the remote folder. Click the Open or Save button to proceed.

Figure 12: Remote Files dialog when connected to a server

Using the Navigator

The LibreOffice Navigator lists objects contained within a document, collected into categories. 
For example, in Writer it shows Headings, Tables, Frames, Comments, Images, Bookmarks, and 
other items, as shown in Figure 13. In Calc it shows Sheets, Range names, Database ranges, 
Images, Drawing objects, and other items. In Impress and Draw it shows Slides, Pages, and 
other items.

To open the Navigator, press the F5 key, or go to View > Navigator on the Menu bar, or click the 
Navigator icon on the Sidebar.

Click the marker (+ or triangle) by any of the categories to display the list of objects in that 
category.

The Navigator provides several convenient ways to move around a document and find items in it:

• When a category is showing the list of objects in it, double-click on an object to jump 
directly to that object’s location in the document.

• Objects are much easier to find if you have given them recognizable names when 
creating them, instead of keeping the default names such as Sheet1, Table1, or Table2. 
The default names may not correspond to the actual position of the object in the 
document.

• Navigator also provides the facility to move, promote, demote items within a document.

• Each Navigator in the individual LibreOffice components has a different range of 
functions. These functions are further explained in the user guide for each LibreOffice 
component.
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Figure 13: Navigator in Writer

Undoing and redoing changes

To undo the most recent unsaved change in a document, use the keyboard shortcut Ctrl+Z, or 
click the Undo icon on the Standard toolbar, or go to Edit > Undo on the Menu bar. Click the 
small triangle to the right of the Undo icon to get a list of all the changes that can be undone. You
can select multiple changes and undo them at the same time.

After changes have been undone, you can redo changes. To redo a change use the keyboard 
shortcut Ctrl+Y, or click the Redo icon, or go to Edit > Redo on the Menu bar. As with Undo, click
on the triangle to the right of the Redo icon to get a list of the changes that can be reapplied.

To repeat the last command applied to your document, use the shortcut Ctrl+Shift+Y. This can 
save several repetitive menu navigation clicks or keyboard shortcuts, especially when the 
command is taken from a secondary menu.

Reloading a document

Reloading is useful in two situations.

• You may want to discard all the changes made in an editing session after the last 
document save.

• You may have made some formatting changes that do not show until the document has 
been closed and reopened; reloading has the same result.

To reload a document, go to File > Reload on the Menu bar. If you have made changes to a file 
since the last save, a confirmation dialog will warn you that reloading will discard your last 
changes. Choose whether to save or discard the changes.

On reloading the document, the File dialog does not open, because the file is already selected.

Using document properties

To open the Properties dialog for a document, go to File > Properties on the Menu bar. The 
Properties dialog provides information about the document and allows you to set some of its 
properties. The dialog and its tabs are described below.
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General
Contains basic information about the current file: file name and type; storage location; file size; 
date, time, and author of file creation and last modification; template used to create the file; date, 
time, and author of digital signature; date, time, and user name when the file was last printed; 
total editing time; and revision number.

Controls available:

• Change Password – opens a dialog to change the password. It is only active if a 
password has been set for the file.

• Digital Signatures – opens the Digital Signatures dialog where you can manage digital 
signatures for the current document.

• Apply user data – saves the full name of the user with the file. You can edit the name by
going to Tools > Options > LibreOffice > User Data on the Menu bar.

• Save preview image with this document – saves a thumbnail.png inside the document.
These images may be used by a file manager under certain conditions.

• Reset Properties – resets the editing time to zero, the creation date to the current date 
and time, and the version number to 1. The modification and printing dates are also 
deleted.

Description
Contains optional editable descriptive information about the document, which may be exported 
as metadata to other file formats.

• Title – enter a title for the document.

• Subject – enter a subject for the document. You can use a subject to group documents 
with similar contents.

• Keywords – enter the words that you want to use to index the content of the document. 
Keywords must be separated by commas. A keyword can contain white space characters
or semicolons.

• Comments – enter comments to help identify the document.

Custom Properties
Use this page to assign custom information fields to the document. In a new document, this page
may be blank. If the new document is based on a template, this page may contain fields. You can
change the name, type, and contents of each row. The information in the fields will be exported 
as metadata to other file formats.

Click Add Property to add a new custom property. Click Reset to delete all custom properties.

CMIS Properties
Used for documents stored on remote servers; not shown otherwise. See the Help for more 
information.

Security
Enables two password-protected security options.

• Open file read-only – select to allow this document to be opened only in read-only 
mode. This file sharing option protects the document against accidental changes. It is still
possible to edit a copy of the document and save that copy with the same name as the 
original.
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• Record changes – select to require that all changes be recorded. To protect the 
recording state with a password, click Protect and enter a password. This is similar to 
Edit > Track Changes > Record on the Menu bar. However, while other users of this 
document can apply their changes, they cannot disable change recording without 
knowing the password.

Protect or Unprotect button protects the change recording state with a password. If change 
recording is protected for the current document, the button is named Unprotect. Click Unprotect
and type the correct password to disable the protection.

Font
When Embed fonts in the document is selected, any fonts used in the document will be 
embedded into the document when it is saved. This may be useful if you are creating a PDF and 
want to control how it will look on other computer systems.

Only embed fonts that are used in documents – If fonts have been defined for the document 
(for example, in the template), but have not been used, select this option to not embed them.

Font scripts to embed – You can choose which types of fonts are embedded: Latin, Asian, 
Complex. 

Statistics
Displays statistics for the current file, such as the number of pages, words, and characters.

Closing a document

If only one document is open and you want to close that document, go to File > Close on the 
Menu bar or click on the X on the right or left end of the Menu bar. On Windows and Linux, the 
document closes and the LibreOffice Start Center opens. On macOS, the document closes and 
only the Menu bar remains at the top of the screen.

If more than one document is open and you want to close one of them, go to File > Close on the 
Menu bar or click on the X on the right or left end of the title bar of that document’s window.

If the document has not been saved since the last change, a message box is displayed. Choose 
whether to save or discard your changes.

Caution

Not saving your document could result in the loss of recently made changes, or 
worse still, the entire file.

Closing LibreOffice

To close LibreOffice completely, go to File > Exit LibreOffice on the Menu bar in Windows and 
Linux. In macOS, go to LibreOffice > Quit LibreOffice on the Menu bar.

In Windows and Linux, when you close the last document using the X on the title bar of the 
window, then LibreOffice will close completely. In macOS, you need to use LibreOffice > Quit 
LibreOffice.

You can also use a keyboard shortcut as follows:

• In Windows and Linux – Ctrl+Q

• In macOS – Command +Q⌘
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If any documents have not been saved since the last change, a message box is displayed. 
Choose whether to save or discard your changes.

Troubleshooting LibreOffice in Safe Mode

You can use Safe Mode to help restore an instance of LibreOffice that has become corrupted and
stopped working or fails to launch.

To access Safe Mode, do one of the following:

• Choose Help > Restart in Safe Mode on the Menu bar.

• Start LibreOffice from the command line with the --safe-mode option.

• In Windows only, choose LibreOffice (Safe Mode) from the Start Menu.

Figure 14: LibreOffice Safe Mode

The following Safe Mode options get more extreme from the top down, so it is recommended that
you try them successively. 

• Restore from backup – LibreOffice keeps backups of previous configurations and 
activated extensions. Use this option to restore the user configuration, installed 
extensions, or both, to a previous known working state if you suspect that your problems 
were caused by recent changes to either.

• Configure – Use this option to disable all user extensions, hardware acceleration, or 
both. This is a good choice if you are experiencing crashes on startup or visual glitches 
that are often related to hardware acceleration.

• Extensions – If you suspect that a corrupted extension is blocking or causing LibreOffice
to crash, you can use this option to uninstall all user extensions and reset the state of 
any shared or bundled extensions. In the case of shared or bundled extensions, the 
option will only work if you have the proper system access rights. It should be exercised 
with caution.

• Reset to factory settings – If all of the above fails, you can reset your settings and your 
user interface modifications, or your entire profile back to factory defaults.
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– Reset settings and user interface modifications – this will reset your User Interface
and configuration changes, but keep things like your personal dictionary, templates, 
etc.

– Reset entire user profile – this will erase all customized options and return your user
profile to the factory default state.

• Continue in Safe Mode – Continuing in Safe Mode will allow you to work in LibreOffice, 
using a temporary profile that was created on startup. Any extensions or configuration 
options you had set up previously will have to be reconfigured in order to be used, 
bearing in mind that any changes made to the temporary user profile will be lost after any
restart.

• Restart in Normal Mode – If you arrived in Safe Mode accidentally, this option will 
discard any changes, terminate Safe Mode, and restart LibreOffice normally.

• Apply Changes and Restart – Choose this option to apply any of the above changes 
and restart LibreOffice.

Note

If you are unable to solve your problem using Safe Mode, the Advanced tab provides
instructions on receiving further aid.

In the Advanced tab you can also create a .zip file of your corrupted user profile 
which can then be uploaded to the bug tracking system where it can be further 
investigated by the developers.

However, be aware that your uploaded user profile may contain sensitive information
such as installed extensions, personal dictionaries, and settings.
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