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Quick printing

To quickly print a document or drawing, click on Print Directly on the Standard toolbar (Figure 1)
to send the entire document to the default printer that is defined for the computer.

If Print Directly is not visible on the Standard toolbar, it can be added as follows:

1) Right-click in an empty area on the Standard toolbar and select Visible Buttons from the 
context menu.

2) Select Print Directly from the list of available tools and the Print Directly tool is added to
the Standard toolbar.

Default printer

To specify the default printer, go to File > Printer Settings on the Menu bar to open the Printer 
Setup dialog. An example of a Printer Setup dialog is shown in Figure 2.

1) Select the required printer from the printers listed in the Name drop-down list.

2) Click on Properties to open the Properties dialog for the selected printer and select the 
required options from those available in the dialog. The options available in this dialog 
depends on the type of printer connected to the computer and the computer operating 
system being used.

3) Click OK to save the selected options and close the Properties dialog.

4) Click OK to save the printer selection and close the Printer Setup dialog.

Figure 1: Standard toolbar with Print Directly installed

Figure 2: Example of a Printer Setup dialog
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Controlled printing

For more control over printing, open and use the Print dialog using one of the following methods. 
Due to different computer setups and operating systems, the print dialog that opens may differ 
from the dialogs shown in this user guide. However, the printing options available for LibreOffice 
remain the same.

• Go to File > Print on the Menu bar.

• Use the keyboard shortcut Ctrl+P (macOS ⌘+P).

• Click on Print on the Standard toolbar.

 Note

The options selected in the Print dialog only apply to the printing of the current 
document that is open in Draw. To specify default print settings for LibreOffice, go to 
Tools > Options > LibreOffice > Print (macOS LibreOffice > Preferences > 
LibreOffice > Print) on the Menu bar to open the Options LibreOffice Print dialog.

Note

Any print options selected in the Print dialog when printing from Draw overrides the 
default printer settings that have been set using Tools > Options > LibreOffice > 
Print (macOS LibreOffice > Preferences > LibreOffice > Print) and Tools > 
Options > LibreOffice Draw > Print (macOS LibreOffice > Preferences > 
LibreOffice Draw > Print).

Note

Due to different computer setups and different operating systems, the print dialog 
that opens may differ from the dialogs displayed in this chapter. However, the 
printing options available for LibreOffice remain the same.

Linux or Windows printing

General options
The following general options are an example of what may be available on the General page of 
the Print dialog (Figure 3).

• Printer –– select the printer to use from the printers available in the drop-down list.

• Properties –– click on this button to open the properties dialog for the printer being used.
The options available in this dialog depends on the type of printer connected to the 
computer and the computer operating system being used.

• Range and Copies –– select from the following options:

– All Pages –– prints all the pages in the document.

– Selection –– prints the pages selected in LibreOffice Draw.

– Pages –– select the page number(s) to print. For multiple pages, use the format 1, 3, 
7 or 1 – 5, 7, 9 for page number selection.

– Include –– select from the drop-down list Odd and Even Pages, Odd Pages, or Even 
Pages.

– More > Paper sides –– select from the drop-down list Print on one side (simplex), 
Print on both sides (duplex long edge), or Print on both sides (duplex short edge).
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Figure 3: Print dialog - Linux or Windows - General page

– More > Number of copies –– enter number of printed copies required for the 
document.

– More > Collate –– collates multiple printed copies into separate documents.

– More > Order –– select from Create separate print jobs for collated output (only 
available when more than one copy is being printed) or Print reverse order.

• Page Layout –– select from the following options:

– Paper size –– select the paper size to use from drop-down list.

– Orientation –– select from the drop-down list Automatic, Portrait or Landscape.

– More > Pages per sheet –– select from the drop-down list how many pages are 
printed on one sheet of paper.

– More > Order –– select from the drop-down list the printing order of multiple pages on 
one sheet of paper.

– More > Draw a border around each page –– when multiple pages are printed on one 
sheet of paper, a border is drawn around each page.

– More > Brochure –– prints the document so the pages can be folded into a brochure 
or booklet.
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Figure 4: Print dialog - Linux or Windows - LibreOffice Draw page

LibreOffice Draw options
The following options are available on the LibreOffice Draw page of the Print dialog (Figure 4) 
where settings are defined specific to the current document type:

• Contents –– when selected prints the Page name and/or Date and time on the drawing.

• Color –– prints the drawing in Original colors, Grayscale, or Black & white.

• Size –– print the drawing using one of the following options:

– Original size –– prints the drawing using its original size.

– Fit to printable page –– the drawing size is changed so that it fits on the paper size 
used for printing.

– Distribute on multiple sheets of paper –– used if the drawing is too large for the paper 
size being used.

– Tile sheet of paper with repeated pages –– used to print multiple copies of a drawing 
on a page.

macOS printing

LibreOffice Draw options
By default, when the Print dialog opens, the page for LibreOffice Draw printing options is already 
selected, as shown in Figure 5.

• Printer –– select the printer to be used from the drop-down list. If the default printer is 
being used, then this printer will already be selected.

• Presets –– select from the drop-down list a printing preset. The presets available depend
on the type of printer connected to the computer. This also includes any custom presets 
that have been created.

• Copies –– enter the number of copies to be printed.

• Black & White –– select this option to print the drawing in monochrome if the printer 
selected is capable of color printing.
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Figure 5: Print dialog - macOS - LibreOffice Draw page

• Two-Sided –– select this option to print the drawing double sided if the printer selected is
capable of double sided printing.

• Pages > All –– prints all the pages in the document.

• Pages > From: to: –– select the page number(s) to print. For multiple pages, use the 
format 1, 3, 7 or 1 – 5, 7, 9 for page number selection.

• Print selection only –– only prints the selected area(s) or object(s) in the current 
drawing.

• Contents –– prints the Page name and/or Date and time on the drawing.

• Color –– prints the drawing in Original colors, Grayscale, or Black & white.

• Size –– print the drawing using one of the following options:

– Original size –– prints the drawing using its original size.

– Fit to printable page –– the drawing size is changed so that it fits on the paper size 
used for printing.

– Distribute on multiple sheets of paper –– used if the drawing is too large for the paper 
size being used.

– Tile sheet of paper with repeated pages –– used to print multiple copies of a drawing 
on a page.
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Figure 6: Print dialog - macOS - LibreOffice Draw - More page

To access more printing options in LibreOffice Draw, click on More to open the second page of 
LibreOffice Draw options, as shown by the example in Figure 6.

• Brochure –– when selected, prints the document so the pages can be folded into a 
brochure or booklet.

• Include — select which pages to print from the drop-down list: All pages; Front 
sides/right pages; Back sides/left pages. Only available when Brochure is selected.

– Use only paper tray from printer preferences — when selected, the printer tray 
selected on the printer overrides the selected tray in the printer properties on the 
computer.

– All Slides — all the slides in the slide show are printed.

– Slides: — enter the slide number(s) in the text box that are to be printed. For multiple 
slides, use the format 1, 3, 7 or 1 – 5, 7, 9 for slide number selection.

– Selection — prints the slides selected in LibreOffice Impress in the Slides pane.

General printing
Click on the LibreOffice drop-down list to select the general printing and select one of the 
following options.

• Media & Quality

– Feed from –– select from the drop-down list the paper tray to use if the printer has 
more than one paper tray.

– Media Type –– select from the drop-down list the paper type that has been loaded into
the paper tray being used, for example Envelope, Photo, Plain Paper.

– Quality –– select the level of printing quality required.

• Layout
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– Pages per sheet –– select from the drop-down list how many pages are printed on 
one sheet of paper.

– Layout Direction –– select the printing order of multiple pages on one sheet of paper.

– Border –– when multiple pages are printed on one sheet of paper, a border is drawn 
around each page.

– Two-Sided –– select from the drop-down list how a multi-page document is going to 
be bound: Off; Long-Edge binding; Short-Edge binding, Booklet.

– Reverse page orientation –– if LibreOffice prints the pages in the wrong order, select 
this option and print the document again.

– Flip horizontally –– if LibreOffice prints the pages in the wrong orientation, select this 
option and print the document again.

• Paper Handling

– Collate pages –– when selected collates multiple printed copies into separate 
documents.

– Pages to Print –– select which pages in the document to print from the drop-down list: 
All pages; Odd only; Even only.

– Page Order –– select the page printing order from the drop-down list: Automatic; 
Normal; Reverse.

– Scale to fit paper size –– adjusts the printed page to fit the paper size.

– Destination Paper Size –– select a paper size from the options available in the 
drop-down list. Only available if Scale to fit paper size has been selected.

• Cover Page –– provides options of when to print a cover page and the type of of cover 
page.

• Watermark –– provides options to print watermark text on the pages, for example 
Confidential if the document is of a sensitive nature.

Printing examples

The following printing instructions are examples only. Actual method of printing may differ from 
these examples as this depends on computer operating system, computer setup, and the printer 
being used. For more information on printing, see the Writer Guide.

Multiple pages on a single sheet
1) Open the Print dialog, see “Controlled printing” on page 5.

2) Select the printer to use if more than one printer is connected to the computer.

3) In Page Layout, select the number of pages to print per sheet of paper from the Pages 
per sheet drop-down list. The preview panel on the right shows how the pages will look 
on a printed sheet of paper.

4) In Page Layout, select how the multiple pages are printed on the sheet of paper from the
Order drop-down list.

5) If necessary, select Draw a border around each page to distinguish each page printed on 
a sheet of paper.

6) Click OK to print the document and close the Print dialog.
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Selecting pages

Individual page
1) Open the Print dialog, see “Controlled printing” on page 5.

2) Select the printer to use if more than one printer is connected to the computer.

3) In Ranges and Copies, select Pages and enter the page number of the page to print.

4) Click OK to print the individual pages and close the Print dialog.

Range of pages
1) Open the Print dialog, see “Controlled printing” on page 5.

2) Select the printer to use if more than one printer is connected to the computer.

3) In Ranges and Copies, select Pages and enter the page numbers of the pages to print 
using the format, for example, 1,3,7 or 2–5,7,9 for page number selection.

4) Click OK to print the pages and close the Print dialog.

Selection printing
1) Select the pages in the Pages panel in LibreOffice Draw.

2) Open the Print dialog, see “Controlled printing” on page 5.

3) Select the printer to use if more than one printer is connected to the computer.

4) In Ranges and Copies, select Selection and then select Odd and Even Pages, Even 
Pages, or Odd Pages from the drop-down list.

5) Click OK to print the pages and close the Print dialog.

Brochure printing
In Writer, Impress, and Draw, a document can be printed as a brochure (also known as booklet 
printing). The pages are arranged so that when the printed pages are folded in half, the pages 
are in the correct order to form a brochure or booklet.

Tip

Plan the document to make it look good when printed as a brochure. Choose 
appropriate margins, font sizes, and so on as the pages are normally printed at half 
size on a sheet of paper. Experiment to get the best document format to match the 
capabilities of the printer being used.

Simplex printer
1) Open the Print dialog, see “Controlled printing” on page 5.

2) Select the printer to use if more than one printer is connected to the computer.

3) In Printer, click Properties to open the properties dialog for the selected printer.

4) Make sure the printer is set to the same orientation (portrait or landscape) as specified in 
the page setup for the document. Usually the orientation does not matter, but it does for 
brochures.

5) Click OK to close the properties dialog and return to the Print dialog.

6) In Page Layout, select More, then select the Brochure option.

7) In Range and Copies, select Even pages or Odd pages from the Selection drop-down 
list.

8) Click OK to print the even or odd pages.
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9) Take the printed pages out of the printer and put back into the printer in the correct 
orientation to print on the blank side. This may require some testing to find out what the 
correct arrangement is for the selected printer.

10) If Even Pages was selected, now select Odd Pages in Range and Copies. If Odd Pages 
was selected, now select Even Pages in Range and Copies.

11) Click OK to finish printing the document as a brochure and close the Print dialog.

Duplex printer
1) Open the Print dialog, see “Controlled printing” on page 5.

2) Select the printer to use if more than one printer is connected to the computer.

3) In Printer, click Properties to open the properties dialog for the selected printer.

4) Make sure the printer is set to the same orientation (portrait or landscape) as specified in 
the page setup for the document. Usually the orientation does not matter, but it does for 
brochures.

5) Click OK to close the properties dialog and return to the Print dialog.

6) In Range and Copies, select More, then select Print on both sides (duplex long edge) 
from the Paper sides drop-down list. Actual options available for duplex printing depend 
on the printer model and the computer system being used.

7) In Page Layout, Select More, then select the Brochure option.

8) In Range and Copies, select the All Pages option.

9) Click OK to print the document as a brochure and close the Print dialog.

Black and white or grayscale printing

Printer settings
To print documents in black and white or grayscale on a color printer:

1) Open the Print dialog, see “Controlled printing” on page 5.

2) Select the printer to use if more than one printer is connected to the computer.

3) Click on LibreOffice Draw to open the printing options page for LibreOffice Draw.

4) In Color, select Grayscale or Black & white.

5) Click OK to print the document and close the Print dialog.

Note

Some color printers may only allow printing in color regardless of the settings 
selected. More details can be found in the information that came with the selected 
printer.

Tip

Grayscale is the best option for printing any colored text or graphics in a document 
on a monochrome printer. Colors printed in shades of gray give more detail. When 
printing color in black and white some of this detail maybe lost.
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Figure 7: Options LibreOffice Draw Print dialog

LibreOffice settings
To change the LibreOffice settings to print all colored text and graphics as grayscale:

1) Go to Tools > Options > LibreOffice Draw  > Print (macOS LibreOffice > Preferences
> LibreOffice Draw > Print) on the Menu bar to open the Options LibreOffice Draw Print 
dialog (Figure 7).

2) In Quality, select either the option Grayscale or Black & white.

3) Click OK to save the change and close the Options LibreOffice Draw Print dialog.

4) Print the document using one of the above procedures and the document is printed as 
grayscale or black and white.

Exporting

LibreOffice can export documents to PDF (Portable Document Format). This industry wide 
standard of file format is ideal for sending a file to be viewed on another computer using PDF 
viewing software.

Directly as PDF
To export the entire document using default PDF settings is as follows:

1) Click on Export Directly as PDF on the Standard toolbar, or got to File > Export As > 
Export Directly as PDF on the Menu bar.

2) Enter a file name and location for the PDF file and click on Save to export the file as PDF.

Note

Note that page range, image compression, or other printing options are not available 
when creating a PDF file using this method.
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Figure 8: PDF Options dialog

Controlling PDF content and quality
For more control over the content and quality of the resulting PDF, use the options available in 
the PDF Options dialog (Figure 8). For more information on available options, see the Getting 
Started Guide.

1) Go to File > Export As > Export as PDF on the Menu bar to open the PDF Options 
dialog.

2) Select the required options available in the General, Initial View, User Interface, Links, 
Security and Digital Signatures pages.

3) Click on Export and a file browser window opens.

4) Navigate to the location and enter a file name for the PDF being created.

5) Click on Save to export the file as PDF. The file browser window and the PDF Options 
dialog close.

Other formats
LibreOffice can export files in various formats, which are listed in the drop-down list of the file 
browser window. For more information on exporting graphics, see Chapter 6, Editing Pictures.

1) Go to File > Export on the Menu bar to open a file browser window.

2) Navigate to the directory where the drawing is going to be saved.

3) Specify a file name for the exported drawing in the Name text box.

4) Select the required file format from the drop-down list.

5) Click on Save to save the file and close the file browser window.

Note

The content of the exported file depends on the elements selected on the drawing. If 
no elements are selected, the entire drawing is exported.
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Figure 9: HTML Export dialog

Web pages
To export a multi-page Draw document as a series of web pages:

1) Go to File > Export on the Menu bar to open a file browser window.

2) Select HTML Document (Draw) (.html;.htm) as the file format and click on Save to open 
the HTML Export dialog (Figure 9).

3) Create a New Design or select an Existing design and click on Next.

4) Follow the prompts to create the web pages and save the drawing as an HTML file. For 
more information on how to create HTMl file, see the Getting Started Guide.

Emailing documents

LibreOffice provides several ways to send documents quickly and easily as an email attachment 
in ODF format (LibreOffice default format), or as a PDF. For more information, see the Getting 
Started Guide.

Note

Documents can only be sent from the LibreOffice menu if an email profile has been 
set up.

Open Document format
To email the current document in ODF format:

1) Go to File > Send > Email Document on the Menu bar. LibreOffice opens the default 
email program with the document attached to a new email.

2) In the email program, enter the recipient, subject, and message, then send the email.
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PDF format
To email the current document as a PDF file:

1) Go to File > Send > E-mail as PDF on the Menu bar. LibreOffice creates a PDF using 
the default PDF settings and then opens the email program with the PDF file attached to 
a new email.

2) In the email program, enter the recipient, subject, and message, then send the email.

Digital signatures

A digital signature is a mathematical scheme for verifying the authenticity of digital versions of 
drawings or documents.

To sign a drawing digitally, a personal key, also known as a certificate, is required. This personal 
key is stored on the computer being used as a combination of a private key, which must be kept 
secret, and a public key. These keys are added to a drawing when a digital signature is applied. 
A certificate is obtained from a certification authority, which may be a private company or a 
government institution.

When a digital signature is applied to a drawing, a checksum is computed from the drawing 
content plus the personal key being used. The checksum and public key are stored together with 
the drawing.

When the drawing is opened on another computer with a recent version of LibreOffice, the 
program computes the checksum again and compares it with the stored checksum. If both 
checksums are the same, the program opens the original, unchanged drawing.

In addition, the program can display the public key information from the certificate. This 
information can then be compared with the public key that is published on the web site of the 
certificate authority. Whenever the drawing is changed, this change breaks the digital signature.

For a more detailed description of how to obtain, use and manage a certificate and signature 
validation, see the Getting Started Guide and “Applying Digital Signatures” in the LibreOffice Help
(https://help.libreoffice.org/7.1/en-US/text/shared/guide/digitalsign_send.html?
&DbPAR=WRITER&System=UNIX).

Figure 10: Options LibreOffice Security dialog
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Figure 11: Security Options and Warnings dialog

Removing personal data

It maybe necessary to remove any personal data, versions, notes, hidden information, or 
recorded change from drawings before being distributed, or PDFs files created.

Setting security and warning options
1) In Tools > Options > LibreOffice > Security (macOS LibreOffice > Preferences > 

LibreOffice > Security), to open Options LibreOffice Security dialog (Figure 10).

2) Click on Options to open the Security Options and Warnings dialog (Figure 11).

3) Select the required options to allow LibreOffice to warn when drawings contain certain 
information and/or automatically remove personal information on saving.

4) Click OK to close the Security Options and Warnings dialog and save the option 
selection.

Removing personal data and drawing information
1) Go to File > Properties on the Menu bar to open the Properties dialog (Figure 12) for the

open drawing.

2) In the General page uncheck Apply user data.

3) Click on Reset Properties removing any information in the created and modified fields, 
deleting the modification and printing dates, resetting the editing time to zero, resetting 
the creation date to the current date and time, and resetting the version number to 1.

4) Click OK to save the changes and close the Properties dialog.

Removing version information
To remove version information from a drawing, use one of the following methods:

• Go to File > Versions on the Menu bar to open a dialog for the drawing, then select the 
versions from the list for deletion and click Delete. The dialog automatically closes.

• Go to File > Save As on the Menu bar and save the drawing with a different name.
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Figure 12: Properties dialog

Figure 13: Redaction 
toolbar

Redaction

Documents can be redacted to remove or hide any sensitive information allowing the selective 
disclosure of information in a document while keeping other parts of the document secret.

When a redacted document is exported to a new document, any redacted portions are removed 
and replaced by redaction blocks of pixels. This prevents any attempt to restore or copy the 
original contents. A redacted document is often exported in PDF format for publication or sharing.

Any documents that are redacted in LibreOffice Writer, Calc, or Impress are automatically 
transferred as a copy to LibreOffice Draw where the redaction is carried out.

Documents, spreadsheets, or presentations
1) Open the document to be redacted in Writer, Calc or Impress, then go to Tools > Redact 

on the Menu bar and the following happens:

– The document is copied, prepared and transferred to Draw as an untitled file.

– Draw opens with the untitled document displayed.

– The Redaction toolbar (Figure 13) automatically opens. If the Redaction toolbar is not 
displayed, go to View > Toolbars on the Menu bar in Draw and select Redaction.

2) Go to Tools > Redact on the Menu bar and select either Rectangle or Freeform, or click
on Rectangle Redaction or Freeform Redaction in the Redaction toolbar.

3) Draw the required shapes to redact the sensitive areas in the document. The redaction 
shape is gray allowing the sensitive areas in the document to be visible before they are 
redacted.

4) If necessary, click on Export Directly as PDF to make an in-redaction copy of the 
document as a PDF file. The sensitive information in the redacted areas can then be 
reviewed that it is correct before redaction is finalized.
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5) Go to Tools > Redact on the Menu bar and select either Redacted Export (White) or 
Redacted Export (Black), or click on Redacted Export (White) or Redacted Export 
(Black) in the Redaction toolbar. This opens a file browser window.

6) Navigate to the folder where the redact document is going to be saved and enter a name 
for the document, then click on Save to create the redacted PDF file.

– The gray redaction shapes are converted to white or black shapes and the document 
is exported as a PDF.

– There is no selectable text in the PDF file and any redacted content is non-existent.

Drawings
Open a drawing in Draw, then use Steps 2) thru 6) in “Documents, spreadsheets, or 
presentations” to create a redacted PDF copy of the drawing file.

Note

When a redacted document is exported as a new PDF file, any redacted portions are
removed from the new document and replaced by redaction blocks of pixels. This 
prevents any attempt to restore or copy the original contents.
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