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Introduction

Many requests for spreadsheet support are the result of using complicated formulas and
solutions to solve simple day-to-day problems. For more efficient and effective solutions, use the
pivot table, a tool for combining, comparing, and analyzing large amounts of data easily. Using
pivot tables, you can view different summaries of the source data, display the details of areas of
interest, and create reports, whether you are a beginner, an intermediate, or an advanced user.
In addition you can create a pivot chart to view a graphical representation of the data in a pivot
table.

Database preconditions

To work with a pivot table, you need a list of raw data, similar to a database table, consisting of
rows (data sets) and columns (data fields). The field names are in the first row above the list.

The data source could be an external file or database. For the simplest case, where data is
contained in a Calc spreadsheet, Calc offers sorting functions that do not require the pivot table.

For processing data in lists, Calc needs to know where in the spreadsheet the list is. The list can
be anywhere in the sheet, in any position. A spreadsheet can contain several unrelated lists.

Calc recognizes your lists automatically. It uses the following logic: Starting from the cell you
have selected (which must be within the list), Calc checks the surrounding cells in all four
directions (left, right, above, below). The border is recognized if the program discovers an empty
row or column, or if it hits the left or upper border of the spreadsheet. This means that the
described functions can only work correctly if there are no empty rows or columns in the list.
Avoid empty lines (for example for formatting). You can format the list by using cell formats.

OTip

To make sure that Calc automatically recognizes a list correctly, check that there are
no empty rows or empty columns within the list.

If you select more than one cell before creating a pivot table, then Calc’s automatic list
recognition logic is not applied. Instead, Calc assumes that the pivot table is to be created using
exactly the cells that you selected.

OTip

Always select only one cell before initiating creation of a pivot table. This allows Calc
to automatically determine the full scope of your data list.

A relatively common source of errors is to inadvertently declare a list by mistake and then to sort
that list. If you select multiple cells—for example, a whole column—then the sorting mixes up the
data that should be together in one row.

In addition to these formal aspects, the logical structure of the list is also very important.

Note

Calc lists must have the normal form; that is, they must have a simple linear
structure.

When entering the data, do not add outlines, groups, or summaries. Here are some mistakes
commonly made by inexperienced spreadsheet users:

* You made several unnecessary sheets; for example, a sheet for each group of articles. In
this case, analyses are only possible within each group.
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* In asales list, instead of only one column for the amount, you made a column for the
amounts for each employee. In this case, the system will have difficulty grouping data
from the various columns together. Thus, an analysis with the pivot table would no longer
be possible. All data must be entered into the same column for the pivot table to be able
to analyze it.

* You entered the amounts in chronological order. At the end of each month, you made a
sum total. In this case, sorting the list for different criteria is not possible because the
pivot table will treat the sum totals the same as any other value. Getting monthly results
is one of the very fast and easy features of the pivot table.

Data sources

The possible data sources for the pivot table are a Calc spreadsheet or an external data source
that is registered in LibreOffice.

Calc spreadsheet

Analyzing a list in a Calc spreadsheet is the simplest and most often used case. Lists might be
updated regularly or the data might be imported from a different application.

The list data might be entered directly into the spreadsheet or copied from another file or
application. You can also use a Web Page Query input filter to insert data from a HTML file, a
CSV file, a Calc spreadsheet, or a Microsoft Excel spreadsheet. See Chapter 10, Linking Data,
for more information.

The behavior of Calc while inserting data from a different application depends on the format of
the data. If the data is in a common spreadsheet format, it is copied directly into Calc. However, if
the data is in plain text format, the Text Import dialog appears after you select the file containing
the data; see Chapter 1, Introduction, for more more information about this dialog.

Registered data source

A registered data source is a connection to data held in a database outside of LibreOffice. When
using a registered data source, the data to be analyzed will not be saved in the spreadsheet;
Calc will always use the data from the original source. Calc is able to use many different data
sources in addition to databases that are created and maintained with LibreOffice Base. For
more information, see Chapter 10, Linking Data.

Using shortcuts

If you use pivot tables often in Calc, you might find the frequent use of the built-in menu paths
inconvenient.

In some cases built-in keyboard shortcuts are already defined; see Appendix A, Keyboard
Shortcuts. An example is the F12 function key, which groups a selected data range. In some
other cases, the built-in toolbars already provide relevant icons. An example is the Insert or Edit
Pivot Table icon on the Standard toolbar.

In addition to using the built-in keyboard shortcuts and toolbar icons, you can also define your
own. See Chapter 14, Setting up and Customizing, for instructions.

Creating a pivot table

If you want Calc to automatically determine the full extent of the raw data list, then select a single
cell within this list. If you want to explicitly define the extent of the raw data list, then select all
relevant cells.

With the cell (or cells) selected, create the pivot table by selecting Insert > Pivot Table on the
Menu bar, selecting Data > Pivot Table > Insert or Edit on the Menu bar, or clicking the Insert
or Edit Pivot Table icon on the Standard toolbar.
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Calc displays the Select Source dialog (Figure 1), where you can choose between using the
selected data cells, a range of cells that has already been named, or a data source that has

already been registered with LibreOffice.

Note

See Chapter 13, Calc as a Database, for more information about named ranges. See
Chapter 10, Linking Data, for more information about linking to registered data

sources.
ATLEST fx 7 = | salesValue
. : F 5
Date Category Region Employee

04/13/08 $498.00 Sailing Maorth Kurt
02/07/08 $1,383.00 Sailing South | Kurt
05/28/08 %4 65500 Tennis East Hans
04/20/08 $3,993.00 Sailing East Fritz
02/28/08 $3,377.00 Golf South  |Ute
01/27/08 $2,095.00 Sailing Morth Brigitte
02/16/08 $4,731.00 Sailing East Ute
04/15/08 $4.330.00 Tennis Sgrrk e
04/20/08 $3,664.00 Golf Sp >elect Source >
06/07/08 5769.00 Tennis We
02/29/08 $293.00 Sailing Ea .
04/06/08 33.705.00 Tennis No n;
06/19/08 $1.747 .00 Golf We . e
05/14/08 344900 Tennis W O Named range:
05/30/08 $1.795.00 Golf SD' 0 Data source registered in LibreCffice
02/28/08 $610.00 Sailing We
0&6/08/08 $1.625.00 Tennis Ea Help oK Cancel
05/12/08 $3,887.00 Sailing So
01/30/08 £2 45800 Tennis West  'Hans
05/09/08 34,369.00 Golf South  |Ute
03/15/08 $1.785.00 Golf East Hans

Figure 1: Select Source dialog

Click OK on the Select Source dialog to display the Pivot Table Layout dialog, which is described

in the next section.

The Pivot Table Layout dialog

The function of the pivot table is managed in two places: first, in the Pivot Table Layout dialog;
and second, through manipulations of the result in the spreadsheet. This section describes the
Pivot Table Layout dialog in detail.

aTip

To access the Pivot Table Layout dialog again after initial creation of a pivot table,
left-click in any cell of the pivot table. Then select Insert > Pivot Table on the Menu
bar, or select Data > Pivot Table > Insert or Edit on the Menu bar, or click the
Insert or Edit Pivot Table icon on the Standard toolbar, or right-click in any cell of
the pivot table and select the Properties option in the context menu.
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Basic layout
In the Pivot Table Layout dialog (Figure 2) are four areas that show the layout of the resulting
pivot table:

* Filters

* Column Fields

* Row Fields

» Data Fields

Beside these four areas is another area labeled Available Fields that contains the names of the
fields in the source data list. To choose a layout, drag and drop the fields from the Available
Fields area to the other four areas.

The Data Fields area must contain at least one field. Advanced users can use more than one
field here. For the fields in the Data Fields area, an aggregate function is used. For example, if
you move the Sales Value field into the Data Fields area, it initially appears there as Sum -
Sales Value.

Pivot Table Layout >
Filters: Available Fields:
Region Date
Sales Value
Category
Region
Ernployee
Column Fields:
Data
Row Fields: Data Fields:
Ermployee Sumn - Sales Value

Drag the [tems into the Desired Position

Options

Source and Destination

Help oK Cancel

Figure 2: Pivot Table Layout dialog
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Row and column fields indicate from which groups the result will be sorted. Often more than one
field is used at a time to get partial sums for rows or columns. The order of the fields gives the
order of the sums from overall to specific.

For example, if you drag Region and Employee into the Row Fields area, the sum will be
divided into the regions. Within the regions will be the listing for the different employees (Figure
3).

Sum - Sales Yalue Category [*] |
Region (= |Employee | *|Golf £ Column Fields:
East Brigitte $5,822
Fritz $15,172 Dat;'
Hans 55,3116
Kurt 59,707
Ute 55,954
MNarth Brigitte 53,814
Fritz 53,443
Hans $3.049 Row Fields: Data Fields:
Kurt £2.214 &g Surn - Sales Value
EiE - 36,221 Employee
South Brigitte 55,151
Fritz 523,290
Hans 34196
Kurt 511,681

Fields that are placed into the Filters area appear at the top of the resulting pivot table as a drop-
down list. The summary in the result takes into account only that part of the base data that you
have selected. For example, if you include Employee in the Filters area, you can filter the result
shown for each employee.

To move a field from an area, just drag it to a new area. To remove a field from the Filters,
Column Fields, Row Fields, or Data Fields areas, drag it to the Available Fields area.

ﬂTip

To rapidly move a selected field from one area of the Pivot Table Layout dialog to
another, press the Alt+letter on the keyboard that corresponds to the underlined letter
in the target area’s label.

Note

By default, Calc inserts a Data field into the Column Fields area. The Data field can
be moved between the Column Fields and Row Fields areas as required. Depending
on its position within the list of fields in its area, the Data field may lead to a button
labeled Data appearing in the results of the pivot table, affecting the layout of the
results. If you do not wish to use this facility, simply place the Data field at the bottom
of the list of fields in its area.

More options

To expand the Pivot Table Layout dialog and show more options, click the expansion symbol
(plus or triangle sign) adjacent to the Options and Source and Destination labels (Figure 4).

Ignore empty rows
If the source data is not in the recommended form, this option tells the pivot table to ignore

empty rows.
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=I Qptions
] lgnore empty rows
[] Total columns
[ Add filter

=l Source and Destination

Source

] Identify categories
Total rows
(] Enable drill to details

()] Selection
Destination
(®) Mew sheet

§'Sales List'.5AS1:5E5157

=]

() Selection

Figure 4: Expanded area of the Pivot Table Layout dialog

Identify categories

With this option selected, if the source data has missing entries in a list and does not meet
the recommended data structure (as in Figure 5 for example), the pivot table adds it to the
listed category above it. If this option is not chosen, then the pivot table inserts (empty).

L 8 | c |

1 |Produce Region Quantity
2 |Apples ltaly 6.2t
3 | Lake Constance 1921
4 California 361t
5 |Pears  faly 70t
] Lake Constance 220t

=
Figure 5: Example of data with missing
entries in Column A

The option Identify categories ensures that in this example rows 3 and 4 are included for
Apples and that row 6 is included for Pears (Figure 6).

Sum - Quantity  |Region |L|

Produce ¥ |California  Italy Lake Constance |Total Result
pples 36t 6.2t 192 ¢ 29.0

Pears 70t 220t 29.0

[Total Result 3.6 13.2t 41.2 58.0 4

Figure 6: Pivot table result with Identify categories selected

Without category recognition, the pivot table shows an (empty) category (Figure 7).

Sum - Quantity |Region Ed|

Produce  |California [taly Lake Constance |Total Result
Apples 62t 6.2
Pears 70t T.Da
[empty) 36t 412 ¢ 44.8
Total Result 3.6t 13.2 t 41.2 t 58.0 1

Figure 7: Pivot table result without Identify categories selected

Logically, the behavior with category recognition is better. A list showing missing entries is
also less useful, because you cannot use functions such as sorting or filtering.
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Total columns, Total rows
With these options you can decide if the pivot table shows an extra row with the sums of
each column, or if it adds on the very right a column with the sums of each row. In some
cases, an added total sum is meaningless, for example if the entries are accumulated or
the result of comparisons.

Add filter
Use this option to add or hide the cell labeled Filter above the pivot table results. This
conveniently provides additional filtering options within the pivot table. For more
information, see “Filtering” on page 27.

Note

The filtering provided through the Add filter option is independent of the filtering
provided by including fields in the Filters area of the Pivot Table Layout dialog.

Enable drill to details
With this option enabled, if you double-click on a single data cell in the pivot table result,
including a cell produced from Total columns or Total rows, a new sheet opens giving a
detailed listing of the individual entry. If you double-click on a cell in either a row or column
field area, then the Show Detail dialog opens (Figure 39). If this function is disabled, the
double-click will keep its usual edit function within a spreadsheet. For more information,
see “Drilling (showing details)” on page 26.

Source
The Selection field in this area shows the sheet name and the range of cells containing the
raw data for the pivot table. If the source spreadsheet contains any named ranges, these
can be selected through the Named range option.

Destination
The controls in this area define where the result will be shown.

Selecting New sheet adds a new sheet to the spreadsheet file and places the results there.
The new sheet is named using the format Pivot Table_sheetname_X; where X is the
number of the table created, 1 for first, 2 for second, and so on. For a sheet named Sales
List, the new sheet for the first pivot table produced would be named Pivot Table_Sales
List_1. Each new sheet is inserted next to the source sheet.

If the target spreadsheet contains any named ranges, these can be selected with the
Named range option.

The Selection field in this area shows the sheet name and the range of cells for the pivot
table’s results.

ﬂTip

To display the pivot table on the same sheet as the raw data, check the Selection
option in the Destination area, click the Shrink button to the right of the Selection
field, click at an appropriate cell in an empty area of the sheet, click the Expand
button, and click OK on the Pivot Table Layout dialog.

More settings for the fields: Field options

The options discussed in the previous section are valid for the pivot table in general. You can
also change settings for any field that is currently included in the pivot table layout. Change a
field’s settings by double-clicking that field within the Filters, Column Fields, Row Fields, or Data
Fields areas of the Pivot Table Layout dialog. Double-clicking a field within the Available Fields
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area has no effect. The options available for fields in the Data Fields area differ from those for
fields in the other three areas.

Options for data fields

Double-click a field in the Data Fields area of the Pivot Table Layout dialog to access the Data
Field dialog shown in Figure 8.

In the Data Field dialog, you can select the function to be used to accumulate the values from the
data source. While you often use the Sum function, other functions (like standard deviation or a
counting function) are also available. For example, the counting function can be useful for non-
numerical data fields.

Select the Show items without data option to include empty columns and rows in the results
table.

Click the expansion symbol (plus sign or triangle) to expand the Displayed value section of the
dialog.

Data Field e
Function

Surm ~
Count

Average

Median

Max

Min

Product

L ER L

[ Show items without data
Mame: Sales Value

=I Displayed value

Type:

Base field Difference from I:}

Base itere |70 Of

% difference from
Running total in
Help % of row Cancel
% of column
% of total
Index

Figure 8: Expanded dialog for a data field

In the Displayed value section, you can choose other possibilities for analysis using the
aggregate function. Depending on the setting for Type, you may have to choose definitions for
Base field and Base item.
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= Displayed value

Type: Difference from
Base field: |Employee
Base iterm:  |Brigitte

Figure 9: Example choices for Base
field and Base item

Table 1 below lists the possible types of displayed value and associated base field and base

item, together with notes on usage.

Table 1: Description of Displayed value options on the Data Field dialog

Type
Normal

Difference
from

% of

%
difference
from

Base field

Selection of a field
from the data
source of the pivot
table (for
example,
Employee).

Selection of a field
from the data
source of the pivot
table (for
example,
Employee)

Selection of a field
from the data
source of the pivot
table (for
example,
Employee)

Base item

Selection of an
element from the
selected base field
(for example,
Brigitte)

Selection of an
element from the
selected base field
(for example,
Brigitte)

Selection of an
element from the
selected base field
(for example,
Brigitte)

Analysis

Simple use of the chosen
aggregate function (for example,
Sum).

The result is the difference
between the result of the base field
and the base item (for example,
sales volume of the other
employees against the sales
volume of Brigitte; see Figure 10).

If previous item or next item is
specified as the Base item, the
reference value is the result for the
next visible member of the base
field, in the base field's sort order.

The result is a percentage ratio of
the value of the base field to the
base item (for example, sales
result of the other employees
relative to the sales result of
Brigitte; see Figure 11).

If previous item or next item is
specified as the Base item, the
reference value is the result for the
next visible member of the base
field, in the base field’s sort order.

From each result, its reference
value is subtracted, and the
difference is divided by the
reference value (for example, sales
of the other employees as relative
difference from the sales of
Brigitte; see Figure 12).

If previous item or next item is
specified as the Base item, the
reference value is the result for the
next visible member of the base
field, in the base field’s sort order.

The Pivot Table Layout dialog | 13



Type Base field Base item Analysis

Running Selection of a field — Each result is added to the sum of

total in from the data the results for preceding items in

source of the pivot the base field, in the base field's
table (for sort order, and the total sum is
example, Date) shown.
Results are always summed, even
if a different summary function was
used to get each result.

% of row — — The result is a percentage of the
value of the whole row (for
example, the row sum).

% of — — The result is a percentage of the

column total column value (for example,
the column sum).

% of total — — The result is a percentage of the
overall result (for example, the total
sum).

Index — — (Default result x total result) / (row
total x column total)

Sum - Sales Value |Data |

Category ~ |Brigitte Fritz Hans Kurt Ute

Golf 526,961 546,639 317,941 528,346 536,127
Sailing 524 422 $19.976 514,060 520,814 530,580
Tennis 7.7 536,638 $30.467 527,675 526,198
Total Result $69,104 $105,453 $62,468 $76,835 $94,905|
Sum - Sales Value |Data |

Category - |Brigitie Fritz Hans kurt Ute

(Golf 519,878 -55,020 1,385 59,166
Sailing -54 446 510,362 -53,608 56,158]
Tennis 520,917 512,746 59,954 510477
Total Result $36,349 -$6,636 §7,71 $25,801
Figure 10: Original pivot table (top) and a Difference from example (bottom)
Sum - Sales Value |Data |

Category - |Brigitie Fritz Hans kourt LUte

(Golf 100.00% 173.73% 66.54% 105.14% 134.00%
Sailing 100.00% 81.80% A7.57% 85.23% 125.21%
Tennis 100.00% 218.04% 171.93% 156.17% 159.12%
Total Result 100.00% 152.60% 90.40% 111.19% 137.34%
Figure 11: Example of a % of analysis

Sum - Sales Value |Data |

Category « |Brigitte Fritz Hans Kourt Ute

(Golf 73.73% -33.46% 514% 34.00%
Sailing -18.20% -42 43% -14.77% 25 21%
Tennis 118.04% 71.93% 56.17% 59.12%
Total Result 52.60% -9.60% 11.19% 37.34%

Figure 12: Example of % difference from analysis
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Options for row and column fields
Double-click a field in the Row or Column Fields areas of the Pivot Table Layout dialog to access
the Data Field dialog shown in Figure 13.

In the Data Field dialog for a row or column field, you can choose to show subtotals for each
category. Subtotals are deactivated by default. Subtotals are useful only if the values in one row
or column field can be divided into subtotals for another (sub)field.

Data Field *

] Show itermns without data

Mame: Region

Options... Cancel Help

Figure 13: Data Field dialog for a row or
column field

Some examples are shown in Figures 14, 15, and 16.

Sum - Sales Value |category [ =]

Reqion ¥ |Golf Sailing Tennis Total Result

East 541,971 522 484 $35,966 $100,421
Marth 518,741 522 468 $34,533 $75,742|
South 556,257 544 801 $34,258 $135,316
West 539,245 520,099 $37.942 $97,286
Total Result $156,214 $109,852 $142,699 $408,765(

Figure 14: No subdivision with only one row or column field
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Sum - Sales Value

Categony |L|

Region ¥ |Employee | * |Golf Sailing Tennis Total Result
East Brigitte $5,822 $2.135 54,872 $12,829|
Fritz 15,172 55,730 $12 455 $33,357
Hans $5,316 5909 $12.220 $18,44
Kurt 39,707 36,475 52417 518,59%
Ute 55,954 57,235 54,002 $17,191
Maorth Brigitte 33,814 510,151 $3,985 $17,95
Fritz 53,443 52,698 59,115 $15,256
Hans 53,049 3,008 55,361 $11,418
Kurt 52,214 3,485 510,499 $16,198
Ute 36,221 $3,126 $5,673 $14,92
South Brigitte 35,151 34,432 $9,58
Fritz 523,290 34,806 515,641 $43,737
Hans 34,196 59,263 53,858 $17,317
Kurt 511,681 57,270 514,759 $33,11
Ute $11,939 $19.030 $30,96
VWest Brigitte 512,174 57,704 58,864 $28,74
Fritz 54,934 56,742 51,427 $13,10
Hans $5,380 5880 59,028 $15,288
Kurt 34,744 53,684 $8,328
Ute 512,013 $1.189 518,623 $31,82
Total Result $156,214 $109,852 $142,699 $408,765]
Figure 15: Division of the regions for employees (two row fields) without subtotals
Sum - Sales Value Category [ ]
Region ¥ |Employee [+ |Golf Sailing Tennis Total Result
East Brigitte §5,822 $2.135 54,872 $12,829|
Fritz 15,172 55,730 512 455 $33,357
Hans 35,316 $909 12,220 $18,44
Kurt 559,707 36,475 52,417 $18,5
Ute $5,954 37,235 54,002 $17,191
[East Sum — Sales Value $41,971 $22,484 $35,966 $100,421
Maorth Brigitte 33,814 510,151 53,985 $17,950]
Fritz 3,443 2,698 59,115 $15,256
Hans 53,049 3,008 55,361 $11,418
Kurt 32,214 $3,485 $10,499 515,193|
Ute 36,221 53,126 $5,673 $14,92
INorth Sum — Sales Value $18,741 $22,468 $34,533 $75,742
South Brigitte 35,151 34,432 $9,583}
Fritz 523,290 34,806 515,641 $43,737
Hans 54,196 9,263 $3,858 17,317
Kurt 11,681 57,270 514,759 $33,71
Ute 511,939 $19.030 $30,96
South Sum — Sales Value $56,257 $44,801 $34,258 $135,316
VWest Brigitte $12.174 57,704 58,864 $28,74
Fritz 54,934 36,742 51,427 $13,10
Hans $5,380 880 59,028 $15,288
Kurt 34,744 33,684 $8,328
Ute $12.013 $1,189 518,623 $31,82
West Sum — Sales Value $39,245 $20,099 $37,942 $97,286
Total Result $156,214 $109,852 $142,699 $408,765]

Figure 16: Division of the regions for employees with subtotals (by region)
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To calculate subtotals that can also be used for the data fields (see above), select the Automatic
option in the Subtotals section of the Data Field dialog.

You can choose the type of subtotal to use by selecting User-defined and then clicking the type
of subtotal you want to calculate from the list. Functions in this list are only available when User-
defined is selected.

Normally, the pivot table does not show a row or column for categories that have no entries in the
underlying database. By choosing the Show items without data option, you can force these to
be displayed.

For illustration purposes, the data was manipulated in such a way that the employee Brigitte has
no sales values for the Golf category.

Employee Brigitte [ .|

Sum - Sales Value |cateqgory | =]

Region ¥ |Sailing Tennis Total Result

East 52135 54 872 $7,007

Marth 510,151 $3.985 $14,136

South 54 432 $4,43

[West 57,704 56,664 $16,568

Total Result $24,422 $17,721 $42,143)

Figure 17: Default setting
Employee Brigitte [ )
Sum - Sales Value |Category |L|
Region w |Golf Sailing Tennis Total Result
East 52134 54 872 §7,007
Morth 510,151 53,985 $14,136
South 54,432 $4,43

est 57.704 58,864 $16,568

Total Result $24,422 $17,721 $42,143]

Figure 18: Setting Show items without data

Click the Options button on the Data Field dialog to access the Data Field Options dialog (Figure
19). Use this dialog to specify additional options for fields in the Column and Row Fields areas of
the Pivot Table Layout dialog.

The following options are provided:

Sort by. Select the data field that you want to sort columns or rows by. Ascending sorts
the values from the lowest value to the highest value. If the selected field is the field for
which the dialog was opened, the items are sorted by name. If a data field was selected,
the items are sorted by the resultant value of the selected data field. Similarly
Descending sorts the values descending from the highest value to the lowest value.
Manual sorts values alphabetically.

Display Options. You can specify the display options for all row fields except for the last,
innermost row field. Select from the Layout drop-down list to select the layout mode for
the field in the list box. Select the Empty line after each item option to add an empty
row after the data for each item in the pivot table. Select or deselect the Repeat item
labels option as required.

Show Automatically. This feature displays the top or bottom nn items when you sort by
a specified field. Click the Show option to turn on the automatic show feature and enter
the maximum number of items that you want to show automatically. The From drop-down
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list selects to show the top or bottom items in the specified sort order. The Using field
drop-down list selects the data field by which to sort the data.

* Hide Items. Use these options to select the items to hide from the calculations.

* Hierarchy. Select the hierarchy to use, when the field has multiple hierarchies. The pivot
table must be based on external source data that contains data hierarchies. For the
majority of users, Calc does not provide multiple hierarchies for a single field and so this
option is normally grayed. If you use a pivot table data source extension, that extension
could define multiple hierarchies for some fields and then the option could become
available. See the documentation supplied with that extension for more details.

Data Field Options x
Sort by
(® Ascending
Ogescending
OManual
Display Options
Layout: |Tabu|ar layout ~

O Empty line after each itemn
O Bepeat itern labels

Show Automatically
] Shows 10 > | items
From

Using field

Hide Items

D R
[ sailing
[ Tennis

Hierarchy: |

Figure 19: Data Field Optibns dialog

Options for filter fields

The Data Field dialog for fields in the Filters area is the same as for fields in the Row and
Column Fields areas, even though it appears to be useless to have the same settings as
described for the row and column fields. With the flexibility of the pivot table, you can switch the
different fields between filters, columns, or rows. The fields keep the settings that you gave them.
The filter field has the same properties as a row or column field. These settings only take effect
when you use the field not as a filter field but as a row or column field.

Working with the results of the pivot table

The Pivot Table Layout dialog is very flexible and a pivot table can be totally restructured with
only a few mouse clicks.
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Changing the layout

The layout of the pivot table can be changed quickly and easily by using drag-and-drop. With the
Pivot Table Layout dialog open, fields can be dragged around from Row Fields, Column Fields,
Filters, and Data Fields areas to any position you want to put them, and then dropped. Unused
fields can also be added, and fields removed in error can be replaced by dragging and dropping
them into the positions required.

Some manipulation can also be carried out in the results view of the pivot table. Within the results
of the pivot table, drag one of the filter, column, or row fields to a different position. The cursor will
change shape from its starting shape (horizontal or vertical block on the arrow head) to the
opposite if moving to a different field, such as from row to column, where it can be dropped.

Sum - Salﬂ%ae [+]
Category * [Bri Fritz
Golf 526,961 $46.839
=ailing 24 422 319,976
Tennis 7721 538.638
Total Result $69,104 $105,453
Figure 20: Drag a column field - note the
cursor shape
Employee | = |Category | = |Sum - Sales Value
Brigitte Golf 526,961
Sailing $24 422
Tennis 517 721
Fritz Golf 546,839
Sailing $19.976
Tennis 538 635|
Hans Golf 17,941
Sailing $14,060)
Tennis 530 467
Kurt Golf 528,346
Sailing 520,814
Tennis 527 675
Ute Golf 536,127
Sailing $30,580
Tennis 528,198
Total Result $408,765|

Figure 21: Result of dragging column field
(see Figure 20)

ISum - Sales ValuegEmployee | =]

\% _— | = [Brigitte Fritz
Golf 526,961 546,839

Sailing $24 422 $19.976
Tennis 51771 535.638
Total Result $69,104 $105,453
Figure 22: Drag a row field - note the cursor
shape

You can remove a column, row, or filter field from the pivot table by clicking on it and dragging it
out of the table. The cursor changes to that shown in Figure 23. A field removed cannot be
recovered, without returning to the Pivot Table Layout dialog to replace it.
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//'rm

Sum - Sales Vdlue |Employee [*]

Cateqory © -+ |Erigitte Fritz

Golf 526,961 546,839
Sailing 524 422 519,976
Tennis 57721 538,638
Total Result $69,104 $105,453

Figure 23: Field dragged out of the pivot table

Grouping rows or columns of a pivot table

For many analyses or summaries, the categories have to be grouped. You can merge the results
in classes. You can only carry out grouping on an ungrouped pivot table.

After selecting the correct cell area, select Data > Group and Outline > Group on the Menu bar,
or press F12 on the keyboard. The type of values to be grouped is what mainly determines how
the grouping function works. You need to distinguish between scalar values, or other values,
such as text, that you want grouped.

Note

Before you can group, you have to produce a pivot table with ungrouped data. The
time needed for creating a pivot table depends mostly on the number of columns and
rows and not on the size of the basic data. Through grouping you can produce the
pivot table with a small number of rows and columns. The pivot table can contain a
lot of categories, depending on your data source.

To remove grouping again, click inside the group, then choose Data > Group and Outline >
uUngroup, or press Ctrl+F12.

Grouping of categories with scalar values

For grouping scalar values, select a single cell in the row or column of the category to be
grouped. Choose Data > Group and Outline > Group on the Menu bar or press F12 on the
keyboard; Calc displays the Grouping dialog shown in Figure 24.

You can define in which value range (Start / End) the grouping should take place. The default
setting is the whole range, from the smallest to the largest value. In the field Group by, you can
enter the class size, also known as the interval size.

Grouping et
Start

® Automatically

O Manually at:
End

® Automatically

O Manually at:
Group by

ho

Help OK Cancel

Figure 24: Grouping dialog with scalar
categories
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Figure 25 shows part of a pivot table created from a list containing speed measurements as a
function of time. This pivot table shows the count of km/h speed measurements in the raw data.

The pivot table in Figure 26 is based on the same raw data. However in this case the speed
measurements are grouped into intervals if 10 km/h.

km/h * [Count - time

30
31
32
33
34
35
36
37
38
39
40
41
42
43
Figure 25: Pivot table
without grouping

Lo e e = Il o B RS T S D ]

km/h w |Count - time

30-39 29
40-49 22
A0-59 23
F0-69 23
70-79 18
B0-89 23
50-99 18
100-109 27
110-1189 35
Total Result 218

Figure 26: Pivot table
with grouping

Grouping of categories with date / time values

For grouping date / time values, select a single cell in the row or column of the category to be
grouped. Choose Data > Group and Outline > Group on the Menu bar or press F12 on the
keyboard; Calc displays the Grouping dialog shown in Figure 27.

Grouping
Start
O] Autornatically
I::'Manuallg,r at: -
End
(® Automatically
(O Manually at: -
Group by
() Mumber of days: | ©
@) |ntervals: Dm
[ Minutes
[ Hours
[ Days
[ Months
[ Quarters
[ Vears
Help oK

X

Cancel

Figure 27: Grouping dialog for date/time

categories

You can define in which value range (Start / End) the grouping should take place. The default
setting is the whole range, from the smallest to the largest value. In the field Group by, you can

Working with the results of the pivot table | 21



enter the class size, also known as the interval size. In this case you can select one of the
predefined time intervals (Seconds, Minutes, Hours, Days, Months, Quarters, or Years) as an
alternative to explicitly specifying a time interval in days.

Figure 28 shows a pivot table configured to show the daily sales in the North region.

Sum - Sales Value |Region |+
Date  |Morth Total Result
01/02/08 3410
01/15/08 31,858
01/17/08 34 842
01/25/08 34 263
01/27/08 52,095
01/30/08 31,260
02/02/08 5734
02/06/08 53,443
02/13/08 3204
03/03/08 53,984
03/06/08 51,379
03/18/08 53,814
03/20/08 3918
04/02/08 51,385
04/03/08 3576
04/06/08 53,704
04/07/08 53,126
04/13/08 5498
04/19/08 34101
D4/22/08 54276
D4/24/08 53,005
04/25/08 52, 564
N&5/M15/08 3520
05/30/08 32,214
0&6M10/08 54,839
NG6M5/08 53,404
06/20/08 53,617
N6/22/08 52,987
NG/28/08 53,049
06/29/08 52 698 $2,698
Total Result $75,742 $75,742|

Figure 28: Pivot table without grouping

Figure 29 shows the same data but configured to show the monthly sales in the North region.

Sum - Sales Region [ ]
Date w |Marth Total Result
an 514 728 $14,728]
Feb 54 381 $4,381
Mar 510,096 $10,096
pr 523,209 $23,2
May 52734 $2,?2§|
Llun 520 594 $20,59
Total Result $75,742 $75,742|

Figure 29: Pivot table with grouping

Grouping without automatic creation of intervals

It is not possible to create intervals for some categories (for example, those containing text
fields). However, for such fields it is possible to define which values are put together in one

group.
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For grouping of these categories, select in the results of the pivot table all the individual field
values that you want to put together in the group. With more than one cell selected, choose Data
> Group and Outline > Group on the Menu bar, or press F12 on the keyboard, to group the
selected cells.

ﬂTip

You can select several non-contiguous cells by pressing and holding the Control key
while clicking with the mouse.

Given the input data shown in Figure 30, create a pivot table with Department in the Row Fields
area and Sum - Sick days in the Data Fields area. The result should be as shown in Figure 31.

Last name First name Department Sick days

Meier Hans Sales !
Muller Karin Accounting !
Schuster Joset Purchasing 3
Huber Ema Purchasing 3
Aigner Hermann Production 7
Schulze Josef Production fi
Schroder Gerhard Production 4
Forster Inge Assembly 4
Meier Gunter Assembly 1
Gabriel Juri Warehouse 0
Schumacher  Helmut Warehouse 5

Figure 30: Database with text categories

Department | ™ |Sum - Sick days
Accounting
Assembly
Production 1
Purchasing
Sales
[Warehouse
Total Result
Figure 31: Pivot table with text
categories

LR

EU"H\J

In the results of the pivot table select Accounting, Purchasing, and Sales in the Department
column. Select Data > Group and Outline > Group on the Menu bar or press F12 on the
keyboard. The pivot table result updates to reflect the new group, as shown in Figure 32.

Department2| * |Department | *|Sum - Sick days

ssembly Assembly 5

Groupl Accounting 7

Purchasing &

Sales 7

\Production Production 15§

[Warehouse \Warehouse 5

Total Result 48]

Figure 32: Summary of single categories in one
group

In the updated pivot table result, select Assembly, Production, and Warehouse in the Department
column. Select Data > Group and Outline > Group on the Menu bar or press F12 on the
keyboard. The pivot table updates again to reflect the new group, as shown in Figure 33.

Working with the results of the pivot table | 23



You can change the default names for the groups and the newly created group field by editing
the name in the input field (for example changing Group2 to Technical). The pivot table will
remember these settings, even if you change the layout later on.

Department2| * |Department | *|Sum - Sick days
Groupl Accounting 7
Purchasing &5
Sales 7
IGroup2 Assembly 5
Production 13
\Warehouse 5
Total Result 48]

Figure 33: Grouping finished

To add partial sums for the groups, right-click the results of the pivot table and select the
Properties option. Double-click the Department2 entry in the Row Fields area and select the
Automatic option on the Data Field dialog (Figure 13). Click the two OK buttons and the pivot
table is updated to include the partial sums for the groups, as shown in Figure 34.

Department2| ¥ |Department | ¥ |Sum - Sick days
Groupl Accounting 7
Purchasing &
Sales 7
{Groupl Result 20
Technical Assembly 5
Production 13
\Warehouse 5
Technical Result 28]
Total Result 4g]

Figure 34: Renamed group and partial results

If it is not enabled already, select the Enable drill to details option on the Pivot Table Layout
dialog. Double-click the Group 1 and Technical entries in the Department2 column to
collapse/expand the group entries (for example, Figure 35 shows both groups collapsed).

Department2| ¥ |Sum - Sick days |
Groupl 23
Technical 2
Total Result 48}
Figure 35: Reduced to the new
groups

Note

A well-structured database makes manual sorting within the pivot table obsolete. In
the example shown, you could add another column with the name Department, that
has the correct entry for each person based on whether the employee’s department
belongs to the group Office or Technical. The mapping for this (1:n relationship) can
be done easily with the VLOOKUP() function.

Sorting the result

The results of a pivot table are by default sorted so that categories in columns and rows are
presented in ascending order. There are three ways to change the sorting order:

* Select a sort order from the drop-down menu on a column’s heading.
» Sort manually by using drag and drop.
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* Select a sort order through the Data Field Options dialog for the appropriate row or
column field (Figure 19).

Select sort order from drop-down menus on each column heading
The simplest way to sort entries is to click the arrow on the right side of the column heading for a
row or column field, and select one of the three sorting options (Figure 36):

* Sort Ascending

* Sort Descending

» Custom Sort

Emploves |"

Sort Ascending
Sort Descending
Customn Sort r

Eearch items

[ Fritz
[] Hans
[ Kurt
[ Ute

b Al

Cancel

Figure 36: Column sorting and
filtering dialog

Selecting the Custom Sort option sorts according to one of the predefined custom sorts defined
in Tools > Options > LibreOffice Calc > Sort Lists. See Chapter 2, Entering, Editing, and
Formatting Data for more information about creating and using sort lists.

This dialog also provides facilities for simple filtering of the data in the pivot table. Check the
required individual boxes to select the data displayed in the results of the pivot table. Options are
provided to show all, show only the current item, or hide only the current item. Click OK to
activate the selected filtering. Once filtering has been carried out, the color of the arrow changes
from black to blue, and a small square of matching color is added to the bottom right of the arrow
button (Figure 37).

Sum - Sales Value exeqory [

Region +|Employke [w]GdIF Sailing Tennis Total Result

East Brigitte I $5822 52135 54,872 $12,829
[Morth Brigitte 53,814 510,151 $3,985 $17,950
South Brigitte 55,151 54,432 $9,583)
[West Brigitte $12,174 7,704 $6,864 $28,742|
Total Result $26,961 $24,422 $17.721 $69,104]

Figure 37: Arrow color change and indicator square on column heading
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Sort manually by using drag and drop

You can change the order within the categories by moving the cells with the category values in
the results of the pivot table. The dragged cell is inserted above the cell on which you drop it.

Be aware that in Calc, a cell must be selected, it is not enough that the cursor is in the cell. The
background of a selected cell is marked with a different color. To mark a single cell do one of the
following:

¢ Click, then Shift+click the cell.

* Press the mouse button, drag a range across two cells, do not release the mouse button,
and then drag back to the first cell. Release the mouse button. You can now move the
individual cell by drag and drop.

To select several cells, mark one cell with no extra key pressed, then press the Shift or Ctrl key
while clicking in other cells.

Sort automatically

To sort automatically, right-click within the pivot table and choose Properties. This will open the
Pivot Table Layout dialog (Figure 2). Double-click the row or column field you want to sort. In the
Data Field dialog which opens (Figure 13), click Options to display the Data Field Options dialog
(Figure 19).

For Sort by, choose either Ascending, Descending, or Manual. If the selected field is the field
for which the dialog was opened, the items are sorted by name. If a data field was selected, the
items are sorted by the resultant value of the selected data field. Ascending sorts the values
from the lowest value to the highest value. Similarly Descending sorts the values descending
from the highest value to the lowest value. Manual sorts values alphabetically.

Drilling (showing details)

Use drilling to show the related detailed data for a single, compressed value in the pivot table
result. This facility is available only if you selected the Enable drill to details option on the Pivot
Table Layout dialog.

To activate a drill, double-click on the cell or choose Data > Group and Outline > Show Details.
There are two possibilities:

¢ The active cell is a row or column field. In this case, drill means an additional breakdown
into the categories of another field. For example, double-click on the cell with the value
Golf. In this instance the values that are aggregated within Golf can be subdivided using
another field.

Sum - Sales Value |Region| ]

Category w |East Morth South Wiast Total Result
Golf $41,971 518,741 556,257 539,245 $156,21

Sailing $22.484 522468 544,801 520,099 $1I}9,B§§|
Tennis $35.,966 $34.533 §34.258 §37.942 $142,6

Total Result $100,421 $75,742 $135,316 $97,286 $408,765]

Figure 38: Before the drill down for Golf

The Show Detail dialog appears allowing you to select the field to use for further
subdivision. In this example, Employee.
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Show Detail hod

Choose the field containing the detail you want to show

Date
Sales Value

OK Cancel Help

Figure 39: Selecting the field for the

subdivision
Sum - Sales Value Regio] ¥ |
Category ¥ |Employ = |East Morth South West Total Result
(Solf Brigitte 55,822 $3.814 35141 312174 $26,961
Fritz 515172 53,443 523,290 34,934 546,839
Hans 35,316 $3.049 54,196 35,380 $17,941
Kurt 9,707 32,214 511,681 34,744 528,346
Ute 356,954 $6,221 511,839 312,013 $36,127
Sailing $22 484 522 468 544 801 520,099 $109,852]
T ennis $35. 966 §34 533 534 258 537,942 $142,599|
Total Result $100,421  $75,742 $135,316 $97,286 $408,765|

Figure 40: After the drill down

To hide the details again, double-click on the cell Golf or choose Data > Group and
Outline > Hide Details.

The pivot table remembers your selection (in our example the field Employee) by adding
and hiding the selected field, so that for the next drill down for a field in the Category
column the dialog does not appear. To remove the selection Employee, open the Pivot
Table Layout dialog and delete the unwanted selection in the Row or Column Fields area.

* The active cell is a data field. In this case, drill down results in a listing of all data entries
of the data source that aggregate to this value.

In our example, if we double-click on the cell with the value $18,741 from Figure 38, we
would have a new list of all data sets that are included in this value. This list is displayed
in a new sheet.

F12 vl fx 2 =
A | B | C D 3

1 |Date Sales Value Category Region Employee
| 2 | 02/06/08 $3,443 Golf Marth Fritz
| 3 | 03M18/08 $3,814 Golf Marth Brigitte
4 | 01M17/08 $4,842 Golf Marth Ute
| 5 | 06/28/08 $3,049 Golf Marth Hans
6 | 03/06/08 $1,379 Golf Marth Ute

7 05/30/08 $2,214 Golf Marth Kurt

Figure 41: New sheet after the drill down for a value in a data field

Filtering

To limit the pivot table analysis to a subset of the information that is contained in the data basis,
you can filter the pivot table results.
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Note

An autofilter or default filter used on the sheet containing the raw data has no effect
on the pivot table analysis process. The pivot table always uses the complete list that
was selected when it was started.

To do this, click the Filter button at the top left above the results, or right-click in the results and
select Filter in the context menu.

Note

The Filter button is available only if the Add filter option on the Pivot Table Layout
dialog is selected.

=~ & | ¢ | o | & | ¢ | & |

1] [Filter

2

3 |Sum - Sales HEmployee | *]

4 |Region  |Brigitte Fritz Hans Kurt Ute Total Result
_ 5 |East 312,829 $33.357 318,445 318,599 7.1 $100,421

6 |Morth 317,950 315,256 311,418 316,198 314,920 $75,742

7 |South 59,583 43,737 7317 $33.710 530,969 $135,316

8 |West 528,742 $13.103 315,288 58,328 $31.825 $97,286

3 |Total Result $69,104 $105,453 $62.468 $76,835 $94.905 $408.765{

Figure 42: Filter button in the upper left area of the pivot table

In the Filter dialog (Figure 43), you can define up to three filter options that are used in the same
way as Calc’s default filter. The controls in the Options section of this dialog are similar to the
equivalent controls on Calc’s Standard Filter dialog — see Chapter 2, Entering, Editing, and
Formatting Data for more information.

Filter >

Filter Criteria

Field name Condition

Operator

Yalue

- none - i

Dgasr: sensitive

O Regular expressions
[ Mo duplications
Cancel

Figure 43: Dialog for defining the filter

Help

The data presented in a pivot table can also be filtered using the drop-downs on the right hand
side of column headings or by using filter fields. Filtering through column headings is described in
“Select sort order from drop-down menus on each column heading” on page 25.

Filter fields (that is, fields that you placed in the Filters area of the Pivot Table Layout dialog) are
another practical way to filter the results of the pivot table. The advantage is that the filtering
criteria used are clearly visible. Click the arrow on the right side of the filter field button to access
the associated filtering dialog (Figure 44).
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Employee - all - v|

Sum - Sales ¥ | ocarch itermns

Region 2 — 3 Total Result
East 535 966]  $100,421
North B Fritz 534,533 $75,742
South HE"“ 534,258)  $135,316
West fart 537,942 $97,286
Total Result ¢ 142,699 __ $408,765

=1 an

Cancel
Figure 44: Filter field filiering dialog

The text adjacent to a filter field button indicates the filtering status, that is “- all -” when nothing is
filtered, “- multiple -” when multiple but not all items are filtered, or the value when only that value
is not filtered.

Updating (refreshing) changed values

After you have created the pivot table, changes in the source data do not cause an automatic
update in the resulting table. You must update (refresh) the pivot table manually after changing
any of the underlying data values.

Changes in the source data could appear in two ways:

* The content of existing data sets has been changed.
For example, you might have changed a sales value. To update the pivot table, left-click
in the results area and choose Data > Pivot Table > Refresh on the Menu bar, or right-
click in the results area and choose Refresh in the context menu.

* You have added or deleted data sets in the original list.
In this case the change means that the pivot table has to use a different area of the
spreadsheet for its analysis. If a simple addition to the list was made (for example, a new
sale from a different employee was inserted), it is possible to update the pivot table by
changing the range in the Selection field in the Source area of the Pivot Table Layout
dialog. Fundamental changes to the data set collection means you must redo the pivot
table from the beginning.

Cell formatting

The cells in the results area of the pivot table are automatically formatted by Calc. You can
change this formatting using all the tools in Calc. However if you make any change in the design
of the pivot table using direct formatting, the formatting will return to that applied automatically by
Calc when the table is next refreshed.

On creating a pivot table, six standard cell styles are added to the list of styles in the document if
they are not included already. Each of these styles is applied to part of the pivot table. You can
customize these pivot table styles. The pivot table styles are:

* Pivot Table Category
« Pivot Table Corner
e Pivot Table Field
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* Pivot Table Result
* Pivot Table Title
¢ Pivot Table Value

OTip

Use the pivot table styles to make sure that the format of your pivot table is not
unexpectedly changed during updates and that all pivot tables in your document
have the same appearance.

For the number format in the data field, Calc uses the number format that is used in the
corresponding cell in the source list. In most cases, this is useful (for example, if the values are in
the currency format, then the corresponding cell in the result area is also formatted as currency).
However, if the result is a fraction or a percentage, the pivot table does not recognize that this
might be a problem; such results must either be without a unit or be displayed as a percentage.
Although you can correct the number format manually, the correction stays in effect only until the
next update.

Deleting a pivot table

To delete a pivot table, left-click in any cell of the pivot table and select Data > Pivot Table >
Delete on the Menu bar, or right-click in any cell of the pivot table and select Delete in the
context menu.

Caution

If you delete a pivot table with an associated pivot chart, the pivot chart is also
deleted. Calc opens a dialog box to confirm the pivot chart deletion.

Using pivot table results elsewhere

The problem

Normally, you create a reference to a value by entering the address of the cell that contains the
value. For example, the formula =C6*2 creates a reference to cell C6 and returns the doubled
value. If this cell is located in the results area of the pivot table, it contains the result that was
calculated by referencing specific categories of the row and column fields. In Figure 45, the cell
C6 contains the sum of the sales values of the employee Hans in the category Sailing. The
formula in the cell C12 uses this value.

12 vl fx ¥ = ||=c6=2
A | 5 . o E
1 [Filter

2

3 [Sum - Sales Value |cateqory [ =]

4 |Employee - |Golf Sailing Tennis Total Result
__ 5 |Brigitte 526,961 $24,422 17,721 $69,104)
& |Hans 517.941 $14,060 $30,467 $62,468
7 Kurt 525,346 520,814 527,675 $76,835

8 |Ute $36,127 $30,580 $28,198 $94,905

9 [Total Result $109,375 $89,876 $104,061 $303,312)
10 |
11
2

Figure 45: Formula reference to a cell of the pivot table
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If the underlying data or the layout of the pivot table changes, then you must take into account
that the sales value for Hans in the Sailing category might appear in a different cell. Your formula
still references the cell C6 and therefore uses a wrong value. The correct value is in a different
location. For example, in Figure 46, the location is now C7.

12 vl fx ¥ = ||=c2
A | 5 s 0 i

1 |Filter

2

3 |Sum - Sales Value |Category Ill

4 |Employee w |Galf Sailing Tennis Total Result
_ 5 |Brigitte 526,961 524,422 517,721 $69,104)
_ 6 |Fritz 546,839 519,976 538,638 $105,453
_ 7 Hans $17.941 $14,060 530,467 $62,468
8 |Kur 528,346 $20,814 527,675 $76,835
g |Ute 536,127 530,580 528,198 $94,905
10 [Total Result $156,214 $109,852 $142,699 $408,765
il
i |

Figure 46: The value that you really want to use can be found
now in a different location

The solution: Function GETPIVOTDATA()

Use the function GETPIVOTDATA() to have a reference to a value inside the pivot table by using
the specific identifying categories for this value. This function can be used with formulas in Calc if
you want to reuse the results from the pivot table elsewhere in your spreadsheet.

Syntax
The syntax has two variations:
GETPIVOTDATA(Target Field; Pivot Table[; Field 1; Item 1][;
[Field 126; Item 126]])
or
GETPIVOTDATA(Pivot Table; Constraints)

The square brackets in the first variation surround optional arguments.

First syntax variation

The Target Field specifies which data field of the pivot table is used within the function. If your
pivot table has only one data field, this entry is ignored, but you must enter it anyway.

If your pivot table has more than one data field, then you have to enter the field name from the
underlying data source (for example “Sales Value”) or the field name of the data field itself (for
example “Sum — Sales Value”).

The argument Pivot Table specifies the pivot table that you want to use. It is possible that your
document contains more than one pivot table. Enter here a cell reference that is inside the area
of your pivot table. It might be a good idea to always use the upper left corner cell of your pivot
table, so that you can be sure that the cell will always be within your pivot table, even if the layout
changes.

Example: GETPIVOTDATA("Sales Value",Al)

If you enter only the first two arguments, then the function returns the total result of the pivot table
(“Sum — Sales Value” entered as the field, will return a value of 408,765).

You can add more arguments as pairs with Field name and Element to retrieve specific partial
sums. In the example in Figure 47, where we want to get the partial sum of Hans for Sailing, the
formula in cell C12 would look like this:
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=GETPIVOTDATA("Sales
Value", A1, "Employee", "Hans", "Category", "Sailing")

12 s fx E — | =GETPIVOTDATA("Sales Value" A1, "Employee”, "Hans","Category”, "Sailing”)
A | 5 O 0 | e | F | 6 |

1 |Filter

2

3 |Sum - Sales Value |Category |L|

4 |Employee ¥ |Golf Sailing Tennis Total Result
5 |Brigitte 526,961 $24 422 17,7 $69,104
& [|Fntz 346,839 519,976 538,638 $105,453]
7 Hans 317,941 $14,060 $30,467 $62,468
.8 Kurt 528,346 $20,814 527 675 $76,835

9 |Ute $36,127 $30,580 $28,198 $94,905

10 [Total Result $156,214 $109,852 $142,699 $408,765

1A

Figure 47: First syntax variation

Second syntax variation

The argument Pivot Table has to be given in the same way as for the first syntax variation.
For the Constraints, enter a list separated by spaces to specify the value you want from the
pivot table. This list must contain the name of the data field, if there is more than one data field;

otherwise it is not required. To select a specific partial result, add more entries in the form of Field
name[Element].

In the example in Figure 48, where we want to get the partial sum of Hans for Sailing, the formula
in cell C12 would look like this:

=GETPIVOTDATA(A1l, "Sales Value Employee[Hans] Category[Sailing]")

12 i fx Z — | =GETPIVOTDATA(AT, "Sales Value Employee[Hans] Category[Sailing]")
A | 8 e o | e [ F [
1 |Filter
2
3 |Sum - Sales Value |category [ ]
4 |Employee ¥ |Golf Sailing Tennis Total Result
_ 5 |Brigitte 526,961 524 422 v $69,10
6 |Fntz 46,839 $19.,976 $38,638 $105,45
7 |Hans 517,941 514,060 530,467 $62,468
8 |Kurt $28,346 520,814 327,675 $76,83
3 |Ute $36,127 530,580 328,198 $94,90
10 [Total Result $156,214 $109,852 $142,699 $408,765|
11

Figure 48: Second syntax variation

When working with data sets containing date information, you must take care if you use the date
information in the GETPIVOTDATA() function. The function will only recognize the date entry if it
is entered into the formula in exactly the same way that it appears in the data set from which the
pivot table is produced. In the example of Figure 49, an error is returned when the date format
does not match that of the data. Only with the correct format is the result returned.
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um - Cost Date -
MName Fhone numbdq ~ |26/01/2010 24/02/2010  |Total Result
lones 12345678821 0.84 1.0928 1.832
12345675822 7.816 1.4812 9.29?;
Jones Sum - Cost 8.656 2.574 11.23'
=mith 12345678911 1.0038 3.7265 4.?3Dj
12345678812 15.811 4. 4125 20.323
Smith Sum - Cost 16.9148 8.138 EE.DEBEI
Total Result 25.5708 10.713 36.283
Fesult Formula
#REF! =GETPIVOTDATA$AS2."Date[26/01/10]")
25.5708 =GETFIVOTDATAISAS2."Date[26/01/2010]")

Figure 49: Error produced if date information is not entered correctly

Using pivot charts

Introduction

A pivot table is a powerful tool to reorganize, manipulate and summarize data. A pivot chart
provides a visual representation of the information in a pivot table. You can create a pivot chart
from the output of a pivot table and, if the pivot table gets changed, so does the pivot chart.

Pivot charts are a special case of the more general Calc charts described in Chapter 3, Creating
Charts and Graphs. The main differences between pivot charts and other charts in Calc are as
follows:

» Apivot chart tracks the changes in the data issued from a pivot table and Calc
automatically adjusts the data series and data range of the pivot chart accordingly.

* Pivot chart buttons are provided on pivot charts. These buttons are unique to pivot charts
and are not provided on Calc’s normal charts. An important purpose of the buttons is to
represent the layout of the underlying pivot table and they show the pivot table’s fields.
Buttons representing the filter fields (if present) are provided at the top of the pivot chart.
Buttons representing the row fields are provided at the bottom of the pivot chart. Buttons
representing the column fields are stacked in the legend at the right of the pivot chart.
You can also use pivot chart buttons to filter the data displayed in the pivot chart.
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Pivot Table

Filter
Eranch |— all - EI
Data |
Car model ¥ |Sum - Show Room  Sum - Used Sum - Repair Shop
Model 01 52 36 1
Model 02 60 41 4
Model 03 21 47
Model 04 55 34
Model 05 38 43 1
Model 06 36 43 42
Model O7 20 55 31
[Total Result 291 304 268]
Pivot Chart
Branch| - all - v
Car Inventory
December 2017
70
Data
60
50 B Sum - Show Room
E 433 m Sum - Used
o 20 Sum - Repair Shop
10
0
Model 01 Model 02 Model 03Model (04 Model 05Model 06 Model 07
Models
Car model v

Figure 50: Sample pivot chart and associated pivot table

Creating a pivot chart

To create a pivot chart, click inside the pivot table and select Insert > Chart on the Menu bar or
click the Insert Chart icon on the Standard toolbar.

Calc automatically detects the pivot table and opens the Chart Wizard. Through the Chart Wizard
you can select the chart type and chart elements for the pivot chart. The wizard is similar to the
corresponding wizard for normal charts but for pivot charts, the steps to define data range and
data series are disabled.

The first step in the wizard is to select the chart type and the same options are available as for a
normal chart (Figure 51).
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Chart Wizard

2. Data Range

3. Data Series

4, Chart Elements

Help

Choose a Chart Type

Pie
Area
Line
-7 WY (Scatter)
Bubble
)\ Met

E Bar

Stock
Colurnn and Line

< Back

[ 13D Look

Shape

ylinder
one
wramid

=
L=
—
L=
P

Mext =

Finish

Cancel

Figure 51: Select the chart type through the Chart Wizard when creating a pivot chart

The second step is to select the chart elements and these are similar to those for normal charts

(Figure 52).

Chart Wizard

Steps

1. Chart Type

2.Data Range

3.Data Series

Title
Subtitle
X axis
Y axis

£ axis

Display Grids

[ ¥ axis Y axis

Choose Titles, Legend, and Grid Settings

Z axis

*

Display legend

O Left
(®) Right
O Top
Dﬂuttcum

Figure 52: Enter chart elements through the Chart Wizard when creating a pivot chart

Click Finish to close the wizard and create the pivot chart.

Editing a pivot chart

After you have created a pivot chart, you may find that you would like to move it, change its size
or improve its appearance. Calc provides tools for changing the chart type, chart elements, fonts,
colors, and many other options. The facilities provided for pivot charts are the same as those
available for normal charts; see Chapter 3, Creating Charts and Graphs.

Updating a pivot chart

If the source data of the pivot table changes, refresh the pivot table and the pivot chart is also
updated accordingly. To refresh the pivot table (and thus the pivot chart), click in any cell within
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the pivot table and select Data > Pivot Table > Refresh on the Menu bar or select Refresh in
the context menu.

Filtering a pivot chart
Use filters to remove unwanted data from a pivot chart.

All filters applied to a pivot table affect any linked pivot chart equally, since the table and chart
show exactly the same data. The various pivot table filtering mechanisms are described in
“Filtering” on page 27.

Pivot chart buttons include a down arrow to indicate that there is an associated pop-up action. If
any filtering is applied, then this arrow turns from black to blue. Pivot chart buttons become
operational when you double-click on the chart and a gray frame appears around the chart. This
action puts the pivot chart into edit mode.

Click a filter field button located at the top of a pivot chart to access a filtering dialog similar to
that shown in Figure 44. Change the filtering applied to the pivot table and pivot chart through
this dialog. The right-hand section of the button’s legend indicates the filtering status, that is “- all
-" when nothing is filtered, “- multiple -” when multiple but not all items are filtered, or the value
when only that value is not filtered.

Buttons located at the bottom and right of a pivot chart that include a downward pointing arrow
provide access to a sorting and filtering dialog similar to the shown in Figure 36. Change the
sorting and filtering applied to the pivot table and pivot chart through this dialog.

Branch | - multiple - hd
Car Inventory
December 2017
60 Data
50
40 B Sum - Show Room
E 30 ® Sum - Used
o 20 Sum - Repair Shop
0

Model 02 Model 04 Model 05 Model 06 Model OF
Models

Car model v

Figure 53: Filtering applied to filter and row fields

Deleting a pivot chart

To delete a pivot chart, select the chart and press Del on the keyboard.

Note

When you delete a pivot chart, the associated pivot table is not affected.
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Caution

If you delete a pivot table with an associated pivot chart, the pivot chart is also
deleted. Calc opens a dialog box to confirm the pivot table deletion.
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