Community

™ LibreOffice o &

Writer Guide 7.3

Chapter 1,
Introducing Writer



Copyright

This document is Copyright © 2022 by the LibreOffice Documentation Team. Contributors are
listed below. You may distribute it and/or modify it under the terms of either the GNU General
Public License (https://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative
Commons Attribution License (https://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors
To this edition
Jean Hollis Weber Kees Kriek

To previous editions

Toni Blackwelder Kees Kriek Jean Hollis Weber

Cathy Crumbley John A Smith Barbara Duprey

Hazel Russman John M. Dlugosz Ron Faile Jr.

Bruce Byfield Gillian Polack Rafael Lima
Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s
mailing list: documentation@global.libreoffice.org

Note

Everything you send to a mailing list, including your email address and any other
personal information that is written in the message, is publicly archived and cannot
be deleted.

Publication date and software version
Published March 2022. Based on LibreOffice 7.3.

Using LibreOffice on macOS

Some keystrokes and menu items are different on macOS from those used in Windows and
Linux. The table below gives some common substitutions for the instructions in this document.
For a detailed list, see the application Help.

Windows or Linux macOS equivalent Effect

Tools > Optllons LibreOffice > Preferences Access setup options

menu selection

Right-click Control+click or right-click o

) pen a context menu

depending on computer setup

Ctrl (Control) 3 (Command) Used with other keys

Alt \_ (Option) or Alt, depending on  Used with other keys
keyboard

F11 #E+T Open Styles deck in Sidebar

Documentation for LibreOffice is available at https://documentation.libreoffice.org/en/


https://documentation.libreoffice.org/en/
mailto:documentation@global.libreoffice.org
https://creativecommons.org/licenses/by/4.0/
https://www.gnu.org/licenses/gpl.html

Contents

L 0 0 ) 5 o | | 2
(070 o] 110U (] £8P 2
[T =T | o - Tod N 2
Publication date and SOftWare VEISION..........coeuuuiiiiiiiiieie e e 2
Using LibreOffice 0N MaCOS..........ooiiiiiiiii et araaas 2

Introduction — What iS WHLer?.....ciiiiiiiinisccssssssss s sssssssssssssss s s s snssssssssssssnssssssnnssssens 5

Parts of the main Writer WiNAOW...........ccuueemmmmmmnmmnnnnnnsnssssssssssssssssssssssssssssssssssssssssssssssssssas 5
LI L= o =V PP 5
=T U - 1 RPN 5
R T =1 o = 1 PN 6
L0 To] o= £ PSR 9

Displaying or hiding t00IDArS...........ooiiiiiiie e e 9
MOSE-USEA TOOIDAIS. ...ttt e e e e e e e e 9
Sub-menus and t00] PAIETIES. .........ooiiiiiii e 9
Locking and unlocking tOOIDAIS. .........iiiiiiii e e 10
Y To AV e o TR (oTe] | o F- U= TSP 10
Floating toolDars. ..........oouiii 10
LOLU LS (0] 4 14T g o TR (0011 o= T 5= 11
1 =1 £ P PUUPO PP 11
) = LU S 0 - | PP 12

Context (right-Click) MENUS........cciiiiiiii i ——— 14

[0 1= 1[0 T 1= 14

DOCUMENT VIBWS...cuuuiiiiiiiiiinnnssssssssssssisssssssss s s sssasssssssssssnsssnssssssssssssnnnssssnnnsssssnnnnses 15
N[0 0 F= VRV =P 15
LAY L] oY= PP 15
FUIN SCIBEN VIBW..... . ettt e e ettt e e e e e et e e e e e ee bt eeeeeeatt e eeeesstaneeeesantnanes 15

Creating a NEW dOCUMENT..........uuuummmmnnnnnnnnnnnnnnnnnnnnnnnnsnsnssnssnssssnsssnssnssssnnssnnnnnsssnnnnnnnnnnsssns 15
From the operating SYSIEM MENU...........ccoiiiiiiiiiiiiiee e e e e e e e e e e e e e e e eaaaranns 15
e o] I aTo IS =1 A O =T o) (= P 15
From the Menu bar, toolbar, or KeYDOard...............uuuueiiiiiiiie e 16
From @ tEMPIALE.........vviiiii it e e e e aran 16

Opening an exiSting dOCUMENL..........cccciimmmmmmmrriisssrnr s sss s s s snssnes 17
Opening files not in OpenDocument Text (.odt) format............cccooev i 18

S T= NV T = W0 [0 T ¥ T 43 T= o | 18
Y= 1YL= o] 121 1 = [0 £ 18

Save a new file or a previously-saved file..........ccoooiii i 18
oV (oI W =] 0 T01 (SIS AV PP 19
STz A= W o0} o )Y PP 19
Y= LY== | 19
SAVE AS COMIMANG......ciiiiiiiii e e e e e e e e e e et e e e e e eata e e e e e eataa e eeeesttan e eetneeanaeennaanes 19
Saving documents autoMALICAIIY............ccoeeiiiiiii e 19
Saving as a Microsoft Word dOCUMENL..............ouuiiiiiiii e e e e e e e 20
Exchanging documents with users of Apple Pages..........ooooiiiiiiiiiiiiiieeeeeee e 20

Chapter 1, Introducing Writer | 3



Using password protection and OpenPGP encryption.......cccccvvvemmmsmmnssssssssssssssssssnnnes 20

(e TS0 1o I o] o] (=T o 1o o 1 PP 20
OPENPGP ENCIYPUON. ...ttt e e e e ettt e et e e e e e e e e e e s e e e e e e e e et e e e e e e e eennnanas 22
Opening and saving files 0N remote SErVers.........ccccummmmnnnnnmnsmnmsnmss ... 22
Moving quickly through a document.............ccooimmmiii s 22
WS To I T I (oI = To TSRS 22
(WS T lo IRt gL A oY/ To T (o] PP 23
Y= na1 a1 I =T 01100 [T £ 25
Undoing and redoing Changes..........cccoiiiiiimmmmmmnissssssssssssssssssnssssssssnes 26
Displaying multiple view of a dOCUMENL..........ccoccmmmmiiiiiiiiiisserrr e 26
Reloading @ dOCUMENT...........ccciiiiiii s s e e nn s 27
Classifying document CONtENtS..........cciiiiiiiiiiismmsssrrssssss s ssssnnes 27
{03 (o X=11'0 Yo T W e Lo Yo 1 3 01T 0 ) O 27

4| Chapter 1, Introducing Writer



Introduction — What is Writer?

Writer is the word processor component of LibreOffice, a freely available, fully-featured office
productivity suite. In addition to the usual features of a word processor (text entry, editing, and
formatting; spelling checker, thesaurus, hyphenation, and autocorrect; find and replace; and
others), Writer provides these important features:

* Change tracking during revisions (Chapter 4)

* Page layout methods, including styles, frames, columns, and tables (Chapters 5 and 6)
» Export to PDF and ePub (Chapter 7)

* Document digital signatures (Chapter 7)

+ Templates and styles (Chapters 8, 9, and 10)

* Built-in drawing tools (Chapter 11)

* Lists (Chapter 12)

* Tables of data (Chapter 13)

* Mail merge (Chapter 14)

* Automated tables of contents and indexes (Chapter 15)

* Master documents, to group a collection of documents into a single document (Chapter
16)

* Fields and forms (Chapters 17 and 18)

» Database integration, including a bibliography database (Chapters 14, 15, and 18)
* Embedding or linking of spreadsheets, equations, and other objects (Chapter 19)
* And many more

Parts of the main Writer window

The main Writer window is shown in Figure 1. Its features are described in this section.

Note

By default, LibreOffice Writer's commands are grouped in menus and toolbars, as
described in this section. In addition, Writer provides other user interface variations,
displaying contextual groups of commands and contents. For more information, see
“Notebook bar” in the Help and Chapter 20, Customizing Writer.

Title bar

The Title bar is located at the top of the Writer window. It shows the file name of the current
document. When the document is not yet named, the document name will appear as Untitled X,
where X is a number. Untitled documents are numbered in the order in which they are created.

Menu bar

The Menu bar is located just below the Title bar in Windows and Linux and at the top of the
screen in macOS. When you select one of the menus, a submenu drops down to show further
options, including:

* Commands that directly cause an action, such as Close or Save, in the File menu.

» Commands that open dialogs. These are indicated by three dots following a command,
such as Find... in the Edit menu.
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« Commands that open further submenus. These are indicated by a right-pointing arrow
following a command, such as Toolbars and Zoom, in the View menu. Moving the
cursor onto one of these items causes its submenu to open.

B Untitledk LibreOffice Writer - O x
Eile Edit Miew Insert Format | Styles Table Form TJools Window Help
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Figure 1: Parts of the main Writer window

Sidebar

The Sidebar is normally open by default on the right side of the Writer window, as shown in
Figure 1. If necessary, select View > Sidebar on the Menu bar to display it. The Sidebar also has
a Hide/Show icon, as shown in Figure 2. When the Sidebar is closed, it can be opened by
clicking this icon, which will be on the far right side of the window.

The Writer Sidebar contains six decks by default: Properties, Page, Styles (also shown as Styles
and Formatting in some installations), Gallery, Navigator, and Style Inspector. Each deck can be
opened by clicking its corresponding icon on the Tab bar to the right of the sidebar.

Two additional decks are available when Experimental Features is enabled in Tools > Options
> LibreOffice > Advanced: Manage Changes and Design. These decks are not covered in this
book.

Each deck consists of a title bar and one or more content panels. A panel is like a combination of
toolbar and dialog. Toolbars and Sidebar panels share many functions. For example, the icons
for making text bold or italic exist in both the Formatting toolbar in the main Writer window and
the Character panel of the Properties deck.

Some panels contain a More Options button, which opens a dialog with additional editing
controls. When the dialog is open, the document is locked for other editing.

To adjust the width of the Sidebar, place the cursor on its left edge. When a double-headed arrow
appears, click and drag to right or left. When the Properties deck is open, you cannot make the
Sidebar smaller than a certain width. When any other deck is open, the Sidebar can be collapsed
to the width of its Tab bar.

To undock the Sidebar and make it floating, and to dock a floating Sidebar, use the drop-down list
in the Sidebar Settings above the Tab bar (see Figure 3). In the same list, you can use the
Customization menu to choose which tabs you want to include in the Sidebar.
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Figure 3: Sidebar Settings menu
The decks contained in the Sidebar are described below.
Properties deck: Contains tools for directly formatting content.
When text is selected, these panels appear:

— Style: Apply, create, or update a paragraph style.
— Character: Modify text properties such as the font name, size, color, weight, or
character spacing.

— Paragraph: Modify a paragraph’s alignment, background color, indent, and spacing,
and toggle numbered or bulleted lists.

When the cursor is in a table, this panel appears in addition to the panels for text.

— Table: Modify table properties such as insert or delete rows, merge or split cells,
define row height and column width, background color, and borders.
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When a graphic or image is selected, these panels appear:
— Area: Modify the fill mode and transparency of the background.
— Image: Modify the graphic's brightness, contrast, color mode, or transparency.

— Wrap: Modify the position of the graphic relative to surrounding text, where these
modifications are available.

— Position and Size: Modify width, height, rotation, or flip.
When a drawing object is selected, these panels appear:

Area: Modify the fill mode and transparency of the background.
Effect. Add and adjust a Glow or Soft Edge effect to the object.
Line: Modify arrows, line style, width, color, or transparency.
Position and Size: Modify width, height, rotation, or flip.

When a frame is selected, these panels appear:

— Area: Modify the fill mode and transparency of the background.

— Wrap: Modify the position of the graphic relative to surrounding text, where these
modifications are available.

When a video or audio clip is selected, these panels appear:
— Media Playback: Control for play, pause, stop, seek, loop, and volume.
— Position and Size: Modify width and height.

Styles deck: Manage the styles used in the document, apply existing styles, create new styles,
or modify them. For more information, see Chapter 8, Introduction to Styles, and Chapter 9,
Working with Styles.

Gallery deck: Shows images and diagrams included in the Gallery themes. The Gallery has two
sections: the first lists the themes by name (Arrows, Bullets, Diagrams, and so on) and the
second displays the images in the selected theme. For more information on using the Gallery to
add images to a document, create new themes and add your own images, see Chapter 11,
Images and Graphics.

Navigator deck: Browse the document and reorganize its content by selecting content
categories, such as headings, tables, frames, images, and so on. For more information, see
“Using the Navigator” on page 23.

Page deck: Contains tools for directly formatting the page style. It has four panels:
— Format: Modify the size, width, height, orientation, and margins of the page.
— Styles: Maodify the page numbering style, background, layout, and number of columns.
— Header: Activate/deactivate the header and modify its margins, spacing, and contents.
— Footer: Activate/deactivate the footer and modify its margins, spacing, and contents.

Caution

Be aware that by changing the options on the Page deck, you will change the page
style in use, modifying not only the current page but all pages using the same page
style in this document.

Style Inspector deck: Displays all the attributes of paragraph styles, character styles, and
manual (direct) formatting for selected text. For more information, see Chapter 7, Working with
Styles.
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Toolbars

LibreOffice has two types of toolbar locations: docked (fixed in place) or floating. Docked toolbars
can be moved to different locations (for example, top, bottom, or side of the workspace) or made
to float. Floating toolbars can be docked.

Displaying or hiding toolbars
To display or hide toolbars, go to View > Toolbars on the Menu bar, then click the name of a

toolbar in the drop-down list. An active toolbar shows a check mark beside its name. Note that
toolbars created from tool palettes are not listed in the View menu.

To hide a toolbar, go to View > Toolbars on the Menu bar and deselect the toolbar, or right-click
in an empty space between the icons on a toolbar and select Close toolbar in the context menu.

Most-used toolbars

In a default LibreOffice installation (Figure 1), the top toolbar, just under the Menu bar, is called
the Standard toolbar.

The second toolbar at the top is the Formatting toolbar. It is context-sensitive; that is, it shows the
tools relevant to the current position of the cursor or the selected object. For example, when the
cursor is in text, the Formatting toolbar provides tools for formatting text. When the cursor is on a
graphic (image), the tools are for formatting images.

To free more space for the document, you can choose a single-toolbar alternative containing the
most-used commands. To activate it, select View > User Interface > Single Toolbar.

Other toolbars are available at View > Toolbars. They are discussed in the relevant chapters of
this book.

Sub-menus and tool palettes

Toolbar icons with a small triangle to their right will display sub-menus, tool palettes, or other
methods of selecting items, depending on the icon.

A tool palette is a pop-up collection of tools attached to a single tool in a toolbar. The palette can
be made into a floating toolbar, as shown in Figure 4. Once removed from the parent toolbar, it
displays a Title bar. Tool palettes can be floating or docked along an edge of the screen or in one
of the existing toolbar areas.

| = Click here and drag to create a

|
Q Q Q Q Q g floating toolbar from a tool palette
Basic Shapes v X
bl EeEOAV
ALGO®® L0000
E@PFOO anceo0
¢-@-+-%-F 99FF+DO

Figure 4: Example of tearing off a tool palette

ﬂTip

If you cannot see the dots at the top of the tool palette, you need to unlock the
toolbar before you can float the palette. See “Locking and unlocking toolbars” below.
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Locking and unlocking toolbars

You can lock all toolbars, or individual toolbars, into place so they cannot be moved. When all
toolbars are locked, you cannot unlock individual ones.

To lock all toolbars in place, go to View > Toolbars on the Menu bar and select Lock Toolbars
at the bottom of the submenu. You will need to restart LibreOffice for this change to take effect.
To unlock all toolbars, click on Lock Toolbars again.

To lock an individual toolbar into place, be sure Lock Toolbars is not selected on View >
Toolbars, then right-click on the toolbar and select Lock Toolbar Position in the context menu.

Moving toolbars

Docked toolbars are indicated by dotted handles on the left end (Figure 5). They can be
undocked and moved to a new docked position or left as a floating toolbar.

To undock a toolbar:

1) Move the mouse pointer over the toolbar handle, which is the small vertical bar to the left
of a docked toolbar, as shown in Figure 5.

2) Hold down the left mouse button and drag the toolbar to a new location.
3) Release the mouse button.

File Edit View Insert Format
:‘ v [ - ig - {f E? qﬂ
1) | Default Style v || (&

Figure 5: Toolbar handles
To move a floating toolbar, click its title bar and drag it to a new floating location or dock the
toolbar at the top or bottom of the main window.
Note

You can also dock a floating toolbar by holding down the Ctrl key and double-clicking
in the title bar of the toolbar.

OTip

If the toolbar handle is not displayed, its position is locked. To unlock the toolbar,
right-click it and then deselect the option Lock Toolbar Position.

Floating toolbars

Writer includes several toolbars, whose default settings correspond to the current position of the
cursor or selection (when toolbars are made active). For example, when the cursor is in a table,
the Table toolbar appears, and when the cursor is in a numbered or bulleted list, the Bullets and
Numbering toolbar appears. You can reposition or dock these toolbars as described in “Moving
toolbars” above.

To position a toolbar, do any of the following:

* Right-click somewhere in the floating toolbar and click Dock Toolbar in the context
menu. You can reposition the toolbar to a different docked position. See “Moving
toolbars” on page 10.

* Click Dock All Toolbars to dock all floating toolbars.
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* Click Lock Toolbar Position to lock a docked toolbar into its position. Locking maintains
the toolbar’s position even when other toolbars on the same bar change location.

e Click Close Toolbar to close the selected toolbar.

Customizing toolbars

You can customize toolbars in several ways, including choosing which icons are visible and
locking the position of a docked toolbar. You can also add icons and create new toolbars, as
described in Chapter 20, Customizing Writer. To access a toolbar’s customization options, right-
click anywhere on the toolbar to open a context menu.

» To show or hide icons defined for the selected toolbar, click Visible Buttons on the
context menu. Visible icons are indicated by an outline around the icon or by a check
mark beside the icon (Figure 6), depending on your operating system. Select or deselect
icons to hide or show them on the toolbar.

o8 @®
~a - i s = = abg .
Eto-lH- D& 2 B- & il |
Defau & Load URL @ Load URL
[ Templates v [ New
[ I’ 1
i Open Remote [ Templates 3
2 save As... ¥ [~ Open
| 4] Email | Open Remote
E EPUB v [ save
i3 Print Directly () B2 save As...
| /o Clear £ Email
{ @ MNavigator
ab Auto Spellcheck [aiEcdnicts
JT Formula Object Read Oniy s
E] Index Entry « [ Export Directly as PDF
B Show [ epuB
[ Record + &= Print
[=] Data Sources ¢ Print Directly ()
Q) Zoom v [ Print Preview
O LibreOffice Help
[ What's This? v b
+ [y copy
v | Paste
v X Clone
Undock Toolbar Lo Clear
v Lock Toolbar Position ¥ <7 Undo
Close Toolbar ¥ (7 Redo
| ¢

Figure 6: Toolbar context menu and selection of visible toolbar icons:
1) Right-click anywhere on the toolbar; 2) Point to Visible Buttons;
3) Visible icons are marked.

* Click Customize Toolbar to open the Customize dialog. See Chapter 20, Customizing
Writer, for more information.
Rulers

The horizontal ruler across the top of the workspace is visible by default but the vertical ruler on
the left is hidden by default. To enable the vertical ruler, choose View > Rulers > Vertical Ruler
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on the Menu bar, or choose Tools > Options > LibreOffice Writer > View. To quickly show or
hide both rulers, use the key combination Ctrl+Shift+R.

OTip

The horizontal ruler has a comments button on its right end; click this to quickly show
or hide any comments.

Status bar

The Writer Status bar is located at the bottom of the workspace. It provides information about the
document and convenient ways to quickly change some document features. It can be hidden by
deselecting it in the View menu.

Document Page Word, character Page L
changes number count style anguage

|
L’! Page 13 of EXPage 9) 18,246 words, 104,913 characters DefaxPage Style  English (USA)

Figure 7: Writer Status bar, left end

el Selection Object g
+ J signature i i?ou 1 er acxlr
Insert ©—I /Numbering l:levell DODMMD = +—{} + 120%

Figure 8: Writer Status bar, right end

Document changes status
This icon changes color to indicate whether the document has no unsaved changes, or it
has been modified but not saved. Click this icon to save the document.

Page number
Shows the sequence number of the current page, the total number of pages in the
document, and the current page number (if different from the sequence number). For
example, if you restarted page numbering at 1 on the third page, its page number is 1 and
its sequence number is 3.

If any bookmarks have been defined in the document, right-clicking this field will show a list
of bookmarks. Click a bookmark to move the cursor to that location in the document.

To jump to a specific page in the document, left-click this field to open the Go to Page
dialog (Figure 14 on page 23). Type the desired page number and click OK.

Word and character count
The word and character counts of the document are shown in the Status bar, and are
updated as you edit. If you select a portion of text, the count for that selection will
temporarily replace the document total count.

The character count includes spaces. To display the character count excluding spaces,
click on the word count in the Status bar, or choose Tools > Word Count.

You can also see the number of words and characters (and other information including the
number of pages, tables, and images) in the entire document in File > Properties >
Statistics.
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Page style
Shows the page style of the current page. To select a different page style, right-click on this
field. A list of page styles pops up; click on one to select it. To edit the attributes of the
current page style, left-click on this field. The Page Style dialog opens.

Caution

Changing the page style here may affect the styles of other pages, depending on
how the page styles are set up. See Chapters 8 and 9 for details about styles.

Text Language
Shows the language and localization used for spelling, hyphenation, and the thesaurus. It
is based on the position of the cursor or the selected text.

Click to open a menu where you can choose another language/localization for the selected
text or for the paragraph where the cursor is located. You can also choose None (Do not
check spelling) to exclude the text from a spelling check or Reset to default language.
Choosing More... opens the Character dialog. See Chapter 3, Working with Text: Basics,
for more information.

Insert mode
Click to change to Overwrite mode; click again to return to Insert mode. In Insert mode, any
text after the cursor position moves forward to make room for the text you type; in
Overwrite mode, text after the cursor position is replaced by the text you type. This feature
is disabled when Edit > Track Changes > Record is activated.

Selection mode
Click to cycle between the selection modes (Standard, Extending, Adding, and Block). The
icon does not change, but when you hover the mouse pointer over this field, a tooltip
indicates which mode is active.

When you right-click this field, a context menu displays the available options. See Chapter
3, Working with text: Basic, for details.

Digital sighature
If the document has been digitally signed, an icon is displayed here; otherwise, it is blank.
Click here to sign the document or to view the existing certificate. See Chapter 8, Printing,
Exporting, Emailing, for more information.

Section or object information
When the cursor is in a section, heading, or list item, or when an object (such as a picture
or table) is selected, information about that item appears in this field. Clicking in this area
opens a relevant dialog.

Table 1: Section or object information in Status bar

Object Information shown Dialog opened
Image Size and position Image
List item Level and list style Bullets and Numbering*
Heading Outline numbering level Bullets and Numbering*
Table Name or number and cell reference of
cursor Table Format
Section Name of section Edit Sections
Other (Blank) Fields

1 If alist style was used with a list item or heading, no dialog appears.
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View layout
Click the corresponding icon to change between single-page, multiple-page, and book
layout views (Figure 9). You can edit the document in any view. Zoom settings interact with
the selected view layout and the window width to determine how many pages are visible in
the document window.

|..I..-i.|i ._|_|_. | I

1 1 2 1

3 5 6 4|5

Figure 9: View layouts: single-page, multiple-page, book

Zoom
To change the view magnification, drag the Zoom slider, or click the + and — signs, or right-
click the zoom level percent to pop up a list of magnification values from which to choose.
Zoom interacts with the selected view layout to determine how many pages are visible in
the document window.

= { + | 100%

Context (right-click) menus

Context menus provide quick access to many menu functions. They are opened by right-clicking
on a paragraph, graphic, or other object. When a context menu opens, the functions or options
available will depend on the object that has been selected. This can be the easiest way to reach
a function, especially if you are not sure where the function is located in the menus or toolbars.

Dialogs

A dialog is a special type of window. Its purpose is to inform you of something, or request input
from you, or both. It provides controls for you to specify how to carry out an action.

In most cases, you can interact only with the dialog (not the document itself) as long as the dialog
remains open. When you close the dialog (usually, clicking OK or a similar button saves your
changes and closes the dialog; clicking Cancel closes the dialog without saving any changes),
then you can again work with the document.

Some dialogs can be left open as you work, so you can switch back and forth between the dialog
and your document. An example of this type is the Find & Replace dialog.
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Document views

Writer has three ways to view and edit a document: Normal, Web, and Full Screen. To change
the view, go to the View menu and click the required view.

You can also choose View > Zoom > Zoom on the Menu bar to display the Zoom & View Layout
dialog, where you can set the same options as on the Status bar.

You can also use File > Print Preview, or press Ctrl+Shift+0O, to view the document, but this view
does not allow editing. See “Previewing pages before printing” in Chapter 7, Printing, Exporting,
Emailing, Signing.

Normal view

Normal view is the default view in Writer. It shows how the document will look when you print it or
create a PDF. In this view, you can use the Zoom slider and the View Layout icons on the Status
bar to change the magnification.

In Normal view, you can hide or show the headers and footers and the gap between pages. To
hide them, uncheck View > Show Whitespace on the Menu bar. A check mark beside this option
indicates that whitespace will be shown. When this option is unchecked, white space, headers,
and footers are also hidden in Full Screen view.

Web view

Web view shows how the document will look if viewed in a Web browser; this is useful when you
create HTML documents. In Web view, you can use only the Zoom slider. The View Layout icons
on the Status bar are disabled, and most of the choices on the Zoom & View Layout dialog are
not available.

Full Screen view

In this view, no toolbars or sidebar are displayed; the document takes up the full area available,
using the zoom and layout settings previously selected. To exit Full Screen view and return to
either Normal or Web view, press the Esc key or click the Full Screen icon on the floating toolbar
in the top left-hand corner. You can also use Ctr/+Shift+J to enter or exit Full Screen view.

Creating a new document

You can create a new, blank document in Writer in several ways. If a document is already open in
LibreOffice, the new document is created in a new window.

From the operating system menu

You can open the LibreOffice Start Center or the Writer component from the operating system
menu in the same way that you start other programs. When LibreOffice was installed on your
computer, in most cases a menu entry for each component was added to the system menu. On
macQOS, the LibreOffice icon will be in the Applications folder. When you double-click this icon,
LibreOffice opens at the Start Center (Figure 10).

From the Start Center

When LibreOffice is open but no document is open, the Start Center (Figure 10) is shown. Click
Create: Writer Document to create a new text document, or click Templates and choose a
template to start a new document using a template other than the default template.
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Figure 10: LibreOffice Start Center

From the Menu bar, toolbar, or keyboard
When Writer is open, you can also start a new Writer document in one of these ways:

* Press the Ctrl+N keys.
¢ Choose File > New > Text Document on the Menu bar.
* Click the New icon on the Standard toolbar.

From a template

Atemplate is a set of predefined styles and settings that is used to create a new document.
Templates enable the easy creation of multiple documents with the same default settings. For
example, all the chapters of the Writer Guide are based on the same template. As a result, all the
chapters look alike; they have the same headers and footers, use the same fonts, and so on.

A new LibreOffice installation may contain only a few templates, but you can create your own or
download more from https://extensions.libreoffice.org/ and other websites. See Chapter 10,
Working with Templates.

To open the Template dialog, where you can choose the template you want to use for creating
your document, do one of the following:

* Press the Ctrl+Shift+N keys.
* Choose File > Templates > Manage Templates on the Menu bar.
* Choose File > New > Templates on the Menu bar.

* Click the arrow next to the New icon on the Standard toolbar and select Templates in the
drop-down list.
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The example shown in Figure 11 highlights a template in the Documents folder. Double-click the
desired template to create a new document based on the that template. You can also right-click

one of the templates and then click Open. For more about the Templates dialog, see Chapter 10,
Working with Templates.
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Figure 11: Creating a document from a template

Opening an existing document

You can open an existing document in several ways.

When no document is open:

» Click Open File or Remote files in the Start Center.
* Choose File > Open or File > Open Remote on the Menu bar.
* Press Ctrl+O on the keyboard.

* Click a thumbnail in the list of recently opened documents displayed in the Start Center.
You can scroll up or down in the Start Center to locate a recently opened document.

Note

Renamed or relocated documents can still be listed in the Start Center. Selecting
one gives an error message that the file does not exist. To remove the thumbnail
from the Start Center, hover the mouse pointer over the thumbnail until an X appears
in the upper right corner, and then click on the X.

If a document is already open:

* Click the Open icon on the Standard toolbar.

* Click the small triangle to the right of the Open icon and select from a list of recently
opened documents, or select Open Remote File.
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* Use File > Recent Documents to make a selection from the submenu.

When using the Open dialog, navigate to the folder you want, select the file, then click Open. If a
document is already open in LibreOffice, the second document opens in a new window.

You can reduce the list of files in the Open dialog by selecting the type of file you are looking for.
For example, if you choose Text documents as the file type, you will only see documents Writer
can open. This method opens Word (.doc and .docx) files and other formats as well as
OpenDocument (.odt).

You can also open an existing Writer document using the same methods you would use to open
any document in your operating system.

Opening files not in OpenDocument Text (.odt) format

You can also open an existing document that is in a format that LibreOffice recognizes by double-
clicking on the file icon on the desktop or in a file manager such as Windows Explorer or macOS
Finder. LibreOffice may need to be associated with file types that are not ODF files for the
appropriate LibreOffice component to open.

For example, on a Windows computer, if you do not have Microsoft Office installed or if Microsoft
Office is installed but you have associated Microsoft Word file types (* . doc or *. docx) with
LibreOffice, then when you double-click on a Word file, it opens in LibreOffice Writer.

If you did not associate the file types with LibreOffice, and Microsoft Office is installed on your
computer, then when you double-click on a Microsoft Word file, it opens in Microsoft Word.

On macOS, if Microsoft Office is not installed and you have not associated those file types with
LibreOffice, the file may open in Apple’s Pages application.

See the LibreOffice Help for more about file associations.

Saving a document

You can save a document using any of the following commands:

* Save — use if you are keeping the document, its current filename and location.

* Save As — use to create a new document, or change the filename and/or file format, or
save the file in a different location on your computer.

* Save Remote — use if your document is already stored in a remote server or will be
stored in a remote server.

* Save a Copy — use to save a copy of your current document and keep it open for more
editing.

» Save All — use to save all the files open in your current session.

Save commands

Save a new file or a previously-saved file
Do one of the following:
* Press Ctrl+S.
* Choose File > Save on the Menu bar.
* Click the Save icon on the Standard toolbar.

If the file has not been saved previously, a Save As dialog appears after selecting one of the
above options. Enter the file name, verify the file type and location, and click Save.
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If a previously-saved file is being saved with the same file name, file type, and location, nothing
else needs to be done.

Save to a remote server

Use this command if your document is already stored on a remote server or you want to store it
on a remote server. Choose File > Save Remote. When the Save As dialog appears, enter or
verify the name, type, and location, then click Save.

See “Opening and saving files on remote servers” on page 22 for more information.

Save a copy

Use this command if you want to keep the document open for more editing and also save a
separate copy of the current version.

Choose File > Save a Copy. When the Save As dialog appears, enter or verify the name, type,
and location, then click Save. The copy is not opened and the original file remains open and
active.

Save all
Use this command to save all files open in the current session.

Choose File > Save All. All open files will be saved without changes to name, type, or location.

Save As command

Use this command if you want to save the current version as a new document by changing the
file name or file type, or by saving the file in a different location on your computer.

Choose File > Save As, or use Ctrl+Shift+S to open a Save As dialog where you can change the
file name, type, or location, and click Save.

If you want to preserve the original file, first save a copy as described above.

Note

LibreOffice uses the term “export” for some file operations involving a change of file
type, such as PDF and ePub. See Chapter 7, Printing, Exporting, E-mailing, for more
information.

Saving documents automatically

You can choose to have Writer save documents automatically in a temporary file at regular
intervals. To set up automatic file saving:

1) Select Tools > Options > Load/Save > General on the Menu bar. (See also Chapter 20,
Setting Up Writer.)

2) Click Save AutoRecovery information every and set the time interval. The default value
is 10 minutes. Enter the value you want by typing it or by pressing the up or down arrow
keys.

3) You may also wish to select Always create backup copy.
4) Click OK to save the changes.
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Saving as a Microsoft Word document
You may need to save documents in Microsoft Word formats such as .docx. To do this:

1) Important: If your file is in Writer’s format (. odt), first save your document in that format.
If you do not, any changes you made since the last time you saved will only appear in the
Microsoft Word version of the document.

2) Then click File > Save As.

3) Onthe Save As dialog, in the File type drop-down menu, select the type of Microsoft
Word format you need. You may also choose to change the file name.

4) Click Save.

This creates a separate document with a different file extension. From this point on, all changes
you make to the document will occur only in the new document. If you want to go back to working
with the . odt version of your document, you must open it again.

ﬂTip

To have Writer save documents by default in a Microsoft Word file format, go to
Tools > Options > Load/Save > General. In the section named Default File Format
and ODF Settings, next to Document type, select Text document, then under
Always save as, select your preferred file format.

Exchanging documents with users of Apple Pages

Although Writer can open and edit files in Apple Pages format (* . pages), it cannot save in that
format or export to that format. Apple Pages cannot open files in OpenDocument format, so if you
need to share files with users of Pages, save your . odt file to a compatible format, such as
.rtf or .docx.

Pages users can also export (not save) a copy of a Pages document in a format compatible with
Writer, such as .docx or . rtf, which writer can then open, edit, and save to.

Using password protection and OpenPGP encryption

LibreOffice provides two types of document protection: password protection and OpenPGP
encryption. Files encrypted with the Save password cannot be decrypted without the password,
which must be sent to each user who needs to decrypt the document. With OpenPGP encryption,
the document is encrypted using an algorithm, which requires a key. Each key is used only once
and is sent to the recipient along with the document.

Password protection

LibreOffice provides two levels of password protection: read-protect (file cannot be viewed
without a password) and write-protect (file can be viewed in read-only mode but cannot be
changed without a password). Thus you can make the content available for reading by one group
of people and for reading and editing by a different group. This behavior is compatible with
Microsoft Word file protection.

To protect a document with passwords:

1) Use File > Save As when saving the document. (You can also use File > Save the first
time you save a new document.)

2) On the Save As dialog, select the Save with password option in the lower left corner
(Figure 12), and then click Save.
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Figure 12: Save with password and Encrypt with GPG key options

3) The Set Password dialog opens (Figure 13). Here you have several choices:
— To read-protect the document, type a password in the two fields at the top of the
dialog.
— To write-protect the document, click the Options button and select Open file read-
only in the File Sharing Password section.

— To write-protect the document but allow selected people to edit it, select Open file
read-only and type a password in the two boxes at the bottom of the dialog.

L3 Set Password S *

File Encryption Password
Enter password to open

Confirm password

Mote: After a password has been set, the document will only
open with the password. Should you lose the password,
there will be no way to recover the document. Please also
nokte that this password is case-sensitive.

= Options|

File Sharing Password
Open file read-only
Enter password to allow editing

Confirm password

Ll Cancel

Figure 13: Two levels of password protection

4) Click OK to save the file. If either pair of passwords does not match, you receive an error
message. Close the message box to return to the Set Password dialog and enter the
password again.

Caution

LibreOffice uses a very strong encryption mechanism that makes it almost
impossible to recover the contents of a document if you lose the password.

Changing or removing the password for a document

When a document is password-protected, you can change or remove the password while the
document is open. Choose File > Properties > General and click the Change Password button.
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OpenPGP encryption

LibreOffice uses the OpenPGP software installed on your computer. If no OpenPGP software is
available, you must download and install one suitable for your operating system before you can
use this option.

You must define a personal pair of cryptography keys with the OpenPGP application. Refer to the
OpenPGP software installed on how to create a pair of keys. For more information on using this
form of encryption, see the supplied Help.

OpenPGP encryption requires the use of the public key of the recipient; this key must be
available in the OpenPGP key chain stored in your computer.?

To encrypt a document:
1) Choose File > Save As,
2) Inthe Save As dialog, enter a name for the file.
3) Select the Encrypt with GPG key option (see Figure 12).
4) Click Save. The OpenPGP public key selection dialog opens.
5) Choose the public key of the recipient. You can select multiple keys.
6) Click OK to close the dialog and save the file encrypted with the selected public keys.

Opening and saving files on remote servers

LibreOffice can open and save files stored on remote servers (that is, not on your computer or
local area network). Keeping files on remote servers allows you to work with the documents
using different computers. For example, you can work on a document in the office and also at
home or elsewhere. Storing files on a remote server also backs up documents, saving data from
computer loss or hard disk failure. Some servers are also able to check files in and out, thus
controlling their usage and access.

LibreOffice supports many document servers that use well-known network protocols such as
FTP, WebDav, Windows share, and SSH. It also supports popular services like Google Drive and
Microsoft OneNote, as well as commercial and open source servers that implement the OASIS
CMIS standard. For more information, see the Getting Started Guide.

Moving quickly through a document

Writer provides ways to move quickly through a document and find specific items by using the
Navigator and other tools.

Using Go to Page
You can jump to a specific page in the document in these ways:

* Use the Go to Page field on the top right of the Navigator (see below).

* Use the Go to Page dialog (Figure 14), which shows the current page number and the
number of pages in the document. Type the number of the destination page in the text
box and click OK. To open this dialog, do any of the following:

— Click on the page number field on the Status Bar.
— Choose Edit > Go to Page on the Menu bar.
— Press Ctrl+G on the keyboard.

2 GPG (GNU Privacy Guard) is an implementation of the Open PGP standard.
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Using the Navigator

In a default installation of LibreOffice, the Navigator is part of the Sidebar. It lists all of the
headings, tables, text frames, graphics, bookmarks, and other objects contained in a document.

To open the Navigator (Figure 15), do one of the following:

» Click the Navigator tab in the Tab bar on the right of the Sidebar.

* Click the Navigator icon (if visible) on the Standard toolbar.

* Press F5.

» Choose View > Navigator on the Menu bar.
Click the + sign or triangle to the left of a category or subcategory to display its contents.
Table 2 summarizes the functions of the icons at the top of the Navigator.

Note

In a master document, the Navigator has different functions. See Chapter 16, Master
Documents.

The Navigator provides several convenient ways to move around a document and find items in it:

» To jump to a specific page in the document, type its sequence number in the box at the
top of the Navigator and press Enter. The sequence number may be different from the
page number if you have restarted numbering at any point.

* When a category is opened to show the list of items in it, double-click an item to jump
directly to that item’s location in the document. For example, you can jump directly to a
selected heading, graphic, or comment by using this method.

» To see the contents in only one category, highlight that category and click the Content
Navigation View icon. Click the icon again to display all the categories. You can also
change the number of heading levels shown when viewing Headings.

* Use the Previous and Next icons to jump to other objects of the type selected in the
Navigate By drop-down list.

* Inthe top left of the Navigator is a Navigate By drop-down list. You can pick a type of
object (such as a bookmark, table, or index entry) and then use the Previous (*) and Next
(v) buttons to jump from one to the next (Figures 15 and 16).
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Table 2: Function of icons in the Navigator

1

2

10

11

12

Note

Navigate By
Header/Footer

Anchor <—> Text
Set Reminder

Previous/Next

Go to Page

Content Navigation
View
List Box On/Off

Heading Levels
Shown

Drag Mode

Promote/Demote
Level
Promote/Demote
Chapter

Opens a drop-down list where you can select the type of
element by which you want to navigate.

Jumps between the text area and the header or footer area
(if the page has them).

Jumps between a footnote anchor and the corresponding
footnote text.

Inserts a reminder. See “Setting reminders” on page 25.

Jumps to the previous/next element of the type selected in
the Navigate By drop-down list.

Jumps to the page number shown in the box. Type a page
number or select it using the + and — signs.

Switches between showing all categories and showing only
the selected category.

Toggles between having the list box shown or hidden.
Choose the number of heading levels to be shown.

Select Insert as Hyperlink, Link, or Copy. See Chapter 3,
Working with Text: Advanced.

Quickly change the level of the selected heading in the
document. See Chapter 3, Working with Text: Advanced..
Move headings and text in the document. See Chapter 3,
Working with Text: Advanced..

A hidden section (or other hidden object) in a document appears gray in the
Navigator, and displays the word “hidden” as a tooltip. For more about hidden
sections, see Chapter 6, Formatting Pages: Advanced.
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OTip

Objects are much easier to find if you give them identifying names when creating
them. By default, LibreOffice gives objects names such as Imagel, Image2, Tablel,
Table2, and so on. These names are assigned in the order in which the objects were
added to the document, which may not correspond to the location of the object in the
document.

You can rename objects after inserting them. For example, to rename an image,
right-click its name in the Navigator, choose Image in the context menu, then choose
Image > Rename. The view jumps to the image (to show which one it is) and a small
dialog pops up. Type a new name for the image and click OK to save.

You can also right-click the image and select Properties. In the Image dialog, go to
the Options page, edit the name, and click OK.

Setting reminders

Reminders let you mark places in your document that you want to return to later on, for example
to add or correct information or simply mark where you finished editing. The possible uses of
reminders are limited only by your imagination.

To set a reminder at the cursor’s current location, click the Set Reminder icon in the Navigator.
You can set up to 5 reminders in a document; setting a sixth causes the first to be deleted.

Reminders are not highlighted in any way in the document, nor are they listed in the Navigator,
S0 you cannot see where they are, except that when you jump from one to the next, the location
of the cursor shows the location of the reminder.

To jump between reminders, first select the Reminder option in the Navigate By drop-down list.
Then click the Previous and Next icons.

Reminders are not saved with the document.
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Undoing and redoing changes

To undo the most recent change in a document, press Ctrl+Z, choose Edit > Undo on the Menu
bar, or click the Undo icon on the Standard toolbar. To get a list of all the changes that can be
undone, click the small triangle to the right of the Undo icon on the Standard toolbar. You can
select several sequential changes on the list and undo them at the same time.

i =- =201
] Actions to undo: 6
L Apply Styles: Caption |
! Change style: Framel -
Insert caption: “Sidebar propertie
Paste clipboard
Insert page break

.....................................................

Delete Comments by Cathy
Typing: * "

MNelata * "

Figure 17: List of actions that can be undone

After changes have been undone, Redo becomes active. To redo a change, select Edit > Redo,
or press Ctrl+Y or click the Redo icon on the Standard toolbar. As with Undo, click the down
arrow icon of the combination icon to get a list of the changes that can be restored.

Displaying multiple view of a document

You can open, view, and edit several views of the same document in LibreOffice at the same
time. These views are displayed in windows that can display different pages or use different
zoom levels or other settings. A change to the document in one window is immediately reflected
in the other windows. In Writer, for example, you might find this useful for copying or moving
information from one page to another.

To open a new window showing the document, go to Window > New Window on the Menu bar.
In each window opened, the filename in the title bar is automatically numbered as shown by the
example in Figure 18. If other LibreOffice documents are open at the same time, the list of
windows also includes them. The active window has a marker by its filename in the list. You can
switch between windows by clicking on a name in the list, or by clicking on the window itself if it is
visible on the display.

s Window Help

New Window 1

Close Window

GS7001-IntroducingLO.odt : 2
GS7001-IntroducingLO.odt : 3
G57014-CustomizingLO.odt

Figure 18: List of open windows

To close a window, go to Window > Close Window on the Menu bar, or use the keyboard
shortcut Ctrl+W, or click the Close icon on the Menu bar or Title bar of the window.
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Reloading a document

You may want to discard all the changes made in an editing session since the last time you
saved it. Undoing each change or remembering where the changes took place can be difficult. If
you are sure you do not want to keep the changes made since last time the document was
saved, you can reload the document.

To reload a document, go to File > Reload on the Menu bar. A confirmation dialog asks if you
want to cancel all changes; choose Yes to return the document to the version that was last
saved.

Classifying document contents

Document classification and security are important for businesses and governments. Where
sensitive information is exchanged between users and organizations, the parties agree how such
information will be identified and handled. LibreOffice provides standardized means for sensitive
information to be identified and protected, using a set of standard fields that can be used to hold
sensitive information.

LibreOffice implemented the open standards produced by TSCP (Transglobal Secure
Collaboration Participation, Inc.). It contains three BAF (Business Authentication Framework)
categories: Intellectual Property, National Security and Export Control. Each category has four
BAILS (Business Authorization Identification and Labeling Scheme) levels: Non-Business,
General Business, Confidential, and Internal Only.

To enable document classification, open the TSCP bar (View > Toolbars > TSCP
Classification). This toolbar contains list boxes to help in selecting the security of the document.
LibreOffice then adds custom fields in the document properties (File > Properties, Custom
Properties tab) to store the classification policy as document metadata.

To prevent a breach in security policy, contents with a higher classification level cannot be pasted
into documents with a lower classification level.

Closing a document

If only one document is open and you want to close that document, go to File > Close on the
Menu bar or click the X on the Title bar. The X may be located on either the right or left end of the
Title bar. In Windows and Linux, when you close the last document, then LibreOffice will close
completely. In macOS, you need to use LibreOffice > Quit LibreOffice.

If more than one document is open and you want to close one of them, go to File > Close on the
Menu bar or click the X on the Menu bar of that document’s window. When only the last
document is open, the X on the Menu bar disappears. The X on the Title bar remains.

If the document has not been saved since the last change, a message box is displayed. Choose
whether to save or discard changes.
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