Y LibreOffice §.. 83

Community

Writer Guide 7.5

Chapter 21,
User Interface Variants



Copyright

This document is Copyright © 2023 by the LibreOffice Documentation Team. Contributors are
listed below. You may distribute it and/or modify it under the terms of either the GNU General
Public License (https://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative
Commons Attribution License (https://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors
To this edition

Jean Hollis Weber Kees Kriek
To previous editions

Jean Hollis Weber

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s
forum at https://community.documentfoundation.org/c/documentation/loguides/ (registration is
required) or send an email to: loguides@community.documentfoundation.org. Emails sent to the
forum are moderated.

Note

Everything you send to a forum, including your email address and any other personal
information that is written in the message, is publicly archived and cannot be deleted.

Publication date and software version
Published February 2023. Based on LibreOffice 7.5.

Using LibreOffice on macOS

Some keystrokes and menu items are different on macOS from those used in Windows and
Linux. The table below gives some common substitutions for the instructions in this document.
For a detailed list, see the application Help.

Windows or Linux macOS equivalent Effect

Tools > Optllons LibreOffice > Preferences Access setup options

menu selection

Right-click Control+click or right-click

. Open a context menu

depending on computer setup

Ctrl (Control) 3 (Command) Used with other keys

Alt U (Option) or Alt, depending on  Used with other keys
keyboard

F11 F+T Open Styles deck in Sidebar

Documentation for LibreOffice is available at https://documentation.libreoffice.org/en/
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Introduction

By default, LibreOffice Writer's commands are grouped in cascading menus and in toolbars filled
with icons—the standard user interface described in Chapter 1. These menus and toolbars are
described in the chapters that discuss the related tasks and functions.

In addition, Writer provides other user interface variants, displaying contextual groups of
commands and contents. This chapter describes these user interface variants and provides a
quick reference to the location of the tools and functions when using each of the variants.

Selecting the user interface

When you set up Writer, you can choose one of these user interfaces, and you can switch
between them and the standard interface at any time.
1) Choose View > User Interface on the Menu bar.

2) On the Select Your Preferred User Interface dialog (Figure 1), choose one of the variants
on the left. An example of the variant is shown in the Preview box on the right, along with
a short description.

3) Choose the relevant button to apply your selection to all components of LibreOffice, or
only to Writer. The Writer window changes to match your selection.

4) Click Close to close the dialog.

® Select Your Preferred User Interface
Ul variants Preview
0 Standard Toolbar
Tabbed File Edit Insert
2 (%X D @
Single Toolbar
v Sityles B | U S

Sidebar

Tabbed Compact

Groupedbar Compact Standard user interface with menu, toolbar, and collapsed sidebar.
Intended for users who are familiar with the classic interface.

Contextual Single

Apply to All " Apply to Writer Close

Figure 1: Selecting a user interface

If you have activated experimental features (Tools > Options > Advanced), several more
choices appear on the left-hand side. These choices are not described here.

Standard interfaces

Three of the user interface choices in Figure 1 are described in Chapter 1, Introducing Writer.

Standard Toolbar
Classic mode with two visible toolbars: standard and formatting. The sidebar shows only its

tabs.

Single Toolbar
Only one toolbar with frequently used features. The sidebar shows only its Hide button.

Sidebar
The sidebar is fully opened and only one toolbar (Formatting) is showing.
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The elements on each of the standard user interfaces can be modified using the View menu on
the Menu bar.

Tabbed interface

The Tabbed interface (Figure 2) provides a familiar interface for users coming from proprietary
office suites such as Microsoft Office. It includes a Menu bar, an Icon bar, a Tab bar, icons for the
active tab, one or more tab-specific menus, and a Quick Menu. On Windows and Linux, the
Menu bar can be hidden or displayed by clicking on the Menu Bar icon in the Icon bar (Figure 4).

1 2 3 4

= '.'.(I‘I-C'J Prafuce.odi - LiseaOffice Wit I
| H57- '|'FI Eilw I v Insert Layout Rferenceg Bevew e Extension Took: I
= =7 T — —_ 5 [
|| Templates (L) Recort Docfimerts ™ [ITl B Save e 1 | PCF = 5 Print Directhy (Lesomark Universal w2 |_v | Digital Signatures
New [l See m Terplate | Open % Open Remscte ave I SectPemcte | Bport [SEPUB | Print [ Print Previem Properties [ Sign Exiting POF

1lconbar 2Activetab 3lconsonactivetab 4 Tabs 5 Tab menus 6 Quick menu
Figure 2: Tabbed Interface with Menu bar hidden

In Writer, this user interface variant includes nine fixed tabs and five additional tabs. Each tab
displays a set of icons grouped by context. The context can change depending on the location of
the cursor or the item selected. Each tab also includes one or more tab-specific drop-down
menus at the right-hand end. The Quick Menu is the same for all tabs.

The Tabbed interface can be customized using the Notebookbar tab of the Customize dialog to
show and hide the individual icons on the various tabs. See Chapter 20, Customizing Writer, for
more information.

If the icons on a tab do not fit into the width of the Writer window, >> appears at the end of the
row. Click it to display the other commands (Figure 3).

Home ¥ Home ¥
» -
) Find A table - d Zoom
HHEQ.  DE®

Figure 3: Displaying more commands on a tab

Icon bar

The icon bar (Figure 4) is located at the top left of the tabs.
1 2 3 4 5 &6
™ OvC @

Figure 4: Tabs — Icon box
1 Menu bar — Show / Hide the menu bar.
2 Open (CtrI+O) — Open a file browser, where you can select the file to be opened.
3 Save (Ctrl+S) — Save the open file.
4 Undo (Ctri+2) — Undo the last action performed.
5 Redo (Ctri+Y) — Redo the last undone action.
6 Print (Ctrl+P) — Open the Print dialog.
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Quick menu

At the right-hand end of the tab bar is a Quick menu (Figure 5) containing some commonly used
commands and links. Some of the Quick menu items have submenus, indicated by arrows on the
right.

(7 New b
W @ Recent Documents  »
Zoom |:B Close

User Interface...
Toolbars ¥
Customize...

Options... Alg+F12

LibreOffice Help  F1
Donate to LibreOffice
About LibreQOffice

lose =me

Figure 5: Quick menu

Fixed tabs

The fixed tabs in Writer are File, Home, Insert, Layout, References, Review, View, Extension,
and Tools. The tabs are described on the following pages. The illustrations show the left and
right ends of the tabs separately so they are large enough to more easily see the commands.

File tab

The File tab (Figure 6) includes commands to create new documents; open, save, print, and
close documents; manage templates; export to PDF and EPUB; display document properties;
add a digital signature; and sign an existing PDF.

*:__:' - ':__} - EDF File Home Insert Layout Reference
D [ Templates (D) Recent Documents ¥ = save as.. D) (1 poF
Mew 7 E Save as Template Open |7 Open Remote Save ﬂ Save Remote Export @, EPUB
nces Review View Extension Tools =
@ :ﬁ_wr! Print Directly (Lexmark Universal v2) DF Digital Signatures B Eile ™
Print E{ Print Preview Properties D Sign Existing PDF C) Help

Figure 6: Tabbed Interface — File tab
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The File tab has two menus (Figure 7): File and Help. The File menu contains the same
commands as the icons on the tab. The Help menu provides links to a variety of resources.

B | Fle v ( [& File «
@ | O New vj @ Help v "
IC'-) Recent Documents * : LibreDffice Help
[& Close What's This?
o e User Guides
Show Tip of the Day
=2 savess. Ctrl+ShiftsS |}
[& SaveaCopy. l Get Help Online
| Send Feedback

2 Epor.
[ Export as PDF... Restart in Safe Mode...
[2 Exportas ERUB.. Get Involved
[©] Email Document... Donate to Li.breDﬂice

Email as PDF... ] License Information

Send via Bluetooth...

About LibreOffice

[ ClosePreview Cirl+Shift+O
B Print.. Cirl+P
I[?g,' Printer Settings...
E,.F Digital Signatures...
[1  Sign Existing PDE...
Properties...

€]

Exit LibreQOffice Cirl+Q

Figure 7: File tab menus

Home tab

The Home tab (Figure 8) includes commands to cut, copy, paste, and format text; insert common
items (image, table, special characters, and page break); apply, update, and edit styles; and
others.

DT v File Home oo o e
Y cut | X Clone Liberation Sans vinp VAN ZE 2L ==
vaste [BCopy | ApCear B J US| x @ |[Al.R.A. = === =R
Review View Extension Tools =
A | Text Body Heading 2 Heading 4 { | EOTable = 1, Zoom Home ¥
4 Heading 1 Heading3 Title PIEEQ-IE®@ OFind

Figure 8: Tabbed Interface — Home tab
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The Home menu (Figure 9) provides additional commands that are not on the tab.

Home

Shadow
Cutline
Overline

Ol = w

UPPERCASE

ho
[ =

lowercasze

Cycle Case Shift+F3

ol

Sentence case
Capitalize Every Word
tOGGLE cASE

Insert non-breaking space  Ctrl+5hift+Space
Insert non-breaking hyphen Ctrl+5Shift+-
Insert soft Hyphen Cirl+-
No-width Optional Break Chrl+/
Mo-width Mo Break

f@ Character...
.7 Bullets and Numbering...

T:/.;; Paragraph...

@ Chapter Numbering...
BH selectal Ctrl+A
~  Standard
Block Area Alt+Shift+F8

E- Direct Cursor Mode
L2 Find... Crl+F

i Find and Replace... Crl+H
—@ Go to Page... Ctrl+3

Figure 9: Home tab menu

Insert tab
The Insert tab (Figure 10) includes commands to insert many commonly used items.

= EDF File Home Insert Layout References

= BTiter Ch & = i

* itle Page [Illg Chart B Gallery H I Bookmark =
@ - B == -

Page Break Section = | Table [% OLE Object Image ol Media Hyperlink @ Cross-reference Field

Review View Extension Tools =
A= F Insert Fontwork _/ "a’_\\ ’3} — - <> b i o Q HFormuIa Insert ¥
Text Box }!-\ AutoText = [ O E @ - i:? - Q - HE - Symbc.l = Er‘l'lD_]I - B @ @ -

Figure 10: Tabbed Interface — Insert tab
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The Insert menu (Figure 11) provides some of the same commands.

Insert ¥

E a Title Page...

i

_r
Lol

Manual Break...

3

Section...

5]

Gallery
Select Source...

Audio or Video...

(K

OLE Object...

Text from File...

= i B

Formula F2

Text Box
Fontwork...
AutoText.., Ctrl+F3

% = [F

Frame Interactively

O I

Flzating Frame...

Signature Line...

[l &

Envelope...

Figure 11: Insert tab menu

Layout tab
The Layout tab (Figure 12) provides commands for working on page layout.
E (_3' b CJ’) b ED# File Home Insert Layout References
ini - I . 0 . _ 1% Page Break 039 <L oo 2
Page Margins  OCrientation Page Size  Page Columns Aanual Break Q.00 - T |0.08" =
Review View Draw Extension Tools =
E Title Page @lf_"; Hyphenation [:i- Select B = I Edit Contour [__] [ Forward One Layout ~
D Watermark 7 Line Numbering Group S0 IE O= TextWrap E,D 1" Back One [‘é Page Style

Figure 12: Tabbed Interface — Layout tab
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The Layout menu (Figure 13) provides commands for a few of the same items.

Layout ¥

B Title Page..
D Watermark...

Page Columns

—
=m  Borders

~  LUse header/footer menu

D«; Page Style...

Figure 13: Layout tab menu

References tab

The References tab (Figure 14) provides commands for working with tables of contents,
indexes, footnotes and endnotes, cross-references, bibliographies, and fields.

BS-c-& Eile Home Insert Layout Referer
B Index Entry |T[L.'] Endnote @ |> Bookmark
Table of Contents Update Index | Footnote i Footnotes and Endnotes | Cross-reference || Caption
TENCEs Review View Extension Tools =
[_ @ More Fields = D Bibliography Database References %
red [ B3 I3 B Bibliography Entry (=] Data Sources 1) Update Al

Figure 14: Tabbed Interface — References tab

The References menu (Figure 15) provides many of the same commands.

References ™

B Index Entry...
B Table of Contents, Index or Bibliography...

|I[IT'] Endnote

Footnote or Endnote...

[ﬁ Page Number
[ Field v

Biblicgraphy Entry...

{£] Bibliography Database

1) Update All

[£ Fields Fo

Figure 15: References tab menu
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Review tab

The Review tab (Figure 16) assists in editing. It provides quick access to recording, showing,
hiding, and managing changes.

BEo~c-&

L]

abc
iy

Spelling  Thesaurus &% Word Count

References Beview

E\?{ Accept

B} Reject Eﬁ'} Reject and Move to Next

b Auto Spellcheck

View

Ej) Accept and Move to Next @ Accept All

Eile

Extension Tools

EE‘ Compare

) Reject All Protect [ Merge

Figure 16: Tabbed Interface — Review tab

I-V_—l Reply Comment

Comment L,_x‘ Delete Comment

Insert

Redact

Layout

@\ D Mext

Record Show < Previous

Review ¥

E‘é Manage

(2

Edit Mode

The Review menu (Figure 17) provides many of the same commands.

Review

ab  spelling...

ab
[0 Thesaurus..

More Dictionaries Online...

For Selection
For Paragraph
For All Text

[T}
=

Hyphenation...
Word Count...

Record
Show

Manage...

Accept All Changes
Reject All Changes

Protect...

I W B B

Compare Document...

]
b ]

Merge Document...

B Redact

Automatic Spell Checking Shift+F7
Ctrl+F7

Ctrl+5Shift+C

F7

Figure 17: Review tab menu
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View tab
The View tab (Figure 18) provides commands related to the display of a document on screen.

E xrj - ':__} - EDF Eile Home Insert Layout

E% l__#. @\.\ ﬂ— Formatting Marks Q ':1:'\ 100% |Z| Full Screen

Normal View Web View Print Preview L. Show Whitespace | Optimal [} Entire Page [o] Page Width

References Review Miew Extension Tools =
D Rulers | [°F Menubar L\\S' :I:':HelplinesWhile Maoving I:E VMiew ¥
Sidebar Grid @ Mavigator Select D Snap to Grid Mew Window ':::{\ Foom

Figure 18: Tabbed Interface — View tab

The View menu (Figure 19) provides many of the same commands.

View

|_—|.g, Mormal
& Web

=
1

Show Whitespace

Menubar

Sidebar Ctrl+F5
Status Bar

Rulers Ctrl+5hift+R
Display Grid

CIEHD S

Snap to Grid

Text Boundaries

Table Boundaries

Images and Charts

Field Shadings Ctrl+F8
Field Mames Ctrl+F9

7 [ & -

=y

4

L

Entire Page
Page Width
Full Screen Ctrl+Shift+])

3] EJ

Figure 19: View tab menu

Extension tab
The Extension tab (Figure 20) contains only the menu for accessing the Extension Manager.

Extension Tools

Extension ™

ﬂ Extension Manager... Ctrl+Alt+E

Figure 20: Tabbed Interface — Extension tab
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Tools tab
The Tools tab (Figure 21) provides several tools for macros, mail merge, and form creation.

E .‘__:I - |+ - %
Q. EE Edit Macros

Run Macro |5 Basic

Ces

Eile

Mail Merge Wizard [ Email

Home

[=] Envelope

Insert

Y4

Layout Reference

/ Form Control Wizards

Toggle Design Mode ™) Group Box

Review WView Extension
¢ [ $0 @ 4a | O [d [H
@ ClRmnEA G

Figure 21: Tabbed Interface — Tools tab

Tools

The Tools menu (Figure 22) provides some of the same commands.

Tools ¥

Q&

[a

| IO [

-
Lt

—
=
= O

Run Macro...
Edit Macros...
Organize Dialogs...

Organize Macros

Mail Merge Wizard...

Envelope...

Address Book Source...

Biblicgraphy Database

Exchange Database...
Data Sources Ctrl+5Shift+F4

AMIL Filter Settings...

Figure 22: Tools tab menu

Additional tabs

Additional tabs appear when an item is selected; they are displayed between the View and
Extension tabs. The additional tabs in Writer are Draw, Image, Media, Object, and Table.

Draw tab

Tools ™

% Options

The Draw tab (Figure 23) is displayed when a drawing object is selected. It provides commands
for captioning and modifying the drawing object and for inserting and modifying Fontwork objects.
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E d_J b 'L_} b EF Eile Home Insert Layout References Review
[ ] 4 EditPoints Line —————— Ha ~ I T E I citContowr | |5 B T
Caption L—‘i % eﬂh Area Fr‘\IE_ - Change Anchaor E E E Text Wrap m E‘E ﬂ

View Draw Extension Tools =
[__—J [ Forward One Enter Group | B4 Toggle Extrusion F Draw ¥
D:' [ Back One Group Exit Group Cﬂ - EEJ - ﬂ - ii * | Insert Fontwork rft £ &+

Figure 23: Tabbed Interface — Draw tab

The Draw menu (Figure 24) provides a subset of commands, which vary depending on the
drawing object.

Draw ~ L

Points

Mame... I
Description... I

Draw ~ !_

Points

Tilt Down
Tilt Up
Tilt Left
Tilt Right

Mame...

Description...
#

Figure 24: Draw tab menu examples

Image tab

The Image tab (Figure 25) provides commands for working with images, including captions,
cropping, borders and area styles and colors, anchors, wrapping, positioning, and filtering.

EDF File Home Insert Layout References
g B’ :E]'Crop Borders FH = E - @Borderﬂolor - r\_‘fﬂ Edit Contour
Caption f3c2h S M | Ares |N|:rne VH | Change Anchor X Text Wrap
Beview View Image Extension Tools =
,___' [ Forward One /7 0% = 0% = Image ™
O] 8ff ol | 5 7 BackOne Filter O o= = & |1.00 c !

Figure 25: Tabbed Interface — Image tab
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The Image menu (Figure 26) provides links to dialogs for working with images.

Image ™ E

Crop
Edit with External Tool

o

Replace...
Compress...

Save...

Area...
Imagehap
Mame...

Description...

Properties...

OB D& EH S 0B E

Insert Caption...

Figure 26: Image tab menu

Media tab
The Media tab (Figure 27) provides commands for positioning and running an audio or video file.
M HS-c-® File Home Insert Layout References
] &= Media Player A T T I EditContour |57 & T [ [, Forward One

. -

Caption {3 2h = A Change Anchor =0 3E [ Text Wrap O e ol /5 3'Back One

Review View Media Extension Tools =

GOnE = Media -
= Media Player rfl £ &

Figure 27: Tabbed Interface — Media tab
The Media menu (Figure 28) provides some of the same commands

vedia ~ [N

Media Player

Mame...

Description...

Insert Caption...
—

Figure 28: Media tab menu
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Object tab
The Object tab (Figure 29) provides commands to position, resize, link, choose colors and
borders for the selected object. The illustration shows the tab when a frame is selected.

/r_} - ':__} - EDF File Home Insert Layout References
I:I 67 Link Frames Borders [ = E - @ Border Color = ET] Edit Contour
Caption Unlink Frames | Area |N|:rne i | | | Change Anchor Text Wrap
Beview View Object Extension Tools =
Object =

,__'_j [y Forward One

00 88 ol | & 7' BackCne I

Figure 29: Tabbed Interface — Object tab

The Object menu (Figure 30) provides a few of the same commands. The illustration shows the
menu when a frame is selected.

Object ¥ L

Link Frames

&

MName...

06

Description...

)

Properties...

Figure 30: Object tab menu

Table tab
The Table tab (Figure 31) is opened when the cursor is in a table.
'i__} - ':__} - EDF Eile Home Insert Layout Refer
[] B2 BB BR [ spiit Cells B HH B M-=-8-
Caption E?’T:‘J Eﬁ B;E derge Cells %SP“tTEME Select Cell @ B | Table Styles .
‘erences Review View Table Extension Tools =
@ Tﬂ\ Formula = 00 Table

(T
e

1«

Optimize Size Sort Z Sum Number Format 76 @Table Properties

Figure 31: Tabbed Interface — Table tab
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The Table menu (Figure 32) includes some commands not shown on the tab.

Table « L -

| Eﬁ’ Autoformat Styles...

Rows...

Columns...

Row Height...
Column Width...

H  Minimize Column Width
5 Optimal Column Width

Protect Cells
~  Row to Break Across Pages
Table to Text...

Mumber Recognition

«  Table Boundaries

Figure 32: Table tab menu

Tabbed Compact interface

The Tabbed Compact interface has the same tabs as the Tabbed interface, but the commands on
each tab are arranged in a single row of icons, many with drop-down menus of choices.

E ‘:__:) - (_) b EF Eile Home Insert Layout References Review View

"% Page Break 'Ir'@' A Table ~ g Chart &DLEDbject Elmage [l Gallery EmlMedia | @2 Hyperlink [P Bookmark [ Cross-reference

Extenszion Tools

EField « | [MHTextBox [ | /OO

Ve — ~ <> > o EE - 55‘- AutoText QSymboI - ]_EFormula =) Emoji =

Figure 33: Tabbed Compact interface example: Insert tab

Groupedbar Compact interface

The Groupedbar Compact interface (Figure 34) is divided into groups that contain commands
organized as sets of icons and menus.

- E - E'f! a|'3 - <__) - @ w || Text Body Indent ~ | | |Liberation Sans ~(1pt [+ .ﬁ, - =

==
File = Edit ~ Styles * X f# Font ¥ B I Q - 'S' W . Paragraph ¥ E -1l .
HEBE-Q-=|/20PE |21 | THQ|MEMV| @ S0 B
Insert ¥ E@ References Review View ™ Form - Extension Menu -

Figure 34: Groupedbar Compact interface example
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The Groupedbar menu (Figure 35) provides a subset of commands, including a convenient way
to change the user interface.

TUQ|MEY| @ A0
View ¥ Form ¥ Extension ¥ Menu ¥
Menubar
[ Sidebar Ctrl+F5
e —
Standard Toolbar T UserInterface ’
Single Toolbar Toolbars »
Sidebar .
Customize...
Tabbed £33 Options.. Al+F12
Tabbed Compact
o Groupedbar Compact ﬂ Extension Manager... Ctrl+Alt+E
Contextual Single (]_j‘ Run Macro.
L—:ﬁ Organize Macros +
) LibreOffice Help F1
[ About LibreOffice

Figure 35: Groupedbar menu

Contextual Single interface

The Contextual Single interface displays a standard Menu bar and a single toolbar with context-
dependent content.
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