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LibreOffice objects know of various event types that can be fired in various situations. You
may intercept these events and process accordingly.

Objets That Provide Events
* The application

» Documents

» Document objects:
« OLE objects

* Forms and controls « Images * ImageMaps

 Basic dialogues and controls * Frames * Hyperlinks

Associating An Event To A Macro

Principe
1. Create the macro to be executed.
Follow this template:

Sub MacroName ()
End Sub

“Name the macro according to the object, action and event type.
example : Sub OnButtonOKClick()

The Sub may bear a parameter. See below.
2. Select the object that carries the event to intercept (list above).
3. Go to the object settings (method varies depending on the object).
4. Select the event to intercept (see the lists in this refcard).
5. point to the macro to be executed when the event fires.
Getting Information About The Event Fired
The Sub may read the input parameter in order to get more information about the event :

Sub EventResponse(ByRef Event As Object)
End Sub

The Event object structure and properties depend upon the type of event that fires the
Sub (see below).

Frequent situations for Basic dialogues controls:

To get to Read

Calling control object Event.Source

Control model object Event.Source.Model

Dialogue object, control owner Event.Source.Context

Event Categories And Properties

Dialogues provide four event categories (col. Cat in the last table):

* AutoTexts

Mouse M Events fired by actions using the mouse (ex: movements or clicks).
Keyboard K Events fired par keypresses.

Focus F Events fired when focus changes.

Specific S Events linked to some controls.

£ The constants listed below are case-sensitive.

Mouse Events

Coordinates are in pixels, measured from the top-left control angle.

See the com. sun. star.awt.MouseEvent structure

Buttons (short) The pressed button (const. com.sun.star.awt.MouseButton).

X (long) and Y (long) X (resp. Y) coordinate of the mouse pointer.

ClickCount (long) Number of clicks associated with the mouse event.
When LibreOffice can respond fast enough, ClickCount is 1 for a
double-click, because one single event is fired.

PopupTrigger True if contextual menu.

(boolean)

Constants defined in com.sun. star.awt.MouseButton

LEFT Left button. RIGHT  Right button MIDDLE  Middle button.

£ The VBA Click and Doubleclick events are not supported by LibO Basic. You may use
the LibO Basic event Mouse button released as a replacement for a Click event and
mimic the Doubleclick event by modifying the application logic.

Keyboard Events

Keyboard events are associated with logical key actions rather than to physical actions.

= Key combination = one single event.

A unique action on a modification key (dead key, ex SHIFT or ALT) doesn’t create an
independent event.

The keyboard Event object holds the properties

KeyCode (short) The keypressed code (com.sun.star.awt.Key.XXX).

Modification keys (R, and [[Xf) do not change that code.

The entered character (takes modification keys into account).

The key functionality, as the constant in

com.sun.star.awt.KeyFunction.XXXX

Specifiiles whether a modification was pressed, see constants

com.sun.star.awt.KeyModifier.XXX.

Constants defined in com. sun. star.awt.Key.XXX (excerpts)

KeyChar (String)
KeyFunc (Integer)

Modifiers (Integer)

NUMe & NUM9  Numbers RETURN POINT B

AdzZ Letters ESCAPE COMMA E
FLaF26 Function keys | TAB Tab LESS

uP Up BACKSPACE @& GREATER

DOWN Down SPACE W EQUAL Eﬂ]
LEFT Left INSERT cuT +
RIGHT Right DELETE copy +[
HOME Home ADD PASTE Ctrl gd V
END End SUBTRACT HELP
PAGEUP Page up MULTIPLY MENU =]
PAGEDOWN  Page down | DIVIDE CONTEXTMENU[E]

= These codes identify physical keys.
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Constants in com. sun.star.awt.KeyFunc . XXX

DONTKNOW None cuT Cut CLOSE Close
NEW New COPY Copy QUIT Quit
OPEN Open PASTE Paste PROPERTIES Properties
SAVE Save UNDO Undo FIND Find
SAVEAS Save as REDO Redo FINDBACKWAR Find

D backwards
PRINT Print REPEAT Repeat FRONT To front
Constants in com. sun. star.awt.KeyModifier.XXX (additive with +/And
MOD1 MOD2 | SHIFT

Focus Events

The focus Event objects provide the following properties
FocusFlags (short)  The focus change reason.

See the com.sun.star.awt.FocusChangeReason constants.
NextFocus (Object) The object that gets the focus (only for the On focus lost) event.
Temporary (Boolean) True if the focus is temporarily lost.
Constants as defined in com. sun.star.awt.FocusChangeReason

TAB Tab has been pressed. BACKWARD Former control.
CURSOR A direction key was AROUND From last to first control
pressed. (forward) or from the first
to the last (backward).
MNEMONIC A shortcut key was UNIQUEMNEMONIC A shortcut key to a unique
pressed. control was pressed.
FORWARD Next control.

Specific Events

Some events (ex : When initiating) can be fired by actions on some controls (ex : radio
buttons). No action is executed to know whether the control status has actually changed.
Avoid such “blind events” by recording the control former value in a global variable, then
check whether the value was changed when the event is fired.

Properties for the Item Status Changed event:

Selected (long) The currently selected entry.

Highlighted (long) The currently highlighted entry.

ItemId (long) The entry ID.

Document Events

Propriétés de I'événement entrant (voir chapitre suivant) :

EventName (string) Le nom de I'événement.

Source (object) Le document a I'origine de I'événement.
ViewController (object) Le contréleur d’affichage concerné, sinon Null.
Supplement (variant) Des infos complémentaires, sinon Empty.

Document Or Application Events

Tools > Customize, Events tab.
Available events:
Event
Start application
Close application
Document created
New document
Document loading finished
Open document
Document is going to be closed
Document closed

The assignhed macro is executed...
After the application start.
Before the application closes.
After File > New.
After creating the document from a template.
After the document was reloaded.
After File > Open.
Before the document is closed.
After the document has been closed.
= Note that the Document closed event may also
be fired on document saving, just before the doc-
ument is closed.
After the document view has been created.
Before the document view is closed.
After the document view has been closed.
After display of the document in the foreground.
After display of another document in the foreground.
Before File > Save, if the document name is specified.
5 See Document closed.
After File > Save, if the document name is specified.
After the document saving has failed.
Before File > Save as (or File > Save if the document
name is not specified).
After File > Save as (or File > Save if the document
name is not specified).
After a Save as error.

View created

View is going to be closed
View closed

Activate document
Deactivate document
Save document

Document has been saved
Saving of document failed
Save document as

Document has been saved as

‘Save as’ has failed

Storing or exporting copy of
document

Document copy has been created
Creating of document copy failed
Print document

After the creation of the copy.

After error on copy creation.

After the Print dialog closes, but before actual
printing.

After the modification status has changed.
After the document title has changed.

After the Print dialog closes, but before actual
printing.

After mail merge printing.

‘Modified’ status changed
Document title changed
Printing of form letters started

Printing of form letters finished

Merging of form fields started

Merging of form fields finished

Changing the page count When the page number changes.

= View events are fired when the document display changes: Preview mode or New
Window mode.

Document Events Sequences

Opening An Existing Document (All Methods)
Open document > View created
Closing The Active Document (All Methods)
View is going to be closed > Document is going to be closed > View closed >
Document closed
Creating A Document From A Template
New document > View created




Interacting With Document Objects

Object properties, then misc.: Macro tab, Macro button, Events button, etc.

° o
£y s
Event Fired when ° g E E “é, g
— =}
s ~fEF
Object clicked The object is selected. o o o
Mouse hover The mouse is moving above the object. o e o o
Hyperlink fired The hyperlink assigned to the objectis o e .
activated.
Mouse quit The mouse pointer is moved outside of o e o o o
the object.
Image loading ended The image loading is finished. .
Image loaded stopped  The images loading was interrupted by .
the user (ex: on page download).
Image loading error The image load failed (ex. image not .
found).
Alphanumerical Some text was entered using the .
characters entered keyboard.
Non-alphanumerical Non-printable chars were entered (tab, .
characters entered enter, etc.).
Frame sized changed The frame size was changed using the .
mouse.
Frame moved The frame was moved using the mouse. .
Before autotext Before the text block insertion. .
insertion
After autotext insertion After the text block insertion. .

Calc Sheets Events

Sheet > Sheet Events (or right-click the sheet tab then Sheet events)

Event The assigned macro is executed...
Activate document After the document was displayed in the foreground.
Deactivate document After another document was displayed in the foreground.
Selection changed After the selection was changed.
Double click After double-clicking a cell.
Right click After right-clicking a range.
Formulas calculated After formulae recalculation.
Content changed After a cell contents has been changed.

Control properties, Events tab.
Common Non-Database Events
Cat Event

The assigned macro is executed...

F When receiving focus  When the control receives the focus.

F When losing focus When a control loses the focus.

K Key pressed When a key is pressed on the focused control.

K Key released When a key is released on the focused control.

M Mouse inside When the mouse pointer is inside control boundaries.

M Mouse moved while key When the mouse is moved while a key is pressed. Ex:
pressed pressing a key during a drag and drop sets the drag/drop

mode (move or copy).
M Mouse moved While the mouse pointer moves over the control.
M Mouse button pressed When a mouse button is pressed while the pointer is over

the control.

== The Mouse button pressed event is also used to notify
of context menu calls.
Then, the event PopupTrigger property is TRUE.
On a right-click call, the event is fired twice: (1) on the
context menu call and (2) for the click itself. If you're
only interested in the click event, ignore calls where
PopupTrigger is TRUE.

When a mouse button is released while the pointer is over

the control.

While the mouse pointer is outside control boundaries.

M Mouse button released

M Mouse outside
Dialog Boxes Events

Some dialog boxes controls provide the supplemental events:

Cat Event The assigned macro is executed...
Execute action When the action starts. Ex: if the form has a Send

button, the sending process is the action to take.

= Use for button click responses.

When the control state has changed.

When moving a scroll bar or a spinbutton.

KM Item status changed
M While adjusting
Database Events Only
Event
After record action
After record change
Before record action

The assigned macro is executed...
After the current record was modified.
Just after the current record pointer was changed.
Before the current record is modified. Allows to ask for a
confirmation.
Before the form data is sent.
Before the modified control contents is written to the database.
Ex. Stop this action by returning FALSE.
After the modified control contents has been written to the
database.

Before submitting
Before update

After update

Event
Prior to reset

The assigned macro is executed...

Before a form is reset. The linked macro can, for example, pre-

vent this action by returning FALSE.

A form is reset if one of the following conditions is met:

1. The user presses an (HTML) button that is defined as a reset
button.

2. Anew and empty record is created in a form that is linked to
a data source. For example, in the last record, the Next
Record button may be pressed.

After a form has been reset.

Before the current record pointer is changed. Ex. To stop this

action by returning FALSE.

Before the form is unloaded (separated from the database).

Before the form is reloaded. The data contents has not been

updated yet.

As soon as the data have been suppressed from the form. Ex.

Ask for a confirmation.

After resetting
Before record change

Before unloading
Before reloading

Confirm deletion

When loading After the form was loaded.

When unloading Just after the form was unloaded (separated from the
database).

When reloading Just after the form has been reloaded. The data have been
already updated.

When the to be loaded form needs parameters (SQL).

This event is fired whenever a parameter can't be provided.

For example, the form data source might be the SQL command:
SELECT * FROM address WHERE name=:name

where :name is a parameter that must be filled out when
loading. The parameter is automatically filled out from the
parent form if possible. If the parameter cannot be filled out, this
event is called and a linked macro can fill out the parameter.
Whenever an error occurs when accessing the database.

= Applies to forms, listboxes and comboboxes.

Fill parameters

An error happened
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