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Using LibreOffice on macOS

Some keystrokes and menu items are different on macOS from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this document. For a
more detailed list, see the application Help.

Windows or Linux macOS equivalent Effect
Tools > Options menu LibreOffice > Preferences Access setup options
Right-click Control +click or right-click

. Open a context menu
depending on computer setup

Ctrl (Control) ¥ (Command) Used with other keys
F5 Shift + 38 + F5 Open the Navigator
F11 B +T Open the sidebar Styles deck
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Multi-page documents

Draw documents, like Impress presentation documents, can consist of multiple pages. This allows
you to create a drawing that has several sections and stored as one file on a computer.

When pages are inserted into a drawing, they are automatically named as Slide 1, Slide 2, and so
on in the Navigator. As you change page order, the pages are automatically renumbered. However,
if you want to easily identify each page, then it is recommended to give each page a memorable
name.

Page pane

By default the Page Pane (Figure 1) appears docked on the left of the workspace when you open
Draw and shows every page in the drawing as a thumbnail. If the Page Pane is not displayed, go
to View > Page Pane on the main menu bar.

g Note

The Page Pane is called Pages when it is in its docked position on the left of the

workspace.
Main menu bar Standard toolbar Line and Filling toolbar
LmnOice Fe BE ves v/_- Page Sraps Tooh  Windes  Helg / B i 2 o Neatike it O B
.- B Lt oo [Br CE— . ‘L.' Lt
j (: | Lt "B | =
Z B "
i a oo B
& —
v | L
I 8 B—B
-
I | v
Page Workspace i

Drawing toolbar Status bar Sidebar
Figure 1: Draw main window showing Page Pane, Workspace and Sidebar
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® 0 Navigator

|h-|:0-

Test drawing E
Figure 2: Navigator dialog

' Navigator x
e =
Page 1
P
Page 3 m

Figure 3: Navigator deck on Sidebar

The Page Pane is used as follows to help you control pages in your drawing:

Select a page using one of the following methods and the page will appear in the
Workspace for editing:

— Click on a page thumbnail in the Page Pane.

— Press the F5 key to open the Navigator dialog (Figure 2).

— Go to View > Navigator on the main menu bar to open the Navigator dialog (Figure 2).
— Click on the Navigator icon on the Sidebar to open the Navigator deck (Figure 3).

Select a thumbnail in the Page Pane, then drag and drop the thumbnail to change the page
order in the document.

Click and drag on the separator line between the Page Pane and Workspace to change
the width of the Page Pane.

Click on the middle of the separator line to show or hide the Page Pane.

Press and hold the Ctrl key, then double-click in the title bar of the Page Pane to undock it
and turn it into a floating window.

Click in the title bar and drag the Page Pane to turn it into a floating window.

Press and hold the Ctrl key, then double-click in the title bar of the floating Page Pane to
dock it back into its default position on the left of the workspace.
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* Click in the title bar and drag the Page Pane to return it to its docked position on the left
side of the Workspace.

* Right-click in the Page Pane and select New Page from the context menu to insert a page
into your drawing.

* Go to Page on the main menu bar to carry out one of the following actions listed in the
context menu:

— Select New Page to insert a new page.

— Select Duplicate Page to insert a duplicate page. The duplicate page will be a duplicate
of the page selected in the Page Pane.

— Select Insert Page from File and the Insert File dialog opens. Navigate to the folder
where the file is located, select then click on Insert.

— Select Rename Page and the selected page in the Page Pane is renamed.
— Select Delete Page and the selected page in the Page Pane is deleted.

* Right-click on a page in the Page Pane and select New Page, Delete Page or Rename
Page from the context menu.

» Select Page > Move on the main menu bar and select Page to Start, Page Up, Page
Down and Page to End from the context menu to move a selected page in the page order.

* Select Page > Navigate on the main menu bar and select To First Page, To Previous
Page, To Next Page and To Last Page from the context menu to select a page for editing.

Master pages

A master page is a page that is used as the starting point for other pages in your drawing. It is
similar to a page style in Writer and controls the basic formatting of all pages based upon it. A
drawing can have more than one master page so that you can assign a different look to pages in
your drawing, for example title page, contents page, and drawing pages.

A master page has a defined set of characteristics, including the background color, graphic, or
gradient; objects (such as logos, decorative lines, and other graphics) in the background, the
formatting of text, blocks of standard text, and insert fields such as page numbering, date, and
filename.

Z Note

LibreOffice uses interchangeable terms for one concept: slide master, master slide,
and master page. All refer to a page which is used to create other pages. When
searching for information in Draw Help, it may be necessary to use alternative search
terms.

Master page view

To add text, objects and fields to a master page, go to View > Master on the main menu bar to
open the master page view and open the Master View toolbar (Figure 4). If this toolbar does not
open, go to View > Toolbars > Master View on the main menu bar.

To return to normal page mode, click on Close Master View in the Master View toolbar or go to
View > Normal on the main menu bar.

Multi-page documents | 7



Master View
7 jo
v o New Master

W Ly Delete Master
W = Rename Master

v - Close Master View

Figure 4: Master View
toolbar

Creating master pages
Each drawing you create already has a default master page, but you can create extra master
pages to change the look of some of the pages in your multi-page drawing.

1) Go to View > Master on the main menu bar to open the master page view.

2) Click on the New Master icon in the Master View toolbar (Figure 4) to create a new master
page. The new master page is automatically selected allowing you to add a new set of
items to create a new look for your pages.

Renaming master pages
Each new master page created has the default name of Default 1, Default 2, and so on. It is
recommended to rename your new master page with a more meaningful name. The default master
page that was created when you first created your drawing can also be renamed.

1) Go to View > Master on the main menu bar to open the master page view.

2) Right-click on a master page in the Page Pane and select Rename Page from the context
menu or click on the Rename Master icon on the Master View toolbar (Figure 4). This
opens the Rename Master Slide dialog (Figure 5) where you can type a new hame.

3) Click OK to save the master page with its new name and close the dialog.

®0® Rename Master Slide
Mame

Default 1

e carcel | (D

Figure 5: Rename Master Slide
dialog

Deleting master pages
The Delete option and Delete icon are only available when there is more than one master page in
your drawing. You cannot delete the default master page that was created when you first created
your drawing.

1) Go to View > Master on the main menu bar to open the master page view.

2) Select and right-click on a master page in the Page Pane and select Delete Page from the
context menu or click on the Delete Master icon in the Master View toolbar (Figure 4).

Inserting fields

You can insert fields on each master page by going to Insert > Field on the main menu bar and
selecting a field from the context menu. The following fields can be inserted into a master page.
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Date (fixed) — inserts the current date into the master page as a fixed field. The date is not
automatically updated.

Date (variable) — inserts the current date into the master page as a variable field. The date
is automatically updated when you open the file.

Time (fixed) — inserts the current time into the master page as a fixed field. The time is not
automatically updated.

Time (variable) — inserts the current time into the master page as a variable field. The time
is automatically updated when you open the file.

Author — inserts the first and last names listed in the LibreOffice user data into the active
page. Go to Tools > Options > LibreOffice > User Data on the main menu bar to enter
your user data into LibreOffice.

Page Number - inserts the page number into every page of the drawing. To change the
number format, go to Page > Properties on the main menu bar to open the Page Setup
dialog (Figure 6). Click on the Page tab and select a number format from the drop-down list
in Layout Settings.

Page Title — inserts the page title. A page title is created in Normal view by going to Page
> Rename Page on the main menu bar and entering a title in Name text box in the
Rename Page dialog (Figure 7) that opens.

Page Count — inserts the total number of pages in your drawing.

File name — inserts the name of the active file. The name only appears after you save the
file.

] [ ] Page Setup

“ Background  Transparency

Paper Format
Format: Ad <]
Width: 29.70 cm 2] RBC -
Height: 21.00 cm [z
Orientation: Portrait
© Landscape
Text direction:  Left-to-right (horizontal) E Paper tray: [From printer settings] E
Margins Layout Settings
Left: 1.00cm |5\ Page numbers: 1,23, .. E
Right: 1.00cm Ié’\ Fit object to paper format
Top: 1.00 cm |5\
Bottom: 1.00 cm |5\
Help Reset Cancel ﬁ
Figure 6: Page Setup dialog
@] @ Rename Page
Name
First Page]
Help cancel | (NG

Figure 7: Rename Page dialog
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® 0 Edit Field
Field Type
0 Fixed
Variable
Language:  English (USA)
Format
Standard (short) i

e | cace | (SR

Figure 8: Edit Field dialog

[ BON Available Master Slides
Select a Slide Design

Standard

| Exchange background page

Delete unused backgrounds

Help Bloaliy cancel oK
Figure 9: Available Master Slides dialog

Editing field format
The format of Date, Time, Author or File name fields is edited as follows on a master slide:

1)
2)
3)
4)
5)

Click on the field to select it.

Select the field content.

Go to Edit > Fields... on the main menu bar to open the Edit Field dialog (Figure 8).
Select an option from the drop down lists for Language and Format.

Click OK to save your changes and close the dialog.

Assigning master pages
When your drawing has more than one master page, you can assign different master pages to
different pages.

1)

2)

Go to View > Normal on the main menu bar and select the page in the Page Pane you
want to assign a new master page to it.

Right-click on the page in the Workspace and select Change Slide Master from the
context menu to open the Available Master Slides dialog (Figure 9).
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3)
4)

5)

6)

[ JoN ] Load Master Slide

Categories Templates
My Templates Alizarin
Business Correspondence Beehive
Other Business Documents Blue Curve
Personal Correspondence and Docum :Blueprint Plans
Presentations Bright Blue
Styles Classy Red
DNA
Focus
v  Preview

Help cancel | (NG
Figure 10: Load Master Slide dialog

Select the master page design you want to use in Select a Slide Design.

If necessary, select the Exchange background page option to use the selected master page
for all pages in the drawing.

If necessary, select the Delete unused backgrounds option to delete any master pages
shown in Select a Slide Design that have not been assigned to a page.

Click OK to assign the selected master page to your page and close the dialog.

Master pages from templates

You can use master pages, which are defined in templates available in LibreOffice. Any master
pages loaded into your drawing are adapted to the page size of your drawing. This may cause
some images to be stretched when adapted to fit your drawing page size.

1)
2)

3)

4)
5)

6)

7)
8)

9)

10)

Go to View > Master on the main menu bar and open Master view in your drawing.

Right click on the master page displayed in your drawing and select Change Master Slide
from the context menu to open the Available Master Slides dialog (Figure 9)

Click on Load... in the Available Master Slides dialog (Figure 9) to open the Load Master
Slide dialog (Figure 10).

Chose a template category from list displayed in Categories.

Choose a template from the list displayed in Templates. A preview of the selected template
is displayed in Preview.

Click OK to close the Load Master Slide dialog and the Available Master Slides dialog
opens displaying the template in Select a Slide Design.

Select the master page design you want to use in Select a Slide Design.

If necessary, select the Exchange background page option to use the selected master page
for all pages in the drawing.

If necessary, select the Delete unused backgrounds option to delete any master pages
shown in Select a Slide Design that have not been assigned to a page.

Click OK to assign the selected master page to your page and close the dialog.
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Templates

A template is a special type of document that you use as a basis for creating other documents. For
example, you can create a template for company drawings so that any new drawing has your
company logo and name on the first page and any remaining pages in your drawing only show the
company name.

Templates can contain anything that regular documents can contain, such as text, graphics, a set
of styles, and user-specific setup information such as measurement units, language, the default
printer, and toolbar and menu customization.

You can create a specific template for any document type (text, spreadsheet, drawing, or
presentation).

If you do not specify a template when you start a new drawing or document, then the
drawing or document is based on a set of properties that are hard coded in LibreOffice.

You can create a default template for your drawings. See “Default template” on page 15 for
more information.

For more information on templates and templates from other sources, see the Getting
Started Guide Chapter 3 Using Styles and Templates.

Z Note

Draw does not have any predefined templates when it is installed on a computer.
However, you can install templates from other sources or create your own templates;
these methods are described in the following sections.

Creating templates

1) Open the drawing that you want to use for a template, or open and edit a template that you

2)

want to use as a basis for your new template.
Add any extra content and styles or edit the content and styles in your drawing.

e @ Save As Template
Template Name

Template Category

MNone

My Templates

Business Correspondence

Other Business Documents

Personal Correspondence and Documents
Presentations

Styles

Set as default template

Help Cancel Save
Figure 11: Save As Template dialog
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3)

4)
5)
6)

7)
8)

9)

10)
11)
12)

Save your template using one of the following methods to open the Save As Template
dialog (Figure 11):

— Go to File > Templates > Save As Template on the main menu bar to open the Save
As Template.

— Click on the small triangle to the right of the Save icon on the Standard toolbar and
select Save as Template on the context menu to open the Save As Template.

Enter a name for your template in the Template Name text box.
Select a category where you want to save your template in the Template Category box.

If you want the template to be used as the default template in Draw, then select the option
Set as default template.

Click on Save to save your template and close the dialog.

Alternatively, go to File > Save As on the main menu bar to open the Save as dialog
(Figure 12).

Navigate to the LibreOffice folder where templates are stored. Actual folder depends on
your computer system and setup.

Enter a filename with the extension .otg in the File name: text box.
In the File type: drop down list, select ODF Drawing Template (.otg) as the file type.
Click on Save to save your template and close the dialog.

Note

When using the Save as dialog (Figure 12), you must use the LibreOffice templates
folder for your template for the Template Manager to recognize and find your
template.

® @ Save as

fUsers/peterschofield/Library/Application Support/LibreOffice/4/user/template a Servers... -

| |Name |T\,rpe Size
"My Documents | Presentations Folder
¢ LibreOffice ~» Test Drawing.otg OpenDocument Drawir 10.7 KB
.y Draw Guide

File name: | Untitled 1 a ﬁ

File type: ODF Drawing Template (.otg) a Cancel

Save with password Automatic file name extension Help

Encrypt with GPG key
Edit filter settings

Figure 12: Save as dialog
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Using templates

Quick Start Center
If LibreOffice is not open, create a new drawing using a template is as follows:

1) Start LibreOffice and click on Templates in the Quick Start Center to open a display of
available templates for all LibreOffice applications.

2) Alternatively, if LibreOffice is not open, start LibreOffice and click on the small triangle to the
right of Templates in the Quick Start Center, then select Draw Templates to open a
display of available templates for Draw.

Templates dialog

Instead of using the default settings in LibreOffice to create a new drawing, use a template from
the Templates dialog (Figure 13) as follows:

1) |If Draw is already open, use one of the following methods to open the Templates dialog
(Figure 13):

— Go to File > New > Templates on the main menu bar.
— Go to File > Templates > Manage Templates on the main menu bar.
— Use the keyboard short cut Shift+Ctrl+N .

2) From the Filter drop down lists for applications and category, select the template you want
to use for your new drawing.

3) Click on Open to create a hew drawing in Draw and close the dialog.

[ ] & Templates
Search... Filter |All Applications E All Categories B
*m
LibreOffice_6.x_Draft_ Te Test Template Modern business letter Modern business letter
mplate sans-serif serif
Businesscard with logo cv Resume Alizarin
o . Move " Export . Import

e cancel (G

Figure 13: Templates dialog
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@9 Open

{Users/peterschofield/Library/Application Support/LibreOffice/4/user/template Servers... s

Places | |Name Type |Si?_e Date modi

7' My Documents Presentations Folder 03/25/20z

' LibreOffice ' groupuinames.xml HML-File 279 Bytes  03/25/20:

'y Draw Guide ' LibreOffice_6.x_Draft_Template.ott OpenDocument Text Te 153.0 KB 02/14/20z
i Test Templateotg OpenDocument Drawir 10.5 KB 05/11/20%

File name: |Test Template.otg OpenDocument Drawing Template 10.5 KB 05/11/2020, 12:03 ﬁ

File type: All files a Cancel
Version: | Current version E Help
Read-only

Figure 14: Open dialog

Open file dialog

If you know which folder contains the template you want to use for a new drawing, proceed as
follows:

1) Goto File > Templates > Open Template on the main menu bar to open the Open dialog
(Figure 14).

2) Navigate to the folder where the template is located.
3) Select the template you want to use.
4) Click on Open to open the template in Draw and close the dialog.

5) Go to File > Save As on the main menu bar to open the Save as dialog (Figure 12 on page
13).

6) Enter a filename using the extension .odg in the File name: text box.
7) Inthe File type: drop down list, select ODF Drawing (.odg) as the file type.
8) Click on Save to save your new drawing and close the dialog.

Default template

If you create a new drawing and do not select a template, LibreOffice creates the drawing using a
set of properties that are hard coded in LibreOffice. However, you can set any drawing template to
be the default template, even a template that you have created, so long as it is located in a
category displayed in the Templates dialog (Figure 13 on page 14).

Setting template as default
Set a template as default for use with a new drawing is as follows:

1) Use one of the following methods to open the Templates dialog (Figure 13 on page 14):
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2)

3)
4)

5)

— Go to File > New > Templates on the main menu bar.
— Go to File > Templates > Manage Templates on the main menu bar.
— Use the keyboard short cut Shift+Ctrl+N .

In the Filter drop down lists, select Drawings as the application and the template category
where the template you want to use is located.

Select the template.

Right-click on the template and select Set as default from the context menu. There is no
confirmation that the selected template has become the default template for new drawings.
The default template is indicated by check mark at the top left corner of the template icon.

Click on Cancel to close the dialog. The next time you create a new drawing, it will be
created using the default template.

Note

If you have created a new drawing that you want to use as the default template, then
you must save the drawing as a template first before you can use it as the default
template. See “Creating templates” on page 12 for more information.

Resetting default
To reset Draw back to the LibreOffice default properties for new drawings:

1)

2)
3)

4)

Use one of the following methods to open the Templates dialog (Figure 13 on page 14):
— Go to File > New > Templates on the main menu bar.

— Go to File > Templates > Manage Templates on the main menu bar.

— Use the keyboard short cut Shift+Ctrl+N .

Right-click on the default template. The default template is indicated by check mark at the
top left corner of the template icon.

Select Reset Default from the context menu. There is no confirmation that Draw has been
reset to using LibreOffice default properties when a new drawing is created.

Click on Cancel to close the dialog. The next time you create a new drawing, it will be
created using the LibreOffice default properties.

Editing templates

You can edit template styles and content, and then, if you wish, reapply the template styles to
drawings that were created from that template.

Note

You can only reapply styles. You cannot reapply content.

Editing

1)

Use one of the following methods to open the Templates dialog (Figure 13 on page 14):
— Go to File > New > Templates on the main menu bar.

— Go to File > Templates > Template Manager on the main menu bar.
— Use the keyboard short cut Shift+Ctrl+N .
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2) Locate the template you want to edit and select it.

3) Right click on the selected template and select Edit from the context menu. The template
opens in Draw.

4) Edit the template just as you would any other drawing.

5) Go to File > Save on the main menu bar or use the keyboard shortcut Ctr/+S to save the
template.

6) To save the edited template as a new template, see “Creating templates” on page 12 for
more information.

Updating documents from modified template
The next time that you open a drawing that was created from the changed template, you will be
asked to confirm whether you want to update the styles in your drawing to the formatting used in

the modified template (Figure 15).
o] Confirmation

The template Test Template' on which this document is based, has been modified.
Do you want to update style based formatting according to the modified template?

WUBEESHIEEN | eop Ol siyes

Figure 15: Confirmation dialog for style update
* Click Update Styles to update any styles in the document that have been changed in the
template and close the confirmation dialog.

* Click Keep Old Styles if you do not want to update any styles in the document that have
been changed in the template and close the confirmation dialog.

Z Note

If you select Keep Old Styles, then the confirmation dialog will not appear again the
next time you open the document after changing the template it is based on. You will
not get another chance to update the styles from the template.

Organizing templates

LibreOffice can only use templates that are in LibreOffice template folders (categories). You can
create new LibreOffice template folders (categories) and use them to organize your templates. For
example, separate categories for different projects or clients. You can also import and export

templates.

9 Tip
The location of LibreOffice template folders varies with your computer operating

system. To learn where the template folders are stored on your computer, go to Tools
> Options > LibreOffice > Paths on the main menu bar.
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Enter category name:
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Figure 16: Template category hame dialog

Creating template folders

1) Use one of the following methods to open the Templates dialog (Figure 13 on page 14):
— Go to File > New > Templates on the main menu bar.
— Go to File > Templates > Manage Templates on the main menu bar.
— Use the keyboard short cut Shift+Ctrl+N .

2) In the Filter drop down lists, select Drawing as the application.

3) Click on the Settings icon and select New Category from the context menu.

4) Enter a name for the new category in the dialog that opens (Figure 16).

5) Click OK to save the new category as a new category (folder) in LibreOffice and close the
dialog.

£7 Note

You can not create a new sub-categories inside existing LibreOffice categories. Any

template category created is added to the template category list in the Templates
dialog.

Renaming template folders

It is recommended to ONLY rename template folders (categories) that you have created.
Renaming LibreOffice template folders could cause problems with the other LibreOffice modules.

1) Use one of the following methods to open the Templates dialog (Figure 13 on page 14):
— Go to File > New > Templates on the main menu bar.
— Go to File > Templates > Manage Templates on the main menu bar.
— Use the keyboard short cut Shift+Ctrl+N .

2) Inthe Filter drop down lists, select Drawing as the application and the category you want to
rename.

3) Click on the Settings icon and select Rename Category from the context menu.
4) Enter a new name for the category in the name dialog that opens (Figure 16).

5) Click OK to save the renamed category as a category (folder) in LibreOffice and close the
dialog.
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® _® Delete Category

Select Category

Mone
My Templates
Business Correspondence

Other Business Documents

Personal Correspondence and Documents
Peter

Presentations

b caco (KIS

Figure 17: Delete Category dialog

Deleting template folders

You cannot delete the template folders supplied with LibreOffice or installed using the Extension
Manager. You can only delete folders that you have created.

1)

2)

3)
4)
5)
6)

Use one of the following methods to open the Templates dialog (Figure 13 on page 14):
— Go to File > New > Templates on the main menu bar.

— Go to File > Templates > Manage Templates on the main menu bar.

— Use the keyboard short cut Shift+Ctrl+N .

In the Filter drop down lists, select Drawing as the application and the category you want to
delete.

Click on the Settings icon and select Delete Category from the context menu.
Select the category in the Delete Category dialog that opens (Figure 17).
Click OK to delete the category and close the dialog.

Click Yes to confirm the deletion of the folder.

Moving templates
To move a template from one template folder to another template folder:

1)

2)

3)
4)

5)

Use one of the following methods to open the Templates dialog (Figure 13 on page
14):

— Go to File > New > Templates on the main menu bar.

— Go to File > Templates > Manage Templates on the main menu bar.

— Use the keyboard short cut Shift+Ctri+N .

In the Filter drop down lists, select Drawing as the application and the category where the
template is located.

Click on the Move icon and the Select Category dialog (Figure 18) opens.

Select a category from Select from Existing Category or enter a name for a new category
in Create a New Category.

Click OK to move the template and close the dialog.
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[ ] [ ] Select Category

Select from Existing Category

My Templates

Business Correspondence

Other Business Documents

Personal Correspondence and Documents
Peter

Presentations

Styles

or Create a New Category

Help Cancel DK

Figure 18: Moving templates dialog

Deleting templates

You cannot delete the templates supplied with LibreOffice or installed using the Extension Manager
from inside LibreOffice. You can only delete templates that you have created or imported. Although
system administrators can remove or add templates manually in the LibreOffice installation folder.

1)

2)

3)
4)
5)

Use one of the following methods to open the Templates dialog (Figure 13 on page
14):

— Go to File > New > Templates on the main menu bar.

— Go to File > Templates > Manage Templates on the main menu bar.

— Use the keyboard short cut Shift+Ctrl+N .

In the Filter drop down lists, select Drawing as the application and the category where the
template is located.

Right click on the template you want to delete and select Delete from the context menu.
Click Yes to confirm the deletion of the template and close the dialog.
Click Cancel to close the Templates dialog.

Importing templates

If the template that you want to use is in a different location, you must import it into a LibreOffice
template folder.

1)

2)
3)

4)

Use one of the following methods to open the Templates dialog (Figure 13 on page
14):

— Go to File > New > Templates on the main menu bar.

— Go to File > Templates > Manage Templates on the main menu bar.

— Use the keyboard short cut Shift+Ctrl+N .

Click the Import icon and the Select Category dialog (Figure 18) opens.

Select a category from Select from Existing Category or enter a name for a new category
in Create a New Category for the imported template.

Click OK and a standard file browser dialog opens.
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5)

6)

7)

Navigate to the folder containing the template you want to import, select it and click Open.
The file browser closes and the template appears in the selected category.

Alternatively, click on the Browse online templates icon to open your browser at the
LibreOffice template page and download the template you want to a folder on your
computer.

Repeat Steps 1 thru 5 above to import the downloaded template into LibreOffice.

Note

The Extension Manager provides an easy way to import and install template
collections that have been packaged as extensions. For more information about the
Extension Manager, see the Getting Started Guide.

Exporting templates

1)

2)
3)
4)

5)

Use one of the following methods to open the Templates dialog (Figure 13 on page
14):

— Go to File > New > Templates on the main menu bar.

— Go to File > Templates > Manage Templates on the main menu bar.

— Use the keyboard short cut Shift+Ctrl+N .

In the Filter drop down lists, select Drawing as the application and the Category where the
template is located.

Select the template you want to export and click the Export icon to open a file browser
window.

Navigate to the folder where you want to export the template to, select it and click Select.
The file browser closes and the template appears in the selected folder.

Click OK to close the information dialog.

Multiple layers

Layers in LibreOffice Draw allow you to assemble elements on a drawing page that are related.
Think of layers as individual workspaces that you can hide from view, hide from printing, or lock.

Layers do not determine the stacking order of objects on your drawing page, except for the
Controls layer which is always in front of all other layers. The stacking order of objects on your
drawing page is determined by the sequence in which you add the objects. You can rearrange the
stacking order by going to Shape > Arrange on the main menu bar.

Layers in a drawing are indicated by tabs located above the Status bar. Click on a tab to select a

layer.

Figure 19 shows the Layout layer has been selected.

Layout Controls Dimension Lines

Slide 1 of 1 (Layout) Shape selected
Figure 19: Layer tabs
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£7 Note

You can lock a layer to protect its contents, or hide a layer and its contents from view
or from printing. When you add a new layer, the layer is added to all of the pages in
your drawing. However, when you add an object to a layer, it is only added to the
current drawing page.

If you want the object to appear on all of the pages (for example, a company logo),
add the object to the master page by going to View > Master on the main menu bar.
To return to your drawing, go to View > Normal on the main menu bar.

Default layers

In Normal view, LibreOffice Draw provides three default layers that are visible to the user and
these default layers cannot be deleted or renamed.

Layout — is the default workspace where objects are normally placed.

Controls — used for form controls that have been assigned an action. Objects on this layer
are always in front of objects on other layers. Normally, form controls are not printed and
the Printable setting has to be set deselected.

Dimension Lines — is where the dimension lines are drawn. By switching the layer to show
or hide, you can easily switch dimension lines on and off.

In Master view, the layer Background objects is where you can place objects that you want to
appear on every page in your drawing, for example date, page number, drawing title and so on.

Inserting layers

1) Right-click the layer tab area at the bottom left of the Workspace area and select Insert

2)

Layer from the context menu, or go to Insert > Layer on the main menu bar to open the
Insert Layer dialog (Figure 20) or click right from existing layers on the tab area.

Type a meaningful name for the layer in the Name and Title text boxes. If necessary, type
a description for the layer in the Description text box.

@ ) Insert Layer
Name
Layerd

Title

Description

Visible
Printable
Locked

v cace | (D

Figure 20: Insert Layer dialog
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3)

4)

5)

6)

Select Visible if you want the layer to be visible in your drawing. When Visible is not
selected, the layer is hidden and its name in the layer tab changes color to blue.

Select Printable if you want the layer to print when you print your drawing. Not printing is
useful if you want use a draft layer for guides or annotations that you use in making the
drawing, but do not want to appear in the final output. The name of a layer is underlined in
the layer tab bar when the Printable option is turned off.

Select Locked to prevent any objects on this layer from deletion, editing, or moving. No
additional objects can be added to a locked layer. Locking a layer is useful, for example,
when a base plan is to be protected while adding a new layer with other details. The name
of a locked layer is written in italic in the layer tab bar.

Click OK to close the dialog and the new layer automatically becomes active.

Modifying layers

1)

2)

Right-click on the name tab of the layer and select Modify Layer from the context menu or
double-click on the layer tab or use Format > Layer... on the main menu bar to open the
Modify Layer dialog. This dialog is similar to the Insert Layer dialog in Figure 20.

Make your changes to the layer, then click OK to save the changes and close the dialog.

Working with layers

Selecting a layer

To select a layer, click on the name tab for the layer at the bottom of the drawing workspace. When
a layer is selected, objects added to your drawing will only be added to that layer. Form controls
are automatically added to the Controls layer and dimension lines added to the Dimension Lines

layer.

If there are several layers in your drawing, a layer tab may not not be visible on the layer tab bar.
Use the navigation icons on the left of the layer tab bar to navigate to the layer you want to use or

modify.

Hiding layers

1)

2)

3)

Right-click on the name tab of the layer and select Modify Layer from the context menu or
double-click on the name tab to open the Modify Layer dialog.

Clear the Visible check box and click OK. The text on the layer name tab changes color to
blue. Any objects placed on a hidden layer will no longer be visible on the other layers in
your drawing.

Alternatively, hold down the Shift key and click on the name tab to hide the layer.

Showing hidden layers

1)

2)

3)

Right-click on the name tab of the layer and select Modify Layer from the context menu or
double-click on the name tab to open the Modify Layer dialog.

Check the Visible check box and click OK. The text for the layer name tab changes to the
default color for text for your computer setup. Any objects placed on a hidden layer will now
become visible on the other layers in your drawing.

Alternatively, hold down the Shift key and click on the name tab to make the layer visible.

Locking layers

1)

Right-click on the name tab of the layer and select Modify Layer from the context menu or
double-click on the name tab to open the Modify Layer dialog.
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2) Check the Locked check box and click OK. The text on the layer name tab is underlined.
Locking a layer prevents any modification of the layer.

3) Alternatively, hold down the Citrl key and click on the name tab to lock the layer.

Unlocking layers
1) Right-click on the name tab of the layer and select Modify Layer from the context menu or
double-click on the name tab to open the Modify Layer dialog.

2) Uncheck the Locked check box and click OK to allow modification of the layer. The text on
the layer name tab is no longer underlined.

3) Alternatively, hold down the Ctrl | key and click on the name tab to unlock the layer.

Renaming layers
1) Right-click on the name tab of the layer and select Rename Layer from the context menu.

2) Type a new name for the layer and click outside the tab area to save the change.
3) Alternatively, follow the procedure in “Modifying layers” on page 23 to rename the layer.

4) Alternatively, hold down the Alt key and click on the name tab. The name becomes
editable and is already selected. Enter the new name and press Enter key.

Deleting layers
1) Right-click on the name tab of the layer and select Delete Layer from the context menu.

2) Confirm the deletion and the layer and all its objects are deleted.

Moving objects layer to layer

If an object, or a group of objects, is selected, the layer where the object has been placed is shown
at the left end of the Status Bar. Move an object, or a group of objects, from one layer to another
layer using one of the following methods:

* Click and hold on the object until the cursor changes shape. While holding down mouse
button, drag the cursor to the tab of the destination layer and release the mouse button.
The position of the object will not change, but its new layer is displayed in the Status Bar.

* Goto Edit > Cut on the main menu bar or right click on the object and select Cut from the
context menu. Click on the tab of the destination layer to make it the active layer. Then go
to Edit > Paste on the main menu bar or right click on the Workspace and select Paste
from the context menu. The position of the object will not change, but its new layer is
displayed in the Status Bar.

£77 Note

You can only rename or delete layers that you have added to a drawing. The default
layers Layout, Controls, Dimension Lines and Background objects, cannot be
renamed or deleted.

Dimensioning

Draw allows you to dimension objects and display these dimensions to make your drawing look
more like an engineering drawing. When you create dimensions, they are automatically placed on
the Dimension Lines layer (see “Default layers” on page 22 for more information).
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Configuring dimensioning

Two ways are available to access the options to configure dimensioning. Both methods use a
similar dialog where you can change the length, measurement, and guide properties of a
dimension line.

Drawing object styles

1)

2)
3)

4)
5)

Use one of the following methods to access your drawing styles to open the Graphics
Styles dialog (Figure 21):

— Go to Format >Styles > Edit Styles on the main menu bar.

— Click on the Styles and Formatting icon on the Line and Filling toolbar to open the
Styles deck on the Sidebar, then right click on a style and select Modify from the
context menu.

— Pressthe F11 key on your keyboard to open the Styles deck on the Sidebar, then
right click on a style and select Modify from the context menu.

— Click on the Styles icon on the Sidebar to open Styles deck, then right click on a style
and select Modify from the context menu.

Click on the Dimensioning tab to open the Dimensioning page in the dialog.

Make the changes you want for dimensioning using the various options in Line and
Legend sections on the Dimensioning page.

Click OK to save your changes and close the dialog.

To reset the dimensioning options to the default properties of the template, open the
Graphics Style dialog as given in Steps 1 and 2 above, then click on Standard.

[ NON ) Graphic Styles: Default
Organizer Line Area Shadowing Transparency Font Font Effects Indents & Spacing
Text Text- Animation- i Conﬁector Al ignmer-lt | Asia-.n Typography -Tahs _Highlighting
Line Legend
Line distance: 0.80 cm |5| Text position

Guide overhang: |0.20 cm |é| | |

e ® e
Guide distance: |0.10 cm |5| l |
Left guide: 0.00 cm (2] AutoVertical

. AutoHorizontal
Right guide: 0.00 cm 1Z]
- Parallel to line
Measure below object
Show measurement units
Decimal places: |2 z
P |:’| Automatic E

Help Reset Standard Cancel ﬁ
Figure 21: Graphic Styles dialog - Dimensioning page
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Guide distance: | -0.20 cm |f| (|* |
Left guide: 1.00 cm |:| AutoVertical

. AutoHorizontal
Right guide: lo.30cm [2]
Parallel to line
Measure below object
i Show measurement units
Decimal places: |2 |2]
= Automatic a

| 14552 mm |

v cce | (D

Figure 22: Dimension Line dialog

Dimension line dialog
1) Draw a dimension line. See “Dimensioning objects” on page 28 for more information.

2) Right-click on the dimension line and select Dimensions from the context menu to open
the Dimension line dialog (Figure 22).

3) Make the changes you want to use for dimensioning using the various options in this dialog.
These options are also available on the Dimensions page in the Graphics Styles dialog
(Figure 21):

4) Click OK to save your changes and close the dialog.

Dimensioning options

With reference to the Dimensions page in the Graphics Style dialog (Figure 21) and the
Dimension Line dialog (Figure 22), the dimensioning options are as follows. The preview in the
dialog will change as you change the following options showing how the dimension line will appear
in your drawing. An example dimension line is shown in Figure .

* Line — sets the distances between the dimension line and guides with respect to each
other, dimension baseline and object. The baseline is not visible in a drawing, but is
indicated by baseline points on each of the guides.

— Line distance — specifies the distance between the dimension line and the object or the
baseline. A minimum of -10mm to a maximum of 10mm can be entered in the text box.
Lower the value, the closer the dimension line is to the object or baseline.

— Guide overhang — is the distance the guide either extends above the dimension line or
is below the dimension line. A minimum of -10mm to a maximum of 10mm can be
entered in the text box. Using a positive value and the guide overhang extends above
the dimension line. Using a negative value and the guide overhang is below the
baseline.
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Figure 23: Example dimension line

Guide distance — specifies the length of the right and left guides below the dimension
line toward the object. A minimum of -10mm to a maximum of 10mm can be entered in
the text box. Positive values extend the guides above the baseline and further away
from the object. Negative values extend the guides below the below and closer to the
object.

Left guide — specifies the length of the left guide starting at the dimension line. A
minimum of -10mm to a maximum of 10mm can be entered in the text box. Positive
values extend the guide below the dimension line toward the object. Negative values
move the guide away from the object.

Right guide — specifies the length of the right guide starting at the dimension line. A
minimum of -10mm to a maximum of 10mm can be entered in the text box. Positive
values extend the guide below the dimension line toward the object. Negative values
move the guide away from the object.

Measure below object — reverses the positions and lengths of the dimension line and
guides set in Line options.

Decimal places — specifies the number of decimal places used for the display of line
properties.

* Legend — sets the properties of the dimension text.

Text position — determines the position of the dimension text with respect to the
dimension line and the guides. The AutoVertical and AutoHorizontal checkboxes must
be cleared before you can assign a text position.

AutoVertical — determines the optimal vertical position for the dimension text.
AutoHorizontal — determines the optimal horizontal position for the dimension text.

Parallel to line — displays, when selected, the text parallel to the dimension line or, when
deselected, at 90 degrees to the dimension line.

Show measurement units — shows or hides the dimension measurement units. You can
also select a measurement unit you want to display from the drop down list.

Z Note

The dimensioning options are always linked and stored with the current work page. All
the changes that you make apply only to this document. New documents are started
with the standard properties of Draw. If you want to use the dimensioning options for
future drawings, save your drawing as a template.
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Guide selection handles

The guide selection handles at the top and bottom of the guides are used to extend the guides
more than the limits of -10mm to 10mm in the Dimensions page in the Graphics Style dialog
(Figure 21) and the Dimension Line dialog (Figure 22).

With reference to the dimension example in Figure 23, the guide selection handles are used as
follows:

* Top guide selection handles — select either selection handle and drag the handle to
increase or decrease the guide overhang of both guides.

* Lower left guide selection handle — select the left guide selection and drag the handle to
increase or decrease of the left guide distance.

* Lower right guide selection handle — select the right guide selection and drag the handle
to increase or decrease of the right guide distance.

@ Tip

When dimensioning objects, it is recommended to use the zoom function, guide lines
and snap functions so that you can accurately place dimension lines on an object. See
Chapter 3 Working with Objects and Object Points for more information.

Dimensioning objects

1) Click on the small triangle next to the Lines and Arrows icon on the Drawing toolbar to
open the Lines and Arrows pop-up toolbar (Figure 24).

Note

34
13

This icon changes depending on the last tool used for Lines and Arrows. Also, this
toolbar can become a floating toolbar by clicking at the top of the pop-up toolbar and
dragging it into the Workspace.

2) Click on the Dimension Line icon and the cursor normally changes to a cross. This
depends on your computer setup.

Lines and Arrows LA
= R BRE %R W 1l1l/{>£

Figure 24: Lines and Arrows toolbar

7.75cm

1= =l

Figure 25: Dimensioning objects

28 | Advanced Draw Techniques



3) Position the cursor at one corner of the object, then click and drag the cursor to the other
corner of the object to draw the dimension line. To restrict drawing the dimension line in the
horizontal or vertical direction, press and hold the Shift key while dragging the cursor.

4) Release the mouse button when you reach the other corner of the object and the
dimension line is drawn with the dimension automatically added (as shown in Figure 25).
The dimension line is also placed automatically on the Dimension Lines layer. See “Default
layers” on page 22 for more information.

5) To edit the text of the dimension, double-click on an unselected dimension line to enter text
edit mode and make your changes. Click outside the dimension line to save the changes.

6) To configure the dimension line. See “Configuring dimensioning” on page 25 for more
information.

£77 Note

After editing the dimension text, entering your own text and then deleting your text, you
have to save your drawing and reopen it to enable automatic measurements for
dimensioning.

g Note

If drawing to scale, the dimension configuration values in the Dimensions page in the
Graphics Style dialog and the Dimension Line dialog will also be to scale. For
example, a value of 10mm in the dialog will result in a dimension value of 300mm if the
scale has been set to 1:30.

Drawing to scale

In Draw a drawing is made on a predefined drawing area. This is normally Letter or A4 page size
depending on your locale, computer setup, and the default printer connected to your computer.
However, depending on the actual size of the drawn objects, it is often convenient to reduce or
enlarge the drawing by scaling (for example 1:10 or 2:1).

You can specify a scale value by going to Tools > Options > LibreOffice Draw > General (Figure
26) and selecting a value from the Drawing scale drop-down list. The default setting for this option
is 1:1. When you make a change to the drawing scale, it is reflected in the rulers at the top and left
side of your drawing.

Any change in the drawing scale has no effect on the basic drawing operations. Draw automatically
calculates the necessary values (for example, dimension lines). The spacing of the grid points is
independent of drawing scale as the grid is an optical drawing aid and not a drawing element.

An increase in scale (for example 1:4) allows you to draw objects that would not fit into the paper
size for your drawing. A decrease in drawing scale (for example 4:1) allows you to draw small
objects accurately at an increased size to make them easier to understand. An example of drawing
to scale is shown in Figure 27. All three rectangles are the same size.

* The left rectangle was drawn at the default 1:1 scale and dimensioned.

* The drawing scale was then changed to 1:4 and the dimensions were automatically
increased by Draw to reflect the decrease in scale for the center rectangle.

* The drawing scale was then changed to 4:1 and the dimensions were automatically
decreased by Draw to reflect the increase in scale for the right rectangle.

Drawing to scale | 29



0@ Options - LibreOffice Draw - General

¥ LibreOffice Text Objects
User Data i e
b, Allow quick editing
View Only text area selectable
Print
Paths Settings Compatibility
Fonts Copy when moving Use printer metrics for document formatting
Security
Personalization Use background cache
Appllcatlmlr:u Colors Objects always moveable
Accessibility
Advanced Do not distort objects in curve
Online Update
OpenCL Unit of measurement: Centimeter ﬁ
» Load/Save ok -
» Language Settings Tab stops: 1.20cm |:,|
¥ LibreOffice Draw
e TOSIELLI R RERESEERRRES . Scal
A I R _
View Drawing scale: | 1:1
Grid
Print

Figure 26: LibreOffice Draw dialog - General page
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Figure 27: Examples of drawing to scale

Views

You can use several views of the same document. They can use different settings for visible,
printable and locked for layers, different zoom factors, different origins, or even use master page
and normal page at the same time. The document format can only contain one view. So make sure
that the view you want to save is active when saving.

To get a new view, go to Window > New Window on the main menu bar to open a new window.
Arrange the windows according to your operating system. The windows act on the same
document. A change to the document in one window is immediately reflected in the other window.

Gallery

Draw includes several images in the Gallery. These images are grouped into themes (for example
Arrows, Bullets, Computers, Diagrams, Environment and so on). The Gallery deck on the Sidebar
(Figure 28) lists the available themes. Click on a theme and its images are displayed below the
theme list.
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Figure 28: Gallery deck in Sidebar

You can create themes and add your images into the new theme to the Gallery. For more
information on creating themes and adding images, see “Creating themes and adding images” on
page 32.

You can also delete images and themes from the Gallery. For more information on deleting
themes and images, see “Deleting gallery themes and images” on page 33.

g Note

It is recommended NOT to delete themes or images that are part of the default
installation of LibreOffice. Deletion could cause problems in other LibreOffice modules
where the default Gallery themes and images have been used.

Using the Gallery
1) Use one of the following methods to open the Gallery deck on the Sidebar (Figure 28):
— Click on the Gallery icon on the Sidebar.
— Go to Insert > Media > Gallery on the main menu bar.
— Click on the Open Clip Art and Media Gallery on the Standard toolbar.

2) Select a theme at the top of the Gallery deck.
3) Use one of the following methods to place an image into your drawing:
— Click on an image in the Gallery deck and drag the image into your drawing.

— Right-click on an image and select Insert from the context menu and the image is
placed at the centre of your drawing.

— Right-click on an image and select Copy from the context menu and then paste the
image into your drawing. The image is placed at the center of your drawing.
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4)

Edit the gallery image to your preferences. For more information on editing pictures, see
Chapter 6 Editing Pictures.

Creating themes and adding images

1)

2)

3)
4)
5)

6)

7
8)

Use one of the following methods to open the Gallery deck on the Sidebar (Figure 28):
— Click on the Gallery icon on the Sidebar.
— Go to Insert > Media > Gallery on the main menu bar.

Click on New Theme at the top of the Gallery deck to open the Properties of New Theme
dialog (Figure 29).

Type a memorable name for your theme in the text box.

Click OK to save the new theme and close the dialog.

Right-click on the new theme name that you have created and select Properties from the
context menu to open the Properties of New Theme dialog (Figure 29).

Click on the Files tab to open the Files page of the Properties of New Theme dialog
(Figure 30).

Click on Find Files to open the Select Path dialog (Figure 31).

Browse to the folder that contains the images you want to use.

[ ] Properties of New Theme

New Theme

Type: Gallery Theme
Location: file:///Users/peterschofield/Library/Application Support/LibreOffice/4/user/gallery/new theme.sdg

Contents: 0 Objects

Modified: 05/13/2020, 12:44:43
Figure 29: Properties of New Theme dialog — General page
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Figure 30: Properties of New Theme dialog - Files page
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| NON | Select path
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Path: |/Users/peterschofield/Library/Mobile Documentsfcom-apple-CIoudDu-cs!LibreDfTice\fDr _
Cancel

Help
Figure 31: Select Path dialog for gallery theme images

9) Click Select to select the files contained in the folder and the Select Path dialog closes.
The list of files contained in the folder now appear in the Properties of New Theme dialog.

10) Select the files you want to use in for your new theme and click Add. The added files will
disappear from the file list and the images will appear in the Gallery.

11) If you want to add all the files in the list, click Add All. All the files will disappear from the list
and the images will appear in the Gallery.

12) Click OK when finished and close the Properties of New Theme dialog.

Deleting gallery themes and images

1) Right-click on a theme or image in the Gallery.
2) Select Delete from the context menu.
3) A confirmation message appears. Click Yes and the image or theme.

£77 Note

The image is a linked file and only the link is deleted from the Gallery. The original
image file is not deleted.

Updating the Gallery

All the images in the Gallery are linked files. Occasionally, it is beneficial to update a theme you
have created to make sure that all the files are still there. To do so, right-click on a theme you have
created and you have added at least one file and then select Update from the context menu.

Renaming themes

To rename a theme you have created, right-click on the theme name and select Rename from the
context menu.
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£7 Note

It is recommended NOT to rename themes or images that are part of the default
installation of LibreOffice. Renaming could cause problems in other LibreOffice
modules where the default Gallery themes and images have been used.

Using drawing objects with Gallery
As well as adding images to the Gallery, you can also drawing objects as follows:

1) Select the theme where you want to add a drawing object or create a new theme.

2) Click on a drawing object you have created and drag the object to the selected theme and
release mouse button. These objects are stored in a folder in your user directory.

After being added to the Gallery, the drawing object loses its connection to graphic styles and all
properties are set as direct formatting. The drawing object can be in new Draw documents and
also used in the other LibreOffice modules in the same way as any other object from the Gallery.

Adding complete themes
There are two ways to add a complete theme to the Gallery:

» If there is a folder with themes, you can add a path to that folder in Tools > Options >
LibreOffice > Paths > Gallery. Click on Edit... and select the folder that contains the
themes. Disadvantage of this method is you might get themes already installed. You cannot
delete a single theme from that folder in your Gallery, but you have to remove the total set
of themes by removing the path to the folder.

* Gallery themes can be installed as extensions. Search for themes at
https://extensions.libreoffice.org/extensions.

Colors

Draw (like all LibreOffice components) uses color palettes for the representation of colors. You can
create colors and color palettes to suit your own needs by modifying colors in a palette, adding
other colors, or creating custom color palettes.

Z Note

LibreOffice uses the RGB (Red, Green, Blue) color model internally for printing in all of
its software modules. The CMYK (Cyan, Magenta, Yellow, Key (Black)) controls are
provided only to ease the input of color values using CMYK notation.

* RGB model — stands for Red, Green, Blue. It is based on the additive color model of light
waves and is designed for electronic displays and computers.. This means, the more color
you add, the closer you get towards white. RGB is created using scales from 0 to 255. So,
black would be R=0, G=0, and B=0. White would be R=255, G=255, and B=255.

* CMYK model — stands for Cyan, Magenta, Yellow, Key (Black). It is a subtractive color
model where you have to subtract colors to get to white. It is mainly used in printing which
is why the ink cartridges for your printer are labeled CMYK. CMYK works on a scale of 0 to
100. If C=100, M=100, Y=100, and K=100, you end up with a black color. But, if all four
colors equal 0, you end up with true white.
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* HSB values — stands for hue, saturation, brightness. HSB values are an alternative
representation of the RGB color model and was designed to be more closely align with the
way human vision perceives color-making attributes. You can use HSB values to fine tune
any custom colors that you create.

Q Tip

More information on color models and color values can be found at
http://en.wikipedia.org/wiki/Color_model.

Changing colors

Changing colors in objects you use color palettes to select colors. These color palettes are
installed with LibreOffice and are used in all the LibreOffice modules. Using these color palettes is
similar across all types of objects, but accessing the color palettes does vary according to the type
of object selected.

Color Bar

Although LibreOffice includes tools that allow you to precisely specify a color, LibreOffice also
includes a Color Bar that allows you to quickly change the color of an object in your drawing. By
default, the colors available in the Color Bar are from the Standard palette.

Z Note

If you have changed the color palette in the Area or Line dialogs, the color palette
used by the Color Bar also changes to the selected color palette.

1) Select the object in your drawing where you want to quickly change the color.
2) Go to View > Color Bar on the main menu bar to open the Color Bar (Figure 32).

3) Left-click on a color to change the area fill color or right-click on a color to change the line
color of a selected object.

4) To remove a color from an object with a fill color, click on the X box in the bottom left corner
of the Color Bar.

5) To close the Color Bar, go to View > Color Bar on the main menu bar and deselect Color
Bar.

Area fill colors
Use the Area dialog as follows:

1) Select an object that has an area fill color, for example a colored square or triangle.
2) Open the Area dialog (Figure 33) using one of the following methods:
— Go to Format > Area on the main menu bar.

— Right click on the object and select Area from the context menu.
— Click on the Area icon on the Line and Filling toolbar.

3) Click on the Color button to open the Color page.
4) Select the color palette to use from the drop down list in Colors > Palette.
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Figure 32: Color Bar dialog
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Figure 33: Area dialog - Color page
5) Click on a color from the ones displayed, or select a color that has been previously used
from Recent Colors.

6) Click OK to save your changes and close the dialog. The selected fill color will appear in
the selected object.

Use the Area section in the Properties deck on the Sidebar (Figure 34) as follows:
1) Select an object that has an area fill color, for example a colored square or triangle.
2) Make sure the Area section in the Properties deck on the Sidebar is expanded.
3) Inthe Fill drop down list, make sure Color is selected.

4) Click on the small triangle to the right of Select the color to apply to open the Fill Color
palette.

5) Select the color palette to use from the drop down list in the Fill Color palette.

6) Click on a color from the colors displayed, or select a color that has been previously used
from Recent Colors.

7) The Fill Color palette will close and the selected fill color will be applied to the object.
Use the Fill Color palette available on the Line and Filling or Drawing toolbar as follows:

1) Select an object that has an area fill color, for example a colored square or triangle.

2) Click on the small triangle to the right of Fill Color on the Line and Filling or Draw toolbar
to open the Fill Color palette.
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3) Select the color palette to use from the drop down list in the Fill Color palette.

4) Click on a color from the colors displayed, or select a color that has been previously used
from Recent Colors.

5) The Fill Color palette will close and the selected fill color will be applied to the object.
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Lines or border colors

The Line Color palettes for lines and borders are identical in appearance and use as the Fill Color
palettes used for area fill colors.

Use the Line dialog (Figure 35) as follows:

1) Select a line or object in your drawing.
2) Open the Line dialog using one of the following methods:
— Go to Format > Line on the main menu bar.

— Right click on the line or object and select Line from the context menu.
— Click the small triangle to the right of the Color drop down list.

3) Select the color palette to use from the drop down list in the Line Color palette

4) Click on a color from the ones displayed, or select a color that has been previously used
from Recent Colors.

5) The Line Color palette will close and the selected color will be applied to the line or border.
6) Click OK to save your changes and close the dialog.
Use the Line section in the Properties deck on the Sidebar (Figure 36) as follows:

1) Select a line or object in your drawing.
2) Make sure the Line section in the Properties deck on the Sidebar is expanded.

3) Click on the small triangle to the right of Select the color of the line to open the Line Color
palette.
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4) Alternatively, click on the small triangle to the right of the Line Color icon on the Line and
Filling toolbar to open the Line Color palette.

5) Select the color palette to use from the drop down list in the Line Color palette.

6) Click on a color from the ones displayed, or select a color that has been previously used
from Recent Colors.

7) The Line Color palette will close and the selected color will be applied to the line or border.
Use the Line Color palette available on the Line and Filling or Drawing toolbar as follows:

1) Select a line or object that in your drawing.

2) Click on the small triangle to the right of Line Color icon on the Line and Filling or
Drawing toolbar to open the Line Color palette.

3) Select the color palette to use from the drop down list in the Line Color palette.

4) Click on a color from the colors displayed, or select a color that has been previously used
from Recent Colors.

5) The Line Color palette will close and the selected color will be applied to the line or border.

Object text

The Font Color palette for text is accessed using the Font Color icon in the Character section in
the Properties deck on the Sidebar (Figure 37), or the Font Color icon available on the Text
Formatting toolbar.

The Font Color palette for text is identical in appearance and use as the Fill Color and Line Color
palettes used for area fill, line and border colors.
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Sidebar - Character section
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£7 Note

The Text Formatting toolbar automatically replaces the Line and Filling toolbar when
text is selected in your drawing. If the Text Formatting toolbar does not appear, go to
View > Toolbars on the main menu bar and select Text Formatting.

1) Select text in a text box or text contained in an object in your drawing.

2) Click on the small triangle to the right of the Font Color icon in the Character section in the
Properties deck on the Sidebar (Figure 37), or the Font Color icon available on the Text
Formatting toolbar to open the Font Color palette.

3) Select the color palette to use from the drop down list in the Font Color palette.

4) Click on a color from the colors displayed, or select a color that has been previously used
from Recent Colors.

5) The Font Color palette will close and the selected color will be applied to the text.

Creating colors

Any custom colors created are automatically placed in the Custom palette. The Custom palette is
available across all modules of LibreOffice.

{7 Note

LibreOffice uses only the RGB color model for printing in color. The RGB values of the
selected color are displayed below the preview boxes.

To create a custom color using the Area dialog (Figure 33 on page 36) is as follows:

1) Go to Format > Area on the main bar to open the Area dialog.
2) Click on the Color button to open the Color page.

[ ] Pick a Color
) Cgum < RGB
, ) Red: EIl B
) Green: 56 |§,|
) Blue: 56 |_5,|
Hex #: fi3838
HSB
O Hue: o Iil
) Saturation: | 78% |§,|
| Brightness: | 100% |é,|
CMYK
Cyan: 0% |é,|
Magenta: 78% |§,|
I Yellow: 8% [
B -~ oG]
Help Cancel -

Figure 38: Pick a Color dialog
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3)
4)

5)

6)

7)

8)
9)

@ )] Name
Please enter a name for the new color:

Color 1

Figure 39: Name dialog
Select a predefined palette from the drop down list to open a color palette that contains a
color similar to the one you want to create.

Select a color in the color palette that is similar to the one you want to create. The color
appears in the New preview box.

If you know the RGB values of your custom color, enter these values in the RGB boxes
under the New preview box. The color in the New preview box will change as you change
the values.

If you do not know the RGB values, then create your custom color as follows:
a) Click on the Pick button to open the Pick a Color dialog (Figure 38).

b) Select the color range in the vertical bar, then click and drag the small target circle until
you have a color that is close to the color your require. You will notice that the values for
RGB, HSB and CMYK will change as you move the small target circle.

c) Alternatively and if you know the CMYK percentage values, enter these percentage
values in the CMYK boxes. You will notice that the RGB values will also change to
match the CMYK percentage values.

d) Click OK to close the Pick a Color dialog and your custom color appears in the New
preview box on the Area dialog.

On the Area dialog, click Add in the Custom Palette option to open the Name dialog
(Figure 39).

Enter a memorable name for your custom color in the text box in the Name dialog.

Click OK to save the name for your custom color and close the Name dialog. Your custom
color will be added to the custom palette.

Note

When you select one of the RGB or HSB options, the main color display in the Pick a
Color dialog (Figure 38) changes its color range to help you create a new color.

Note

It is important to use a memorable name for your custom color so that you can easily
recognize it in the Custom palette. If you do not give the color a memorable name, the
color will be given a hex number, which will make it difficult identifying colors when you
have more than one custom color.

Deleting colors

Only colors that you have created and are available in the custom palette can be deleted as
follows:
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1) Go to Format > Area on the main menu bar to open the Area dialog (Figure 33 on page
36).

2) Click on the Color button to open the Color page.

3) Select the custom palette from the drop down list in Colors > Palette.

4) Select the color you want to delete.

5) In Custom Palette, click on Delete and the color is deleted without any confirmation.
6) Click OK to close the Area dialog.

Bézier curves

In LibreOffice you can use Bézier' curves in your drawing. A curve is defined by means of a start
point, an end point, and, where necessary, control points. For points on the curve the terms nodes
or anchors are often used. For more information and an explanation of the mathematical
background of Bézier curves, see http://en.wikipedia.org/wiki/Bezier_curve.

Bézier curves are very useful for experimenting with the shape and form of curves. In point mode
you can change the curve alignment by dragging the points with the mouse. In the example shown
in Figure 40, the curve leaves the start point PO in the direction of the first control point P1 and
arrives at the end point P3 from the direction of the second control point P2. The more distant a
control point is from the start or end point the smaller the curvature at that point. If a control point
lies directly on one of these points, it has no influence on the curve.

P.

Po P.
Figure 40: Example of a Bézier curve

Drawing Bézier curves

1) Click on the Curve icon in the Curves and Polygons section of the Shapes deck on the
Sidebar or in the Drawing toolbar.

2) Click at the start point where you want to draw the curve and, keeping the mouse button
pressed, drag the cursor to the approximate the position of the end point for the curve.

3) Release the mouse button, then drag the end point of the curve to its end position.

4) Double-click when you have reached the end position of the curve and a curve is drawn.
The arc of the curve is determined by the distance you have dragged to create the end
point.

5) Click on the Points icon on the Drawing toolbar or press the F8 key to open the Edit
Points toolbar (Figure 41).

1 Beézier curves were invented by Pierre Bézier, an engineer working with the Renault car manufacturer,
who developed the technique in the 1960s. The technology was intended to make modeling the surface
of vehicles easier.
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6) Click once on the curve to display the start and end points. The start point of the curve is
larger than the end point.

7) Move the cursor over the start or end point and drag the control point to change the curve
shape. As you drag a start or end point, a control point appears at the end of a dashed line
connected to the point you have selected, as shown in Figure 42.

8) When you have the position for your start or end point, release the cursor and the control
point remains active.

9) Click on the control point and drag it to also change the shape of the curve.
10) When you have finished editing the curve, click anywhere on the workspace to deselect the
curve and stop editing points.
Edit Points
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Figure 41: Edit Points toolbar
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Edit Points tools

After the Edit Points toolbar has been opened, each time you select an object that has been
converted to a curve or polygon, the toolbar will appear. Each time you deselect an object that has
been converted, the toolbar will close. Available tools on the Edit Points toolbar will depend on the
object selected and which object point has been selected.

With reference to Figure 41, the tools available on the Edit Points toolbar allow you to edit and
change the shape of a Bézier curve and are explained as follows:
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* Points — allows you to activate or deactivate the edit mode for Bézier objects. In the edit
mode, individual points of the drawing object can be selected.

* Move Points — activates a mode in which you can move points. Click on a point and drag it
to another location. The curve on both sides of the point follows the movement; the section
of the curve between points changes shape. Point at the curve between two points or within
a closed curve and drag the mouse to shift the entire curve without distorting the form.

* Insert Points — activates the insert mode and allows you to insert points. You can also
move points, just as in the move mode. If, however, you click at the curve between two
points and move the mouse a little while holding down the mouse button you insert a new
point. The point is a smooth point, and the lines to the control points are parallel and remain
so when moved. If you wish to create a corner point you must first insert either a smooth or
a symmetrical point which is then converted to a corner point by using Corner Point.

* Delete Points — deletes one or several selected points. If you wish to select several points,
click the appropriate points while holding down the Shift key. After selecting the points to
be deleted, click this icon or press Delete key.

* Convert To Curve — converts a curve into a straight line or converts a straight line into a
curve. If you select a single point, the curve segment after the point will be converted. If you
convert the segment from straight to curve, the point itself and the other end point of the
segment each gets a control point. If you convert from curve to straight these control points
are removed. If you select more than two points, each time you click this icon, a different
portion of the curve will be converted. If necessary, round points are converted into corner
points. If a section of the curve is straight, the end points of the line have a maximum of
one control point each.

* Close Bézier — closes or opens a poly line or a curve. Aline is closed by connecting the
last point with the first point. The first point is indicated by an enlarged square.

* Split Curve — splits a curve into two or more curves. Select the point or points where you
want to split the curve, then click.

« Corner Point — converts the selected point or points into corner points (Figure 43). Corner
points have two movable control points, which are independent from each other. A curved
line, therefore, does not go straight through a corner point, but forms a corner.

Figure 43: Corner point

* Smooth Transition — converts a corner point or symmetrical point into a smooth point
(Figure 44). Both control points of the corner point are aligned in parallel and can only be
moved simultaneously. The control points may differ in length, allowing you to vary the
degree of curvature.

Figure 44: Smooth transition point
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Symmetric Transition — converts a corner point or a smooth point into a symmetrical point
(Figure 45). Both control points of the corner point are aligned in parallel and have the
same length. They can only be moved simultaneously and the degree of curvature is the
same in both directions.

Figure 45: Symmetric transition point

Eliminate Points — The angle from which the point reduction is to take place can be set by
going to Tools > Options > LibreOffice Draw > Grid.

Adding comments to a drawing

Draw supports comments similar to those in Writer and Calc.

1)

2)
3)
4)

5)
6)

Go to Insert > Comment the main menu bar. A comment box appears with a small marker
box containing your initials in the upper left-hand corner of your drawing. Draw
automatically adds your name and the date at the bottom of the comment (Figure 31).
Type or paste your comment into the text box.

To apply basic formatting to the text, right-click and select the formatting option from the
context menu.

To delete a comment, right-click on the comment or marker box or click on the small
triangle in the bottom right of the comment and select a delete option from the context
menu.

To move a comment, click on the small marker box and drag it to a new position.
To show or hide the comments, go to View > Comments on the main menu bar.

Ps 1||This is a comme B Bold

| Italic
U Underline
€, Strikethrough

~ Paste

Delete Comment
Delete All Comments by Peter Schofield

Delete All Comments

Figure 46: Comment in a drawing
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£7 Note

For your initials and name to appear in a comment, you have to enter your user data.
Go to Tools > Options > LibreOffice > User Data on the main menu bar and enter all
the necessary data. If more than one person edits the document, each author is
automatically allocated a different background color.

Connecting and breaking lines

It is possible in Draw to connect separate line elements together to make one line, or to break a
line that is composed of separate elements.

* To connect lines, select the lines and go to Shape > Connect on the main menu bar. The
end points on the line are joined together. The resulting shape is a poly line, not a closed
shape.

* To break a line that is composed of separate elements, select it and go to Shape > Break
on the main menu bar. Deselect the object and then select each separate element. Each
separate element is indicated with start and end points. Click on an element and drag it to a
new position.

Coordinate system

X and Y axes

The x-axis is the haorizontal position of an object and the y-axis is the vertical position of an object.
The rulers do not show a minus sign if there are negative coordinates. However, the minus sign for
negative coordinates is shown in the position field in the Status Bar and the Position and Size
dialog.

Workspace

The Workspace is larger than the drawing page. The area outside the drawing page is one page
width right and left and a half page above and below the drawing page. The size of the drawing
page is indicated by highlighted portions in the horizontal and vertical rulers.

You can draw objects that are partly or wholly outside the drawing page. However, when the
drawing is printed, any portion of an object or an object not on the drawing page is not printed,
saved or exported. This allows the Workspace area around the drawing page to be used for drafts
when creating objects.

Object position

The coordinates of objects and snap guides are shown relative to the origin. The default origin for
coordinates (0.00/0.00 position) is the top-left corner of the drawing page without margins or the
top left corner of the drawing page where the margins intersect. To change the default origin, click
and drag the intersection of the rulers in the top left corner of the Workspace to the desired
position. Guide lines will appear as you drag the default origin to its new position. This origin
setting is only for the current view and is not saved in the document.

The area inside the default origin is the area used for the grid when the option Snap to Grid and
Display Grid are selected.
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To reset the default origin back to its original setting at the top-left corner of the page, double click
in the top-left corner on the Workspace where the horizontal and vertical rulers meet.

Accuracy

Draw uses internally integer values in 1/100 mm. Therefore it is not possible to get an exact
position for 1/8 inch, for example. Also, many dialog fields are restricted to two decimals.

To work in maximal possible accuracy, go to Tools > Options > Draw > General and set the
option Unit of measurement to Millimeter. The rulers will also show metric units. However, to use
your favorite measurement unit, right click on the ruler and select your favorite measurement unit
from the context menu.
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