
 Draw Guide

Chapter 8  
Tips and Tricks



Copyright

This document is Copyright © 2005–2011 by its contributors as listed below. You may distribute it 
and/or modify it under the terms of either the GNU General Public License 
(http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution 
License (http://creativecommons.org/licenses/by/3.0/), version 3.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors
Martin Fox John Cleland Jean Hollis Weber

Feedback
Please direct any comments or suggestions about this document to: 
documentation@global.libreoffice.org

Acknowledgments
This chapter is based on an original French document written for OpenOffice.org 1.x by Michel 
Pinquier (translated into English by Alex Thurgood) and previous content revised by Jim Taylor. 
The chapter was revised for OpenOffice.org 2.0 by Linda Worthington, Daniel Carrera, Jean Hollis 
Weber, and Agnes Belzunce, and later translated into German by Wolfgang Uhlig. The German 
revisions were then translated into English and revised for OpenOffice.org 3.3 and LibreOffice 3.3 
by Martin Fox. Other contributors included Peter Hillier-Brook, Hazel Russman, Gary Schnabl, and 
Claire Wood.

Publication date and software version
Published 31 July 2011. Based on LibreOffice 3.3.3.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. 
The table below gives some common substitutions for the instructions in this chapter. For a more 
detailed list, see the application Help.

Windows/Linux Mac equivalent Effect
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Positioning objects with zoom

With zoom you can place objects with higher precision.

Figure 1: Using zoom to place objects 
with greater precision

Zoom adjustments using the status bar
The current zoom value is shown at the right-hand end of the status bar next to the zoom slider.

Figure 2: Zoom level on Status Bar

You can adjust the zoom value by using the slider, right-click on the zoom percent to select from a 
menu of preset values, or double-click to open the Zoom & View Layout dialog.

Figure 3: Zoom & View Layout

You can enter a zoom factor in the Variable field, select 100%, or use one of the three other 
choices. (The three options on the right hand side of the dialog are not available in Draw; they are 
active only for text documents.)

• Optimal: The drawing or selected object(not the page) is enlarged to just fit in the Draw 
page area.

• Fit width and height: The drawing page edges are set to show the entire page within the 
Draw page area. This is the same effect as choosing “Entire Page” from the right-click 
menu on the status bar.

• Fit width: The right and left page edges are set to the vertical edges of the Draw page area.

The exact effect of choosing one of these options depends on whether you have the Page pane 
switched on or off. 
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Figure 4: Zoom values – Fit width and height, Fit width, and Optimal

The Zoom toolbar
The Zoom toolbar provides additional zoom options. On the Standard toolbar (View > Toolbars > 
Standard), click on the downwards arrow of the Zoom button . You can also permanently 
display the toolbar by clicking on View > Toolbars > Zoom.

Figure 5: Zoom Toolbar

Zoom in. Enlarges the monitor picture. First click on the button, then on the object. 
Alternatively drag to create a zoom “window”.

Zoom out. Makes the monitor picture smaller. Just click on the button.

Reverts objects to their original size.

Changes display to the previous and next zoom factors. If these buttons are not 
visible, turn them on by clicking on the small black arrow on the title bar of the Zoom 
toolbar, then on Visible Buttons and finally on either of these two buttons.

Shows the entire page.

Zooms to page width.

Resizes the display to include all objects on the slide.

Zooms the selected object to Optimal.

Enables moving the drawing inside the Draw window, using the mouse.

Positioning objects with snap functions

In Draw, objects can be accurately and consistently positioned using grid points, special snap 
points and lines, object frames, individual points on objects, or page edges. This function is known 
as Snap.

To use the snap function easily, work with the highest practical zoom value. You can use two 
different snap functions at the same time, for example snapping to a guide line and to the page 
edge. It is best, however, to activate only those functions that you really need.

Examples for setting up the snap functions are found in Chapter 10 (Advanced Draw Techniques).
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Snap to grid
Use this function to move an object exactly to a grid point. This function can be switched on and off 

with View > Grid > Snap to Grid and on the Options toolbar with the icon .

Figure 6: Exact positioning with the snap to 
grid function

Showing the grid
To make the grid visible, choose View > Grid > Display Grid. Alternatively turn the grid on (or off) 

with the icon  on the Options toolbar.

Changing the color of the grid points
By default the grid points are bright gray and not always easy to see. Go to Tools > Options > 
OpenOffice.org > Appearance. In the Drawing / Presentation section, you can change the color 
of the grid points. On the Color Settings pulldown menu select a more suitable/visible color, for 
example black.

Figure 7: Changing the color of the grid points

Configuring the grid
Under Tools > Options > LibreOffice Draw > Grid you can change the settings of the grid (Figure
8).

No adjustment is necessary in the Grid field, as these settings can be changed directly from the 
icons on the Options toolbar.
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Figure 8: Configuring the grid

Resolution: sets the horizontal and vertical distance between two grid points.

Figure 9: Grids with different resolutions

Subdivisions: determines how many steps there are between adjacent grid points. Intermediate 
steps make it possible to have a larger separation between two grid points, so the drawing remains 
clearer. Objects can snap to intermediate points in exactly the same way as to grid points.

Figure 10: Grid with intermediate steps (subdivisions)

The snap field settings are largely self-explanatory. One important setting is the Snap range. Grid 
points and snap lines are both visual help elements that are managed separately by Draw. If you 
have activated a snap function and then move an object, Draw looks in the vicinity of the position 
of the object for those special help elements to determine the final position of the object; with the 
snap range setting, you can determine the extent of this search area. Exactly how large the snap 
area is depends on the current environment: which particular snap functions are in use, how the 
grid is configured, and whether or not there may be collisions with other objects. It is usually 
necessary to do a little experimenting to find what best suits your needs.
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Snap to Snap objects (snap lines and snap points)
Unlike grid points, Snap lines and Snap points are created by the user. Snap lines run horizontally 
or vertically and appear as dashed lines. Snap points appear as small crosses, again with dashed 
lines.

Note
In LibreOffice the names of the buttons in the Options toolbar are Display Guides 
and Snap to Guides when what is actually meant is Display Snap line and Snap to 
Snap line. These will hopefully be corrected in a subsequent version.

If you have activated this function, you can position objects exactly. Horizontal and vertical snap 
lines can be used together. Snap lines are not active immediately after inserting them but are 

turned on (or off) using the  icon or with the View menu. If the snap line is no longer needed 

you can hide it (or subsequently display it again) with the Display Guides icon  or using the 
View menu.

Figure 11: Objects ‘connected’ to snap lines (left) or to a snap point (right).  
Note that the snap point functions as if it were the intersection of two snap 
lines.

Inserting a snap line with the mouse
To insert a snap line in a drawing:

1) Hover the mouse cursor over the vertical ruler to create a vertical snap line or over the 
horizontal ruler to create a horizontal snap line.

2) Click and hold the left mouse button.

3) Drag the mouse into the drawing area to produce a snap line.

The snap line can be moved at any time by dragging it with the mouse. Moving a snap line will not, 
however, move any objects that have already been snapped to that line.
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Inserting snap points and snap lines using coordinates
The command Insert > Snap Point/Line opens a dialog where you can specify X and Y 
coordinates and choose the type of snap object: point, vertical line, or horizontal line.

Figure 12: Setting a) snap object type and 
b) snap object position using X,Y coordinates

Editing snap points and snap lines
All snap objects can be edited after setting them. If you right-click on a snap object, an appropriate 
menu opens allowing you to edit or delete the snap object.

Snap to page edge
With this function you can snap objects to the page edge. A combination with snap lines and snap 
to grid is also possible.

Figure 13: Objects positioned on the 
page margins

Snap to object border
With this function you can position one drawing object on the border of another. The connection 
point can lie anywhere on the object border. To use this function, first deactivate Snap to grid. 
Figure 14 shows some examples. Note that a typical object border will touch the border of a round 
object at only one of its four points.
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Figure 14: Objects positioned on the border of another object

Snap to object points
This function operates in a similar manner to the one just described. The difference is that the 
connection point can lie only at one of the four corner points of both the object being moved and 
the target object. This leads to the situation where two round objects have a connection point that 
does not lie on either object but at one of the red circled points.

Figure 15: Objects connected to the object point of another object

Help to position objects with guiding lines
To simplify the positioning of objects it is possible to make visible guide lines—extensions of the 
edges of the object—while it is being moved. These guide lines have no snap function.

The guide lines can be (de-)activated under Tools > Options > LibreOffice Draw > View > 

Guides when moving, or by clicking the  icon on the Options toolbar.
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Figure 16: Working with guiding lines

Drawing to scale

In Draw a drawing is made on a predefined drawing area or canvas. This will usually be in the 
Letter or A4 format depending on your locale settings, and will be output to some “standard” printer 
that you have set up on your computer (usually referred to as the default printer). Depending on 
the actual size of the drawn objects, it is often necessary or convenient to reduce or enlarge the 
drawing by some scaling value. You can specify the scale that you wish to use under Tools > 
Options > LibreOffice Draw > General.

The scale and selected unit of measurement are automatically reflected in the rulers, the window 
position and the window size. Scale settings can be stored permanently in a template that you can 
then use for new drawings.

The scale you use has no effect on the basic drawing operations. Draw will automatically calculate 
the necessary values (for example, dimension lines). The grid spacing is independent of drawing 
scale as the grid is not a drawing element but only an optical drawing aid.

Note
If you want to insert elements in a drawing from the Gallery or Clipboard, you 
should draw these to the same scale as you are using for the drawing to ensure 
the proper size ratio is maintained.

Splitting drawings on multiple layers

Layers are like transparencies that lie one on top of another on an overhead projector. You can 
insert and extract single layers as desired. For example in architecture the floor plan, heating, and 
electrical wiring can all be on separate layers. With complex drawings this layer technique offers 
many advantages. You can make layers visible or invisible as needed or you can protect a layer 
from further changes while you work.

In Draw three layers are always present by default: Layout, Controls, and Dimension Lines. Layout 
is the default layer when you create a new drawing.

To change to a layer, click on its tab. Everything that is drawn will be placed on the currently 
selected layer. The Controls layer is for control elements such as icons and pulldowns and is not 
usually used for ordinary drawing elements. The Dimension Lines layer is used whenever you 
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insert a dimension line on a drawing (unless the layer is made invisible). Use Insert > Layer to 
insert a new layer in a drawing (Figure 17).

Figure 17: Insert and modify layers

On the Insert Layer dialog you can specify the following properties:

• Visible: If this property is not activated, the layer will not be shown (the layer is removed 
from the stack).

• Printable: If this property is not activated, the layer will not be printed. This is useful if you 
use a ‘draft’ layer for guides or annotations that you use in making the drawing but should 
not appear in the final output.

• Locked: All objects on this layer are protected from deletion, editing, or moving. No 
additional objects can be added to a protected layer. This property is useful when a base 
plan is to be protected while adding a new layer with other details.

Right-click on a layer tab to bring up a menu where you can insert or delete a layer, rename an 
existing layer, or modify a layer. You can change the names of the user-defined layers; the default 
layer names cannot be changed.

If you choose Modify the dialog is similar to Figure 17, but you cannot edit the Name. You can edit 
the Title and Description and change the properties of the layer (Visible, Printable, Locked).

Tip
You can move objects on one layer while you are working on another layer. To 
avoid accidentally deleting or moving objects on another layer, you should lock 
that layer.

An example drawing: house plan and furniture
A popular application for programs like Draw is the “moving the furniture” scenario. You can easily 
draw the floor plan of a room or a house using Draw. The simplest way is to draw walls as thick 
lines. You can also draw single rectangles or polygons, place them together, select them and then 
from the right-click menu use Shapes > Merge to make a single figure, then add a hatching 
pattern. Before you do this, you should read the section “Drawing to scale” on page 11.
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For this example a suitable measurement unit is centimeter. The drawing scale and grid settings 
depend on the size of the floor plan.

Use the Position and Size dialog (right-click and choose Position and Size) to easily position and 
dimension the individual wall sections. Make sure that the rectangles completely overlap (see 
Figure 18) otherwise the merging will give uneven edges.

Figure 18: Wall corner from two rectangles. From upper to lower:  
before merging, after merging and after hatching

Figure 19 shows the finished floor plan. In addition, a chest of drawers has been added.

The body of the chest is drawn on the Layout layer; the pulled-out drawer and the open doors are 
drawn as a group and put on a separate user-defined layer (Layer4 in our example). Figure 20 
shows how this is done. Making the layer with the drawers and doors visible or hidden will show 
them open and closed (see Figure 21). Hidden layers are shown with a colored tab.

Figure 19: Floorplan with chest of drawers
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Figure 20: Using layers for different parts of a drawing. (Left) Draw the body of the chest on 
the Layout layer. (Right) Create a new layer and draw the open drawers and doors, keeping 
the Layout layer visible to help you position the additional objects.

   

Figure 21: Making layers visible or hidden. (Left) Hide the Layout layer to see what is on 
Layer4. (Right) Show the Layout layer and hide Layer4 to show chest with drawers closed.

Caution If you copy a drawing object to the Clipboard or into the Gallery, all layers other 
than the three standard layers (Layout, Controls and Dimension Lines) are lost and 
all objects will be pasted into the Layout layer. The reconstruction of layers is much 
easier if you assemble objects on a layer into a group before copying.

Changing the layer of a drawing object
Draw has no direct command to change layers. To move an object to another layer, change to the 
new layer, select the desired object or group, and then cut and paste it into position. Watch the 
status bar (the selected object’s layer name is shown in the information field) to follow and check 
the change.

You can also click on the object, hold the mouse button pressed for about two seconds until the 
mouse cursor changes from a hand to a pointer with an open rectangle, and then drag and drop it 
on the appropriate layer.
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Creating a multi-page document

Draw documents, like presentation (Impress) documents, can consist of multiple pages. As in 
Impress, tools to manage pages and backgrounds are available.

Pages are automatically named as Slide 1, Slide 2, and so on. This description is relative; if you 
move pages around, they are automatically renumbered. If you want to have fixed slide (page) 
names, you must name them yourself. Page names are useful for working with the Navigator and 
when you want to insert single slides using Insert > File into another document.

Using the Pages area
By default the Pages area is docked on the left of the 
Draw window. It shows every page in the document as a 
small picture. Select a picture from the Pages area and 
the corresponding page is loaded in the main workspace. 
Click on the page to activate it for editing.

The Pages area behaves similar to the Styles and 
Formatting area. Drag on the gray separator line to 
change the width of the Pages pane. Click on the middle 
of this line to show or hide the pane. Double-click with the 
Control key pressed in the upper gray area to dock or 
undock the area, which can be turned into a floating 
window.

In the Pages area you can drag and drop a picture to 
change the order of pages in the document; a black 
horizontal line shows the position where the page will be 
inserted.

Using the context menu you can insert or delete pages or 
duplicate pages with copy and paste (alternatively create 
duplicate pages using Insert > Duplicate Slide on the 
menu).
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Using page backgrounds
With background pages you set common page settings for multiple pages of the Draw document. 
These include setting the color or graphics of the background, background objects, and fields such 
as page numbering and author.

Note

The terms used in this area may not be completely consistent, so that the terms 
Slide/Page and Master/Background/Page Template are used more or less 
interchangeably in places. When looking for information in Help, it may be 
necessary to use alternative search terms.

Creating a page background
Change with View > Master to the Master view and note that a related Master View toolbar opens. 
If this toolbar does not appear, activate it with View > Toolbars. In this toolbar are switches for a 
new background page and for renaming the master page. These functions are also available by 
right-clicking on a page picture in the Pages area of the Master view. The button for deleting a 
master page is only available when you select a background page in the Pages area which has not 
yet been assigned to any page.

Figure 22: Master View toolbar

To return to normal mode, click the Close Master View button or View > Normal.

You can edit background pages just like normal pages. With Format > Page > Background you 
can set the color, pattern, or background picture. These settings are specific to each background 
page. In the Master view, you can set the size and orientation of the page; such settings apply to 
all pages.

If you insert drawing objects on a background page, they are visible on all pages that use this 
background. This a convenient way, for example, to place a logo on every page.

Master pages are organized in layers just like normal pages. The layers of normal pages are 
associated with the layer of the same name on the Master page. Accordingly the layers 
Layout/Control/Dimension Lines are considered to be a unit and the Master page layer Background 
objects is associated with them.

With Insert > Fields you can insert the date, time, page number, author and filename. No other 
fields are available. With page number you cannot insert a fixed page number but only a variable; 
the actual number appears on the page itself and is determined by the position of the page. The 
number is automatically adjusted if the page is subsequently moved.

Assigning and managing page backgrounds
You can open the Slide Design dialog (Figure 23) in two ways:

• Right-click on the page and choose Page > Slide design, or

• Look in the status bar to see which background page is the current one. Double-click in this 
field.

The Slide Design dialog (Figure 23) shows the available background pages for that page.
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Figure 23: Slide design dialog

If the Exchange background page option is selected, the selected background page will be used 
on all pages of the document, not just on the currently active page.

The Delete unused backgrounds option deletes any backgrounds (as shown in the Slide Design 
dialog) that have not been assigned to a page.

Click the Load button to open the Load Slide Design dialog. From here you can load previously 
prepared background pages. All Draw and Impress templates can be used for this purpose. Note, 
however, that using Impress templates will bring in only the background and not the other elements 
prepared in Impress.

Figure 24: Load Slide Design dialog

There is no special option to store background pages as templates. Instead you can load a 
document with the desired background page and store this document as a document template with 
File > Template > Save.

Color palette: adding or changing single colors

Draw (like all LibreOffice components) uses color palettes for the representation of colors. In 
addition you can customize the color palette to suit your own needs and wishes. You can modify 
colors in a palette, add other colors, or create new color palettes.

Color palette: adding or changing single colors 17



Reach these options with Tools > Options > LibreOffice > Colors or with Format > Area > 
Colors (tab) (see Figure 25). The latter method allows color palettes to be loaded or to be stored 
for future use. Any modifications made to colors apply only to the currently active palette.

LibreOffice always uses the RGB color model internally. Other methods are also available for the 
definition of a color value.

The color values can be input directly as numbers. Choose between the RGB color model (base 
colors Red, Green and Blue) and CMYK (base colors Cyan, Magenta, Yellow and Black, K= Key). 
The conversion to RGB values is made automatically.

Tip
Information about color models can be found under:

http://en.wikipedia.org/wiki/Color_model 

Individual color tones are produced by using different values of the base colors. The color value 
can be any integer value between 0 and 255. As an example, Red 3 has  a red value of 184, a 
green value of 71 and a blue value of 0 in the RGB model. The CMYK color model uses 
percentages (in this case 0%, 44%, 72%, and 28% respectively).

Change these values to manipulate the color tone. Either enter a number directly or use the 
spinners on the right side of each field. The change in color will be shown in the lower color field 
(see Figure 25). Click the Modify button to apply and store the new setting.

To add a new color to the current palette, enter a new name in the Name field and set the desired 
color values. Click Add. The new color will be added to the end of the palette and stored in the 
currently active palette.

You can also delete colors from a palette. Select the color from the Color pulldown menu and click 
on the Delete button, then on OK to confirm the change.

Figure 25: The Colors tab in the Area dialog

Click on the Edit button to open a dialog where you can set individual colors (see Figure 26). Many 
more input possibilities are available in this dialog.
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In the lower area you can enter values in the RGB and CMYK models as well as the HSB (Hue, 
Saturation and Brightness) model.

The two color samples at the lower right show the current color (left) and the new color specified by 
the color value fields (right).

Figure 26: Color dialog

The color windows in the upper area permit a direct selection of color without any knowledge of 
color values. The right upper color window is linked directly with the various color model input 
fields; if you click on a color in this window the numbers change accordingly and a preview of the 
color appears in the right of the two color fields (lower right in Figure 26; see also Method 2 below).

If you click OK, the color window is closed and the input field is again active. You can at this stage 
select the color you have just defined,  give it a new name, and store it by clicking the Add button. 
The old color will then (without any further warning) be overwritten.

Changing colors using the Color dialog

Method 1
You can change the current color by modifying the individual color values explicitly. It is possible to 
change from one color model to another during this process but the settings are always calculated 
and stored according to the RGB model. This may result in some slight adjustment to your input 
values in the other models.

The color wheel to the left illustrates the HSB color model. This model 
defines the color tone in terms of three parameters: Hue (possible 
values from 0 to 359), Saturation (possible values from 0 to 100) and 
Brightness (possible values from 0 to 100) is defined. The number for 
the hue represents the angle in the color wheel, the other two are both 
percentage values.
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Method 2
You can select a new color by clicking on a point in the color window at the upper right of the 
dialog. The chosen color is shown in a black frame which can be dragged with the mouse. If this 
color is not quite right, you can fine tune it as described above in Method 1 by changing the color 
values.

As you drag the small square you will see the value change in the 
number fields. The CMYK and RGB are more or less self 
explanatory. To make the HSB model a little clearer, some 
additional comments are necessary.

To better understand the working of the HSB model, move the 
frame from left to right and top to bottom. You will see that the 
Hue and Saturation values swing between their maximum and 
minimum (hue by horizontal movement and saturation by vertical 
movement), but the brightness remains the same (see figure at 
left). This latter can only be adjusted by entering a value into the 
number field.

Method 3
The left color window is divided like a chess board into 8 x 8 individual fields, each with a different 
color. Most important are the colors in each of the corner fields. The color red changes stepwise to 
green in the first row, and stepwise to yellow in the first column. The color green in the last column 
changes stepwise to blue.

This window thus contains a stepwise change between each of the four main colors in the corner 
points. If you hover the mouse over a square the RGB value is shown as a tooltip. For example, 
the yellow corner field (lower left) has RGB values of 255, 255 and 0 (full red, full green and no 
blue).

Click on this yellow field. A frame appears. If you click the -> arrow under the color windows the 
selected color is assigned.

You can change the color spread in this window to a more specific range by changing one or more 
of the corner fields. Click on the corner you want to change, then select the preferred color from 
the right color window with the mouse and/or set it using the number fields. Now click on the <- 
arrow; the new color will be assigned to the corner square you selected  and the overall 
appearance of the window changes accordingly.
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Figure 27: Changing the color of a corner square

Creating cool effects

Duplication
Duplication makes copies of an object while applying a set of 
changes (such as color or rotation) to the duplicates.

To start duplication, click on an object or group and choose 
Edit > Duplicate. The Duplicate dialog (Figure 29) appears.

Figure 29: Duplicate dialog

Choose the number of copies, their separation (placement), rotation, and so on. The choices 
above applied to a blue rectangle produce the result shown in Figure 28.
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Cross-fading
Cross-fading transforms one shape into another. The result is a new group of objects including the 
two end points and the intermediate steps.

Figure 30: Cross-fading example

To do a cross-fade, first select two objects.

Figure 31: The two objects 
selected for cross fading

Then choose Edit > Cross-fading.

Figure 32: Cross-fading dialog

On the dialog choose the number of increments (transition steps). You probably want to have 
Cross-fade attributes and Same orientation both checked. The end result is shown in Figure 30.

Which object goes in front?

How do I tell Draw that I want  and not ?

Select  (the object we want in front), right-click and choose Arrange > Bring to Front (or press 

Ctrl+Shift+plus). Or select  (the object we want behind), right-click and choose Arrange > 
Send to Back or press Ctrl+Shift+minus.
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