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What is Writer?

Writer is the word processor component of LibreOffice, a freely available, fully-featured office 
productivity suite. In addition to the usual features of a word processor (text entry, editing, and 
formatting; spelling checker, thesaurus, hyphenation, and autocorrect; find and replace; and 
others), Writer provides these important features:

• Change tracking during revisions (Chapter 4)

• Page layout methods, including styles, frames, columns, and tables (Chapters 5 and 6)

• Export to PDF and ePub (Chapter 7)

• Document digital signatures (Chapter 7)

• Templates and styles (Chapters 8, 9, and 10)

• Built-in drawing tools (Chapter 11)

• Lists (Chapter 12)

• Tables (Chapter 13)

• Mail merge (Chapter 14)

• Automated tables of contents and indexes (Chapter 15)

• Master documents, to group several documents into a single document (Chapter 16)

• Fields and forms (Chapters 17 and 18)

• Database integration, including a bibliography database (Chapters 14, 15, and 18)

• Embedding or linking of spreadsheets, equations, and other objects (Chapter 19)

• And many more

Parts of the main Writer window

The main Writer window is shown in Figure 1. Its features are described in this section.

Note

By default, LibreOffice Writer’s commands are grouped in menus and toolbars, as 
described in this section. In addition, Writer provides other user interface variations, 
displaying contextual groups of commands and contents. For more information, see 
the Help and Chapter 20, Customizing Writer.

Title bar
The Title bar is located at the top of the Writer window. It shows the file name of the current 
document. When the document is not yet named, the document name will appear as Untitled X, 
where X is a number. Untitled documents are numbered in the order in which they are created.

Menu bar
The Menu bar is located just below the Title bar in Windows and Linux and at the top of the 
screen in macOS. When you select one of the menus, a submenu drops down to show further 
options, including:

• Commands that directly cause an action, such as Close or Save in the File menu.

• Commands that open dialogs. These are indicated by three dots following a command, 
such as Find and Replace... in the Edit menu.
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• Commands that open further submenus. These are indicated by a right-pointing arrow 
following a command, such as Toolbars and Zoom, in the View menu. Moving the 
mouse pointer onto one of these items opens its submenu.

Figure 1: Parts of the main Writer window

Sidebar
The Sidebar is normally open by default on the right side of the Writer window, as shown in 
Figure 1. If necessary, select View > Sidebar on the Menu bar to display it. The Sidebar also has
a Hide/Show icon, as shown in Figure 2. When the Sidebar is closed, this icon is on the far right 
of the window; click it to open the Sidebar.

The Writer Sidebar contains seven decks by default: Properties, Styles (also shown as Styles 
and Formatting in some installations), Gallery, Navigator, Page, Style Inspector, and Manage 
Changes. Each deck can be opened by clicking its corresponding icon on the Tab bar to the right 
of the sidebar.

Each deck consists of a title bar and one or more content panels. A panel is like a combination of 
toolbar and dialog. Toolbars and Sidebar panels share many functions. For example, the icons 
for making text bold or italic exist in both the Formatting toolbar in the main Writer window and 
the Character panel of the Properties deck.

Some panels contain a More Options button, which opens a dialog with additional editing 
controls. When the dialog is open, the document is locked for other editing.

To adjust the width of the Sidebar, place the mouse pointer on its left edge. When a double-
headed arrow appears, click and drag to right or left. You cannot make the Sidebar smaller than a
certain width, which varies depending on which deck is open.

To undock the Sidebar and make it floating, and to dock a floating Sidebar, use the drop-down list
in the Sidebar Settings located above the Tab bar (see Figure 3). In the same list, you can use 
the Customization menu to choose which tabs you want to include in the Sidebar.
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Figure 2: Properties deck of Sidebar

Figure 3: Sidebar Settings menu

The decks contained in the Writer Sidebar are described below.

Properties deck: Contains tools for directly formatting content.

When text is selected, these panels appear:

– Style: Apply, create, or update a paragraph style.

– Character: Modify text properties such as the font name, size, color, weight, or 
character spacing.

– Paragraph: Modify a paragraph’s alignment, background color, indent, and spacing, 
and toggle numbered or bulleted lists.

When the cursor is in a table, this panel appears in addition to the panels for text:

– Table: Modify table properties such as insert or delete rows, merge or split cells, 
define row height and column width, background color or image, and borders.
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When a graphic or image is selected, these panels appear:

– Area: Modify the fill mode and transparency of the background.

– Wrap: Modify the position of the graphic relative to surrounding text, where these 
modifications are available.

– Image: Modify the graphic's brightness, contrast, color mode, or transparency.

– Position and Size: Modify width, height, rotation, or flip.

When a drawing object is selected, these panels appear:

– Area: Modify the fill mode and transparency of the background.

– Position and Size: Modify width, height, rotation, or flip.

– Line: Modify arrows, line style, width, color, or transparency.

– Effect: Add and adjust a Glow or Soft Edge effect to the object.

When a frame is selected, these panels appear:

– Area: Modify the fill mode and transparency of the background.

– Wrap: Modify the position of the graphic relative to surrounding text, where these 
modifications are available.

When a video or audio clip is selected, these panels appear:

– Media Playback: Control for play, pause, stop, seek, loop, and volume.

– Position and Size: Modify width and height.

Styles deck: Manage the styles used in the document, apply existing styles, create new styles, 
or modify them. For more information, see Chapter 8, Introduction to Styles, and Chapter 9, 
Working with Styles.

Gallery deck: Shows images and diagrams included in the Gallery themes. The Gallery has two 
sections: the first lists the themes by name (Arrows, Bullets, Diagrams, and so on) and the 
second displays the images in the selected theme. For more information on using the Gallery to 
add images to a document, create new themes and add your own images, see Chapter 11, 
Images and Graphics.

Navigator deck: Browse the document and reorganize its content by selecting content 
categories, such as headings, tables, frames, images, and so on. For more information, see 
“Using the Navigator” on page 23.

Page deck: Contains tools for formatting the page style. It has four panels:

– Format: Modify size, width, height, orientation, and margins of the page.

– Styles: Modify page numbering style, background, layout, and number of columns.

– Header: Activate/deactivate header and modify its margins, spacing, and contents.

– Footer: Activate/deactivate footer and modify its margins, spacing, and contents.

Note

Changing the options on the Page deck modifies the page style in use, affecting not 
only the current page but all pages using the same page style in this document.

Style Inspector deck: Displays all the attributes of paragraph styles, character styles, and 
manual (direct) formatting for selected text. For more information, see Chapter 7, Working with 
Styles.

Manage Changes deck: Lists tracked changes that have not yet been accepted or rejected. For 
more information, see Chapter 3, Working with Text: Advanced.
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Toolbars
Toolbars can be docked (fixed in place) or floating. Docked toolbars can be moved to different 
locations or made to float, and floating toolbars can be docked.

Displaying or hiding toolbars
To display or hide toolbars, go to View > Toolbars on the Menu bar, then click the name of a 
toolbar in the drop-down list. An active toolbar shows a check mark beside its name. Note that 
toolbars created from tool palettes are not listed in the View menu.

To hide a toolbar, go to View > Toolbars on the Menu bar and deselect the toolbar, or right-click 
in an empty space between the icons on a toolbar and select Close Toolbar in the context menu.

Most-used toolbars
In a default LibreOffice installation (Figure 1), the top toolbar, just under the Menu bar, is called 
the Standard toolbar.

The second toolbar at the top is the Formatting toolbar. It is context-sensitive; that is, it shows the
tools relevant to the current position of the cursor or the selected object. For example, when the 
cursor is in text, the Formatting toolbar provides tools for formatting text. When the cursor is on a 
graphic (image), the tools are for formatting images.

Other toolbars are discussed in the relevant chapters of this book.

To free more space for the document, you can choose a single-toolbar alternative containing the 
most-used commands. To activate it, select View > User Interface > Single Toolbar.

Sub-menus and tool palettes
Toolbar icons with a small triangle to their right will display sub-menus, tool palettes, or other 
methods of selecting items, depending on the icon.

A tool palette is a pop-up collection of tools attached to a single tool in a toolbar. The palette can 
be made into a floating toolbar, as shown in Figure 4. Once removed from the parent toolbar, it 
displays a Title bar. Tool palettes can be floating or docked along an edge of the screen or in one 
of the existing toolbar areas.

  

Figure 4: Example of tearing off a tool palette: click on 
the dots and drag to form a floating toolbar

Tip

If you cannot see the dots at the top of the tool palette, you need to unlock the 
toolbar before you can float the palette. See “Locking and unlocking toolbars” below.
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Locking and unlocking toolbars
You can lock all toolbars, or individual toolbars, into place so they cannot be moved. When all 
toolbars are locked, you cannot unlock individual ones.

To lock all toolbars in place, go to View > Toolbars on the Menu bar and select Lock Toolbars 
at the bottom of the submenu. You will need to restart LibreOffice for this change to take effect. 
To unlock all toolbars, click on Lock Toolbars again.

To lock an individual toolbar into place, be sure Lock Toolbars is not selected on View > 
Toolbars, then right-click on the toolbar and select Lock Toolbar Position in the context menu.

Moving toolbars
Docked toolbars are indicated by dotted handles on the left end (Figure 5). They can be 
undocked and moved to a new docked position or left as a floating toolbar.

To undock a toolbar:

1) Move the mouse pointer over the toolbar handle, which is the small vertical bar to the left 
of a docked toolbar, as shown in Figure 5.

2) Click and hold down the left mouse button and drag the toolbar to a new location.

3) Release the mouse button.

Figure 5: Toolbar handles

To move a floating toolbar, click and hold down its title bar and drag it to a new floating location or
dock the toolbar at the top or bottom of the main window.

To dock a floating toolbar, hold down the Ctrl key and double-click in the title bar of the toolbar.

Tip

If the toolbar handle is not displayed, its position is locked. To unlock the toolbar, 
right-click it and then deselect the option Lock Toolbar Position.

Floating toolbars
Writer includes several toolbars, whose default settings correspond to the current position of the 
cursor or selection (when toolbars are made active). For example, when the cursor is in a table, 
the Table toolbar appears, and when the cursor is in a numbered or bulleted list, the Bullets and 
Numbering toolbar appears. You can reposition or dock these toolbars as described in “Moving 
toolbars” above.

To position a toolbar, do any of the following:

• Right-click somewhere in the floating toolbar and click Dock Toolbar in the context 
menu. You can reposition the toolbar to a different docked position. See “Moving 
toolbars” on page 10.

• Click Dock All Toolbars to dock all floating toolbars.

• Click Lock Toolbar Position to lock a docked toolbar into its position. Locking maintains 
the toolbar’s position even when other toolbars on the same bar change location.

• Click Close Toolbar to close the selected toolbar.
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Customizing toolbars
You can customize toolbars in several ways, including choosing which icons are visible and 
locking the position of a docked toolbar. You can also add icons and create new toolbars, as 
described in Chapter 20, Customizing Writer. To access a toolbar’s customization options, right-
click anywhere on the toolbar to open a context menu.

• To show or hide icons defined for the selected toolbar, move the mouse pointer to Visible
Buttons in the context menu. Visible icons are indicated by an outline around the icon or 
by a check mark beside the icon (Figure 6), depending on your operating system. Select 
or deselect icons to hide or show them on the toolbar.

• To open the Customize dialog, click Customize Toolbar or choose View > Toolbars > 
Customize. See Chapter 20, Customizing Writer, for more information.

Figure 6: Toolbar context menu and selection of visible toolbar icons:
1) Right-click anywhere on the toolbar; 2) Point to Visible Buttons; 
3) Visible icons are marked.

Rulers
The horizontal ruler across the top of the workspace is visible by default but the vertical ruler on 
the left is hidden by default. To enable the vertical ruler, choose View > Rulers > Vertical Ruler 
on the Menu bar, or choose Tools > Options > LibreOffice Writer > View (macOS: LibreOffice 
> Preferences > LibreOffice Writer > View). To quickly show or hide both rulers, use the key 
combination Ctrl+Shift+R.
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Tip

The horizontal ruler has a comments button on its right end; click this to quickly show
or hide any comments.

Status bar
The Writer Status bar is located at the bottom of the workspace. It provides information about the
document and convenient ways to quickly change some document features. It can be hidden by 
deselecting it in the View menu.

Figure 7: Writer Status bar, left end

Figure 8: Writer Status bar, right end

Document changes status
This icon changes color to indicate whether the document has unsaved changes. You can
click this icon to save the document.

Page number
Shows the sequence number of the current page, the total number of pages in the 
document, and the current page number (if different from the sequence number). For 
example, if you restarted page numbering at 1 on the third page, its page number is 1 and
its sequence number is 3.

If any bookmarks have been defined in the document, you can right-click this field to show
a list of bookmarks. Click a bookmark to move the cursor to that location in the document.

To jump to a specific page in the document, left-click this field to open the Go to Page 
dialog (Figure 14 on page 23). Type the desired page number and click OK.

Word and character count 
The word and character counts of the document are shown in the Status bar, and are 
updated as you edit. If you select a portion of text, the count for that selection will 
temporarily replace the document total count.

The character count shown here includes spaces. To display the character count 
excluding spaces, click on this field or choose Tools > Word Count on the Menu bar.

You can also see the number of words and characters (and other information including 
the number of pages, tables, and images) in the entire document in File > Properties > 
Statistics.

Page style
Shows the page style of the current page. To select a different page style, right-click on 
this field. A list of page styles pops up; click on one to select it. To edit the attributes of the
current page style, left-click on this field. The Page Style dialog opens.
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Caution

Changing the page style here may affect the styles assigned to other pages, 
depending on how the page styles are set up. See Chapters 8 and 9 for details.

Text Language
Shows the language and localization used for spelling, hyphenation, and the thesaurus. It 
is based on the position of the cursor or the selected text.

Click to open a menu where you can choose another language/localization for the 
selected text or for the paragraph where the cursor is located. You can also choose None 
(Do not check spelling) to exclude the text from a spelling check or Reset to default 
language. Choosing More...  opens the Character dialog. See Chapter 3, Working with 
Text: Basics, for more information.

Insert mode
Click to change to Overwrite mode; click again to return to Insert mode. In Insert mode, 
any text after the cursor position moves forward to make room for the text you type; in 
Overwrite mode, text after the cursor position is replaced by the text you type. You cannot
switch modes when Edit > Track Changes > Record is active.

Selection mode
Click to display a list of the selection modes (Standard, Extending, Adding, and Block), 
then click on one to activate it. The icon changes to indicate the mode, and a tooltip 
shows which mode is active. See Chapter 3, Working with text: Basics, for more 
information.

Digital signature
If the document has been digitally signed, an icon is displayed here; otherwise, it is blank.
Click here to sign the document or to view the existing certificate. See Chapter 7, Printing,
Exporting, Emailing, Signing, for more information.

Section or object information
When the cursor is in a section, heading, or list item, or when an object (such as a picture
or table) is selected, information about that item appears in this field. Clicking in this area 
opens a relevant dialog.

Table 1: Section or object information in Status bar

Object Information shown Dialog opened

Image Size and position Image

List item Level and list style Bullets and Numbering1

Heading Outline numbering level Bullets and Numbering1

Table Name or number and cell reference of 
cursor

Table Format

Section Name of section Edit Sections

Other (Blank) Fields

View layout
Click the corresponding icon to change between single-page, multiple-page, and book 
layout views (Figure 9). You can edit the document in any view. Zoom settings interact 
with the selected view layout and the window width to determine how many pages are 
visible in the document window.

1 If a list style was used with a list item or heading, no dialog appears.
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Figure 9: View layouts: single-page, multiple-page, book

Zoom
To change the view magnification, drag the Zoom slider, or click the + and − signs, or 
right-click the zoom level percent to pop up a list of magnification values from which to 
choose. Zoom interacts with the selected view layout to determine how many pages are 
visible in the document window.

Context (right-click) menus

Context menus provide quick access to many menu functions. They are opened by right-clicking 
on a paragraph, graphic, or other object. When a context menu opens, the functions or options 
available will depend on the object that has been selected. This can be the easiest way to reach 
a function, especially if you are not sure where the function is located in the menus or toolbars.

Dialogs

A dialog is a special type of window. Its purpose is to inform you of something, or request input 
from you, or both. It provides controls for you to specify how to carry out an action.

In most cases, you can interact only with the dialog (not the document itself) as long as the dialog
remains open. When you close the dialog (usually, clicking OK or a similar button saves your 
changes and closes the dialog; clicking Cancel closes the dialog without saving any changes), 
then you can again work with the document.

Some dialogs can be left open as you work, so you can switch back and forth between the dialog
and your document. An example of this type is the Find & Replace dialog.

Document views

Writer has three ways to view and edit a document: Normal, Web, and Full Screen. To change 
the view, go to the View menu and select the required view.

Normal view
Normal view is the default view in Writer. It shows how the document will look when you 
print it or create a PDF. In this view, you can use the Zoom slider and the View Layout 
icons on the Status bar to change the magnification. You can also hide or show the 
headers and footers and the gap between pages, by selecting View > Show Whitespace
on the Menu bar. This works only when single-page view is active on the Status bar. 
Hiding whitespace also works in Full Screen view.
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Web view
Web view shows how the document will look if viewed in a Web browser; this is useful 
when you create HTML documents. In Web view, you can use only the Zoom slider. The 
View Layout icons on the Status bar are disabled, and most of the choices on the Zoom &
View Layout dialog are not available.

Full Screen view
In Full Screen view, no toolbars or sidebar are displayed; the document takes up the full 
area available, using the zoom and layout settings previously selected. To exit Full Screen
view and return to the previous view, press the Esc key or click the Full Screen button on
the floating toolbar in the top left-hand corner. You can also use Ctrl+Shift+J to enter 
or exit Full Screen view.

Tip

You can also view a document using File > Print Preview, or press Ctrl+Shift+O, 
but this view does not allow editing. See Chapter 7, Printing, Exporting, Emailing, 
Signing.

Starting a new document

You can start a new, blank document in Writer in several ways. If a document is already open in 
LibreOffice, the new document is created in a new window.

• When LibreOffice is running but no document is open, the Start Center (Figure 10 on 
page 16) is shown. Click one of the icons to open a new document of that type, or click 
the Templates icon to start a new document using a template.

• Use File > New on the Menu bar and select the type of document in the submenu.

• When Writer is open, use the keyboard shortcut Ctrl+N to create a new Writer 
document.

• If a document is already open in LibreOffice, click the New icon on the Standard toolbar 
and a new document of the type shown on the icon is created in a new window. The New
icon changes depending on which component of LibreOffice was last created.

• If a document is already open in LibreOffice, click on the small triangle to the right of the 
New icon on the Standard toolbar and select the type of document in the context menu.

From the Start Center
When LibreOffice is open but no document is open, the Start Center (Figure 10) is shown. Click 
Create: Writer Document to create a new text document, or click Templates and choose a 
template to start a new document using a template other than the default template.

To filter the collection of documents shown, select a document type in the Filter drop-down list. To
remove from the list any documents that are no longer available (for example, if they have been 
renamed or moved in the file system on your computer or network), use the drop-down on the top
right.
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Figure 10: LibreOffice Start Center

From a template
A template is a set of predefined styles and settings that is used to create a new document. 
Templates enable the easy creation of multiple documents with the same default settings. For 
example, all the chapters of the Writer Guide are based on the same template. As a result, all the
chapters look alike; they have the same headers and footers, use the same fonts, and so on.

A new LibreOffice installation may contain only a few templates, but you can create your own or 
download more from https://extensions.libreoffice.org/ and other websites. See Chapter 10, 
Working with Templates.

To open the Template dialog, where you can choose the template you want to use for creating 
your document, do one of the following:

• Press the Ctrl+Shift+N keys.

• Choose File > Templates > Manage Templates on the Menu bar.

• Choose File > New > Templates on the Menu bar.

• Click the arrow next to the New icon on the Standard toolbar and select Templates in the
drop-down list.

The example shown in Figure 11 highlights a template in the Documents folder. Double-click the 
desired template to create a new document based on that template. You can also right-click one 
of the templates and then click Open. For more about the Templates dialog, see Chapter 10, 
Working with Templates.
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Figure 11: Creating a document from a template

Opening an existing document

You can open an existing document in several ways.

When no document is open:

• Click Open File or Remote files in the Start Center.

• Choose File > Open or File > Open Remote on the Menu bar.

• Press Ctrl+O on the keyboard.

• Click a thumbnail in the list of recently opened documents displayed in the Start Center. 
You can scroll up or down in the Start Center to locate a recently opened document.

Note

Renamed or relocated documents can still be listed in the Start Center. Selecting 
one gives an error message that the file does not exist. To remove the thumbnail 
from the Start Center, hover the mouse pointer over the thumbnail until an X appears
in the upper right corner, and then click on the X.

If a document is already open:

• Click the Open icon on the Standard toolbar.

• Click the small triangle to the right of the Open icon and select from a list of recently 
opened documents, or select Open Remote File.

• Use File > Recent Documents to make a selection from the submenu.

When using the Open dialog, navigate to the folder you want, select the file, then click Open. If a 
document is already open in LibreOffice, the second document opens in a new window.
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You can reduce the list of files in the Open dialog by selecting the type of file you are looking for. 
For example, if you choose Text documents as the file type, you will only see documents that 
Writer can open. This method opens Word (.doc and .docx) files and other formats as well as 
OpenDocument (.odt).

You can also open an existing Writer document using the same methods you would use to open 
any document in your operating system.

Opening files not in OpenDocument Text (.odt) format
You can open an existing document that is in a format that LibreOffice recognizes by double-
clicking on the file icon on the desktop or in a file manager such as Windows Explorer or macOS 
Finder. LibreOffice may need to be associated with file types that are not ODF files for the 
appropriate LibreOffice component to open.

For example, on a Windows computer, if you do not have Microsoft Office installed or if Microsoft 
Office is installed but you have associated Microsoft Word file types (*.doc or *.docx) with 
LibreOffice, then when you double-click on a Word file, it opens in LibreOffice Writer.

If you did not associate the file types with LibreOffice, and Microsoft Office is installed on your 
computer, then when you double-click on a Microsoft Word file, it opens in Microsoft Word.

On macOS, if Microsoft Office is not installed and you have not associated those file types with 
LibreOffice, double-clicking a file may open it in Apple’s Pages application.

To avoid files opening in the wrong application, do not double-click on them; instead, right-click 
on the file and select Open with > LibreOffice.

See the LibreOffice Help for more about file associations.

Saving a document

You can save a document using any of the following commands:

• Save – use if you are keeping the document, its current filename and location.

• Save As – use to create a new document, or change the filename and/or file format, or 
save the file in a different location on your computer.

• Save Remote – use if your document is already stored in a remote server or will be 
stored in a remote server.

• Save a Copy – use to save a copy of your current document and keep the current 
document open for more editing.

• Save All – use to save all the files open in your current session.

Save commands

Save a new file or a previously-saved file
Do one of the following:

• Press Ctrl+S.

• Choose File > Save on the Menu bar.

• Click the Save icon on the Standard toolbar.

If the file has not been saved previously, a Save As dialog appears after selecting one of the 
above options. Enter the file name, verify the file type and location, and click Save.

If a previously-saved file is being saved with the same file name, file type, and location, nothing 
else needs to be done.
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Save to a remote server
Use this command if your document is already stored on a remote server or you want to store it 
on a remote server. Choose File > Save Remote. When the Save As dialog appears, enter or 
verify the name, type, and location, then click Save.

See “Opening and saving files on remote servers” on page 22 for more information.

Save a copy
Use this command if you want to keep the document open for more editing and also save 
a separate copy of the current version.

Choose File > Save a Copy. When the Save As dialog appears, enter or verify the 
name, type, and location, then click Save. The copy is not opened and the original file 
remains open and active.

Save all
Use this command to save all files open in the current session.

Choose File > Save All. All open files will be saved without changes to name, type, or location.

Save As command
Use this command if you want to save the current version as a new document by changing the 
file name or file type, or by saving the file in a different location on your computer.

Choose File > Save As, or use Ctrl+Shift+S to open a Save As dialog where you can change the
file name, type, or location, and click Save.

If you want to preserve the original file, first save a copy as described above.

Note

LibreOffice uses the term “export” for some file operations involving a change of file 
type, such as PDF and ePub. See Chapter 7, Printing, Exporting, E-mailing, for more
information.

Saving documents automatically
You can choose to have Writer save documents automatically in a temporary file at regular 
intervals. To set up automatic file saving:

1) Select Tools > Options > Load/Save > General on the Menu bar (macOS: LibreOffice 
> Preferences > Load/Save > General). (See also Chapter 20, Setting Up Writer.)

2) Click Save AutoRecovery information every and set the time interval. The default value
is 10 minutes. Enter the value you want by typing it or by pressing the up or down arrow 
keys.

3) You may also wish to select Always create backup copy.

4) Click OK to save the changes.

5) You will be prompted to restart LibreOffice. You can choose to restart immediately or later.
The changes will be active after the restart.

Saving as a Microsoft Word document
You may need to save documents in Microsoft Word formats such as .docx. To do this:

1) Important: If your file is in Writer’s format (.odt), first save your document in that format. 
If you do not, any changes you made since the last time you saved will only appear in the 
Microsoft Word version of the document.
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2) Then click File > Save As.

3) On the Save As dialog, in the File type drop-down menu, select the type of Microsoft 
Word format you need. You may also choose to change the file name.

4) Click Save.

This creates a separate document with a different file extension. From this point on, all changes 
you make to the document will occur only in the new document. If you want to go back to working
with the .odt version of your document, you must open it again.

Tip

To have Writer save documents by default in a Microsoft Word file format, go to 
Tools > Options > Load/Save > General (macOS: LibreOffice > Preferences > 
Load/Save > General). In the section named Default File Format and ODF Settings, 
next to Document type, select Text document, then under Always save as, select 
your preferred file format.

Exchanging documents with users of Apple Pages
Although Writer can open and edit files in Apple Pages format (*.pages), it cannot save in that 
format or export to that format. Apple Pages cannot open files in OpenDocument format, so if you
need to share files with users of Pages, save your .odt file to a compatible format, such as
.rtf or .docx.

Pages users can also export (not save) a copy of a Pages document in a format compatible with 
Writer, such as .docx or .rtf, which writer can then open, edit, and save to.

Using password protection and OpenPGP encryption

LibreOffice provides two types of document protection: password protection and OpenPGP 
encryption. Files encrypted with the Save password cannot be decrypted without the password, 
which must be sent to each user who needs to decrypt the document. With OpenPGP encryption,
the document is encrypted using an algorithm, which requires a key. Each key is used only once 
and is sent to the recipient along with the document.

Password protection
LibreOffice provides two levels of password protection: read-protect (file cannot be viewed 
without a password) and write-protect (file can be viewed in read-only mode but cannot be 
changed without a password). Thus you can make the content available for reading by one group
of people and for reading and editing by a different group. This behavior is compatible with 
Microsoft Word file protection.

To protect a document with passwords:

1) Use File > Save As when saving the document. (You can also use File > Save the first 
time you save a new document.)

2) On the Save As dialog, select the Save with password option in the lower left corner 
(Figure 12), and then click Save.

20 | Chapter 1, Introducing Writer



Figure 12: Save with password and Encrypt with GPG key options

3) The Set Password dialog opens (Figure 13). Here you have several choices:

– To read-protect the document, type a password in the two fields at the top of the 
dialog.

– To write-protect the document, click the Options button and select Open file read-
only in the File Sharing Password section.

– To write-protect the document but allow selected people to edit it, select Open file 
read-only and type a password in the two boxes at the bottom of the dialog.

Figure 13: Two levels of password protection

4) Click OK to save the file. If either pair of passwords does not match, you receive an error 
message. Close the message box to return to the Set Password dialog and enter the 
password again.

Caution

LibreOffice uses a very strong encryption mechanism that makes it almost 
impossible to recover the contents of a document if you lose the password.

Changing or removing the password for a document

When a document is password-protected, you can change or remove the password while the 
document is open. Choose File > Properties > General and click the Change Password button.
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OpenPGP encryption
LibreOffice uses the OpenPGP software installed on your computer. If no OpenPGP software is 
available, you must download and install one suitable for your operating system before you can 
use this option.

You must define a personal pair of cryptography keys with the OpenPGP application. Refer to the
OpenPGP software installed on how to create a pair of keys. For more information on using this 
form of encryption, see the supplied Help.

OpenPGP encryption requires the use of the public key of the recipient; this key must be 
available in the OpenPGP key chain stored in your computer.2

To encrypt a document:

1) Choose File > Save As,

2) In the Save As dialog, enter a name for the file.

3) Select the Encrypt with GPG key option (see Figure 12).

4) Click Save. The OpenPGP public key selection dialog opens.

5) Choose the public key of the recipient. You can select multiple keys.

6) Click OK to close the dialog and save the file encrypted with the selected public keys.

Opening and saving files on remote servers

LibreOffice can open and save files stored on remote servers (that is, not on your computer or 
local area network). Keeping files on remote servers allows you to work with the documents 
using different computers. For example, you can work on a document in the office and also at 
home or elsewhere. Storing files on a remote server also backs up documents, saving data from 
computer loss or hard disk failure. Some servers are also able to check files in and out, thus 
controlling their usage and access.

LibreOffice supports many document servers that use well-known network protocols such as 
FTP, WebDav, Windows share, and SSH. It also supports popular services like Google Drive and 
Microsoft OneNote, as well as commercial and open source servers that implement the OASIS 
CMIS standard. For more information, see the Getting Started Guide.

Moving quickly through a document

Writer provides ways to move quickly through a document and find specific items, including:

• Go to Page

• Navigator

• Outline folding

• Reminders

Using Go to Page
You can jump to a specific page in the document in these ways:

• Use the Go to Page field on the top right of the Navigator (see below).

• Use the Go to Page dialog (Figure 14), which shows the current page number and the 
number of pages in the document. Type the number of the destination page in the text 
box and click OK. 

2 GPG (GNU Privacy Guard) is an implementation of the Open PGP standard.
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To open the Go to Page dialog, do any of the following:

– Click on the page number field on the Status Bar.

– Choose Edit > Go to Page on the Menu bar.

– Press Ctrl+G on the keyboard.

Figure 14: Go to Page dialog

Using the Navigator
In a default installation of LibreOffice, the Navigator is part of the Sidebar. It lists all of the 
headings, tables, text frames, graphics, bookmarks, and other objects contained in a document.

To open the Navigator (Figure 15), do one of the following:-

• Click the Navigator tab in the Tab bar on the right of the Sidebar.

• Click the Navigator icon (if visible) on the Standard toolbar.

• Press F5.

• Choose View > Navigator on the Menu bar.

Click the + sign or triangle to the left of a category or subcategory to display its contents.

Table 2 summarizes the functions of the icons at the top of the Navigator.

Note

In a master document, the Navigator has different functions. See Chapter 16, Master
Documents.

The Navigator provides several convenient ways to move around a document and find items in it:

• To jump to a specific page in the document, type its sequence number in the box at the 
top of the Navigator and press Enter. The sequence number may be different from the 
page number if you have restarted numbering at any point.

• When a category is opened to show the list of items in it, double-click an item to jump 
directly to that item’s location in the document. For example, you can jump directly to a 
selected heading, graphic, or comment by using this method.

• To see the contents in only one category, highlight that category and click the Content 
Navigation View icon. Click the icon again to display all the categories. You can also 
change the number of heading levels shown when viewing Headings.

• Use the Previous and Next icons to jump to other objects of the type selected in the 
Navigate By drop-down list.

• In the top left of the Navigator is a Navigate By drop-down list. You can pick a type of 
object (such as a bookmark, table, or index entry) and then use the Previous (^) and Next
(v) buttons to jump from one to the next (Figures 15 and 16).
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Figure 15: The Navigator in the Sidebar

Table 2: Function of icons in the Navigator

1 Navigate By
Opens a drop-down list where you can select the type of 
element by which you want to navigate.

2 Header/Footer
Jumps between the text area and the header or footer area 
(if the page has them).

3 Anchor <–> Text
Jumps between a footnote anchor and the corresponding 
footnote text.

4 Set Reminder Inserts a reminder. See “Setting reminders” on page 25.

5 Previous/Next
Jumps to the previous/next element of the type selected in 
the Navigate By drop-down list.

6 Go to Page
Jumps to the page number shown in the box. Type a page 
number or select it using the + and – signs.

7
Content Navigation 
View

Switches between showing all categories and showing only 
the selected category.

8 List Box On/Off Toggles between having the list box shown or hidden.

9
Heading Levels 
Shown

Choose the number of heading levels to be shown.

10 Drag Mode
Select Insert as Hyperlink, Link, or Copy. See Chapter 3, 
Working with Text: Advanced.

11
Promote/Demote 
Level

Quickly change the level of the selected heading in the 
document. See Chapter 3, Working with Text: Advanced.

12
Promote/Demote 
Chapter

Move headings and text in the document. See  Chapter 3, 
Working with Text: Advanced.

Note

A hidden section (or other hidden object) in a document appears gray in the 
Navigator, and displays the word “hidden” as a tooltip. For more about hidden 
sections, see Chapter 6, Formatting Pages: Advanced.

24 | Chapter 1, Introducing Writer



Figure 16: Navigate By list on Navigator

Tip

Objects are much easier to find if you give them identifying names when creating 
them. By default, LibreOffice gives objects names such as Image1, Image2, Table1, 
Table2, and so on. These names are assigned in the order in which the objects are 
added to the document, which may not correspond to the location of the object in the
document.

You can rename objects after inserting them. For example, to rename an image, 
right-click its name in the Navigator, choose Image in the context menu, then choose
Image > Rename. The view jumps to the image (to show which one it is) and a small
dialog pops up. Type a new name for the image and click OK to save.

You can also right-click the image and select Properties. In the Image dialog, go to 
the Options page, edit the name, and click OK.

Using outline folding
Using outline folding, you can hide and show all content under headings, including text, images, 
tables, frames, shapes, and text boxes. In large documents, this feature can help you quickly 
scroll to the right position for editing and reading.

To enable this feature, go to Tools > Options > LibreOffice Writer > View (macOS: LibreOffice 
> Preferences > LibreOffice Writer > View and select Show outline-folding buttons. Optionally 
select Include sub levels. 

Outline folding works with the Navigator and directly using a mouse. For more information, see 
Chapter 3, Working with Text: Advanced.

Setting reminders
Reminders let you mark places in your document that you want to return to later on, for example 
to add or correct information or simply mark where you finished editing. 

To set a reminder at the cursor’s current location, click the Set Reminder icon in the Navigator. 
You can set up to 5 reminders in a document; setting a sixth causes the first to be deleted.
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Reminders are not highlighted in any way in the document, nor are they listed in the Navigator, 
so you cannot see where they are, except that when you jump from one to the next, the location 
of the cursor shows the location of the reminder.

To jump between reminders, first select the Reminder option in the Navigate By drop-down list. 
Then click the Previous and Next icons. 

Reminders are not saved with the document.

Undoing and redoing changes

To undo the most recent change in a document, press Ctrl+Z, choose Edit > Undo on the 
Menu bar, or click the Undo icon on the Standard toolbar. 

To get a list of all the changes that can be undone, click the small triangle to the right of the Undo
icon on the Standard toolbar. You can select several sequential changes on the list and undo 
them at the same time (Figure 17).

Figure 17: List of actions that can be undone

After changes have been undone, Redo becomes active. To redo a change, select Edit > Redo, 
or press Ctrl+Y or click the Redo icon on the Standard toolbar. As with Undo, click the down 
arrow icon of the combination icon to get a list of the changes that can be restored.

Displaying multiple views of a document

You can open, view, and edit several views of the same document in LibreOffice at the same 
time. These views are displayed in windows that can show different pages or use different zoom 
levels or other settings. A change to the document in one window is immediately reflected in the 
other windows. In Writer, for example, you might find this useful for copying or moving 
information from one page to another.

To open a new window showing the document, go to Window > New Window on the Menu bar. 
In each window opened, the filename in the title bar is automatically numbered as shown by the 
example in Figure 18.

If other LibreOffice documents are open at the same time, the list of windows also includes them.
The active window has a marker by its filename in the list. You can switch between windows by 
clicking on a name in the list, or by clicking on the window itself if it is visible on the display.

To close the active window, go to Window > Close Window on the Menu bar, or use the 
keyboard shortcut Ctrl+W, or click the Close icon on the Menu bar or Title bar of the window.
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Figure 18: List of open windows

Reloading a document

Reloading is useful in two situations.

• To discard all the changes made in an editing session after the last document save.

• To show any formatting changes that do not show until the document has been closed 
and reopened; saving and then reloading has the same result.

To reload a document, go to File > Reload on the Menu bar. If you have made changes to a file 
since the last save, a confirmation dialog will warn you that reloading will discard your last 
changes. Choose whether to save or discard the changes.

Closing a document

To close a document, go to File > Close on the Menu bar or click the X on the right or left end of 
the Menu bar (in Windows and Linux) or the Title bar (in macOS). When you close the last 
document in Windows or Linux, the LibreOffice Start Center opens. In macOS, only the Menu bar
remains at the top of the screen.

If the document has not been saved since the last change, a message box is displayed. Choose 
whether to save or discard your changes.
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