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OLE objects

Object Linking and Embedding (OLE) is a software technology that allows linking and embedding
of the following types of files into an Impress presentation.

LibreOffice spreadsheets
LibreOffice charts
LibreOffice drawings
LibreOffice formulas
LibreOffice text

The major benefit of using OLE objects is that it provides a quick and easy method of editing an 
object using tools from the software that created the object. These file types can all be created 
using LibreOffice and OLE objects can be created from new or from an existing file.

Inserting new OLE objects
1) Select the slide in a presentation where the OLE object is going to be inserted.

2) Go to Insert > Object > OLE Object on the Menu bar to open the Insert OLE Object 
dialog (Figure 1).

3) Select Create new and then select the type of OLE object in Object Type.

4) Click OK and a new OLE object is inserted in the center of the slide in edit mode. The 
toolbars displayed change providing the necessary tools to create a new OLE object.

Notes

When inserting a new OLE object, it is only available in the presentation it is 
being inserted into and the OLE object can only be edited using Impress.

For computers using the Windows operating system, an additional option of 
Further objects is available in the Object Type list. Clicking on Further objects 
opens an Insert Object dialog (Figure 2) allowing an OLE object using other 
software that is compatible with OLE and LibreOffice to be inserted. This option is
available for new OLE objects and OLE objects from a file.

Figure 1: Insert OLE Object dialog – Create new
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Figure 2: Insert OLE Object dialog - Windows further options page

Figure 3: Insert OLE Object dialog - Create from file page

Inserting OLE objects from files
1) Select the slide in a presentation where the OLE object is going to be inserted.

2) Go to Insert > Object > OLE Object on the Menu bar to open the Insert OLE Object 
dialog (Figure 3).

3) Select Create from file, then click on Search and a file browser window opens.

4) Navigate to where the file is located, then select the file required and click Open. The 
filename appears in the File text box in the Insert OLE Object dialog.

5) Insert the OLE object into the center of the slide in edit mode using one of the following 
methods:

– Click OK to insert the file as an OLE object.

– Select Link to file, then click OK to insert the OLE object with a link to the original 
file.

– Select Display as icon, then click OK to insert the OLE object as an icon. When the 
icon is clicked on, the OLE object opens in a new window.
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Note

By default, when inserting a file into a slide as an OLE object, any changes made 
to the original file after insertion do not affect the copy of the file inserted into a 
presentation. Also, changes to the file copy in a presentation do not change the 
original file. If any changes made to the file, either in the original or in the 
presentation, are to appear in both versions the original file has to be linked with 
the presentation when the file is inserted.

Editing OLE objects
1) Double-click on the OLE object to open it in edit mode. The toolbars in Impress change to

provide the necessary tools for editing an OLE object.

2) When editing the OLE object is complete, click anywhere outside the OLE object to exit 
editing.

3) Save the presentation. Any changes made to the OLE object are also saved.

Resizing and moving OLE objects
Resizing and moving OLE objects is exactly the same as resizing and moving graphic objects in 
Impress. For more information, see Chapter 5, Managing Graphic Objects.

Notes

When resizing or moving a spreadsheet in slides, ignore any horizontal and 
vertical scroll bars, and the first row and first column. The first row and first 
column are easily recognizable because of their light background color. They are 
only used for spreadsheet editing purposes and are not included in the 
spreadsheet that appears as an OLE object on the slide.

Do not double click on an OLE spreadsheet object when moving or resizing. 
Double clicking opens the OLE object editing mode for spreadsheets.

Spreadsheets

To include a spreadsheet in an Impress presentation, either insert an existing spreadsheet file or 
insert a new spreadsheet as an OLE object. For more information on spreadsheets, see the Calc
Guide and the Getting Started Guide.

Embedding a spreadsheet into Impress includes most of the functionality of a Calc spreadsheet. 
Impress is capable of using Calc functions to carry out calculations and data analysis. However, if
complex data or formulas are going to be used, it is recommended to perform those operations in
a separate Calc spreadsheet first, then embed the spreadsheet into Impress with the results.

It is tempting to use spreadsheets in Impress for creating tables or presenting data in a tabular 
format. However, inserting a table into Impress is often more suitable and faster, depending on 
the complexity of the data. See Chapter 3, Adding and Formatting Text for more information on 
inserting and formatting tables.

The entire spreadsheet is inserted into a slide as an OLE object. If the spreadsheet contains 
more than one sheet and the one required is not visible, double-click the spreadsheet and then 
select a different sheet from the sheet tab row at the bottom. See “Editing OLE objects” on 
page 7 for more information on editing a spreadsheet as an OLE object.
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Figure 4: Example of spreadsheet editing in Impress

Figure 5: Formatting toolbar

Editing spreadsheets
When a spreadsheet is inserted into a slide, it is in edit mode ready for inserting or modifying 
data or modifying the format (Figure 4). The following also happens to provide tools and functions
for spreadsheets:

• Calc formatting toolbar opens at the top of the Workspace as shown by the example in 
Figure 4. The following tools become available providing basic formatting for 
spreadsheets:

– Name Box — gives the active cell reference or the name of a selected range of cells.

– Function Wizard; Select Function; Formula.

– Input Line — edit box for entering data or reviewing the displayed contents of the 
active cell. If necessary, click on the triangle ▼ on the right to expand the edit box 
and provide space for long functions requiring multiple lines.

• Formatting toolbar for spreadsheets (Figure 5) opens replacing the Line and Filling 
toolbar.

• Menu bar changes providing spreadsheet formatting options.

Cell navigation
By default, when an embedded spreadsheet is opened, the active cell is A1. To move around the 
spreadsheet to select a cell to make it active, use one of the following methods:

• Keyboard arrow keys.

• Position the cursor in a cell and click.
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• Press the Enter key to move one cell down and Shift+Enter combination to move 
one cell up.

• Press the Tab key to move one cell to the right and Shift+Tab combination to move 
one cell to the left.

Note

Other keyboard shortcuts are available to navigate around a spreadsheet. Refer 
to Getting Started Guide or the Calc Guide for more information.

Entering data
Data input into a cell can only be done when a cell is active. An active cell is easily identified by a
thickened and bolder border. The cell reference for the active cell is displayed in the Name Box 
at the left hand end of the Calc editing toolbar.

1) Double-click on the embedded spreadsheet to open editing mode.

2) Select a cell to make it active and start typing in the cell or in the Input Line. The data 
input displayed in the Input Line makes the data entry easier to read.

3) Use the various tools and options on the Menu bar to enter data, formula, function, text, 
or date into a cell.

4) To confirm data input into a cell use one of the following methods:

– Select a different cell with the cursor.

– Press the Enter key, or the Shift+Enter key combination.

– Press the Tab key, or Shift+Tab key combination.

5) When editing the embedded spreadsheet is complete, click anywhere outside the border 
to exit edit mode and save the changes.

Tip

Sometimes it is useful to treat numbers as text (for example, telephone numbers).
To prevent Impress from removing the leading zeros or right aligning numbers in 
a cell, type a single quotation mark (') before entering a number as text.

Merging cells
1) Double-click on the embedded spreadsheet to open editing mode.

2) Highlight the required number of cells to be merged.

3) If there is no data in the cells being merged, use one of the following methods to merge 
cells:

– Go to Format > Merge and Unmerge Cells > Merge and Center Cells on the Menu 
bar.

– Go to Format > Merge and Unmerge Cells > Merge Cells on the Menu bar.

– Right-click on the selected cells and select Merge Cells from the context menu.

4) If the selected cells for merging contain data, the Merge Cells dialog (Figure 6) 
automatically opens. Merge the selected cells as follows:

a) Use one of the methods in Step 3 to merge cells and open the Merge Cells dialog.
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Figure 6: Merge Cells dialog

b) Select an option in the Merge Cells dialog.

c) Click OK to merge the cells and close the Merge Cells dialog.

5) When finished editing the embedded spreadsheet, click anywhere outside the border to 
exit edit mode and save the changes.

Unmerging cells
Only multiple cells that have been merged can be unmerged or split into separate cells.

1) Double-click on the embedded spreadsheet to open editing mode.

2) Select a cell that was formed from merging from multiple cells.

3) Unmerge the merged cell into separate cells using one of the following methods:

– Go to Format > Merge and Unmerge Cells > Unmerge Cells on the Menu bar.

– Right-click on the cell and select Unmerge Cells from the context menu.

4) When editing the embedded spreadsheet is complete, click anywhere outside the border 
to exit edit editing mode and save the changes.

Inserting cells
1) Double-click on the embedded spreadsheet to open editing mode.

2) Select the same number of cells on the embedded spreadsheet that are going to be 
inserted.

Figure 7: Insert Cells dialog
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3) Insert cells using one of the following methods. Inserting cells opens the Insert Cells 
dialog (Figure 7).

– Go to Sheet > Insert Cells on the Menu bar.

– Right-click on the selected cells and select Insert from the context menu.

– Use the keyboard shortcut Ctrl++ (macOS ⌘++).

4) Select an insert option for cells, then click OK to insert the cells and close the Insert Cells 
dialog.

5) When editing the embedded spreadsheet is complete, click anywhere outside the border 
to exit edit editing mode and save the changes.

Inserting rows
1) Double-click on the embedded spreadsheet to open editing mode.

2) Select the same number of rows on the embedded spreadsheet that are going to be 
inserted.

3) Insert rows using one of the following methods:

– Go to Sheet > Insert Rows > Rows Above or Sheet > Insert Rows > Rows Below 
on the Menu bar.

– Right-click on the row header for the selected rows and select Insert Rows Above or 
Insert Rows Below from the context menu.

– Open the Insert Cells dialog and select Entire row to insert rows above the selected 
rows.

4) When editing the embedded spreadsheet is complete, click anywhere outside the border 
to exit edit editing mode and save the changes.

Inserting columns
1) Double-click on the embedded spreadsheet to open editing mode.

2) Select the same number of columns on the embedded spreadsheet that are going to be 
inserted.

3) Insert columns using one of the following methods:

– Go to Sheet > Insert Columns > Columns Before or Sheet > Insert Columns > 
Columns After on the Menu bar.

– Right-click on the column header for the selected columns and select Insert 
Columns Before or Insert Columns After from the context menu.

– Open the Insert Cells dialog and select Entire column to insert columns to the left of 
the selected columns.

4) When editing the embedded spreadsheet is complete, click anywhere outside the border 
to exit edit editing mode and save the changes.

Deleting cells
1) Double-click on the embedded spreadsheet to open editing mode.

2) Select the cells on the embedded spreadsheet that are going to be deleted.

3) Delete the selected cells using one of the following methods. Deleting cells opens the 
Delete Cells dialog (Figure 8).
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Figure 8: Delete Cells dialog

– Go to Sheet > Delete Cells on the Menu bar.

– Right-click on the selected cells and select Delete from the context menu.

– Use the keyboard shortcut Ctrl+- (macOS ⌘+-).

4) Select a delete option in the Delete Cells dialog, then click OK to delete the cells and 
close the dialog.

5) When editing the embedded spreadsheet is complete, click anywhere outside the border 
to exit edit editing mode and save the changes.

Deleting rows
1) Double-click on the embedded spreadsheet to open editing mode.

2) Select the rows for deletion on the embedded spreadsheet.

3) Delete the selected rows using one of the following methods:

– Go to Sheet > Delete Rows on the Menu bar.

– Right-click in the row header for the selected rows and select Delete Rows from the 
context menu.

– Open the Delete Cells dialog and select Delete entire row(s).

4) When editing the embedded spreadsheet is complete, click anywhere outside the border 
to exit edit editing mode and save the changes.

Deleting columns
1) Double-click on the embedded spreadsheet to open editing mode.

2) Select the columns for deletion on the embedded spreadsheet.

3) Delete the selected columns using one of the following methods:

– Go to Sheet > Delete Columns on the Menu bar.

– Right-click in the column header for the selected columns and select Delete 
Columns from the context menu.

– Open the Delete Cells dialog and select Delete entire column(s).

4) When editing the embedded spreadsheet is complete, click anywhere outside the border 
to exit edit editing mode and save the changes.

Quickly inserting sheets
1) Double-click on the embedded spreadsheet to open editing mode.
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2) Quickly insert a sheet using one of the following methods:

– Click on the plus sign to the left of the sheet names and a new sheet is added to the 
spreadsheet after the last sheet in the spreadsheet.

– Go to Sheet > Insert Sheet at End on the Menu bar and enter a name for the sheet 
in the Append Sheet dialog that opens, then click OK. A new sheet is added to the 
spreadsheet after the last sheet in the spreadsheet.

3) When editing the embedded spreadsheet is complete, click anywhere outside the border 
to exit edit editing mode and save the changes.

Note

If there are multiple sheets in an embedded spreadsheet, only the active sheet is 
shown on the slide after exiting edit mode.

Inserting sheets
For more control over inserting sheets into an embedded spreadsheet, the Insert Sheet dialog 
(Figure 9) is used as follows:

1) Double-click on the embedded spreadsheet to open editing mode.

2) Open the Insert Sheet dialog using one of the following methods:

– Right-click on the sheet names and select Insert Sheet from the context menu.

– Go to Sheet > Insert Sheet on the Menu bar.

3) In Position, select one of the following options:

– Before current sheet — inserts sheets before the active sheet in the spreadsheet.

Figure 9: Insert Sheet dialog

– After current sheet — inserts sheets after the active sheet in the spreadsheet.

4) In Sheet, select New sheet and the No. of sheets required.
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5) In the Name text box, enter a name for the new sheet. This option is not available if 
inserting multiple sheets.

6) Click OK to insert the sheet and close the Insert Sheet dialog.

7) When editing the embedded spreadsheet is complete, click anywhere outside the border 
to exit edit editing mode and save the changes.

Insert sheet from file
When inserting a sheet from a file, the Insert Sheet dialog has to be used.

1) Double-click on the embedded spreadsheet to open editing mode.

2) Open the Insert Sheet dialog using one of the following methods:

– Right-click on the sheet names and select Insert Sheet from the context menu.

– Go to Sheet > Insert Sheet on the Menu bar.

3) In Position, select one of the following options:

– Before current sheet — inserts sheets before the active sheet in the spreadsheet.

– After current sheet — inserts sheets after the active sheet in the spreadsheet.

4) In Sheet, select From file and click on Browse to open an Insert browser window.

5) Navigate to the file location and select the file.

6) Click on Open and the sheet names contained in the file appear in the preview box.

7) If necessary, click on Link to create a link to the original file.

8) Select the sheet required for insertion in the preview box.

9) Click OK to insert the selected sheet into the embedded spreadsheet and close the Insert
Sheet dialog.

10) When editing the embedded spreadsheet is complete, click anywhere outside the border 
to exit edit editing mode and save the changes.

Renaming sheets
1) Double-click on the embedded spreadsheet to open editing mode.

2) Select the sheet for renaming to make it active.

3) Right-click on the sheet tab and select Rename Sheet from the context menu, or go to 
Sheet > Rename Sheet on the Menu bar.

4) Enter a new name for the sheet in the Rename Sheet dialog that opens.

5) Click OK to save the name change and close the Rename Sheet dialog.

6) When editing the embedded spreadsheet is complete, click anywhere outside the border 
to exit edit editing mode and save the changes.

Moving or copying sheets
1) Double-click on the embedded spreadsheet to open editing mode.

2) Select the sheet for moving or copying to make it active.
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Figure 10: Move/Copy Sheet dialog

3) Right-click on the sheet tab and select Move or Copy Sheet from the context menu, or 
go to Sheet > Move or Copy Sheet on the Menu bar to open the Move/Copy Sheet 
dialog (Figure 10).

4) Move or copy a sheet to another position within the embedded spreadsheet in the same 
presentation as follows:

a) In Action, select Move or Copy option.

b) In Location, select a destination from the options in the To document drop-down list. 
In Impress, the presentation is named as Untitled 1 (current document).

c) In Insert before, select the position within the spreadsheet from the available list.

d) If necessary, enter a new name for the sheet in the New name text box.

e) Click on Move to move the sheet, or Copy to copy the sheet and close the Move/Copy
sheet dialog.

5) Move or copy a sheet to another document containing a spreadsheet is as follows:

a) Make sure the spreadsheet in the target document is selected.

b) In Action, select Move or Copy option.

c) In Location, select a destination from the options in the To document drop-down list. 
In Impress, the presentation is named as Untitled 1 (current document). If the 
document is a Calc spreadsheet, the filename of the Calc spreadsheet is displayed.

d) In Insert before, select the position within the spreadsheet from the available list.
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e) If necessary, enter a new name for the sheet in the New name text box.

f) Click on Move to move the sheet, or Copy to copy the sheet and close the Move/Copy
sheet dialog.

6) To move the sheet within the embedded spreadsheet using the cursor, click on the sheet 
tab and drag the selected sheet to a new position.

7) When editing the embedded spreadsheet is complete, click anywhere outside the border 
to exit edit editing mode and save the changes.

Note

To move or copy a sheet from an embedded spreadsheet in an Impress 
presentation into another document, then the target document must be a Calc 
spreadsheet or a document that contains an embedded Calc spreadsheet. 

Deleting sheets
1) Double-click on the embedded spreadsheet to open editing mode.

2) Select the sheet for deletion to make it active.

3) Right-click on the sheet tab and select Delete Sheet from the context menu, or go to 
Sheet > Delete Sheet on the Menu bar.

4) Click Yes to confirm the deletion of the sheet.

5) When editing the embedded spreadsheet is complete, click anywhere outside the border 
to exit edit editing mode and save the changes.

Formatting spreadsheets
For presentation purposes, it may be necessary to change the formatting of a spreadsheet to 
match the style used in the presentation.

When working on an embedded spreadsheet, any styles created in Calc are also available for 
use. However, if styles are going to be used, it is recommended to create specific styles for 
embedded spreadsheets. Calc styles maybe unsuitable when working in Impress.

Cell data formatting
1) Select a cell or a range of cells in an embedded spreadsheet using one of the following 

methods:

– Click in a cell to select it.

– To select the whole sheet, click on the blank cell at the top left corner between the 
row and column headers.

– To select the whole sheet, use the keyboard shortcut Ctrl+A (macOS ⌘+A).

– To select a column, click on the column header at the top of the spreadsheet.

– To select a row, click on the row header on the left hand side of the spreadsheet.

2) Open the Format Cells dialog (Figure 11) using one of the following methods:

– Right-click on a cell and select Format Cells from the context menu.

– Go to Format > Cells on the Menu bar.

– Use the keyboard shortcut Ctrl+1 (macOS ⌘+1).

16 | Chapter 7, OLE, Spreadsheets, Charts, and Other Objects



Figure 11: Format Cells dialog

3) Use the various pages in the Format Cells dialog to format the cell data so that it matches
the style of the presentation.

4) Click OK to close the Format Cells dialog and save the formatting changes.

5) When editing the embedded spreadsheet is complete, click anywhere outside the border 
to exit edit editing mode and save the changes.

Row formatting
1) Select a row by clicking in the row header.

2) Adjust the row height using one of the following methods:

– Right-click in the row header and select Row Height from the context menu to open 
the Row Height dialog (Figure 12), then enter the required row height in the Height 
text box.

– Right-click in the row header and select Row Height from the context menu to open 
the Row Height dialog, then select Default value for row height.

– Right-click in the row header and select Optimal Height from the context menu to 
open the Optimal Height dialog (Figure 13). Enter an optimal height in the Add text 
box, or select Default value. The optimal row height depends on the font size of the 
largest character in a row.

– Hover the cursor over the bottom border in the row header until it changes shape, 
then click and drag the border to increase or decrease the row height.
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Figure 12: Row Height dialog Figure 13: Optimal Row Height dialog

Figure 14: Column Width dialog Figure 15: Optimal Column Width dialog

3) When editing the embedded spreadsheet is complete, click anywhere outside the border 
to exit edit editing mode and save the changes.

Column formatting
1) Select a column by clicking in the column header.

2) Adjust the column width using one of the following methods:

– Right-click in the column header and select Column Width from the context menu to 
open the Column Width dialog (Figure 14), then enter the required column width in 
the Width text box.

– Right-click in the column header and select Column Width from the context menu to 
open the Column Width dialog, then select the Default value for column width.

– Right-click in the column header and select Optimal Width from the context menu to 
open the Optimal Column Width dialog (Figure 15). Enter an optimal width in the Add
text box, or select Default value. The optimal column width depends on the longest 
entry within a column.

– Hover the cursor over the left or right border in the column header until it changes 
shape, then click and drag the border to increase or decrease the column width.

3) When editing the embedded spreadsheet is complete, click anywhere outside the border 
to exit edit editing mode and save the changes.

Using formatting styles
When using styles in an embedded spreadsheet and the spreadsheet is in edit mode, Impress 
displays the available styles for a spreadsheet in the Cell Styles panel in the Styles deck on the 
Sidebar (Figure 16). Styles used in an embedded spreadsheet are similar to LibreOffice 
paragraph styles.

1) Select the data in a cell or cells in the embedded spreadsheet.

2) Click on Styles to open the Styles deck in the Sidebar, then click on Cell Styles to open 
the Calc styles panel.

3) Double-click on a style to apply that style to the cell data.
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Figure 16: Cell Styles panel in Styles deck on Sidebar

4) When editing the embedded spreadsheet is complete, click anywhere outside the border 
to exit edit editing mode and save the changes.

Charts

A chart is a graphical interpretation of information that is contained in a spreadsheet. The 
following information only provides basic information on charts. For more information about 
creating charts and the use of charts, see the Calc Guide.

Inserting charts
1) Select a slide to insert a chart.

2) Use one of the following methods to insert a chart:

– Go to Insert > Chart on the Menu bar and an example chart (Figure 17) is inserted at
the center of the selected slide in editing mode.

– Click on Insert Chart on the Standard toolbar and an example chart is inserted in the 
center of the slide in editing mode.

– Go to Insert > Object > OLE Object on the Menu bar to insert a chart as an OLE 
object. See “OLE objects” on page 5 for more information on inserting OLE objects.

3) If necessary, click outside the chart area to cancel editing mode.

Note

When an embedded chart is in editing mode, the Formatting toolbar (Figure 18) 
for charts and a Standard toolbar for charts (Figure 19) automatically open 
replacing the Line and Filling and Standard toolbars.

Selecting chart types
Data can be presented using a variety of different chart types. Impress contains several 
examples of chart types that will help to convey information to an audience. Select a chart type 
using the Chart Type dialog or the Chart Type panel in the Properties deck on the Sidebar.
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Figure 17: Example chart in editing mode

Figure 18: Formatting toolbar for charts

Figure 19: Standard toolbar for editing charts

Chart types
The following summary of available chart types to help selection of a chart type suitable for the 
data being used to create the chart. Column, bar, pie and area charts are available as 2D or 3D 
types. For more information on charts, see the Calc Guide.

Column
Used to display data that shows trends over time. This chart is the default chart type used
when a chart is inserted into a slide. It is recommended to use column charts where there 
is a relatively small number of data points. If the data is a large time series, it is 
recommended to use a line chart.

Bar
Gives immediate visual impact for data comparison where time is not important, for 
example comparing the popularity of products in a marketplace.

Pie
Gives a comparison of proportions. For example, when comparing what departments 
spent on items or what departments actually spent overall. They work best with a small 
range of values, for example six or less. Using larger range of values, reduces the visual 
impact of a pie chart.

Area
Versions of line or column charts. Useful when emphasis of volume change is required. 
Area charts have a greater visual impact than a line chart, but the type of data used does 
make a difference to visual impact.

Line
Time series with progression. Ideal for raw data and useful for charts with data showing 
trends or changes over time where an emphasis in continuity is required. In line charts, 
the X-axis is ideal for representing time series data.
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XY (Scatter)
Typically used for showing and comparing numeric values, like scientific, statistical, and 
engineering data. Combines X and Y values into single data points and displays them in 
irregular intervals, or clusters. The X-axis usually plots the independent variable or control
parameter (often a time series).

Bubble
Used to represent three variables. Two variables identify the position of the center of a 
bubble on a Cartesian graph, while the third variable indicates the radius of the bubble.

Net
Similar to polar or radar graphs and are useful for comparing data not in time series, but 
show different circumstances, such as variables in a scientific experiment. The poles of 
the net chart are the Y-axes of other charts. Generally, between three and eight axes are 
ideal; any more and this type of chart becomes confusing.

Stock
Specialized column graphs specifically used for stocks and shares. choose traditional 
lines, candlestick, and two-column charts. The data required for these charts is 
specialized with a series for opening price, closing price, and high and low prices. The 
X-axis represents a time series.

Column and line
Combination of two other chart types. It is useful for combining two distinct, but related 
data series, for example sales over time (column) and the profit margin trends (line).

Chart Type dialog
1) Make sure the chart is selected and in editing mode. The chart has a border and selection

handles when in editing mode.

2) Open the Chart Type dialog (Figure 20) using one of the following methods:

– Click on Chart Type on the Formatting toolbar.

– Go to Format > Chart Type on the Menu bar.

– Right-click on the chart and select Chart Type from the context menu.

Figure 20: Chart Type dialog
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3) Select a chart type from the left-hand preview box and the chart examples on the right 
change. The available options for chart types also change to match the selected chart 
type.

4) Select a chart example from the right-hand preview box.

5) Select the options required for the chart type selected.

6) Click OK to close the Chart Type dialog and return to the edit window.

7) Continue to format the chart, add data to the chart, or click outside the chart to return to 
normal view.

Sidebar Chart Type and Elements
1) Make sure the chart is selected and in editing mode. The chart has a border and selection

handles when in editing mode.

2) Click on Properties on the Sidebar to open the Properties deck.

3) Click on Chart Type to open the Chart Type panel (Figure 21).

4) Select a chart type from the Chart Type drop-down list.

5) Select a chart example from the preview box.

6) Select the required formatting options for the chart type from the Chart Type panel. The 
available options change to match the chart type that has been selected.

7) Click on Elements to open the Elements panel (Figure 22).

8) Select the required formatting options for the chart type from the Elements panel.

9) When formatting the chart is complete and all the data has been added to the chart, click 
outside the chart to return to deselect editing and return to normal view.

Note

The Chart Type and Element panels in the Properties deck on the Sidebar are 
only available when a chart has been selected and is in editing mode.

Figure 21: Chart Type panel in Properties deck on Sidebar
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Figure 22: Elements panel in Properties deck on Sidebar

Figure 23: Data Table dialog

Formatting charts

Entering chart data
1) Make sure the chart is selected and in editing mode. The chart has a border and selection

handles when in editing mode.

2) Open the Data Table dialog (Figure 23) using one of the following methods:

– Click on Data Table on the Formatting toolbar for charts.

– Go to View > Data Table on the Menu bar.
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– Right-click on the chart and select Data Table from the context menu.

3) Type or paste information into the cells to enter data into the Data Table dialog.

4) Use the tools in the top of the Data Table dialog to insert, delete or reposition rows or 
columns.

5) Click on Close to save the changes and close the Data Table dialog.

6) When formatting the chart is complete and all the data has been added to the chart, click 
outside the chart to return to deselect editing and return to normal view.

Note

To insert, delete or reposition a column, use the tools Insert Series, Delete 
Series, Move Series Left, and Move Series Right in the Data Table dialog.

Adding or removing chart elements
1) Make sure the chart is selected and in editing mode. The chart has a border and selection

handles when in editing mode.

2) Add an element to the chart using one of the following methods:

– Go to Insert on the Menu bar and select an element from the submenu.

– Right-click directly on the chart and select an element from the context menu.

– Right-click directly on the chart wall and select an element from the context menu.

– Open the Elements panel in the Properties deck on the Sidebar and select an 
element from the options available.

Note

The method selected to add an element changes the type of element that can be 
added to the chart. Also, when adding some elements to the chart, a dialog may 
open with more options to select for the element being added.

3) Remove an element from a chart using one of the following methods:

– Right-click on the chart element and select the delete option from the context menu. 
Type of element selected changes the delete options in the context menu.

– Select a chart element and press the Delete or Backspace key to remove the 
element from the chart.

– Open the Elements panel in the Properties deck on the Sidebar and deselect the 
element.

4) When formatting the chart is complete and all the data has been added to the chart, click 
outside the chart to return to deselect editing and return to normal view.

Chart and chart elements formatting
For more information on formatting a chart, chart elements, and the formatting options available, 
see the Calc Guide.

1) Make sure the chart is selected and in editing mode. The chart has a border and selection
handles when in editing mode.

2) Format an element on the chart using one of the following methods:

– Go to Format on the Menu bar and select an element for formatting.
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– Right-click on an element and select Format XXXX from the context menu. The 
format options available depend on which chart element has been selected. For 
example, select the chart wall and the format option is called Format Chart Wall.

– Use the various tools on the Formatting toolbar for charts to format a chart element.

3) Select an element and open a formatting dialog specific for the element selected.

4) Use the various options in the formatting dialog to format the element.

5) When formatting the chart is complete and all the data has been added to the chart, click 
outside the chart to return to deselect editing and return to normal view.

Resizing and moving charts
A chart and its chart elements can be resized and moved just like other objects on a slide. For 
more information on resizing and moving a chart, see Chapter 5, Managing Graphic Objects and 
the Calc Guide.

Audio and video

Inserting audio or video

Using a file browser
1) Go to Insert > Audio or Video on the Menu bar and a file browser for Insert Audio or 

Video opens (Figure 24).

2) Navigate to the folder where the audio or video file is located. Only the audio and video 
files that are compatible with Impress will be available in the file browser.

Figure 24: Insert Audio or Video dialog
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Figure 25: Media Playback toolbar

3) Select a compatible audio or video file and click Open to embed the file in the center of 
the slide. The Media Playback toolbar (Figure 25) automatically opens.

4) Reposition and/or resize the audio or video file. See Chapter 5, Managing Graphic 
Objects for more information.

Using the Gallery
1) If the Gallery deck is not already open, use one of the following methods to open the 

Gallery deck:

– Go to View > Sidebar on the Menu bar to open the Sidebar and select Gallery from 
the options available.

– Use the keyboard shortcut Ctrl+F5 (macOS ⌘+F5) to open the Sidebar and select 
Gallery from the options available.

– Go to View > Gallery on the Menu bar.

2) Browse to a theme containing media files, for example Sounds.

3) Click on the audio or video option required and drag it onto the slide. The Media Playback
toolbar automatically opens.

4) Reposition and/or resize the audio or video file. See Chapter 5, Managing Graphic 
Objects for more information.

Media playback
The Media Playback toolbar automatically opens when an audio or video file is selected. The 
Media Playback toolbar contains the following tools from left to right:

Insert Audio or Video
Opens the Insert Audio or Video file browser where a media file is selected for insertion 
into a slide.

Play
Plays the media playback.

Pause
Pauses the playing of the media.

Stop
Stops the playing of media.

Repeat
When selected, repeats the playing of the media until the tool is deselected.

Position
Selects the position of where to start playing from within the media file.

Mute
Suppresses the volume of a media file.
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Volume
Adjusts the volume of the media file.

Media Path
Indicates where the media file is stored on a computer.

Formulas

Go to Insert > Object > Formula Object on the Menu bar to create a formula in a slide. A 
formula can also be inserted as an OLE object. See “OLE objects” on page 5 for more 
information.

When editing a formula, the Math menu becomes available allowing the creation or editing of a 
formula. For more information on how to create formulas, see the Math Guide or the Getting 
Started Guide.

When creating formulas, care should be taken with font sizes to make sure formulas are similar 
in size to the font used in the presentation. To change font attributes of a formula, go to Format >
Font Size on the Menu bar. To change font type, go to Format > Fonts on the Menu bar.

Note

Unlike formulas in Writer, a formula in Impress is treated as an object and is not 
automatically aligned with the rest of the objects on the slide. The formula can be 
moved around like other objects in Impress, but cannot be resized.

Drawings, text files, HTML files and other objects

Drawings, text files, HTML files and other objects can be inserted into an Impress presentation, 
but only objects that are compatible with Impress can be inserted. Go to Insert > File on the 
Menu bar to open a file selection dialog. Only files compatible with Impress are available for 
selection. Drawings, text files, HTML files and other objects can also be inserted as OLE objects. 
See “OLE objects” on page 5 for more information.
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