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Please direct any comments or suggestions about this document to the Documentation Team’s 
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Everything you send to a mailing list, including your email address and any other 
personal information that is written in the message, is publicly archived and cannot 
be deleted.

Publication date and software version
Published June 2021. Based on LibreOffice 7.1 Community.
Other versions of LibreOffice may differ in appearance and functionality.

Using LibreOffice on macOS
Some keystrokes and menu items are different on macOS from those used in Windows and 
Linux. The table below gives some common substitutions for the instructions in this document. 
For a detailed list, see the application Help.

Windows or Linux macOS equivalent Effect

Tools > Options 
menu selection

LibreOffice > Preferences Access setup options

Right-click Control+click or right-click 
depending on computer setup

Open a context menu

Ctrl (Control) ⌘ (Command) Used with other keys

F11 ⌘+T Open the Styles deck in the Sidebar

Documentation for LibreOffice is available at http://documentation.libreoffice.org/en/
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Introduction

LibreOffice is a productivity suite that is compatible with other major office suites and available on
a variety of platforms. It is open source software and therefore free to download, use, and 
distribute. If you are new to LibreOffice, this appendix will provide some information regarding its 
history, its community, and some of its technical specifications.

A short history of LibreOffice

The OpenOffice.org project began when Sun Microsystems released the source code 
(“blueprints”) for its StarOffice® software to the open source community on October 13, 2000. 
OpenOffice.org 1.0, the product, was released on April 30, 2002. Major updates to 
OpenOffice.org included version 2.0 in October 2005 and version 3.0 in October 2008. On 
January 26, 2010, Oracle Corporation acquired Sun Microsystems.

On September 28, 2010, the community of volunteers who develop and promote OpenOffice.org 
announced a major change in project structure. After ten years’ successful growth with Sun 
Microsystems as founding and principle sponsor, the project launched an independent foundation
called The Document Foundation, to fulfill the promise of independence written in the original 
charter. This foundation is the cornerstone of a new ecosystem where individuals and 
organizations can contribute to and benefit from the availability of a truly free office suite.

Unable to acquire the trademarked OpenOffice.org name from Oracle Corporation, The 
Document Foundation named its product LibreOffice. Continuing the version numbers from 
OpenOffice.org, LibreOffice 3.3 was released in January 2011 and version 7.0 was released in 
August 2020.

In February 2012, The Document Foundation was incorporated in Berlin as a German Stiftung. 
You can read more about The Document Foundation at: www.documentfoundation.org.

The LibreOffice community

The Document Foundation’s mission is:

“...to facilitate the evolution of the OpenOffice.org Community into a new open, 
independent, and meritocratic organizational structure within the next few months. An 
independent Foundation is a better match to the values of our contributors, users, and 
supporters, and will enable a more effective, efficient, transparent, and inclusive 
Community. We will protect past investments by building on the solid achievements of our 
first decade, encourage wide participation in the Community, and co-ordinate activity 
across the Community.”

Some of our corporate supporters include GNOME Foundation, Google, Red Hat, and Collabora. 
Additionally, over 450,000 people from nearly every part of the globe have joined this project with
the idea of creating the best possible office suite that all can use. This is the essence of an “open
source” community!

With its open source software license, LibreOffice is key in the drive to provide an office suite that
is available to anyone, anywhere, for commercial or personal use. The software has been 
translated into many languages and runs on all major operating systems. New functionality can 
be added in the form of extensions.

The LibreOffice community invites contributors in all areas, including translators, software 
developers, graphic artists, technical writers, editors, donors, and end-user support. Whatever 
you do best, you can make a difference in LibreOffice. The community operates internationally in 
all time zones and in many languages, linked through the internet at www.libreoffice.org and 
www.documentfoundation.org.
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How is LibreOffice licensed?

LibreOffice is distributed under both the Mozilla Public License (MPL) 2.0 
(www.libreoffice.org/about-us/licenses/) and the GNU Lesser General Public License (LGPL) 
3.0+ (www.gnu.org/licenses/lgpl-3.0.en.html).

What is open source?

The four essential rights of open-source software are embodied within the Free Software 
Foundation’s family of the GNU General Public License (GPL):

• The right to use the software for any purpose.

• Freedom to redistribute the software for free or for a fee.

• Access to the complete source code of the program (that is, the “blueprints”).

• The right to modify any part of the source, or use portions of it in other programs.

The basic idea behind open source is very simple: When programmers can read, redistribute, 
and modify the source code for a piece of software, the software evolves. People improve it, 
people adapt it, people fix bugs.

For more information on Free and Open Source software, visit these websites:

• Open Source Initiative (OSI): www.opensource.org

• Free Software Foundation (FSF): www.fsf.org

What are open standards?

An open standard provides a means of doing something that is independent of manufacturer or 
vendor, thus enabling competing software programs to freely use the same file formats. HTML, 
XML, and ODF are examples of open standards for documents.

An open standard meets the following requirements:

• It is well documented with the complete specification publicly available, either free or at a 
nominal charge.

• It can be freely copied, distributed and used. The intellectual property of the standard is 
made irrevocably available on a royalty-free basis.

• It is standardized and maintained in an independent, open forum (also called “standards 
organization”) using an open process.

What is OpenDocument?

OpenDocument (ODF) is an XML-based file format for office documents (text documents, 
spreadsheets, drawings, presentations, and more), developed at OASIS (www.oasis-open.org), 
an independent, international standards group. OpenDocument version 1.2 was adopted by the 
International Standards Organization and named ISO/IEC 26300:2015 standard1. In December 
2019, ODF 1.3 was approved as a committee specification.

Unlike other file formats, ODF (ISO/IEC 26300:2015) is an open standard. It is publicly available, 
royalty-free, and without legal or other restrictions; therefore ODF files are not tied to a specific 
office suite and anybody can build a program that interprets these files. For this reason ODF is 
quickly becoming the preferred file format for government agencies, schools and other 
companies who prefer not to be too dependent on any one software supplier.

1 www.iso.org/standard/66363.html, www.iso.org/standard/66375.html, and 
www.iso.org/standard/66376.html
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LibreOffice 7.1 saves documents in ODF 1.3 Extended by default. LibreOffice can also open and 
save in earlier versions of the ODF standard, as well as many other file formats, as summarized 
below.

For a full list of file formats that LibreOffice can read and write, see 
https://en.wikipedia.org/wiki/LibreOffice#Supported_file_formats 

OpenDocument filename extensions
The most common filename extensions used for OpenDocument documents are:

*.odt for word processing (text) documents

*.ods for spreadsheets

*.odp for presentations

*.odb for databases

*.odg for graphics (vector drawings)

*.odc for charts

*.odf for formulas (scientific formulas and  equations)

File formats LibreOffice can open

LibreOffice can open a wide variety of file formats in addition to the OpenDocument formats, 
including Portable Document Format (PDF).

Opening text documents
In addition to OpenDocument formats (.odt, .ott, .oth, .odm, and .fodt), Writer can open the 
following text document formats, and a variety of legacy formats not listed below:

Microsoft Word 6.0/95/97/2000/XP/Mac) (.doc and .dot)
Microsoft Word 2003 XML (.xml)
Microsoft Word 2007/2010 XML (.docx, .docm, .dotx, .dotm)
Microsoft WinWord 5 (.doc) WordPerfect Document (.wpd)
Microsoft Works (.wps) Lotus WordPro (.lwp)
Abiword Document (.abw, .zabw) ClarisWorks/Appleworks Document (.cwk)
MacWrite Document (.mw, .mcw) Rich Text Format (.rtf)
Text CSV (.csv and .txt) StarWriter formats (.sdw, .sgl, .vor)
DocBook (.xml) Unified Office Format text (.uot, .uof)
T602 Document (.602, .txt) Hangul WP 97 (.hwp)
Apple Pages 4 (.pages) eBook (.pdb)
HTML Document (.htm, .html) OpenOffice.org 1.x (.sxw, .stw, and .sxg)
... and many others

Most of these file types are automatically detected by LibreOffice, so they can be opened without 
explicitly selecting the document type in the file picker.

When opening .htm or .html files (used for web pages), LibreOffice customizes Writer for working 
with these files.
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Opening spreadsheets
In addition to OpenDocument formats (.ods, .ots, and .fods), Calc can open the following 
spreadsheet formats:

Microsoft Excel 97/2000/XP (.xls, .xlw, and .xlt)
Microsoft Excel 4.x–5.0/95 (.xls, .xlw, and .xlt)
Microsoft Excel 97-2003 (.xml)
Microsoft Excel 2007-365 (.xlsx, .xlsm, .xltx, .xltm)
Microsoft Excel 2007-2010 binary (.xlsb)
Lotus 1-2-3 (.wk1, .wks, and .123)
Data Interchange Format (.dif)
Rich Text Format (.rtf)
Text CSV (.csv and .txt)
StarCalc (.sdc and .vor)
OpenOffice.org 1.x (.sxc and .stc) 
dBASE (.dbf)
SYLK (.slk)
Unified Office Format spreadsheet (.uos, .uof)
HTML Document (.htm and .html files, including Web page queries)
Quattro Pro 6.0 (.wb2)
Apple Numbers 2 (.numbers)
... and many others

Opening presentations
In addition to OpenDocument formats (.odp, .odg, .otp, and .fopd), Impress can open the 
following presentation formats:

Microsoft PowerPoint 97/2000/XP (.ppt and .pot)
Microsoft PowerPoint 2007-365 (.pptx, .pptm, .potx, .potm)
StarDraw and StarImpress (.sda, .sdd, .sdp, and .vor)
OpenOffice.org 1.x (.sxi and .sti) 
Unified Office Format presentation (.uop, .uof)
CGM – Computer Graphics Metafile (.cgm)
Portable Document Format (.pdf)
Apple Keynote 5 (.key)
... and many others

Opening graphic files
In addition to OpenDocument formats (.odg and .otg) and Portable Document Format (.pdf), 
Draw can open the following graphic formats:

Adobe Photoshop (*.psd)
AutoCAD Interchange Format (*.dxf)
Corel Draw (*.cdr)
Corel Presentation Exchange (*.cmx)
Microsoft Publisher 98-2010 (*.pub)
Microsoft Visio 2000-2013 (*.vdx; *.vsd; *.vsdm; *.vsdx)
WordPerfect Graphics (*.wpg)
OpenOffice.org 1.x (.sxd and .std) 

BMP JPEG, JPG PCX RAS TGA
DXF MET PGM SDA TIF, TIFF
EMF PBM PNG SDD WMF
EPS PCD PPM SVG XBM
GIF PCT PSD SVM XPM
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Opening formula files
In addition to OpenDocument Formula (.odf) files, Math can open the formats used by 
OpenOffice.org 1.x (.sxm), StarMath (.smf), and MathML (.mml) files.

When opening a Word document that contains an embedded equation editor object, if the option 
MathType to LibreOffice Math or reverse is checked in Tools > Options > Load/Save > 
Microsoft Office, the object will be automatically converted to a LibreOffice Math object.

File formats LibreOffice can save to

Saving in an OpenDocument format guarantees the correct rendering of the file when it is 
transferred to another person or when the file is reopened with a later version of LibreOffice or 
with another program. It is strongly recommended that you use OpenDocument as the default file
formats. However, you can save files in other formats, if you wish.

Tip

When sharing a document that you do not expect the recipient to modify, the 
preferred option is to convert the document to PDF. LibreOffice provides a 
straightforward way to convert documents to PDF. See Chapter 10, Printing, 
Exporting, Emailing, and Signing, in this guide.

Saving text documents
In addition to OpenDocument formats (.odt, .ott, and .fodt), Writer can save in these formats:

Office Open XML Text (.docx) Microsoft Word 2007–365 (.docx, .dotx)

Microsoft Word 97–2003 (.doc) Microsoft Word 2003 XML (.xml)

Rich Text Format (.rtf) Text (.txt)

Text Encoded (.txt) Unified Office Format text (.uot, .uof)

HTML Document (.html and .htm) DocBook (.xml)

Encryption support within the Microsoft Word 97/2000/XP filter allows password protected 
Microsoft Word documents to be saved.

Note

The .rtf format is a common format for transferring text files between applications, 
but you are likely to experience loss of formatting and images. For this reason, other 
formats should be used.

Saving spreadsheet files
In addition to OpenDocument formats (.ods, .ots, and .fods), Calc can save in these formats:

Office Open XML Spreadsheet (.xlsx) Data Interchange Format (.dif)

Microsoft Excel 2007–365 XML (.xlsx) dBase (.dbf)

Microsoft Excel 97–2003 (.xls and .xlw) SYLK (.slk)

Microsoft Excel 97–2003 Template (.xlt) Text CSV (.csv and .txt)

Microsoft Excel 2003 XML (.xml) Unified Office Format spreadsheet (.uos)

HTML Document (Calc) (.html and .htm)
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Saving presentations
In addition to OpenDocument formats (.odp, .otp, .fodp, and .odg), Impress can save in these 
formats:

Microsoft PowerPoint 2007–365 (.pptx, .potm)
Microsoft PowerPoint 2007–365 AutoPlay (.ppsx)
Microsoft PowerPoint 97–2003 (.ppt)
Microsoft PowerPoint 97–2003 Template (.pot)
Microsoft PowerPoint 97–2003 AutoPlay (.pps)
Office Open XML Presentation (.pptx, .potm, .ppsx)
Unified Office Format presentation (.uop)

Impress can also export to any of the graphics formats listed for Draw.

Saving drawings
Draw can save in the OpenDocument Drawing formats (.odg, .otg, and .fodg).

Draw can export to any of the following graphics formats: BMP, EMF, EPS, GIF, JPEG, PNG, 
SVG, TIFF, and WMF.

Note

Adobe [Macromedia] Flash (.swf) export has been removed from LibreOffice 7. Flash
Player reached end-of-life in December 2020.

Saving Writer/Web documents
Writer/Web can save to these formats:

HTML document (.html and .htm), as HTML 4.0 Transitional
Text and Text Encoded (LibreOffice Writer/Web) (.txt)

Exporting to other formats

LibreOffice uses the term “export” for some file operations involving a change of file type. If you 
cannot find what you want under File > Save As, look under File > Export (not available in 
Math) for additional types.

Two popular formats that LibreOffice can export to are PDF (Writer, Calc, Impress, and Draw) 
and EPUB (Writer only).  See Chapter 10, Printing, Exporting, Emailing, and Signing Documents,
for more information about exporting to those formats.

LibreOffice can also export files to HTML and XHTML. In addition, Draw and Impress can export 
to a range of image formats.

To export to one of these formats, choose File > Export. On the Export dialog, specify a file 
name for the exported document, then select the desired format in the file format list and click the
Export or Save button as appropriate.
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