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Introduction

LibreOffice can be used without requiring a pointing device, such as a mouse or trackball, by 
using the keyboard shortcuts that are available in LibreOffice. Tasks as varied and complex as 
docking and undockingtoolbars and windows, or changing the size or position of objects, can all 
be accomplished using keyboard shortcuts. Although LibreOffice has an extensive set of 
keyboard shortcuts, each LibreOffice module has keyboard shortcuts that are specific to that 
module.

This appendix lists some of the more common keyboard shortcuts that apply to multiple 
components of LibreOffice. For shortcuts specific to Writer, Calc, Impress, Draw, Math, or Base, 
refer to the relevant user guide or search the LibreOffice Help.

To assist the user with identification of useful keyboard shortcuts, shortcuts are indicated by text 
next to menu items and as tooltips for some tools on the toolbars. In Writer, for example, some 
commonly used keyboard shortcuts are as follows:

• The menu item File > Open includes text indicating that Ctrl+O (macOS ⌘+O) is a 
keyboard shortcut.

• The Align Left tool in the Formatting toolbar has a tooltip indicating that Ctrl+L 
(macOS ⌘+L) is a keyboard shortcut.

LibreOffice provides further information about the keys used and the available keyboard 
shortcuts in the list presented on the Keyboard tab of the Customize dialog for Linux/Windows 
(Figure 1) or macOS (Figure 2).

Figure 1: Customize dialog – Keyboard tab for Linux (Windows is similar)
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Figure 2: Customize dialog – Keyboard tab in macOS

Note

Some keyboard shortcuts listed may not be available if the operating system uses
the same shortcuts for other tasks. To resolve any conflicts, assign different keys 
to these shortcuts by reconfiguring either LibreOffice (see Chapter 13, 
Customizing LibreOffice) or the operating system (see operating system 
documentation or help).

Assistive tools in LibreOffice

In addition to keyboard shortcuts, LibreOffice supports some assistive technology tools like 
screen magnification software, screen readers, and on-screen keyboards. Please note that 
except for the Windows platform, accessibility support relies on Java technology for 
communications with assistive technology tools. This means that the first program startup may 
take a few seconds longer, because the Java runtime environment has to be started as well.

A current list of supported assistive tools can be found on the Wiki at 
https://wiki.documentfoundation.org/Accessibility.
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Information for macOS users

Some keystrokes and menu items are different in macOS than those used in Windows or Linux. 
Table 1 gives the common substitutions that are used in a LibreOffice document. For a more 
detailed list, see LibreOffice Help.

Table 1: macOS equivalent keystrokes

Windows or Linux macOS equivalent Effect

Tools > Options 
menu selection

LibreOffice > Preferences Access setup options

Right-click Control+click or right-click 
depending on computer setup

Open a context menu

Ctrl (Control) ⌘ (Command) Used with other keys

Alt  (Option)⌥  or Alt, depending 
on keyboard

Used with other keys

F11 ⌘+T Open Styles deck in Sidebar

Note

Actual keys available on a macOS keyboard depend on the type of keyboard 
being used. For example, a macOS laptop keyboard may not have a Delete key,
but a macOS keyboard with a numeric keypad does have a Delete key.

Note

Some keyboard shortcuts are not available for computers using macOS. This is 
indicated in the following tables by a blank cell.

Keyboard shortcuts

Note

Some of the shortcut keys may be assigned to the computer operating system 
and are not available for LibreOffice. Either assign different keys in LibreOffice 
using Tools > Customize > Keyboard on the Menu bar, or in the computer 
operating system. For more information, see Chapter 13, Customizing LibreOffice
or the documentation/help for the computer operating system.

Using keyboard shortcuts
LibreOffice functions can easily be used by using keyboard shortcuts. For example, the Ctrl+O 
(macOS ⌘+O) keyboard shortcut is shown next to Open in the File menu on the Menu bar. To 
use this keyboard shortcut, press and hold down the Ctrl (macOS ⌘) key and then press the O 
key. Release both keys together after the dialog box opens.
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Opening menus and menu items
Table 2: Keys for opening menus and menu items

Windows
Linux

macOS Effect

Alt+<?>

Windows only

Opens a menu where <?> is an underlined character
of the menu being opened. For example, Alt+F 
opens the File menu.

When a menu is opened, there may be submenu 
items with underlined characters. Press the 
underlined character directly to carry out the action 
or option.

Where two menu items have the same underlined 
character, press the character key again to move to 
the next menu item.

Menu items that have no underlined character have 
to be clicked on directly.

Esc Esc Closes an open menu.

F6

Repeatedly pressing F6 switches the focus through 
the following objects:

• Menu bar

• Every toolbar from top to bottom and from 
left to right

• Every free window from left to right

• Document

F6

Repeatedly pressing F6 switches the focus through 
the following objects:

• Each toolbar from top to bottom and from 
left to right

• Sidebar

• Document

Shift+F6 Shift+F6
Switches focus through objects in the opposite 
direction.

Ctrl+F6 ⌘+F6 Switches the focus to the document.

F10 Switches focus to the Menu bar and back.

Accessing menu commands
1) Press Alt or F6 or F10 to select the first item on the Menu bar (normally the File menu). 

In macOS, selection is the first tool on the Standard toolbar.

2) Press the right or left arrow to move the selection right or left.

3) Press the Home key (macOS Fn+left arrow) or End key (macOS Fn+right arrow) 
to move menu selection to the first or last item on the Menu bar.

4) Press the down or up arrow to move the selection down or up the list of menu commands.

5) If necessary, press the right arrow to open any submenus on the selected menu. 
Submenus are indicated by a triangle ► next to the name of the selected menu.
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6) If necessary, press the down or up arrow to move the selection down or up the list of 
submenu commands.

7) If necessary, press the left arrow to close a submenu.

8) Press Enter to run the selected menu or submenu command.

Accessing toolbar commands
1) Press F6 repeatedly until the first icon on a toolbar is selected.

2) On a horizontal toolbar, press the right or left arrows to move tool selection to the right or 
left.

3) On a vertical toolbar, press the up or down arrows to move tool selection upward or 
downward.

4) Press the Home key (macOS Fn+left arrow) or End key (macOS Fn+right arrow) 
to move tool selection to the first or last tool on a toolbar.

5) Press Enter to action the selected tool on the toolbar.

6) To insert an object into a drawing or presentation after selecting the required object on the
Drawing toolbar, use the key combination Ctrl+Enter (macOS ⌘+Enter) to insert the 
object in the center of the drawing page or slide.

Note

If a tool on a toolbar has an editable text field, for example Load URL or Line 
Width, the Tab or Shift+Tab keys are then used to move the selection right or 
left onto the next tool on the toolbar.

Navigation and selection
Navigate through a document and make selections using the keyboard is as follows:

• To move the cursor, use one of the keys or key combinations given in the following table.

• To select any text while moving the cursor, hold down the Shift key as the cursor is 
moved.

• To select a word, position the cursor in the word and double-click.

• To select a sentence, position the cursor in the sentence and triple-click.

• To select a paragraph, position the cursor in the paragraph and click four times.

• To select all of the text or objects in a document, use Ctrl+A (macOS ⌘+A).

• Use Ctrl+Del (macOS ⌘+Delete) to delete everything from the cursor position to the 
end of the word.

Table 3: Keys for navigation and selection

Windows
Linux

macOS Effect

Left Arrow
Left Arrow
Ctrl+B

Moves the cursor one character to the left.

Right Arrow
Right Arrow
Ctrl+F

Moves the cursor one character to the right.
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Windows
Linux

macOS Effect

Ctrl+Left 
Arrow ⌥+Left Arrow Moves the cursor one word to the left.

Ctrl+Right 
Arrow

⌥+Right 
Arrow Moves the cursor one word to the right.

Up Arrow
Up Arrow
Ctrl+P

Moves the cursor up one line.

Down Arrow
Down Arrow
Ctrl+N

Moves the cursor down one line.

Ctrl+Up or 
Down Arrow

⌥+Up or Down 
Arrow

Moves the cursor up or down to the beginning of 
the previous or next paragraph.

Home
Fn+Left 
arrow
Ctrl+A

Moves the cursor to the beginning of the current 
line.

Ctrl+Home ⌘+Up Arrow Moves the cursor to the beginning of the document.

End
Fn+Right 
arrow
Ctrl+E

Moves the cursor to the end of the current line.

Ctrl+End ⌘+Down 
Arrow Moves the cursor to the end of the document.

Page Up Fn+Up Arrow Scrolls up one page.

Ctrl+Page 
Up

+Fn+Up⌘  
Arrow Moves the cursor to the header.

Page Down Fn+Down 
Arrow Scrolls down one page.

Ctrl+Page 
Down

+Fn+Down⌘  
Arrow Moves the cursor to the footer.

Controlling dialogs
When opening any dialog, one element (for example button, option field, entry in a list box, or 
checkbox) is highlighted indicating that the element has focus on it. How the element is 
highlighted depends on the operating system and how the computer is setup.

Table 4: Keys for controlling dialogs

Shortcut Keys Result

Enter
Activates selected button.

When no button is selected, Enter is equivalent to clicking OK.

Esc

Closes dialog without saving any changes made while the dialog 
was open.

Esc is also equivalent to clicking Cancel.

When a drop-down list is open and selected, Esc closes the list.

Spacebar Checks or clears an empty checkbox.
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Shortcut Keys Result

Up or Down arrow
Moves focus up and down a list.

Increases or decreases value of a variable.

Moves focus vertically within a section of dialog.

Left or Right 
arrow Moves focus horizontally within a section of a dialog.

Tab Advances focus to the next section or element of a dialog.

Shift+Tab Returns focus to the previous section or element in a dialog.

Alt+Down arrow

(macOS ⌥+Down 
arrow)

Shows items in a drop-down list.

Controlling documents and windows
Table 5: Keys for controlling documents and windows

Windows
Linux

macOS Effect

Ctrl+O ⌘+O Opens the Open dialog to select and open a 
document.

Ctrl+S ⌘+S
Saves the current document. If the document is a 
previously unsaved file, the shortcut opens the 
Save As dialog.

Ctrl+N ⌘+N Creates a new document.

Shift+Ctrl+
N

⌘+Shift+N Opens the Templates dialog.

Ctrl+P ⌘+P Opens the Print dialog to print the document.

Ctrl+F ⌘+F Opens the Find toolbar.

Ctrl+H ⌥+⌘+F Opens the Find and Replace dialog.

Ctrl+Shift+
F Searches for the last entered search term.

Ctrl+Shift+
J

Toggles the view between full-screen mode and 
normal mode in Writer or Calc.

Ctrl+Shift+
R

⌘+Shift+R Opens and closes the rulers.

F1 F1

Opens the LibreOffice Help contents in your default
browser. If the local Help package is not installed, 
LibreOffice opens the online Help located at 
https://help.libreoffice.org.

Shift+F1 Shift+F1

Turns the cursor into a What’s This? question 
mark. Shows the tip for an item underneath the 
cursor. The shortcut does not work with the online 
help.

Shift+F2 Shift+F2
Turns on Extended Tips for the currently selected 
command, icon or control. The shortcut does not 
work with the online help.
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Windows
Linux

macOS Effect

Ctrl+Shift+
F10

⌘+Shift+F1
0

Docks and undocks floating toolbars, Sidebar and 
Navigator.

Ctrl+F4 or 
Alt+F4

+F4⌘ Closes the current document. Closes LibreOffice 
when the last open document is closed.

Ctrl+Q +Q⌘ Exits LibreOffice.

Editing or formatting documents
Table 6: Keys for editing or formatting documents

Windows
Linux

macOS Effect

Enter Enter

When an OLE object is selected, activates the 
software used to create the OLE object.

When a drawing object is selected, activates text 
mode.

Ctrl+X +X⌘ Cuts selected text or objects from a document and 
places them in the clipboard.

Ctrl+C +C⌘ Copies selected text or objects and places them in 
the clipboard.

Ctrl+V +V⌘ Places text or objects from the clipboard that have 
copied or cut into the document.

Ctrl+Alt+S
hift+V

+⌘ ⌥+Shift+
V

Pastes unformatted text from the clipboard. The text
is pasted using the format that exists at the 
insertion point.

Ctrl+Shift
+V +Shift+V⌘ Opens the Paste Special dialog.

Ctrl+A +A⌘ Selects all text and objects in a document.

Ctrl+Z +Z⌘ Undoes last action.

Ctrl+Y +Y⌘ Redoes last action.

Ctrl+Shift
+Y

+Shift+Y⌘ Repeats last command.

Ctrl+I +I⌘ Applies the Italic attribute to selected characters 
and text.

Ctrl+B +B⌘ Applies the Bold attribute to selected characters 
and text.

Ctrl+U +U⌘ Applies the Underline attribute to selected 
characters and text.

Ctrl+M +M⌘
Removes direct formatting from selected text or 
objects. This command is also available in Format 
> Clear Direct Formatting in the Menu bar.
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Sidebar keyboard shortcuts

General
Table 7: General keyboard shortcuts for the Sidebar

Windows
Linux

macOS Effect

Tab Tab Moves the focus in the Sidebar.

Shift+Tab Shift+Tab Moves the focus in the reverse direction in the 
Sidebar.

Shift+F10 Shift+F10 Opens a context menu for the selected element in 
the Sidebar.

Home
Fn+Left 
Arrow Moves focus to first entry.

End
Fn+Right 
Arrow Moves focus to last entry.

Up or Down 
Arrow

Up or Down 
Arrow

Moves the selection up or down and opens the 
panels in the selected deck.

Right 
Arrow

Right Arrow Opens any sub-elements in the selected element.

Left 
Arrow

Left Arrow Closes any sub-elements in the selected element.

Ctrl+Ente
r

+Enter⌘ Opens the Properties dialog for the selected 
element.

Gallery
Table 8: Keyboard shortcuts for Gallery in Sidebar

Windows
Linux

macOS Effect

Ctrl+R
Opens the Enter Title dialog. Only themes 
added to LibreOffice can be renamed. Themes 
installed with LibreOffice cannot be renamed.

Ctrl+D +D⌘
Deletes themes that have been added to 
LibreOffice. Themes installed with LibreOffice 
cannot be deleted.

Insert Inserts a new theme into the Gallery and opens 
the Insert of New Theme dialog.

Ctrl+Shift+In
sert

+Shift+Ins⌘
ert

Inserts the selected object as a linked object 
into the current document.

Ctrl+I Ctrl+I Inserts a copy of the selected object into the 
current document.

Ctrl+P
Spacebar
Enter

Ctrl+P
Spacebar
Enter

Switches between a view of a list of object 
previews and a selected object.
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Database table keyboard shortcuts

Table 9: Keyboard shortcuts for database tables

Windows
Linux

macOS Effect

Ctrl+Shift+F
4

+Shift+F4⌘ Opens and closes a database table in a 
document for editing.

Spacebar Spacebar Toggles row selection, except when the row is in
edit mode.

Ctrl+Spaceba
r

+Spacebar⌘ Toggles row selection.

Shift+Spaceb
ar

Shift+Spaceb
ar Selects the current column.

Ctrl+Page Up +⌘ ⌥ + Fn+ 
Up Arrow Moves the cursor to the first row.

Ctrl+Page 
Down

+⌘ ⌥ + Fn+ 
Down Arrow Moves the cursor to the last row.

Controlling macros

Table 10: Keys for controlling macros

Windows
Linux

macOS Effect

Ctrl+* (multiplication 
sign on number pad only)

+* ⌘ (multiplication sign
on number pad only)

Runs a macro field.

Shift+Ctrl+Q +Ctrl+Q⌘ Stops a running macro.

Note

For more information on macros, see Chapter 11, Getting Started with Macros.

Entering Unicode numbers

Each character in LibreOffice can be entered into a document by typing its Unicode hexadecimal 
number and then pressing Ctrl+Alt+X (mac OS ⌘+⌥+X). For example, to enter the copyright 
sign into text, type U+00A9 followed immediately by Ctrl+Alt+X (mac OS ⌘+⌥+X) and the 
copyright sign © appears at the cursor position in the text.

Note

Unicode hexadecimal numbers in the range U+0000 to U+0020 are not converted
into characters using the conversion shortcut Ctrl+Alt+X (mac OS ⌘+⌥+X).

Defining keyboard shortcuts

In addition to using the built-in keyboard shortcuts listed in this Appendix, custom keyboard 
shortcuts can be defined. For more information, see Chapter 13, Customizing LibreOffice.
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To check if a keyboard shortcut is is already in use, open the Keyboard page in the Customize 
dialog and scroll though the listed keyboard shortcuts. Go to Tools > Customize on the Menu 
bar to open the Customize dialog.

Further reading

For help with keyboard shortcuts, or using LibreOffice with a keyboard only, search the 
application Help using the keywords “shortcut keys” or “accessibility”.
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