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Using LibreOffice on macOS

Some keystrokes and menu items are different on macOS from those used in Windows and
Linux. The table below gives some common substitutions for the instructions in this document.
For a detailed list, see the application Help.

Windows or Linux macOS equivalent Effect

Tools > Optllons LibreOffice > Preferences Access setup options

menu selection
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: Open a context menu

depending on computer setup

Ctrl (Control) 3 (Command) Used with other keys

Alt \_ (Option) or Alt, depending on  Used with other keys
keyboard
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Introduction

Fields are used for a variety of purposes: for example, data that changes (such as the current
date or the total number of pages) or might change (the name of a product or book under
development), user-defined numbering sequences, automatic cross-references, and conditional
content (words or paragraphs that are visible or printed in some conditions but not others). Index
entries are also fields.

This chapter describes some common uses of fields. A full discussion of fields and their use is
beyond the scope of this book. Power users can find more details in the application Help.

OTip

Fields have a gray background when viewed on screen, unless you have deselected
View > Field shadings on the Menu bar or changed the color of field shadings in
Tools > Options > LibreOffice > Application Colors. This gray background does
not show when you print the file or export to PDF.

Keyboard shortcuts for fields
Here are some handy keyboard shortcuts to use when working with fields:

Ctrl+F2 Open the Fields dialog.
Ctrl+F8 Turn field shadings on or off.
Ctrl+F9 Show or hide field nhames.
F9 Update fields.

Quick and easy field entry

To quickly insert common fields into your document, choose Insert > Page Number or Insert >
Field on the Menu bar and selecting the required field in the submenu.

Page Number

Page Number
Header and Footer 3 Page Count
Date
Erl'lvelc:-pe.,. _ Time
Signature Line... Title
First Author
Subject

More Fields... 38F2

Figure 1: Inserting common fields

Using document properties to hold metadata and information
that changes

The Properties dialog (File > Properties) for a document has six tabs. The information on the
General tab and the Statistics tab is generated by the program. Some information (the name of
the person on the Created and Modified lines of the General tab) is derived from the User Data
page in Tools > Options > LibreOffice. The options on the Font and Security tabs are discussed
elsewhere in this book.
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Use the Description and Custom Properties tabs for:

* Metadata to assist in classifying, sorting, storing, and retrieving documents. Some of this
metadata is exported to the closest equivalent in HTML and PDF; some fields have no
equivalent and are not exported.

* Information that changes. You can store data for use in fields in your document; for
example, the title of the document, contact information for a project participant, or the
name of a product might change during the course of a project.

This dialog can be used in a template, where the field names can serve as reminders to writers of
information they need to include. (Placeholders can serve a similar function within the text; see
page 20.)

You can return to this dialog at any time and change the information you entered. When you do
so, all of the references to that information will change wherever they appear in the document.
For example, on the Description tab (Figure 2) you might need to change the contents of the Title
field from the dratft title to the production title.

'eo @ Properties of “WG7217-Fields_JHW"
General Description Custom Properties Security Font Statistics

Title:  Chapter 17 Fields
Subject:

Keywords:

Comments:

Figure 2: The Description tab of the document’s Properties dialog

Use the Custom Properties tab (Figure 3) to store information that does not fit into the fields
supplied on the other tabs of this dialog.

-rr. ; ® Properties of "WG7217-Fields_JHW"
General Description Custom Properties Security Font Statistics
Name Type Value
Guide Name B Tex B  writer Guide X
LibreOffice Version 8 Tex 7.2

Figure 3: Custom Properties tab

When the Custom Properties tab is first opened in a new document, it may be blank. If the new
document is based on a template, this tab may contain fields.

Click the Add Property button in the lower right of the tab (not shown in illustration) to insert a
row of boxes where you can enter your custom properties.

* The Name box includes a drop-down list of typical choices; scroll down to see all the
choices. If none of the choices meet your needs, you can type a new name into the box.

* Inthe Type column, you can choose from Text, DateTime, Date, Duration, Number, or
Yes or no for each field. You cannot create new types.

* Inthe Value column, type or select what you want to appear in the document where this
field is used. Choices may be limited to specific data types depending on the selection in
the Type column; for example, if the Type selection is Date, the Value for that property is
limited to a date.

Using document properties to hold metadata and information that changes | 5



To remove a custom property, click the button at the right-hand end of the row.

OTip

To change the format of the Date value, go to Tools > Options > Language
Settings > Languages and change the Locale setting.

Using other fields to hold information that changes

One way that people use fields is to hold information that is likely to change during the course of
a project. For example, the name of a manager, a product, or even your entire company may
change. If you have inserted the changeable information as fields, you can change the
information in one place, and it will automatically change in all the places where that field occurs.

Writer provides several places where you can store the information referred to by a field. We will
look at some of them here.

Seven document properties (Page Number, Page Count, Date, Time, Title, First Author, and
Subject) are on the Insert > Field menu (Figure 1). To insert one of these fields, click it in the
menu. Some of these fields get their information from the Document Properties dialog (Figure 2).

Other document properties are on the Doclnformation and Document tabs of the Fields dialog
(Figures 4 and 5), reached by choosing Insert > Field > More Fields or pressing Ctrl+F2.

The Custom item in the Type list on the DocInformation tab is derived from the Custom
Properties tab of the Document Properties dialog (Figure 3); it does not appear on the list if no
custom properties have been defined.

Some of the field values are picked up from the User Data page of the Tools > Options >
LibreOffice dialog, so make sure the information on that page is correct.

To insert one of these fields, select it in the Type list and then select in the Select and Format lists
if choices appear. Finally, click Insert.

[ EON ) Fields
Document  Cross-references  Functions Variables  Database
Type Select Format
Comments Author 12/31/99
Created Time 12/31/1999
v Custom iDate” i Dec31,99
Guide Name Dec 31, 1999
LibreOffive Version 31. Dec. 1999
Keywords December 31, 1999
Last printed 31. December 1999
Modified Fri, Dec 31, 99
Revision number Fri 31/Dec 99
Subject Fri, December 31, 1999
Title Friday, December 31, 1999
Total editing time 12-31
99-12-31
1999-12-31
12/99
Dec 31
Fixed content

Help Close | Insert |

Figure 4: Inserting a Date Modified field using the DocInformation tab of the Fields dialog
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[ JoN | Fields

w. Cross-references  Functions  Doclnformation  Variables  Database
Type Select Format
Author File name
Chapter File name without extension
Date Path
File name Path/File name
Page
Paragraph Signature
Sender
Statistics
Templates
Time

Figure 5: Inserting a File name field using the Document tab of the Fields dialog

OTip

Although these fields are often used to hold information that changes, you can make
the content unchangeable by selecting the Fixed content option (visible in Figure 4,
lower right) when inserting the field. If necessary, you can come back to this dialog
later and deselect this option to make the field variable again. For example, if you
use a field to insert the creation date of a document, you do not want that date to
change.

Using AutoText to insert often-used fields

If you use the same fields often, you can use AutoText as a quick and easy way to insert them.
To define an AutoText entry for a field:

1) Insert a field into your document, as described previously.
2) Select the field you inserted, and then choose Tools > AutoText (or press Ctrl+F3).

3) On the AutoText dialog (Figure 6), choose the group where this new entry will be stored
(in this example, My AutoText), type a name for the entry, and change the suggested
shortcut if you wish.

4) Click the AutoText button and click New to have the entry inserted as a field. Do not
choose New (text only) because the AutoText entry will be plain text, not a field. (The
New selections do not appear until you have selected a group and typed a name for the
entry.)

5) Click Close to close the AutoText dialog.
6) To insert this field at the cursor position, type the shortcut and press F3.
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@ @ AutoText

Display remainder of name as suggestion while typing
Name: |sample Shoricut: s

» Business Cards, Work (3 ¥z x 2)
My AutoText

» Only for Templates

» Standard

Save Links Relative To

File system Internet

Help AutoText ~ | Categories... Path... Close Insert

o New E

Mew (text only)

Import...

Figure 6: Creating a new AutoText entry

Defining your own humbering sequences

You may want to define your own numbering sequences to use in situations where you do not
always want the number at the start of the paragraph, or where you want more control than the
built-in numbering choices give you, or where list styles do not do what you want.

This topic describes how to create a numbering sequence, using a number range variable field.
To create a number range variable using Arabic (1 2 3) numbers:

1) Position the cursor in a blank paragraph in your document.

2) Choose Insert > Field > More Fields or press Ctrl+F2, then select the Variables tab
(Figure 7).

3) Inthe Type list, select Number range. In the Format list, select Arabic (1 2 3). Type
whatever you want in the Name field. (We have used Step in this example.)

4) Click Insert. The name of the variable (Step) now appears in the Selection list, and a
number field (showing 1) appears at the insertion point in your document. The Fields
dialog remains open.

7) If you click several more times on the Insert button in the Fields dialog, the numbers 2, 3,
4, and so on will appear in the document.

5) You can now delete the fields you inserted; the Step sequence remains in the Select box
in the Fields dialog (in this document only). You can insert this field at any place in the
document.

To avoid doing all of that every time you want to put in a Step number, create an AutoText entry
for Step. Then you can insert the field in the same way you would insert any other AutoText. See
“Using AutoText to insert often-used fields” on page 7.
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Type

Set variable

Show variable

DDE field

Insert Formula
Input field

Number range

Set page variable
Show page variable
User Field

Name

Step

Help

Document | Cross-references |

Select

Drawing
Figure
Illustration
Table

Text

Value

Fields

Functions  Docinformation JEUE R Database
Format

Arabic (1 2 3)

P e L e i (A

1st, 2nd, 3rd, ...

One, Two, Three, ...

First, Second, Third, ...

A, B, .., Aa, AB, ... (Bulgarian)
a, b, .., aa, ab, ... (Bulgarian)
A, B, .., Aa, BB, ... (Bulgarian)
a, b, .., aa, 66, ... (Bulgarian)

Numbering by Chapter
Level None E

Separator

cose | (EZEN

Figure 7: Defining a number range variable

ﬂTip

If a user-defined variable is not in use in the document, the X icon next to the Value
box is active. You can delete the variable by clicking this icon. To remove a variable
that is used in the current document, first delete from the document all fields using
that variable, and then remove the variable from the list.

Using automatic cross-references

If you type in cross-references to other parts of the document, those references can easily get
out of date if you reword a heading, add or remove figures, or reorganize topics. Replace any
typed cross-references with automatic ones and, when you update fields, all the references will
update automatically to show the current wording or page numbers.

The Cross-references tab of the Fields dialog (Figure 8) lists some items, such as headings,
numbered paragraphs, and bookmarks. If figure captions, table captions, user-defined number
range variables, and some other items have been defined in a document, that type also appears

in the list.

OTip

Some people use Writer's Hyperlink feature for cross-references. However, the
visible text of the hyperlink does not change if you change the text of the item to
which it links. For that reason, you are advised to use cross-references in most
situations. The exception is when the document is to be saved as HTML; cross-
references do not become hyperlinks in an HTML document, so you need to use
hyperlinks in the Writer document.

Using automatic cross-references | 9




Fields

Document Functions  Doclnformation  Variables  Database

Type
Set Reference
Insert Reference
Headings
Numbered Paragraphs
Figure
Bookmarks
Footnotes

Insert reference to

Selection

Filter Selection

Introduction
Keyboard shortcuts for fields
Quick and easy field entry
Using document properties to hold metadata and information that changes
Using other fields to hold information that changes
Using AutoText to insert often-used fields
Defining your own numbering sequences
Using automatic cross-references
Inserting cross-references

Zzg\eter Available formats
"Refeience Preparing items as targets for cross-referencing
IAbovefBeIow Using bookmarks

Setting references
As Page Style
Number o S
Number (no context) Name | Copyright
MNumber (full context)

Value
Help SN insert |

Figure 8: The Cross-references tab of the Fields dialog

Inserting cross-references
To insert a cross-reference to a heading, figure, or other item shown on the Cross-references tab:

1) Place the cursor where you want the cross-reference to appear in the document.

2) If the Fields dialog is not open, choose Insert > Cross-reference or press Ctrl+F2. On
the Cross-references tab (Figure 8), in the Type list, click the type of item you are
referencing (for example, Headings or Figure).

3) Click the required item in the Selection list, which shows both automatically created
entries (for example, Headings) and user-defined references (for example, bookmarks).

4) In the Insert reference to list, choose the type of reference required. The choices vary
with the item being referenced (see “Formats for cross-references” below).

For headings, usually you will choose Reference (to insert the full text of the heading) or
Page (to insert the number of the page the heading is on).

For figures, usually you will choose Numbering (to insert only the figure number),
Category and Number (to insert the word “Figure” and its number), Reference (to insert
the word “Figure” with its number and the full text of the caption), or Page.

5) Click Insert.
For a full list of the reference formats available and their use, consult the Help.

Formats for cross-references
For all types of cross-reference, you can select from the following formats:

» Page: the page number of the target.
* Chapter: the number of the chapter where the referenced target is located.
* Reference: the full text set as reference.

* Above/Below: the word above or below depending on the position of the field relative to
the referenced target.
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* As Page Style: similar to Page, the page number where the reference is, but using the
formatting specified in the page style. This is very useful when putting a reference to a
page in the front matter where roman numerals are usually employed.

For headings or numbered paragraphs, three additional options are available:
* Number: Inserts the number of the heading or numbered paragraph, including superior
levels depending on the context.*

* Number (no context): inserts only the number of the heading or of the numbered
paragraph. For example, if referencing a numbered item 2.4, it inserts 4.

* Number (full context): inserts the full number including higher hierarchical levels. For
example, if referencing a numbered item 2.4, the full numbering (2.4) is inserted.

For objects inserted with captions such as a table or a figure, you can choose:
* Category and Number: inserts both the category and number of the referenced object
(for example, Figure 6). This is the most used formatting for figures and tables.

» Caption Text: inserts the full caption of the referenced object. For example, Figure 6:
This is an example figure.

* Numbering: inserts the sequential number of the referenced object, without the category
(for example, if referencing Table 2, the field will contain only the number 2).

Preparing items as targets for cross-referencing

Occasionally you might want to insert a cross-reference to something that is not automatically
shown on the Cross-references tab: an illustration without a caption or an item in a bullet list, for
example. Before you can insert a cross-reference to such an item, you must prepare the item as
a target to be referenced. To do this, you can either use bookmarks or set references.

After a target has been defined, you can cross-reference to it as described on page 10.

Using bookmarks

Bookmarks are listed in the Navigator and can be accessed directly from there. They can be
used only for location references such as page numbers, not for text references. In HTML
documents, bookmarks are converted to anchors that you can jump to using a hyperlink.

1) Select the text you want to bookmark, or click in the required place in the text. Choose
Insert > Bookmark.

2) On the Insert Bookmark dialog, the larger box lists any previously defined bookmarks.
Type a name for this bookmark in the top box. Click OK.

Setting references
Set references can be used for text references (such as headings or figure captions) as well as
location references. Be sure to select the entire text you want to use as a text reference.

1) Choose Insert > Cross-reference or press Ctrl+F2.

2) On the Cross-references tab of the Fields dialog (Figure 9), select Set Reference in the
Type list. The Selection list shows any references that have been defined. This dialog can
remain open while you set several items as references.

1 For example, when you are in a chapter 1, subchapter 2, subpart 5, this may be numbered as 1.2.5.
When you insert here a reference to text in the previous subpart "1.2.4" and you apply the "Number"
format, then the reference will be shown as "4". If in this example the nhumbering is set to show more
sublevels, the same reference will be shown as "2.4" or "1.2.4", depending on the setting. If you use
the "Number (full context)" format, you will always see "1.2.4", no matter how the numbered paragraph
is formatted.
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3) Click in the document and highlight the text of the first item to set as a target for a cross-
reference. Click on the Fields dialog. The text of the item will appear in the Value box in
the lower right. In the Name box, type some text by which you can identify this item.

4) Click Insert. The text you typed in the Name box now appears in the Selection list.

OTip

See Chapter 16, Master Documents, for how to create cross-references to other
subdocuments in a master document.

ok B Fields
Document [ReettoniECh-) Functions  Docinformation  Variables  Database

Type Selection

Set Reference Filter Selection

Insert Reference

Headings

Numbered Paragraphs

Figure

Bookmarks

Footnotes

Insert reference to

Name | Statistics|
Value | use fields like statistics
|

Help M insert |

Figure 9: Setting text to be used as a target for a cross-reference

Using fields in headers and footers

You may want to use fields like statistics while writing, and replace them with others, like Chapter,
when the document is ready for use.

You can insert fields into headers or footers, using techniques described earlier in this chapter:

* Toinsert a page number, document title, author, creation date and time, current date and
time, or total page count field, use Document Properties (see page 4) or choose Insert >
Field > [item] on the Menu bar.

* Toinsert a cross-reference to a bookmark, heading, or other item, you can use Insert >
Cross-reference or Insert > Field > More Fields > Cross-references (tab).

* If you have used Heading 1 for your chapter titles, you can use a Document field to insert
the current chapter title, so the header or footer contents change from one chapter to the
next. See Figure 10. (Writer calls chapter titles Chapter names.) If you have used outline
numbering on your Heading 1, you can choose whether to include these numbers in the
field (Chapter number and name). Use Insert > Field > More Fields > Document.

* You can insert cross-references to other heading levels by specifying a value in the Level
box in the lower right of the Document tab of the Fields dialog (Figure 10). That is,
Level 1 = Heading 1, Level 2 = Heading 2, and so on.
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Note

A cross-reference field in the header of a page picks up the first heading of that level
on the page, and a field in the footer picks up the last heading of that level on the

page.
[ JoN ) Fields
Cross-references  Functions  Doclnformation  Variables  Database
Type Select Format
Author Chapter name
Chapter Chapter number
Date Chapter number and name
File name Chapter number without separator

Page

Paragraph Signature
Sender

Statistics

Templates

Time

Level

1 [

Help cose | (IEZEN

Figure 10: Inserting the current chapter number and name into your document

* Toinclude the chapter number with the page number, position the cursor just before the
Page field you inserted. On the Document tab of the Fields dialog, select Chapter in the
Type column and Chapter number without separator in the Format column. Click
Insert.

Go to the header or footer where you inserted this field and type the character you want
to appear between the chapter number and the page number; for example, a hyphen.

The table of contents will not automatically pick up these chapter numbers, so you need
to make a change on the Entries tab of the Table of Contents, Index or Bibliography
dialog, as described in Chapter 15, Tables of Contents, Indexes, Bibliographies.

* You can add a page count to the footer; for example, Page 9 of 12. Type the word Page

and a space in front of the Page field. Type a space, the word of, and a space after the
Page field. Then choose Insert > Field > Page Count.

Developing conditional content

Conditional content is text and graphics that are included or excluded from a document
depending on a condition you specify.

A simple example is a reminder letter for an overdue account. The first and second reminders
might have a subject line of “Reminder Notice”, but the third reminder letter might have the
subject “Final Notice” and a different final paragraph.

A more complex example is a software manual for a product that comes in two versions, Pro and
Lite. Both product versions have much in common, but the Pro version includes some features
that are not in the Lite version. If you use conditional content, you can maintain one file
containing information for both versions and print (or create online help) customized for each
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version. You do not have to maintain two sets of the information that is the same for both
versions, so you will not forget to update both versions when something changes.

OTip

In some cases, the same effect can be obtained by hiding a paragraph or character
style; see Chapter 9, Working with Styles.

Choose the types of conditional content to use

This section describes several Writer features that can help you design and maintain conditional
content. You can use one or any combination of these features in the same document.

Conditional text

With conditional text, you can have two alternative texts (a word, phrase, or sentence). One
text will be displayed and printed if the condition you specify is met, and the other will be
displayed and printed if the condition is not met. You cannot include graphics or edit the
text except in the Field dialog (not in the body of the document). You also cannot format
part of the text (for example, bold one word but not the others), but you can format the field
to affect all of the field contents (for example, making all of the words bold or italic). You
cannot include a cross-reference or other field in the text.

Hidden text
With hidden text (a word, phrase, or sentence), you have only two choices: show or hide. If
the condition you specify is met, the text is hidden; if the condition is not met, the text is
displayed. The disadvantages are the same as for conditional text: you cannot include
graphics, edit the text in the body of the document, format part of the text, or include a field.

Hidden paragraphs
Hidden paragraphs are like any other paragraphs, but you can specify a condition under
which the paragraph is not displayed or printed. A blank paragraph can also be hidden, for
example if a database field has no content for the current record. This is very useful when
merging an address into a letter: if you allow two lines for the street address and the
database record uses only one line, you can prevent the blank line from appearing in your
document. You can include graphics, edit the text in the body of the document, format any
part of the text, and include fields.

Hidden sections
Hidden sections are like hidden paragraphs, but they can include more than one
paragraph, for example, a heading plus one or more paragraphs. However, a section
cannot contain less than a paragraph, so you cannot use this method for single words or
phrases. The contents of a hidden section behave just like the contents of any other part of
the document, but you can specify a condition under which the section is not displayed or
printed. In addition, you can password protect a section.

Plan your conditional content

Conditions are what programmers call logical expressions. You must formulate a logical
expression for each condition because a condition is always either true (met) or false (not met).
You can use the same condition in many places in your document, for different types of
conditional content.

To make conditional content work, you need to:

1) Choose or define a variable.
2) Define a logical expression (condition) involving the selected variable.
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Choose or define a variable
You can use the following variables in your condition:

e User-defined variables

« Predefined LibreOffice variables, which use statistical values from the document
properties

* User data
» Database field contents—for example, from your address book

You cannot use internal variables (for example, page number, or chapter name) to formulate
conditions.

Define a logical expression (condition) involving the variable

The condition compares a specified fixed value with the contents of a variable or database field.
To formulate a condition, use the same elements as you would to create a formula: operators,
mathematical and statistical functions, number formats, variables, and constants. The possible
operators, and many examples of use, are given in the Help; look in the index under Defining

Conditions and conditional. You can define quite complex expressions, but in most cases a
simple condition will do the job.

Create the variable

To create the variable, you can use choices found on the Doclnformation, Variables, and
Database tabs of the Fields dialog.

DocInformation fields

“Using document properties to hold metadata and information that changes” on page 4 described
how to set up a custom document property. You can use that document property as the variable
in your condition statement.

User-defined variable field
To set up a variable or user field:

1) Place the cursor where you want the field to be inserted.
2) On the Fields dialog, select the Variables tab (Figure 13).

3) Select Set variable in the Type list and Text in the Format list. Type a hame for the
variable in the Name box, and a value in the Value box. | have chosen ProLite for the
name (to remind me that this variable is related to the two product versions), and | set the
value as Lite because | can remember “If it is the Lite version, then this text should be
hidden.”

4) Select Invisible so the field does not show in the document. Click Insert, then click
Close. A small gray mark will appear where you inserted the field.
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® 0 Fields

Document  Cross-references  Functions  Doclnformation Database
Type Select
Set variable Text
Show variable General
DDE field -1235
Insert Formula -1234.57
Input field -1,235
MNumber range -1,234.57
Set page variable Additional formats...
Show page variable
User Field

Invisible
Name Value
ProLite Lite
Help cose | (N

Figure 11: Defining a variable to use with conditional content

eTip

Because the gray mark is so small, you may have trouble finding it again, especially
if you have other fields in the document. You may prefer to leave the variable field
visible while you work, and change it to invisible just before you create final copy.

At any time, you can place the insertion point just before the field and choose Edit >
Fields or right-click the field and choose Fields in the context menu. On the Edit
Fields dialog (Figure 16), select or deselect Invisible.

Apply the condition to the content

Now that you have defined the variable, you can use it in a condition statement. This topic
describes some of the possibilities.

Conditional text

First, let us set up some conditional text that will insert the words Great Product Lite into the Lite
version and Great Product Pro into the Pro version of the manual. You would use this field
whenever you want to mention the name of the product.

1) Place the cursor where you want one of these phrases to appear. (You can move or
delete it later, if you wish.)

2) On the Functions tab of the Fields dialog, select Conditional text in the Type list.
3) As shown in Figure 12, type ProLite EQ "Lite" in the Condition box, Great

Product Lite inthe Then box, and Great Product Pro inthe Else box.

Note

These fields are case-sensitive, and quotation marks are required around a text
value such as Lite.

4) Click Insert to insert the field, then click Close. You should see Great Product Lite in the
text.
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[ JoN ) Fields

Document  Cross-references Rgiil=(-uEly Doclnformation  Variables  Database

Type Format Condition
Conditional text ProLite EQ "Lite"
Input list
Input field Then
Execute macro
Placeholder Great Product Lite
Combine characters
Hidden text Else
Hidden Paragraph Great Product Pro

Figure 12: Inserting conditional text

ﬂTip

If you want to insert this field into your text in many places (as you probably would for
a product name), create an AutoText entry for it. See “Using AutoText to insert often-
used fields” on page 7 for instructions.

Hidden text

You might use hidden text for words or short phrases that describe features of Great Product Pro
that are not found in the Lite version. You can reuse the same field in several places in the
document—for example, by copying and pasting it. To create a hidden text field:

1) On the Functions tab of the Fields dialog, select Hidden text in the Type list (Figure 13).

[ JoN ] Fields
Document  Cross-references Ugi< bl Docinformation  Variables — Database
Type Format Condition
Conditional text ProLite EQ "Lite"
Input list
Input field Hidden text
Execute macro
Placeholder , and six color choices
Combine characters
Hidden text
Hidden Paragraph Macro

Figure 13: Creating a condition for hidden text

2) Type ProLite EQ "Lite" in the Condition box and type the required text in the Hidden
text box. Remember, this is the text that is hidden if the condition is true.

3) Click Insert to create and insert the field.
To show all hidden text so you can edit it, do one of the following:
* Onthe Tools > Options > LibreOffice Writer > View page, select the Display fields:
Hidden text option.

» Double-click in front of the variable that you used to define the condition for hiding the
text, and enter a different value for the variable.

Hidden paragraphs
A conditional paragraph is hidden if the condition is true. To hide a paragraph:
1) Click in the paragraph to be hidden.

2) On the Functions tab (Figure 14) of the Fields dialog, select Hidden Paragraph in the
Type list.

3) For this example, type ProLite EQ "Lite" in the Condition box.
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4) Click Insert to create and insert the field.

® 0 Fields

Document  Cross-references J=luthy Docinformation  Variables  Database

Type Format Condition
Conditional text ProLite EQ "Lite"|
Input list
Input field Value

Execute macro
Placeholder
Combine characters
Hidden text

Hidden Paragraph

Macro

Figure 14: Creating a condition for a a hidden paragraph
To show all hidden paragraphs so you can edit them, do one of the following:

* Choose View > Field Hidden Paragraphs on the Menu bar.

* On the Tools > Options > LibreOffice Writer > View page, select the Display Fields:
Hidden paragraphs option.

* Double-click in front of the variable that you used to define the condition for hiding the
paragraph, and enter a different value for the variable.

Hidden sections
A conditional section is hidden if the condition is true. To create a conditional section:

1) Select the text that you want to be included in the conditional section. (You can edit this
text later, just as you can edit any other text.)

2) Choose Insert > Section. On the Insert Section dialog (Figure 15), go to the Section tab,
then select Hide and enter the condition in the With Condition box. You can also give
the section a hame; this is strongly recommended, so you can find it again easily if you
have several sections in your document.

3) Click Insert to insert the section into your document.
To show a hidden section so you can edit it:
1) Choose Format > Sections.

2) On the Edit Sections dialog (similar to the Insert Section dialog), select the section from
the list.

3) Deselect Hide and click OK. You can now edit the contents of the section. Afterwards,
you can choose Format > Sections and select Hide to hide the section again.

To make the hidden section a normal part of the document (that is, to remove the section
markers, but not the contents of the section):

1) Show the hidden section, as described above.
2) On the Edit Sections dialog, select the section from the list.
3) Click Remove. The contents of the section are now a normal part of the document.
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Extra features Link
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Write Protection
Protect
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Properties
Editable in read-only document

Help Reset cancel ([IEZD

Figure 15: Creating a section to be hidden when a specified condition is met

Change the value of the variable

To change the value of the variable between Lite and Pro:
1) Find the variable field you created in “Choose or define a variable” on page 15.
2) Click once just in front of this field, then right-click and click Fields in the context menu.
3) On the Edit Fields dialog (Figure 16), change the value of the variable to Pro.

4) If you have set fields to update automatically, all of the conditional and hidden text that
uses this variable as a condition will change.

Note
Conditional text and hidden text can only be edited in the Edit Fields dialog.

eTip

To turn on automatic updating of fields, choose Tools > Options > LibreOffice
Writer > General, and select Fields under Automatically Update.
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Figure 16: Changing the value of the variable

Using placeholder fields

A placeholder field prompts you to enter something (text, a table, a frame, an image, or an
object).

To insert a placeholder field into a document:

1) On the Functions tab of the Fields dialog, select Placeholder in the Type column and
select what the placeholder is for in the Format column.

2) In the Placeholder box, type the text that you want to appear in the placeholder field.

3) Inthe Reference box, type the text that you want to display as a help tip when you rest
the mouse pointer over the field.

Figure 17 shows the results of inserting a placeholder field for an image.

‘o0 ® Fields
Docinformation | Variables | Database
Document | Cross-references . Funmetions
<Loco=1 Type Format Placeholder
Insert |0gu here Conditional text Text

Input list Table

Input field Frame Reference

Execute macro Image

Placeholder Object

Combine characters

Hidden text

Hidden Paragraph

Figure 17: Inserting a placeholder field

Because the <Logo> field is an Image placeholder, when you click the field in the document, the
Insert Image dialog opens, prompting you to select an image. When you select an image and
click Open, the image replaces the field in the document.
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Similarly, clicking on a Table placeholder field opens the Insert Table dialog, clicking on a Frame
placeholder field opens the Frame dialog, and clicking on an Object placeholder field opens the
Insert OLE Object dialog. The Text placeholder field is different: you simply click it and type some
text in the Placeholder box, which replaces the field.

Using other fields

Other uses of fields, including database fields, are described in various chapters of this book.

LibreOffice provides many other fields that you may find useful, but they are too specialized to
cover in this book. Please refer to the Help system for details, instructions, and examples.

Classifying document contents

Document classification and security are important for businesses and governments. Where
sensitive information is exchanged between users and organizations, the parties agree how such
information will be identified and handled. LibreOffice provides standardized means for sensitive
information to be identified and protected, using a set of standard fields that can be used to hold
sensitive information.

LibreOffice implemented the open standards produced by TSCP (Transglobal Secure
Collaboration Participation, Inc.). It contains three BAF (Business Authentication Framework)
categories: Intellectual Property, National Security and Export Control. Each category has four
BAILS (Business Authorization Identification and Labeling Scheme) levels: Non-Business,
General Business, Confidential, and Internal Only.

To enable document classification, open the TSCP bar (View > Toolbars > TSCP
Classification). This toolbar contains list boxes to help in selecting the security of the document.
LibreOffice then adds custom fields in the document properties (File > Properties, Custom
Properties tab) to store the classification policy as document metadata.

To prevent a breach in security policy, contents with a higher classification level cannot be pasted
into documents with a lower classification level.
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