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Introduction

Any text used in slides is contained in text boxes. This chapter describes the following:

• How to create, modify, use, and delete text boxes.

• How to create, modify and format the various types of text that can be inserted.

• How to insert special forms of text such as numbered or bulleted lists, tables, fields, and 
hyperlinks.

Working with text boxes

Adding text boxes to slides is carried out using one of the following methods:

• Use a predefined Impress layout which includes AutoLayout text boxes.

• Create a text box using the Insert Text Box for a horizontally aligned text box on the 
Standard toolbar (Figure 1) or the Drawing toolbar (Figure 2).

• Create a text box using the Insert Vertical Text for a vertically aligned text box on the 
Standard toolbar (Figure 1) or the Drawing toolbar (Figure 2).

• Use the keyboard shortcut F2 to insert a horizontally aligned text box.

Figure 1: Standard toolbar

Figure 2: Drawing toolbar

Figure 3: Text Formatting toolbar

Note

When inserting text boxes and adding or formatting text, the Text Formatting toolbar 
(Figure 3) automatically opens replacing the Line and Filling toolbar, if the Line and 
Filling toolbar is active and displayed.

Note

The Insert Vertical Text tool for creating a vertical text box and inserting vertical text
is only available when Asian and Complex text layout (CTL) options are enabled. 
Go to in Tools > Options > Language Settings > Languages on the main menu 
bar to select these options for vertical text.

Note

AutoLayout text boxes can be moved, resized and deleted in the same way as text 
boxes. See “Moving text boxes” on page 7, “Text positioning” on page 9, and “Error: 
Reference source not found” on page Error: Reference source not found for more 
information.
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Figure 4: Layouts section in Properties 
on Sidebar

Figure 5: Layout context menu on Menu bar

AutoLayout text boxes

AutoLayout text boxes are automatically created when you select one of the slide layouts 
available in Impress.

1) Select an Impress slide layout using one of the following methods:

– Open the Layouts section on the Properties deck of the Sidebar (Figure 4).

– Go to Slide > Layout on the Menu bar to open a context menu (Figure 5).

2) Click on the text Click to add Title or Click to add Text. This text will automatically 
disappear replaced by a flashing text cursor. The Text Formatting toolbar (Figure 3 on 
page 5) automatically opens replacing the Line and Filling toolbar.

3) Type or paste your text into the AutoLayout text box and, if necessary, format the text to 
your requirements using the information in this chapter.

4) If necessary, copy, resize and/or reposition the AutoLayout text box using the information 
in this chapter.

5) Click outside the AutoLayout text box to deselect it.
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Creating text boxes

1) Click on Insert Text Box or Insert Vertical Text on the Standard toolbar (Figure 1 on 
page 5) or the Drawing toolbar (Figure 2 on page 5). The Text Formatting toolbar 
(Figure 3 on page 5) automatically opens replacing the Line and Filling toolbar.

2) Create a text box using one of the following methods:

– Click on the slide and a text box is automatically created with the text cursor flashing 
in the text box. This text box will increase in width as you enter text in a single line and
its height will not change. To create multiple lines and increase the height, press the 
Enter key to create a new single line paragraph.

– Click and drag the cursor to set the width of the text box. As you enter text, the height 
of a text box will automatically increase as text wraps, creating a multiple line text box.

3) Type or paste your text in the text box.

4) Click outside the text box to deselect it.

Note

If you are using a vertical text box, it is the height that will increase as a single line 
when you enter text. If you click and drag using vertical text box, you set the height of
the text box and the width of the text box automatically increases creating multiple 
vertical lines.

Moving text boxes

1) Click in the text box to select it so that the border is displayed indicating that the text box 
is in edit mode.

2) Move the cursor over the highlighted border and the cursor changes shape to the move 
cursor for your operating system (for example, a hand).

3) When the move cursor appears, click once on the border to display the selection handles.

4) Click and hold on the border, then drag the cursor to move the text box. A dashed outline 
of the text box shows where your text box will be placed as shown in Figure.

5) Release the mouse button when the text box is in the desired position.

6) Click outside the text box to cancel edit mode.

Note

Do not click on a selection handle as this will not move the text box, but resize the 
text box.

Resizing text boxes

1) Click in the text box to select it so that the border is displayed indicating that the text box 
is in edit mode.

2) Move the cursor over the highlighted border and click once on the border to display the 
selection handles.
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Figure 6: Moving text box

Figure 7: Resizing text box

3) Move the cursor over a selection handle and the cursor changes shape indicating the 
direction the text box will be resized. Click and hold as you resize the text box, a dashed 
outline appears indicating the new size of the text box as shown in Figure . The selection 
handles are used to resize the text box as follows:

– Corner handles change the width and height of the text box simultaneously.

– Top and bottom selection handles change the height of the text box.

– Right and left selection handles change the width of the text box.

4) Release the mouse button when the text box is at the desired size.

5) Click outside the text box to cancel edit mode.

Note

To maintain the proportions of a text box while resizing, press and hold the Shift key, 
then click and drag a selection handle. Make sure to release the mouse button 
before releasing the Shift key.
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Figure 8: Text dialog

Text positioning

The Text dialog (Figure 8) provides options that allow you to position text within an AutoLayout 
text box or a text box.

1) Select a text box so that the border and selection handles are displayed.

2) Right click in the text box and select Text from the context menu to open the Text dialog.

3) Select the various options on the Text page to position your text within the text box.

4) Click OK to save your changes and close the dialog.

5) Click outside the text box to deselect it.

The options in the Text dialog are as follows:

• Drawing Object Text

– Fit width to text – width of the text box is automatically adjusted to the width of the 
text.

– Fit height to text – height of the text box is automatically adjusted to the height of the 
text.

– Fit to frame – the text width and height is adjusted to the width and height of the text 
box.

• Spacing to Borders – creates margins around the text within the text box.

• Text Anchor – sets the anchor point for the text within the text box. When the Full width 
option is selected, the text is automatically positioned in the center of the text box.

Note

Text Animation in the Text dialog sets the text animation effects and these are 
explained in Chapter 9, Slide Shows.
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Figure 9: Position and Size dialog

Position and Size dialog

For more accurate control over the size and position of an AutoLayout text box or a text box, use 
the Position and Size dialog (Figure 9) instead of using the mouse.

1) Click in the text box to select it so that the border is displayed indicating that the text box 
is in edit mode.

2) Open the Position and Size dialog using one of the following methods:

– Go to Format > Object and Shape > Position and Size on the main menu bar.

– Right-click on the text box and select Position and Size from the context menu.

– Use the keyboard shortcut F4.

3) Select the various options on the Position and Size page to position the text box.

4) Click OK to save your changes to the text box and close the Position and Size dialog.

5) Click outside the text box to cancel edit mode.

The options in the Position and Size page are as follows:

• Position

– Position X (horizontal) and Position Y (vertical) – specify position of the text box. The 
position values of the text box represent the distance of the Base point to the top left 
corner of the slide.

– Base point – position the text box by selecting one of the nine available positions. By 
default, the Base point is the top left corner of the text box.

• Size

– Width and Height – specify size of the text box. To maintain the width/height ratio of 
the text box, select Keep ratio. The size values represent the distance of the Base 
point relative to the top left corner of the slide.
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Figure 10: Position and Size 
section in Properties deck on 
Sidebar

– Base point – position the text box by selecting one of the nine available positions. By 
default, the Base point is the top left corner of the text box.

• Protect – prevent accidental modification of the position or size of the text box by 
selecting Position and/or Size options.

• Adapt – allow the text box to adjust its height and/or width as you enter text by selecting 
Fit width to text and/or Fit height to text.

Position and Size on Sidebar

For more accurate control over the size and position of a text box, the Position and Size section 
in the Properties deck on the Sidebar (Figure 10) can also be used. However, there are fewer 
options available in the Position and Size section on the Sidebar than in the Position and Size 
dialog.

1) Click in the text box to select it so that the border is displayed indicating that the text box 
is in edit mode.

2) Click on Properties on the Sidebar to open the Properties deck, then click on Position 
and Size to open the section.

3) Specify measurement values in the Position X (horizontal) and Position Y (vertical) boxes 
to position of the text box on the slide. The position values of the text box represent the 
distance between the top left of text box to the top left corner of the slide.

4) Specify measurement values in the Width and Height boxes to adjust the size of the text 
box. To maintain the width/height ratio of the text box, select Keep ratio.

5) When satisfied with your changes, click outside the text box to cancel edit mode.

Deleting text boxes

1) Click in the text box to select it so that the border and selection handles are displayed 
indicating that the text box is in edit mode.

Working with text boxes | 11



2) Press the Delete or Backspace key to delete the text box.

Tip

If you have more than one text box to delete, it can be quicker to drag a selection 
marquee around the text boxes and then press the Delete or Backspace key. Take 
care to avoid selecting and accidentally deleting any other text boxes or shapes you 
want to keep.

Inserting text

Pasting text

You can insert text into an AutoLayout or normal text box by copying it from another document 
and pasting it into Impress. However, the text will probably not match the formatting of the 
surrounding text or that of the other slides in the presentation. This may be what you want on 
some occasions. However, you may want to make sure that the presentation style is consistent 
and does not become a patchwork of different styles, font types, bullet points, and so on.

Unformatted text

It is good practice to paste text without formatting and apply the formatting later reducing the risk 
of errors in your presentation.

1) Highlight and copy the text in another document or slide.

2) Create a text box on your slide and make sure the text cursor is flashing in the text box. 
See “AutoLayout text boxes” on page 6 or “Creating text boxes” on page 7 for more 
information. 

3) Paste unformatted text into the text box using one of the following methods:

– Go to Edit > Paste Special > Paste Unformatted Text on the main menu bar.

– Click on the small downward arrow ▼to the right of the Paste tool on the Standard 
toolbar (Figure 1 on page 5) and select Unformatted Text from the context menu.

– Use the keyboard shortcut Ctrl+Shift+V and select Unformatted text from the dialog 
that opens.

– Use the keyboard shortcut Ctrl+Alt+Shift+V and unformatted text is pasted into the text
box.

Text is pasted at the cursor position in the text box formatted using the Default Drawing 
Style or the Presentation Style, if text was pasted into an AutoLayout text box.

4) Format the text to your requirements using the tools on the Text Formatting toolbar 
(Figure 3 on page 5) or the options in Format on the main menu bar. Alternatively and for 
text boxes only, apply a Drawing Style to the text. See Chapter 2, Master Slides, Styles 
and Templates for information.

Note

You cannot change a Presentation Style used in AutoLayout text boxes by selecting 
another Presentation Style. Make sure the AutoLayout text box uses the 
Presentation Style you want to use. See Chapter 2, Master Slides, Styles and 
Templates for information. Outline levels and outline styles are changed using the 
Tab key or Shift+Tab key combination.
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Formatted text

Pasting formatted text into a text box or AutoLayout text box will overwrite any formatting and 
replace the text box style.

1) Highlight and copy the text in another document or slide.

2) Create a text box on your slide and make sure the text cursor is flashing in the text box. 
See “AutoLayout text boxes” on page 6 or “Creating text boxes” on page 7 for more 
information.

3) Paste formatted text into the text box. Text is pasted at the cursor position in the text box 
and the text formatting of the pasted text overwrites any style formatting of the text box.

4) If necessary, format the text to your requirements using the various tools on the Text 
Formatting toolbar or using the options available in Format on the Menu bar.

5) To clear any formatting of the pasted text and use the text box style, go to Format > 
Clear Direct Formatting on the Menu bar. See Chapter 2, Master Slides, Styles and 
Templates for more information.

Note

You can create your own Drawing Styles in Impress. These Drawing Styles are only 
available for the Impress presentation which you have created and saved them. You 
can also create templates that include any Drawing Styles that you have created.

Inserting special characters

You can insert special characters into your text, such as copyright, math, geometric, or monetary 
symbols, or characters from another language.

1) Click at the position where you want to insert the special character into the text.

2) Go to Insert > Special Character on the Menu bar to open the Special Characters dialog
(Figure 11).

3) Select the font and character subset from the Font and Subset drop-down menus.

Figure 11: Special Characters dialog
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4) Select the special character you want to insert. A preview of the selected character 
appears in the preview box at the top of the dialog and the special character name is 
displayed below the preview box.

Alternatively, select the special character from the display of Recent Characters or 
Favorite Characters. A preview of the selected character appears in the preview box at 
the top of the dialog and the special character name is displayed below the preview box.

5) Click Insert to close the dialog and insert the special character at the cursor position in 
the text.

Alternatively, double-click on the special character you want to insert. This closes the 
dialog and inserts the special character at the cursor position in the text.

6) If you use a special character frequently, click on Add to Favorites and the special 
character is added to the display of Favorite Characters.

Inserting formatting marks

Formatting marks are a type of special character that you can insert into your text to correct the 
formatting. For example, it may not be desirable for words that are separated by a space or a 
hyphen to span over two lines. The solution is to insert a non-breaking space or non-breaking 
hyphen.

1) Click at the position where you want to insert the formatting mark into the text.

2) Go to Insert > Formatting Mark on the Menu bar to open a context menu (Figure 12).

3) From the options displayed in the context menu, select the formatting mark you require. It
is inserted into the text at the cursor position.

The formatting marks that are available in Impress are as follows:

• Non-breaking space – inserts a space that will keep two adjacent words or characters 
together on line breaks (keyboard shortcut Ctrl+Shift+Space).

• Non-breaking hyphen – inserts a hyphen that will keep two adjacent characters 
together on line breaks (keyboard shortcut Ctrl+Shift+Hyphen).

• Soft hyphen – inserts an invisible hyphen within a word that will appear and create a line
break once it becomes the last character in a line (keyboard shortcut Ctrl+Hyphen).

• Narrow no break space – inserts a narrow space that will keep two adjacent words or 
characters together on line breaks. A narrow space has a width that is about 70% of a 
normal space. It is used to represent the narrow space occurring around punctuation 
characters and can also be used as a numeric group separator.

• No-width optional break – inserts an invisible space within a word that will insert a line 
break once it becomes the last character in a line (keyboard shortcut Ctrl+Forward Slash).

• No-width no break – inserts an invisible space within a word that will keep the word 
together at the end of a line.

Figure 12: Formatting marks
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• Left-to-right mark – inserts a text direction mark that affects the text direction of any text
following the mark. Only available when Complex text layout (CTL) is enabled.

• Right-to-left mark – inserts a text direction mark that affects the text direction of any text
following the mark. Only available when Complex text layout (CTL) is enabled.

Formatting text

Text formatting can give a presentation a consistent look and a dynamic feel. This will enhance 
the understanding of your audience by preventing any distracting elements in your presentation. 
Text formatting can be applied (for example color, alignment, bullet types) to characters, words, 
sentences, paragraphs, and lists.

Quick font resizing

You can quickly increase or decrease font size of selected text using the tools Increase Font 
Size (Ctrl+]) and Decrease Font Size (Ctrl+[) on the Text Formatting toolbar (Figure 3 on page 5)
The amount by which the font size changes depends on the standard sizes available for the font 
in use.

Note

AutoLayout text boxes automatically adjust font size of any text inserted into the 
AutoLayout text box. For example, inserting a long piece of text into an AutoLayout 
text box, the font size may decrease in size to fit into the box.

Selecting text

Text must be selected before it can be formatted using one of the following methods. Any 
formatting changes will apply only to the selected text.

• To format all the text in a text box, click once on the border of the text box to display the 
selection handles. Any formatting changes will apply to all text in the text box.

• To format only part of the text, select text using one of the following methods:

– Click in the text and drag the cursor over the text to highlight the text.

– Double-click on text to select a complete word or triple click to select a whole 
paragraph.

– Click in the text, then press and hold the Shift key and use the keyboard arrow keys to
extend to select text.

Note

When you select text, the Text Formatting toolbar automatically opens replacing the 
Line and Filling toolbar.

Using styles

When you enter text, either in an AutoLayout text box or in a text box, it is formatted with a set of 
predefined attributes known as a style. The style used depends on the type of text box being 
used. For more information on using, modifying and updating styles, see Chapter 2, Master 
Slides, Styles and Templates.
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Sometimes it is quicker and more efficient to apply manual or direct formatting. However, in 
situations where you need to perform the same formatting to many different parts of a 
presentation, the use of styles is recommended. This will create a consistent look to your 
presentation and reduce the possibility of any errors. Impress has two categories of styles – 
Presentation Styles and Drawing Styles.

Presentation Styles

Presentation styles are used in AutoLayout text boxes, master slide backgrounds, and master 
slide background objects.

The style applied to the text depends on the type of AutoLayout text box. These styles cannot be 
deleted, renamed or changed for another presentation style if you want to change the formatting 
of the text. For example, to change an outline style for another outline style, you have to change 
the outline level by using the Tab key or Shift+Tab key combination. 

Presentation styles can be modified to change the text formatting or updated to change the style 
after formatting the text.

Drawing Styles

Drawing styles are used for text in text boxes and any graphic object you place on a slide. For 
information on formatting graphic objects, see Chapter 6, Formatting Graphic Objects.

When you enter text into a text box, the Default Drawing Style is applied to the text. You can 
change this style by selecting another style from the text group of Drawing Styles.

These styles cannot be deleted or renamed, but can be modified to change the text formatting or 
updated to change the style after formatting the text.. You can also create custom drawing styles 
that are only available for the presentation being created.

Note

Unlike LibreOffice Writer, where it is recommended to use styles whenever possible, 
manual or direct formatting has to be used more often in LibreOffice Impress. The 
reason being is that Presentation Styles in Impress are restricted. For example, you 
cannot have two different Outline 1 levels using different types of bullet points for the 
same outline level.  Also, the lack of support for character styles forces the use of 
manual or direct formatting to format sections of text when necessary.

Text formatting

Direct or manual text formatting can be applied directly to characters, words, sentences, and 
paragraphs. Direct formatting overrides any formatting that has been applied to text when using 
styles.

1) Select the text you want to format, see “Selecting text” on page 15 for more information.

2) Format text using one of the following methods. Formatting applied to text is immediate.

– Various formatting tools on the Text Formatting toolbar (Figure 3 on page 5).

– Go to Format on the Menu bar. Selecting a formatting option will open a context 
menu or dialog where you can select further formatting options to apply to your text.

– Use the options available in the Paragraph and Character dialogs.

– Use the options available in the Paragraph and Character sections in the Properties 
deck on the Sidebar.

3) Click outside the text box to deselect the text.
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Figure 13: Paragraph dialog - Indents and Spacing page

Paragraph dialog

The Paragraph dialog (Figure 13) is used to format paragraphs of text.

1) Select text in a paragraph or the whole paragraph that you want to format.

2) Format text using one of the following methods and open the Paragraph dialog. Any 
formatting applied to a paragraph is immediate.

– Right click on the selected text and select Paragraph from the context menu.

– Go to Format > Paragraph on the Menu bar.

3) Use the various options available on the tabbed pages of the Paragraph dialog to format 
your text.

4) Click OK to save your changes and close the dialog.

5) Click outside the text box to deselect the text.

Indents and spacing options

The Indents and Spacing options page (Figure 13) in the Paragraph dialog has three main 
sections as follows:

• Indent – specifies the amount of space to leave between the left and the right page 
margins and the paragraph.

– Before text – enter the amount of space that you want to indent the paragraph from 
the page margin. If you want the paragraph to extend into the page margin, enter a 
negative number.

– After text – enter the amount of space that you want to indent the paragraph from the 
page margin. If you want the paragraph to extend into the page margin, enter a 
negative number.

– First line – indents the first line of a paragraph by the amount that you enter. To create
a negative hanging indent enter a positive value for Before text and a negative value 
for First line. To create a positive hanging indent enter a positive value for Before text 
and a larger positive value for First line.

– Automatic – when selected, automatically indents a paragraph according to the font 
size and the line spacing. The setting value for First line is ignored.
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• Spacing – specifies the amount of space to leave between paragraphs.

– Above paragraph – enter the amount of space that you want to leave above a 
paragraph.

– Below paragraph – enter the amount of space that you want to leave below a 
paragraph.

– Don’t add space between paragraphs of the same style – when selected, only the 
spacing below a paragraph is applied when the preceding and following paragraphs 
are of the same paragraph style.

• Line spacing – specifies the amount of space to leave between lines of text in a 
paragraph. The options available from the drop-down list are as follows:

– Single – applies single line spacing to a paragraph. This is the default setting.

– 1.15 Lines – sets the line spacing to 1.15 lines.

– 1.5 Lines – sets the line spacing to 1.5 lines.

– Double – sets the line spacing to two lines.

– Proportional – select this option and then enter a percentage value in the box, where 
100% corresponds to single line spacing.

– At Least – sets the minimum line spacing to the value that you enter in the box. If you 
use different font sizes within a paragraph, the line spacing is automatically adjusted 
to the largest font size. If you prefer to have identical spacing for all lines, specify a 
value in that corresponds to the largest font size.

– Leading – sets the vertical space height that is inserted between two lines.

– Fixed – enter a fixed value to be used for line spacing.

Tip

Setting the line spacing to less than 100% is a good method to place a lot of text into 
a text box when space is limited. However, care must be taken as too small a value 
will make the text hard to read.

Tip

You can change the default unit of measurement in Tools > Options > LibreOffice 
Impress > General on the Menu bar.

Asian Typography options

The Asian Typography options page (Figure 14) is only available when Asian and Complex 
Text Layout (CTL) options are enabled in Tools > Options > Language Settings > Languages
on the Menu bar. The Line Change options are as follows:

• Apply list of forbidden characters to the beginning and end of lines – prevents the 
characters in the list from starting or ending a line. The characters are relocated to either 
the previous line or the next line. To edit the list of restricted characters that start or end a
line, go to Tools > Options > LibreOffice > Language Settings > Asian Layout on the 
Menu bar.

• Allow hanging punctuation – prevents commas and periods from breaking the line. 
Instead, these characters are added to the end of the line, even in the page margin.

• Apply spacing between Asian and non-Asian text – inserts a space between Asian and 
non-Asian characters.
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Figure 14: Paragraph dialog - Asian Typography page

Figure 15: Paragraph dialog - Tabs page

Note

To create tabs and use the same settings for tabs in more than one text box, it is 
recommended to modify, update or create a custom drawing style and apply the style
to the text. See Chapter 2, Master Slides, Styles and Templates for more information.

Tab options

Use the Tabs options page (Figure 15) to determine the tab stops in an AutoLayout text box or 
text box as follow:

• Position – enter a measurement in the text box to set the position of a tab in a text box. 
Any tabs already created are listed in the preview box below the measurement setting.

• Type – determines the type of tab used.

– Left – aligns the left edge of the text to the tab stop and extends the text to the right. If
Asian language support is enabled in LibreOffice Preferences, this tab stop is called 
Left/Top.

– Right – aligns the right edge of the text to the tab stop and extends the text to the left 
of the tab stop. If Asian language support is enabled in LibreOffice Preferences, this 
tab stop is called Right/Bottom.

– Center – aligns the center of the text to the tab stop.

– Decimal – aligns the decimal point of a number to the center of the tab stop. The 
numbers to the left of the decimal point are aligned to the left of the tab. The numbers 
to the right of the decimal point are aligned to the right of the tab.

– Character – enter a character to use as a decimal separator when using decimal tabs.

• Fill character – specifies the type of character inserted between the tab insertion point 
and the tab stop.

– None – no fill characters are inserted between the tab insertion point and the tab stop.
It also removes any existing fill characters between the tab insertion point and the tab 
stop.

– Dots...... – inserts dots between the tab insertion point and the tab stop.

– Dashes----- – inserts dashes between the tab insertion point and the tab stop.

– Line______ – draws a line between the tab insertion point and the tab stop.
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– Character – specify a character for insertion between the tab insertion point and the 
tab stop.

Creating tabs

1) Select the text box so that the selection handles on the text box border are displayed.

2) Right click on the selected text box and select Paragraph from the context menu or go to 
Format > Paragraph on the main menu bar to open the Paragraph dialog.

3) Click on Tabs to open the Tabs page in the Paragraph dialog (Figure 15 on page 19).

4) Enter the position measurement for the tab stop in the Position text box.

5) Select the type of tab from the options in Type.

Note

If you set the type to Decimal, the default character used is the character used for 
decimal points in your computer setup. If required, specify the character to be used 
as the decimal point In Character box.

6) Select the type of Fill Character. The fill character will be inserted between the tab 
insertion point and the tab stop.

7) Click on New to create the new tab stop in the text box. The new tab stop appears in the 
Position preview box.

8) Click OK to save your changes and close the dialog.

9) To use the new tab stop in more than one text paragraph in a text box or in another text 
box:

– Modify or update the presentation or drawing style used for the text.

– Create a custom drawing style and apply it to the text.

Editing tabs

1) Select the text box so that the selection handles on the text box border are displayed.

2) Right click on the selected text box and select Paragraph from the context menu or go to 
Format > Paragraph on the main menu bar to open the Paragraph dialog.

3) Click on Tabs to open the Tabs page in the Paragraph dialog.

4) Select the tab you want to edit in the Position preview box.

5) Select the Type and Fill Character you want to use for the selected tab stop.

6) Click OK to save your changes and close the dialog.

7) If necessary, update the style used for the text.

Note

To change the tab position, you have to delete the selected tab first, then create a 
new tab with the changes you require.

Deleting tabs

1) Select the text box so that the selection handles on the text box border are displayed.

2) Right click on the selected text box and select Paragraph from the context menu or go to 
Format > Paragraph on the main menu bar to open the Paragraph dialog.

3) Click on Tabs to open the Tabs page in the Paragraph dialog (Figure 15).
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4) Select the tab you want to delete in the Position preview box.

5) Click on Delete to delete the selected tab.

Alternatively, click Delete All to delete all of the tab stops that are set for the selected text
box.

6) Click OK to save your changes and close the dialog.

Deleting tabs

1) Select the text box so that the selection handles on the text box border are displayed.

2) Right click on the selected text box and select Paragraph from the context menu or go to 
Format > Paragraph on the main menu bar to open the Paragraph dialog.

3) Click on Tabs to open the Tabs page in the Paragraph dialog.

4) Select the tab you want to delete in the Position preview box.

5) Click on Delete to delete the selected tab, or click Delete All to delete all of the tab stops 
that are set for the selected text box.

6) Click OK to save your changes and close the dialog.

Alignment options

Use the Alignment options page (Figure 16) to determine the text alignment in text boxes as 
follows.

• Options

– Left – aligns text to the left margin of the text box. If Asian language support is 
enabled, this option is named Left/Top.

– Right – aligns text to the right margin of the text box. If Asian language support is 
enabled, this option is named Right/Bottom.

– Center – aligns the text to the center of in the text box.

– Justified – aligns the text to the left and to the right margins of the text box.

• Text-to-text

– Alignment – provides alignment options for oversized or undersized characters in the 
text relative to the rest of the text.

Figure 16: Paragraph dialog - Alignment page
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• Properties

– Text direction – specifies the text direction for text that uses Complex Text Layout 
(CTL) and is only available if complex text layout support is enabled.

• Preview field – displays a preview of how the text will appear in the text box.

Sidebar Paragraph section

An alternative method of formatting paragraphs is to use the Paragraph section (Figure ) in the 
Properties deck on the Sidebar. The formatting options available in the Paragraph section are 
limited, but are similar in use to the formatting options available in the various pages of the 
Paragraph dialog.

1) Select a text box so that the selection handles on the text box border are displayed.

2) On the Sidebar, click on Properties to open the Properties deck.

3) Click on Paragraph to open the Paragraph section.

4) Format the text using the various tools available in the Paragraph section. See 
“Paragraph dialog” on page 17 for more information on formatting options.

5) If necessary, click on More Options on the right of the title bar to open the Paragraph 
dialog to format text.

The text formatting options available in the Paragraph section in the Properties deck on the 
Sidebar are as follows:

• Align Left, Align Center, Alight Right, Align Justified – determines how text is aligned
to the text box margins. These tools are also available on the Text Formatting toolbar 
(Figure 3 on page 5).

• Left-To-Right, Right-To-Left – only available when Asian and Complex Text Layout 
(CTL) options have been selected in Tools > Options > Language Settings > 
Languages. These tools are also available on the Text Formatting toolbar.

• Align Top, Center Vertically, Align Bottom – aligns text to the top, center or bottom of 
a text box. This is similar to vertical alignment of data within a table cell. These tools are 
also available on the Text Formatting toolbar.

Figure 17: Paragraph section in 
Properties deck on Sidebar
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• Increase Paragraph Spacing, Decrease Paragraph Spacing – increases or decreases 
the spacing above and below the selected text. These tools are also available on the Text
Formatting toolbar.

• Above Paragraph Spacing, Below Paragraph Spacing – increases or decreases the 
spacing either above or below selected text. Enter the amount of spacing you require in 
the text box.

• Set Line Spacing – adjust the spacing between the lines of selected text. Click on the 
small triangle to the right of the icon and select the type of line spacing you require from 
the drop-down list. This tool is also available on the Text Formatting toolbar.

• Increase Indent, Decrease Indent – each click increases or decreases the indent level 
of selected text by the default value for Impress. To specify your own indent 
measurement, enter a value in the Before text, After text or First line boxes.

• Hanging Indent – sets a different indent for the first line of text to the indent set for a 
whole paragraph of text as follows:

– Enter a negative value in the First line box to reduce the indent of the first line of text.

– Enter a positive value in the First line box to increase the indent of the first line of text.

– First click sets a negative hanging indent and a second click sets a positive hanging 
indent.

– This tool is only active when a Before text indent has been set for the paragraph of 
text.

– To remove a hanging indent, set the value in the First line box to zero.

Character formatting

Direct or manual character formatting can be applied directly to individual characters and words. 
Direct character formatting will override any formatting that has been applied using direct text 
formatting and presentation or drawing styles.

1) Select the characters you want to format, see “Selecting text” on page 15 for more 
information.

2) Format characters using one of the following methods. Formatting applied to character(s) 
is immediate.

– Various formatting tools on the Text Formatting toolbar (Figure 3 on page 5).

– Go to Format on the Menu bar. Selecting a formatting option will either open a 
context menu or dialog where you can select further formatting options to apply to 
your text.

– Use the options available in the Character dialog.

– Use the options available in the Character section on the Sidebar.

3) Click outside the text box to deselect the text.

Character dialog

The Character dialog (Figure 18) is used to format individual characters.

1) Open the Character dialog using one of the following methods:

– Right click on the selected text box and select Character from the context menu, then
select the characters you want to format.
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Figure 18: Character dialog - Fonts page

– Select the characters you want to format, then go to Format > Character on the 
Menu bar.

2) Use the various options available on the tabbed pages of the Character dialog to format 
the selected characters.

3) Click OK to save your changes and close the dialog.

4) Click outside the text box to deselect the text.

Fonts

Use the Font page (Figure 18) in the Character dialog to select the font family, typeface (Italic, 
Bold, and so on), size, and language. A sample of the font is displayed in the preview box in the 
lower part of the dialog.

If support for Asian language and Complex Text Layout (CTL) has been enabled in Tools > 
Options > Language Settings > Languages, then formatting options are also available for 
Asian and CTL fonts in the Character dialog.

Note

The number of typefaces available will change depending on the font family that is 
selected.

Tip

When creating a presentation in multiple languages, you can use the language 
setting to create styles that only differ in the language in formatting attributes. This 
allows you to easily check spelling of all of the presentation contents without affecting
appearance.
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Figure 19: Character dialog - Font Effects page

Font Effects

The options on the Font Effects page (Figure 19) in the Character dialog to apply font color, text 
decoration and effects to the selected text or characters. A sample of the font effect is displayed 
in the preview box in the lower part of the dialog.

• Font Color

– Font color – sets the color for the selected text. Select a color from one of the 
available palettes. If Automatic is selected, the text color is set to black for light 
backgrounds and to white for dark backgrounds.

– Transparency – sets the transparency of the selected text. Enter a value in the text 
box. 100% entirely transparent, 0% no transparency.

• Text Decoration

– Overlining – select the overlining style from the drop down list and the overlining color 
from one of the available palettes. If Automatic is selected, the text color is set to 
black for light backgrounds and to white for dark backgrounds.

– Strikethrough – select a strikethrough style for the selected text.

– Underlining – select the underlining style from the drop down list and the underlining 
color from one of the available palettes. If Automatic is selected, the text color is set to
black for light backgrounds and to white for dark backgrounds.

– Individual words – when selected, any overlining or underlining is applied to words 
only and spaces are ignored.

• Effects

– Case – select a capitalization effect from the drop down list.

– Relief – select a relief effect for the selected text. Embossed relief makes the 
characters appear as if they are raised above the page. Engraved relief makes the 
characters appear as if they are pressed into the page.

– Emphasis mark – select a character to display over or below the entire length of the 
selected text.
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Figure 20: Character dialog - Position page

– Position – specifies where to display the emphasis marks. Either above the text or 
below the text.

Position

The options on the Position page (Figure 20) allows you to set the position, scaling and spacing 
of selected text.

• Position – sets the subscript or superscript options for a character.

– Normal – removes superscript or subscript formatting.

– Superscript – reduces the font size of the selected text and raises the text above the 
baseline.

– Subscript – reduces the font size of the selected text and lowers the text below the 
baseline.

– Raise/lower by  – enter the amount to raise or to lower the selected text in relation to 
the baseline. 100% is equal to the height of the font.

– Relative font size – enter the amount to reduce the font size of the selected text.

– Automatic – sets the amount by which the selected text is automatically raised or 
lowered in relation to the baseline.

• Scaling

– Scale width – enter a percentage of the font width to horizontally stretch or compress 
the selected text.

• Spacing – specifies the spacing between individual characters.

– Character spacing – specifies the spacing between the characters of the selected 
text. Enter the amount to expand or condense the text in the text box. To increase 
spacing, set a positive value; to reduce spacing, set a negative value.

– Pair kerning – automatically adjusts the character spacing for specific letter 
combinations. Kerning is only available for certain font types and requires printer 
support for this option.

Highlighting

The options on the Highlighting page (Figure 21) allows you to highlight text so that the 
characters are different color to the rest of the text in the text box.

• Colors – select a highlight color from one of the available palettes.

• Active – shows the present color of the text and the Red, Green and Blue (RGB) settings
for the present color.
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Figure 21: Character dialog - Highlighting page

• New – shows the highlight color of the text that has been selected in Colors and the 
Red, Green and Blue (RGB) settings for the new color. The color can also be selected by
changing the values in the RGB boxes or using the Pick a Color dialog when you click on
Pick.

Sidebar Character section

An alternative method of formatting text is to use the Character section (Figure 22) in the 
Properties deck on the Sidebar. The formatting options available in the Character section are 
limited, but are similar in use to the formatting options available in the various pages of the 
Character dialog.

1) Select a text box so that the selection handles on the text box border are displayed.

2) On the Sidebar, click on Properties to open the Properties deck.

3) Click on Character to open the Character section.

4) Format the text using the various tools available in the Character section. See “Character 
dialog” on page 23 for more information on formatting options.

5) If necessary, click on More Options on the right of the title bar to open the Character 
dialog to format text.

The text formatting options available in the Character section in the Properties deck on the 
Sidebar are as follows:

• Font Name and Font Size – select the font family and size that you want to use from the
drop-down lists. These tools are also available on the Text Formatting toolbar.

• Bold and Italic – applies a bold or italic typeface to the selected text. These tools are 
also available on the Text Formatting toolbar.

• Underline – underlines the selected text. Click on the small triangle ▼ to the right and 
select the type of underlining you want to use from the drop-down list. Click More 
Options at the bottom of this drop-down list to open the Character dialog.

• Strikethrough – draws a line through the selected text. This tool is also available on the 
Text Formatting toolbar.

• Shadow – adds a shadow to the selected text. This tool is also available on the Text 
Formatting toolbar.
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Figure 22: Character section in 
Properties deck on Sidebar

• Increase Font Size and Decrease Font Size – each click increases or reduces the size 
of the selected characters by the same amount. Actual size depends on your computer 
setup. These tools are also available on the Text Formatting toolbar.

• Font Color and Highlight Color – click on the small triangle ▼ to the right of these icons
and select a color from the available palettes. These tools are also available on the Text 
Formatting toolbar.

• Clear Direct Formatting – removes any direct formatting and formatting by character 
styles from the selected text. Direct formatting is formatting that you applied without 
using styles: for example, setting bold typeface by clicking on Bold. This tool is also 
available on the Text Formatting toolbar.

• Set Character Spacing – click on the small triangle ▼ to the right of this tool and select 
the type of spacing between characters required. Spacing between characters is also 
know as kerning. You can also set a custom value for character spacing.

• Superscript – reduces the font size of the selected text and raises the text above the 
baseline. This tool is also available on the Text Formatting toolbar.

• Subscript – reduces the font size of the selected text and lowers the text below the 
baseline. This tool is also available on the Text Formatting toolbar.

Creating lists

The procedure to create a bulleted or numbered list varies depending on the type of text box 
used. The tools to manage and format a list are the same.

AutoLayout text boxes

In AutoLayout text boxes and by default, the outline styles available are bulleted lists. An example
of these outline styles is shown in Figure 23. These outline styles are presentation styles and 
cannot be deleted, but can be modified or updated to your requirements. See Chapter 2, Master 
Slides, Styles and Templates for more information on styles.

By default, the list created in an AutoLayout text box is a bulleted list. To customize the list 
appearance or to change from bulleted to numbered or numbered to bulleted, see “Formatting 
lists” on page 31 for more information.

1) Create a new presentation and go to View > Normal on the Menu bar to make sure you 
are in normal view.
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Figure 23: Example of outline bullet styles

Figure 24: Outline toolbar

2) Select a layout for the slide using one of the following methods:

– Right click in a blank area on the slide and select a layout type from the context menu 
that opens.

– Go to Slide > Layout on the main menu bar and select a layout from the drop-down 
list.

– Select a layout from the layouts displayed in the Layouts section in the Properties 
deck on the Sidebar.

3) Click on the text Click to add Text and start typing your first list item.

4) Click on Enter when you have finished typing the first list point creating a new list point.

5) Use the keyboard combination Shift+Enter to start a new line without creating a new list 
point. This new line will have the same indentation as the text in the list point.

6) To demote the outline level of a list point, use one of the following methods:

– Click on the Tab key.

– Use the keyboard shortcut Shift+Alt+Right Arrow.

– Click on Demote on the Outline toolbar (Figure 24).

– Click on Demote on the Lists section in the Properties deck on the Sidebar.

– Go to Format > Lists on the Menu bar and select Demote from the context menu.

7) To promote the outline level of a list point, use one of the following methods:

– Use the keyboard shortcut Shift+Tab.

– Use the keyboard shortcut Shift+Alt+Left Arrow.

– Click on Promote on the Outline toolbar.

– Click on Promote on the Lists section in the Properties deck on the Sidebar.

– Go to Format > Lists on the Menu bar and select Promote from the context menu.

8) To move a list point lower in the list order without changing the outline level, use one of 
the following methods:

– Click on Move Down on the Outline toolbar.

– Click on Move Down on the Lists section in the Properties deck on the Sidebar.
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– Go to Format > Lists on the Menu bar and select Move Down from the context 
menu.

– Use the keyboard shortcut Shift+Alt+Down  Arrow.

9) To move a list point higher in the list order without changing the outline level, use one of 
the following methods:

– Click on Move Up on the Outline toolbar.

– Click on Move Up on the Lists section in the Properties deck on the Sidebar.

– Go to Format > Lists on the Menu bar and select Move Up from the context menu.

– Use the keyboard shortcut Shift+Alt+Up Arrow.

10) To change the type and appearance of your list, see “Formatting lists” on page 31 for 
information.

Note

Do not try to change the outline style of a list point by selecting the list point and then
selecting another outline style as you would in Writer. In Impress it is not possible to 
change presentation styles used for outline levels in this way.

Note

In AutoLayout text boxes, promoting or demoting an item in a list changes the 
presentation style to match the outline level. For example, second outline level 
corresponds to Outline 2 style, third outline level to Outline 3 style, and so on. This 
change of outline level may change the formatting of the list point (for example font 
size, bullet type, and so on).

Text boxes

1) Create a text box on a slide and make sure the cursor is flashing in the text box. See 
“Creating text boxes” on page 7 on how to create a text box.

2) Create a list using one of the following methods:

– Click on Toggle Bulleted List or Toggle Numbered List in the Text Formatting 
toolbar (Figure 3 on page 5)

– Click on Toggle Bulleted List or Toggle Numbered List in the Lists section in the 
Properties deck on the Sidebar (Figure 26 on page 34).

– Go to Format > Lists on the main menu bar and select Bullet List or Numbered List
from the context menu.

3) Type the text and click on Enter to start a new list point.

4) Use the keyboard combination Shift+Enter to start a new line without creating a new list 
point. The new line will have the same indentation as the list point.

5) To increase the indent level of a list point, use one of the following methods:

– Click on the Tab key.

– Click on the Demote icon on the Outline toolbar (Figure 24 on page 29).

– Click on the Demote icon on the Lists section in the Properties deck on the Sidebar

– Go to Format > Lists on the main menu bar and select Demote from the context 
menu.

6) To decrease the indent level of a list point, use one of the following methods:

– Use the keyboard shortcut Shift+Tab.
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– Click on the Promote icon on the Outline toolbar.

– Click on the Promote icon on the Lists section in the Properties deck on the Sidebar.

– Go to Format > Lists on the main menu bar and select Promote from the context 
menu.

7) To move a list point lower in the list order without changing the indent level, use one of the
following methods:

– Click on the Move Down icon on the Outline toolbar.

– Click on the Move Down icon on the Lists section in the Properties deck on the 
Sidebar.

– Go to Format > Lists on the main menu bar and select Move Down from the context 
menu.

– Use the keyboard shortcut Shift+Ctrl+Down  Arrow.

8) To move a list point higher in the list order without changing the indent level, use one of 
the following methods:

– Click on the Move Up icon on the Outline toolbar.

– Click on the Move Up icon on the Lists section in the Properties deck on the Sidebar.

– Go to Format > Lists on the main menu bar and select Move Up from the context 
menu.

– Use the keyboard shortcut Shift+Ctrl+Up Arrow.

9) To change the type and appearance of your list, see “Formatting lists” on page 31 for 
information.

Formatting lists

You can format the appearance of a list as follows:

• Change the list type, properties, size, position, and scope for the entire list or for a single 
list point using the Bullets and Numbering dialog (Figure 25).

• Change the list type, promote or demote a list point, or move a list point up or down in the
list order using the Lists section in the Properties deck on the Sidebar (Figure 26 on 
page 34).

• Promote or demote a list point, or move a list point up or down in the list order using the 
Outline toolbar (Figure 24 on page 29).

• Change the list type using the tools on the Text Formatting toolbar (Figure 3 on page 5).

• Format the text used in the list. See “Formatting text” on page 15 for more information.

The Bullets and Numbering dialog (Figure 25) gives you greater control of how your list will look 
on your slide.

• Level – select the level(s) that you want to define the formatting options for. The selected
level(s) is highlighted in the preview.

• Properties

– Type – select the numbering style for the list indicator from the drop down list. When 
Graphic is selected as Type, select an image from a file or the Gallery.

– Color – select a color for the list indicator from the palettes available.

– Start at – enter a new starting number for the current level. Default figure is 1.
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Figure 25: Bullets and Numbering dialog

• Separator

– Before – enter a character or text to display in front of the number in the list. For 
example, to create a list that uses the style "[•", enter "[" in this box.

– After – enter a character or text to display behind the number in the list. For example, 
to create a list that uses the style "1.)", enter ".)" in this box.

• Size

– Rel. Size – enter a percentage amount to resize the list indicator in relation to the font 
height of the current list.

– Width – only available when Graphic is selected as Type. Enter a width for the 
graphic.

– Height – only available when Graphic is selected as Type. Enter a height for the 
graphic.

– Keep ratio – only available when Graphic is selected as Type. Maintains the size 
proportions of the graphic.

• Position

– Indent – set the indent measurement for the list point(s).

– Width – set the indent measurement of the text from the list indicator. For example, 
this makes sure there is enough room for the list indicator when large numbers used.

– Relative – select this option to measure the indent value relative to the previous level 
and not from the margin.

– Alignment – sets the paragraph alignment for the list indicator.

• Scope

– Slide – applies the changes to the slide.

– Selection – applies the changes only to the selected text.

– Apply to Master – applies the changes to the master slide being used.
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Bullets and Numbering dialog

The Bullets and Numbering dialog (Figure 25) can be opened using one of the following methods
after selecting text or a text box:

• Go to Format > Bullets and Numbering on the Menu bar.

• Right click on the selected text and select Bullets and Numbering from the context 
menu.

• Click on More Options on the right side of Lists section in the Properties deck on the 
Sidebar.

• Click on More Bullets or More Numbering after clicking on the down pointing arrow ▼ 
on the right of Toggle Bulleted List or Toggle Numbered List on the Lists section in the
Properties deck on the Sidebar.

• Click on More Bullets or More Numbering after clicking on the down pointing arrow ▼ 
on the right of Toggle Bulleted List or Toggle Numbered List on the Text Formatting 
toolbar (Figure 3 on page 5).

Sidebar Lists section

The Lists section (Figure 26) is opened by clicking on Properties on the Sidebar and then 
selecting Lists. Text or a text box must be selected for the Lists options to become available.

• Toggle Bulleted List – this tool is also available on the Text Formatting toolbar (Figure 3 
on page 5) and is accessed using one of the following methods:

– After selecting text, click on this icon to create a bulleted list. Click again to revert 
back to normal text.

– Click on the down pointing arrow ▼ on the right to open a selection of bulleted list 
types (Figure 27).

• Click on More Bullets (Figure 27) to open the Bullets and Numbering dialog.

• Toggle Numbered List – this tool is also available on the Text Formatting toolbar and is 
accessed using one of the following methods:

– After selecting text, click on this icon to create a numbered list. Click again to revert 
back to normal text.

– Click on the down pointing arrow ▼ on the right to open a selection of numbered list 
types (Figure 28).

– Click on More Numbering (Figure 28) to open the Bullets and Numbering dialog.

• Demote – this tool is also available on the Outline toolbar (Figure 24 on page 29). Click 
on this tool to increase the indent level of a list point.

• Promote – this tool is also available on the Outline toolbar. Click on this tool to decrease 
the indent level of a list point.

• Move Down – this tool is also available on the Outline toolbar. Click on this tool move a 
list point lower in the list order without changing the indent level.
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Figure 26: Lists section in Properties 
deck on Sidebar

Figure 27: More bullet types

Figure 28: More numbering types

• Move Up – this tool is also available on the Outline toolbar. Click on this tool move a list 
point higher in the list order without changing the indent level.

• More Options – click on this icon in the Lists section title bar to open the Bullets and 
Numbering dialog for access to a more detailed selection of options for formatting lists.

34 | Chapter 3, Adding and Formatting Text



Figure 29: Table Design section in 
Properties deck on Sidebar

Figure 30: Table toolbar

Using tables

Tables are a powerful mechanism to convey structured information quickly when used in a 
presentation. You can create tables directly in your presentation eliminating the need to embed a 
Calc spreadsheet or a Writer text table. However, in some circumstances, it makes sense to 
embed a table into a presentation, especially when you require greater functionality in the table. 
The tables provided by Impress do have a limited functionality.

Several predefined table designs are available in the Table Design section in the Properties deck 
on the Sidebar (Figure 29). The Sidebar Table Design section is only available when a table is 
selected.

When working with tables in Impress, the Table toolbar (Figure 30) automatically opens providing
tools for creating and formatting your table. 

Inserting tables

When inserting a table into a slide, it is useful to know the number of rows and columns required 
as well as an approximate idea of the table will look. The table can then be formatted after 
creation should it be necessary.

Note

When a table is inserted into a slide, the table is created inside a text box. This text 
box is the same size as the rows and columns of the table.

Insert Table dialog

1) Select the slide which will contain the table and, if necessary, modify the slide layout to 
create space for the table.
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Figure 31: Insert Table dialog

Figure 32: Table 
graphic

2) Go to Insert > Table on the Menu bar to open the Insert Table dialog (Figure 31).

3) Specify the Number of columns and Number of rows in the text boxes.

4) Click OK to insert the table in the slide and close the dialog.

Table graphic

1) Select the slide which will contain the table and, if necessary, modify the slide layout to 
create space for the table.

2) Click on Table on the Standard toolbar or the Table toolbar (Figure 30) to open the Table 
graphic (Figure 32).

3) Drag the cursor across and down in the table graphic to create the required number of 
rows and columns.

4) Release the mouse button to insert the table in the slide and close the Table graphic.

5) If necessary, click on More Options in the Table graphic to open the Insert Table dialog 
and create the rows and columns required.

Note

When inserting tables into a slide, the table is created with the default style and 
settings already applied. Currently these defaults are hard coded in LibreOffice. The 
table can then be formatted to your requirements.

36 | Chapter 3, Adding and Formatting Text



Formatting tables

Sidebar Table Design section

To open and use the Table Design section in the Properties deck on the Sidebar (Figure 29 on 
page 35):

1) Insert a table into a slide) or select a table in a slide.

2) Click on Table Design in the Properties deck on the Sidebar to open the section and 
display the available designs, or click on Table Design on the Table toolbar (Figure 30 on 
page 35).

3) Select a design for your table and the types of rows and columns from the available 
options.

The following options for rows and columns are available in the Table Design section:

• Header row – selected by default. The first row is normally a header row and is 
displayed with a different background from the rest of the table.

• Total row – If selected, it changes the background of the last row to make it stand out 
from the other rows.

• Banded rows – selected by default and alternate rows have different backgrounds 
making it easier to read data entered into the rows. An example of banded rows is shown
in Figure 33.

• First column – when selected, highlights the first column of the table using a darker 
background.

• Last column – when selected, highlights the last column of the table using a darker 
background.

• Banded columns – when selected, alternate columns are highlighted with dark and light 
colors. An example of banded columns is shown in Figure 33.

Figure 33: Example table with banded rows and 
columns

Table toolbar

When a table is selected, the Table toolbar is displayed. If the Table toolbar is not displayed when
a table is selected, go to View > Toolbars > Table on the Menu bar. The Table toolbar contains 
the majority of the tools required to format a table.

• Table – inserts a new table in the selected slide.

• Border Style – opens a drop down selection of available border styles. Select cells in a 
table, then apply a border style. If the required border style is not available, use the 
Borders page in the Table Properties dialog (Figure 40 on page 41).
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• Border Color  – select a color from the available palettes for the borders that are used 
for selected cells. If the required border color is not available, use the Borders page in 
the Table Properties dialog.

• Borders – opens a drop-down menu where you can select a predefined border 
configuration for selected cells. If the required border pattern is not available, use the 
Borders page in the Table Properties dialog.

• Area Style/Filling – opens a drop-down menu where you can select how selected cells 
are filled: None, Color, Gradient, Hatching, Bitmap or Pattern. Depending on Area Style 
selection, the drop-down menu lists the available fillings for the Area Style selected. 
Refer to Chapter 6, Formatting Graphic Objects for more information.

• Merge Cells – merges the selected cells into one cell. The contents of merged cells are 
also merged. Alternatively, right-click on selected cells and select Merge Cells from the 
context menu, or go to Format > Table > Merge Cells on the Menu bar.

• Split Cells – splits a selected cell into multiple cells either horizontally or vertically. Make 
sure that the cursor is positioned on the cell you want to split, then click on Split Cells to 
open the Split Cells dialog (Figure 34).

Alternatively, right-click on the selected cell and select Split Cells from the context menu, 
or go to Format > Table > Split Cells on the Menu bar.

In the Split Cells dialog, select the number of cells required when splitting a cell and 
whether to split the cell horizontally or vertically. When splitting horizontally, you can 
select Into equal proportions to create cells of equal size. The contents of the split cell are
kept in the original cell (left or top cell).

Figure 34: Split Cells dialog

• Optimize – evenly distributes the selected rows and columns in a table either horizontally
or vertically. Clicking on Optimize opens the Optimize toolbar (Figure 35) and contains 
the following tools:

– Minimal Column Width – defines the minimal column width for selected columns. 
Minimal column width depends on the shortest entry within a column.

– Minimal Row Height – determines the minimal row height for selected rows. Minimal 
row height depends on the font size of the smallest character in the row.

– Optimal Column Width – defines the optimal column width for selected columns. 
Optimal column width depends on the longest entry within a column.

– Optimal Row Height – determines the optimal row height for selected rows. Optimal 
row height depends on the font size of the largest character in the row.
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Figure 35: Optimize
toolbar

– Distribute Columns Evenly – adjusts the width of the selected columns to match the 
width of the widest column in the selection. The total width of the table cannot exceed 
the width of the page.

– Distribute Rows Equally – adjusts the height of the selected rows to match the height 
of the tallest row in the selection.

Alternatively, right-click in selected cells and select from the context menu the appropriate
Optimize tool.

• Align Top, Center Vertically, Align Bottom – selects vertical alignment of text in 
selected cells. Alternatively, right-click in selected cells and select Align from the context 
menu or go to Format > Align on the Menu bar and select the required alignment.

• Insert Row Above, Insert Row Below, Insert Column Before, Insert Column After – 
select a row or column then click on one of these tool to insert a row or column.

Alternatively, go to Format > Table > Insert Row or Insert Column on the Menu bar to 
open the Insert Row dialog (Figure 36) or Insert Column dialog (Figure 37). Select 
number of rows or columns and the insertion position then click OK to insert.

Figure 36: Insert Rows dialog

Figure 37: Insert Columns 
dialog

• Delete Row, Delete Column – clicking on these tools deletes a single row or column 
that contains a selected a cell. To delete more than one row or column, highlight cells 
across the number of rows or columns as required, then click on Delete Row or Delete 
Column.

Alternatively, right-click in the selected cells and select Delete > Delete Row or Delete 
Column from the context menu.
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To delete the whole table, select the table so that the text box border and selection 
handles are displayed. Click on Delete Row or Delete Column to delete the table.

• Select Table, Select Column, Select Rows – these tools select a complete table or 
columns or rows where cells are selected.

By default these tools are not displayed on the Table toolbar. To display these tools, right-
click in a blank area on the toolbar and select Visible Buttons from the context menu. 
Click on the tool you want displayed in the toolbar.

• Table Design – when clicked, this tool opens the Table Design section in the Properties 
deck on the Sidebar. See “Sidebar Table Design section” on page 37 for more 
information.

• Table Properties – click this tool on to open the Table Properties dialog.

Table Properties dialog

The Table Properties dialog (Figure 38) has four tabbed pages that provide formatting options for 
Font, Font Effects, Borders and Background. The Table Properties dialog is opened using one
of the following methods:

• Right-click in a table and select Table Properties from the context menu.

• Go to Format > Table > Properties on the Menu bar.

• Click on Table Properties on the Table toolbar.

The formatting options available on each dialog page are as follows:

• Font (Figure 38) – select the required Family, Typeface (Italic, Bold, etc.), Size and 
Language for text in the table. A sample of the font selected is displayed in the preview 
box. See “Fonts” on page 24 for more information.

Figure 38: Table Properties dialog - Font page
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Figure 39: Table Properties dialog - Font Effects page

Figure 40: Table Properties dialog - Borders page

• Font Effects (Figure 39) – select the required Font Color, Text Decoration and Effects for
the text in the table. A sample of the font effects applied to the text is displayed in the 
preview box. See “Font Effects” on page 25 for more information.

• Borders (Figure 40) – select advanced options that are not available when using Border 
Style, Border Color and Borders tools on the Table toolbar.

• Background (Figure 41) – select a color from the available palettes for the background 
of selected cells. This dialog provides the same functions as Area Style/Filling on the 
Table toolbar.
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Figure 41: Table Properties dialog - Background page

Position and size

Tables are placed into text boxes when created and are treated just like any other graphic object 
in an Impress presentation. However, only the Position and Size dialog (Figure 9 on page 10) can
be used for tables. See “Position and Size dialog” on page 10 for more information.

Open the Position and Size dialog using one of the following methods after selecting the table:

• Right click on the table and select Position and Size from the context menu.

• Go to Format > Object and Shape > Position and Size on the Menu bar.

• Use the keyboard shortcut F4.

You can also change text box position by dragging with the cursor and change text box size 
using the selection handles. See “Working with text boxes” on page 5 for more information.

Note

When the size of a text box containing a table is changed, the table also increases or
decreases in size to keep the text filled with the table.

Using fields

Fields allow the automatic insertion of text into a slide. Fields are commonly used when creating 
templates and slide masters. For more information, see Chapter 2, Slide Masters, Styles, and 
Templates.

Inserting fields

Insert a field into a slide as follows:

1) Select the slide where you want to add a field.

2) Go to Insert > Field on the Menu bar and select the type of field. The field is placed on 
the selected slide in a text box.

3) If necessary, position and resize the field text box. See “Working with text boxes” on 
page 5 for more information.
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4) If necessary, format the text used for the field information. See “Formatting text” on 
page 15 for more information.

Field types

The types of field available are as follows:

• Date (fixed) – inserts the current date into your slide as a fixed field. The date is not 
automatically updated. Available date formats depends on the language setting in Tools 
> Options > Language Settings > Language. Right click on the date field and select 
the required date format from the context menu.

• Date (variable) – inserts the current date into your slide as a variable field. The date is 
automatically updated each time you open the file. Available date formats depends on 
the language setting in Tools > Options > Language Settings > Language. Right click 
on the date field and select the required date format from the context menu.

• Time (fixed) – inserts the current time into your slide as a fixed field. The time is not 
automatically updated. Available time formats depends on the language setting in Tools 
> Options > Language Settings > Language. Right click on the time field and select 
the required time format from the context menu.

• Time (variable) – inserts the current time into your slide as a variable field. The time is 
automatically updated each time you open the file. Available time formats depends on 
the language setting in Tools > Options > Language Settings > Language. Right click 
on the time field and select the required time format from the context menu.

• Author – inserts the first and last names of the author of the presentation. This 
information is taken from values entered in the LibreOffice user data. To modify this 
information go to Tools > Options > LibreOffice > User Data.

• Slide Number – inserts the slide number into the current slide. Alternatively, go to 
Format > Slide Number on the Menu bar. If you want to add a slide number to every 
slide, go to View > Master Slide on the Menu bar and insert the slide number field.

• Slide Title – inserts the slide title. The default slide name is Slide # if you have not 
renamed the slide.

• Slide Count – inserts the total number of slides in the presentation.

• File Name – inserts the name of the file used for the presentation. The file name only 
appears after you have saved the file.

Using hyperlinks

When inserting text that can be used as a hyperlink, such as a website address or URL, Impress 
formats it automatically, creating a hyperlink, and applying color and underlining. If you do not 
want Impress to use its default settings, then you have to insert a hyperlink manually.

Tip

To prevent LibreOffice from automatically turning website addresses or URLs into 
hyperlinks, go to Tools > AutoCorrect Options > Options and deselect URL 
Recognition.
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Figure 42: Hyperlink dialog - Internet page

Tip

To change the color of hyperlinks, go to Tools > Options > LibreOffice > 
Application Colors, scroll to Unvisited links and/or Visited links, select the 
checkboxes, then select new colors from the color palettes for the links and click OK.
Note this color change will change the color for all hyperlinks across all components 
of LibreOffice.

Inserting hyperlinks

1) Go to Insert > Hyperlinks on the main menu bar or use the keyboard shortcut Ctrl+K to 
open the Hyperlink dialog (Figure 42).

2) On the left hand side, select the type of hyperlink you want to insert.

The top right part of the dialog changes depending on the hyperlink type. A full description
of all options, and their interactions, is beyond the scope of this chapter. A summary of the
most common choices used in a presentation is given below.

3) Create your hyperlink using the dialog, then click Apply to insert the hyperlink into your 
slide. The hyperlink is inserted into a text box.

4) Click Close or OK to close the dialog.

Hyperlink types

• Internet (Figure 42) – select either Web or FTP protocol. Enter the required web address
in the URL: text box and a name for the hyperlink in the Text: text box.

• Mail (Figure 43) – enter email details in Recipient and the subject of the link in Subject.

• Document (Figure 44) – creates a hyperlink to another document or to another place in a
document, commonly referred to as a bookmark. Enter the details in the Path text box, or
click on Open File to open a file browser. Leave this blank if you want to link to a target 
in the same presentation.
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Figure 43: Hyperlink dialog - Mail page

Figure 44: Hyperlink dialog - Document page

Optionally, you can specify a target, for example a specific slide. Click on Target in 
Document to open a dialog where you can select the target. If you know the name of the 
target, you can type it into the Target text box.

• New Document (Figure45) – creates a hyperlink to a new document. Select Edit now to 
edit the newly created document immediately or Edit later to only create the hyperlink. 
Choose the type of document to create from the File type drop down list. Click on Select
path to open a file browser so that you can choose a directory for the new document.

The Further Settings section on the Hyperlink dialog is common to all the hyperlink types, 
although some choices are more relevant to some types of links.

• Frame – set the value to determine how the hyperlink will open. This applies to 
documents that open in a web browser.
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Figure 45: Hyperlink dialog - New Document page

• Form – specifies if the link is to be presented as text or as a button.

• Text – specifies the text that will be visible to the user.

• Name – applicable to HTML documents. It specifies text that will be added as a NAME 
attribute in the HTML code behind the hyperlink.

Formatting hyperlinks

A hyperlink is inserted in the center of the current slide. To edit the text, the size of a hyperlink 
text box, or to reposition the hyperlink on the slide:

1) Select it by dragging a selection across the text to display the text box border and 
selection handles. Do not click on the hyperlink because this will open the hyperlink.

2) Right-click on the selected hyperlink and select the type of formatting you want to change 
from the options available in the context menu.

3) To reposition hyperlink, click and drag on the border to move the hyperlink on the slide.

4) Select Position and Size from the context menu or press the F4 key to open the Position
and Size dialog where you can change the options to move the hyperlink or resize the 
text box. See “Working with text boxes” on page 5 for more information.
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