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Introduction

You can create 2D and 3D objects in Draw. This chapter shows how to draw simple 2D objects. 
The following chapters describe how to work with and edit such objects. For more information on 
3D objects, see Chapter 7 Working with 3D Objects.

All shapes, whether they are lines, rectangles, or more complicated shapes, are called objects. 
This is common notation in vector drawing software.

The drawing tools are found on the Drawing toolbar (Figure 1). This toolbar is normally located at 
the bottom of the workspace. If you do not see it, you can activate it by going to View > Toolbars 
on the Menu bar.

As with all the components of LibreOffice, you can undock the Drawing toolbar and place it 
wherever you want to on the Draw workspace as a floating toolbar. You can also configure toolbars
by adding, moving, hiding, or deleting toolbar icons. See Chapter 1 Introducing Draw for more 
information.

When you draw a shape, select an object for editing or add text to the drawing, the information 
field in the Status bar (Figure 2) changes to reflect the action taken or in progress. See Chapter 1 
Introducing Draw for more information on the Status bar.

Figure 1: Drawing toolbar

Figure 2: Status bar

Drawing basic shapes

Basic shapes, including text, are treated as objects in Draw. The standard set of tools available for 
drawing basic shapes on the Drawing toolbar are shown in Figure 1. Click on the small triangle on 
the right of the Drawing toolbar, then select Visible Buttons from the drop down menu to open a 
list of available tools (Figure 3).

The tools that are already placed on the Drawing toolbar are indicated by a check mark ( )✓  next to 
the icon in the Visible Buttons list, for example Select, Line and so on. The tools without a check 
mark ( )✓ , for example To Curve, To Polygon, and so on, are not installed on the Drawing toolbar.

Please note that some of the icons on the Drawing toolbar will change shape according to the last 
tool used from the selection of available tools. The icons that have a small triangle to the right of 
the icon indicates that more tools are available. See “Drawing geometric shapes” on page 14 for 
information on the available shapes.
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Figure 3: Drawing toolbar - Visible Buttons

Note

When you draw a basic shape or select one for editing, the information area at the left 
side in the status bar changes to reflect the present action: for example Line created, 
Text frame xxyy selected, and so on.

Straight lines
A straight line is the simplest element or object in Draw to create.

 1) Use one of the following options to start drawing a line:

• Click the insert Line icon in the Drawing toolbar.

• Click the small triangle on the right of the Lines and Arrows icon in the Drawing 
toolbar and select the Insert Line icon from the drop down list.

• Click the Insert Line icon in the Lines and Arrows section of the Shapes deck on the 
Sidebar.

Figure 4: Line 
starting point
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 2) Place the cursor at the point where you want to start the line (Figure 4) and drag the mouse
while keeping the mouse button pressed.

 3) Release the mouse button at the point where you want to end the line. A selection handle 
appears at each end of the line, showing that this object is the currently selected object. 
The selection handle at the starting point of the line is slightly larger than the other selection
handle.

 4) Keep the Ctrl  key pressed while drawing a line to enable the end of the line to snap to the 
nearest grid point.

Note

This is the default behavior of the Ctrl  key. However, if the Snap to Grid option on 
the View > Grid menu has been selected, the Ctrl  key deactivates the snap to grid 
activity.

 5) Keep the Shift  key pressed while drawing a line to restrict the drawing angle of the line to 
a multiple of 45 degrees (0, 45, 90, 135, and so on).

Note

This is the default behavior of the Shift  key. However, if the option When creating or 
moving objects in the Constrain Objects section of Tools > Options > LibreOffice 
Draw > Grid has been selected, the action of the Shift  key is the opposite. Lines will 
automatically be drawn at a multiple of 45 degrees unless the Shift  key is pressed.

 6) Keep the Alt  key pressed while drawing a line to cause the line to extend outwards 
symmetrically in both directions from the start point. This lets you draw lines by starting 
from the middle of the line.

When a line is drawn, it uses default attributes. To change any of these attributes, select a line by 
clicking on it, then use one of the following methods to change the properties:

• Go to the Properties deck on the Sidebar and open the Line pane (Figure 5).

• Right-click on the line and select Line from the context menu to open the Line dialog 
(Figure 6).

Figure 5: Line section in Properties deck on 
Sidebar
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Figure 6: Line dialog - Line page

Figure 7: Line and Filling toolbar

• Go to Format > Line on the main menu bar to open the Line dialog (Figure 6).

• Use the controls in the Line and Filling toolbar (Figure 7). If the Line and Filling toolbar is
not visible, go to View > Toolbars on the main menu bar and select Line and Filling from 
the drop down menu.

Arrows
Arrows are drawn like lines. Draw classifies arrows as a subgroup of lines, that is lines with 
arrowheads. Hovering the mouse cursor over each of the type of arrows available will tell you the 
type of line endings each icon will draw.

Note

The icon for the tool used most recently will already be selected on the Drawing 
toolbar to make it easier to use the same tool again.

The line endings available are lines, arrows, circles, squares, dimension lines and 45 degree lines. 
The information field on the Status bar shows them only as lines.

 1) Use one of the following options to start drawing an arrow:

• Click the Lines and Arrows icon in the Drawing toolbar to draw the type of arrow 
indicated by the icon.

• Click the small triangle on the right of the Lines and Arrows icon in the Drawing 
toolbar and select the type of arrow you require from the drop down list (Figure 8).

• Click the icon of the type of arrow you require in the Lines and Arrows section of the 
Shapes deck on the Sidebar (Figure 10).
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Figure 8: Lines and Arrows

Figure 9: Shapes deck in Sidebar

 2) Place the cursor at the point where you want to start the arrow and drag the mouse while 
keeping the mouse button pressed. The arrowhead is drawn at the end point of the arrow 
when you release the mouse button.

Note

After drawing the line, you can change the arrow style by opening the Line dialog 
(Figure 6) and going to the Arrow Styles page. Here you will find a larger selection of 
line endings to use in your drawing.
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Note

You can also select the arrow style using the left or right drop down list in the Line 
section on the Properties deck (Figure 5). The left drop down list places an arrowhead
at the start of a line. The right drop down list places an arrowhead at the end of a line.

Rectangles or squares
• Drawing a rectangle or a square is similar to drawing a straight line using one of the 

following methods:

• Click on the Rectangle icon in the Drawing toolbar (Figure 1 on page 4).

• Select Rectangle icon in Basic Shapes on the Shapes deck in the Sidebar (Figure 10 
on page 8).

• Select the icon for the type of rectangle or square from the Legacy Rectangles toolbar 
(Figure 11). To display the Legacy Rectangles toolbar, go to View > Toolbars on the 
main menu bar and select it.

Figure 10: Legacy Rectangles 
toolbar

• As you draw the rectangle with the mouse cursor, the rectangle appears with its bottom 
right corner attached to the cursor.

• Squares are rectangles with all sides of equal length. To draw a square, click on the 
Rectangle icon and hold down the Shift  key while you draw a square.

• To draw a rectangle or square from its center rather than the bottom right corner, position 
your cursor on the drawing, press the mouse button and then hold down the Alt  key while 
dragging with the cursor. The rectangle or square uses the start point (where you first 
clicked the mouse button) as the center.

Note

If the option When creating or moving objects has been selected in the Constrain 
Object section of Tools > Options > LibreOffice Draw > Grid, the action of the Shift
key is reversed: the Rectangle tool draws a square. To draw a rectangle, press the 
Shift  key. This Shift  key reversal also applies when drawing ellipses and circles.

Ellipses or circles
• Draw an ellipse (also called an oval) or a circle using one of the following methods:

• Click on the Ellipse icon in the Drawing toolbar (Figure 1 on page 4).

• Select Ellipse icon in Basic Shapes on the Shapes deck in the Sidebar (Figure 10 on 
page 8).

• Select the icon for the type of ellipse or circle from the Legacy Circles and Ovals 
toolbar (Figure 11). To display the Legacy Circles and Ovals toolbar, go to View > 
Toolbars on the main menu bar and select it.
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Figure 11: Legacy Circles and Ovals toolbar

• As you draw the ellipse with the mouse cursor, the ellipse or circle appears with its bottom 
right corner attached to the cursor.

• A circle is an ellipse with both axes the same length. To draw a circle, click on the Ellipse 
icon and hold down the Shift  key while you draw a circle.

• To draw an ellipse or circle from its center, position the cursor on the drawing, press the 
mouse button and then hold down the Alt  key while dragging with the cursor. The ellipse 
or circle uses the start point (where you first clicked the mouse button) as the center.

Tip

To quickly insert a line, rectangle, ellipse, or text, press and hold down the Ctrl  key 
and then click on one of the icons for Line, Rectangle, Ellipse, or Text and a standard 
sized object is drawn automatically in the work area. The size, shape, and color are all 
standard values. These attributes can be changed later, if desired. See Chapter 4 
Changing Object Attributes for more information.

Dimension lines
Dimension lines display a measurement of an object in the drawing (Figure 12). The dimension line
does not belong to the object itself, but it is usually placed close to it. An object can have as many 
dimension lines as necessary to indicate measures of its sides, edges, and distances.

Figure 12: Measuring an object 
with dimension lines

You can control the display of a dimension line components and appearance by selecting it, right-
clicking, and choosing Dimensions in the context menu to display the Dimension line dialog 
(Figure 13).

 1) Use one of the following options to start drawing a dimension line:

• Click the small triangle on the right of the Lines and Arrows icon in the Drawing 
toolbar and select Dimension Line from the drop down list (Figure 9 on page 8).

• Click the Dimension Line icon in the Lines and Arrows section of the Shapes deck on
the Sidebar (Figure 10 on page 9).
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Figure 13: Dimension lines setting dialog

 2) Place the cursor at the point where you want to start the dimension line and drag the 
mouse while keeping the mouse button pressed. The dimension line is drawn and 
automatically calculates and displays the linear dimension.

 3) To adjust the settings of a dimension line, right click on the dimension line and select 
Dimension from the context menu to open the Dimension Line dialog (Figure 13).

 4) Change the dimension settings using the various options in the Dimension Line dialog, 
then click OK to save your changes and close the dialog.

Arcs and segments
If you regularly draw arcs or segments (partial circles or ellipses), then you can use the optional 
Legacy Circles and Ovals toolbar (Figure 11 on page 10). Go to View > Toolbar on the main 
menu bar and select Legacy Circles and Ovals to open the toolbar.

• When you hover the cursor over an icon on this toolbar, the name of the object you are 
selecting is displayed.

• Click on the required icon in the Legacy Circles and Ovals toolbar. As you draw your 
object with the mouse cursor, the object appears with its bottom right corner attached to the
cursor.

• To draw an object from its center, position the cursor on the drawing, press the mouse 
button and then hold down the Alt  key while dragging with the cursor. The object uses the 
start point (where you first clicked the mouse button) as the center.

An arc or segment is drawn as follows:

 1) Select the appropriate icon in the Legacy Circles and Ovals toolbar (Figure 11 on page
10), then click and drag with the cursor to start creating your arc or segment.

 2) Release the mouse button then move the cursor to the position where you want the arc or 
segment to start and click to start drawing the arc or segment. The status bar indicates the 
angle in degrees.

Drawing basic shapes | 11



 3) Release the mouse button then move the cursor to the position where you want the arc or 
segment to finish. The status bar shows the angle in degrees.

 4) When you have drawn the arc or segment you require, click again to complete the arc or 
segment.

Curves, polygons or freeform lines
Use one of the following options to start drawing a curve, polygon or freeform line. Moving the 
mouse cursor over one of the icons shows a tooltip giving the type of curve, polygon or freeform 
line:

• Click the small triangle on the right of the Curve and Polygons icon in the Drawing toolbar
and select the type of curve, polygon or freeform line from the drop down list (Figure 19).

• Select and click the type of curve, polygon or freeform line in the Curve and Polygons 
section of the Shapes deck on the Sidebar (Figure 10 on page 9).

Notes

The icon for the tool used most recently is shown on the Drawing toolbar to make it 
easier to use the same tool again.

Figure 14: Curves and 
Polygons toolbar

Curves
 1) Click and hold the left mouse button to create the starting point of the curve, then drag from

the starting point drawing a line. Release the mouse button and continue to drag the cursor 
to bend the line into the required curve shape.

 2) Click to set the end point of the curve and fix it on the page.

 3) Continue dragging the cursor to draw straight lines at the end of your curve. Each mouse 
click sets a corner point and allows you to continue drawing another straight line from the 
corner point.

 4) Double-click to end the drawing of your curve and lines.

Notes

A filled curve automatically joins the last point to the first point to close off the object 
and fills it with the selected fill color. A curve without filling will not be closed at the end 
of the drawing.

Polygons
 1) Click and draw the first line from the start point while holding down the left mouse button. 

As soon as you release the mouse button, a line between the first and second points is 
drawn.

 2) Move the cursor to draw the next line. Each mouse click sets a corner point and allows you 
to draw another line.

 3) Double-click to end the drawing of your polygon.
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Notes

A filled polygon automatically joins the last point to the first point to close off the figure 
and fills it with the selected fill color. A polygon without filling will not be closed at the 
end of the drawing.

Polygons 45°
Like ordinary polygons, these are formed from lines, but the angles between lines are restricted to 
45 or 90 degrees. If required, hold down the Shift  key as you draw the line so that the line is 
drawn at an angle other than 45 or 90 degrees.

Freeform lines
Using the freeform line tools is similar to drawing with a pencil on paper.

 1) Click and drag the cursor to the line shape you require.

 2) Release the mouse button when you are satisfied with your freeform line and the drawing is
completed.

 3) If Freeform Line Filled is selected, the end point is joined automatically to the start point 
and the object is filled with the selected color.

Glue points and connectors

Glue points
All Draw objects have glue points, which are not normally displayed. Glue points become visible 
when the Connectors icon is selected on the Drawing toolbar (Figure 1 on page 4) or when an 
icon in the Connectors section on the Shapes deck in the Sidebar (Figure 10 on page 9).

Most objects have four glue points (Figure 15). You can add more glue points and customize them,
using the Glue Points toolbar (Figure 16). Go to View > Toolbars > Glue Points to open the 
toolbar.

Glue points are not the same as the selection handles of an object. Selection handles are for 
moving or changing the shape of an object. Glue points are used to fix or glue a connector to an 
object so that when the object moves, the connector stays fixed to the object. For a more detailed 
description on the use of glue points, see Chapter 3, Working with Objects and Object Points and 
Chapter 8, Connections, Flowcharts, and Organization Charts.

Figure 15: Glue points
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Figure 16: Glue points toolbar

Figure 17: Connector between two objects

Figure 18: Connectors toolbar

Connectors
Connectors are lines or arrows whose ends automatically snap to a glue point of an object. 
Connectors are especially useful in drawing organization charts, flow diagrams, and mind-maps. 
When objects are moved or reordered, the connectors remain attached to a glue point. Figure 17 
shows an example of two objects and a connector.

Draw offers a range of different connectors and connector functions. On the Drawing toolbar, click 
on the triangle next to the Connector icon to open the Connectors toolbar (Figure 18), or select a 
connector from Connectors section in the Shapes deck in the Sidebar (Figure 10 on page 9). For 
a more detailed description of the use of connectors, see Chapter 8, Connections, Flowcharts, and
Organization Charts.

Drawing geometric shapes

The icons for drawing geometric shapes are located on the Drawing toolbar and on the Shapes 
deck in the Sidebar (Figure 10 on page 9). Clicking on the triangle to the right of an icon on the 
Drawing toolbar opens a floating toolbar giving access to the tools for that shape.

The use of these tools for geometric shapes is similar to the tool used for drawing rectangles and 
squares. For more information, see “Rectangles or squares” on page 9.

The icons used on the Drawing toolbar for drawing geometric shapes always indicates the last tool
used and may not be the same as the icons shown in the following sections.

You can add text to all of these geometric shapes. For more information, see Chapter 11 Advanced
Draw Techniques.

Figure 19: Basic Shapes toolbar
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Basic shapes
Click on the triangle to the right of the Basic Shapes icon to open the Basic Shapes toolbar 
(Figure 20) for drawing basic shapes. This toolbar also includes a rectangle tool identical to the 
one already displayed on the Drawing toolbar. Alternatively, select the required icon in the Basic 
Shapes section in the Shapes deck on the Sidebar (Figure 10 on page 9).

Symbol shapes
Click on the triangle to the right of the Symbol Shapes icon to open the Symbol Shapes toolbar 
(Figure 21) for drawing symbols. Alternatively, select the required icon in the Symbol Shapes 
section in the Shapes deck on the Sidebar (Figure 10 on page 9).

Figure 20: Symbol Shapes toolbar

Block arrows
Click on the triangle to the right of the Block Arrows icon to open the Block Arrows toolbar 
(Figure 22) for drawing block arrows. Alternatively, select the required icon in the Block Arrows 
section in the Shapes deck on the Sidebar (Figure 10 on page 9).

Figure 21: Block Arrows toolbar

Flowcharts
Click on the triangle to the right of the Flowchart icon to open the Flowchart toolbar (Figure 23) 
for symbols used in drawing flowcharts. Alternatively, select the required icon in the Flowchart 
section in the Shapes deck on the Sidebar (Figure 10 on page 9).

The creation of flowcharts, organization charts, and similar planning tools are further described in 
Chapter 8 Connections, Flowcharts and Organization Charts.

Figure 22: Flowchart toolbar

Callouts
Click on the triangle to the right of the Callout icon to open the Callouts toolbar (Figure 24) for 
drawing callouts. Alternatively, select the required icon in the Callouts section on the Shapes deck
on the Sidebar (Figure 10 on page 9).

Figure 23: Callouts toolbar
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Stars and banners
Click on the triangle to the right of the Star icon to open the Stars and Banners toolbar (Figure 1) 
for drawing stars and banners. Alternatively, select the required icon in the Stars and Banners 
section in the Shapes deck on the Sidebar (Figure 10 on page 9).

Figure 24: Stars and Banners toolbar

3D Objects
Click on the triangle to the right of the 3D icon to open the 3D-Objects toolbar (Figure 25) for 
drawing 3D objects. Alternatively, select the required icon in the 3D-Objects section in the Shapes
deck on the Sidebar (Figure 10 on page 9).

Figure 25: 3D-Objects toolbar

Adding text

In Draw you can add, insert, and format text to a drawing, objects, and shapes as follows:

• As a dynamic text frame, which is an independent Draw object and expands as you add 
more text within the frame.

• Text within a previously drawn object. This integrates text within the object and is placed 
within the boundary rectangle that surrounds an object. This boundary rectangle is not 
dynamic and care must be taken so that your text does not go outside of the object 
boundaries.

For more information on how to add, insert, and format text in a drawing or drawing objects, see 
Chapter 9 Adding and Formatting Text.
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