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Designing a presentation

In addition to careful planning of the content, as discussed in Chapter 1 Introducing Impress, you 
need to plan the appearance of the presentation. It is best to do this after you have developed an
outline, because the outline will determine some of the requirements for the appearance of the 
slides. For example:

• What color combinations (background and text) will look good and also be easy for your 
audience to read?

• Would an image help your audience understand the contents better?

• Do you want particular text and image to appear on all the slides? For example a 
company name and logo.

• Would the audience benefit from having the slides numbered so that they can quickly 
refer to one of them?

• Do you want a background graphic or gradient? If so, you need to pick something that 
does not interfere or clash with content such as the colors used in charts.

• Will you need one or more master slide?

• Will one slide design suit all of the presentation content?

You can change the appearance of slides as you develop the presentation, but planning ahead 
will save you time in the long run.

What are master slides?

A master slide is a slide that is used as the starting point for other slides. It is similar to a page 
style in LibreOffice Writer as it controls the basic formatting of all slides based on it. A 
presentation can have more than one master slide.

Note

LibreOffice uses three terms for one concept: master slide, slide master, and master 
page. All refer to a slide which is used to create other slides. This user guide uses 
the term master slide, except when describing the user interface.

A master slide has a defined set of characteristics, including the background color, graphic, or 
gradient. It also can include objects (for example, logos, decorative lines) in the background; 
headers and footers; placement and size of text frames; and text formatting.

All of the characteristics of master slides are controlled by styles. The styles of any new slide you
create are inherited from the master slide from which it was created. In other words, the styles of 
the master slide are available and applied to all slides created from that master slide. Changing a
style in a master slide results in changes to all the slides based on that master slide. It is, 
however, possible to modify each individual slide without affecting the master slide.

Note

It is highly recommended to use the master slides whenever possible. However, 
there are occasions where manual changes are needed for a particular slide.  For 
example, you could edit an individual slide to enlarge the chart area when the text 
and chart layout is used.
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Master slides have two types of styles associated with them: presentation styles and drawing 
styles. The presentation styles can be modified, but new presentation styles cannot be created. 
For drawing styles, you can modify the styles and also create new drawing styles. For more 
information, see “Working with styles” on page 22.

Working with master slides

Impress comes with a collection of master slides. These master slides are shown in the Master 
Slides deck of the Sidebar (Figure 1). This deck has three sections: Used in This Presentation, 
Recently Used, and Available for Use. Click the expand marker next to the name of a section to 
expand it and show thumbnails of the master slides, or click the collapse marker to collapse the 
section to hide the thumbnails.

Each of the master slides shown in the Available for Use section is from a template of the same 
name. These presentation templates are included when install LibreOffice on your computer. If 
you have created your own templates, or added templates from other sources, master slides 
from those templates will also appear in this list. See “Working with templates” on page 27 for 
more information about templates.

If you have decided to create a new presentation without using one of the templates available 
(see Chapter 1, Introducing Impress for more information), then a default master slide is 
available. This default master slide is a good starting point for creating master slides. An example
of the default master slide is shown in Figure 2.

Figure 1: Master Slides deck on Sidebar
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Figure 2: Default master slide

Figure 3: 
Master View 
toolbar

Figure 4: Rename Slide dialog

Creating master slides

Creating a new master slide is carried out when Impress is in Master View.

1) Go to View > Master Slide on the main menu bar to open Master View in the 
Workspace. The Master View toolbar also opens (Figure 3). If the Master View toolbar 
does not open, go to View > Toolbars on the main menu bar and select Master View.

2) Create a new master slide using one of the following methods and a new master slide 
appears in the Slides Pane:

– Click on New Master in the Master View toolbar.

– Right-click on a master slide in the Slides Pane and select New Master from the 
context menu.

– Go to Slide > New Master on the Menu bar.

3) Rename the new master slide using one of the following methods and open the Rename 
Slide dialog (Figure 4):

– Click on Rename Master in the Master View toolbar.

– Right-click on the new master slide in the Slides Pane and select Rename Master 
from the context menu.
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4) Enter a memorable name for the new master slide in the Name text box, then click on OK
to save the changes and close the dialog.

5) Make sure the new master slide is selected in the Slides Pane and add all the text, 
graphics and master elements that you want to use for the new master slide. The 
chapters in this user guide give more information on adding, editing, formatting and 
managing the different types of objects on a master slide.

6) When finished creating a new master slide, use one of the following methods to return to 
Normal View:

– Click on Close Master View on the Master View toolbar.

– Go to View > Normal on the Menu bar.

7) Save the presentation file before continuing.

Applying master slides

To apply a master slide to all slides or selected slides in a presentation:

1) Click on the Master Slides icon to open the Master Slides deck on the Sidebar (Figure 1 
on page 6).

2) Right-click on the master slide you want to use in the Used in This Presentation section in
the Master Slides deck on the Sidebar. 

3) Select Apply to All Slides or Apply to Selected Slides from the context menu.

Loading additional master slides

In a presentation, you may need to mix multiple master slides that may belong to different 
templates (for more information, see “Working with templates” on page 27). For example, you 
may want a completely different layout for the first slide of the presentation, or want to add a slide
from a different presentation to your current presentation.

1) Select the slide or slides in the Slides Pane where you want to change the master slide.

2) Go to Slide > Change Slide Master on the Menu bar to open the Available Master Slides
dialog (Figure 5).

3) To add master slides, click on Load to open the Load Master Slide dialog (Figure 6).

4) In the Load Master Slide dialog, select the template category and the template from which
to load the master slide

5) Click OK to close the Load Master Slide dialog and the master slides from the selected 
template appear in the Available Master Slides dialog.

6) Select the master slide you want to use in Select a Slide Design box.

7) To apply the selected master slide to all slides in your presentation, select the Exchange 
background page check box.

8) To apply the slide design to the selected slides only, deselect the Exchange background 
page check box.

9) Click OK to apply your selection to the slides and close the Available Master Slides 
dialog.

8 | Chapter 2, Master Slides, Styles, and Templates



Figure 5: Available Master Slides dialog

Figure 6: Load Master Slide dialog
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Editing master slides

The following items can be changed on a master slide:

• Background (color, gradient, hatching, or bitmap). See “Selecting and applying 
backgrounds” on page 11 for more information.

• Background objects (for example, adding a logo or decorative graphics), See “Adding 
images” on page 13, Chapter 4, Adding and Formatting Pictures, Chapter 5, Managing 
Graphic Objects, and Chapter 6, Formatting Graphic Objects for more information.

• Text attributes for the main text area and notes. See “Adding text and fields” on page 19 
and Chapter 3, Adding and Formatting Text for more information.

• Size, placement, and contents of header and footer elements to appear on every slide. 
See “Adding text and fields” on page 19 and Chapter 3, Adding and Formatting Text for 
more information.

• Size and placement of default frames for slide titles and content. See “Default text areas” 
on page 14 for more information.

Editing a master slide is as follows:

1) Select View > Master Slide from the Menu bar. This also opens the Master View toolbar 
(Figure3 on page 7).

2) Select a master slide you want to edit in the Slides Pane so that it appears in the 
Workspace (Figure 7).

3) Go to Slide > Properties on the Menu bar or right-click in the Workspace and select 
Properties from the context menu to open the Slide Setup dialog (Figure 8).

4) Use the various options in the Slide, Background and Transparency pages in the Slide 
Setup dialog to make changes to the format of your master slide.

5) Click OK to save your changes and close the Slide Setup dialog.

6) Select an object on the master slide, then right-click on the object to open a context 
menu.

Figure 7: Master slide view
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Figure 8: Slide Setup dialog

7) Select one of the options from the context menu to edit the object. Selecting an option 
may open another context menu, a dialog, an application or file browser window so you 
can make the necessary changes to your selected object.

8) Click on Close Master View on the Master View toolbar or go to View > Normal on the 
Menu bar to exit from editing master slides.

9) Save your presentation file before continuing.

Note

Any changes made to a master slide when in Master Slide view will appear on all 
slides using the same master slide. Always make sure you close Master Slide view 
and return to Normal view before working on any of the presentation slides.

Any changes made to any object on a slide in Normal view (for example, changes to bullet point 
style, color of the title area, and so on) will not be overridden by subsequent changes made to 
the master slide used for that slide. However, where it is desirable to revert the formatting of a 
manually formatted object on a slide to the style defined in the master slide, select the object on 
the slide and use one of the following methods to change the formatting:

• Go to Format > Clear Direct Formatting on the Menu bar.

• Right-click on an object and select Clear Direct Formatting from the context menu.

Note

Depending on the contents of a slide, you may want to apply a different layout. The 
title and text boxes inherit the properties of a master slide, but if you have changed 
the position of these text boxes in the master slide, the layout may appear corrupted.
You may need to re-position some of the layout elements manually on a slide.

Selecting and applying backgrounds

Backgrounds can be applied to a number of elements in Impress (for example: slide, default text 
area, image and so on). The procedure is similar when applying a background to a slide or an 
object.
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Figure 9: Slide Setup dialog - Background page

Using slide setup

1) Select View > Master Slide from the Menu bar. This also opens the Master View toolbar 
(Figure3 on page 7).

2) Select a master slide you want to edit in the Slides Pane so that it appears in the 
Workspace (Figure 7 on page 10).

3) Go to Slide > Properties on the Menu bar or right-click in the Workspace and select 
Properties from the context menu to open the Slide Setup dialog (Figure 8).

4) Select the Background tab to open the Background page (Figure 9).

5) Select the type of background required from Color, Gradient, Bitmap, Pattern and Hatch. 
See Chapter 6, Formatting Graphic Objects for more information on how to use the 
options available for each type of background selected.

6) When satisfied with your background, click OK to save your changes and close the Slide 
Setup dialog.

Using background style

1) Select View > Master Slide from the Menu bar. This also opens the Master View toolbar.

2) Select a master slide you want to edit in the Slides Pane so that it appears in the 
Workspace.

3) Click on Styles on the Sidebar to open the Styles deck.

4) Click on Presentation Styles on the Styles deck to open the Presentation Styles list 
(Figure 10).

5) Right-click on Background style and select Modify from the context menu to open the 
Background dialog. This dialog has one tab (Area) and offers the same options as the 
Background page in the Slide Setup dialog (Figure 9).

6) Select the type of background required from Color, Gradient, Bitmap, Pattern and Hatch. 
See Chapter 6, Formatting Graphic Objects for more information on how to use the 
options available for each type of background selected.

7) When satisfied with your background, click OK to save your changes and close the 
Background dialog.
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Figure 10: Styles deck on Sidebar

Tip

You can create custom fills to each type of background. See Chapter 6, Formatting 
Graphic Objects for more information on creating custom fills for each type of 
background.

Adding images

When you want the same image to appear on every slide of your presentation, the easiest and 
quickest solution is to use the master slide. It saves time while creating the presentation allowing 
you to modify or reposition the image on all slides. If the same image is added to each slide 
manually, modification and repositioning have to be performed on each individual slide in the 
presentation. In addition to images, you can add a number of other objects in the background, for
example decorative lines, text, and shapes.

LibreOffice supports a large number of image and graphic formats. For more information on 
working with images, see Chapter 4, Adding and Formatting Pictures, Chapter 5, Managing 
Graphic Objects and Chapter 6, Formatting Graphic Objects.

For example, one of the most common actions in preparing a presentation is to add an image to 
the master slide. To insert an image already available on the computer, follow these steps:

1) Select View > Master Slide from the Menu bar. This also opens the Master View toolbar 
(Figure3 on page 7).

2) Select the master slide where you want to add an image.

3) Select Insert > Image… on the Menu bar to open the file browser.

4) Navigate to the directory where your image is located and select it.

5) Click Open and the image is placed into your master slide and the file browser closes.

6) If necessary, modify and/or reposition the image on your master slide.

7) Right-click on the image and select Arrange > Send to Back from the context menu. This
moves the image to the background so that any information you add to the slide when 
creating a presentation appears over the background image.
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Note

LibreOffice offers the option to insert an image as a link to the file rather than 
embedding it in your presentation. This is only useful when a presentation is not 
intended for distribution onto other computers and it will remain in the same 
computer and directory structure. For example, it could be created on a notebook 
computer, which is then used to give the presentation to a group of clients.

However, if the presentation file is to be distributed onto other computers, the image 
must be embedded to avoid the “missing image” syndrome when the presentation is 
given using a different computer.

Default text areas

When a master slide is opened for editing, it contains five default text areas, as shown in 
Figure 2 on page 7.

• Title area for AutoLayouts

• Object area for AutoLayouts

• Date area

• Footer area

• Slide number area

Position and size

Click with the mouse button on any of these areas to display the selection handles around the 
default text area. Use these selection handles to modify the size and position of a default text 
area.

1) To quickly change the position of a default text area:

a) Select the default text area you want to reposition so that the selection handles are 
visible.

b) Move the cursor toward the border of the default text area, not on a selection handle, 
and the cursor changes shape. The cursor shape is dependent on your computer 
setup (normally a clenched hand).

c) Click the left mouse button and drag the default text are to the desired position, then 
release the left mouse button. 

2) To quickly change the shape and/or size of a default text area:

a) Position the cursor over a left or right selection handle.

b) Click the left mouse button and drag the left or right selection handle to change the 
width of the default text area.

c) Position the cursor over a top or bottom selection handle.

d) Click the mouse button and drag the top or bottom selection handle to change the 
height of the default text area.

e) Position the cursor over a corner selection handle.

f) Click the mouse button and drag the corner selection handle to change both the 
height and width of the default text area at the same time.

g) Release the mouse button when the default text area is the required width or height.
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Note

The shape of the mouse cursor usually changes shape when positioned over a 
selection handle giving a clear visual indication of how it will affect the shape of the 
default text area.

Tip

Keep the Shift key pressed while dragging a selection handle to maintain the ratio 
between the width and height dimensions of the default text area.

Figure 11: Position and Size dialog

To accurately control the shape, size and position of a default text area, it is recommended to use
the Position and Size dialog or the Position and Size section in the Properties deck on the 
Sidebar.

1) Select the default text area by clicking on its border.

2) Use one of the following methods to access the options available for the position and size
of a default text area:

– Go to Format > Object and Shape > Position and Size on the Menu bar to open the
Position and Size dialog (Figure 11).

– Use the keyboard shortcut F4 to open the Position and Size dialog.

– Right-click on the border of the default text area and select Position and Size from 
the context menu to open the Position and Size dialog.

– Click on Properties on the Sidebar and open the Properties deck, then open the 
Position and Size section (Figure 12).

The functions of the Position and Size options are explained fully in the Draw Guide. Only short 
descriptions of the most important functions are provided as follows:

• Use Position to specify the X (horizontal) and Y (vertical) position of the default text 
area. The values represent the distance of the selected base point and the default 
position is the top left corner of the slide.
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Figure 12: Position and Size section in 
Properties on Sidebar

• Use Size to specify the width and height of the default text area.

• In the Position and Size dialog only, the Base point section allows you to select a point on
the rectangular area that you do not want to move while resizing. The default setting of 
top left corner means that the position of the top left corner of the area will not change 
after resizing.

• Use Rotation to rotate the default text area. For example, you can place the footer area 
on the side by rotating each text area by 90 degrees and obtain a more modern-looking 
layout. In general it is preferable to use only right angles for ease of editing, although the 
program does not impose restrictions on the values that can be used.

• Use Slant & Corner Radius page to add a corner radius to a text box border only if a 
visible line style has been selected. The slant options works are only available for images
or shapes.

Background

Change the type of area fill used for backgrounds in a default text area using one of the following
methods. The options available depend on the type of area fill selected. See Chapter 6, 
Formatting Graphic Objects for more information on changing backgrounds.

• Go to Format > Object and Shape > Area on the Menu bar to open the Area dialog 
(Figure 13).

• Right-click on the default text area and select Area from the context menu to open the 
Area dialog.

• Click on Properties on the Sidebar and open the Properties deck, then open the Area 
section (Figure 14).
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Figure 13: Area dialog

Figure 14: Area section in Properties on 
Sidebar

Figure 15: Line dialog
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Figure 16: Line section in Properties deck on 
Sidebar

Border

Change the type of line used for borders in a default text area using one of the following 
methods. The options available in this dialog will depend on the type of line selected. See 
Chapter 6, Formatting Graphic Objects for more information on changing borders.

• Go to Format > Object and Shape > Line on the Menu bar to open the Line dialog 
(Figure 15).

• Right-click on the object and select Line from the context menu to open the Line dialog.

• Click on Properties on the Sidebar and open the Properties deck, then open the Line 
section (Figure 16).

Alignment

Change the alignment of default text area in relation to its position on a master slide or the 
alignment between a default text area and other objects on a master slide using one of the 
following methods. See Chapter 5, Managing Graphic Objects for more information on changing 
alignment of default text areas.

• Go to Format > Align on the Menu bar and select the type of alignment from the options 
available in the context menu.

• Right-click on the object and select Align from the context menu, then select the type of 
alignment from the options available in the context menu.

• Click on the downward triangle ▼ to the right of Align on the Line and Filling toolbar and 
select the type of alignment from the options available.

• Select the required alignment tool in the Position and Size section on the Properties deck
on the Sidebar (Figure 12 on page 16).

Arrangement

Arrange the position of an object on a slide in relation to other objects on a slide using one of the 
following methods. See Chapter 5, Managing Graphic Objects for more information on changing 
position of default text areas in relation to other objects.
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• Go to Format > Arrange on the Menu bar and select the type of arrangement from the 
options available in the context menu.

• Right-click on the object and select Arrange from the context menu, then select the type 
of arrangement from the options available in the context menu.

• Click on the required arrangement tool on the left end of the Line and Filling toolbar.

• Select the required arrangement tool in the Position and Size section on the Properties 
deck on the Sidebar.

Adding text and fields

Adding text and fields to a master slide allows you to place information that you want to appear 
on all the slides in your presentation: for example a presentation title, company name and logo, 
date and slide number. For more information on adding and formatting text and fields, see 
Chapter 3, Adding and Formatting Text.

Text

Text objects can be placed anywhere on the master page so that it appears on every slide in your
presentation. Text objects can also be placed in the footer if you do not want to use the default 
fields in the footer of your presentation.

1) Select View > Master Slide from the Menu bar to open the master slide view. This also 
opens the Master View toolbar (Figure3 on page 7).

2) Select the master slide where you want to add a text object so that it appears in the 
Workspace.

3) Switch on text editing mode using one of the following methods. The Text Formatting 
toolbar (Figure 17) automatically opens replacing the Line and Filling toolbar.

– Select Insert Text Box on the Standard or Drawing toolbar.

– Go to Insert > Text Box on the Menu bar.

– Use the keyboard shortcut F2.

4) Click once on the master slide so that a text box is created and there is a flashing cursor 
inside the text box.

5) Type or paste your text into the text object.

6) Format the text after placing it on your master slide. See Chapter 3, Adding and 
Formatting Text for more information.

7) Click outside the text object to close the Text Formatting toolbar and reopen the Line and 
Filling toolbar.

8) Click Close Master View on the Master View toolbar or go to View > Normal on the 
Menu bar when you have completed adding and formatting text to your master slide.

Default footer sections

By default, the footer used in a slide consists of three sections (Figure 2 on page 7) with each 
section containing a default field as follows:

• Left section – date and time and is labelled Date Area. Field name is <date/time>.

Figure 17: Text Formatting toolbar
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Figure 18: Header and Footer dialog

• Center section – footer text and is labelled Footer Area. Field name is <footer>. This 
section could be used for the presentation title, file name and so on.

• Right section – slide number and is labelled Slide Number Area. Field name is 
<number>.

Header and Footer dialog

The default footer fields are set up as follows using the Header and Footer dialog (Figure 18):

1) Select View > Master Slide from the Menu bar to open the master slide view. This also 
opens the Master View toolbar (Figure3 on page 7).

2) Select the master slide where you want to add a text object so that it appears in the 
Workspace.

3) Select Date and Time for the date and time to appear in the left section of the footer.

– For a fixed date and time in the left footer section, select Fixed and enter the date you
want to use in the Fixed text box.

– For a variable date and time in the left footer section, select Variable, then select the 
format and language you want to use from the Format and Language drop down lists. 
Using a variable date and time means that each time the presentation is opened, the 
date and time are updated.

4) To place text in the footer center section, select Footer and then type or paste your text 
into the Footer text input field.

5) To place the slide number in the right section of the footer, select Slide number.

6) If you do not want the footer to appear on the first slide of your presentation, select Do 
not show on the first slide. The first slide is normally the title slide of your presentation.

7) Click Apply to save your changes and close the Header and Footer dialog.

8) To format the text used for the default footer fields, see Chapter 3 Adding and Formatting 
Text for more information.
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9) Click Close Master View on the Master View toolbar or go to View > Normal on the 
Menu bar when you have completed setting up the default footer fields.

Note

The default sections in a footer can be formatted, resized and repositioned. See 
“Default text areas” on page 14 for more information.

Custom footer sections

The default fields in a footer section can be replaced with text or manual fields as follows:

1) Select View > Master Slide from the Menu bar to open the master slide view. This also 
opens the Master View toolbar (Figure3 on page 7).

2) Highlight the default field in the footer section and press the Delete or Backspace key. A 
flashing text cursor will appear in the footer section and the Text Formatting toolbar 
automatically opens replacing the Line and Filling toolbar.

3) Type in your text or insert a manual field into the footer section. For more information on 
manual fields, see “Manual fields” below.

4) Format the text or manual field placed in the footer section. See Chapter 3, Adding and 
Formatting Text for more information.

5) Click outside the footer section to close the Text Formatting toolbar and reopen the Line 
and Filling toolbar.

6) Click Close Master View on the Master View toolbar or go to View > Normal on the 
Menu bar when you have completed setting up a custom footer section.

Manual fields

Manual fields, for example date or page number (slide number), can be added as text objects on 
a master slide or replace one of the default footer fields. The fields you can use in Impress are:

• Date (fixed)

• Date (variable) – updates automatically when you open the presentation again.

• Time (fixed)

• Time (variable) – updates automatically when you open the presentation again and each 
time you open a slide more than once during a presentation.

• Author – first and last names listed in the LibreOffice user data.

• Slide number

• Slide Title

• Slide Count

• File Name

To place a field on your master slide:

1) Select View > Master Slide from the Menu bar to open the master slide view. This also 
opens the Master View toolbar (Figure3 on page 7).

2) Click anywhere on the master slide.

3) Go to Insert > Field on the Menu bar and select the required field from the context menu.

4) By default the field is placed in the center of the master slide. Reposition the field text box
to the desired position on your master slide. See “Default text areas” on page 14 for more
information.
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5) To format the text used in a field, see Chapter 3 Adding and Formatting Text for more 
information.

6) Click Close Master View on the Master View toolbar or go to View > Normal on the 
Menu bar when you have completed replacing the default footer fields.

To replace a default footer field on your master slide:

1) Select View > Master Slide from the Menu bar to open the master slide view. This also 
opens the Master View toolbar (Figure3 on page 7).

2) Highlight all of the characters used in the default field you want to replace in the footer.

3) Go to Insert > Field on the Menu bar and select the required field from the context menu.

4) To format the text used in a field, see Chapter 3 Adding and Formatting Text for more 
information.

5) Click Close Master View on the Master View toolbar or go to View > Normal on the 
Menu bar when you have completed replacing the default footer fields.

Tip

To change the number format (1, 2, 3 or a, b, c or i, ii, iii, and so on) for the slide 
number, go to Slide > Properties on the Menu bar and select in Layout Settings 
the type of number to use from the Slide numbers: drop down list..

To change the author information, go to Tools > Options > LibreOffice > User Data
on the Menu bar.

Working with styles

A style is a set of formats that you can apply to selected elements such as slides, text, lists, 
frames, borders, lines and area fills in a presentation to quickly set or change their appearance. 
Applying a style means applying a group of formats at the same time providing a consistent look 
to your presentation. For example, to manually change an attribute on the same object type on 
every slide in your presentation is time consuming and prone to errors. Using styles reduces time
and provides greater accuracy.

Impress has two types of styles available for formatting text and graphic objects – presentation 
styles and drawing styles.

• For information on formatting text, see Chapter 3, Adding and Formatting.

• For information on formatting graphic objects, see Chapter 6, Formatting Graphic Objects
and the Draw Guide.

• More information on styles used in LibreOffice can be found in the Getting Started Guide.

Note

The presence of text and title styles both in the presentation and drawing styles may 
seem confusing. This apparent duplication is because Impress uses special text 
boxes (auto layout boxes) when adding structured text to slides where presentation 
styles apply. The title and other text styles in drawing styles are used on any other 
text boxes you may want to add, or text associated with shapes or lines.
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Presentation styles

Presentation styles in Impress are used when creating a presentation using one of the Impress 
slide layouts. These presentation styles are divided into four categories.

• Background and Background objects – are used to format objects on the default 
master slide such as icons, decorative lines, and shapes.

• Notes – formats the text used in presentation notes.

• Outline 1 thru Outline 9 – are used for the different levels of the outline to which they 
belong. For example, Outline 2 is used for the sub-points of Outline 1, Outline 3 is used 
for the sub-points of Outline 2 and so on.

• Subtitle and Title – formats the text used for any titles or subtitles used on slides.

Note

As with the Heading styles in Writer, the Outline styles in Impress are hierarchically 
linked. For example, a change to an attribute in the Outline 1 style will cascade 
through all the other styles for Outline levels.

The default master slide and slide layouts in Impress use auto layout boxes. Presentation styles 
can only be used within these auto layout boxes. An example of text using these presentation 
styles is shown in Figure 2 on page 7.

Note

Any text added to a slide using the text tools available is automatically placed in a 
standard text box and allocated the Default Drawing Style from Drawing Styles. For 
more information on formatting text, see Chapter 3, Adding and Formatting Text.

Presentation styles cannot be created or deleted, but can be formatted, modified or updated to 
your requirements. Also, you cannot change the presentation style used for an object with 
another presentation style. For example, text with Outline 2 style cannot be changed to Outline 3 
style.

Note

Changing outline levels is done in normal view using the Tab key or Shift+Tab key 
combination or the Promote and Demote tools on the Outline toolbar. See Chapter 
3, Adding and Formatting Text for more information.

Drawing styles

Drawing styles in Impress define the characteristics of graphic objects (including text objects) that
you place on a slide. These styles include attributes for line, area, shadowing, transparency, text, 
connectors and dimensioning.

For example, if you need to create organization charts in your presentation, you will probably 
want all of the objects to have a consistent appearance, such as line style, font type, shadow, 
and so on. The easiest way to achieve this result with the minimum effort is to use a drawing 
style for the objects and apply it to each object. The major benefit is that if you decide to change, 
say, the background color of objects, all you need to do is modify the style rather than each 
individual object.

Drawing styles included with Impress cannot be deleted, but you can format, modify and update 
drawing styles. You can also create new or custom styles, see “Custom styles” on page 25. Any 
custom style created is only available in the presentation where it was created.
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Accessing styles

Use one of the following methods to access or modify styles available in Impress:

• Use the keyboard shortcut F11 (Windows and Linux) or +T⌘  (macOS).

• Go to Format > Styles on the Menu bar.

• Click on Show the Styles Sidebar located on the Line and Filling toolbar.

• Click on Styles on the Sidebar to open the Styles deck.

Editing styles

Formatting presentation and drawing styles can be carried out in either Normal or Master Slide 
view. Formatting options are available in dialogs for each style or using Format in the Menu bar. 
For more information on formatting text and objects, see Chapter 3, Adding and Formatting Text 
and Chapter 6, Formatting Graphic Objects.

Dialog formatting

1) Select an object on a slide or master slide and its style is highlighted in the Styles deck on
the Sidebar.

2) Go to Format > Styles > Edit Style on the Menu bar or right-click on the highlighted style
in the Styles deck on the Sidebar to open the formatting dialog for the selected style. An 
example dialog for Outline 1 style is shown in Figure 19.

3) Use the various options available in the tabbed pages of the dialog to format the style.

4) Click OK to save your formatting changes and close the dialog.

Note

Clicking on Reset before clicking OK removes all formatting changes you have made
in the style formatting dialog.

Figure 19: Example dialog for formatting styles
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Format menu

1) Open the Styles deck on the Sidebar. See “Accessing styles” on page 24 for more 
information.

2) Go to Format on the Menu bar to open a drop down menu with various formatting options
available. Depending on the object selected, some formatting options will not be available
and are greyed out.

3) Select a formatting option from the drop down menu. Depending on the option selected, 
another drop down menu may open giving further formatting options or a formatting 
dialog will open.

Modifying

1) Open the Styles deck on the Sidebar. See “Accessing styles” on page 24 for more 
information.

2) Click on Presentation Styles or Drawing Styles at the top left of the Styles deck to open
the list of presentation or drawing styles.

3) Right-click on the style you want to modify and select Modify from the context menu to 
open the formatting dialog for the style selected. An example dialog for Outline 1 style is 
shown in Figure 19.

4) Make the necessary changes to the selected presentation or drawing style using the 
various options available in the dialog that has opened.

5) Click OK to save your changes and close the dialog.

Updating

Updating a presentation or drawing style is similar to modifying, but you make format changes to 
the text or object first. Updating styles can only be carried out in Normal view.

1) Select the text or object on your slide in Normal view.

2) Use the various tools on the Text Formatting toolbar, Line and Filling toolbar, or the 
options in Format on the Menu bar to format the selected object.

3) Open the Styles deck on the Sidebar. See “Accessing styles” on page 24 for more 
information.

4) Click on Presentation Styles or Drawing Styles at the top left of the Styles deck to open
the list of styles. The style used for the selected object will be highlighted.

5) Click on Update Style at the top right of the Styles deck and the style is updated to 
include the formatting changes you have made to the selected object.

Custom styles

You cannot create custom presentation styles in Impress, but you can create custom drawing 
styles. These custom drawing styles are only available for the presentation that you are creating.

1) Create or select the object on your slide you want to use for creating a new drawing style.

2) Format the object to your requirements using the various formatting options available in 
the Text Formatting toolbar, Line and Filling toolbar, or the options in Format on the Menu
bar.

3) Open the Styles deck on the Sidebar. See “Accessing styles” on page 24 for more 
information.

4) Click on Drawing Styles at the top left of the Styles deck to open the list of drawing 
styles.
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Figure 20: Create Style dialog

5) Click on New Style from Selection at the top right of the Styles deck and the Create 
Style dialog opens (Figure 20).

6) Enter a name for your custom style in the Style Name text box.

7) Click OK to close the Create Style dialog. The custom style is created and appears in the 
drawing styles list in the Styles deck on the Sidebar.

Direct formatting

Direct formatting overrides any formatting applied to an object when a style is used. You cannot 
remove direct formatting from an object by applying a style to it. To remove any direct formatting, 
select the object so that the selection handles are visible, then use one of the following methods 
to clear any direct formatting:

• Use the keyboard shortcut Ctrl+Shift+M.

• Go to Format > Clear Direct Formatting in the Menu bar.

• If the object is a text object, highlight all of the text and then click on Clear Direct 
Formatting on the Text Formatting toolbar.

• If the object is a text object, highlight all of the text, right-click on the selected text and 
select Clear Direct Formatting from the context menu.

Linked styles

Impress styles support inheritance which allows a style to be linked to another (parent) style so 
that it inherits all the formatting settings of the parent. This inheritance creates families of styles.

For example, if you require multiple boxes that differ in color, but are otherwise identically 
formatted, the best way to proceed is to define a style for the box including borders, area fill, font,
and so on and a number of styles that are hierarchically dependent which differ only in the fill 
color attribute. If you need to change the font size or the thickness of the border, you only have to
change the parent style and all the other styles will change accordingly.
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Assigning styles keyboard shortcuts

LibreOffice provides a set of predefined keyboard shortcuts which allow you to quickly apply 
styles while working with a document. You can redefine these shortcuts or define your own, as 
described in Appendix A, Keyboard Shortcuts.

Working with templates

A template is a special type of presentation that you use as a basis to create your presentations. 
For example, you can create a template for business presentations so that any new 
presentations has your company logo, name and information on the first slide and the remaining 
slides in your presentation only show the company logo and name.

Templates can contain anything that presentations can contain, such as text, graphics, a set of 
styles, and user-specific setup information such as measurement units, language, the default 
printer, and toolbar and menu customization.

All document types created using LibreOffice are based on templates. You can create a specific 
template for any document type (text, spreadsheet, drawing, presentation). If you do not specify 
a template when you start a new document, then the default template for that type of document is
used. If you have not specified a default template, LibreOffice uses the blank template for that 
type of document that is installed with LibreOffice. This default template can be changed, see 
“Setting default template” on page 29 for more information.

However, Impress is a little different from other LibreOffice components, in that it starts with the 
Select a Template dialog (Figure 21), unless you have decided to turn off this dialog in LibreOffice
options. When you create a presentation, if the template dialog is active, it opens offering several
choices for templates as a starting point for your presentation.

If you have turned off the Select a Template dialog when creating a new presentation, LibreOffice
uses the LibreOffice default template for presentations. If you have defined your own default 
template, LibreOffice uses your default template when you create a presentation.

For more information on templates and how to use them, see the Getting Started Guide.

Figure 21: Select a Template dialog
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Templates supplied with LibreOffice

Impress comes with a set of predefined templates. These templates only contain backgrounds 
and background objects providing you with a starting point to create your own presentations or 
presentation templates.

Any templates that you create will be located in the My Templates folder after you have saved 
your presentation as a template. Your templates will appear in the LibreOffice startup window and
the Select a Template dialog the next time you start LibreOffice.

Use one of the following methods to create a new presentation using a template:

• Click on the small down arrow▼ on the right of Templates in LibreOffice start up window 
and then select Impress Templates from the context menu to display the available 
presentation templates. Select a template and a new presentation opens.

• Go to File > New > Templates on the Menu bar to open the Templates dialog (this dialog
is similar to the Select a Template dialog in Figure 21). Select Presentations from the 
Filter drop down list to display presentation templates. Select a presentation template 
and click OK. The dialog closes and a new presentation opens.

• Use the keyboard shortcut Shift+Ctrl+N to open the Templates dialog (this dialog is similar
to the Select a Template dialog in Figure 21). Select Presentations from the Filter drop 
down list to display presentation templates. Select a presentation template and click OK. 
The dialog closes and a new presentation opens.

Creating templates

Create a template and save it to a template folder as follows:

1) Open the presentation that you want to use for a template, or open a template that you 
want to use as a basis for your template.

2) Add and format content and styles to your presentation.

3) Go to File > Templates > Save As Template on the Menu bar to open the Save as 
Template dialog (Figure 22).

4) Enter a name for the new template in the Template Name text box.

Figure 22: Save As Template 
dialog

28 | Chapter 2, Master Slides, Styles, and Templates



5) Select a destination folder for the new template.

6) If required, select the option Set as default template to use as the default template the 
next time you open LibreOffice and do not select a template. See “Setting default 
template” on page 29 for more information on default templates.

7) Click on Save to save your template and close the Save as Template dialog. Your 
templates will appear in the LibreOffice startup window and the Select a Template dialog 
the next time you start LibreOffice.

Setting default template

If you create a new presentation and do not select a template, LibreOffice creates the 
presentation from the default Impress template. This is normally a blank template. However, you 
can set any presentation template to be the default template, even a template that you have 
created. The template has to be located in a folder displayed in the Save as Template dialog so 
that LibreOffice can find it. You can always reset to the default template back to the LibreOffice 
default template later if you choose.

Changing default template

1) Use one of the following methods to open the Select a Template dialog (Figure 21 on 
page 27):

– Go to File > New > Templates on the Menu bar.

– Go to File > Templates > Manage Templates on the Menu bar.

2) Select the template you want to use as the default LibreOffice presentation template.

3) Right click on the selected template and select Set as Default from the context menu.

4) Click on Open and a new presentation opens using the new default template and sets the
default presentation template in LibreOffice. The next time that you create a new 
presentation and do not select a template, the presentation will be created using the new 
default presentation template.

Resetting default template

To reset the default presentation template back to the original LibreOffice default template for 
presentations:

1) Use one of the following methods to open the Select a Template dialog (Figure 21 on 
page 27):

– Go to File > New > Templates on the Menu bar.

– Go to File > Templates > Manage Templates on the Menu bar.

2) Click on Settings and select Reset Default Template > Presentation from the context 
menu. The next time that you create a new presentation and do not select a template, the
presentation will be created using the default LibreOffice template for presentations.

Editing templates

You can edit template styles and content and reapply the template styles to presentations that 
were created from that template.

1) Use one of the following methods to open the Select a Template dialog (Figure 21 on 
page 27):

– Go to File > New > Templates on the Menu bar.

– Go to File > Templates > Manage Templates on the Menu bar.
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– Click on the small down arrow▼ on the right of Templates in LibreOffice start up 
window and select Impress Templates from the context menu.

2) Right click on the template you want to edit and select Edit from the context menu and 
the template will open in Impress.

3) Carry out your editing updates of any styles, text and/or objects on the selected template.

4) Go to File > Save on the Menu bar or use the keyboard shortcut Ctrl+S to save your 
changes.

5) Close the template or create a presentation using the edited template.

Note

Any presentation created from the template before editing can be updated to show 
the changed template settings the next time you open the presentation after template
editing. A confirmation dialog opens asking if you want to use the updated styles or 
keep the old styles. If select to the keep the old styles, then the presentation will 
continue to use the old styles without any confirmation.

Organizing templates

LibreOffice can only use templates that are in LibreOffice template folders (categories). You can 
create new LibreOffice template folders or categories and use them to organize your templates. 
For example, separate template categories for different projects or clients. You can also import 
and export templates.

Tip

The location of LibreOffice template folders varies with your computer operating 
system. To learn where the template folders are stored on your computer, go to 
Tools > Options > LibreOffice > Paths.

Creating template categories

1) Use one of the following methods to open the Select a Template dialog (Figure 21 on 
page 27):

– Go to File > New > Templates on the Menu bar.

– Go to File > Templates > Manage Templates on the Menu bar.

2) Right click on Settings and select New Category from the context menu.

3) Enter a category name in Enter category name text box that has opened (Figure 23).

4) Click OK to save your new category and the category will appear in the drop down list for 
categories filter at the top of the Select a Template dialog.

Figure 23: Creating new category
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Deleting template categories

You cannot delete the template categories supplied with LibreOffice or installed using the 
Extension Manager. You can only delete categories that you have created.

1) Use one of the following methods to open the Select a Template dialog (Figure 21 on 
page 27):

– Go to File > New > Templates on the Menu bar.

– Go to File > Templates > Manage Templates on the Menu bar.

2) Right click on Settings and select Delete Category from the context menu to open the 
Delete Category dialog (Figure 24).

3) Select the category you want to delete.

4) Click OK to delete the category and confirm the deletion.

Figure 24: Delete Category dialog

Figure 25: Select Category dialog
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Moving templates

To move a template from one category to another category:

1) Use one of the following methods to open the Select a Template dialog (Figure 21 on 
page 27):

– Go to File > New > Templates on the Menu bar.

– Go to File > Templates > Manage Templates on the Menu bar.

2) Select the template you want to move and click on Move.

3) Select a category from the dis[played list or select Create a New Category in the Select 
Category dialog (Figure 25).

4) Click OK to move the template to its new category and close the Select Category dialog.

Deleting templates

You cannot delete the templates supplied with LibreOffice or installed using the Extension 
Manager. You can only delete templates that you have created or imported.

1) Use one of the following methods to open the Select a Template dialog (Figure 21 on 
page 27):

– Go to File > New > Templates on the Menu bar.

– Go to File > Templates > Manage Templates on the Menu bar.

2) Right click on the template you want to delete and select Delete from the context menu.

3) Click on Yes to confirm the deletion.

Importing templates

If the template that you want to use is in a different location on your computer, you must import it 
into a LibreOffice template folder for LibreOffice to recognize the template.

1) Use one of the following methods to open the Select a Template dialog (Figure 21 on 
page 27):

– Go to File > New > Templates on the Menu bar.

– Go to File > Templates > Manage Templates on the Menu bar.

2) Click Import and the Select Category dialog (Figure 25) opens.

3) Select a category from the dis[played list or select Create a New Category in the Select 
Category dialog.

4) In the file browser window that opens, navigate to the folder where your template is 
located on your computer that you want to import.

5) Select the template and click Open. The file browser window closes and the template 
appears in the selected category.

Exporting templates

1) Use one of the following methods to open the Select a Template dialog (Figure 21 on 
page 27):

– Go to File > New > Templates on the Menu bar.

– Go to File > Templates > Manage Templates on the Menu bar.

2) Select the template you want to export, then click on Export to open a file browser 
window.

3) Navigate to the folder where you want to export the template and click on Select. The 
template is exported and the file browser window closes.
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