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OLE objects

Object Linking and Embedding (OLE) is a software technology that allows linking and embedding
of the following types of files into an Impress presentation.

* LibreOffice spreadsheets
* LibreOffice charts

* LibreOffice drawings

* LibreOffice formulas

* LibreOffice text

The major benefit of using OLE objects is that it provides a quick and easy method of editing the
object using tools from the software used to create the object. These file types can all be created
using LibreOffice and OLE objects can be created from new or from an existing file.

Inserting new OLE objects

When you insert a new OLE object into your presentation, it is only available in your presentation
and can only be edited using Impress.

1) Select the slide where you want to insert an OLE object.

2) Go to Insert > Object > OLE Object on the Menu bar to open the Insert OLE Object
dialog (Figure 1).

3) Select Create new and then select the type of OLE object you want to create.

4) Click OK and a new OLE object is inserted in the center of the slide in edit mode. The

toolbars displayed change providing the necessary tools for you to create a new OLE
object.

Note

For computers operating Windows, an additional option of Further objects is
available in the Object Type list. Clicking on Further objects opens an Insert Object
dialog (Figure 2) allowing you to create an OLE object using other software that is
compatible with OLE and LibreOffice. This option is available for new OLE objects
and OLE objects from a file.

Insert OLE Object X

© Create new Create from file

Object Type
LibreOffice 7.0 Spreadsheet
LibreOffice 7.0 Drawing
LibreOffice 7.0 Formula

LibreOFfice 7.0 Chart

LibreOFfice 7.0 Text

Help Cancel OK

Figure 1: Insert OLE Object dialog
for new objects
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Object Type: oK |
(+ Create New CpenCifice org 1.1 Drawing - | [

CpenCifice org 1.1 Formula Cancel
'S OpenOffice .org 1.1 Presentation

Create from File OpenCifice org 1.1 Spreadshest
OpenOffice.org 1.1 Text Document
Package

Paintbrush Picture

Wordpad Document W

[ Display As lcon

Result
Inserts a new OpenDocument Drawing object

into your document .
)

Figure 2: Insert Object dialog for Windows OS

Insert OLE Object X

Create new @ Create from file

File

Link ko file Search...

Display as icon

Help Cancel oK

Figure 3: Insert OLE Object dialog
from file

Inserting OLE objects from files
To insert a file into your presentation as an OLE object:
1) Select the slide where you want to insert an OLE object.

2) Go to Insert > Object > OLE Object on the Menu bar to open the Insert OLE Object
dialog (Figure 1).

3) Select Create from file and the dialog changes to a file search dialog (Figure 3).
4) Click on Search and a file open dialog is displayed.
5) Locate the file required and click Open. The filename appears in the File text box.

6) Insert the OLE object using one of the following methods to insert the OLE object in the
center of the slide in edit mode:
— Click OK to insert the file as an OLE object.
— Select Link to file, then click OK to insert the OLE object with a link to the original file.

— Select Display as icon, then click OK to insert the OLE object as an icon. When the
icon is clicked on, the OLE object opens in a new window.
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Note

When inserting an existing file into a slide as an OLE object, by default, any changes
made to the original file after insertion do not affect the copy of the file inserted into a
presentation. Also, changes to the file copy in a presentation do not change the
original file. If you want any changes made to the file, either in the original or in your
presentation, to appear in both versions you have to link the original file with your
presentation when it is inserted.

Editing OLE objects

To edit an OLE object after it has been created or inserted from a file:

1) Double-click on the OLE object to open it in edit mode. The toolbars in Impress will
change to provide the tools necessary to edit the OLE object.

2) When finished editing the OLE object, click anywhere outside the OLE object to cancel
editing.

3) Save the presentation. Any changes made to the OLE object are also saved.

Resizing and moving OLE objects

Resizing and moving OLE objects is exactly the same as resizing and moving graphic objects in
Impress. For more information, see Chapter 5, Managing Graphic Objects.

Note

When resizing or moving a spreadsheet on slides, ignore any horizontal and vertical
scroll bars, and the first row and first column. The the first row and first column are
easily recognizable because of their light background color. They are only used for
spreadsheet editing purposes and will not be included in the spreadsheet that
appears as an OLE object on the slide.

Note

Do not double click on a spreadsheet OLE object when editing. Double clicking
opens the OLE object editing mode for spreadsheets.

Spreadsheets

To include a spreadsheet in an Impress slide, you can either insert an existing spreadsheet file or
insert a new spreadsheet as an OLE object (see “OLE objects” on page 5 for more information).
For more information on spreadsheets, see the Calc Guide and the Getting Started Guide.

Embedding a spreadsheet into Impress includes most of the functionality of a Calc spreadsheet.
Impress is capable of using Calc functions to carry out calculations and data analysis. However, if
you plan to use complex data or formulas, it is recommended to perform those operations in a
separate Calc spreadsheet first, then embed into Impress the spreadsheet with the results.

You may be tempted to use spreadsheets in Impress for creating tables or presenting data in a
tabular format. However, inserting a table into Impress is often more suitable and faster,
depending on the complexity of your data. See Chapter 3, Adding and Formatting Text for more
information on inserting and formatting tables.
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Note

The entire spreadsheet is inserted into a slide as an OLE object. If the spreadsheet
contains more than one sheet and the one required is not visible, double-click the
spreadsheet and then select a different sheet from the sheet tab row at the bottom.
See “Editing OLE objects” on page 7 for more information on editing a spreadsheet
as an OLE object.
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Figure 4: Example OLE spreadsheet in editing mode
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Editing spreadsheets

When a spreadsheet is inserted into a slide, it is in edit mode ready for inserting or modifying
data or modifying the format (Figure 4). The following also happens to provide and functions for
spreadsheets:

* Calc formula toolbar replaces the Line and Filling bar as shown in Figure 4

* The Formatting toolbar (Figure 5) for spreadsheets opens providing tools required for
basic formatting of a spreadsheet.

* The Menu bar changes to provide spreadsheet formatting options.
The Calc formula bar contains the following from left to right:
* Active cell reference or the name of a selected range of cells.
* Function Wizard tool.
* Select Function tool.
*  Formula tool.
* An edit box to enter or review the displayed contents of the active cell. Click on the small
triangle v to the right of the edit box to expand, if necessary, the edit box.

Cell navigation

By default, when an embedded spreadsheet is opened, the active cell is AL. To move around the
spreadsheet to select a cell to make it active, you can use one of the following methods:

* Keyboard arrow keys.
» Position the cursor in a cell and click.
* Enter key to move one cell down and Shift+Enter key combination to move one cell up.

* Tab key to move one cell to the right and Shift+Tab key combination to move one cell to
the left.
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Note

Other keyboard shortcuts are available to navigate around a spreadsheet. Refer to
Getting Started Guide for more information.

Entering data

Data input into a cell can only be done when a cell is active. An active cell is easily identified by a
thickened and bolder border. The cell reference or coordinates for the active cell is displayed at
the left hand end of the Calc editing toolbar.

1) Select the cell to make it active and start typing. The data input is also displayed in the
edit box on the Calc formula toolbar making the data entry easier to read.

2) Use the various tools and options on the Menu bar to enter data, formula, function, text,
or date into a cell.

3) To confirm data input into a cell select a different cell with the cursor, or use the Enter key,
Shift+Enter key combination, Tab key, or Shift+Tab key combination.

ﬂTip

Sometimes it is useful to treat numbers as text (for example, telephone numbers)
and to prevent Impress from removing the leading zeros or right align them in a cell.
To force Impress to treat numbers as text, type a single quotation mark (') before
entering the number.

Merging cells
1) Highlight the required number of cells to be merged.

2) Merge the highlighted cells using one of the following methods to open the Merge Cells
dialog (Figure 6).
— Go to Format > Merge Cells > Merge and Center Cells on the Menu bar.
— Go to Format > Merge Cells > Merge Cells on the Menu bar.
— Right-click on the selected cells and select Merge Cells from the context menu.
3) Select an option, click OK to merge the cells and close the Merge Cells dialog.

Splitting cells
Only multiple cells that have been merged can be split into separate cells.

1) Select a cell that was merged from multiple cells.

Merge Cells x

some cells are not empty.

Move the contents of the hidden cells into the First cell

[(1[2]—[1 2]
© Keep the contents of the hidden cells
(112 |—[1 2]
Empty the contents of the hidden cells
(12 ]—[1 %]
Help Cancel OK

Figure 6: Merge Cells dialog
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2) Split the merged cell into separate cells using one of the following methods:

— Go to Format > Merge Cells > Split Cells on the Menu bar.
— Right-click on the cell and select Split Cells from the context menu.

Inserting cells, rows, or columns

1) Select the same number of cells, rows, or columns on the embedded spreadsheet that
you want to insert.

2) Insert cells using one of the following methods:
— Go to Sheet > Insert Cells on the Menu bar.

— Right-click on the selected cells and select Insert... from the context menu.

Inserting cells opens the Insert Cells dialog (Figure 7). Select an insert option, then click
OK to insert the cells and close the dialog.

3) Insert rows using one of the following methods:

— Go to Sheet > Insert Rows > Rows Above or Sheet > Insert Rows > Rows Below
on the Menu bar.

— Right-click on the selected rows and select Insert Rows Above or Insert Rows
Below from the context menu.

4) Insert columns using one of the following methods:

— Go to Sheet > Insert Columns > Columns Before or Sheet > Insert Columns >
Columns After on the Menu bar.

— Right-click on the selected rows and select Insert Columns Before or Insert
Columns After from the context menu.

Selection
Q shift cells down

Shift cells right
Entire row

Entire column

Help Cancel oK

Figure 7: Insert Cells dialog

Selection
© shift cells up

shift cells left
Delete entire row(s)

Delete entire column(s)

Help Cancel oK

Figure 8: Delete Cells dialog

10 | Chapter 7, Spreadsheets, Charts, and Other Objects



Deleting cells, rows, or columns

1) Select the same number of cells, rows, or columns on the embedded spreadsheet that
you want to delete.

2) Delete cells using one of the following methods:
— Go to Sheet > Delete Cells on the Menu bar.

— Right-click on the selected cells and select Delete... from the context menu.

Deleting cells opens the Delete Cells dialog (Figure 8). Select a delete option, then click
OK to delete the cells and close the dialog.

3) Delete rows using one of the following methods:
— Go to Sheet > Delete Rows on the Menu bar.

— Right-click on the selected rows and select Delete... from the context menu.
4) Delete columns using one of the following methods:

— Go to Sheet > Delete Columns on the Menu bar.
— Right-click on the selected rows and select Delete Columns from the context menu.

Inserting sheets
1) Double-click on the embedded spreadsheet to open in edit mode.

2) Insert a sheet using one of the following methods:

— Click on the plus sign to the left of the sheet names.

— Right-click on the sheet names and select Insert > Sheet from the context menu and
the Insert Sheet dialog (Figure 9) opens.

— Go to Sheet > Insert Sheet on the Menu bar to open the Insert Sheet dialog.

3) When finished editing the embedded spreadsheet, click anywhere outside the border to
cancel edit mode and save the changes.

Note

If there are multiple sheets in an embedded spreadsheet, only the active sheet is
shown on the slide after exiting edit mode.

Position

© Before current sheet

After currenkt sheet

Sheet
© New sheet
No. of sheets: | 1 +
Name: Sheet3
From file

Figure 9: Insert Sheet dialog
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Insert Sheet dialog
1) Open the Insert Sheet dialog.

2) Select Position for the new sheet in the spreadsheet — Before current sheet or After
current sheet.

3) Insert a new sheet as follows:
a) Select New sheet.
b) Select No. of sheets to be inserted in the text box.

c) Inthe Name text box, enter a name for the new sheet. This option is not available if
inserting multiple sheets.

4) Insert a sheet from a file as follows:
a) Select From file.
b) Click on Browse to open an Insert dialog and navigate to the file location.
c) If necessary click on Link to create a link to the original file.

d) Select the file and click on Open and the sheet names in the file appear in the
preview box.

e) Select the sheet you want to insert.

5) Click OK to close the dialog and insert the sheet into the embedded spreadsheet.

6) When finished editing an embedded spreadsheet, click anywhere outside the border to
cancel edit mode and save the changes.

Renaming sheets
1) Double-click on the embedded spreadsheet to open in edit mode.

2) Select the sheet you want to rename.

3) Right-click on the sheet tab and select Rename Sheet from the context menu, or go to
Sheet > Rename Sheet on the Menu bar to open the Rename Sheet dialog (Figure 10).

4) Enter a new name for the sheet in the Name text box.
5) Click OK to save the name change and close the dialog.

6) When finished editing the embedded spreadsheet, click anywhere outside the border to
cancel edit mode and save the changes.

Moving or copying sheets
1) Double-click on the embedded spreadsheet to open in edit mode.

2) Select the sheet you want to move or copy.

Rename Sheet x

MName

Sheet1
Help Cancel OK

Figure 10: Rename Sheet dialog
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3)

4)

5)

6)

Move/Copy Sheet X

Action
© Move Copy

Location
To document

Untitled 1 (current document) -

Insert before

Sheet2
-move to end position -

New name

Sheet1
Help Cancel oK

Figure 11: Move/Copy Sheet dialog

Right-click on the sheet tab and select Move or Copy Sheet from the context menu, or
go to Sheet > Move or Copy Sheet on the Menu bar to open the Move/Copy Sheet
dialog (Figure 11).

Move or copy a sheet to another position within the OLE spreadsheet in the same
presentation is as follows:

a) Select the option Move or Copy in Action.

b) Select the Location in the To document drop down list. In Impress, the presentation
is named Untitled 1 (current document).

c) Select the position within the spreadsheet from the available list in Insert before.
d) If necessary, enter a new name for the sheet in the New name text box.

e) Click OK to move or copy the sheet and close the dialog.

Move or copy a sheet to another document containing a spreadsheet is as follows:
a) Make sure the spreadsheet in the target document is selected.

b) Select the option Move or Copy in Action.

c) Select the Location in the To document drop down list. In Impress, the document is
named Untitled 1 (current document). If the document is a Calc spreadsheet, the
filename of the Calc spreadsheet is displayed.

d) Select the position within the spreadsheet from the available list in Insert before.
e) If necessary, enter a new name for the sheet in the New name text box.

f) Click OK to move or copy the sheet and close the dialog.

To move the sheet with a mouse within the embedded spreadsheet, click on the sheet tab
and drag it to a new paosition.
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7) When finished editing the embedded spreadsheet, click anywhere outside the border to

cancel edit mode and save the changes.

Deleting sheets

1)
2)
3)

4)
5)

Double-click on the embedded spreadsheet to open in edit mode.
Select the sheet you want to delete.

Right-click on the sheet tab and select Delete Sheet from the context menu, or go to
Sheet > Delete Sheet on the Menu bar.

Click Yes to confirm the deletion of the sheet.

When finished editing the embedded spreadsheet, click anywhere outside the border to
cancel edit mode and save the changes.

Formatting spreadsheets

For presentation purposes, it may be necessary to change the formatting of a spreadsheet to
match the style used in the presentation.

When working on an embedded spreadsheet, you can also access any styles created in Calc
and use them. However, if you are going to use styles, it is recommended to create specific
styles for embedded spreadsheets, as Calc styles maybe unsuitable when working in Impress.

Cell data formatting

1)

2)

3)

4)
5)

Select a cell or a range of cells in an embedded spreadsheet using one of the following
methods:
— Click in a cell to select it.

— To select the whole sheet, click on the blank cell at the top left corner between the row
and column headers.

— To select the whole sheet, use the keyboard shortcut Ctri+A.

— To select a column, click on the column header at the top of the spreadsheet.

— To select a row, click on the row header on the left hand side of the spreadsheet.
Open the Format Cells dialog (Figure 12) using one of the following methods:

— Right-click on a cell and select Format Cells from the context menu.

— Go to Format > Cells on the Menu bar.

— Use the keyboard shortcut Ctri+1.

Use the various pages in the Format Cells dialog to the cell data so that it matches the
style of your presentation.

Click OK to close the Format Cells dialog and save your changes.

When you are satisfied with the formatting changes, click outside the spreadsheet area to
save your changes and cancel editing mode.

Row formatting

1)
2)

Select a row by clicking in the row header.
Adjust the row height using one of the following methods:

— Right click in the row header and select Row Height from the context menu and set
the row height in the Height text in the Row Height dialog that opens.

— Right click in the row header and select Row Height from the context menu and
select the Default value for row height in the Row Height dialog that opens.
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Format Cells *

Numbers

Category Format Language
Al Default - English (UK) -
User-defined -1235
Percent -1,235
currency -1,234.57
Date -1,234.57
Time (1,235)
Scientific (1,234.57)
Fraction
Boolean Value
Text
-1234.56789012346

Options

Decimal places: + MNegative numbers red

Leading zeroes: | 1 — |+ Thousands separator

Format code

General

Help Reset Cancel OK

Figure 12: Format Cells dialog

Right click in the row header and select Optimal Height from the context menu. Enter
an optimal height in the Add text box or select the Default value in the Optimal Row
Height dialog that opens. The optimal row height depends on the font size of the
largest character in a row.

Hover the cursor over the bottom border in the row header until it changes shape,
then click and drag the border to increase or decrease the row height.

3) When you are satisfied with the formatting changes, click outside the spreadsheet area to
save your changes and cancel editing mode.

Column formatting
1) Select a column by clicking in the column header.

2) Adjust the column width using one of the following methods:

Right click in the column header and select Column Width from the context menu
and set the column width in the Width text box in the Column Width dialog that opens.
Right click in the column header and select Column Width from the context menu
and select the Default value for column width in the Column Width dialog that opens.
Right click in the column header and select Optimal Width from the context menu.
Enter an optimal width in the Add text box or select the Default value in the Optimal
Column Width dialog that opens. The optimal column width depends on the longest
entry within a column.

Hover the cursor over the left or right border in the column header until it changes
shape, then click and drag the border to increase or decrease the column width.

3) When you are satisfied with the formatting changes, click outside the spreadsheet area to
save your changes and cancel editing mode.
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Using formatting styles

! Styles X

=y ® A A
Default %’»’

Accent =
Heading @

T
Status

Text

Figure 13: Calc Styles deck in
Sidebar

When using styles in an embedded spreadsheet and the spreadsheet is in edit mode, Impress
displays the available styles for a spreadsheet in the Styles deck on the Sidebar (Figure 13).
Styles used in an embedded spreadsheet are similar to paragraph styles used in LibreOffice

Writer.

1) Select the data in a cell or cells in the embedded spreadsheet.
2) Click on Styles to open the Styles deck in the Sidebar.

3) Double-click on a style to apply that style to the cell data.

4) When you are satisfied with the formatting changes, click outside the spreadsheet area to
save your changes and cancel editing mode.

Charts

A chart is a graphical interpretation of information that is contained in a spreadsheet. More
information about charts and the use of charts, see the Calc Guide.

Inserting charts

1) Select the slide where you want to insert a chart.

2) Use one of the following methods to insert a chart:

— Go to Insert > Object > OLE Object on the Menu bar to insert a chart as an OLE
object. See “OLE objects” on page 5 for more information on inserting a chart as an

OLE object.

— Go to Insert > Chart on the Menu bar and an example chart is inserted in the center
of the slide in editing mode (Figure 14).
— Click on Chart on the Standard toolbar and an example chart is inserted in the center
of the slide in editing mode.
3) If necessary, click outside the chart area to cancel editing mode.
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Q Note

When a chart is in editing mode, the Formatting toolbar (Figure 15) for charts
automatically opens replacing the Line and Filling and Standard toolbars.

-
=)

12

B Column 1
HColumn2 ™
Column 3
Flgure 14: Example chart in editing mode
Formatting v
Chart Area > | B ok R B Wl [ B JL i jo e

Figure 15: Chart Formatting toolbar

Il column |

= Bar = ] - {
Pie = | = -— )

&l Area

12 Line Normal

L£ XY (Scatter) 3DLook | | Realistic -

| Bubble

B Net Shape

i stock

lii columnand Line Cylinder
Cone

Pyramid

Help Cancel OK
Figure 16: Chart Type dialog

Selecting chart type

Your data can be presented using a variety of different charts. Impress contains several
examples of chart types that will help you convey your message to your audience. You can select
a chart type using the Chart Type dialog (Figure 16) or the Chart Type section in the Properties
deck on the Sidebar (Figure 17).
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Figure 17: Chart Type section in
Properties on Sidebar
Chart Type dialog

1) Make sure the chart is selected and is in editing mode. The chart has a border and
selection handles when in editing mode.

2) Open the Chart Type dialog using one of the following methods:

— Click Chart Type on the Formatting toolbar.
— Go to Format > Chart Type on the Menu bar.
— Right-click on the chart and select Chart Type from the context menu.

3) Select a chart type from the left-hand preview box and the chart examples on the right
change. Also, the available options for chart types change to match the chart type.

4) Select a chart example from the right-hand preview box.
5) Select the options required for the chart type selected.
6) Click OK to close the Chart Type dialog and return to the edit window.

7) Continue to format the chart, add data to the chart, or click outside the chart to return to
normal view.

Sidebar Chart Type

1) Make sure the chart is selected and is in editing mode. The chart has a border and
selection handles when in editing mode.

2) Click on Properties on the Sidebar to open the Properties deck.
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3)
4)
5)
6)

7)

Click on the downward pointing arrow V on the left of title bar for the Chart Type section.
Select the chart type from the drop down list.
Select a chart example from the preview box.

Select the chart elements required for the chart type from the Elements section on the
Sidebar.

Continue to format the chart, add data to the chart, or click outside the chart to return to
normal view.

Chart types

The following summary of available chart types will help you to choose a type suitable for the
data being used to create the chart. Column, bar, pie and area charts are available as 2D or 3D
types. For more information on charts, see the Calc Guide.

Column — displays data that shows trends over time. This chart is the default chart type
used when a chart is inserted into a slide. It is recommended to use column charts where
there is a relatively small number of data points. If there is a large time series as data, it
is recommended to use a line chart.

Bar — give an immediate visual impact for data comparison where time is not important,
for example comparing the popularity of products in a marketplace.

Pie — give a comparison of proportions. For example, when comparing what different
departments spent on different items or what different departments actually spent overall.
They work best with a small range of values, for example six or less. Using larger range
of values, the visual impact of a pie chart begins to fade.

Area — are versions of line or column charts. They are useful when emphasis of volume
change is required. Area charts have a greater visual impact than a line chart, but the
type of data used does make a difference to the visual impact.

Line — are time series with progression. Ideal for raw data and useful for charts with data
showing trends or changes over time where an emphasis in continuity is required. On
line charts, the X-axis is ideal for representing time series data. 3D lines confuse the
viewer, so just using a thicker line gives a better visual impact.

XY (Scatter) — are great for visualizing data that have not been analyzed fully and may
be best for data where have a constant value for comparison. For example weather data,
reactions under different acidity levels, conditions at altitude, or any data which matches
two numeric series. The X-axis usually plots the independent variable or control
parameter (often a time series).

Bubble — are used to represent three variables. Two variables identify the position of the
center of a bubble on a Cartesian graph, while the third variable indicates the radius of
the bubble.

Net — are similar to polar or radar graphs and are useful for comparing data not in time
series, but show different circumstances, such as variables in a scientific experiment.
The poles of the net chart are the Y-axes of other charts. Generally, between three and
eight axes are best; any more and this type of chart becomes confusing.

Stock — are specialized column graphs specifically used for stocks and shares. choose
traditional lines, candlestick, and two-column charts. The data required for these charts is
specialized with a series for opening price, closing price, and high and low prices. The X-
axis represents a time series.
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Data Table X

B B H B £E)
k! column1 [l  column2 i)l Column3
Categories | Y-Values | Y-Values | Y-Values
1 |Row1 9.1 3.2 454
2 |Row2 2.4 8.8 9.65
3 |Row3 3.1 1.5 3.7
4 |Row 4 4.3 9.02 6.2

Figure 18: Data Table dialog

Column and line — are a combination of two other chart types. It is useful for combining
two distinct, but related data series, for example sales over time (column) and the profit
margin trends (line).

Entering chart data

1)

2)

3)
4)

5)
6)

Make sure the chart is selected and is in editing mode. The chart has a border and
selection handles when in editing mode.

Open the Data Table dialog (Figure 18) using one of the following methods:

— Click on Data Table on the Formatting toolbar for charts.

— Go to View > Data Table on the Menu bar.

— Right-click on the chart and select Data Table from the context menu..
Type or paste information into the cells to enter data into the Data Table dialog.

Use the tools in the top left corner of the Data Table dialog to insert, delete or reposition
rows or columns (series).

Click on Close to save the changes and close the Data Table dialog.

Click outside the chart to return to normal view.

Note

To insert, delete or reposition a column, use the tools Insert Series, Delete Series,
Move Series Left, and Move Series Right in the Data Table dialog.

Adding or removing chart elements

1) Make sure the chart is selected and is in editing mode. The chart has a border and
selection handles when in editing mode.

2) To add an element to the chart use one of the following methods.
— Go to Insert on the Menu bar and select, from the submenu, an element to add to the
chart.
— Right-click on the chart and select an element from the context menu.
— Right-click on the chart wall and select an element from the context menu
— Right-click on an element and select an element from the context menu.

— Open the Elements section in the Properties deck on the Sidebar (Figure 17 page 18)
and select elements from the options available.
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Note

Depending on the method selected to add an element will affect what type of element
you can add to the chart. Also, when adding some elements to the chart, a dialog
may open with more options to select for the element being added.

3) Toremove an element from a chart use one of the following methods:

— Right-click on the chart element you want to remove and select the delete option from
the context menu. The type of element selected for removal changes the delete
options in the context menu.

— Select a chart element and press the delete or backspace key to remove it from the
chart.

— Open the Elements section in the Properties deck on the Sidebar and deselect the
element.

4) Click outside the chart to return to normal view.

Chart and chart elements formatting

1) Make sure the chart is selected and is in editing mode. The chart has a border and
selection handles when in editing mode.

2) To format an element on the chart use one of the following methods.
3) Go to Format on the Menu bar and select an element you want to format.

— Right-click on an element and select Format XXXX from the context menu. The
format option changes depending on which chart element has been selected. For
example, select the chart wall and the format option is called Format Chart Wall.

— Use the various tools on the Formatting toolbar for charts (Figure 16 on page 17) to
format a chart element.

4) Selecting an element opens a formatting dialog specific for the element selected. Use the
various options in the formatting dialog to format the element. For more information on
formatting a chart, chart elements, and formatting options available, see the Calc Guide.

Resizing and moving charts

A chart and its chart elements can be resized and moved just like all other objects on a slide. For
more information on resizing and moving a chart, see Chapter 5, Managing Graphic Objects and
the Calc Guide.

Audio and video

Inserting audio or video

Using a file browser
1) Go to Insert > Audio or Video on the Menu bar and a file browser for Insert Audio or
Video opens (Figure 19).

2) Navigate to the folder where the audio or video file is located. Only the audio and video
files that are compatible with Impress will be highlighted in the file browser.

3) Select the compatible audio or video file required and click Open to embed the file in the
center of the slide. The Media Playback toolbar (Figure 20) automatically opens.

4) Reposition and/or resize the audio or video file. See Chapter 5, Managing Graphic
Objects for more information.
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Cancel

Insert Audio or Video

§ Downloads { | iTunes | iTunes Media | Music | Band Of The Coldstream Guards | Voice OF The Guns
J1 Music : _ :
& Pictures 01 Under The Banner Victory.m4a 5.8MB Audio 7Jun2013
02 Entry OF Gladiators.m4a 5.5 MB Audio 7Jun2013
H Videos “| 03 National Emblem.m4a 6.2MB  Audio 7Jun2013
04 Voice OF The Guns.m4a 6.7 MB Audio  7Jun2013
7 e 05 Light Of Foot.m4a 6.1 MB Audio 7Jun2013
O icloud & B 06 Cobenhavner March.m4a 5.3MB Audio 7Jun2013
07 Radeztky March.m4a 5.7MB Audio 7Jun 2013
& wD Silver 2 | 08 The Consort.m4a 9.9 MB Audio 7Jun2013
3 WD Black = 09 La Prer De Victoire.m4a 7.3MB Audio 7Jun2013
= 10 El Abanico.m4a 5.8 MB Audio 7Jun2013
O Toshibasilver & | 11 with Sword And Lance.m4a 5.5 MB Audio 7Jun2013
12 Anchors Aweigh.m4a 6.6 MB Audio  7Jun2013
& Toshiba Black = 13 Sambre et Meuse.m4a 61MB  Audio 7Jun2013

Figure 19: Insert Audio or Video file browser
Media Playback

= ®

n ® = (- - Scaled * | Mo Media Selected

Figure 20: Media Playback toolbar

Using
1)

the Gallery

If the Gallery deck is not already open, use one of the following methods to open the

Gallery deck:

— Go to View > Sidebar on the Menu bar to open the Sidebar and select Gallery from
the options available.

— Go to View > Gallery on the Menu bar.

2) Browse to a theme containing media files, for example Sounds.
3) Click on the audio or video option required and drag it onto the slide. The Media Playback
toolbar automatically opens.
4) Reposition and/or resize the audio or video file. See Chapter 5, Managing Graphic
Objects for more information.
Media playback

The Media Playback toolbar automatically opens when an audio or video file is selected. The
Media Playback toolbar contains the following tools from left to right:

Insert Audio or Video — opens the Insert Audio or Video file browser where you can
select a media file for insertion into a slide.

Play — plays the media playback.

Pause — pauses the playing of the media.

Stop — stops the playing of media.

Repeat — if selected, repeats the playing of the media until the tool is deselected.
Position — selects the position of where to start playing from within the media file.
Mute — suppresses the volume of a media file.

Volume - adjusts the volume of the media file.
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* Media Path — indicates where the media file is stored on a computer

Formulas

Go to Insert > Object > Formula on the Menu bar to create a formula in a slide. A formula can
also be inserted as an OLE object; see “OLE objects” on page 5 for more information.

When editing a formula, the Math menu becomes available allowing you to create or edit a
formula. For information on how to create formulas, see the Math Guide or the Getting Started
Guide.

When creating formulas, care should be taken about font sizes used to make sure they are
similar in size to the font size used in the presentation. To change font attributes of a formula, go
to Format > Font Size on the Menu bar. To change font type, go to Format > Fonts on the
Menu bar.

Note

Unlike formulas in Writer, a formula in Impress is treated as an object and will not be
automatically aligned with the rest of the objects on the slide. The formula can be
moved around like other objects in Impress, but cannot be resized.

Drawings, text files, HTML files and other objects

You can insert into a presentation drawings, text files, HTML files and other objects, but only
objects that are compatible for insertion into an Impress presentation. Go to Insert > File on the
Menu bar to open a file selection dialog. Only files compatible with Impress will be available for
selection. Drawings, text files, HTML files and other objects can also be inserted as OLE objects;
see “OLE objects” on page 5 for more information.
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