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Introduction
By default, commands and tools used in LibreOffice Impress are grouped in a user interface 
consisting of cascading menus and toolbars. The functions and use of these cascading menus 
and toolbars are described in previous chapters of this user guide.

This chapter describes the user interface variants that are available for LibreOffice Impress. A 
user then has the option to select the user interface that suits their requirements and methods of 
creating presentations in LibreOffice Impress.

Selecting user interface
To select a user interface variant or switch between the user interface variants:

1) Go to View > User Interface on the Menu bar to open the Select Your Preferred User 
Interface dialog (Figure 1).

2) In UI variants, select one of the variants. An example of the selected variant is shown in 
the Preview box, along with a short description.

3) Click on Apply to Impress to apply the variant selection to LibreOffice Impress only, or 
click on Apply to All to apply the user interface variant to all the LibreOffice modules. The
LibreOffice window changes to match the selected variant.

4) Click Close to close the dialog.

Note
If the option Enable experimental features has been selected in the Tools > 
Options > Advanced dialog, several more variants appear in UI variants. Being 
experimental, these variants are not described in this user guide.

Figure 1: Select Your Preferred User Interface Variant dialog
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Figure 2: Standard Toolbar user interface in LibreOffice Impress

Standard Toolbar user interface
The Standard Toolbar user interface is the default view when LibreOffice is installed and the 
Workspace opened for the first time. Figure 2 shows an example of the default Workspace view 
in LibreOffice Impress consisting of the following:

• Menu bar at the top of the Workspace.
• Standard toolbar positioned below the Menu bar.
• Drawing toolbar positioned vertically on the left of the Workspace.
• Sidebar on the right of the Workspace.

For more information on the Impress Workspace, see Chapter 1, Introducing Impress.

Tabbed user interface
The Tabbed user interface provides a familiar interface for users coming from proprietary office 
suites, for example, Microsoft Office.  Every tab within this user interface consists of a set of tools
grouped by context. The context changes automatically depending on the LibreOffice module 
and the object selected.

If the tool icons on a tab page do not fit into the width of the Impress window, a double 
chevron >> appears at the right end of the row. Click the double chevron >> to display more 
commands.

On Windows and Linux operating systems, the Menu bar can be hidden or displayed by clicking 
on Menubar at the left end of the Tab bar.

On the right of the Tab bar, a Quick menu (≡) (Figure 3) is available giving access to some 
commonly used commands and links. Some of the Quick menu items have submenus, indicated 
by a small triangle ► on the right. The Quick menu is the same for all tabs.
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Figure 3: Quick menu options

Figure 4: Icon bar

On the left of the Tab bar, an Icon bar (Figure 4) is available giving access to some commonly 
used tools – Menubar; Open (Ctrl+O); Save (Ctrl+S);Undo (Ctrl+Z); Redo (Ctrl+Y); Start from
First Slide (F5).
The Tabbed user interface can be customized as follows:

1) Click on Quick menu and select Customize from the submenu to open the Customize 
dialog.

2) Click on Notebookbar to open the Notebookbar page in the Customize dialog.
3) Select or deselect the various tools in Assigned Commands.
4) Click OK to save the changes and close the Customize dialog.

For more information on the customization of LibreOffice, see the Getting Started Guide and the 
Writer Guide.

Note
When using the Tabbed user interface, the Impress toolbars are no longer visible. If 
necessary, it is possible to open toolbars by going to View > Toolbars on the Menu 
bar or Quick menu > Toolbars.

Fixed tabs
File tab
The File tab (Figure 5) is a fixed tab providing a default set of tools, for example, to create new 
documents; open, save, print, and close documents; manage templates and so on. The File tab 
has a File menu (Figure 6) and a Help menu (Figure 7) providing links to a variety of resources 
and containing the same tools as the tools available on the tab.

File tab tools from left to right
1) New 2) Open Templates Manager (Shift+Ctrl+N)
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3) Save as Template
4) Open (Ctrl+O)
5) Recent Documents
6) Open Remote File
7) Save (Ctrl+S)
8) Save As
9) Save Remote File
10) Export

11) Export Directly as PDF
12) Attach to Email
13) Print (Ctrl+P)
14) Print Directly
15) Toggle Print Preview (Shift+Ctrl+O)
16) Properties
17) Digital Signatures
18) Sign Existing PDF

Figure 5: Tabbed user interface - File tab

Figure 6: File tab - File menu
Figure 7: File tab - Help 
menu

Home tab
The Home tab (Figure 8) is a fixed tab providing a default set of tools, for example, to cut, copy, 
paste, and format text; insert common items; and so on. The Home menu (Figure 9) at the right 
end of the Home tab bar provides additional tools that are not on the tab.

Home tab tools from left to right
1) Paste (Ctrl+V)
2) Cut (Ctrl+X)
3) Copy (Ctrl+C)
4) New Page (Ctrl+M)

5) Duplicate Page
6) Delete Page
7) Slide Layout
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8) Clone Formatting (double click for 
multi-selection)

9) Clear Direct Formatting (Shift+Ctrl+M)
10) Font Name
11) Bold (Ctrl+B)
12) Italic (Ctrl+I)
13) Underline (Ctrl+U)
14) Strikethrough
15) Toggle Shadow
16) Font Size
17) Set Character Spacing
18) Character Highlighting Color
19) Increase Font Size (Ctrl+])
20) Decrease Font Size (Ctrl+[)
21) Font Color
22) Align Top
23) Align Left (Ctrl+L)
24) Center Vertically
25) Align Center (Ctrl+E)
26) Align Bottom
27) Align Right (Ctrl+R)
28) Toggle Unordered List
29) Justified (Ctrl+J)

30) Toggle Ordered List
31) Set Line Spacing
32) Increase Indent
33) Increase Paragraph Spacing
34) Decrease Indent
35) Decrease Paragraph Spacing
36) Left-To-Right
37) Right-To-Left
38) Insert Text Box (F2)
39) Insert Vertical Text
40) Insert Line
41) Rectangle
42) Curves and Polygons
43) Basic Shapes
44) Connectors
45) Flowchart
46) Line Color
47) Fill Color
48) Start from First Slide (F5)
49) Start from Current Slide (Shift+F5)
50) Find and Replace (Ctrl+H)
51) Start from First Slide (F5)

Figure 8: Tabbed user interface - Home tab

Figure 9: Home tab - Home 
menu

Insert tab
The Insert tab (Figure 10) is a fixed tab providing a default set of tools to insert many commonly 
used items. The Insert menu (Figure 11) at the right end of the Insert tab bar provides some of 
the same tools.
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Insert tab tools from left to right
1) New Page (Ctrl+M)
2) Duplicate Page
3) Insert Page from File
4) Table
5) Insert Chart
6) OLE Object
7) Insert Image
8) Open Clip Art and Media Gallery
9) Photo Album
10) Insert Audio or Video
11) Insert Hyperlink (Ctrl+K)
12) Insert Fontwork Text
13) Insert Snap Guide
14) Field
15) Insert Text Box (F2)
16) Insert Vertical Text
17) Insert Line
18) Rectangle
19) Polygon

20) Ellipse
21) Curve
22) Callouts
23) Lines and Arrows
24) Curves and Polygons
25) Basic Shapes
26) Stars and Banners
27) Symbol Shapes
28) Callouts
29) Block Arrows
30) Flowchart
31) Connectors
32) 3D Objects
33) Insert Special Characters
34) Insert Formula Object (Ctrl+Alt+=)
35) Insert Emoji
36) Insert Image
37) Insert Text Box (F2)
38) New Page (Ctrl+M)

Figure 10: Tabbed user interface - Insert tab

Chapter 12, User Interface Variants | 9



Figure 11: Insert tab - 
Insert menu

Layout tab
The Layout tab (Figure 12) is a fixed tab providing a default set of tools to create a slide layout. 
The Layout menu (Figure 13) at the right end of the Layout tab bar provides some of the same 
tools.

Layout tab tools from left to right
1) Page Properties
2) Header and Footer
3) Set Background Image
4) Save Background Image
5) New Page (Ctrl+M)
6) Duplicate Page
7) Delete Page
8) Rename Page
9) Hide Slide
10) Show Slide

11) Page Up (Shift+Ctrl+Up)
12) Page Down (Shift+Ctrl+Down)
13) Change Slide Master
14) Master Background
15) Master Objects
16) Rotate
17) Align Objects
18) Arrange
19) Slide Layout

Figure 12: Tabbed user interface - Layout tab
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Figure 13: Layout tab – 
Layout menu

Slide Show tab
The Slide Show tab (Figure 14) is a fixed tab providing a default set of tools for creating a slide 
show. The Slide Show menu (Figure 15) at the right end of the Slide Show tab bar provides 
some of the same tools.

Slide Show tab tools from left to right
1) Start from First Slide (F5)
2) Start from Current Slide (Shift+F5)
3) Rehearse Timings
4) Custom Slide Show
5) Slide Show Settings
6) Slide Transition

7) Animation
8) Minimize Presentation
9) Color
10) Grayscale
11) Start from First Slide (F5)

Figure 14: Tabbed user interface - Slide Show tab
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Figure 15: Slide Show tab - 
Slide Show menu

Review tab
The Review tab (Figure 16) is a fixed tab providing a default set of tools for reviewing a slide 
show. The Review menu (Figure 17) provides additional text editing tools. Some of these tools 
appear only if Asian or Complex Text Layout are selected in Tools > Options > Language 
Settings > Languages.

Review tab tools from left to right
1) Spelling (F7)
2) Thesaurus (Ctrl+F7)
3) Toggle Automatic Spell Checking (Shift+F7)
4) Hyphenation
5) Comment (Ctrl+Alt+C)
6) Next Comment (Ctrl+Alt+Page Down)
7) Previous Comment (Ctrl+Alt+Page Up)

8) Delete Comment
9) Delete All Comments
10) Comments
11) Redact Document
12) Toggle Edit Mode (Shift+Ctrl+M)
13) Comment (Ctrl+Alt+C)

Figure 16: Tabbed user interface - Review tab
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Figure 17: Review tab - Review
menu

View tab
The View tab (Figure 18) is a fixed tab providing a default set of tools to control the display of 
slides on a screen. The View menu (Figure 19) provides additional tools relating to the display of 
slides on a screen.

Top row, left to right
1) Normal
2) Slide Sorter
3) Notes
4) Outline
5) Master Slide
6) Master Notes
7) Master Handout
8) Zoom & Pan (Ctrl to Zoom Out, Shift to Pan)
9) Zoom Previous

10) Entire Page
11) Zoom Next
12) Page Width
13) Sidebar (Ctrl+F5)
14) Rulers (Shift+Ctrl+F5)
15) Display Grid
16) Menubar
17) Toggle View Bars Visibility

Figure 18: Tabbed user interface - View tab
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Figure 19: View tab - View 
menu

Extension tab
The Extension tab (Figure 20) is a fixed tab containing only the tool to access the Extension 
Manager allowing the installation of extensions that are compatible for use in LibreOffice.

Figure 20: Tabbed user interface - 
Extension tab

Tools tab
The Tools tab (Figure 21) is a fixed tab providing a default set of tools for working with, for 
example, macros; color replacer; media player; and so on. The Tools menu (Figure 22) provides 
some of the same tools, plus extra tools for organizing, for example, macros and dialogs; image 
map; data sources; and so on.
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Tools tab tools from left to right
1) Run Macro
2) Basic (Alt+F11)
3) Edit Macros
4) Minimize Presentation
5) Color Replacer
6) Media Player
7) Design Mode
8) Toggle Form Control Wizards
9) Group Box
10) Label
11) Option Button
12) Text Box
13) List Box
14) Check Box
15) Combo Box
16) Numerical Field
17) Formatted Field

18) Currency Field
19) Date Field
20) Pattern Field
21) Time Field
22) Push Button
23) File Selection
24) Image Button
25) Navigation Bar
26) Image Control
27) Table Control
28) Form Properties
29) Form Navigator
30) Activation Order
31) Open in Design Mode
32) Control Properties
33) Automatic Control Focus
34) Options (Alt+F12)

Figure 21: Tabbed user interface - Tools tab

Figure 22: Tools tab - Tools 
menu
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Additional tabs
Additional tabs appear between the View and Extension tabs when an object in Impress is 
selected.

Draw tab
The Draw tab (Figure 23) becomes available when a drawing object is selected in a slide. It 
provides tools for editing, transforming, grouping, aligning, and distributing draw objects. The 
Draw tab menu (Figure 24) provides some of the tools required for editing, transforming and 
converting drawing objects.

Draw tab tools from left to right
1) Interaction
2) Transformations

Rotate
Set to Circle (Slant)
Flip
Distort
In 3D Rotation Object
Interactive transparency tool
Set in Circle (perspective)

3) Rotate
4) Flip Vertically
5) Flip Horizontally
6) Distort
7) Set to circle (slant)
8) Line Style
9) Area
10) Area Style/Filling
11) Line Color
12) Arrow Style
13) Shadow
14) To Curve
15) Left
16) Top
17) Centered
18) Center
19) Right
20) Bottom
21) Bring to Front (Shift+Ctrl++)
22) Send to Back (Shift+Ctrl+-)
23) Bring Forward (Ctrl++)
24) Send Backward (Ctrl+-)
25) Points (F8)
26) Convert to Curve

27) Symmetric Transition
28) Close Bézier
29) Eliminate Points
30) Move Points
31) Split Curve
32) Insert Points
33) Corner Point
34) Delete Points
35) Smooth Transition
36) Show Glue Points Functions
37) Combine (Shift+Ctrl+K)
38) Merge
39) Split (Shift+Ctrl+Alt+K)
40) Subtract
41) Select at least three objects to distribute
42) Intersect
43) Group (Shift+Ctrl+G)
44) Enter Group (F3)
45) Exit Group (Ctrl+F3)
46) Toggle Extrusion
47) Depth
48) Direction
49) 3D Color
50) Surface
51) Insert Fontwork Text
52) Fontwork Shape
53) Fontwork Alignment
54) Fontwork Same Letter Heights
55) Fontwork Character Spacing
56) Area
57) Line
58) Position and Size (F4)

Figure 23: Tabbed user interface - Draw tab

16| Chapter 12, User Interface Variants



Figure 24: Draw tab - Draw
menu

Image tab
The Image tab (Figure 25) becomes available when an image is selected in a slide, for example 
a photograph. It provides tools for working with images, such as cropping, borders, area styles, 
colors, and so on. The Image tab menu (Figure 26) provides links to dialogs for working with 
images.

Image tab tools from left to right
1) Interaction
2) Compress
3) Rotate
4) Crop Image
5) Flip Vertically
6) Flip Horizontally
7) Replace
8) Save
9) Line
10) Area
11) Line Style
12) Area Style/Filling
13) Line Width
14) Line Color
15) Arrow Style
16) Shadow
17) To Curve
18) Left
19) Top

20) Centered
21) Center
22) Right
23) Bottom
24) Bring to Front (Shift+Ctrl++)
25) Send to Back (Shift+Ctrl+-)
26) Bring Forward (Ctrl++)
27) Send Backward (Ctrl+-)
28) Filter
29) Brightness
30) Contrast
31) Transparency
32) Gamma
33) Image Mode
34) Color
35) Area
36) Line
37) Position and Size (F4)

Figure 25: Tabbed user interface - Image tab
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Figure 26: Image tab - 
Image menu

Object tab
The Object tab (Figure 27) becomes available when an object, such as a chart, is selected. It 
provides tools to position, resize, choose colors, and so on for the selected object. The Object 
tab menu (Figure 28) provides extra tools matching the type of object selected.

Object tab tools from left to right
1) Interaction
2) Transformations
3) Rotate Flip Vertically
4) Flip Horizontally
5) Distort
6) Set to circle (slant)
7) Line
8) Area
9) Line Style
10) Area Style/Filling
11) Line Width
12) Line Color
13) Arrow Style
14) Shadow

15) To Curve
16) Left
17) Top
18) Centered
19) Center
20) Right
21) Bottom
22) Bring to Front (Shift+Ctrl++)
23) Send to Back (Shift+Ctrl+-)
24) Bring Forward (Ctrl++)
25) Send Backward (Ctrl+-)
26) Area
27) Line
28) Position and Size (F4)

Figure 27: Tabbed user interface - Object tab
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Figure 28: Object 
tab - Object menu

Table tab
The Table tab (Figure 29) becomes available when a table is selected in a slide. It provides tools 
to format a table to the presentation requirements. The Table tab menu (Figure 30) includes 
extra tools for editing a table.

Table tab tools from left to right
1) Interaction
2) Insert Column Before
3) Insert Row Above
4) Insert Column After
5) Insert Row Below
6) Delete Column
7) Delete Row
8) Insert Line
9) Area
10) Borders (Shift to overwrite)
11) Border Style
12) Area Style/Filling
13) Border Color
14) Fill Color
15) Merge Cells

16) Split Cells
17) Select Table
18) Select Column
19) Select Row
20) Optimize
21) Align Top
22) Align Left (Ctrl+L)
23) Center Vertically
24) Align Center (Ctrl+E)
25) Align Bottom
26) Align Right (Ctrl+R)
27) Right-toLeft
28) Justified (Ctrl+J)
29) Table Design
30) Table Properties

Figure 29: Tabbed user interface - Table tab

Figure 30: Table tab - Table menu

Media tab
The Media tab (Figure 31) only becomes available when a media object is selected in a slide. It 
provides tools for positioning and running an audio or video file. The Media tab menu (Figure 32) 
includes extra tools for editing a media object.
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Media tab tools from left to right
1) Name
2) Media Player
3) Rotate
4) Left
5) Top
6) Centered
7) Center
8) Right
9) Bottom
10) Bring to Front (Shift+Ctrl++)
11) Send to Back (Shift+Ctrl+-)

12) Bring Forward (Ctrl++)
13) Send Backward (Ctrl+-)
14) Play
15) Pause
16) Stop
17) Repeat
18) Media Player
19) Area
20) Line
21) Position and Size (F4)

Figure 31: Tabbed user interface - Media tab

Figure 32: Media tab 
- Media menu

Single Toolbar & Sidebar user interfaces
When selected, the Single Toolbar and Sidebar user interfaces only show the Menu bar with no
toolbars. However, toolbars can be added to either of these user interfaces by going to View > 
Toolbars on the Menu bar and selecting the required toolbar from the options available. For 
more information on toolbars, see Appendix B, Toolbars in this guide and the Getting Started 
Guide.

Tabbed Compact user interface
The Tabbed Compact user interface has the same tabs as the Tabbed user interface, but the 
tools on each tab are arranged as a single row of tools. Some of these tools have drop-down 
menus with extra options. Figure 33 shows an example of the File tab in the Tabbed Compact 
user interface.

The tab menu on the right of the Tabbed Compact user interface provides the same options as 
the tab menus in the Tabbed user interface, see “Tabbed user interface” on page 5 for more 
information.
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Figure 33: Example of Tabbed Compact user interface showing File tab

Groupedbar Compact user interface
The Groupedbar Compact user interface is divided into groups that contain commands 
organized as sets of tools and menus. The tools and menus that are available change to suit the 
type of object selected. Clicking on the double chevron >> displays more tools for editing an 
object. Figure 34 shows an example of Groupedbar Compact user interface when a basic 
shape object is selected.

The Groupedbar Compact menu (Figure 35) on the right-hand end of this interface provides 
extra tools for working with LibreOffice Impress, including convenient ways to change the user 
interface and access toolbars.

Figure 34: Example of Groupedbar Compact user interface with an object selected

Figure 35: Menu for 
Groupedbar Compact UI

Contextual Single user interface
The Contextual Single user interface displays a single toolbar to suit the type of object that has 
been selected. Clicking on the double chevron >> displays more tools for editing an object. 
Figure 36 shows an example of a Contextual Single user interface when a basic shape object is
selected.
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Figure 36: Example of Contextual Single user interface with a basic shape selected
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