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Who is this book for?

LibreOffice is a feature-rich, free, and open source office suite. It includes several powerful 
applications for word processing, spreadsheets, presentations, graphics, databases, and formula 
editing. Writer is the word-processing application. It is compatible with a wide range of document 
formats including Microsoft Word (.doc, .docx), and you can export your work in several formats 
including PDF.

Anyone who wants to get up to speed quickly with Writer will find this book valuable. You may be 
new to word processing software, or you may be familiar with another office suite.

What’s in this book?

This book introduces the main features of Writer, the word processor component of LibreOffice, 
and provides instructions for their use.

Minimum requirements for using LibreOffice

For a detailed list of requirements and operating systems supported, see the LibreOffice website,
https://www.libreoffice.org/get-help/system-requirements/.

How to get LibreOffice

Versions of LibreOffice Community for Windows, Linux, and macOS are freely available and can 
be downloaded from https://www.libreoffice.org/download. Linux users will also find a version of 
LibreOffice included by default in the majority of Linux distributions. Portable and other versions 
of LibreOffice are listed on the download page. Linux, Enterprise, Online, and other versions may
differ in appearance and functionality from the descriptions in this book.

Installing LibreOffice

Information on installing and setting up LibreOffice on the various supported operating systems is
given here: https://www.libreoffice.org/get-help/install-howto/.

Setting up and customizing LibreOffice

You can change the default settings (options) in LibreOffice to suit your preferences. To change 
settings, go to Tools > Options on the Menu bar (LibreOffice > Preferences on macOS). 
Settings are described in the Help and in Chapter 2, Setting up LibreOffice, in the Getting Started
Guide. Some settings of particular interest to users of Writer are covered in Chapter 20, Setting 
up Writer, in this book.

Tip

Many settings are intended for power users and programmers. If you do not 
understand what an option does, we recommend leaving it on the default setting 
unless instructions in this book recommend changing the setting.

You can customize menus, toolbars, and keyboard shortcuts in LibreOffice, add new menus and 
toolbars, and assign macros to events. See Chapter 20, Customizing Writer, for details.
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Extensions and add-ons

You can add functionality to LibreOffice with extensions and add-ons. Several extensions are 
installed with the program and you can get others from the official extensions repository, 
https://extensions.libreoffice.org/ and from other sources. See Chapter 20, Customizing Writer, 
for more information on installing extensions and add-ons.

Where to get more help

This book, the other LibreOffice user guides, the Help system, and user support systems assume
that you are familiar with your computer and basic functions such as starting a program, opening 
and saving files.

Help system
LibreOffice comes with an extensive online Help system. This is your first line of support. 
Windows and Linux users can choose to download and install the offline Help for use when not 
connected to the Internet; the offline Help is installed with the program on macOS.

To display the Help system, press F1 or select Help > LibreOffice Help on the Menu bar. If you 
do not have the offline help installed on your computer and you are connected to the Internet, 
your default browser will open the online Help pages on the LibreOffice website.

The Help menu includes links to other LibreOffice information and support resources. Notice that 
options marked with a ‡ sign are only accessible if your computer is connected to the Internet.

• What's This? For quick tips when a toolbar is visible, place the mouse pointer over any of
the icons to see a small box (“tooltip”) with a brief explanation of the icon’s function. For a 
more detailed explanation, select Help > What's This? and hold the pointer over the 
icon. In addition, you can choose whether to activate Extended Tips using Tools > 
Options > LibreOffice > General.

• User Guides ‡ Opens your default browser at the Documentation page of the LibreOffice 
website https://documentation.libreoffice.org/en/. There you will find user guides (to 
download as free PDFs or buy as printed copies) and other useful information.

• Show Tip of the Day Opens a small window with a random tip on how to use LibreOffice.

• Search Commands Opens a window where you can type a few letters or the name of a 
Menu bar command, to quickly find where the command is located. Clicking on a 
command in the resulting list may open a relevant dialog or have other effects.

• Get Help Online ‡ Opens your default browser at the Ask LibreOffice forum of questions 
and answers from the LibreOffice community https://ask.libreoffice.org/en/questions/.

• Send Feedback ‡ Opens your default browser at the Feedback page of the LibreOffice 
website https://www.libreoffice.org/get-help/feedback/. From there you can report bugs, 
suggest new features and communicate with others in the LibreOffice community.

• Restart in Safe Mode Opens a dialog where you can restart LibreOffice and reset the 
software to its default settings.

• Get Involved ‡ Opens your default browser at the Get Involved page of the LibreOffice 
website, https://www.libreoffice.org/community/get-involved/. There you can choose a 
topic of interest to help improve the program.

• Donate to LibreOffice ‡ Opens your default browser at the Donation page of the 
LibreOffice website https://donate.libreoffice.org/.

• License Information Outlines the licenses under which LibreOffice is made available.
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• Check for Updates ‡ Opens a dialog and checks the LibreOffice website for updates to 
your version of the software.

• About LibreOffice Opens a dialog and displays information about the version of 
LibreOffice and the operating system you are using. This information will often be 
requested if you ask the community for help or assistance with the software. (On macOS, 
this option is found under LibreOffice on the Menu bar.)

Other free online support
The LibreOffice community not only develops software, but provides free, volunteer-based 
support. See Table 1 and this web page: https://www.libreoffice.org/get-help/.

For comprehensive online support from the community, look at mailing lists and the Ask 
LibreOffice website, https://ask.libreoffice.org/en/questions/. Other websites run by users also 
offer free tips and tutorials.

Table 1: Free support for LibreOffice users

Free LibreOffice support

FAQs
Answers to frequently asked questions
https://wiki.documentfoundation.org/Faq

Mailing lists
Free community support is provided by a network of 
experienced users
https://www.libreoffice.org/get-help/mailing-lists/

Questions & 
Answers and 
Knowledge Base

Free community assistance is provided in a question & answer 
format. Search similar topics or ask a new question in 
https://ask.libreoffice.org/en/questions
The service is available in several other languages; just replace 
/en/ with de, es, fr, ja, ko, nl, pt, tr, and many others in the web 
address above.

Native language 
support

The LibreOffice website in various languages
https://www.libreoffice.org/community/nlc/
Mailing lists for native languages
https://wiki.documentfoundation.org/Local_Mailing_Lists
Information about social networking
https://wiki.documentfoundation.org/Website/Web_Sites_servic
es

Accessibility options
Information about available accessibility options. 
https://www.libreoffice.org/get-help/accessibility/

Paid support and training
You can also pay for support through service contracts from a vendor or consulting firm 
specializing in LibreOffice. For information about certified professional support, see The 
Document Foundation’s website: https://www.documentfoundation.org/gethelp/support/.

For schools, educational and research institutions, and large organizations, see 
https://www.libreoffice.org/download/libreoffice-in-business/.
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What you see may be different

Illustrations
LibreOffice runs on Windows, Linux, and macOS operating systems, each of which has several 
versions and can be customized by users (fonts, colors, themes, window managers). The 
illustrations in this guide were taken from a variety of computers and operating systems. 
Therefore, some illustrations will not look exactly like what you see on your computer display.

Also, some of the dialogs may be different because of the settings selected in LibreOffice. You 
can either use dialogs from your computer’s operating system or from LibreOffice. The 
differences affect mainly Open, Save, and Print dialogs. To change which dialogs are used, go to 
Tools > Options > LibreOffice > General and select or deselect the option Use LibreOffice 
dialogs.

Icons
The LibreOffice community has created icons for several icon sets: Breeze, Colibre, Elementary, 
Karasa Jaga, Sifr, and Sukapura; some are also available in a dark version. As a user, you can 
can select your preferred set. The icons in this guide have been taken from a variety of 
LibreOffice installations that use different sets of icons. The icons for some of the many tools 
available in LibreOffice may differ from the ones used in this guide.

To change the icon set used, go to Tools > Options > LibreOffice > View. In the Icon Style 
section, choose from the drop-down list.

Notes

Some Linux distributions include LibreOffice as part of the installation and may not 
include all the icon sets mentioned above. You should be able to download other 
icon sets from the software repository for your Linux distribution.

The Galaxy, Oxygen, and Tango icon sets are no longer included as part of the 
standard installation package for Windows, macOS, or Linux. You can download and
install them as extensions from https://extensions.libreoffice.org/en/extensions/. 

In addition, some of the previously included gallery sets are now available only as 
extensions; see https://extensions.libreoffice.org/?Tags%5B%5D=49 or search for 
specific ones. For example, the People Gallery is available from 
https://extensions.libreoffice.org/en/extensions/show/people-gallery 

Using LibreOffice on macOS

Some keystrokes and menu items are different on macOS from those used in Windows and 
Linux. The table below gives some common substitutions for the instructions in this chapter. For 
a more detailed list, see the application Help.

Windows or Linux macOS equivalent Effect

Tools > Options 
menu selection

LibreOffice > Preferences Access setup options

Right-click Control+click and/or right-click 
depending on computer setup

Opens a context menu

Ctrl (Control)  (Command)⌘ Used with other keys

F11 +T⌘ Open the sidebar Styles deck
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Frequently asked questions

How is LibreOffice licensed?
LibreOffice is distributed under the Open Source Initiative (OSI) approved Mozilla Public 
License (MPL). See https://www.libreoffice.org/about-us/licenses/ 

It is based on code from Apache OpenOffice made available under the Apache License 2.0 
but also includes software that differs from version to version under a variety of other Open 
Source licenses. New code is available under LGPL 3.0 and MPL 2.0.

May I distribute LibreOffice to anyone? May I sell it? May I use it in my business?
Yes.

How many computers may I install it on?
As many as you like.

Why do I need Java to run LibreOffice? Is it written in Java?
LibreOffice is not written in Java; it is written in the C++ language. Java is one of several 
languages that can be used to extend the software. The Java JDK/JRE is only required for 
some features. The most notable one is the HSQLDB relational database engine.

Java is available at no cost. More information and download links to the appropriate edition 
for your operating system can be found at: https://java.com/en/download/manual.jsp

Note

If you want to use LibreOffice features that require Java, it is important that the 
correct 32-bit or 64-bit edition matches the installed version of LibreOffice. See the 
Advanced Options in Chapter 2 of this guide. If you do not want to use Java, you can
still use nearly all of the LibreOffice features.

How can I contribute to LibreOffice?
You can help with the development and user support of LibreOffice in many ways, and you 
do not need to be a programmer. To start, check out this web page: 
https://www.libreoffice.org/community/get-involved/.

May I distribute the PDF of this book, or print and sell copies?
Yes, as long as you meet the requirements of one of the licenses in the copyright statement
at the beginning of this book. You do not have to request special permission. We request 
that you share with the project some of the profits you make from sales of books, in 
consideration of all the work we have put into producing them. Visit 
https://www.libreoffice.org/donate/ for instructions on how to donate to LibreOffice.

What’s new in this user guide?

LibreOffice 7.2 Community includes many changes not visible in the user interface. These 
changes include improved interoperability with Microsoft’s proprietary file formats and 
performance improvements in handling large files, opening certain .docx and .xlsx files, 
managing font caching, and opening presentations and drawings that contain large images.

More information is in the announcement:
https://blog.documentfoundation.org/blog/2021/08/19/libreoffice-7-2-community/.
Release Notes are here: https://wiki.documentfoundation.org/ReleaseNotes/7.2. 

This user guide has been updated from Writer Guide 7.1. It covers changes that are visible in the
user interface, including:

• Added a note about icon sets and Gallery sets in this Preface.

• Added details about the Insert > Formatting Mark submenu (Chapter 2).
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• Updated list terminology and changed screenshots in Chapters 4, 8, 9, 11, and anywhere
else lists are mentioned.

• Added new gutter margins and choices for page background fills (Chapters 5, 6, and 9).

• Updated details about some options on tabs of the PDF Options dialog (Chapter 7).

• Added new, advanced features of the Style Inspector (Chapter 9)

• Updated details about Templates dialog (Chapter 10).

• Added “no registered database” error message in Mail Merge Wizard (Chapter 14).

• Added information on classifying document contents (Chapter 17).

• Added Basic Fonts options and custom dictionaries (Chapter 20).

• New Chapter 21 on user interface variants.

• Minor rewording, updates to terminology, and replacement figures in many chapters.
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