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Introduction

In Impress there are several toolbars available to help you create an Impress presentation. Each 
toolbar has a default set of tools and the option to add additional tools to a toolbar.

Note

The icons displayed in the Impress toolbars may differ from what you see on your 
screen. Toolbar icons depend on the computer system being used and how a 
LibreOffice has been setup.

Using toolbars

Displaying toolbars

To display and make a toolbar active go to View > Toolbars on the Menu bar. A context menu 
opens with a list of available toolbars for creating presentations in LibreOffice Impress. Click on a
toolbar name to make it active. Active toolbars are indicated by a check mark next to the name 
as shown in Figure 1.

Figure 1: Impress toolbars

Note

Some toolbars, although selected in View > Toolbars on the Menu bar, will not 
display until an object of the correct type is selected in the presentation. For 
example, the Image toolbar only displays when an image is selected.

Closing toolbars

To close a toolbar, use one of the following methods:

• Go to View > Toolbars on the Menu bar and deselect the toolbar.
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• Right-click on an icon on a toolbar and select Close Toolbar from the context menu.

• Click on the X in the right corner of the title bar of a floating toolbar.

Moving toolbars

Locked toolbars

When a toolbar has been docked, it can also be locked into its position on the Impress main 
window. A floating toolbar cannot be locked into position.

• To lock a toolbar into its docked position, right click in a blank area on the toolbar and 
click on Lock Toolbar Position in the context menu. A check mark appears against this 
option indicating the toolbar is now locked.

• To unlock a toolbar, right click in a blank area on the toolbar and click on Lock Toolbar 
Position in the context menu. The check mark next to this option disappears indicating 
the toolbar is now unlocked. Also, a small vertical bar appears at the left end of the 
toolbar and is used to move the toolbar.

Docked toolbars

By default, some toolbars are docked into position in the Impress main window. For example, the
Standard toolbar is docked at the top of the main window. Docked toolbars can be undocked and
moved to a new docked position on the main window or left as a floating toolbar. Before moving a
toolbar, the toolbar must be unlocked.

1. Move the mouse cursor over the small vertical handle at the left end of the toolbar. The 
mouse cursor changes to a moving cursor for your computer system and setup.

2. Click and hold down the left mouse button and drag the toolbar to a new location. This 
can be a new docked position or a floating toolbar. A hashed border appears around the 
toolbar indicating the toolbar position as you drag it.

3. Release the mouse button.

Floating toolbars

To move a floating toolbar, click on its title bar and drag it to a new floating location. Release the 
mouse button when the toolbar is in the desired position. A floating toolbar does not have to be 
positioned on the Impress main window for it to function.

Docking toolbars

To dock a toolbar, use one of the following methods:

• Click on the title bar and drag it to the top, bottom, left side, or right side of the main 
window. When the toolbar reaches a docking position, a hashed border appears at the 
docked position. Release the mouse button and the toolbar is docked.

• Right click ion the toolbar and select Dock Toolbar from the context menu. The toolbar 
moves into a docked position. If the position is not suitable, move the toolbar to a new 
docked position.

• To dock all floating toolbars that are active, right click on the toolbar and select Dock All 
Toolbars from the context menu.

Editing toolbars

When LibreOffice is installed on your computer, a set of toolbars suitable for each LibreOffice 
module are also installed. Each toolbar has a default set of tools to get you started in creating 
LibreOffice documents.
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Adding tools

Install additional tools using Visible Buttons as follows:

1. Right-click on a toolbar and select Visible Buttons from the context menu to display a list
of available tools.

2. Click on the tool you want to install and the tool will appear in the toolbar. The list of 
available tools closes automatically. A highlight or check mark next to the tool indicates 
that the tool is already installed on the toolbar.

Note

When adding tools using Visible Buttons, the tool is added to the toolbar at the 
same position as the tool appears in the Visible Buttons list. That is, the top tool in 
Visible Buttons appears at the left end of the toolbar; the bottom tool in Visible 
Buttons list appears at the right end of the toolbar. Tool positions cannot be changed
using Visible Buttons.

Deleting tools

Remove tools using Visible Buttons from a toolbar as follows:

1. Right-click on a toolbar and select Visible Buttons from the context menu to display a list
of available tools.

2. Click on the tool you want to remove and the tool is removed from the toolbar. The 
highlight or check mark next to the tool is also removed. The list of available tools closes 
automatically.

Customizing toolbars

Extra tools and commands that are not available in Visible Buttons can be added to a toolbar 
using customization. Customization also allows you to create new toolbars should you require a 
specific set of tools for a specific task. For information on customizing toolbars, see the Getting 
Started Guide.

Toolbars

Note

The tools installed on a toolbar are normally indicated in Visible Buttons either by 
the tool icon being highlighted or by a check mark. However, this install indication 
depends on computer setup and computer operating system being used.

Note

On some toolbars, the icons have a small downward pointing triangle ▼ to the right 
of an icon. Click on this triangle to open further options that are available for use.

Note

Some of the tools in the toolbars also have the option of using a keyboard shortcut 
instead of clicking on the tool. For a full list of keyboard shortcuts that are available in
Impress, see Appendix A, Keyboard Shortcuts.
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3D-Objects

The 3D-Objects toolbar provides tools to create 3D objects in a presentation. It is activated either
by going to View > Toolbars > 3D-Objects on the Menu bar or by clicking on the 3D Objects 
icon on the Drawing toolbar.

1. Cube
2. Sphere
3. Cylinder
4. Cone

5. Pyramid
6. Torus
7. Shell
8. Half Sphere

3D-Settings

The 3D-Settings toolbar and its tools only become active when an object has been converted to 
3D using the tool Toggle Extrusion and the converted object is then selected.

1. Toggle Extrusion
2. Tilt Down
3. Tilt Up
4. Tilt Left
5. Tilt Right

6. Depth
7. Direction
8. Lighting
9. Surface

10. 3D Color

Align Objects

The Align Objects toolbar allows you to align several objects on a slide to improve the visual 
impact of a presentation.

1. Left
2. Centered
3. Right

4. Top
5. Center
6. Bottom

Comments

The Comments toolbar allows you to add, delete and navigate comments in a presentation. To 
use comments, it is recommended to add your name and initials in Tools > Options > 
LibreOffice > User Data so that comments can be easily identified.

1. Comment (Ctrl+Alt+C)
2. Previous Comment (Ctrl+Alt+PgUp)
3. Next Comment (Ctrl+Alt+PgDown)

4. Delete Comment
5. Delete All Comments
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Drawing

The Drawing toolbar provides the majority of the tools normally used to create graphic objects on 
a slide. Some tool icons on this toolbar change to show the last tool selected and used.

1. Select
2. Zoom & Pan
3. Zoom
4. Text Box (F2)
5. Vertical Text
6. Fontwork
7. Line Color
8. Fill Color
9. Line

10. Rectangle
11. Ellipse
12. Line Ends with Arrow
13. Lines and Arrows
14. Curves and Polygons
15. Connectors
16. Basic Shapes
17. Symbol Shapes
18. Block Arrows (Arrow Shapes in Visible 

Buttons))
19. Flowchart
20. Callouts (Callout Shapes in Visible Buttons)

21. Stars and Banners (Star Shapes in Visible 
Buttons)

22. 3D Shapes
23. Position and Size (F4)
24. Rotate
25. Flip
26. Align
27. Arrange
28. Distribution
29. Shadow
30. Crop
31. Filter
32. Edit Points (F8)
33. Glue Points
34. To Curve
35. To Polygon
36. To 3D
37. T0 3D Rotation Object
38. Toggle Extrusion
39. Insert
40. Controls

Some icon shapes shown on the Drawing toolbar depend on the last tool that had previously 
been selected and used.

• Click on the small downward pointing triangle ▼ to the right of an icon to open a pop up 
menu. Select the required shape you want to draw on a slide.

• To create a sub-toolbar, click and drag at the top of the pop up menu to an empty area on
the main window The sub-toolbars for each object type and the various shapes available 
are shown below.
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Edit Points

The Edit Points toolbar becomes active when you select a polygon object and click Edit Points 
or use the keyboard shortcut F8. The tools provided allow you to edit the points of a curve or an 
object converted to a curve.

1. Edit Points (F8)
2. Move Points
3. Insert Points
4. Delete Points
5. Convert to Curve
6. Close Bezier

7. Split Curve
8. Corner Point
9. Smooth Transition

10. Symmetric Transition
11. Eliminate Points

Find

The Find toolbar opens by default in the bottom left corner of the Impress main window. The Find
toolbar cannot be undocked and made into a floating toolbar.

1. Close Find Bar
2. Find Text
3. Find Previous
4. Find Next

5. Find All
6. Match Case
7. Find and Replace (Ctrl+H)

Fontwork

The Fontwork toolbar is used to create graphical text objects in a presentation and provide the 
tools allowing you to edit the graphical text object.

1. Insert Fontwork
2. Fontwork Shape
3. Fontwork Same Letter Heights

4. Fontwork Alignment
5. Fontwork Character Spacing
6. Toggle Extrusion
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Form Controls

The Form Controls toolbar provides tools required to create an interactive form. The toolbar adds
controls to a form in a text, drawing, spreadsheet, presentation, or HTML document (for example 
a button that runs a macro).

1. Select
2. Toggle Design Mode
3. Form Control Wizards
4. Form Design
5. Control Properties
6. Form Properties
7. Label
8. Text Box
9. Check Box

10. Option Button
11. List Box
12. Combo Box
13. Push Button
14. Image Button

15. Formatted Field
16. Date Field
17. Numerical Field
18. Group Box
19. Time Field
20. Currency Field
21. Pattern Field
22. Table Control
23. Navigation Bar
24. Image Control
25. File Selection
26. Spin Button
27. Scrollbar

Form Design

The Form Design toolbar opens a form in Design Mode so that a form can be edited. You cannot 
activate the controls of the form or edit contents in Design Mode. However, you can change the 
position and size of the controls, edit other properties, and add or delete controls in Design 
Mode.

1. Select
2. Control Properties
3. Form Properties
4. Position and Size (F4)
5. Form Navigator
6. Activation Order
7. Add Field
8. Automatic Control Focus
9. Bring to Front (Ctrl+Shift++)

10. Send to Back (Ctrl+Shift+-)

11. Group (Ctrl+Shift+G)
12. Ungroup (Ctrl+Alt+Shift+G)
13. Enter Group (F3)
14. Exit Group (Ctrl+F3)
15. Align
16. Open in Design Mode
17. Grid
18. Snap to Grid
19. Helplines While Moving

Form Navigation

The Form Navigation toolbar provides tools to edit a database table or to control the data view. 
The toolbar is normally displayed at the bottom of a document that contains fields that are linked 
to a database. The Form Navigation toolbar is only active when forms are connected to a 
database.

The Form Navigation toolbar allows you to move within records as well as to insert and to delete 
records. If data is saved in a form, the changes are transferred to the database. This toolbar also 
provides tools providing sort, filter, and search functions for data records.
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1. Find Record
2. Record
3. Absolute Record
4. Text -> Record
5. Total No. of Records
6. First Record
7. Next Record
8. Last Record
9. New Record

10. Save Record
11. Undo Data entry

12. Delete Record
13. Refresh
14. Refresh Control
15. Sort
16. Sort Ascending
17. Sort Descending
18. AutoFilter
19. Apply Filter
20. Form-Based Filters
21. Reset Filter/Sort
22. Data source as Table

Glue Points

The Gluepoints toolbar provides tools to insert a glue point or modify the properties of a glue 
point. A glue point is a point where you can attach a connector. By default, LibreOffice 
automatically places a glue point at the center of each side of the bounding rectangle for every 
object you create.

1. Insert Glue Point
2. Exit Direction Left
3. Exit Direction Top
4. Exit Direction Right
5. Exit Direction Bottom
6. Glue Point Relative

7. Glue Point Horizontal Left
8. Glue Point Horizontal Center
9. Glue Point Vertical Top

10. Glue Point Vertical Center
11. Glue Point Vertical Bottom

Image

The Image toolbar provides tools to edit, modify, align, reposition and resize images. The Image 
toolbar only becomes active and available when an image is selected in a presentation. The 
Image toolbar automatically replaces the Line and Filling toolbar when it becomes active.

1. Position and Size (F4)
2. Align
3. Left
4. Centered
5. Right
6. Top
7. Center
8. Bottom
9. Bring to Front (Ctrl+Shift++)

10. Bring Forward (Ctrl++)
11. Send Backward (Ctrl+-)
12. Send to Back (Ctrl+Shift+-)
13. In Front of Object
14. Behind Object

15. Reverse
16. Line Style
17. Line Width
18. Line Color
19. Area Style/Filling
20. Fill Color
21. Shadow
22. Filter
23. Image Mode
24. Crop
25. Vertically
26. Horizontally
27. Transformations
28. Color

12 | Appendix B, Toolbars



29. Line
30. Area

31. Animation
32. Interaction

Insert

The Insert toolbar allows you to insert different types of objects into your presentation.

1. New Page (Ctrl+M)
2. Floating Frame
3. Insert Page from File
4. Table
5. Image

6. Media
7. Formula
8. Chart
9. OLE Object

Legacy Circles and Ovals

The Legacy Circles and Ovals toolbar provides tools to insert different types of circles and ovals 
into your presentation.

1. Ellipse
2. Circle
3. Ellipse Pie
4. Circle Pie
5. Ellipse Segment
6. Circle Segment
7. Ellipse Unfilled

8. Circle Unfilled
9. Ellipse Pie Unfilled

10. Circle Pie Unfilled
11. Ellipse Segment Unfilled
12. Circle Segment Unfilled
13. Arc
14. Circle Arc

Legacy Rectangles

The Legacy Rectangles toolbar provides tools to insert different types of rectangles and squares
into your presentation.

1. Rectangle
2. Square
3. Rectangle Rounded
4. Rounded Square

5. Rectangle Unfilled
6. Square Unfilled
7. Rounded Rectangle Unfilled
8. Rounded Square Unfilled

Line and Filling

The Line and Filling toolbar lets you modify the main properties of an object. The tools and drop 
down lists vary according to the type of object selected.

1. Position and Size (F4)
2. Align

3. Left
4. Centered
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5. Right
6. Top
7. Center
8. Bottom
9. Arrange

10. Bring to Front (Ctrl+Shift++)
11. Bring Forward (Ctrl++)
12. Send Backward (Ctrl+-)
13. Send to Back (Ctrl+Shift+-)
14. In Front of Object
15. Behind Object
16. Reverse
17. Line Style
18. Line Width
19. Line Color
20. Area Style/Filling

21. Fill Color
22. Shadow
23. Arrow Style
24. Vertically
25. Horizontally
26. Transformations
27. Distribution
28. Line
29. Area
30. 3D Effects
31. Image Map
32. Animation
33. Interaction
34. Styles (F11)
35. Grid
36. Helplines While Moving

Master View

The Master View toolbar provides tools where you can create a new master slide, rename a 
master slide, delete a master slide, and close master slide view. This toolbar is only active when 
Impress is in master view.

1. New Master
2. Rename Master

3. Delete Master
4. Close Master View

Media Playback

The Media Playback toolbar provides the standard tools required to insert, view, play and listen to
audio and video files. Impress supports many different media formats.

1. Insert Audio or Video
2. Play
3. Pause
4. Stop
5. Repeat

6. Position
7. Mute
8. Volume
9. View

Options

The Options toolbar allows you to define various settings for newly created presentation 
documents. For example how objects snap to the grid, object editing.

1. Rotation Mode after Clicking Object
2. Grid
3. Display Snap Guide
4. Helplines While Moving

5. Snap to Grid
6. Snap to Snap Guides
7. Snap to Page Margins
8. Snap to Object Borders
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9. Snap to Object Points
10. Allow Quick Editing
11. Select Text Area Only

12. Double-click to edit Text
13. Modify Object with Attributes
14. Exit All Groups

Outline

The Outline toolbar provides frequently used editing tools for working with text outlines.

1. Demote (Alt+Shift+Right)
2. Promote (Alt+Shift+Left)
3. Move Down (Alt+Shift+Down)
4. Move Up (Alt+Shift+Up)
5. Show Formatting

6. Black & White View
7. Show Only First Level
8. Show All Levels
9. Hide Subpoints

10. Show Subpoints

Presentation

The Presentation toolbar provides frequently used tools for working with presentations.

1. New Slide
2. Duplicate Slide
3. Rename Slide
4. Delete Slide
5. Slide Layout
6. Change Slide Master
7. Expand Slide
8. Go to First Slide

9. Go to Previous Slide
10. Go to Next Slide
11. Go to Last Slide
12. Move Slide to Start
13. Move Slide Up
14. Move Slide Down
15. Move Slide to End

Slide Sorter

The Slide Sorter toolbar allows you to select slides in the current presentation and start a 
presentation from the first slide.

1. Select 2. Start from First Slide (F5)

Slide View

The Slide View toolbar opens with the Slide Sorter view.

1. Rehearse Timings
2. Show Slide

3. Hide Slide
4. Slides per Row
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Standard

The Standard toolbar is common to all LibreOffice modules and provides the most common tools 
when creating and editing documents using LibreOffice. The Standard toolbar will differ between 
the different LibreOffice modules to allow for different toolsets used in creating the different types 
of documents.

1. Load URL
2. New (Ctrl+N)
3. Templates (Ctrl+Shift+N)
4. Open (Ctrl+O)
5. Open Remote
6. Save (Ctrl+S)
7. Save As (Ctrl+Shift+S)
8. Email
9. Edit Mode (Ctrl+Shift+M)

10. PDF
11. Print Directly
12. Print (Ctrl+P)
13. Cut (Ctrl+X)
14. Copy (Ctrl+C)
15. Paste (Ctrl+V)
16. Close (installed)
17. Clear (Ctrl+Shift+M)
18. Undo (Ctrl+Z)
19. Redo (Ctrl+Y)
20. Find and Replace (Ctrl+H)
21. Auto Spellcheck (Shift+F7)
22. Zoom & Pan
23. Zoom

24. Grid
25. Helplines While Moving
26. Display Views
27. Views Tab Bar
28. Format Slide
29. Master Slide
30. Start from First Slide (F5)
31. Start from Current Slide (Shift+F5)
32. Table
33. Image
34. Media
35. Chart
36. Text Box (F2)
37. Symbol (toolbar name Insert Special 

Characters)
38. Vertical Text
39. Insert Fontwork
40. Hyperlink (Ctrl+K)
41. Draw Functions
42. Interaction
43. LibreOffice Help
44. What’s That

Standard (Single Mode)

The Standard (Single Mode) toolbar becomes active when the user interface is switched to single
mode. Go to View > User Interface on the Menu bar and select Single Toolbar.

1. New (Ctrl+N)
2. Open (Ctrl+O)
3. Save (Ctrl+S)
4. PDF
5. Print (Ctrl+P)
6. Print Preview (Ctrl+Shift+O)
7. Undo (Ctrl+Z)
8. Redo (Ctrl+Y)
9. Find and Replace (Ctrl+H)

10. Clone
11. Spelling
12. Entire Page
13. New Slide
14. Duplicate Slide

15. Rename Slide
16. Delete Slide
17. Slide Layout
18. Display Views
19. Text Box (F2)
20. Image
21. Media
22. Chart
23. Table
24. Insert Fontwork
25. Line
26. Rectangle
27. Ellipse
28. Lines and Arrows
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29. Curves and Polygons
30. Connectors
31. Basic Shapes
32. Symbol Shapes
33. Arrow Shapes
34. Flowchart Shapes
35. Callout Shapes
36. Star Shapes
37. 3D Objects
38. Position and Size (F4)
39. Rotate
40. Flip
41. Align

42. Arrange
43. Distribution
44. Group (Ctrl+Shift+G)
45. Ungroup (Ctrl+Alt+Shift+G)
46. Enter Group (F3)
47. Exit Group (Ctrl+F3)
48. Select
49. Entire Page
50. Zoom & Pan
51. Zoom
52. Start from First Slide (F5)
53. Start from Current Slide (Shift+F5)

Standard (Viewing Mode)

The Standard (Viewing Mode) toolbar provides tools to save, edit and distribute a document.

1. Save As (Ctrl+Shift+S)
2. Edit Mode (Ctrl+Shift+M)
3. Read Only Mode
4. Email
5. PDF
6. EPUB

7. Print Directly
8. Print (Ctrl+P)
9. Copy (Ctrl+C)

10. Find and Replace (Ctrl+H)
11. Zoom
12. Start from First Slide (F5)

Table

The Table toolbar provides tools to edit and format a table placed on a slide. This toolbar only 
becomes active when a table is selected.

1. Table
2. Border Style
3. Border Color
4. Borders (Shift to overwrite)
5. Area Style/Filling
6. Merge Cells
7. Split Cells
8. Optimize
9. Top

10. Center
11. Bottom

12. Insert Row Above
13. Insert Row Below
14. Insert Column Before
15. Insert Column After
16. Delete Row
17. Delete Column
18. Select Table
19. Select Column
20. Select Row
21. Table Design
22. Table Properties

Text

The Text toolbar provides tools to insert text boxes and callouts into a slide
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1. Text Box (F2)
2. Fit Text in Textbox Size
3. Callouts

4. Vertical Text
5. Fit Vertical Text to Frame
6. Vertical Callouts

Text Formatting

The Text Formatting toolbar provides tools for formatting text and alignment commands. This 
toolbar becomes active when text in a text box or graphic object has been selected and it 
automatically replaces the Line and Filling toolbar.

1. Font Name
2. Font Size
3. Increase (Ctrl+])
4. Decrease (Ctrl+[)
5. Bold (Ctrl+B)
6. Italic (Ctrl+I)
7. Underline
8. Double Underline
9. Strikethrough

10. Overline
11. Superscript (Ctrl+Shift+P)
12. Subscript (Ctrl+Shift+B)
13. Shadow
14. Outline
15. Clear (Ctrl+Shift+M)
16. lowercase
17. UPPERCASE
18. SMALL CAPITALS

19. Font Color
20. Highlight Color
21. Bullets

22. Numbering
23. Outline
24. Left (Ctrl+L)
25. Center (Ctrl+E)
26. Right (Ctrl+R)
27. Justified (Ctrl+J)
28. Top
29. Center
30. Bottom
31. Line Spacing
32. Character Spacing
33. Increase
34. Decrease
35. Text direction from left to right
36. Text direction from top to bottom
37. Left-To-Right
38. Right-To-Left
39. Select All (Ctrl+A)
40. Character
41. Paragraph

Transformations

The Transformations toolbar provides tools to modify the shape, orientation or fill of selected 
object(s).

1. Rotate
2. Flip
3. In 3D Rotation Object
4. Set in Circle (perspective)
5. Set to circle (slant)

6. Distort
7. Transparency tool (Interactive transparency 

tool)
8. Gradient tool (Interactive gradient tool)

TSCP Classification

The TSCP Classification toolbar provides tools to help in selecting the security of a document. 
LibreOffice adds custom fields in the document properties (File > Properties > Custom 
Properties) to store the classification policy as document metadata. TSCP stands for 
Transglobal Secure Collaboration Participation.
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1. Apply document classification (Level) 2. Manage Document Classification

Zoom

The Zoom toolbar provides tools to reduce or enlarge the screen display of the current 
document..

1. Zoom In
2. Zoom Out
3. 100%
4. Zoom Previous
5. Zoom Next
6. Entire Page

7. Page Width
8. Optimal
9. Object Zoom

10. Zoom & Pan
11. Shift
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