
Draw Guide

Chapter 7  
Working with 3D Objects



Copyright

This document is Copyright © 2005–2012 by its contributors as listed below. You may distribute it 
and/or modify it under the terms of either the GNU General Public License 
(http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution 
License (http://creativecommons.org/licenses/by/3.0/), version 3.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors
John Cleland Martin Fox Jean Hollis Weber
John A Smith Peter Schofield

Feedback
Please direct any comments or suggestions about this document to: 
documentation@global.libreoffice.org

Acknowledgments
This chapter is based on an original French document written for OpenOffice.org 1.x by Michel 
Pinquier (translated into English by Alex Thurgood) and previous content revised by Jim Taylor. 
The chapter was revised for OpenOffice.org 2.0 by Linda Worthington, Daniel Carrera, Jean Hollis 
Weber, and Agnes Belzunce, and later translated into German by Wolfgang Uhlig. The German 
revisions were then translated into English and revised for OpenOffice.org 3.3 and LibreOffice 3.3 
by Martin Fox. Other contributors included Peter Hillier-Brook, Hazel Russman, Gary Schnabl, and 
Claire Wood.

Publication date and software version
Published 4 October 2012. Based on LibreOffice 3.5.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. 
The table below gives some common substitutions for the instructions in this chapter. For a more 
detailed list, see the application Help.

Windows or Linux Mac equivalent Effect

Tools > Options 
menu selection

LibreOffice > Preferences Access setup options

Right-click Control+click and/or right-
click depending on 
computer setup

Open a context menu

Ctrl (Control) z (Command) Used with other keys

F5 Shift+z+F5 Open the Navigator

F11 z+T Open the Styles and Formatting window

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation

http://www.libreoffice.org/get-help/documentation
mailto:documentation@global.libreoffice.org
http://creativecommons.org/licenses/by/3.0/
http://www.gnu.org/licenses/gpl.html


Contents

Copyright.............................................................................................................................. 2

Note for Mac users...............................................................................................................2

Introduction.......................................................................................................................... 4

Creating.................................................................................................................................4
Extrusion...................................................................................................................................... 4

Body rotation................................................................................................................................5
To 3D rotation.......................................................................................................................... 5
In 3D rotation...........................................................................................................................5

Ready-made 3D objects.............................................................................................................. 6

3D scenes.................................................................................................................................... 6

3D settings................................................................................................................................... 6

Text and Fontwork....................................................................................................................... 7
Text......................................................................................................................................... 7
Fontwork................................................................................................................................. 8

Editing 3D objects................................................................................................................8
Rotation....................................................................................................................................... 8

3D-Settings rotation..................................................................................................................... 9

3D effects................................................................................................................................... 10
3D Effects dialog................................................................................................................... 11
3D conversion....................................................................................................................... 11
3D Effects - Geometry........................................................................................................... 12
3D Effects – Shading............................................................................................................. 14
3D Effects – Illumination........................................................................................................ 16
3D Effects – Textures............................................................................................................ 17
3D Effects - Material.............................................................................................................. 19

3D-Settings toolbar editing......................................................................................................... 21

Combining 3D objects....................................................................................................... 21

Working with 3D Objects 3



Introduction

Although Draw does not match the functionality of leading drawing or picture editing programs, it is 
capable of producing and editing 3D drawings and pictures.

Draw offers two different types of 3D objects: 3D bodies and 3D shapes. Depending on which type 
you choose, there are different possibilities for editing an object (rotation, illumination, perspective). 
3D shapes are easier to set up and edit than 3D bodies, but 3D bodies allow for more 
customization.

Creating

You can create 3D bodies using extrusion, body rotation, and 3D settings on objects and text.

If the 3D icons are not visible on the Drawing toolbar (Figure 1), click on the small triangle to the 
right of the Drawing toolbar, then select Visible Buttons > To 3D or To 3D Rotation Object from 
the available list of icons (Figure 2).

Figure 1: Drawing toolbar

Figure 2: Available 3D icons

Extrusion
1) Draw an object using one of the shape tools on the Drawing toolbar, for example 

square/rectangle, circle/ellipse, or text.

2) Make sure the object you want to convert to 3D is selected.

3)  Click the To 3D  icon on the Drawing toolbar, or go to Modify > Convert > To 3D, or 
right-click on the object and select Convert > To 3D, from the context menu and your 
selected 2D object is converted to 3D (Figure 3).

Extrusion is a procedure by which parallel surfaces are moved to create a 3D object. It happens 
when a 2D surface is moved forward out of the drawing level. Then, at the same time, the object is 
slightly tilted and central projection turned on so that the converted object is better recognized as a 
3D object. Draw uses a default value for extrusion (body depth) based on the size of a 2D object. 
This value can be changed after after carrying out extrusion; see “Editing 3D objects” on page 8 for 
more information.

Figure 3: Extruding a 3D object from a 2D object
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Body rotation

To 3D rotation
To 3D body rotation converts an object into 3D by rotating the object using the left edge of the 
object as the axis of rotation. Body rotation is best shown by using a thick line as an example 
object. The actual 3D shape created depends on line thickness, line angle and line shape (Figure 
4).

1) Draw a line and make sure it is selected.

2) To convert the line into a 3D object, click on the To 3D Rotation Object icon  on the 
Drawing toolbar or got to Modify > Convert > To 3D Rotation object on the main menu 
bar.

Figure 4: To 3D body rotation

In 3D rotation
In 3D body rotation converts an object into 3D by rotating the object using a movable axis of 
rotation. The default location of this rotation axis is the left edge of the object, but the location and 
angle of rotation can be adjusted, allowing you to create 3D objects that have different shapes. 
Body rotation is best shown by using a thick line as an example object. The actual 3D shape 
created also depends on line thickness, line angle and line shape (Figure 5).

1) Draw a line and make sure it is selected.

2) Click on the small triangle next to the Effects icon on the Drawing toolbar and select the In 

3D Rotation Object icon  from the popup toolbar.

Figure 5: In 3D body rotation
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3) Alternatively, go to View > Toolbars > Mode on the main menu bar to open the Mode 

toolbar and select the In 3D Rotation Object icon .

4) If necessary, adjust the position and angle of the rotation axis. This is shown as a dashed 
line with rotation points at each end.

5) Click anywhere outside the object and it is converted into a 3D shape.

Note

The shape of the Effects icon on the Drawing toolbar changes depending on the 
last tool that was used.

If the Effects icon is not visible on the Drawing toolbar, then click the small triangle 
on the right of the toolbar and click on Visible Buttons, then select Effects.

Ready-made 3D objects
LibreOffice has a collection of ready-made 3D objects available for immediate use. To access 
these 3D objects, go to View > Toolbars > 3D Objects on the main menu bar or click on the 3D 
Objects icon on the Drawing toolbar to open the 3D-Objects toolbar (Figure 6).

Figure 6: 3D Objects toolbar

Note

The shape of the 3D Objects icon on the Drawing toolbar changes depending on 
the last tool that was used.

If the 3D Objects icon is not visible on the Drawing toolbar, then click the small 
triangle on the right of the toolbar and click on Visible Buttons, then select 3D 
Objects.

Drawing 3D objects using this toolbar is exactly the same as drawing basic shapes. See Chapter 2 
Drawing Basic Shapes in this guide for more information.

3D scenes
When a 3D object is created, it becomes what is known as a 3D scene. Draw treats this 3D scene 
exactly like a group of objects. Press the F3 key, or right click on a 3D object and select Enter 
Group, or click on Modify > Enter Group on the main menu bar so that you edit the individual 
elements of a 3D scene. See Chapter 6 Editing Pictures in this guide for more information.

To exit a 3D scene, press the Ctrl + F3 key combination, or right click on a 3D object and select 
Exit Group, or click on Modify > Exit Group on the main menu bar.

3D settings
A 2D object can be converted to 3D using using the Extrusion On/Off icon on the 3D-Settings 
toolbar (Figure 7 and Figure 8). The tools provided on the 3D-Settings toolbar are then used to edit 
the 3D object.

1) To open the 3D-Settings toolbar, go to View > Toolbars > 3D-Settings on the main menu 
bar.

2) Select an object and click on the Extrusion On/Off icon to convert the object to 3D. The 
tools on the 3D-Settings toolbar then become available for use.
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Figure 7: 3D-Settings toolbar

Figure 8: Available 3D icons

• Extrusion On/Off – switches the 3D effects on or off for the selected object.

• Tilt Down – tilts the selected object downward by 5 degrees each time the icon is used.

• Tilt Up – tilts the selected object upward by 5 degrees each time the icon is used.

• Tilt Left – tilts the selected object left by 5 degrees each time the icon is used.

• Tilt Right – tilts the selected object right by 5 degrees each time the icon is used.

• Depth – opens the extrusion depth dialog allowing you to set the depth from an object.

• Direction – opens the extrusion direction dialog allowing you to set extrusion direction and 
perspective or parallel extrusion.

• Lighting – opens the extrusion lighting dialog allowing you to set lighting direction and 
intensity.

• Surface – opens the extrusion surface dialog allowing you to set surface material or 
wireframe display.

• 3D Color – opens the extrusion color toolbar allowing you to set the color used for the 
extrusion.

Note
3D settings cannot be used on 2D objects converted to 3D using the To 3D icon on 
the Drawing toolbar.

Text and Fontwork

Text
Draw treats text like an object which can be converted to 3D as easily as any other object in your 
drawing.
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1) Click on the Text icon  on the Drawing toolbar.

2) Move the cursor onto your drawing and click once to create a text box, then type your text.

3) Click again on the text box to select it. Selection handles show on the text box.

4) Click the To 3D  icon on the Drawing toolbar, or go to Modify > Convert > To 3D, or 
right-click on the object and select Convert > To 3D from the context menu and your 
selected text is converted to 3D.

5) See “Editing 3D objects” on page 8 on how to change the 3D effects for your 3D text.

Fontwork
The Fontwork Gallery in Draw contains a set of templates allowing you to create artistic text for 

your drawings. Click on the Fontwork icon  on the Drawing toolbar to open the Fontwork 
Gallery (Figure 9). See Chapter 5 Managing Graphic Objects in the Impress Guide for more 
information on the Fontwork Gallery and its tools.

After creating your fontwork, it can be converted to a 3D object using the procedures given in “3D 
settings” on page 6 and “Text” on this page.

Figure 9: Fontwork Gallery

Editing 3D objects

Rotation
Rotating 3D objects is similar to rotation for 2D objects (see Chapter 3 Working with Objects and 
Object Points in this guide for more information) plus rotation about global axes. Click once on a 
3D object to select it and then click on it again to go into rotation mode.
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Figure 10: Rotating 3D objects

The corner selection handles allow you to rotate the 3D object in exactly the same way as rotating 
a 2D object.

The center selection handles at the sides and top and bottom of a selected object allow you to 
rotate a 3D object about the vertical and horizontal axes respectively (Figure 10).

When you move your cursor onto a 3D object, it normally changes to a double-headed circular 
arrow. Press and keep the mouse button pressed and, as you move the cursor, the 3D object is 
rotated globally about any axes. Release the mouse button when you are satisfied with the effect.

The rotation point  in the center of a selected 3D object can be moved to change the center of 
rotation and create a different effect when you carry out rotation. Move your cursor over the 
rotation point until it changes (normally a pointed fist), then click and hold. Drag the rotation point to 
a new position and release the mouse button.

3D-Settings rotation
3D objects created using the Extrusion On/Off tool on the 3D-Settings toolbar (see “3D settings” 
on page 6) are rotated or tilted using the Tilt tools on the 3D-Settings toolbar (highlighted in Figure 
11). Each time a Tilt tool is clicked, the object is moved 5 degrees down, up, left or right about the 
horizontal or vertical axes.

Double clicking on this type of 3D object activates the rotation handles with only the corner rotation 
handles active. When you move your cursor over a corner rotation handle, the cursor normally 
changes to a circular double-headed arrow allowing you to rotate the 3D object as you move the 
cursor. This rotation is also carried out on the underlying 2D object.

This type of 3D object can also be rotated using the Position and Size dialog. Select the 3D object 
and go to Format > Position and Size, or right click on the selected object and select Position 
and Size from the context menu, or press the F4 key. Click on the Rotation tab to open the 
Rotation dialog (Figure 12) where you can set the pivot point and rotation angle.

Figure 11: Tilt tools on 3D-Settings toolbar
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Figure 12: Rotation dialog

Figure 13: 3D Effects dialog - Geometry

3D effects
The 3D Effects dialog (Figure 13) offers a wide range of possible settings for 3D objects created 
using the following methods. This dialog can also be used to convert a 2D object to 3D using the 
tools in the bottom left corner of the dialog:

• “Extrusion” (see page 4).
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• “Body rotation” (see page 5).

• “Ready-made 3D objects” (see page 6).

To open the 3D Effects dialog, select your 3D object and right-click on the object then select 3D 
Effects from the context menu.

Note

You can add a 3D Effects icon  to the Drawing toolbar, or any other toolbar, by 
going to View > Toolbars > Customize or clicking on the small triangle at the right 
of the toolbar and selecting Customize Toolbar. When the Customize dialog 
opens, go to Toolbars, select the toolbar and click on the Add button. This will 
display the Add Commands dialog. The 3D Effects icon is located in the Options 
category.

3D Effects dialog
The 3D Effects dialog is divided into five main areas as follows:

• Geometry  – adjusts the shape of the selected 3D object; see “3D Effects - 
Geometry” on page 12 for more information.

• Shading  – sets the shading and shadow options for the selected 3D object; see “3D 
Effects – Shading” on page 14 for more information.

• Illumination  – defines the light source for the selected 3D object; see “3D Effects – 
Illumination” on page 16 for more information.

• Textures  – sets the properties of the surface texture of the selected 3D object and is 
only available after surface textures have been applied to the 3D object; see “3D Effects – 
Textures” on page 18 for more information.

• Material  – changes the coloring of the selected 3D object; see “3D Effects - Material” 
on page 19 for more information.

Any of these 3D settings that you apply to a 3D object are not carried out until you click on the 

Assign icon . This allows you to make all the 3D Effects changes first before applying them to 
your 3D object.

3D conversion
In the bottom left of all the Effects dialogs are tools allowing you to convert a 2D object to a 3D 
object and to change the projection used in a 3D object.

• Convert to 3D  – converts the selected object to 3D using extrusion; see “Extrusion” on 
page 4 for more information.

• Convert to Lathe Object  – converts a 2D object to 3D using body rotation; see “Body 
rotation” on page 5 for more information.

• Perspective On/Off  – switches perspective projection on or off for a 3D object. 
Perspective projection is where projecting lines from the center of projection pass through 
an imaginary plane until they meet at a point some distance from an object.
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3D Effects - Geometry
On the Geometry page of the Effects dialog (Figure 13 on page 10) you can make changes to the 
geometry of a 3D object.

• Geometry – define the shape properties for the selected 3D object.

– Rounded edges – enter the amount by which you want to round the corners of the 
selected 3D object. Figure 14 shows an example of a 3D cylinder with the rounded 
edges increased to 30%.

Figure 14: Example of increased rounded edges

– Scaled depth – enter the amount by which to increase or decrease the frontal area of 
the selected 3D object. Figure 15 shows an example of a 3D cylinder with the scaled 
depth increased to 150%. A scaled depth of less than 100% decreases the frontal area.

Figure 15: Example of increased scaled depth

– Rotation angle – enter the angle in degrees to rotate the selected 3D rotation object. 
This option is only available when a 2D object is converted to 3D using the To 3D 
Rotation Object tool. Figure 16 shows an example of a 2D circle converted to 3D and 
the rotation angle changed to 175 degrees.
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Figure 16: Example of a 175 deg rotation angle

– Depth – enter the extrusion depth for the selected 3D object. This option is not valid for 
3D rotation objects. Figure 17 shows an example of a 2D circle converted to a 3D 
cylinder with the extrusion depth increased to 3 cm.

Figure 17: Example of increased depth

• Segments – changes the number of segments that Draw uses to draw a 3D rotation 
object. The higher the number of segments, the smoother the object surface will be. 
However, a high segment number may increase the time it takes to generate the 3D object 
on your display. Figure 18 shows the difference on a 3D sphere when the segments have 
been increased from 10 to 30 segments horizontally and vertically.

– Horizontal – enter the number of horizontal segments to use in the selected 3D rotation 
object.

– Vertical – enter the number of vertical segments to use in the selected 3D rotation 
object.

Figure 18: Example of using segments

• Normals – modifies the rendering style of the 3D surface (Figure 19 and Figure 20).

– Object-Specific  – renders the 3D surface according to the shape of the object. For 
example, a circular shape is rendered with a spherical surface.

– Flat  – renders the 3D surface as polygons.

– Spherical  – renders a smooth 3D surface regardless of the shape of the object.
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Figure 19: Example of using Object Specific, Flat and Spherical

Figure 20: Example of using Invert Normals and Double-sided Illumination

– Invert Normals  – inverts or reverses the light source.

– Double-sided Illumination  – lights an object from the outside and the inside of the 
object. To use as an ambient light source, click this button, and then click the Invert 
Normals button.

– Double-Sided  – closes the shape of a 3D object that was created by extruding a 
free-form line.

3D Effects – Shading
On the Shading page of the Effects dialog (Figure 21) you can set the shading and shadow options 
for the selected 3D object.

• Shading – specifies the type of shading applied to a 3D object (Figure 22).

– Mode – selects the shading method used on a 3D object.

– Flat – assigns a single color of shading to a single segment on the surface of the object.

– Gouraud – blends shading colors across the segments.

– Phong – averages the shading color of each pixel in a segment based on the pixels that 
surround it, and requires the most processing power.

• Shadow – adds or removes a shadow from a selected 3D object (Figure 23).

– 3D Shadowing On/Off  – switches the shadowing on or off.

– Surface angle – enter an angle from 0 to 90 degrees for casting a shadow.
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Figure 21: 3D Effects dialog - Shading

Figure 22: Example of using Shading

Figure 23: Example of using Shadow
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Figure 24: Example of using Camera

• Camera – sets the camera options for a selected 3D object as if you are actually using a 
camera to take a photograph (Figure 24).

– Distance – enter the distance to leave between the camera and the center of the 
selected object.

– Focal length – enter the focal length of the camera lens, where a small value 
corresponds to a fish-eye lens and a large value to a telephoto lens.

Figure 25: 3D Effects dialog - Illumination

3D Effects – Illumination
On the Illumination page of the Effects dialog (Figure 25) you define how a 3D object is lit, and the 
settings apply to all 3D objects in a scene. You can specify the light source for the object, as well 
as the color of the light source and of the ambient light.

By default one light source is already selected when you open the Illumination page. However, you 
can select another light source or use more than one light source for illumination. A maximum of 
eight sources can be used and each light source can use a different color. At least one light source 
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must be active; otherwise, the rendering and shading functions on 3D Effects will not function 
correctly.

1) Double click on a Light source icon  to turn the light source on, or select a light source 
and press the space bar. 

2) Select a color for the light from the drop down list for Light source. A different color can be 
used for each light source selected.

3) If necessary, select a color from the drop down list for Ambient light to set the color of the 
surrounding light.

4) To deselect a light source, select the light source and click on it again.

The light source location and color are shown in the lower right corner of the Illumination page 
(Figure 26). The vertical slider bar adjusts the lighting angle and the horizontal slider bar rotates 
the light about the object. Alternatively you can click on the light point and drag the light source to 
where you want it.

Figure 26: Adjusting a light source

Figure 27: 3D Effects - Textures
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To change the preview from a sphere to a cube, click on the small square to the right of the 
horizontal slider bar and below the vertical slider bar.

Each light source selected is shown as a small colored sphere in the color specified for it. The 
larger colored sphere indicates the active light source.

3D Effects – Textures
On the Textures page of the Effects dialog (Figure 27) you can set the properties of the surface 
texture for a selected 3D object. The Textures page is only available after you have set the Area 
Fill of a 3D object to Gradient, Hatching or Bitmap.

• Type – sets the color properties of the texture.

– Black & White  – converts the texture to black and white.

– Color  – converts the texture to color.

• Mode – shows or hides shading.

– Only Texture  – applies the texture without shading.

– Texture and Shading  – applies the texture with shading. To define the shading 
options for the texture, use the Shading page of this dialog.

• Projection X – sets the options for displaying the texture along the X axis. Only one of the 
three following options can be selected.

– Object-Specific  – automatically adjusts the texture for best fit based on the shape 
and size of the object. This is the default setting.

– Parallel  – applies the texture parallel to the horizontal axis and is mirrored on the 
rear side of the object.

– Circular  – wraps the horizontal axis of the texture pattern around an object.

• Projection Y – sets the options for displaying the texture along the Y axis. Only one of the 
three following options can be selected.

– Object-Specific  – automatically adjusts the texture for best fit based on the shape 
and size of the object. This is the default setting.

• Parallel  – applies the texture parallel to the vertical axis and is mirrored on the rear side 
of the object.

– Circular  – wraps the vertical axis of the texture pattern around an object.

• Filter – filters out noise that can occur when you apply a texture to a 3D object.

– Filtering On/Off  – blurs the texture slightly to remove unwanted speckles.

Before Textures can be used, you must change the area fill of your 3D object. For more 
information, see Chapter 4 Changing Object Attributes.

1) Select your 3D object.

2) Right click on your 3D object and select Area from the context menu or go to Format > 
Area on the main menu bar to open the Area dialog.

3) From the Fill drop down list, select Gradient, Hatching or Bitmap.

4) Select the fill from the list that appears and then click the OK button. The texture is then 
applied to your selected 3D object.
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Figure 28: 3D Effects - Material

3D Effects - Material
On the Materials page of the Effects dialog (Figure 28) you can change the appearance of a 3D 
object to represent different materials.

• Material – assigns a predefined color scheme or lets you create your own color scheme.

– Favorites – select a predefined color scheme, or select a custom color scheme that has 
been user defined.

– Object color – select the color that you want to apply to a 3D object.

– Illumination color – select the color to illuminate the object and brightening parts of the 
object which lie in shadow making the object seem more illuminated.

• Specular – sets the light reflection properties for the selected object simulating the 
reflecting capacity of the surface. The position of the illuminated point is determined by the 
setting of the first light source.

– Color – select the color that you want the object to reflect.

– Intensity – enter the intensity of the specular effect.

• Color icon  – opens the Color dialog allowing you to define your own colors using the 
two-dimensional graphic and numerical gradient chart.

Tip
Do not use a very high brightness values for individual colors. These are all 
additive and it is easy to end up with a colored area that is white.

When you use individual color parameters additional effects can be produced, which are similar to 
the color parameters in “3D Effects – Illumination” on page 16.
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Materials and textures can be combined with each other and it is a matter of trial and error to 
achieve the desired result.

Note
Metallic and glass surfaces do not simulate well because the appearance of these 
materials is produced using reflection.

Illumination example

When textures are also used, the Illumination color is combined with the white color part of the 
texture (Figure 29). The left object has black Illumination and the right object bright green.

Figure 29: Example of material illumination

Specular example

For the left object in Figure 30, the specular color is the same as the object color and the 
illumination intensity is set to a low value to create the impression of a matt object surface.

Figure 30: Example of using specular illumination

For the right object in Figure 30, the color of the illumination point is the same as the light source 
color to create a shiny appearance to the object surface.

3D-Settings toolbar editing

3D objects created using the Extrusion On/Off tool  on the 3D-Settings toolbar (Figure 7 on 
page 7) are handled differently from other 3D objects. You have to use the tools on the 3D-Settings 
toolbar to make any changes to a 3D object created using the Extrusion On/Off tool. These tools 
are highlighted in Figure 31.

Figure 31: 3D-Settings toolbar - editing
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• Depth  – sets the extrusion depth and direction from the pop-up options.

• Direction  – sets a direction and a perspective or parallel extrusion from the pop-up 
options.

• Lighting  – sets the lighting direction and lighting intensity from the pop-up options.

• Surface  – sets the surface material or use a wireframe display from the pop-up 
options.

• 3D Color  – sets the extrusion color from the pop-up options..

The result of any changes made using these editing tools is applied to the selected 3D object 
immediately and the effect is displayed.

The 3D Effects dialog described in “3D effects” on page 10 cannot be used on 3D objects created 
using the Extrusion On/Off tool because the correct formatting results will not be achieved. If you 
have used the 3D Effects dialog in error, you can remove any incorrect formatting by going to 
Format > Default Formatting on the main menu bar.

Combining 3D objects

Multiple 3D objects can be grouped or combined together in the same way as 2D objects. See 
Chapter 5 Combining Multiple Objects for more information.
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