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What is Draw?

LibreOffice Draw is a vector graphics drawing program, although it can also perform some 
operations on raster graphics (pixels). Using Draw, you can quickly create a wide variety of 
graphical images.

Vector graphics store and display an image as an assembly of simple geometric elements such as 
lines, circles, and polygons, rather than a collection of pixels (points on the screen). Vector 
graphics allow for easier storage and scaling of the image.

Draw is fully integrated into the LibreOffice suite, and this simplifies exchanging graphics with all 
components of the suite. For example, if you create an image in Draw, reusing it in a Writer 
document is as simple as copying and pasting the image. You can also work with drawings directly 
from within Writer or Impress, using a subset of the functions and tools from Draw.

The functionality of LibreOffice Draw is extensive and, even though it was not designed to rival 
high-end graphics applications, it possesses more functionality than the drawing tools that are 
generally integrated with most office productivity suites.

A few examples of the drawing functions are: layer management, magnetic grid-point system, 
dimensions and measurement display, connectors for making organization charts, 3D functions 
that enable small three-dimensional drawings to be created (with texture and lighting effects), 
drawing and page-style integration, and Bézier curves.

This chapter introduces some features of Draw and does not attempt to cover all of the Draw 
features. See the Draw Guide and the Help for more information.

Draw main window

The main components of the Draw main window are shown in Figure 1.

Workspace
The large area in the center of the Draw main window (Workspace) is where you create your 
drawings. This drawing area can be surrounded with toolbars and information areas. The number 
and position of the visible tools vary with the task in hand and user preferences, therefore your 
setup may look different from Figure 1.

The maximum size of a drawing page in LibreOffice Draw is limited by your computer setup and 
the page size that you can set and use in your printer.

By default, the Workspace consists of three layers (Layout, Controls and Dimension Lines) and 
the tabs for these default layers appear in the bottom left corner of the Workspace. The default 
layers cannot be deleted or renamed, but you can add layers as and when necessary.

Pages pane
You can split drawings in Draw over several pages. Multi-page drawings are used mainly for 
presentations. The Pages pane, on the left side of the Draw main window, gives an overview of the
pages that you create in your drawing. If the Pages pane is not visible, go to View on the Menu bar
and select Page Pane. To make changes to the page order, drag and drop one or more pages.

Layers bar
A layer is a workspace where you insert your drawings elements and objects. The Layers bar is 
located on the bottom of the workplace and contains the guides for layer selection and layer 
command. For more information on layers, see “Working with layers“ on page 9.
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Figure 1: Draw main window

Sidebar
The Sidebar has five main decks in Draw. To expand a deck, click on its icon or click on the small 
triangle at the top of the icons and select a deck from the drop-down list. If the Sidebar is not 
visible, go to View on the Menu bar and select Sidebar from the submenu.

Properties
Contains panes for object properties: Page, Character, Paragraph, Lists, Area, Shadow, 
Line, and Position and Size. The visible panes change depending on the object selected.

Shapes

Provides quick selection of most items on the Drawing toolbar: Lines & Arrows, Curves, 
Connectors, Basic Shapes, Symbols, Block Arrows, Flowchart symbols, Callouts, Stars, and 
3D Objects.

Styles

Here you can edit and apply Drawing styles to objects within your drawing. When you edit a 
style, the changes are automatically applied to all of the elements formatted with this style in 
your drawing. (In Draw, Presentation styles are not available.)
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Gallery

Opens the Drawing gallery where you can insert an object into your drawing either as a copy 
or as a link. A copy of an object is independent of the original object. Changes to the original 
object have no effect on the copy. A link remains dependent on the original object. Changes 
to the original object are also reflected in the link.

Navigator
Opens the Draw Navigator, in which you can quickly move between pages in your drawing or
select an object on the drawing. It is recommended to give pages and objects in your 
drawing meaningful names so that you can easily identify them when using the Navigator.

Rulers
You should see rulers (bars with numbers) on the upper and left-hand sides of the workspace. If 
they are not visible, you can enable them by selecting View > Rulers in the Menu bar. The rulers 
show the size of a selected object on the page using double lines (highlighted in Figure 2). When 
no object is selected, they show the location of the mouse pointer, which helps to position drawing 
objects more accurately.

You can also use the rulers to manage object handles and guide lines when positioning objects.

The page margins in the drawing area are also represented on the rulers. You can change the 
margins directly on the rulers by dragging them with the mouse. The margin area is indicated by 
the grayed out area on the rulers as shown in Figure 2.

Figure 2: Rulers showing size of a selected object

To change the measurement units of the rulers, which can be defined independently, right-click on 
a ruler and select the measurement unit from the drop down list, as illustrated for the horizontal 
ruler in Figure 3.

Figure 3: Ruler units
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Status bar
The Status bar (Figure 4) is located at the bottom of the workspace in all LibreOffice components. 
It includes several Draw-specific fields. For details on the contents and use of these fields, see 
Chapter 1, Introducing LibreOffice, in this guide and Chapter 1, Introducing Draw, in the Draw 
Guide.

You can hide the Status Bar by going to View on the Menu bar and deselecting Status Bar.

Figure 4: Status bar

Note

The sizes are given in the current measurement unit. They might not be the same as 
the ruler units. The measurement unit on the Status bar is defined in Tools > Options 
> LibreOffice Draw > General, where you can also change the scale of the page.

Toolbars
To display or hide the various Draw toolbars, go to View > Toolbars on the Menu bar and select 
which toolbars you want to display. By default, the Standard toolbar is shown, but the Line and 
Filling, Text Formatting, and Options toolbars are not shown.

The tools available in the Draw toolbars are described below. See also “Editing objects” on page
22. The appearance of the toolbar icons may vary depending on your operating system and the 
selection of icon size and style in Tools > Options > LibreOffice > View. For more information 
about working with toolbars, see Chapter 1, Introducing LibreOffice, in this guide.

Standard toolbar
The Standard toolbar is the same for all LibreOffice components and is not described in 
detail in this chapter. By default, it is located just under the Menu bar.

Drawing toolbar
The Drawing toolbar contains all the necessary functions for drawing various geometric and 
freehand shapes and for organizing them on the page. By default, it is docked vertically on 
the left side of the Draw window.

Line and Filling toolbar
Use the Line and Filling toolbar to modify the main properties of a drawing object. The icons 
and pull-down lists vary according to the type of object selected. The functions on this toolbar
are also provided in the Properties pane of the sidebar when a drawing object is selected.

Text Formatting toolbar
If the selected object is text, the Sidebar shows relevant formatting choices in the Properties 
pane. If you have enabled both the Line and Filling toolbar and the Text Formatting toolbar, 
Draw switches between them depending on what object is selected.

Options toolbar
Use the Options toolbar to activate or deactivate various drawing aids.
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Working with layers

Use layers to create a complex drawing by stacking simpler drawings in each layer. The area of a 
layer that does not contain an object is transparent. You can add any number of layers in a drawing
document. Layers are common to all pages of the drawing.

A Draw document contains three default layers that you cannot delete or rename. Here are the 
common ways of using them:

• Layout: on this layer you place title, text, and object placeholders on your page.

• Controls: on this layer is always on the top of any other. Here you put buttons and other 
controls on your drawing.

• Dimension Lines: on this layer you place the dimension lines for your object, if relevant.

A layer can be set to visible or hidden, printable or not, locked or unlocked. To quickly toggle the 
attributes for a selected layer, you can use keyboard shortcuts:

• Shift+click – toggle visible/hidden layer

• Ctrl+click – lock/unlock layer

• Ctrl+Shift+click – toggle printable/not printable layer

Adding a layer
To add a layer to your drawing, select Insert > Layer from the Menu bar or right-click any layer tab 
in the Layers bar on the bottom of the workspace (Figure 1 on page 6) and choose Insert Layer. 
The Insert Layer dialog opens (Figure 5).

Add a name, title, and description of the layer. Select if you want it printable or not, visible or 
hidden, or locked to prevent further changes or accidental edits. A hidden layer still shows in the 
Layers bar, but its name is in blue. You cannot reorder layers in the Layers bar.

Note

Layers do not determine the stacking order of objects on the page, except for the 
Controls layer which is always in front of other layers. The stacking order of objects is 
determined by the sequence in which you add the objects. You can rearrange the 
stacking order by right-clicking on an object and choosing Arrange.

Figure 5: Insert Layer dialog
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Figure 6: Color Bar

Figure 7: Area dialog - Color

Choosing and defining colors

To display the color palette currently in use (Figure 6), select View > Color Bar. By default, the 
Color Bar is displayed to the right of the Workspace. To close the Color Bar, go to View on the 
Menu bar and deselect Color Bar. Using the Color Bar, you can rapidly choose the color of 
objects in your drawing (lines, areas, and 3D effects). The box with the X at the bottom left of the 
Color Bar corresponds to none (no color).
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Figure 8: SidebarArea and Line Color

Figure 9: Pick a Color dialog

You can also access several specialized color palettes in Draw, as well as change individual colors
to your own taste. To do this, go to Format > Area on the Menu bar to open the Color section in 
the Area dialog (Figure 7).
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To choose another palette, click on the Palette drop down list and select one of the palettes 
available in LibreOffice.

Alternatively, when an object in your drawing is selected, click on Area or Line in the Sidebar and 
select a color from the Color drop down list to change the area or line color of your object (Figure
8).

To add a custom color to the custom palette, first select your color by clicking the Pick button in the
Area – Color dialog to open the Pick a Color dialog (Figure 9). Here you can change any color by 
either dragging the round cursor to different locations on the visible color palette, or by modifying 
the numerical values in the fields provided to the right of the color palette in either CMYK or RGB 
color schemes.

For a more detailed description of color palettes and their options, as well as more on the 
difference between the CMYK and RGB color schemes, refer to Chapter 11, Advanced Draw 
Techniques, in the Draw Guide.

Drawing basic shapes
Draw provides a wide range of shapes, located in palettes accessed from the Drawing toolbar or 
from the Shapes deck in the Sidebar. This section describes only a few of the basic shapes, 
including text, which are treated as objects in Draw. See the Draw Guide for a complete description
of the shapes available.

Some of the icons on the Drawing toolbar will change according to the shape that has been 
selected from the choices available. Icons with tool palettes available are indicated by a small 
triangle to the right of the icon.

Note

When you draw a basic shape or select one for editing, the Information field in the 
status bar changes to reflect the present action: for example Line created, Text frame 
xxyy selected, and so on.

Drawing a straight line
 1) Use one of the following options to start drawing a line:

a) Click the insert Line icon in the Drawing toolbar.

b) Click the small triangle on the right of the Lines and Arrows icon in the Drawing 
toolbar and select the Insert Line icon from the drop down list.

c) Click the Insert Line icon in the Lines and Arrows section of the Shapes deck on the 
Sidebar.

Figure 10: Line starting point
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 2) Place the cursor at the point where you want to start the line (Figure 10) and drag the 
mouse while keeping the mouse button pressed.

 3) Release the mouse button at the point where you want to end the line. A selection handle 
appears at each end of the line, showing that this object is the currently selected object. 
The selection handle at the starting point of the line is slightly larger than the other selection
handle.

 4) Keep the Ctrl key pressed while drawing a line to enable the end of the line to snap to the 
nearest grid point.

Note

This is the default behavior of the Ctrl key. However, if the Snap to Grid option on the 
View > Grid menu has been selected, the Ctrl key deactivates the snap to grid activity.

 5) Keep the Shift key pressed while drawing a line to restrict the drawing angle of the line to a 
multiple of 45 degrees (0, 45, 90, 135, and so on).

Note

This is the default behavior of the Shift key. However, if the option When creating or 
moving objects in the Constrain Objects section of Tools > Options > LibreOffice 
Draw > Grid has been selected, the action of the Shift key is the opposite. Lines will 
automatically be drawn at a multiple of 45 degrees unless the Shift key is pressed.

 6) Keep the Alt key pressed while drawing a line to cause the line to extend outwards 
symmetrically in both directions from the start point. This lets you draw lines by starting 
from the middle of the line.

When a line is drawn, it uses default attributes. To change any of these attributes, select a line by 
clicking on it, then go to the Properties deck on the Sidebar and open the Line pane (Figure 8 on 
page 11). Alternatively, right-click and select Line from the context menu or go to Format > Line 
on the Menu bar to open the Line dialog (Figure 25 on page 26). Line style, line width, and line 
color can also be changed using the controls in the Line and Filling toolbar (if visible) at the top of 
the workspace.

Drawing an arrow
Arrows are drawn like lines. Draw classifies arrows as a subgroup of lines: lines with arrowheads. 
The information field on the Status bar shows them only as lines.

 1) Use one of the following options to start drawing an arrow:

a) Click the Lines and Arrows icon in the Drawing toolbar.

b) Click the small triangle on the right of the Lines and Arrows icon in the Drawing 
toolbar and select the type of arrow you require from the drop down list (Figure 11).

c) Click the icon of the type of arrow you require in the Lines and Arrows section of the 
Shapes deck on the Sidebar.

 2) Place the cursor at the point where you want to start the arrow and drag the mouse while 
keeping the mouse button pressed. The arrowhead is drawn at the end point of the arrow 
when you release the mouse button.

Figure 11: Lines and Arrows
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Note

Hovering the mouse cursor over each of the type of arrows available will tell you the 
type of line endings each icon will draw. The line endings available are lines, arrows, 
circles, squares, dimension lines and 45 degree lines.

The icon for the tool used most recently will already be selected on the Drawing 
toolbar to make it easier to use the same tool again.

After drawing the line, you can change the arrow style by opening the Line dialog 
(Figure 25 on page 23) and going to the Arrow Styles page. Here you will find a larger
selection of line endings to use in your drawing.

Drawing a dimension line
Dimension lines display a measurement of an object in the drawing (Figure 12). The dimension line
does not belong to the object itself, but it is usually placed close to it. An object can have as many 
dimension lines as necessary to indicate measures of its sides, edges, and distances.

 1) Use one of the following options to start drawing a dimension line:

a) Click the small triangle on the right of the Lines and Arrows icon in the Drawing 
toolbar and select Dimension Line from the drop down list (Figure 11).

b) Click the Dimension Line icon in the Lines and Arrows section of the Shapes deck on
the Sidebar.

 2) Place the cursor at the point where you want to start the dimension line and drag the 
mouse while keeping the mouse button pressed. The dimension line is drawn and 
automatically calculates and displays the linear dimension.

You can control the display of a dimension line components and appearance by selecting it, right-
clicking, and choosing Dimensions in the context menu to display the Dimension line dialog  
(Figure 13).

Figure 12: Measuring an object with 
dimension lines
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Figure 13: Dimension line settings dialog

Drawing rectangles or squares
Drawing a rectangle is similar to drawing a straight line.

 1) Click on the Rectangle icon in the Drawing toolbar or select Rectangle icon in Basic 
Shapes on the Shapes deck in the Sidebar. As you draw the rectangle with the mouse 
cursor, the rectangle appears with its bottom right corner attached to the cursor.

 2) Squares are 4 sided shapes with all sides of equal length. To draw a square, click on the 
Rectangle icon and hold down the Shift key while you draw a square.

 3) To draw a rectangle or square from its center rather than the bottom right corner, position 
your cursor on the drawing, press the mouse button and then hold down the Alt key while 
dragging with the cursor. The rectangle or square uses the start point (where you first 
clicked the mouse button) as the center.

Note

If the option When creating or moving objects has been selected in the Constrain 
Object section of Tools > Options > LibreOffice Draw > Grid, the action of the Shift 
key is reversed: the Rectangle tool draws a square. To draw a rectangle, press the 
Shift key. This Shift key reversal also applies when drawing ellipses and circles.

Drawing circles or ellipses
To draw an ellipse (also called an oval):

 1) Click on the Ellipse icon in the Drawing toolbar or select Ellipse icon in Basic Shapes on 
the Shapes deck in the Sidebar.

 2) A circle is a round shape with both axes the same length. To draw a circle, click on the 
Ellipse icon and hold down the Shift key while you draw a circle.
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 3) To draw an ellipse or circle from its center, position the cursor on the drawing, press the 
mouse button and then hold down the Alt key while dragging with the cursor. The ellipse or 
circle uses the start point (where you first clicked the mouse button) as the center.

Note

If you first press and hold down the Ctrl key and then click on one of the icons for Line,
Rectangle, Ellipse, or Text, a standard sized object is drawn automatically in the work 
area; the size, shape, and color are all standard values. These attributes can be 
changed later, if desired. See the Draw Guide for more information.

Drawing curves or polygons
 1) Use one of the following options to start drawing a curve or polygon. Moving the mouse 

cursor over one of the icons shows a tooltip giving the type of curve or polygon:

a) Click the small triangle on the right of the Curve and Polygons icon in the Drawing 
toolbar and select the type of curve or polygon from the drop down list (Figure 14).

b) Select and click the type of curve or polygon in the Curve and Polygons section of the 
Shapes deck on the Sidebar.

 2) Place the cursor at the point where you want to start the dimension line and drag the 
mouse while keeping the mouse button pressed. The dimension line is drawn and 
automatically calculates and displays the linear dimension.

 3) Hold down the Shift key when drawing curves or polygons to restrict the angles between 
the lines to 45 or 90 degrees.

Figure 14: Curves and Polygons

Note

The icon for the tool used most recently is shown on the Drawing toolbar to make it 
easier to use the same tool again

Curves
 1) Click and hold the left mouse button to create the starting point of the curve, then drag from

the starting point to draw a line. Release the mouse button and continue to drag the cursor 
to bend the line into a curve.

 2) Click to set the end point of the curve and fix the line on the page.

 3) To continue with the line, drag the mouse cursor to draw a straight line. Each mouse click 
sets a corner point and allows you to continue drawing another straight line from the corner 
point. A double-click ends the drawing of your line.

 4) A filled curve automatically joins the last point to the first point to close off the figure and fills
it with the selected fill color. A curve without filling will not be closed at the end of the 
drawing.

Polygons
 1) Click and draw the first line from the start point with the left mouse button held down. As 

soon as you release the mouse button, a line between the first and second points is drawn.

 2) Move the cursor to draw the next line. Each mouse click sets a corner point and allows you 
to draw another line. A double-click ends the drawing.
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 3) A filled polygon automatically joins the last point to the first point to close off the figure and 
fills it with the selected fill color. A polygon without filling will not be closed at the end of the 
drawing.

Polygons 45°
Like ordinary polygons, these are formed from lines, but the angles between lines are restricted to 
45 or 90 degrees when the Shift key is held down as you draw the line.

Freeform lines
Using the freeform line tools is similar to drawing with a pencil on paper. Press and hold the left 
mouse button and drag the cursor to the shape you require. It is not necessary to end the drawing 
with a double-click, just release the mouse button and the drawing is completed.

If Freeform Line Filled is selected, the end point is joined automatically to the start point and the 
object is filled with the selected color.

Adding text
To activate the text tool, click on the Text icon. You can display the Text Formatting toolbar (View >
Toolbars) or use the Character pane in the Properties deck of the Sidebar to select font type, font 
size, and other text properties before you start typing.

After activating the Text command, click at the location where you want to position the text. A small 
text frame appears, containing only the cursor. This frame can be moved like any other object. A 
text frame is also dynamic and grows as you enter text.

The information field in the status bar shows that you are editing text and also provides details 
about the current cursor location using paragraph, row, and column numbers (Figure 15).

Figure 15: Text information on Status bar

You can insert a line break with Shift+Enter or start a new paragraph using Enter. The insertion of 
line breaks or new paragraphs does not terminate text editing or deselect the text frame. When you
have finished typing text, click outside the text frame to cancel adding or editing text.

Text properties can also be changed during text input, with any changes taking effect from the 
cursor position onwards. To change the properties for all of the text in the text frame, you have to 
highlight all text in the text frame.

You can create Drawing styles that you can reuse for other text frames using the Styles deck on 
the Sidebar. Drawing styles affect all of the text within a text frame. To only format parts of the text, 
use direct formatting with the Text Formatting toolbar or the Character and Paragraph panes in 
the Properties deck of the Sidebar. See also “Using styles” on page 25.

Text frames can also have fill colors, shadows, and other attributes, just like any other object. You 
can rotate the frame and write the text at any angle. These options are available by right-clicking 
on the text frame itself.

If you double-click on a graphic object, or press F2 or click on the Text icon when an object is 
selected, you can add text to the graphic object. This text then becomes part of the graphic object.
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A graphic object is not dynamic and does not behave like a text frame. To keep text within the 
borders of the object, you have to use paragraphs, line breaks, or smaller text size, increase the 
object size, or a combination of all four methods.

For more information about text, see Chapter 2, Drawing Basic Shapes, and Chapter 9, Adding 
and Formatting Text, in the Draw Guide.

Using glue points and connectors

Glue points
All Draw objects have glue points, which are not normally displayed. Glue points become visible 
when the Connectors icon is selected on the Drawing toolbar or when a Connector is selected in 
the Shapes deck in the Sidebar.

Most objects have four glue points (Figure 16). You can add more glue points and customize them,
using the Glue Points toolbar (Figure 17). Go to View > Toolbars > Glue Points to open the 
toolbar.

Glue points are not the same as the selection handles of an object. Selection handles are for 
moving or changing the shape of an object. Glue points are used to fix or glue a connector to an 
object so that when the object moves, the connector stays fixed to the object. For a more detailed 
description on the use of glue points, see Chapter 3, Working with Objects and Object Points, and 
Chapter 8, Connections, Flowcharts, and Organization Charts, in the Draw Guide.

Figure 16: Glue points

Figure 17: Glue points toolbar

Connectors
Connectors are lines or arrows whose ends automatically snap to a glue point of an object. 
Connectors are especially useful in drawing organization charts, flow diagrams, and mind-maps. 
When objects are moved or reordered, the connectors remain attached to a glue point. Figure 18 
shows an example of two objects and a connector.

Draw offers a range of different connectors and connector functions. On the Drawing toolbar, click 
on the triangle next to the Connector icon to open the Connectors toolbar (Figure 19), or select a 
connector from Connectors section in the Shapes deck in the Sidebar. For a more detailed 
description of the use of connectors, see Chapter 8, Connections, Flowcharts, and Organization 
Charts, in the Draw Guide.
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Figure 18: Connector between two objects

Figure 19: Connectors toolbar

Drawing geometric shapes

The icons for drawing geometric shapes are located on the Drawing toolbar. The geometric shapes
are explained in the following sections. Clicking on the triangle to the right of the icon on the 
Drawing toolbar opens a floating toolbar giving access to the tools for that shape. These shapes 
are also available on the Shapes deck in the Sidebar.

Tip

The use of these tools for geometric shapes is similar to the tool used for drawing 
rectangles or squares. For more information, see page 15 in this chapter or Chapter 2,
Drawing Basic Shapes, in the Draw Guide.

Notes

The icons for geometric shapes displayed on the Drawing toolbar will change shape 
according to the last tool selected and used to draw an object.

You can add text to all of these geometric shapes. For more information, see Chapter 
2 and Chapter 11 in the Draw Guide.

Basic shapes

Symbol shapes

Block arrows
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Flowcharts
The creation of flowcharts, organization charts, and similar planning tools is further described
in Chapter 8, Connections, Flowcharts, and Organization Charts, in the Draw Guide.

Callouts

Stars and banners

3D Objects

Selecting objects

Direct selection
The easiest way to select an object is to click directly on it. For objects that are not filled, click on 
the object outline to select it. One click selects; a second click deselects. To select or deselect 
more than one object, hold the Shift key down while clicking.

Selection by framing
You can also select several objects at once by dragging the mouse cursor to draw a rectangle 
(also known as a marquee) around the objects. Only objects that lie entirely within the rectangle 
will be selected.

To select multiple objects by framing, the Select icon on the Drawing toolbar must be active.

Selecting hidden objects
Even if objects are located behind others and not visible, they can still be selected. Hold down the 
Alt key and click on the object at the front of where the hidden object is located, then click again to 
select the hidden object. If there are several hidden objects, keep holding down the Alt key and 
clicking until you reach the object you want. To cycle through the objects in reverse order, hold 
down the Alt+Shift keys and click. This is a quick way to reach an object, but it may not be practical
if there a large number of objects in a drawing.

When you click on the selected object, its outline will appear briefly through the objects covering it.

Note

Using the Alt key method works on computers using Windows or macOS. On Linux, 
use the Tab key to cycle through the objects, stopping at the object you want to select. 
To cycle through the objects in reverse order, press Shift+Tab.
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Arranging objects
In a complex drawing, several objects may be stacked on top of one another. You can rearrange 
the stacking order by moving an object forward or backward using one of the following methods:

• Select an object, go to Shape > Arrange on the Menu bar, or right-click on the object and 
select Arrange from the drop-down menu, then select one of the following options:

– Bring to Front

– Bring Forward

– Send Backward

– Send to Back

– In Front of Object

– Behind Object

• Select an object, then use one of the following keyboard shortcuts:

– Ctrl+Shift++ (bring to front)

– Ctrl++ (bring forward)

– Ctrl+- (send backward)

– Ctrl+Shift+- (send to back)

• Select an object, then select one of the Arrange icons (Figure 20) on left of the Line and 
Filling toolbar on the Menu bar. When you hover the mouse cursor over one of the icons, 
its function will be indicated.

Figure 20: Arrange icons

Moving objects and adjusting object size

When moving an object or changing its size, check the information area of the Status bar at the 
bottom of the Draw window (Figure 21). From left to right, it shows what object is selected, its 
position on the drawing in X/Y coordinates and dimensions of the object. The units of 
measurement are those selected in Tools > Options > LibreOffice Draw > General.

For more information on moving and adjusting object size, see Chapter 3, Working with Objects 
and Object Points, in the Draw Guide.

Figure 21: Left end of status bar when moving or adjusting an object
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Moving objects
To move an object (or a group of objects), select it and then click within the object borders and hold
down the left mouse button while dragging the mouse. During movement, a ghost image of the 
object appears to help with repositioning (Figure 22). To locate the object at its new location, 
release the mouse button.

Figure 22: Moving an object

Adjusting object size
To change the size of a selected object (or a group of selected objects), move the mouse cursor to 
one of the selection handles. The mouse cursor will change shape to indicate the direction of 
movement for that selection handle. As you change the size of the object, a ghosted outline of the 
object appears (Figure 23). When you have reached the desired size of the object, release the 
mouse button.

The results depend on which selection handle you use. To resize an object along one axis, use a 
side, top, or bottom handle. To resize along both axes, use a corner handle.

Figure 23: Adjusting object size

Note

If you press the Shift key while resizing an object, the change in size will be carried out
symmetrically with respect to the two axes so that the aspect ratio of the object 
remains the same. This Shift key behavior works on all selection handles.

This is the default behavior of the Shift key. However, if When creating or moving 
objects has been selected in the Constrain Objects section of Tools > Options > 
LibreOffice Draw > Grid, the action of the Shift key is reversed and the aspect ratio 
will be preserved unless the Shift key is pressed.

Editing objects

To edit an object or change attributes such as color or border width, you can use the Properties 
deck in the Sidebar or display and use the Line and Filling toolbar or the Text Formatting toolbar,
or right-click on an object to pop up a context menu. The functions are similar to those described 
for creating objects. For more information on editing objects and changing attributes, see Chapter 
4, Changing Object Attributes, in the Draw Guide.
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Using the Properties deck in the Sidebar
When you select an object in your drawing, the sections in the Properties deck of the Sidebar 
become active. You can change the properties or options of an object without having to open a 
dialog or use any of the toolbars provided by Draw. To expand a section, click on the arrow (^) sign 
next to the title of the section.

Formatting lines and borders
In LibreOffice the term line applies to a freestanding segment (line), the outer edge of a shape 
(border), or an arrow. In most cases the properties of the line you can modify are its style (solid, 
dashed, invisible, and so on), its width, and its color.

Select the line you need to format and then use the controls on the Line section in the Sidebar to 
change the most common options (Figure 24).

If you need to fine tune the appearance of a line, choose Format > Line from the Menu bar, or 
right-click on the line and select Line from the context menu, or select the More Options icon on 
the right of the section title in the Sidebar. All of these methods open the Line dialog (Figure 25), 
where you can set line properties. This dialog contains three pages: Line, Line Styles, and Arrow 
Styles.

Arrows, arrowheads, and other line endings are usually referred to as arrows and can be treated 
the same as lines when editing and changing attributes.

Several types of arrowheads are available. Each end of a line can have a different arrowhead or no
arrowhead. Arrowheads are only applicable to lines and they have no effect on the border of an 
object.

Figure 24: Line section in Sidebar
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Figure 25: Line dialog

Formatting area fills
The term area fill refers to the inside of an object, which can be a uniform color, gradient, hatching, 
pattern, or bitmap. An area fill can be made partly or wholly transparent. In most cases, you will 
choose one of the standard area fill options, which are all available in the Area section (Figure 26) 
of the Properties deck on the Sidebar or from the Line and Filling toolbar. You can also define 
your own area fills. For more information on area, see Chapter 4, Changing Object Attributes, in 
the Draw Guide.

Figure 26: Area section in the Sidebar
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Using styles

Suppose that you want to apply the same area fill, line thickness, and border to a set of objects. 
This repetitive process can be greatly simplified by the use of styles. Styles allow you to define a 
set of formats (a style) and then apply that set of formats to multiple objects with one click. In Draw,
you can define several styles for different types of lines, shapes, and text.

Figure 27: Styles deck in Sidebar

For more information on styles, see Chapter 3, Using Styles and Templates, in this guide; Chapter 
8, Introduction to Styles, in the Writer Guide; and Chapter 4, Changing Object Attributes, in the 
Draw Guide.

Positioning objects

Snap function
In Draw, objects can be accurately and consistently positioned using the snap function. Grid points,
snap points and lines, object frames, individual points on objects, or page edges can all be used 
with the snap function.

The snap function is easier to work with at the highest zoom values that are practical for your 
display. Two different snap functions can be used at the same time; for example snapping to a 
guide line and to the page edge. It is recommended, however, to activate only the functions that 
you really need.

For more detailed information about the snap function, see Chapter 3, Working with Objects and 
Object Points, and Chapter 11, Advanced Draw Techniques, in the Draw Guide.

Snap to grid
Use Snap to grid to position an object to a grid point. Go to View > Snap Guides > Snap to Grid 
on the Menu bar or click on the Snap to Grid icon on the Options toolbar (Figure 28) to turn on or 
off the snap to grid function. If the Options toolbar is not visible, you can go to View > Toolbars > 
Options on the Menu bar to display it.
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Figure 28: Options toolbar

Figure 29: Configuring the grid

Displaying the grid
To display the grid in Draw or to switch off the grid, go to View > Grid and Helplines > Display 
Grid on the Menu bar or click the Display Grid icon on the Options toolbar.

Configuring the grid
The resolution, snap, and snap position of the grid points can be configured. Go to Tools > 
Options > LibreOffice Draw > Grid on the Menu bar to open the Options dialog for the grid 
(Figure 29).

• Vertical and horizontal spacing of the dots in the grid. You can also change the unit of 
measurement used in the general Draw options by going to Tools > Options > LibreOffice
Draw > General.

• The resolution is the size of the squares or rectangles in the grid. For example, if the 
resolution is 1 cm horizontal and 2 cm vertical, the grid consists of rectangles 2 cm high 
and 1 cm wide.

• Subdivisions are additional points that appear along the sides of each rectangle or square 
in the grid. Objects can snap to subdivisions as well as to the corners of the grid.

• The pixel size of the snap area defines how close you need to bring an object to a snap 
point or line before it will snap to it.
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• The default color of the grid is light gray. To change the color of the grid points, go to Tools 
> Options > LibreOffice > Application Colors on the Menu bar.

Help lines
Draw has help lines to help you to position an object using the rulers at the top and left side of the 
workspace. To turn on or off the help lines, go to Tools > Options > LibreOffice Draw > View on 
the Menu bar and select Helplines while moving or go to the Options toolbar and click the 
Helplines While Moving icon.

Applying special effects

With Draw, you can apply many special effects to objects and groups of objects. This section is an 
introduction to some of these effects. For more information on special effects, see Chapter 3, 
Working with Objects and Object Points, and Chapter 4, Changing Object Attributes, in the Draw 
Guide.

To access the tools used for special effects, go to View > Toolbars > Transformations (Figure 30)
or go to Shapes > Transformations on the Menu bar, or Transformations on the Standard 
toolbar, or right-click on the object and use the context menu.

Figure 30: Transformations toolbar

Rotating or slanting an object
To rotate or slant an object (or a group of objects), select the object, then go to rotation mode:

• Right-click on the object or group and select Transformations > Rotate.

• Click on the arrow next to the Transformations icon on the Standard toolbar, then select 
Rotate.

• Click on the Rotation icon on the Transformations toolbar (Figure 30).

The selection handles will change shape and color (Figure 1) and a rotation point will appear in the
center of the object. As you move the mouse cursor over the handles, the cursor changes shape. 
The corner handles rotate an object and the top, bottom, and side handles slant an object.

Figure 31: Rotating objects

Move the mouse cursor to one of the corner handles and it normally changes to an arc with an 
arrow at each end. Click and hold the mouse button, then start to move the cursor to rotate the 
object. A ghost image of the object being rotated appears and the current angle of rotation is 
shown in the status bar.
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Note

If you press the Shift key while rotating or slanting an object, movement will be 
restricted to 15° of movement.

This is the default behavior of the Shift key. However, if When creating or moving 
objects has been selected in the Constrain Objects section of Tools > Options > 
LibreOffice Draw > Grid, the action of the Shift key is reversed and rotation or 
slanting will be restricted to 15° of movement unless the Shift key is pressed.

Note

Rotation works differently for 3D objects because rotation occurs around global axes 
and not around a single axis. For more information, see Chapter 7, Working with 3D 
Objects, in the Draw Guide.

The rotation point is normally located at the center of an object. To change the position of the 
rotation point, click on the object with the mouse cursor and drag the object until the rotation point 
is at the desired position. This rotation point can even be outside of the object.

To slant a selected object, use the handles located at the midpoints on the top, bottom and sides of
the object. The mouse cursor changes when it hovers over one of these midpoint handles. The 
axis used for slanting an object is the object edge directly opposite the midpoint handle being used 
to slant the object. This axis stays fixed in location while the other sides of the object move in 
relation to it as you drag the mouse cursor.

Click and hold the mouse button, then move the cursor to slant the object. A ghost image of the 
object being slanted appears (Figure 32) and the current angle of slant is shown in the status bar.

Figure 32: Slanting an object

Flipping an object
The quickest and easiest method to flip an object horizontally or vertically is as follows:

 1) Click on a graphic object and the selection handles will show.

 2) Right-click and select Flip > Vertically or Horizontally, or go to Shape > Flip > Vertically 
or Horizontally on the Menu bar, or click on the Vertically or Horizontally icon on the Line
and Filling toolbar.

However, the Flip tool on the Transformations toolbar provides greater control over the flipping 
process. You can use the Flip tool to change the position and angle that the object flips over, as 
described in Chapter 4, Changing Object Attributes, in the Draw Guide.
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Distorting an object
Three tools on the Transformations toolbar let you drag the corners and edges of an object to 
distort the image.

• Distort tool distorts an object in perspective.

• Set in Circle (perspective) creates a pseudo three-dimensional effect.

• Set to Circle (slant) creates a pseudo three-dimensional effect. Despite the (slant) in the 
name of this tool, it operates differently to the slanting created by the Rotate tool.

In all three cases you are initially asked if you want to transform the object to a curve. This is a 
necessary first step, so click Yes. Then you can move the object handles to produce the desired 
effect. See Chapter 4, Changing Object Attributes, in the Draw Guide for more information on how 
to distort an object.

Dynamic transparency gradients
You can control transparency gradients in the same manner as color gradients. Both types of 
gradient can be used together. With a transparency gradient, the direction and degree of object fill 
color changes from opaque to transparent. In a regular gradient, the fill changes from one color to 
another, but the degree of transparency remains the same.

The Interactive Transparency and Interactive Gradient tools on the Transformations toolbar 
dynamically control transparency and color gradients. See Chapter 4, Changing Object Attributes, 
in the Draw Guide for more information on how to create transparencies and gradients in an object.

Duplication
Duplication makes copies of an object while applying a set of changes such as color or rotation to 
the duplicates that are created.

 1) Click on an object or group of objects and go to Edit > Duplicate or Shape > Duplicate on 
the Menu bar, or press Shift+F3, to open the Duplicate dialog (Figure 33).

 2) Select the required options chosen from the options available. For example, when the 
options in the dialog are applied to a rectangle, they produce the result shown in Figure 34.

Cross-fading
Cross-fading transforms one object shape to another object shape and only works when two 
objects are selected.

 1) Select two differently shaped objects.

 2) Go to Shape > Cross-fading on the Menu bar to open the Cross-fading dialog (Figure 35).

– Select Increments to determine the number of shapes between the two objects.

– Select Cross-fading attributes to apply a gradual change of line and fill properties 
between the two objects.

– Select Same orientation to apply a smooth transition between the two objects.

 3) Click OK and the result is a new group of objects with the first object selected as the start 
object and the second object selected as the end object. For example, when the options in 
the dialog are applied to a rectangle and a triangle, the cross fade produces the result 
shown in Figure 36.
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Figure 33: Duplicate dialog

Figure 34: Duplication result
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Figure 35: Cross-fading dialog

Figure 36: Cross-fading result

Combining multiple objects

Using Draw, you can group or combine objects together allowing you to treat multiple objects as 
one unit, or to merge objects to form a new shape. For more information, see Chapter 5, 
Combining Multiple Objects, in the Draw Guide.

Grouping of objects is similar to putting objects into a container. You can move the objects as a 
group and apply global changes to the objects within the group. A group can always be undone 
(ungroup) and the objects that make up the group can always be manipulated separately. The 
objects within a group also retain their own individual properties.

Combining objects is a permanent merging of objects that creates a new object. The original 
objects are no longer available as individual entities and cannot be edited as individual objects. 
Any editing of a combined object affects all the objects that were used when combination was 
carried out.

Grouping

Temporary grouping
A temporary grouping is when several objects are selected using the Select icon on the Drawing 
toolbar or using the mouse to drag a rectangle (also known as a marquee) around the objects. Any 
changes to object parameters you carry out are applied to all of the objects within the temporary 
group. For example, you can rotate a temporary group of objects in its entirety.

To cancel a temporary grouping of objects simply click outside of the selection handles displayed 
around the objects.

Permanent grouping
A permanent grouping of objects can be created after you have selected your objects. Go to 
Shape > Group > Group on the Menu bar, or right-click on the selection and select Group from 
the context menu, or use the keyboard shortcut Ctrl+Shift+G. When you deselect your selection, 
the objects remain grouped together.

When objects are permanently grouped, any editing operations carried out on that group are 
applied to all members of the group. If you click on one member of the group, the whole group is 
selected.
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You can edit an individual member of a group without ungrouping or breaking the group. Select the
group and go to Shape > Group > Enter Group, or right-click and select Enter Group from the 
context menu, or use the keyboard shortcut F3, or double-click on the group.

When you have finished editing an individual member of a group, go to Shape > Group > Exit 
Group, or right-click and select Exit Group, or use the keyboard shortcut Shift+F3.

Ungrouping
To ungroup or break apart a group of objects, select the group then go to Shape > Group > 
Ungroup on the Menu bar, or right-click and select Ungroup from the context menu or use the 
keyboard shortcut Ctrl+Alt+Shift+G.

Combining objects
Combining objects is a permanent merging of objects that creates a new object. The original 
objects are no longer available as individual entities and cannot be edited as individual objects. 
Any editing of a combined object affects all the objects that were used when combination was 
carried out.

Select several objects, then go to Shape > Combine on the Menu bar, or right-click on the objects 
and select Shapes > Combine from the context menu, or use the keyboard shortcut Ctrl+Shift+K.

After you have selected your objects, the Merge, Subtract, and Intersect functions also become 
available so that you can create a new object from your selected objects. See Chapter 5, 
Combining Multiple Objects, in the Draw Guide for more information on these functions.

Arranging, aligning, and distributing objects
In Draw you can arrange, align, and distribute selected objects in relation to each other:

• Arrange the position of an object by moving it either forward or backward in relation to the 
order of objects.

• Align objects with respect to each other using Left, Centered, or Right for horizontal 
alignment and Top, Center, or Bottom for vertical alignment.

• Distribute objects so that the space between each of the objects is the same.

See Chapter 5, Combining Multiple Objects, in the Draw Guide for more information on arranging 
and aligning objects in relation to each other.

Inserting and editing images

Draw contains a number of functions for editing images (also called pictures, raster graphics, or 
bitmaps); for example, photos and scanned images. This includes the import and export of images,
and conversion from one image format to another.

Draw includes a large range of filters so that it can read and display several image file formats. It 
also includes several tools for working with images, but does not have the same functionality as 
specialized programs like GIMP or Adobe Photoshop. See Chapter 6, Editing Images, in the Draw 
Guide for more information.

You can add images from several sources:

• Directly from a scanner (Insert > Media > Scan)

• Created by another program, including photographs from a digital camera (Insert > Image)

• The Draw Gallery; see Chapter 11, Images and Graphics, in this guide.
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Working with 3D objects

Although Draw does not match the functionality of specialized drawing or image editing programs, 
it is capable of producing and editing very good 3D drawings.

You can create a 3D object by selecting a 3D shape from the Shapes deck in the Sidebar, or by 
converting a 2D object (right-click and choose Convert > To 3D). Draw also offers several 
methods of editing a 3D object, using the 3D Effects dialog.

See Chapter 7, Working with 3D Objects, in the Draw Guide for more information.

Exporting images

Draw saves images in the Open Document Format *.odg. To save an image or the entire Draw file 
in another format, use File > Export and select a format from the drop-down list. The image 
formats that Draw can export and save to are listed in Appendix B, Open Source, Open Standards,
OpenDocument, in this guide.

You can also export Draw files to HTML, XHTML, PDF, or Flash. PDF export from LibreOffice is 
described in Chapter 10, Printing, Exporting, Emailing, and Signing, in this guide.

HTML export uses a conversion wizard that creates as many web pages as there are pages in 
your Draw document. You can optionally choose to display pages in frames with a navigator and 
set an index page. For more information, see Chapter 12, Creating HTML Files, in this guide.

Inserting comments in a drawing

You can insert comments into your drawing in a similar process to the one used in Writer and Calc.

Go to Insert > Comment on the Menu bar. A small box containing your initials appears in the 
upper left-hand corner of your drawing with a larger text box beside it (Figure 37). Draw 
automatically adds your name and the date at the bottom of this text box. Type or paste your 
comment into the text box.

You can apply basic formatting to parts of the text by selecting it, right-clicking, and choosing from 
the context menu. From this menu, you can also delete the current comment, all the comments 
from the same author, or all the comments in the document.

You can move the small comment markers to anywhere you wish on the drawing. Typically you 
might place it on or near an object you refer to in the comment.

To show or hide the comment markers, go to View > Comments on the Menu bar.

Go to Tools > Options > User Data to enter the name and initials you want to appear in the 
comment marker and in the Author field of the comment. If more than one person edits the 
document, each author is automatically allocated a different background color.

Figure 37: Inserting comments
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