) LibreOffice

Getting Started Guide

Chapter 2
Setting up LibreOffice

Choosing Options to Suit the Way You Work



Copyright

This document is Copyright © 2018 by the LibreOffice Documentation Team. Contributors are listed
below. You may distribute it and/or modify it under the terms of either the GNU General Public
License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons
Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.
Contributors
This book is adapted and updated from Getting Started with OpenOffice.org 3.3.

To this edition
Paul Figueiredo Dave Barton Amanda Labby
Jorge Rodriguez Olivier Hallot

To previous editions

Jean Hollis Weber Agnes Belzunce Hazel Russman
John A Smith Martin Saffron Steve Schwettman
Ron Faile Jr. Daniel Carrera Peter Hillier-Brook
Stefan A. Keel Michele Zarri

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s
mailing list: documentation@global.libreoffice.org

g Note:

Everything you send to a mailing list, including your email address and any other
personal information that is written in the message, is publicly archived and cannot be
deleted.

Publication date and software version
Published May 2018. Based on LibreOffice 6.0.

Documentation for LibreOffice is available at https.//documentation.libreoffice.org/en/english-documentation/


https://documentation.libreoffice.org/en/english-documentation/
mailto:documentation@global.libreoffice.org
http://creativecommons.org/licenses/by/4.0/
http://www.gnu.org/licenses/gpl.html

Contents

3 0 0 )7 5 ' | L S 2
(0] 01171 o101 (o] =TT PSP O SPPPPPRPIN 2
B0 IR 1 =0 1o o 2

B Lo o (=17 010 ES=To [11 1] o < 2
TS0 | o= Lo TP PSP 2
Publication date and SOftWAre VEISION...........iiiiiiiiiiiieee et eeeeeaes 2
Using LibreOffice 0N MacCOS...........oemmmmeeiieeieiiiieneens s s nna s 4
Choosing options for all of LibreOffice.........cccoiiiiiiimmmmmiss s, 4
USET DAL OPTIONS. ... eeeiiiii ittt e e e e oo ettt et e e ettt e e e e e e e e e e e e e e e e e e e e e e eenne 5
LCT=T 01T =110 1 0] o 1= TP 5
V=TV o] o] (o g PP 6
T a1 0] o] (o USRI 8
PALNS OPTIONS. ...ttt et e e e e e e e e e e 9
o] a1 0] o] 1T0] o - TP P TP PP PP PSPP 10
Y=ol | g3V o] o] i o] 1 1T 11
Security OptioNs and WaIMINGS.........ooviiiiiiiiiiie i e e e e e e e e e e et e e e et aeearaa s 12

ST ST ] g =117 1o ] o 1P 13
APPIICALION COIOTS. ...ttt e e e e e e e e e e e ettt r e e e e e e e e e eeeeeeeeas 14
Yoot TS o111 Y] o] 1] 1= 15
Y0 V7= T Tol=To o] o] 10 o 1= 15
BASIC IDE OPTIONS. ...ttt ettt e e e e e e e e e e e e s e bbb et e e et aa e 17
ONIINE UPUALE OPLIONS. ... ittt ettt e e e e e e e e e e e e s s sttt e et eeeeeeeeeeeeeeeenannes 17

L@ 0 =] 0 O8I o] o] 1o 1= 30 18
Choosing options for loading and saving documents..........cccoviniiinnneesssssnnnnsssssn. 18
L= 1= - 1S 18
V42N (0] o 1=T 4 1= T T PO P PP SPPP 20

Y ol g0 E{o ] 1RO o] = PR 21

L Y o0 g o = 11 o111 25 22

(04 T ToX=71 Yo I F= T Vo [0 F: Vo T=R=T=1 ] Lo L= 23
Install the required dICHONANES. .........uuuiiiiiiiiiie e e e e e e e e e e e e e e e eennnes 23
Change some locale and language SEtHNGS. .....ccooiiiiieeiiiiie e e e e e e e 23

(O gToToFY=I] o111 TaTo o] o] 1 o] 1 1= PSPPI 25
ENglisSh SENENCE CNECKING. ... .uiiiiiiiiiiieiee e e e e e e e eennes 26
Grammar CRECKING......coo i e e e 27

0T o (0 = U1 o PP 27
(@1 1= TP OO SUPPPPPPN 27
Other languages SENENCE CNECKING. ... ... uriiiiiiiiiieiee e 27
Choosing INternet OPLiONS.........uuuuuummmmmnnnnnnnnnsnnnnnnnnsnssssssssssssssssssssssssssssnssnsssssssssnnnnnsssssssnns 28
Controlling LibreOffice’s AutoCorrect fuNCLIONS.........ccocemmmmrmrnininissssssnss s 28
Troubleshooting LibreOffice in Safe Mode...........coouiim s 29

Chapter 2 Setting Up LibreOffice | 3



Using LibreOffice on macOS

Some keystrokes and menu items are different on macOS from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this book. For a more
detailed list, see the application Help.

Windows or Linux  macOS equivalent Effect
Tools > Options LibreOffice > ,
) Access setup options

menu selection Preferences
Right-click Control+click and/or right-

click depending on Open a context menu

computer setup
Ctrl (Control) ¥ (Command) Used with other keys
F5 Shift+3+F5 Open the Navigator
F11 FH+T Open the sidebar Styles and Formatting deck

Choosing options for all of LibreOffice

This section covers some of the settings that apply to all the components of LibreOffice. For
information on settings not discussed here, see the Help.

Click Tools > Options. The list in the left-hand box of the Options — LibreOffice dialog varies
depending on which component of LibreOffice is open. The illustrations in this chapter show the list
as it appears when a Writer document is open.

Click the marker (+ or triangle) by LibreOffice on the left-hand side. A list of pages drops down.
Selecting an item in the list causes the right-hand side of the dialog to display the relevant page.

% 0 Options - LibreOfFfice - User

¥ LibreOfFice .

General
View
Print
Paths
Fonts
Security
Personalization
Application Colors
Accessibility
Advanced
BasicIDE
Online Update
OpencCL

Load/Save

Language Sektings

LibreOffice Writer

LibreOffice writer/web

LibreOffice Base

Charts

Internet

VvV VyVvVFVvVVYY

Figure 1: LibreOffice options
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£7 Note

The Reset button, located in the lower right of the full Options dialog, has the same
effect on all pages of the dialog. It resets the options to the values that were in place
when you opened the dialog.

If you are using a version of LibreOffice other than US English, some field labels may be different
from those shown in the illustrations.

User Data options

Because LibreOffice can use the name or initials stored in the LibreOffice — User Data page for
several things — including document properties (‘created by’ and ‘last edited by’ information), the
name of the author of comments and changes, and the sender address in mailing lists — you will
want to ensure that the correct information appears here.

Fill in the form (not shown here), or amend or delete any existing information. If you do not want
user data to be part of the document’s properties, clear the box at the bottom.

General options
The options on the LibreOffice — General page (Figure 1) are described below.

Help - Extended tips
When Extended tips is active, a brief description of the function of a particular icon or menu
command or a field on a dialog appears when you hold the mouse pointer over that item.

#® 0O Options - LibreOffice - General

¥ LibreOffice Help

| Extended tips

View

Print Print Dialogs
Paths , . s
Fonts [ Use LibreOffice dialogs
Security
Personalization Document Status
Application Colors | Printing sets "document modified" status
Accessibility
Advanced i
Basic IDE Year (Two Digits)
Online Update Interpret as years between 1930  : and 2029
OpenCL
> Load/Save % Help Improve LibreOFfice
» Language Settings
> LibreOFffice Writer Collect usage data and send it to The Document Foundation
> LibreOffice writer/web
* LibreOffice Base LibreOffice Quickstarter
® Charts 9 Enabl ¢ ickstart
» Internet nable systray Quickstarter
Help | OK Cancel Reset

Figure 2: Setting general options for LibreOffice

Print Dialogs - Use LibreOffice dialogs
Same as above, but for the Print dialogs. Available only in some operating systems and
desktop managers. (Not shown in illustration.)

Document status - Printing sets “document modified” status
If this option is selected, then the next time you close the document after printing, the print
date is recorded in the document properties as a change and you will be prompted to save
the document again, even if you did not make any other changes.
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Year (two digits)

Specifies how two-digit years are interpreted. For example, if the two-digit year is set to
1930, and you enter a date of 1/1/30 or later into your document, the date is interpreted as
1/1/1930 or later. An “earlier” date is interpreted as being in the following century; that is,
1/1/20 is interpreted as 1/1/2020.

Help Improve LibreOffice — Collect usage data and send it to The Document Foundation
Send usage data to help The Document Foundation improve usability of the software. Data
about usage patterns helps with identifying the most frequently used sequences of
commands while performing common tasks; the developers can then design a user interface
that is easier to use and more productive. The usage data is sent anonymously and carries
no document contents, only the commands used.

View options

The options on the LibreOffice — View page affect the way the document window looks and
behaves. Some of these options are described below Figure 3. Set them to suit your personal

preferences.

% O Options - LibreOffice - View

¥ LibreOffice
User Data
ral

Print
Paths

Fonts

Security
Personalization
Application Colors

User Interface
Toolbar icon size:

Auktomatic
Sidebar icon size:
Automatic

Motebookbar icon size:

Graphics Output

& Use hardware acceleration
& Use anti-aliasing
Use OpenGL for all rendering

| Ignore OpenGL blacklist
GLis currently disabled.

Accessibility Automatic =
‘gg:iir:[c)eEd Icon style: Menu
< Icons in menus:
Online Update Galaxy =
OpenCL o Show &
» Load/Save [ Screen fFontantialiasing
» Language Settings . . - Shortcuts in context menus:
> LibreOFfice Writer from: 8 pixels = Automatic =
»  LibreOffice Writer/Web
» LibreOffice Base Mouse )
P Charts Mouse positioning: E Ea
" Internet 2 e show preview of fonts
No automatic positioning
Middle mouse button:
Paste clipboard >
Help | OK Cancel Reset

Figure 3: Choosing View options for LibreOffice applications

User Interface — Scaling
If the text in the help files or on the menus of the LibreOffice user interface is too small or too
large, you can change it by specifying a scaling factor. Sometimes a change here can have
unexpected results, depending on the screen fonts available on your system. However, it
does not affect the actual font size of the text in your documents.

User Interface - Icon size
This box specifies the display size of toolbar icons (Automatic, Small, or Large). The
Automatic icon size option uses the setting for your operating system.

User Interface - Icon style
This box specifies the icon style (theme). Here the Automatic option uses an icon set
compatible with your operating system and choice of desktop: for example, KDE or Ghome
on Linux.
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User interface — Screen font anti-aliasing
(Not available in Windows.) Select this option to smooth the screen appearance of text. Enter
the smallest font size to apply anti-aliasing.

Mouse positioning
Specifies if and how the mouse pointer will be positioned in newly opened dialogs.

Middle mouse button
Defines the function of the middle mouse button.

— Automatic scrolling — dragging while pressing the middle mouse button shifts the
view.

— Paste clipboard — pressing the middle mouse button inserts the contents of the
“Selection clipboard” at the cursor position.

The “Selection clipboard” is independent of the normal clipboard that you use by Edit >
Copyl/Cut/Paste or their respective keyboard shortcuts. Clipboard and “Selection clipboard”
can contain different contents at the same time.

Function Clipboard Selection clipboard
Copy content Edit > Copy Ctrl+C Select text, table, or object.
Paste content Edit > Paste Ctr/+V pastes at the  Clicking the middle mouse button pastes
cursor position. at the mouse pointer position.
Pasting into another No effect on the clipboard The last marked selection is the content of
document contents. the selection clipboard.

Graphics output — Use hardware acceleration
Directly accesses hardware features of the graphical display adapter to improve the screen
display. Not supported on all operating systems and LibreOffice distributions.

Graphics output — Use anti-aliasing
Enables and disables anti-aliasing, which makes the display of most graphical objects look
smoother and with fewer artifacts. Not supported on all operating systems and LibreOffice
distributions.

‘:@:‘ Tip

Press Shift+Ctrl+R to restore or refresh the view of the current document after
changing the anti-aliasing settings, to see the effect.

Graphics output — Use OpenGL for all rendering (on restart)
Enables and disables the use of the 3D graphics language OpenGL. Not supported on all
operating systems and LibreOffice distributions.

Graphics output — Force OpenGL even if blacklisted (on restart)
Forces the use of OpenGL even if the graphics device is blacklisted. A device is blacklisted
when it is buggy or may render graphics with poor quality. Not supported on all operating
systems and LibreOffice distributions.

Menu - icons in menus
Causes icons as well as words to be visible in menus.

Font Lists — Show preview of fonts
Causes the font list to look like Figure 4, Left, with the font names shown as an example of
the font; with the option deselected, the font list shows only the font names, not their
formatting (Figure 4, Right). The fonts you will see listed are those that are installed on your
system.
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Fonts which are tuned for use with a specific script, such as Arabic, Hebrew, Malayalam, and
so on, now show an additional preview of some sample text in the target script.

W SE HE S| 11| B2
& D - ]
;e,i;va!u'*seﬁ&ﬂ@ ¢

Liberation Serif [IRSNACINRAIN : 30 ALY,

. Liberation Serif =
Linux Biolinum G
Linux Libertine Display G

Linux Libertine Display G Linux Libertine G

LKLUG

Linux Libertine G r | Lohit Punjabi .
LKLUG \-"Eé'w anﬁc [ Loma |

mry_KacstQurn

BBl Liberation Serif

Linux Biolinum G

Lohit Punjabi aaH}:ﬂ' NanumBarunGothic
e NanumGothic
Loma anus ng NanumMyeongjo
" . £ Nimbus Mono L

e L ot Al & Lol Nimbus Roman No9 L
NanumBarunGothic 33 Nambus Sans L
NanumGothic a2 Noto Sans CJKJP Black

. Noto Sans CJK JP Bold
NanumMyeongjo i Noto Sans CJK JP DemiLight .

Figure 4: Font list (Left) with preview; (Right) without preview

Print options

On the LibreOffice — Print page, set the print options to suit your default printer and your most
common printing method. Most of these options should be self-explanatory.

The option PDF as Standard Print Job Format is not available on Windows. Select this option to
change the internal print job format from a Postscript document description to a PDF description.
This format has a number of advantages over Postscript. For more information, see
http://www.linuxfoundation.org/collaborate/workgroups/openprinting/

pdf _as_standard_print_job_format

Deselecting this option reverts to the Postscript document workflow system.

In the Printer warnings section near the bottom of the page, you can choose whether to be warned
if the paper size or orientation specified in your document does not match the paper size or
orientation available for your printer. Having these warnings turned on can be quite helpful,
particularly if you work with documents produced by people in other countries where the standard
paper size is different from yours.

‘:@:‘ Tip

If your printouts are incorrectly placed on the page or chopped off at the top, bottom,
or sides, or the printer is refusing to print, the most likely cause is page size
incompatibility.
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@ O Options - LibreOffice - Print

¥ LibreOffice

Y Y Y YYYYY

User Data
General

View

Print

Paths

Fonks

Security
Personalization
Application Colors
Accessibility
Advanced

Basic IDE
Online Update
OpenCL

Load/Save

Language Settings
LibreOFffice Writer
LibreOffice Writer/Web
LibreOffice Base
Charts

Internet

Help

Paths options

On the LibreOffice — Paths page, you can change the location of files associated with, or used by,
LibreOffice to suit your working situation. In a Windows system, for example, you might want to
store documents by default somewhere other than My Documents.

Settings For:

Reduce Print Data

® Printer

[[] Reducetransparency

Automatically

Mo transparency

| Reduce bitmaps

High print quality

) Printto file

[] Reduce gradient

Gradient stripes: 64
Intermediate color

] Convert colors to grayscale

MNormal prinkt quality

Resolution: |200 DPI (default)
Include transparent objects

[ PDF as standard print job format

Printer Warnings

[] Paper size & Transparency

["] Paper orientation

L OK | Cancel Reset

Figure 5: Choosing general printing options to apply to all LibreOffice components

To make changes, select an item in the list shown in Figure 6 and click Edit. On the Select Path
dialog (not shown; may also be titled Edit Paths), add or delete folders as required, and then click
OK to return to the Options dialog. Note that some items can have at least two paths listed: one to
a shared folder (which might be on a network) and one to a user-specific folder (normally on the
user’'s personal computer).

‘:Q:‘ Tip

You can use the entries on the LibreOffice — Paths page to compile a list of files, such
as those containing AutoText, that you need to back up or copy to another computer.

Paths used by LibreOfficeDev

Type a
AutoCorrect
AutoText
Backups
Classification
Dictionaries
Gallery

Images

My Documents
Templates

Path

/home/olivier/.config/libreofficedev/4/user/autocorr
/homefolivier/.config/libreofficedev/4/user/autotext
/home/olivier/.config/libreofficedev/4/user/backup
Jopt/libreofficedev6.0/program/../share/classification/example.xml
/home/olivier/.config/libreofficedev/4/user/wordbook
/home/olivier/.config/libreofficedev/4/user/gallery
/home/olivier/.config/libreofficedev/4/user/gallery
/home/olivier/Documents
/home/olivier/.config/libreofficedev/4/user/template;/home/olivier/Templa

Temporaryfiles ftmp

Figure 6: Viewing the paths of files used by LibreOffice
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Fonts options

You can define replacements for any fonts that might appear in your documents. If you receive
from someone else a document containing fonts that you do not have on your system, LibreOffice
will substitute fonts for those it does not find. You might prefer to specify a different font from the
one that the program chooses.

Z Note

These choices do not affect the default font for your documents. To do that, you need
to change the default template for documents, as described in Chapter 3.

On the LibreOffice — Fonts page:

1) Select the Apply replacement table option.

2) Select or type the name of the font to be replaced in the Font box. (If you do not have this
font on your system, it will not appear in the drop-down list in this box, so you need to type
itin.)

3) Inthe Replace with box, select a suitable font from the drop-down list of fonts installed on
your computer.

4) The check mark to the right of the Replace with box turns green. Click on this check mark.
A row of information now appears in the larger box below the input boxes. Select Always to
replace the font, even if the original font is installed on your system. Select Screen only to
replace the screen font only and never replace the font for printing. The results of
combining these selections are given in Table 2.

5) In the bottom section of the page, you can change the typeface and size of the font used to
display source code such as HTML and Basic (in macros).

Replacement Table
Font: Replace with:

DejaVu Math TeX Gyre v | KacstDigital v R

Always Screenonly | Font Replace with

[ () Carlito FreeSans

& Applyreplacement table

Font Settings For HTML, Basic and SQL Sources

Fonts: |Automatic s

[ MNon-proportional fonts only
Size: 10 <

OK Cancel Reset

Figure 7: Defining a font to be substituted for another font
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Table 1. Font substitution replacement actions

Always Screenonly  Replacement action

checkbox  checkbox

checked blank Font replacement on screen and when printing, whether the font is
installed or not.

checked checked Font replacement only on screen, whether the font is installed or not.

blank checked Font replacement only on screen, but only if font is not available.

blank blank Font replacement on screen and when printing, but only if font is not
available.

Security options

Use the LibreOffice — Security page to choose security options for saving documents and for
opening documents that contain macros.

Security options and warnings
If you record changes, save multiple versions, or include hidden information or notes in your
documents, and you do not want some of the recipients to see that information, you can set
warnings to remind you to remove it, or you can have LibreOffice remove some of it
automatically. Note that (unless removed) much of this information is retained in a file
whether the file is in LibreOffice’s default OpenDocument format, or has been saved to other
formats, including PDF.

Click the Options button to open a separate dialog with specific choices (Figure 10). See
“Security options and warnings” on page 12.

Security Options and Warnings

Adjust security related options and define wamings for hidden information in Options.
QOCUMmEnts.,

Passwords for Web Connections
Persistently sawe passwonds for web connections

MAET SEcurty

Addjust thee Security bevel lor executing macros and specily Irusted macro
developers,

Certificate Path

Select the Network Security Services certificale dinectony 1o use for digital
gignatures.

TS5AS

Maintain a list of Time Stamping Authority (TSA) URLS to be used for digital
signatures in PDF export,

Figure 8: Choosing security options for opening and saving documents

bacro Security...

Cerificate...

Passwords for web connections
You can enter a master password to enable easy access to websites that require a user
name and password. If you select the Persistently save passwords for web connections
option, the Set Master Password dialog opens (Figure 12). LibreOffice will securely store all
passwords that you use to access files from web servers. You can retrieve the passwords
from the list after you enter the master password.

Security options | 11



L8 D Set Master Password

Passwords for web connections are protected by a master
password. You will be asked to enter it once per session, if
LibreOffice retrieves a password from the protected password
list.

Enter password:

Reenter password:

Caution: If you forget the master password, you will be
unable to access any of the information protected by it.
Passwords are case sensitive.

Help OK Cancel

Figure 9: Set Master Password dialog for web connections

Macro security
Click the Macro Security button to open the Macro Security dialog (not shown here), where
you can adjust the security level for executing macros and specify trusted sources.

Certificate Path
Users can digitally sign documents using LibreOffice. A digital signature requires a personal
signing certificate. Most operating systems can generate a self-signed certificate. However, a
personal certificate issued by an outside agency (after verifying an individual’s identity) has a
higher degree of trust associated with it than does a self-signed certificate. LibreOffice does
not provide a secure method of storing these certificates, but it can access certificates that
have been saved using other programs. Click the Certificate button and select which
certificate store to use.

g Note

The Certificate Path option appears only on Linux and Mac systems. On Windows,
LibreOffice uses the default Windows location for storing and retrieving certificates.

TSAs -Time Stamping Authorities
Allows you to optionally select a Time Stamping Authority (TSA) URL for PDF documents
created by LibreOffice. Adding a trusted timestamp to an electronic signature on a PDF
provides a digital seal of data integrity and a trusted date and time of when the file was
signed. Recipients of PDF documents with a trusted timestamp can verify when the
document was digitally or electronically signed, as well as verify that the document was not
altered after the date the timestamp vouches for.

Security options and warnings
The following options are on the Security options and warnings dialog (Figure 10).

12 | Choosing options for all of LibreOffice



& : Security {]|:|1i|:l>n5: and ';".farr".inu_:;s :
Security Warnings
Warn if document containg recorded changes, versions, hidden information or notes:
When saving or sending B When signing
When printing When creating PDF files
| Security Options
Remaove personal information on saving
Recommend password protection on saving
£ Cui-click required to follow hyperlinks
Block any links from documents not amaong the trusted locations (see Macro Security)

i

Help SENOERN  Cancel

Figure 10: Security options and warnings dialog

Remove personal information on saving
Select this option to always remove user data from the file properties when saving the file. To
manually remove personal information from specific documents, deselect this option.

Ctrl-click required to follow hyperlinks
The default behavior in LibreOffice is to Ctrl+click on a hyperlink to open the linked
document. Many people find creation and editing of documents easier when accidental clicks
on links do not activate the links. To set LibreOffice to activate hyperlinks using an ordinary
click, deselect this option.

The other options on this dialog should be self-explanatory.

Personalization
You can customize the overall appearance of LibreOffice with themes designed for Mozilla Firefox.

On the LibreOffice — Personalization page, select Own Theme and then click Select Theme.
Another dialog opens. Type a search term, click Search, and wait while theme thumbnails load.
Select one and click OK to apply the theme. After a brief pause the appearance of LibreOffice will
refresh and reflect the selected theme. An example is shown in Figure 13. For full details about
themes, visit the Mozilla website: https://www.https://addons.mozilla.org/en-US/firefox/themes/

Firefox Themes

1 Default look, do not use Themes

Pre-installed Theme (if available)

Select Theme

Figure 11: Personalization dialogs
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@ o0 Select Firefox Theme

Search Term or Firefox Theme URL

Categories

LibreOffice | | Color Music Nature Solid

_

Help oK Cancel

Figure 12: Theme selection from Mozilla Firefox

File Edit View Insert Format Table Tools Window Help' :

B-rE-des F el $E D¢ 0 G RN - & O - -
:ﬂ 000TextBody v LiheralionSan.s vliin « B 7 U E! == : iz o= ‘5‘5_ v a7 - 3 -

Figure 13: Sample personalized theme

Application colors

Writing, editing, and (especially) page layout are often easier when you can see the page margins
(text boundaries), the boundaries of tables and sections (in Writer documents), page breaks in
Calc, grid lines in Draw or Writer, and other features. In addition, you might prefer to use colors that
are different from LibreOffice’s defaults for such items as comment indicators or field shadings.

On the LibreOffice — Application colors page (Figure 14), you can specify which items are visible
and the colors used to display various items.

» To show or hide items such as text boundaries, select or deselect the options next to the
names of the items.

* To change the default colors for items, click the down-arrow in the Color Setting column by
the name of the item and select a color from the list box. Note that you can change the list
of available colors selecting other available palettes.

» To save your color changes as a color scheme, click Save, type a name in the Scheme
box, and then click OK.
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Color Scheme

Scheme: |LibreOffice i Save Delete

-

Custom Colors

On User interface elements Color setting
General
Document background [ ] Automatic nd
[ Textboundaries [ Automatic -
Application background [ ] Automatic =
[ Object boundaries [ Automatic -
& Table boundaries [ Automatic -
Font color I ~utomatic -
[ Unvisited links I ~utomatic -
] wisited links I ~utomatic hd

| oK | | Cancel Reset

Figure 14: Showing or hiding text, object, and table boundaries

Accessibility options

Accessibility options include whether to allow animated graphics or text, how long help tips remain
visible, some options for high contrast display, and a way to change the font for the LibreOffice
user interface.

Accessibility support relies on the Java Runtime Environment for communication with assistive
technology tools. The Support assistive technology tools option is not shown on all LibreOffice
installations. See Assistive Tools in LibreOffice in the Help for other requirements and information.

Select or deselect the options as required.

Miscellaneous Options
[] Usetextselection cursor in read-only text documents
& Allow animated images
& Allow animated text

Options for High Contrast Appearance
—] Automatically detect high contrast mode of operating system
[] UseautomaticFont color For screen display

& Use system colors For page previews

Figure 15: Choosing accessibility options

Advanced options

Java options
If you install or update a Java Runtime Environment (JRE) after you install LibreOffice, or if
you have more than one JRE installed on your computer, you can use the LibreOffice —
Advanced options page to choose the JRE for LibreOffice to use.
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£7 Note

LibreOffice needs Java to run several wizards (such as File > Wizards > Letter) and
to run databases with the internal HSQLDB engine.

% 0 Options - LibreOffice - Advanced

¥ LibreOffice Java Options

User Data ikl
General & Usea Javaruntime environment
g:ie:é Java runtime environments (JRE) already installed:
Paths Vendor Version Features Add...
Fonks S :
Security O
Personalization Parameters...
Application Colors
Accessibility Class Path...
Online Update
OpenCL
* Load/Save
* Language Settings
> LibreOffice Writer e i i i f
b LibreOFffice Writer/web Location: fusr/lib/jvm/java-8-openjdk-amd64/jre
P LibreOffice Base
» Charts Optional Features
F Internet & Enable experimental features (may be unstable)
& Enable macro recording (may be limited)
Open Expert Configuration
Help | OK | | Cancel Reset

Figure 16: Choosing a Java runtime environment

If you are a system administrator, programmer, or other person who customizes JRE
installations, you can use the Parameters and Class Path pages (reached from the Java
page) to specify this information.

If you do not see anything listed in the middle of the page, wait a few minutes while
LibreOffice searches for JREs on the hard disk.

If LibreOffice finds one or more JREs, it will display them there. You can then select the Use
a Java runtime environment option and (if necessary) choose one of the JREs listed.

Optional (unstable) options

Enable experimental features
Selecting this option enables features that are not yet complete or contain known bugs. The
list of these features is different version by version.

Enable macro recording (limited)
This option enables macro recording, with some limitations. Opening a window, switching
between windows, and recording in a different window to that in which the recording began,
are not supported. Only actions relating to document contents are recordable, so changes in
Options or customizing menus are not supported. For more about macro recording, see
Chapter 13, Getting Started with Macros.

Expert Configuration
Most users will have no need to use this. Click the Expert Configuration button to open a
new window in which you can fine-tune the LibreOffice installation. The page offers detailed
configuration options for many aspects of LibreOffice's appearance and performance.
Double-click on a listed preference to enter a value to configure the preference.
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A Caution

The Expert Configuration dialog lets you access, edit, and save configuration
preferences that can turn the user profile of LibreOffice unstable, inconsistent, or even
unusable.

Basic IDE options

The Basic IDE Options are available after Enable experimental features has been selected on
the Advanced page of the Options dialog and the options have been saved. These options are for
macro programmers and are not discussed here.

Code Completion

Enable code completion

Code Suggestion

Autocorrection
Autoclose quotes
Autoclose parenthesis

Autoclose procedures

Language Features

Use extended types

Figure 17: Basic IDE Options dialog

Online update options

On the LibreOffice — Online Update page (Figure 18), you can choose whether and how often to
have the program check the LibreOffice website for program updates. If the Check for updates
automatically option is selected, an icon appears at the right-hand end of the menu bar when an
update is available. Click this icon to open a dialog where you can choose to download the update.

If the Download updates automatically option is selected, the download starts when you click the
icon. To change the download destination, click the Change button and select the required folder in
the file browser window.

If the Send OS version & simple hardware info option is selected, the information of the
computer architecture and operating system will be sent to the server for statistics collection.

Online Update Options
® Check for updates automatically

Every day
@® Everyweek

Every month
Last checked: 07/15/18, 05:17:00 PM
Check Now

Download updates automatically

Download destination: /home/olivier/Desktop
Change...

Send OS version and basic hardware information

User Agent: LibreOffice 6.0.5.2
(54c8cbb85F300ac59db32feBa675(f7683cd5a16;
Linux;
X86_64;
)

Figure 18: Online update options
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OpenCL options

OpenCL (Open Computing Language) is a software architecture used to write programs that run in
different processors of the computer, such as the CPU and GPU (graphics processing unit) of the
video card. With OpenCL enabled, LibreOffice can benefit from the very fast numerical calculations
performed in the GPU, which is especially useful in very large spreadsheets with extensive
calculations. The computer video card driver must have support for OpenCL to use this feature.

OpenCL Options —Allow use of Software Interpreter (even when OpenCL is not available)
Mark this box to emulate OpenCL if your computer video card driver does not support
OpenCL.

Allow use of OpenCL
Let LibreOffice use the video card GPU to perform numerical calculation with great speed
gain. The two boxes below list the OpenCL drivers whitelist and blacklist. Click the Edit,
Add... and Delete buttons to modify the lists entries.

OpenCL Options

& Allow use of Software Interpreter (even when OpencCL is not available)

& Allow use of OpencCL;

OpenCL is not used.

Figure 19: OpenCL options

Choosing options for loading and saving documents

You can set the options for loading and saving documents to suit the way you work.

If the Options dialog is not already open, click Tools > Options. Click the expansion symbol (+ or
triangle) to the left of Load/Save.

General

Most of the choices on the Load/Save — General page are familiar to users of other office suites.
Some items of interest are described below.

Load user-specific settings with the document
A LibreOffice document contains certain settings that are read from the user’s system. When
you save a document, these settings are saved with it.

Select this option so that when a document loads, it ignores the stored settings in favor of the
settings on your computer.

Even if you do not select this option, some settings are taken from your LibreOffice
installation:

+ Settings available in File > Print > Options

* Name of Fax

* Spacing options for paragraphs before text tables

* Information about automatic updating for links, field functions and charts
* Information about working with Asian character formats.
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% O Options - Load/Save - General

¥ LibreOffice Load
User Data ik}
General [ Load userspecific settings with the document
View
Print
Paths
Fonts Save
Security
Personalization
Application Colors "] Edit document properties before saving
Accessibility
Advanced —| Always create backup copy
Basic IDE -
Online Update [ Save URLs relative to File system
OpenCL
¥ Load/Save

[ Load printer settings with the document

& Save AutoRecoveryinformation every: [10 - minutes

[ save URLs relative to internet

v

gperties Default File Format and ODF Settings

Microsoft Office ODF format version: |1.2 Extended (recommended) =

HTML Compatibility
* Language Settings & warn when not saving in ODF or default Format
» LibreOffice Writer
*  LibreOFfice Writer/Web Document type: Text document 2
» LibreOffice Base
» Charts Always save as: ODF Text Document (*.odkt) =
* Internet

Help | OK || Cancel Reset

Figure 20: Choosing Load and Save options

The following setting is always loaded with a document, whether or not this option is marked:

« Data source linked to the document and its view.

If you deselect this option, the user’s personal settings do not overrule the settings in the
document. For example, your choice (in the options for LibreOffice Writer) of how to update
links is affected by the Load user-specific settings option.

Load printer settings with the document
If enabled, the printer settings will be loaded with the document. This can cause a document
to be printed on a distant printer (perhaps in an office setting), if you do not change the
printer manually in the Print dialog. If disabled, your standard printer will be used to print this
document. The current printer settings will be stored with the document whether or not this
option is selected.

Save AutoRecovery information every __ Minutes
Choose whether to enable AutoRecovery and how often to save the information used by the
AutoRecovery process. AutoRecovery in LibreOffice saves the information needed to restore
all open documents in case of a crash. If you have this option set, recovering your document
after a system crash will be easier.

Edit document properties before saving
If you select this option, the Document Properties dialog pops up to prompt you to enter
relevant information the first time you save a new document (or whenever you use Save As).

Always create backup copy
Saves the previous version of a document as a backup copy whenever you save a
document. Every time LibreOffice creates a backup copy, the previous backup copy is
replaced. The backup copy gets the extension BAK. Authors whose work may be very
lengthy should always consider using this option.
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Save URLs relative to file system | internet
Use this option to select the default for relative addressing of URLSs in the file system and on
the Internet. Relative addressing is only possible if the source document and the referenced
document are both on the same drive.

A relative address always starts from the directory in which the current document is located.
In contrast, absolute addressing always starts from a root directory. The following table
demonstrates the difference in syntax between relative and absolute referencing.

Examples File system Internet
relative ..[images/img.jpg ../images/img.jpg
absolute file:/l/c|/work/images/img.jpg http://myserver.com/work/images/img.jpg

If you choose to save relatively, the references to embedded graphics or other objects in your
document will be saved relative to the location in the file system. In this case, it does not
matter where the referenced directory structure is recorded. The files will be found regardless
of location, as long as the reference remains on the same drive or volume. This is important if
you want to make the document available to other computers that may have a completely
different directory structure, drive or volume names. It is also recommended to save relatively
if you want to create a directory structure on an Internet server.

If you prefer absolute saving, all references to other files will also be defined as absolute,
based on the respective drive, volume or root directory. The advantage is that the document
containing the references can be moved to other directories or folders, and the references
remain valid.

Default file format and ODF settings
ODF format version. LibreOffice by default saves documents in OpenDocument Format
(ODF) version 1.2 Extended. While this allows for improved functionality, there may be
backwards compatibility issues. When a file saved in ODF 1.2 Extended is opened in an
editor that uses earlier versions of ODF (1.0/1.1), some of the advanced features may be
lost. Two notable examples are cross-references to headings and the formatting of numbered
lists. If you plan to share documents with people who use editors that use older versions of
ODF, you may wish to save the document using ODF version 1.0/1.1.

Document type. If you routinely share documents with users of Microsoft Office, you might
want to change the Always save as attribute for documents to the Microsoft Office formats.
Current versions of Microsoft Word can open ODT files, so this may no longer be needed.

VBA Properties

On the VBA Properties page, you can choose whether to keep any macros in Microsoft Office
documents that are opened in LibreOffice.

If you choose Load Basic code, you can edit the macros in LibreOffice. The changed code is
saved in an ODF document but is not retained if you save into a Microsoft Office format.

If you choose Save original Basic code, the macros will not work in LibreOffice but are retained
unchanged if you save the file into Microsoft Office format.

If you are importing a Microsoft Word or Excel file containing VBA code, you can select the option
Executable code. Whereas normally the code is preserved but rendered inactive (if you inspect it
with the StarBasic IDE you will notice that it is all commented), with this option the code is ready to
be executed.
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Microsoft Word 97/2000/XP
F] Load Basic code

[=] Executable code

] Save original Basic code

Microsoft Excel 97/2000/XP
[l Load Basic code

[ Executable code

F Save criginal Basic code

Microscft PowerPoint 97/2000/XP
Fl Load Basic code

F Save original Basic code

Figure 21: Choosing Load/Save VBA Properties

Save original Basic code takes precedence over Load Basic code. If both options are selected
and you edit the disabled code in LibreOffice, the original Microsoft Basic code will be saved when
saving in a Microsoft Office format.

To remove any possible macro viruses from the Microsoft Office document, deselect Save original
Basic code. The document will be saved without the Microsoft Basic code.

Microsoft Office

On the Load/Save — Microsoft Office page (Figure 22), you can choose what to do when importing
and exporting Microsoft Office OLE objects (linked or embedded objects or documents such as
spreadsheets or equations).

Select the [L] options to convert Microsoft OLE objects into the corresponding LibreOffice OLE
objects when a Microsoft document is loaded into LibreOffice (mnemonic: “L” for “load”).

Select the [S] options to convert LibreOffice OLE objects into the corresponding Microsoft OLE
objects when a document is saved in a Microsoft format (mnemonic: “S” for “save”).

Embedded Objects

5]

MathType to LibreOffice Math or reverse
WinWord to LibreOffice Writer or reverse
Excel to LibreOffice Calc or reverse
PowerPaint 1o LibreOffice Impress or reverse
Smartar to LibreOffice shapes or reverse

Ea@aagcE
EoaBE

[L]: Load and convert the object

[5]: Convert and save the object
Character Highlighting

Export as: () Highlighting ~ Shading

Figure 22: Choosing Load/Save Microsoft Office options
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HTML compatibility

Choices made on the Load/Save — HTML Compatibility page (Figure 23) affect HTML pages
imported into LibreOffice and those exported from LibreOffice. See HTML documents;
importing/exporting in the Help for more information.

HTML Compatibility

Font Sizes Import

Size1: |7 = ] Use'English (USA)' locale for numbers
Size2: 110 = Import unknown HTML tags as fields
size3: [12 = Ignore font settings
Sized: |14 : Export

: - LibreOffice Basic
Size5: (18 =

_ - & Displaywarning
Size6: (24 -

Prinkt layout

Size 7: 36 2

& Copylocalimages to Internet

Characterset: |Unicode (UTF-8) o

Figure 23: Choosing HTML compatibility options

Font sizes
Use these fields to define the respective font sizes for the HTML <font size="1"> to <font
size="7"> tags, if they are used in the HTML pages. (Many pages no longer use these tags.)

Import - Use 'English (USA)' locale for numbers
When importing numbers from an HTML page, the decimal and thousands separator
characters differ according to the locale of the HTML page. The clipboard, however, contains
no information about the locale. If this option is not selected, numbers will be interpreted
according to the Locale setting in Tools > Options > Language Settings > Languages
(see page 23). If this option is selected, numbers will be interpreted as for the English (USA)
locale.

Import — Import unknown HTML tags as fields
Select this option if you want tags that are not recognized by LibreOffice to be imported as
fields. For an opening tag, an HTML_ON field will be created with the value of the tag name.
For a closing tag, an HTML_OFF will be created. These fields will be converted to tags in the
HTML export.

Import - Ignore font settings
Select this option to have LibreOffice ignore all font settings when importing. The fonts that
were defined in the HTML Page Style will be used.

Export
To optimize the HTML export, select a browser or HTML standard from the Export box. If
LibreOffice Writer is selected, specific LibreOffice Writer instructions are exported.

Export - LibreOffice Basic
Select this option to include LibreOffice Basic macros (scripts) when exporting to HTML
format. You must activate this option before you create the LibreOffice Basic macro;
otherwise the script will not be inserted. LibreOffice Basic macros must be located in the
header of the HTML document. Once you have created the macro in the LibreOffice Basic
IDE, it appears in the source text of the HTML document in the header.

If you want the macro to run automatically when the HTML document is opened, choose
Tools > Customize > Events. See Chapter 13, Getting Started with Macros, for more
information.
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Export — Display warning
When the LibreOffice Basic option (see above) is not selected, the Display warning option
becomes available. If the Display warning option is selected, then when exporting to HTML
a warning is shown that LibreOffice Basic macros will be lost.

Export - Print layout
Select this option to export the print layout of the current document as well. The HTML filter
supports CSS2 (Cascading Style Sheets Level 2) for printing documents. These capabilities
are only effective if print layout export is activated.

Export — Copy local graphics to Internet
Select this option to automatically upload the embedded pictures to the Internet server when
uploading using FTP.

Export — Character set
Select the appropriate character set for the export.

Choosing language settings

To customize the language settings in LibreOffice, you can do any of the following:

* Install the required dictionaries
* Change some locale and language settings
* Choose spelling options

Install the required dictionaries

LibreOffice automatically installs many dictionaries with the program. To add other dictionaries, be
sure you are connected to the Internet, and then choose Tools > Language > More Dictionaries
Online. LibreOffice will open your default web browser to a page containing links to additional
dictionaries that you can install. Follow the prompts to select and install the ones you want.

Change some locale and language settings

You can change some details of the locale and language settings that LibreOffice uses for all
documents, or for specific documents.

In the Options dialog, click the expansion symbol (+ sign or triangle) by Language Settings >
Languages. The exact list shown depends on the Enhanced language support settings (see
Figure 25).

+ LibreOffice #I LibreOffice
+ Load/Save + Load/Save
=1 Language Settings = Language Settings
Lanquages: Lanquages
Writing Aids Writing Aids
English sentence chedking Searching in Japanese
+ LibreQffice Writer Asian Layout
+ LibreQffice Writer Mieb Complex Text Layout
+ LibreOffice Base English sentence chedking
+ Charts # LibreOffice Writer
# Internet + - LibreOffice Writer/M/eb
+/ LibreOffice Base
# Charts
1 Internet

Figure 24: LibreOffice language options, without and with Asian and
CTL options enabled
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On the right-hand side of the Language Settings — Languages page, change the User interface,
Locale setting, Default currency, and Default languages for documents as required. In the
example, English (USA) has been chosen for all the appropriate settings.

gs - Languages

Language OFf

User interface: Default - English (USA) =
Locale setting: English (USA) =
Decimal separator key: & same as locale setting (, )

Default currency: Default- USD ™

Date acceptance patterns: |M/D/Y;M/D

Default Languages for Documents

Weskern: "‘@ English (UsA) ™
] Asian: Default - Chinese (simplified)
| Complex text layout: Default-Hind

For the current document only

Enhanced Language Support

| Ignore system inpukt language

Figure 25: Choosing language options

User interface
The language of the user interface is usually set at the time LibreOffice is installed to match
the language of the operating system. If more than one language has been installed for
LibreOffice, you can select which language will be used for menus, dialogs, and help files.

Locale setting
The local setting is the basis for many other settings within LibreOffice, for example defaults
for numbering, currency, and units of measure. Unless you select something else here, the
locale of the operating system will be set as default.

Decimal separator key
If the Decimal separator key option is selected, LibreOffice uses the character defined by the
default locale. If this option is not selected, the keyboard driver defines the character used.

Default currency
The Default currency is that used in the country entered as Locale. The default currency
determines the proper formatting of fields formatted as currency. If the locale setting is
changed, the default currency changes automatically. If the default currency is changed, all
dialogs involving currency and all currency icons will be changed in all open documents.
Documents that were saved with one currency as the default will open using the new
currency defaults.

Date acceptance patterns
Date acceptance patterns define how LibreOffice recognizes input as dates. Locale also
defines the default expression of dates. You can define additional date patterns, separated
by semicolons, using Y, M, & D for Year, Month, and Day. LibreOffice will always correctly
interpret dates entered in ISO 8601 format as Y-M-D and YYYY-MM-DD.
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A Caution

Data entered into a Calc spreadsheet or a Writer table must be entered in a format
defined by Locale in order to be recognized as dates.

Default languages for documents

Select the languages used for the spelling checker, thesaurus, and hyphenation features of
LibreOffice. If these options are only for the current document, select For the current
document only.

If necessary, select the options to enable support for Asian languages (Chinese, Japanese,
Korean) and support for CTL (complex text layout) languages such as Urdu, Thai, Hebrew,
and Arabic. If you choose either of these options, the next time you open this dialog, you will
see some extra choices under Language Settings, as shown in Figure 24. These choices
(Searching in Japanese, Asian Layout, and Complex Text Layout) are not discussed here.

Enhanced language support — Ignore system input language

Default language settings depend on the Locale setting. The default locale is based on that
of the computer’s operating system. A keyboard layout is normally based on the language
used by the operating system but can be changed by the user. If this option is not selected,
and there is a change in keyboard layout, input from the keyboard will be different from what
is expected.

Choose spelling options

To choose the options for checking spelling, click Language Settings > Writing Aids. In the
Options section of the page (Figure 26), choose the settings that are useful for you.

Some considerations:

If you do not want spelling checked while you type, deselect Check spelling as you type.
This option can also be deselected using the Automatic Spell Checking button on the
Standard toolbar.

If you want grammar to be checked as you type, you must have Check spelling as you
type enabled too.

If you use a custom dictionary that includes words in all uppercase and words with numbers
(for example, AS/400), select Check uppercase words and Check words with numbers.

Check special regions includes headers, footers, frames, and tables when checking
spelling.

Here you can also select which user-defined (custom) dictionaries are active by default, and add or
remove user-installed dictionaries, by clicking the New or Delete buttons. Dictionaries installed by
the system cannot be deleted.
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gs - Writing Aids

Writing Aids
Available language modules:

Edit...

Z Hunspell spellChecker

& Lightproof grammar checker (English)
& Libhyphen Hyphenator |

= s s -

User-defined dictionaries:

% en-Us [English (UsSA)] | New.
& en-GB [English (UK)]
B technical [all]

& IgnoreAllList [All] Delete

Edit...

Options:

Check spelling as you type Edit...
Check grammar as you type :]
&  Check uppercase words

[1  checkwords with numbers

& Check special reaions
Get more dictionaries online...

Figure 26: Choosing languages, dictionaries, and options for checking spelling

English sentence checking

On the Language Settings > English sentence checking page, you can choose which items are
checked for, reported to you, or converted automatically. This menu is also found in the English
dictionaries extension installed by default by LibreOffice. Select Tools > Extension Manager,
select the English spelling dictionaries and click the Options button to reveal the menu. Select
which of the optional features you wish to check.

After selecting the additional grammar checks, you must restart LibreOffice, or reload the
document, for them to take effect.

gs - English sentence checking

Grammar checking

[] Possible mistakes [] Capitalization

[] word duplication [] Parentheses
Punctuation

B word spacing [] Emdash

[] Quotation marks B Multiplication sign

[] sentence spacing [] Endash

[] Apostrophe [ Ellipsis

[] Morespaces [] Minus sign
Others

[] convert to metric (°C, km/h, m, kg, [)
[] Thousand separation of large numbers
[] Convert to non-metric (°F, mph, ft, lb, gal)

Figure 27: Choosing options for checking sentences in English
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Grammar checking

Possible mistakes
Checks for things such as; with it’s, he don't, this things and so on.

Capitalization
Checks for the capitalization of sentences. The sentence boundary detection depends on
abbreviations.

Word duplication
Checks for all word duplication, rather than just the default words ‘and’, ‘or’, ‘for’, and ‘the’.

Parentheses
Checks for pairs of parentheses and quotation marks.

Punctuation

Word spacing
This option is selected by default. It checks for single spaces between words, indicating
instances of double or triple spaces, but not of more spaces than that.

Sentence spacing
Checks for a single space between sentences, indicating when one or two extra spaces are
found.

More spaces
Checks word and sentence spacing for more than two extra spaces.

Em dash; En dash
These options force a non-spaced em dash to replace a spaced en dash, or force a spaced
en dash to replace a non-spaced em dash.

Quotation marks
Checks for correct typographical double guotation marks.

Multiplication sign
This option is selected by default. It replaces an ‘X’ used as a multiplication symbol with the
correct typographical symbol.

Apostrophe
Replaces an apostrophe with the correct typographical character.

Ellipsis
Replaces three consecutive periods (full stops) with the correct typographical symbol.

Minus sign
Replaces a hyphen with the correct minus typographical character.

Others

Convert to metric; Convert to non-metric
Converts quantities in a given type of unit to quantities in the other type of unit: metric to
imperial or imperial to metric.

Thousands separation of large numbers
Converts a number with five or more significant digits to a common format, that is one which
uses the comma as a thousands separator, or to the ISO format which uses a narrow space
as a separator, depending on the locale setting for the document.

Other languages sentence checking

LibreOffice can also check sentences in other languages, notably Hungarian, Russian, and
Brazilian Portuguese. These checkers are enabled by default if the language is the computer’s
default language. The set of rules available for these sentence checkers depends on the language.
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Choosing Internet options

The Internet options available depend on your operating system.
Use the Proxy page (if available) to save proxy settings for use with LibreOffice.

> LibreOffice Sending Documents as E-mail Attachments

¥ Load/Save
Gé{neral E-mail program: |fusr/bin/thunderbird

VBA Properties & suppress hidden elements of documents
Microsoft Office o S5

HTML Compatibility
Language Settings
LibreOFfice Writer
LibreOFfice Writer/Web
LibreOFffice Base
Charts
Internet

Proxy

4 vV VvV YVYVYYWY

Mediawiki

Figure 28: Internet options, showing E-mail page available to Linux users

If you are using a Unix- or Linux-based operating system (including Mac OS X), an additional page
of E-mail options is available, where you can specify the e-mail program to use when you send the
current document as e-mail. Under Windows the operating system’s default e-mail program is
always used.

A MediaWiki publisher is included on Windows and Linux. To enable it, select MediaWiki in the
Internet options, then click the Add button to open the dialog shown in Figure 29. Here you can
specify the address (URL) and log-in information for a wiki. You can add several wikis to the list.

3 Mediawiki
MediaWiki Server

URL [

Account

Username |

Password |

l Help l l oK ] l Cancel

Figure 29: Specifying a MediaWiki server account

Controlling LibreOffice’s AutoCorrect functions

Some people find some or all of the items in LibreOffice’s AutoCorrect function annoying because
they change what you type when you do not want it changed. Many people find some of the
AutoCorrect functions quite helpful; if you do, then select the relevant options. But if you find
unexplained changes appearing in your document, this is a good place to look to find the cause.

To open the AutoCorrect dialog, click Tools > AutoCorrect > AutoCorrect Options. (You
need to have a document open for this menu item to appear.) In Writer, this dialog has five
tabs. In other components of LibreOffice, the dialog has only four tabs. More details are
given in the component guides.
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Troubleshooting LibreOffice in Safe Mode

Safe Mode offers various options to help restore an instance of LibreOffice that has become
corrupted and stopped working or fails to launch for a variety of reasons.

To access Safe Mode:

Choose Help > Restart in Safe Mode... from the menu bar
Start LibreOffice from the command line with the --safe-mode option
In Windows Only, choose LibreOffice (Safe Mode) from the Start Menu

#® Safe Mode

LibreOfficeDev is now running in safe mode which temporarily disables your user configuration and extensions.
You can make one or more of the following changes to your user profile to return LibreOfficeDev to a working state.
The proposed changes get more radical from top down so it is recommended to try them successively one after ancther.

@ Restore from backup!
Restore user configuration to the last known working state
Restore state of installed user extensions ko the last known working state

Configure

Disable all user extensions

Disable hardware acceleration (OpenGL, OpencCL)
Extensions

Uninstall all user extensions

Reset state of shared extensions

Reset state of bundled extensions

Reset to factory settings
Reset sett ngs and user nterface modifications

Reset entire user profile

> Advanced

Help | Continuein Safe Mode | Restartin Normal Mode Apply Changes and Restart

Figure 30: LibreOffice Safe Mode

In Safe Mode, you can find options for repairing or restoring your copy of LibreOffice. The
following options get more extreme from the top down, so it is recommended that you try them
successively.

Restore from Backup — LibreOffice keeps backups of previous configurations and activated
extensions. Use this option to restore the user configuration, installed extensions or both,
to a previous known working state if you suspect that your problems were caused by recent
changes to either.

Configure — This option allows you to disable all user extensions, hardware acceleration, or
both. This is a good option if you are experiencing crashes on start up or visual glitches
that are often related to hardware acceleration.

Extensions — If you suspect that a corrupted extension is blocking or causing LibreOffice to

crash, this option allows you to uninstall all user extensions, as well as resetting the state of
any shared or bundled extensions. In the case of shared or bundled extensions, the option
will only work if the user has the proper system access rights and should be exercised with

caution.

Reset to Factory Settings — If all of the above fails, you can reset your settings and your
user interface modifications, or your entire profile back to factory defaults.

— Reset Settings and User Interface Modifications — this will reset your User Interface and
configuration changes, but keep things like your personal dictionary, templates, etc...

— Reset Entire User Profile — this will erase all customized options and return your user
profile to the factory default state.
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* Apply Changes and Restart - Choose this option to apply any of the above changes and
restart LibreOffice.

» Continue in Safe Mode — Continuing in Safe Mode will allow you to work in LibreOffice as
you are used to, but using a temporary profile that was created on start up. Any extensions
or configuration options you had set up previously will have to be reconfigured in order to
be used, bearing in mind that any changes made to the temporary user profile will be lost
after any restart.

» Restart in Normal Mode — If you arrived in Safe Mode accidentally, this option will discard
any changes, terminate Safe Mode and restart LibreOffice normally.

Z Note

If you are unable to solve your problem using Safe Mode, the advanced tab will
provide instructions on receiving further aid.

In the advanced tab you also have the option to create a zip file of your corrupted user
profile which can then be uploaded to the bug tracking system where it can be further
investigated by the developers.

However, be aware that your uploaded user profile may contain sensitive information
such as installed extensions, personal dictionaries and settings.
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