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macOS equivalent

Effect
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Ctrl (Control) & (Command) Used with other keys
Ctrl+Q H£+0 Exit / quit LibreOffice
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Introduction

This chapter covers methods for collaboration through sharing and reviewing spreadsheets:
simultaneous editing, recording changes, adding comments, reviewing changes, merging and
comparing documents, saving, and using document versions.

Some menu commands are not available (grayed out) when sharing or change tracking are active.

Sharing spreadsheets

Sharing a spreadsheet allows several users to open the same file for editing at the same time. The
spreadsheet needs to be on a shared drive, server, website, or similar. Some conditions must be
met on operating systems with user permission management:

* The shared file needs to reside in a location which is accessible by all collaborators.

* The file permissions for both the document and the corresponding lock file need to be set
so that all collaborators can create, delete, and change the files.

Consult your operating system’s documentation for details on setting file permissions. See also
“Opening and saving files on remote servers” in Chapter 1, Introducing LibreOffice, in the Getting
Started Guide.

@ Tip

Each collaborator should enter their name in Tools > Options > LibreOffice > User
Data.

Setting up a spreadsheet for sharing
With the spreadsheet open, choose Tools > Share Spreadsheet to enable or disable sharing.
[ ] Share Document '

. Share this spreadsheet with other users

Mote: Changes to formaitting attributes like fonts, colors, and number formats
will not be saved and some functionalities like editing charts and drawing
objects are not available in shared mode. Turn off shared mode to get
exclusive access needed for those changes and functionalities.

| Users Currently Accessing This Spreadsheet

Name Accessed
Jean Weber (exclusive access) 26/08/2018 06:41 06:41

el cancel | (D

Figure 1: Choosihg to share a spréadsheét

To enable sharing, select the checkbox at the top of the dialog (Figure 1) and click OK. If the
spreadsheet has been saved previously, a message appears stating that you must save it to
activate shared mode; click Yes to continue. If the spreadsheet has not been saved previously, the
Save dialog opens. After saving, the text “(shared)” is shown on the Title bar, after the title.
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Tools > Share Spreadsheet can also be used to switch a spreadsheet from shared to unshared.
However, this means that other users can no longer edit it. Instead, you may wish to save a copy of
the shared spreadsheet using another name or path, thus creating a copy of the shared
spreadsheet, and then switch the copy to unshared.

Opening a shared spreadsheet

When you open a shared spreadsheet, a message appears stating that some features are not
available in this mode. Click OK to open the document. You can select the option to not show the
warning again.

The following features are disabled in a shared spreadsheet:
Edit > Track Changes, except for Merge Document

Insert > Media > Audio or Video
Insert > Comment

Insert > Object

Insert > Chart

Insert > Named Range or Expression
Insert > Pivot Table

Insert > Floating Frame

Insert > Fontwork

Insert > Signature Line

Format > Merge Cells
Format > Print Ranges

Sheet > Move or Copy Sheet

Sheet > Delete Sheet

Sheet > Insert Sheet from File

Sheet > Named Ranges and Expressions
Sheet > Rename Sheet

Sheet > Sheet Tab Color

Data > Define Range

Data > Sort

Data > Sort Ascending
Data > Sort Descending
Data > Subtotals

Data > Validity

Data > Multiple Operations
Data > Consolidate

Data > Group and Outline
Data > Pivot Table

Tools > Protect Sheet
Tools > Protect Spreadsheet Structure

Saving a shared spreadsheet

When you save a shared spreadsheet, if it has not been modified and saved by another user since
you opened it, it is saved as usual.

If the spreadsheet has been modified and saved by another user since you opened it, one of the
following will occur:

» If the changes do not conflict, the document is saved, the message “Your spreadsheet has
been updated with changes saved by other users” appears, and any cells modified by the
other user are shown with a red border.
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] Resolve Conflicts

There are conflicting changes in this shared spreadsheet. Conflicts must be resolved before saving the spreadsheet. Keep either
own or other changes.

Conflict Author Date

. ¥ Lulu-sales (ODocs
Cell B318 changed from 'again’ to ‘again and again and again’ Eric Lindsay 06/05/2019 13:08
Cell B318 changed from 'again’ to ‘once more’ Jean Weber 06/05/2019 13:08

Keep Mine Keep Other

Help Keep All Mine Keep All Gthers Cancel

Figure 2: Resolve Conflicts dialog

» If the changes conflict, the Resolve Conflicts dialog (Figure 2) is shown. You must decide
for each conflict which version to keep, yours or the other person’s. When all conflicts are
resolved, the document is saved. While you are resolving the conflicts, no other user can
save the shared document.

» If another user is trying to save the shared spreadsheet and resolve conflicts, they see a
message that the file is locked due to a merge in progress. They can cancel the Save
command and retry saving later.

When you successfully save a shared spreadsheet, the document shows the latest version of all
changes saved by all users.

Reviewing documents

You can use several methods to review, edit, and comment on a spreadsheet. Each reviewer
works on a separate copy of the document.

* You can use change marks to show added and deleted material. Later, you or another
person can review the document and accept or reject each change.

* You can make changes to a copy of the document (stored in a different folder, under a
different name, or both), then use Calc to compare the files and show the changes. See
page 12.

* You can save versions that are stored as part of the original file. See page 12.

Reviewers can leave comments in the document, either attached to specific changes or
standalone.

Preparing a document for review (optional)

Before you send a spreadsheet to someone else to review or edit, you may want to set it up so that
the editor or reviewer does not have to remember to turn on the revision marks.

After you have turned on revision marks, you can optionally password protect the spreadsheet so
that any user must enter the correct password in order to accept or reject changes.

1) Open the spreadsheet and select Edit > Track Changes > Record from the Menu bar. You
can also use File > Properties > Security and select Record changes.

2) (Optional) Click Edit > Track Changes > Protect. On the Protect Records dialog, type a
password (twice) and click OK. You can also use File > Properties > Security and click
the Protect button to open the Enter Password dialog.
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Recording changes

To record changes, open the spreadsheet and make sure that the Edit > Track Changes >
Record menu item has a check mark next to it, indicating that change recording is active.

A Caution

After making some changes, do not turn off change recording. Turning off change
recording in Calc causes all the recorded changes to be accepted and no longer
shown as changes. A message box will warn you if you try to do this.

When changes are made in a cell, a colored border with a dot in the upper left-hand corner
appears around the cell (Figure 3). A deleted column or row is marked by a heavy colored bar.

A B c | D | E]

E Baseball Budget Proposal

2 |Item Description Quantity Cost/item Total Comments
3 |Uniforms 10 $50.00 $500.00 Need to update the tee
4 |Baseballs 250 $2.00 $500.00 We need 10 per game
5 |Umpire fees 25 $50.00 $1,250.00 1 umpire per game
6 Bats 5 $35.00 $175.00 We need bats of variot
7 |Snacks m $15.00 $0.00 Max cost per game for
| 8 |Batting helmets 5 $40.00 $200.00 We need a minimum o
| 9 |Catching gear 1 $300.00 $300.00 Need to protect catche
10 |Spare gloves $45.00 $90.00 Just in case someone
| $3.015.00 Total
]

Ff&ure 3: Edited document with red border on changed cells

To see the changed information, hover the mouse pointer over the changed cell. See Figure 4.

1 Ba jean Weber, 26/05/2019 08:50:29:

2 Iltem Description Quantity o Cell B3 changed from '25' to '10'

3 Uniforms | 10 7 ; eed 1o updat
4 |Baseballs 250 $2.00  $500.00 Weneed10p

5 \Umpire fees 25 $50.00 $1,250.00 1 umpire per ¢
Figure 4: Showing details of the change

£7] Note

Some changes, for example cell formatting, are not recorded and marked.

@ Tip

To change the color that indicates a changed cell, select Tools > Options >
LibreOffice Calc > Changes.

You may want to explain your rationale for the changes. You can do this by adding comments to
the changes you made or by adding general comments to the spreadsheet.

Adding comments to changes

Calc automatically adds to any recorded change a comment that describes what was changed (for
example, Cell B4 changed from ‘9’ to ‘4’). Reviewers and authors can add their own comments to
explain their reasons for the changes.

Reviewing documents | 7



To add a comment to a change:

1) Make the change to the spreadsheet.
2) Select the cell with the change.

3) Choose Edit > Track Changes > Comment from the Menu bar. A small dialog opens. Type
your comment and click OK. See Figure 5.

£7] Note

Do not use Insert > Comment from the Menu bar or the context menu for this
purpose. Comments inserted using that method are handled differently (see page 9)
and do not appear in the Manage Changes dialog.

_ A B C | D |E]
1 Baseball Budget Proposal
2 |Item Description Quantity Cost/item Total Comments
3 Uniforms | 10| $50.00 $500.00 Need to update the
4 Baseba“s 250 @ @ Cell B3 changed from "25’ to '10' r ga
i Umpire fees 25 ﬂ COA::::::S Jean Weber, 26/05/2019 08:50 -ame
& Bats 5 § Tex of vé
7 Snacks m 3 We can only afford 10 uniforms] ame
| & |Batting helmets 5 § imui
| 9 |Catching gear 1 % t cat
‘10 Spare gloves § mec
1
12
? Help - Cancel E |
| o |

i ' 1
Figure 5: Entering a comment associated with a change

After you have added a comment to a changed cell, you can see the change and the comment by
hovering the mouse pointer over the cell, as shown in Figure 6.

A B c \ D [E]
E Ba jean Weber, 26/05/2019 08:50:29:
2 |Item Description Quantity gos We can only afford 10 uniforms
3 \Uniforms [ 10 ( Cell B3 changed from "25' to '10') ate
4 Baseballs 250 $2.00  $500.00 We need 10 pe
s |Umpire fees 25 $50.00 $1,250.00 1 umpire per ga

Figure 6: Comment added to cell B3

The comment also appears in the dialog when you are accepting and rejecting changes, as shown
in the first line of Figure 10 on page 11.

Editing comments on changes

1) Select the cell with the change comment that you want to edit.

2) Choose Edit > Track Changes > Comment from the Menu bar. The box shown in Figure 5
opens.

3) Edit the comment and click OK.
The automatically-added comment provided by Calc cannot be edited.

You can move through the comments by using the arrows at the bottom of the dialog.
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Adding other (general) comments

Calc provides another type of comments, which authors and reviewers often use to exchange
ideas or ask for suggestions.

To add a general comment:

1) Select the cell that the comment applies to.

2) Select Insert > Comment or right-click and select Insert Comment. The box shown in
Figure 7 appears.

We need 10 per game

1 umpire per game |
We need bats of various sizes

Max cost per game for after-game snacks e
|We need a minimum of 5

Need to protect catcher; old gear damaged

Figure 7: Inserting a comment

3) Type your comment in the box, then click outside the box to close it.

Now the cell to which you added the comment has a colored dot in the upper right-hand corner, as
shown in Figure 8. It does not have a colored border, unless the cell was also changed.

We need bats of various sizes

Max cost per game for after-game snacks

We need a minimum of 5 i
Figure 8: Colored dot in cell containing a comment

Comment
indicator

@ Tip

You can change the colors Calc uses for comments by selecting Tools > Options >
LibreOffice > Application Colors and adjusting the color for Notes background.

To view the comment you just added, hover the mouse pointer over the cell that has a comment;
the comment appears, as shown below.

We need 10 per game

1 umpire per game

We need bats of various sizes

Max cost per game for after-game snacks | 4
|We need a minimum of 5

Need to protect catcher; old gear damaged
Figure 9: Viewing a comment

Why do we need
5 helmets?

Editing general comments
You can edit and format the text of a general comment, just as you do for any other text.
1) Right-click on the cell containing the comment marker and choose Edit comment from the

context menu.

2) Calc shows the cell's comment. The cursor changes to the usual text-entry cursor, and the
Formatting toolbar changes to show text attributes.

3) When editing is done, click outside the comment to deselect it.
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Formatting general comments

You can change the background color, border style, transparency, and other attributes of a
comment.

1) Right-click on the cell containing the comment marker, and choose Show comment from
the context menu.

2) Click on the comment itself. The Formatting toolbar changes to show many of the comment
formatting options. These are the same as the options for formatting graphics; see Chapter
5, Using Graphics, for more information.

You can also right-click on the comment to see a menu of choices, some of which lead to
dialogs in which you can fine-tune the formatting; these dialogs are also discussed in
Chapter 5.

3) When done, click outside the comment to deselect it. To hide the comment again, right-click
on the cell and choose Hide Comment on the context menu.

Finding general comments

The small comment markers in the corners of cells can be difficult to see, so Calc provides two
other ways to find them: by showing all comments and by using the Navigator. To show all general
comments, choose View > Comments from the Menu bar. To hide all comments, choose View
Comments again.

If any general comments are in the spreadsheet, the Navigator shows a symbol (usually a + or an
arrow) next to the word Comments. Click on this symbol to display a list of comments. Double-click
on a comment in the list to jump directly to the cell it is associated with.

£7] Note

View > Comments and the Navigator show general comments but not the comments
associated with tracked changes.

Accepting or rejecting changes

When you receive a document with changes, you can step through each change and decide how
to proceed. To begin this process:

1) Open the edited document.

2) Select Edit > Track Changes > Manage. The Manage Changes dialog shown in Figure 10
appears.

3) You can step through the changes one at a time, choosing to accept or reject each change
as you go through. You can also accept or reject all changes at one time.

The Comment column by default contains an explanation of the change that was made. If the
reviewer added a comment to the change, it is displayed, followed by the description of the
change.

If a change has been superseded by a later change (by either the same person or another person),
the changes are hierarchically arranged with an expansion symbol for opening up the hierarchy.

Below the list of changes to be accepted or rejected are shown any changes that have previously
been dealt with.

On the Filter tab of this dialog (Figure 11), you can choose how to filter the list of changes: by date,
author, cell range, or comments containing specific terms. After selecting the filter criteria, switch
back to the List tab to see the results. Filtering the changes affects only the contents of the List tab
on the dialog, you will not see any filtered results in your spreadsheet.
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0 e

¥ Accepted
Changed cont Sheetl.F14
Changed cont Sheetl.F14
Changed cont Sheetl.F14

Jean Weber
Jean Weber
Jean Weber

Figure 10: Manage Changes dialog

31/12/2018

N @
Date:
since
and
Author:

Jean Weber

Range:

Comment:

AUI:I_'F'[

Reject

Manage Changes
ﬁ Filter
Action Position Author | Date Comment

Changed content_Sheet1.B3 Jean Weber 26/05/2019 08:5 We can only afford 10 uniforms (Cell B3 changed fror
Changed content Sheetl.C4 Jean Weber 26/05/2019 08:5 We can get a quantity discount. (Cell C4 changed frol
Changed content Sheetl.B7 Jean Weber 26/05/2019 08:5 Players can bring their own snacks. {Cell B7 changed
Changed content Sheetl.B10 Jean Weber 26/05/2019 08:5 Two new spares are enough. We also have old glove:
Changed content Sheetl.F2 Jean Weber 26/05/2019 09:3 (Cell F2 changed from 'Comments' to 'Notes')

26/05/2019 10:1 (Cell F14 changed from '<empty=' to 'cell with wrong
26/05/2019 10:1 (Cell F14 changed from ‘cell with wrong word' to "cell
26/05/2019 10:1 (Cell F14 changed from "cell with rong word' to '<=em;

Accept Reject Accept All Reject All ﬁ

Manage Changes

List[Filker

)
[an]
2
[}
(=]

©

<>

Accept All Reject All ﬁ

Figure 11: Filters set here affect the list of changes shown on the List tab

Merging documents

The processes discussed to this point are effective when you have one reviewer at a time.
Sometimes, however, multiple reviewers all return edited versions of a document at the same time.
In this case, it may be faster to review all of the changes at once, rather than one review at a time.

For this purpose, you can merge documents in Calc.

To merge documents, all of the edited documents need to have recorded changes in them.

1) Open the original document.

2) Select Edit > Track Changes > Merge Document.

Merging documents | 11



3) Afile selection dialog opens. Select a file you want to merge and click Open.

4) After the documents merge, the Manage Changes dialog opens, showing changes by more
than one reviewer. If you want to merge more documents, close the dialog and then repeat
steps 2 and 3.

Now all of the changes are combined into one document and you can accept or reject the changes.
Changes from different authors appear in cells outlined in different colors.

Comparing documents

Sometimes reviewers may not record the changes they make. Calc can find the changes by
comparing documents.

In order to compare documents you need to have the original document and the one that is edited.
To compare them:

1) Open the edited document that you want to compare with the original document.
2) Select Edit > Track Changes > Compare Document.
3) An open document dialog appears. Select the original document and click Open.

Calc finds and marks the changes as follows:

* All data that occurs in the edited document but not in the original is identified as inserted.
* All data in the original document that is not in the edited document is identified as deleted.
» All data that is changed is marked as changed.

From this point you can go through and accept or reject changes as described earlier.

Saving versions

For auditing and other purposes, you may need to save new versions of a spreadsheet. You can
do this by saving a copy of the spreadsheet (under a different name) after each revision, or by
using Calc’s version feature.

A Caution

If you select File > Save As for a document with different versions stored in it, the old
versions are not saved in the new file.

To use version management in Calc:

1) Choose File > Versions from the Menu bar. A version management dialog (Figure 12)
opens, showing a list of the existing versions saved in this file.

@ @ BaseballBudget
New Versions

Save New Version Always save a new version on closing

Existing Versions

Date and time |Saved by Comments

Figure 12: Version management dialog
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2) Click the Save New Version button to save a new version. A dialog (Figure 13) opens
where you can enter comments about this version.

1@ Insert Version Comment

| Saved by: Jean Weber
Revision accepted by management|

Help cancel | (NOKIN

Figure 13: Insert Version Comment dialog

3) After you enter your comment and click OK, the new version is included in the Existing
Versions list (Figure 14).

® @ BaseballBudget
New Versions

Save New Version Always save a new version on closing

Existing Versions

Date and time Saved by |Commems

26/05/2019 12:56 Jean Weber COMNAL .. .cccnnnninniessssisssessesiessesssn e s s

i26/05/2019 12:58 Jean Weber | Revision accepted by management
Help CMIS Delete Compare Show... |.Close Open

FigUre 14: 'Upd'ated version list
4) Save the file. Both versions are now included in the same file.
From this point you can:

* View an old version — Select the version and click Open: a read-only copy of a previous
version opens.

* Compare all versions — Clicking Compare performs an action similar to merging
documents. A Manage Changes dialog opens, showing all of the changes through the
different versions.

* Review the version comments — Select a version and click Show to display the full
comments made by yourself or other reviewers.

* Delete a version — Select a version and click Delete.

Saving versions | 13
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