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Ctrl (Control) 3 (Command) Used with other keys
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F11 #+T Opens the Styles and Formatting window
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Why use a master document?

Master documents are typically used for producing long documents such as a book, a thesis, or a
long report. A master document (*.ODM) joins separate text documents (*.ODT) into one larger
document, and unifies the formatting, table of contents (TOC), bibliography, index, and other tables
or lists.

A master document is especially useful in these situations:

When graphics, spreadsheets, or other material cause the file size or number of pages to
become quite large; writing, reviewing, and editing may be easier when done on subsets of
the full document.

When different people are writing different chapters or other parts of the full document.

When files will be published as stand-alone documents as well as becoming part of a larger
document. The chapters of this Writer Guide are an example of this.

When subdocuments are used in more than one final document.

You can use several methods to create master documents. Each method has its advantages and
disadvantages. Which method you choose depends on what you are trying to accomplish. The
different methods are described in this chapter, along with suggestions on when to use each one.

A master document is not always the best method to use in any of the situations
given above. You may find that an ordinary document (.ODT) containing sections
linked to other files may do the job just as well. For more about using sections to
combine files, see Chapter 4, Formatting Pages.

Tip

Styles in master documents and subdocuments

A subdocument can be used in several master documents. Each master document may have
different style definitions (font, type size, color, page size, margins, and so on), which affect the
appearance of the final document, but the individual subdocuments retain their original
characteristics.

The relationship between styles in a master document and its subdocuments is as follows:

Custom styles used in subdocuments, such as paragraph styles, are automatically
imported into the master document.

If more than one subdocument uses a custom style with the same name (for example,
myBodyText), then only the one in the first subdocument is imported into the master
document.

If a style with the same name exists in the master document and in the subdocuments (for
example, Default), then the style is applied as defined in the master document.

The styles in the subdocuments are only changed in the master document, so when a
subdocument is opened for editing the original styles are not affected.

If you use the same document template for the master document and its
subdocuments, the subdocuments will look the same when they are loaded into
the master document as they do when viewed as individual files. When you modify
: or create a style, make the change in the template (not in the master document or
Tip any of the subdocuments). Then when you reopen the master document or a
subdocument, the styles will update from the template.

For subdocuments used in several master documents with different templates, this
tip is not so relevant.
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Creating a master document: scenarios

The three most common scenarios for creating a master document depend on the current state of
your document:

You have one existing document (a book) that you want to split into several subdocuments
(chapters) that will be controlled by the master document.

You have several existing documents (chapters) by one or more authors that you want to
combine into one book, controlled by the master document.

You have no existing documents but intend to write a long book containing several
chapters, possibly by multiple authors.

We will look at each of these scenarios in turn.

Splitting a document into master and subdocuments

When you have one existing document that you want to split into a master document and several
subdocuments, you can have Writer split the document automatically at headings with an outline
level of your choice.

Although this method is quick and easy, some cleanup work may be necessary:

The page style of the first page (and possibly all pages) in each subdocument reverts to
Default. If you are using custom page styles and you want the subdocuments to use the
same page layout, whether part of the master document or standalone, you will need to
reapply at least the first page style.

The automatically generated file names for the subdocuments are maindocnameX.odt,
where X is 1, 2, 3, and so on. If you have a Preface or other “chapter” starting with a
Heading 1 before Chapter 1, the file names will not directly correspond to the chapter
numbers. You may wish to rename the subdocuments; see “Adding, deleting, or renaming
subdocuments” on page 14.

If the original document is associated with a template, the .ODM file will also be associated
with that template, but the subdocuments will not. The subdocuments will inherit the styles
in the original document, but their association with the template will be lost. You may wish
to use the Template Changer extension to reassociate the template with each of the
subdocuments.

How to do it:
1) Open the document and choose File > Send > Create Master Document.
2) On the Name and Path of Master Document dialog box (Figure 1):

a) Navigate to the folder where you want to save the master document and its
subdocuments (or create a new folder).

b) Type a name for the master document in the File name box.

c) Inthe separated by: list (which may be labelled Template on Windows), choose the
outline level where the file should be split into subdocuments. Usually this is Outline:
Level 1 for a chapter heading, but your document may be structured differently. For
more information about outline levels, see “Defining a hierarchy of headings” in
Chapter 6, Introduction to Styles.

d) Leave the Automatic file name extension option selected, and click Save to split the
document into subdocuments and create the master document.

If you selected Outline: Level 1 and the paragraph style at that level is Heading 1, each of the
subdocuments begins with a Heading 1 paragraph.

Splitting a document into master and subdocuments



[§ Name and Path of Master Document F=H"%"

fhome/jeanweber/Documents/LibreOffice Docs/Getting Started

Title [Type |size |Date modified
it 0100GS3-GettingSt OpenDocument M 88.0 KB 02/01/2011, 10:14:11

File name: I B Save

separated by: Outline: Level 1 " [ Cancel ]

File type: ODF Master Document v [ Hel ]
bl Help

Automatic file name extension

Figure 1: Splitting a document into master and subdocuments

Combining several documents into a master document

When you have several existing documents, you can combine them into one document controlled
by a master document.

This method works best when all of the documents were created from the same template, but you
can also use it when the documents have been created from different templates. This method is
especially useful when the subdocuments are created or maintained by multiple writers. For
example, you might be creating an anthology of short stories or a book of symposium papers.

How to do it:

Use one of the techniques described in “Starting with no existing documents” below to create a
blank master document and insert the other documents as subdocuments of the master document.

Starting with no existing documents

When you start with no existing documents, you can set up everything the way you want from the
beginning. Follow these steps, in the order given. Each step is explained in detail in the following
subsections.

Step 1. Plan the project

Step 2. Create a template

Step 3. Create the master document

Step 4. Create subdocuments

Step 5. Add some pages to the master document

Step 6. Insert the subdocuments into the master document
Step 7. Add table of contents, bibliography, index
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Step 1. Plan the project

Although you can make changes at most steps in this process, the more you can plan before you
start, the less work you will have to do to correct any problems later. Here are some things you
need to plan.

Parts of book or report required. What pages will be in the master document and what will be in
the subdocuments?

Consider as an example a book with the parts given in the table below.

Part Location

Title (cover) page In master document
Copyright page In master document
Table of contents (TOC) In master document
Preface (Foreword) Subdocument
Chapters 1to 7 Subdocuments
Index In master document

Page, paragraph, character, frame, and numbering styles. See Chapter 6, Introduction to
Styles, and Chapter 7, Working with Styles, for instructions on how to create or modify styles and
examples of the use of styles in book design. Pay particular attention to setting up headings using
styles, as described in “Defining a hierarchy of headings” in Chapter 6, Introduction to Styles.

Fields and AutoText entries, as required. See Chapter 3, Working with Text, and Chapter 14,
Working with Fields, for ideas.

One or more templates for master and subdocuments. If you are starting a new project, create
the master document and all the subdocuments from the same template. Not using the same
template can create style inconsistencies that could cause your document not to look like you
expect. For example, if two subdocuments have a style with the same name that is formatted
differently in each document, the master document will use the formatting from the first
subdocument that was added.

Page numbering. In our example, the pages are numbered sequentially from the title page. (The
title page style can be defined to not show the page number, but it will still count as page 1.)
Therefore the first chapter begins on a higher number page, for example page 5. To create a book
in which the page numbering restarts at 1 for the first chapter, you need to do some additional
work. See “Restarting page numbering” on page 11.

Step 2. Create a template

You can create your template from an existing document or template that contains some or all of
the page, paragraph, character, and other styles you want for this document, or you can create the
template from a blank document. For more about templates, see Chapter 10, Working with
Templates.

Be sure to use File > Templates > Save when creating the template.

A master document (*.odm) created from a template is associated with that
Note template, but the name of the template is not shown in the Document Properties
dialog (File > Properties) as it is for *.odt files.
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Step 3. Create the master document

It does not matter in what order you create the master and subdocuments, and you do not have to
create all the subdocuments at the same time, when you are starting the project. You can add new
subdocuments at any time, as you need them.

Follow this process to create the master document.

1) Open a new document from the template you created in Step 2, by choosing File > New >
Templates and Documents, then selecting the template you created. Be sure the first
page of this new document is set to the page style you want for the first page of the final
document; if it is not, change it. In our example, the style for the first page is Title page.

2) If any text or page breaks came into this document from the template, delete the text. (The
TOC, index, and any fields in headers and footers can stay.)

3) Click File > Send > Create Master Document. Save the master document in the folder for
this project. We will return to this master document later. For now, you can either leave it
open or close it.

Using File > New > Master Document is not recommended, because the resulting
Note master document file (.ODM) is not associated with a template. However, you can
later apply a template using the Template Manager extension.

Step 4. Create subdocuments

A subdocument is no different from any other text document. It becomes a subdocument only when
it is linked into a master document and opened from within the master document. Some settings in
the master document will override the settings in a subdocument, but only when the document is
being viewed, manipulated, or printed through the master document.

Create a subdocument in the same way as you create any ordinary document:

1) Open a blank document based on the project template (very important) by choosing File >
New > Templates and Documents, then selecting the required template.

2) Delete any unwanted text or other material, and set the first page to the page style you
specified for the first page of a chapter.

3) Click File > Save As. Give the document a suitable name and save it in the folder for this
project.

If you already have some of the chapters written, the files are probably not based on the template
you just created for this project. You will need to change the template attached to the existing files.
You can do this manually, or by using the Template Changer extension to LibreOffice; both
methods are described in Chapter 10, Working with Templates.

Step 5. Add some pages to the master document

To assist you, do the following:
* Make sure paragraph marks are showing. You can set them in Tools > Options >
LibreOffice Writer > Formatting Aids, or click the Nonprinting Characters icon @ on
the Standard toolbar.

* Show text boundaries, table boundaries, and section boundaries (Tools > Options >
LibreOffice > Appearance).

If your master document does not contain any required “front matter” such as a title page, copyright
page, or TOC page, add them now. The example in this section uses the sequence of page styles
given in “Step 1. Plan the project” on page 7.
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1)

2)

3)

Note

Type the contents of the title page (or leave placeholders and fill in later). With the insertion
point in the last blank paragraph on the page, click Insert > Manual Break. On the Insert
Break dialog box, select Page break and the page style for the second page (Copyright
page in our example), and leave the Change page number option deselected. Click OK.

Insert Break Es
Type

> Line break l l

¢ Column break l Cancel l

|

oK

@ Page break
Style
Copyright page v

[ Help

[0 Change page humber

Figure 2: Inserting a page break between the title page
and the copyright page

Type the contents of the copyright page (or leave placeholders). With the insertion point in
the last blank paragraph on the page, insert another manual page break, this time setting
the page style to Table of Contents page.

On the Table of Contents page, leave a blank paragraph or two or insert a TOC (Insert >
Indexes and Tables > Indexes and Tables). The TOC will not have any contents until you
add the subdocuments, but you should see a grey mark or box indicating its location. For
more about inserting and formatting TOCs, see Chapter 12, Tables of Contents, Indexes,
and Bibliographies.

Depending on the style definitions for the first paragraph (usually a heading) on the
Copyright and TOC pages, you may not need to insert manual page breaks.

Step 6. Insert the subdocuments into the master document

Now we are ready to add the subdocuments.

1)
2)

3)

Tip

Subdocuments are inserted into a master document before the item highlighted in
the Navigator. If you insert the last subdocument first, and then insert the other
subdocuments before the last one, they will end up in the correct sequence without
the necessity of moving them up or down in the list.

Display the Navigator (click View > Navigator, or press F5, or click the Navigator icon @
Be sure the Navigator is showing the master view (see “Using the Navigator” on page 17).
Click on the Toggle icon at the upper left to toggle between regular and master views.

On the Navigator, select Text, then click and hold on the Insert icon, move the mouse
pointer down, and click File.

Starting with no existing documents



4)

5)

6)

x Navigator
B P k[

Index

MNew Document

Figure 3: Inserting a subdocument into a master
document using the Navigator

A standard File Open dialog box appears. Select the required file (which you created in
Step 3) and click OK. This example uses 7 chapters and a preface; we will load Chapter 7
first, as suggested in the Tip above.

The inserted file is listed in the Navigator before the Text item, as shown in Figure 4.

» Mavigator
E Pk a5
|McweUp|

ap T—Graphics.odt

Figure 4: Navigator after inserting one subdocument

Because the Text section contains the title page and other material, highlight it and click the
Move Up icon to move it to the top of the list.

Highlight the subdocument you just inserted (Chapter 7), then click and hold on the Insert
icon, move the mouse pointer, and click File to insert the first subdocument; in this
example, Preface. Chapter 7 remains highlighted. Repeat with Chapter 1, Chapter 2, and
so on until all the subdocuments have been added to the list. The Navigator will now look
something like Figure 5.

Save the master document again.

x Mavigator
BE Pkt R =t N

Ch1-Intro.odkt
Ch2-Setup.odt
Ch3-Edit.odt
Ch4-Layout.odt
Ch5-Templates.odkt
Ch&-Fields.odt
Ch7-Graphics.odt

I 0 0 0 0 o

Figure 5. The Navigator showing a series of files
in @ master document
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Step 7. Add table of contents, bibliography, index

You can generate a table of contents, bibliography, or index for the book, using the master
document. You must insert these items into a text section in the master document. For more about
these document elements, see Chapter 12, Creating Tables of Contents, Indexes, and
Bibliographies.

Put the insertion point on the page in the first text section where the table of contents is to go and
choose Insert > Indexes and Tables > Indexes and Tables to create the table of contents.

If you do not have a Text section at the end of the master document, insert one before the last
subdocument, then move it down so it is after the last subdocument. Now, if you have included
bibliographic entries in your subdocuments, you can put the insertion point on the page in this last
text section where the bibliography is to go and create the bibliography.

If you have included index entries in your subdocuments, put the insertion point on the page in the
last text section where the index is to go and create the index.

Figure 6 shows the Navigator after addition of a TOC and index.

x Navigator

B Bkt B ==

Preface.odk ||
Chi-Intro.odt
Ch2-Setup.odt
Ch3-Edit.odt
Chd-Layout.odk
Ch5-Templates.odk
Che-Fields.odt

— Ch7-Graphics.odkt
@ Text

i;}.‘g Alphabetical Index
Texkt

I 0 00 A o 0 o

]

Lol

Figure 6: Navigator showing subdocuments, table of
contents, and index in a master document

Restarting page humbering

The example in the previous section showed a very basic collection of files with sequential page
numbering. This is useful for many documents, including e-books, but a typical “printed book” has
the following sequence of page numbers:

* No page numbers on cover page or copyright page

* Lower-case roman numerals in the front matter, starting with i

* Arabic numerals in the body of the document, starting with 1

* Page numbering sequential through the rest of the book

To set up a master document to produce such a book, you need to define a different paragraph
style for the heading of the first chapter and assign two special characteristics to it.

Restarting page numbering 11



Example

Each chapter may start with a Heading 1 paragraph, set up on the Text Flow tab of the Paragraph
Style dialog box to start on a new page (Figure 7). The Page number is set to 0, with the effect that
numbering continues from the number of the previous page.

x Paragraph Style: Heading 1
Cutline & Mumbering Tabs Drop Caps Background Borders
Qrganizer Indents & Spacing Alignment | Text Flow | Font | FontEffects | Position
Hyphenation

[] Automatically

2 A
£ Lu Charackers at line end

2 D Characters at line begin
0 D Maximum number of consecutive hyphens
Breaks
Insert Type |Page M Position [Before |
With Bage Styie [Default C]  Pagepumber o[£

Figure 7: Text Flow tab of Paragraph Style dialog box for Heading 1

Look on the Outline & Numbering tab (Figure 8) of this dialog box to see what outline level
Heading 1 is assigned to. Usually this will be Outline Level 1. The level cannot be changed here
because it has been set in Tools > Outline Numbering.

b

Paragraph Style: Heading 1

Organizer | Indents & Spacing | Alignment | Text Flow | Font | Font Effects | Position

i Outline & Numbering | Tabs Drop Caps Background Borders
Outline
Outline level | evel 1
Numbering
Numbering Style Outline Numbering

Figure 8: Outline & Numbering tab of Paragraph Style dialog box for Heading 1

Only one paragraph style can be assigned to Outline Level 1 through Tools > Outline Numbering.
However, you can assign additional paragraph styles to any outline level by using the Outline &
Numbering tab on the Paragraph Style dialog box.

Therefore, you want to define a style called Heading 1 Chapter 1 that is identical in appearance to
Heading 1 but has one essential difference: on the Text Flow tab, set the Page number to 1 (Figure
9). Then, on the Outline & Numbering tab, set the Outline level to Level 1 (Figure 10). This ensures
that the heading will appear in the Table of Contents along with the other chapter headings. (The
Numbering Style for this heading is None, as it was not assigned an outline level through the
Outline Numbering dialog box.

Now, assign the new style to the first paragraph of Chapter 1, and you're done.
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Paragraph Style: Heading 1 Chapter 1

QOutline & Numbering Tabs Drop Caps Background Borders
Organizer Indents & Spacing Alignment | Text Flow Font Font Effects Position
Hyphenation

Ay

2

£
W

Characters at line end

[2¥]
£ ¥

Characters at line begin

0 +| Maximum number of consecutive hyphens
Breaks
¥ Insert Type Page v Position |Before re

With Page Style Default v @ﬂumber 1 — )

Figure 9: Set the page number to restart at 1 for this heading style

Paragraph Style: Heading 1 Chapter 1
Organizer Indents & Spacing Alignment Text Flow | Font Font Effects Position
Outline & Numbering Tabs Drop Caps Background Barders
QOutline
Qutline level Level 1 v
Numbering —
Numbering Style None |

Figure 10: Assign the style to outline level

Editing a master document

After creating a master document, you may want to change its appearance or contents.

Changing the appearance of the master document

You can change the styles in the template as your project develops. Do not make changes to
styles in the master document or in any of the subdocuments—make those changes in the
template.

To update the master document (and all of the subdocuments) with changes to the template, just
open the master document. You will get two messages: first, to ask if you want to update all links;
and second, if you want to apply the changed styles. Answer Yes to both of these messages.

Editing subdocuments

You cannot save edits made to a subdocument from within the master document. Instead, you
must open the subdocument, either by double-clicking on it in the master document’s Navigator, or
by opening it from outside the master document. Then you can edit it just as you would edit any
other document.

Editing a master document 13




If, while editing a subdocument, you make any changes to the styles that you want to apply to the
master document, you must copy those changed styles to the master document or to its template.
A better strategy is to make the changes directly in the master document or its template.

If you change the contents of any subdocument, you need to manually update the table of
contents, bibliography, and index from within the master document.

Adding, deleting, or renaming subdocuments

To add a subdocument, follow the method described in “Step 6. Insert the subdocuments into the
master document” on page 9.

To delete a subdocument, right-click on its filename in the Navigator and choose Delete.

If you rename a subdocument by changing its filename, the next time you update links in the
master document, that subdocument will show up as a broken link (shown in red). You can fix this
by right-clicking on it in the Navigator, choosing Edit Link, and selecting the renamed file; however,
the file name shown in the Navigator does not change (only the link changes). This can be quite
confusing, so a better strategy is to delete the subdocument from the Navigator and then add the
renamed file.

Cross-referencing between subdocuments

The methods described earlier in this chapter are all most writers will need when using master
documents. However, you might want to include automatically updated cross-references between
subdocuments. This section describes how to do this.

The process to create cross-references between subdocuments is time consuming, but it works.

Preparing items as targets for cross-referencing

Before you can insert a cross-reference to anything that is not automatically shown on the
References tab, such as a heading, you must prepare or “set” that heading as an item to be
referenced. To do this, you can either use bookmarks or set references.

When you set references, be sure to select the entire text you want to use as the reference, such
as a heading or figure number. Keep a list of what you have named the reference fields, and be
sure every name is unique. One way to keep track of this information is by putting it in a separate
text file or a spreadsheet.

The field names are case-sensitive. You can check the field name by holding the cursor over the
referenced item. In our example (Figure 11), the heading has the field name word count.

Counting all the words in a changedldocument

|Reference: word count |ﬁ-:|.h:'

Figure 11: Finding the field name for a heading

Using bookmarks

Bookmarks are listed in the Navigator and can be accessed directly from there with a single mouse
click. To insert a bookmark:

1) Select the text you want to bookmark. Click Insert > Bookmark.

2) Onthe Insert Bookmark dialog box, the larger box lists any previously defined bookmarks.
Type a name for the new bookmark in the top box. Click OK.
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Insert Bookmark

Bookmarks
inserkpagenum

usedocproperties

Figure 12: Inserting a bookmark

Setting references
1) Click Insert > Cross-reference.

2) Onthe Cross-references tab of the Fields dialog box (Figure 13), click Set Reference in
the Type list. The Selection list shows any references that have been defined. You can

leave this page open while you set many headings as references.

3) Click in the document and highlight the text of the first heading to be used as a target for a
cross-reference. Click on the Fields dialog box. The text of the heading will appear in the
Value box in the lower right of the dialog box. In the Name box, type some text by which

you can identify this heading.

4) Click Insert. The text you typed in the Name box now appears in the Selection list.

5) Repeat steps 3 and 4 as often as required.

» Fields

Document | Cross-references| Functions | Doclnformation | Variables | Database

Type Selection

Insert Reference create md and subdocs
Headings creakte templaktes
Mumbered Paragraphs Cross-ref bebween subdocs
Bookmarks insert subdocs

Method 1.Quick and easy
Method 2.Mot too complicated
Method 3.Complete control

nsert reference to Mame

(word count

Value

Word count

| Insert || Close

|| Help |

Figure 13: Setting text to be used as a target for a cross-reference

Cross-referencing between subdocuments
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Inserting the cross-references

1)
2)

3)

o

Open the master document. In the Navigator, select a subdocument, right-click and choose
Edit from the context menu. The subdocument opens for editing.

In the subdocument, place the cursor where you want the cross-reference to appear. Click
Insert > Cross Reference.

On the Cross-references tab of the Fields dialog box (Figure 14), select Insert Reference

in the Type list on the left hand side. The Selection list in the middle column shows only the
reference field names for the subdocument you are using, so ignore that list and check the
list you created manually in step 1.

Fields

Document |Cross-references| Functions | Docinformation | Variables | Database

Type Selection

Set Reference Method 1.Quick and easy -~

Method 2.Mot too complicated

Headings Method 3.Complete control
Mumbered Paragraphs Plan project
Bookmarks Problem solving

Starting with no exiskting docs =
Step 4

Insert reference to Mame

|word count |

Chapter
Reference Value
Above/Below
As Page Skyle

| Insert || Close || Help |

Figure 14. Fields dialog box showing manual entry of field name

4)

5)

In the Name field in the lower right hand column, type the name of the reference you set in
the subdocument you are referring to. In our example, the reference is in Chapter 3, and its
name is word count.

Click Insert, type any text you want to appear between the reference and page number
(such as “on page”), and then insert another reference with the Page format. Nothing will
appear in the subdocument except tiny gray bars indicating the fields. When you hover the
mouse pointer over one of these fields, you will see the field name.

on page .

"

word count

Figure 15: Viewing the field name
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(You can turn on the display of field codes by clicking View > Field Names. The two fields
shown as gray lines in Figure 15 now look like Figure 16.)

wiord count on page Dward count.

Figure 16. Displaying field codes

6) After you have inserted all the cross-references required in the subdocument, save and
close it and return to the master document window.

Within the master document, navigate to the page of the subdocument on which you inserted the
cross-reference field. You should now see the text of the cross-reference appear in the spot where
you inserted it, because within the master document, the subdocument can find the target of that
field reference.

Counting all the words in a changed document on page B,

|wurd count

Figure 17. Field contents visible

This technique also works if you open a subdocument directly in step 2 (that is, not from within the
master document) and insert a cross-reference field.

Using the Navigator

The Navigator is a very useful tool that helps you move quickly to specific parts of your document.
It also provides information about the content of the document and enables you to reorganize
some of the content. For example, if each chapter in your final book is a separate document, then
in the master document they can be reordered, and the references are renumbered automatically
and the table of contents and index can be updated.

In Writer, the Navigator has two distinct forms. One form is used in ordinary text documents and
the other in master documents.

In an ordinary text document, the Navigator displays lists of the graphics, tables, index entries,
hyperlinks, references, and other items in the document, as shown on the left hand side of Figure
18. Click the indicator (+ sign or triangle) by any list to display the contents of the list. You can
double-click an entry in the Navigator and jump immediately to that place in the document.

In a master document, you can toggle between the regular and master views by clicking on the
Toggle icon at the upper left. In the master view, the Navigator lists the subdocuments and text
sections, as shown on the right hand side of Figure 18. The use of the Navigator in a master
document is covered in more detail later in this chapter (see “Step 6. Insert the subdocuments into
the master document” on page 9 and “Cross-referencing between subdocuments” on page 14).

Using the Navigator 17
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Figure 18. The Navigator for a text document (left) and for a master document (right)

Creating one file from a master document and its
subdocuments

Master documents are .odm files containing linked subdocuments, which are in .odt format.
Although linked files are very useful when writing and editing a large document such as a book,
sometimes you might need to have a copy of the entire book in one file.

To export a master document to a .odt file (without affecting the original .odm file):

1) Open the master document. Choose File > Export from the menu bar.

2) On the Export dialog (Figure 19), type a hame for the exported .odt file and choose
OpenDocument Text (.odt) from the File format list (it should be the default choice). Click
Export. This step changes the .odm file into a .odt file, with each subdocument in a
separate section.

S} €$3400-GettingStartedLibO_old.odt OpenDocument Text  10.56 MB 30/03/2012, 15:
@ 053400-CGettingStarted LibO_test.odt OpenDocument Text 10,55 MB 31/03/2012, 14:
m s B WL T I R I R T e W L A T . A/ FT kAR AT e B R B B .
File name: ’EIB:%DO—GettingStartedLibD |'] [ Export ]
File format: [DDF Text Document (.odt) L ] ( Cancel |
- Help |
M Automatic file name extension
[ Selection

Figure 19: Exporting a master document to an OpenDocument Text (.odt) file
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3) Close the master document and open the new .odt file, updating all links.
4) Choose Edit > Links from the menu bar.

If the Links command is grayed-out, the cursor is probably in a write-protected
part of the document (for example, in one of the linked documents). Move the
cursor into a part of the document that is not write-protected; the Links command
then becomes available.

Tip

5) The Edit Links dialog shows all the linked files. Select all the files in the Source file list and
click Break Link. This step embeds (includes) the contents of all the subdocuments into
one single file (but with each subdocument remaining in a separate section) and removes
the write protection on the sections.

x Edit Links

Source file Element: Type Status | Close |
0102GS3-5ettingUpLO.odt Document Manual | Help |
0103G53-SkylesandTempla Document Manual

0104GS3-GettingStarted Wi Document Manual E | Update |
0105GS3-GethingStarted Wi Document Manual

0106GS3-GettingStarted Wi Document Manual

0107GS3-GettingStartedWi Document Manual

0108G53-GetkingStarted Wi Document Manual | ModiFy... |
0109GS3-GettingStarted Wi Document Manual —
0110GS3-Prinking Ex ki D I M | :
110052 PrnthoExportieg pocument el o) [ ereskink |
Source file file:///home/david/Desktop/0101GS3-IntroducingLO.odt

Element:

Type: Document

Update: Automatic @ Mapual

Figure 20: Breaking links to include files in one document

6) After breaking the links, you may also wish to remove some or all of the sections. To do
this, go to Format > Sections, select the sections you wish to remove, and click Remove.
The contents of those sections remain in the document; only the section markers are

removed.
The Help does not mention steps 4 and 5 above, giving only the step for removing
Ti the sections. If you have no hidden sections, that technique works fine and is
p faster; however, if you want to break the links but retain some or all of the sections

(particularly hidden sections), then the method described in this chapter is safer.

Problem solving

Some combinations of choices do not work together, and some techniques that affect master
documents are not at all obvious. This section describes some problems and what to do about
them.

Anchoring pictures to a page

The problem
A picture (graphic) anchored “to page” in a subdocument is not displayed in the master document
although it always appears correctly in the subdocument.
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Because the master document reorganizes the page flow, page numbers, and cross-references
when it collates all the subdocuments together, the absolute reference to a page X in a
subdocument is lost in the master document. The picture loses its anchor reference and simply
disappears.

The solution
To avoid this problem but keep pictures positioned precisely on a particular page, anchor the
pictures as follows:

1) Right-click on the picture and choose Picture from the context menu.

2) On the Type tab of the Picture dialog box (Figure 21), set the anchor to To character or To
paragraph.

3) Under Position, choose suitable horizontal and vertical references to the page. Click OK to
save the changes.

Picture
Type Options | Wrap | Hyperlink | Picture | Crop [ Borders | Background | Macro
Size Anchor
Width [14.03cm [J]  ©OTopage
[] Relative ® To paragraph
Height lmm ¢ To character
[ Relative  As character
[ Keep ratio
Original Size l
Position
Horizontal Center v by [0.00cm o to Paragraph area v
[ Mirror on even pages
Vertical Top v by |0.00cm |2| to |Margin v
[ Follow text flow

l OK HCanceI H Help H Reset ]

Figure 21. Anchoring a graphic and setting its position on a page

Restarting list numbering when using custom styles

The problem
When custom numbering styles are used for lists, the first item in the first list in a file continues
numbering from the last list in the previous chapter.

The solution

You need to explicitly set the first list item to restart numbering at 1. However, if you right-click on
the paragraph and choose Restart humbering, the setting is not saved when the file is saved.
(This works for other lists in a document, but not the first.)

Here is the secret:

1) Right-click on the first list item in the first list in the document and choose Paragraph, not
Restart Numbering.
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2) On the Paragraph dialog, go to the Outline & Numbering tab.

3) Under Numbering, choose Restart at this paragraph and 1 for Start with. Click OK to

save.

Note: If you do not explicitly choose 1 for Start with, the setting is not retained.
Unfortunately there seems to be no way to build it into a paragraph style.

Restart at this paragraph
Start with

Paragraph
Background
Indents & Spacing | Alignment | Text Flow |OQutline & Numbering Tabs | Drop Caps | Borders
Outline
Qutline level Body text
Numbering
Numbering Style OOoNum 123

Problem solving
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