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Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. 
The table below gives some common substitutions for the instructions in this chapter. For a more 
detailed list, see the application Help.

Windows or Linux Mac equivalent Effect

Tools > Options 
menu selection

LibreOffice > Preferences Access setup options

Right-click Control+click and/or right 
click depending on 
computer setup

Opens a context menu

Ctrl (Control) z (Command) Used with other keys

F5 Shift+z+F5 Opens the Navigator

F11 z+T Opens the Styles and Formatting window

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
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Creating simple drawings

You can create 2D and 3D objects in Draw. This chapter shows how to draw simple 2D objects. 
The following chapters describe how to work with and edit such objects. For more information on 
3D objects, see Chapter 7 Working with 3D Objects in this guide.

All shapes, whether they are lines, rectangles, or more complicated shapes, are called objects. 
This is common notation in vector drawing software.

The drawing tools are found on the Drawing toolbar (Figure 1).

As described in Chapter 1 Introducing Draw, the Drawing toolbar is normally located at the bottom 
of the window. If you do not see it, you can activate it from the View > Toolbars menu. As with all 
the components of LibreOffice, you can undock the Drawing toolbar and place it wherever you 
want to on the Draw window as a floating toolbar. You can also configure toolbars by adding, 
moving, hiding, or deleting toolbar icons.

Figure 1: Drawing toolbar

When you draw a shape, select one for editing or add text, the Information field in the status bar 
(Figure 2) changes to reflect the action taken or in progress. See Chapter 1 Introducing Draw for 
more information on the status bar.

Figure 2: Draw status bar

Custom shapes

Draw also offers the ability to create custom shapes, which are the equivalent of Autoshapes in 
Microsoft Office. Custom shapes differ in their properties and are dealt with separately in the 
relevant chapters of this guide. The main differences relate to the behavior of 3D objects and text 
handling. Text frames in Draw have their own geometric format.

Drawing basic shapes

Basic shapes, including text, are treated as objects in Draw. The various tools available for drawing 
basic shapes, from left to right on the Drawing toolbar, are given in Table 1.

Please note that some of the icons on the Drawing toolbar will change according to the shape that 
has been selected from the choice available. Available tools are indicated by a small triangle or 
arrow to the right of the icon. See “Drawing geometric shapes” on page 13 for information on the 
available shapes.
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Table 1: Basic drawing tools

Icon Tool name Icon Tool name Icon Tool name Icon Tool name

Select Line
Line ends 
with arrow

Rectangle

Ellipse Text Vertical text Curve

Connector
Lines and 
arrows

Basic 
shapes

Symbol 
shapes

Block arrows Flowcharts Callouts Stars

Drawing straight lines
We begin with the drawing of the simplest element—a straight line.

Click on the Line icon  and place the mouse pointer at the point where you want to start the line 
(Figure 3). Drag the mouse while keeping the mouse button pressed. Release the mouse button at 
the point where you want to end the line. A selection handle appears at each end of the line, 
showing that this object is the currently selected object. The selection handle at the starting point of 
the line is slightly larger than the other selection handle.

Figure 3: Drawing a straight line

Keeping the Shift key pressed while you draw a line restricts the drawing angle of the line to a 
multiple of 45 degrees (0, 45, 90, 135, and so on).

Caution
This is the default behavior of the Shift key. However, if the option When creating 
or moving objects in the Snap position section of Tools > Options > LibreOffice 
Draw > Grid has been selected, the action of the Shift key is the opposite. Lines 
will automatically be drawn at a multiple of 45 degrees unless the Shift key is 
pressed.

Keeping the Ctrl key pressed while drawing a line enables the end of the line to snap to the 
nearest grid point.

Caution This is the default behavior of the Ctrl key. However, if the Snap to Grid option on 
the View->Grid menu has been selected, the Ctrl deactivates the snap to grid 
activity.
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Figure 4: Line dialog

Figure 5: Information area in the status bar

The spacing (resolution) of the grid points can be adjusted under Tools > Options > LibreOffice 
Draw > Grid. See Chapter 3 Working with Objects and Object Points for more information.

Holding down the Alt key while drawing a line results in the line extending outwards symmetrically 
in both directions from the start point. This lets you draw lines by starting from the middle of the 
line.

When a line is drawn, it uses default attributes. To change any of these attributes, select the line by 
clicking on it, then right-click and select Line to open the Line dialog (Figure 4). Line style, line 
width and line color can also be changed using the controls in the Line and Filling toolbar at the top 
of the workspace.
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While you are working with a line (or any other element), you can use the information field on the 
Status bar to monitor the activity. A description of the current activity or selection is shown when 
you are working with elements. Figure 5 shows two examples.

Drawing arrows
Arrows are drawn like lines. In fact Draw classifies arrows as a subgroup of lines: lines with 
arrowheads. The information field on the status bar shows them only as lines. Click on the Line 

Ends with Arrow icon  to draw an arrow. The arrow head is drawn at the end point of the arrow 
when you release the mouse button.

Drawing different types of lines and arrows

Click on the small triangle or arrow to the right of the Lines and Arrows  icon on the Drawing 
toolbar to open a pop-up toolbar with ten tools for drawing lines and arrows. Alternatively, go to 
View > Toolbars > Arrows to open the Arrows toolbar as a floating toolbar (Figure 6 and Table 2). 
The icon for the tool used most recently will be shown on the Drawing toolbar to make it easier to 
use the same tool again.

After drawing the line, you can change the arrow style by clicking on the Arrowheads icon  in 
the Line and Filling toolbar and select the arrow start and end options.

Figure 6: Arrows toolbar

Table 2: Tools of the Arrows toolbar

Icon Tool name Icon Tool name Icon Tool name Icon Tool name

Line
Line ends 
with arrow

Line with 
arrow/circle

Line with 
arrow/square

Line (45°)
Line starts 
with arrow

Line with 
circle/arrow

Line with 
square/arrow

Dimension 
line

Line with 
arrows

Drawing rectangles or squares

Drawing a rectangle is similar to drawing a straight line. Click on the Rectangle icon  in the 
Drawing toolbar. As you draw the rectangle with the mouse cursor, the rectangle appears with the 
bottom right corner of the rectangle attached to the cursor.

Squares are rectangles with all sides of equal length. To draw a square, click on the Rectangle  
icon  and hold down the Shift key whilst you draw a square.

Note

If the option When creating or moving objects has been selected in Tools > 
Options > LibreOffice Draw > General, the action of the Shift key is reversed. 
When the Rectangle tool is selected, a square is drawn. To draw a rectangle you 
have to press the Shift key when drawing. This Shift key reversal also applies when 
drawing ellipses and circles in “Drawing ellipses and circles” on page 8.
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To draw a rectangle or square from its center rather than the bottom right corner, position your 
cursor on the drawing, press the mouse button and then hold down the Alt key while dragging with 
the cursor. The rectangle or square uses the start point (where you first clicked the mouse button) 
as the center.

With the rectangle or square selected, you can quickly change border style, line width, or color, 
and the type of fill color or fill pattern using the tools on the Line and Filling toolbar. For more 
information on changing the attributes of a rectangle or square, see Chapter 4 Changing Object 
Attributes.

Drawing ellipses and circles

To draw an ellipse (also called an oval), click on the Ellipse icon  on the Drawing toolbar. A 
circle is an ellipse with both axes the same length. To draw a circle, click on the Ellipse icon and 
hold down the Shift key whilst you draw a circle.

To draw an ellipse or circle from its center, position your cursor on the drawing, press the mouse 
button and then hold down the Alt key while dragging with the cursor. The ellipse or circle uses the 
start point (where you first clicked the mouse button) as the center.

With the ellipse or circle selected, you can quickly change border style, line width, or color, and the 
type of fill color or fill pattern using the tools on the Line and Filling toolbar. For more information on 
changing the attributes of an ellipse or circle, see Chapter 4 Changing Object Attributes.

Note

If you first press and hold the Ctrl key down and then click on one of the icons for 
Line, Rectangle, Ellipse or Text, an object is drawn automatically in the center of the 
workspace area using default values. The object attributes can then be changed 
using the Line Fill toolbar or the information in Chapter 4 Changing Object 
Attributes. This only works if the icon has no associated toolbar; that is no triangle or 
arrow on the right side of the icon.

Adding arc and segment tools to the Drawing toolbar
If you have to draw arcs or segments (partial circles or ellipses), then you can add the Circles and 
Ovals toolbar (Figure 7) to the Drawing toolbar. The Circles and Ovals toolbar is an optional toolbar 
that requires you to customize the Drawing toolbar.

Figure 7: Circles and Ovals toolbar

1) Go to View > Toolbars > Customize to open the Customize dialog (Figure 8). 
Alternatively, right click on an icon in the Drawing toolbar and select Customize Toolbar.

2) Make sure the Toolbars page of the Customize dialog is open, then select Drawing in the 
Toolbar field and click on Add.

3) In the Add Commands dialog (Figure 9), select Drawing in the Category list.

4) Select the first Ellipse command in the Commands list. The Description section at the 
bottom of the dialog will indicate that you have selected the command for the Circles and 
Ovals toolbar.

5) Click on Add and then click Close.

6) In the Customize dialog, make sure that the checkbox by the new Ellipse command is 
checked.
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Figure 8: Customize dialog

Figure 9: Add Commands dialog

7) Select the new Ellipse command and use the up and down arrow buttons to move it to the 
desired position on the Drawing toolbar.

8) Click OK to save the customized Drawing toolbar.

The new Ellipse icon  appears on the Drawing toolbar with a small triangle or arrow to the 
right of it. Click on this triangle or arrow to open the Circles and Ovals toolbar (Figure 7). To make 
this toolbar into a floating toolbar, drag the toolbar onto the workspace area.
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To remove the standard Ellipse icon  from the Drawing toolbar, open the Customize dialog and 
deselect it in the Commands list. Alternatively, select the Ellipse command, click the Modify button 
and select Delete from the drop-down menu.

To return the Drawing toolbar to its default settings, open the Customize dialog. Click on the 
Toolbars button, select Restore Default Settings from the drop down list and click on the Yes 
button to reset the toolbar.

Drawing arcs or segments
1) To draw an arc or segment, select the appropriate icon in the Circles and Ovals toolbar 

(Figure 7).

2) Click and drag with the mouse cursor to create a guide circle or ellipse, then release the 
mouse button.

3) Move the cursor to the position where you want the arc or segment to start. The status bar 
indicates the angle in degrees.

4) Single-click on this point to start drawing the arc or segment.

5) Move the cursor to create the arc or segment. The status bar indicates the angle in 
degrees.

6) When you have drawn the arc or segment you require, single click once more to complete 
the arc or segment.

Drawing curves or polygons

To draw a curve or polygon click the Curve icon  on the Drawing toolbar. Click on the triangle or 
arrow to the right of the icon to open the tools that are available (Figure 10 and Table 3).

Note
Hovering the mouse pointer over this icon gives a tooltip of Curve. If you open the 
floating toolbar, the title is Lines as shown in Figure 10.

Figure 10: Curves (Lines) toolbar

Table 3: Curve and polygon tools

Icon Tool name Icon Tool name Icon Tool name Icon Tool name

Curve filled
Polygon 
filled

Polygon 45° 
filled

Freeform line 
filled

Curve Polygon Polygon 45° Freeform line

If you move the mouse cursor over one of the icons, a tooltip pops up with a description of the 
function. For a more detailed description for handling Bézier curves, see Chapter 10 Advanced 
Draw Techniques.

Curves
Click and hold the left mouse button to create the starting point of your curve, then, while holding 
down the left mouse button, drag from the starting point to draw a line. Release the left mouse 
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button and continue to drag the cursor to bend the line into a curve. Click to set the end point of the 
curve and fix the line on the page. To continue with your line, drag the mouse cursor to draw a 
straight line. Each mouse click sets a corner point and allows you to continue drawing another 
straight line from the corner point. A double click ends the drawing of your line.

A filled curve automatically joins the last point to the first point to close off the figure and fills it with 
the current standard fill color. A curve without filling will not be closed at the end of the drawing.

Polygons
Click and draw the first line from the start point with the left mouse button held down. As soon as 
you release the mouse button, a line between the first and second points is drawn. Move the 
cursor to draw the next line. Each mouse click sets a corner point and allows you to draw another 
line. A double-click ends the drawing.

A filled polygon automatically joins the last point to the first point to close off the figure and fills it 
with the current standard fill color. A polygon without filling will not be closed at the end of the 
drawing.

Polygons 45°
Like ordinary polygons, these are formed from lines, but the angles between lines are restricted to 
45 or 90 degrees.

Note
Holding down the Shift key when drawing lines with the Curve or Polygon tools will 
also restrict the angles between the lines to 45 or 90 degrees.

Freeform lines
Using the Freeform Line tools is similar to drawing with a pencil on paper. Press and hold the left 
mouse button and drag the cursor to the line shape you require. It is not necessary to end the 
drawing with a double-click, just  release the mouse button and the drawing is completed.

If Freeform Line Filled is selected, the end point is joined automatically to the start point and the 
object is filled with the appropriate color.

Figure 11: Gluepoints

Figure 12: Gluepoints toolbar
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Glue points and connectors

Glue points
All Draw objects have glue points, which normally are not displayed. Gluepoints become visible 

when the Connectors icon  on the Drawing toolbar is selected.

Most objects have four gluepoints (Figure 11). You can add more glue points and customize glue 
points, using the Gluepoints toolbar (Figure 12). Go to View > Toolbars > Gluepoints to open the 
toolbar.

Glue points are not the same as the selection handles of an object. The handles are for moving or 
changing the shape of an object, as described in Chapter 3 Working with Objects and Object 
Points. Glue points are used to fix or glue a connector to an object so that when the object moves, 
the connector stays fixed to the object. For a more detailed description on the use of glue points, 
see Chapter 8 Connections, Flowcharts and Organization Charts.

Connectors
Connectors are lines or arrows whose ends automatically snap to a glue point of an object. 
Connectors are especially useful in drawing organization charts, flow diagrams, and mind-maps. 
When objects are moved or reordered, the connectors remain attached to a glue point. Figure 13 
shows an example of two objects and a connector.

Figure 13: A connector between two objects

Draw offers a range of different connectors and connector functions. Click on the arrow next to the 

Connector icon  to open the Connectors toolbar (Figure 14 and Table 4).

For a more detailed description of the use of connectors, see Chapter 8 Connections, Flowcharts 
and Organization Charts.

Figure 14: Connectors toolbar

Table 4: Connector tools

Icon Tool name Icon Tool name Icon Tool name Icon Tool name

Connector
Connector 
ends with 
arrow

Connector 
with arrows

Line 
connector
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Icon Tool name Icon Tool name Icon Tool name Icon Tool name

Line 
connector 
ends with 
arrow

Line 
connector 
with arrows

Straight 
connector

Straight 
connector 
ends with 
arrow

Straight 
connector 
with arrows

Curved 
connector

Curved 
connector 
ends with 
arrow

Curved 
connector 
with arrows

Drawing geometric shapes

The icons for drawing geometric shapes are located on the Drawing toolbar and each geometric 
shape is explained in the following sections. Clicking on the triangle or arrow to the right of the icon 
opens a floating toolbar giving access to the tools for that geometric shape.

Tip
The use of these tools for geometric shapes is similar to the tool used for drawing 
rectangles and squares. For more information, see “Drawing rectangles or squares” 
on page 7.

Note
The icons for geometric shapes displayed on the Drawing toolbar will change shape 
according to the last tool selected and used to draw an object.

Basic shapes

Click on the triangle or arrow to the right of the Basic Shapes icon  to open the Basic Shapes 
toolbar (Figure 15) for drawing basic shapes. This toolbar also includes a rectangle tool identical to 
the one already displayed on the Drawing toolbar.

Figure 15: Basic Shapes toolbar

Symbol shapes

Click on the triangle or arrow to the right of the Symbol Shapes icon  to open the Symbol 
Shapes toolbar (Figure 16) for drawing symbols.

Figure 16: Symbol Shapes toolbar
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Block arrows

Click on the triangle or arrow to the right of the Block Arrows icon  to open the Block Arrows 
toolbar (Figure 17) for drawing block arrows.

Figure 17: Block Arrows toolbar

Flowcharts

Click on the triangle or arrow to the right of the Flowcharts icon  to open the Flowchart toolbar 
(Figure 18) for symbols used in drawing flowcharts. The creation of flowcharts, organization charts, 
and similar planning tools are further described in Chapter 9 Organization Charts, Flow Diagrams, 
and More.

Figure 18: Flowcharts toolbar

Callouts

Click on the triangle or arrow to the right of the Callouts icon  to open the Callouts toolbar 
(Figure 19) for drawing callouts.

Figure 19: Callouts toolbar

Stars and banners

Click on the triangle or arrow to the right of the Stars icon  to open the Stars and Banners 
toolbar (Figure 20) for drawing stars and banners.

Figure 20: Stars and Banners toolbar

Adding text to drawings and objects

In Draw you can add, insert and format text to a drawing, objects and shapes as follows:
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• As a dynamic text frame, which is an independent Draw object and expands as you add 
more text within the frame.

• Text within a previously drawn object. This integrates text within the object and is placed 
within the boundary rectangle that surrounds an object. This boundary rectangle is not 
dynamic and care must be taken so that your text does not go outside of the object 
boundaries.

• For more information on how to add, insert and format text in a drawing or drawing objects, 
see Chapter 9 Adding and Formatting Text.
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