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Introduction

This chapter covers the more advanced tools for working with text in Writer:
* The built-in language tools
* Advanced find-and-replace techniques, including wildcards
» Track changes and insert comments
* Footnotes and endnotes
» Linking to other parts of a document
e Line numbering

This chapter assumes that you are familiar with the basic text techniques described in Chapter 2,
Working with Text: Basics. We recommend that you also display formatting aids, such as end-of-
paragraph marks, tabs, breaks, and other items in Tools > Options > LibreOffice Writer >
Formatting Aids.

For information on formatting text (characters, paragraphs, lists), see Chapter 4.

Using built-in language tools

Writer provides some tools that make your work easier if you mix multiple languages within the
same document or if you write documents in various languages:

» Paragraph and character styles

* The functions in Tools > Language

* Language settings in Options

* The functions available on the status bar

The main advantage of changing the language for a text selection is that you can then use the
correct dictionaries to check spelling and apply the localized versions of AutoCorrect replacement
tables, thesaurus, and hyphenation rules. A grammar checking dictionary may also be available for
the selected language.

You can also set the language for a paragraph or a group of characters as None (Do not check
spelling). This option is especially useful when you insert text such as web addresses or
programming language snippets that you do not want to check for spelling.

Using paragraph and character styles

Changing the language on the Font tab of the Paragraph Styles dialog (Figure 1) will change the
language for all paragraphs that use that paragraph style. If you will have whole paragraphs in
different languages in a single document, you can use a different paragraph style for each
language. For example, you might define Text Body-EN and Text Body-FR in a document
containing paragraphs in both English and French

You can also set certain paragraphs to be checked in a language that is different from the
language of the rest of the document by putting the cursor in the paragraph and changing the
language on the Task Bar.

See Chapter 9, Working with Styles, for information on how to manage the language settings of a
style.
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Organizer Indents & Spacing Alignment Text Flow | Font | Font Effects Position

Family Typeface Size:

|D_iberati0n Sans | Bold 14 pt

Liberation Sans Regular 10 pt

Liberation Sans Narrow Bold 10.5 pt

Liberation Serif Italic 11 pt

Libian SC Bold Italic 12 pt

LiHei Pro 13 pt

Linux Biolinum G 14 pt

Linux Libertine Display G 15 pt

Linux Libertine G 16 pt

LiSong Pro 18 pt

Lucida Grande 20 pt

I iminari 27 nt

[Language: English (USA) ﬁ]

Figure 1: Setting the language for a paragraph style

Using Tools > Language

You can set the language for the whole document, for individual paragraphs, or even for individual
words and characters, from Tools > Language on the Menu bar.

* For Selection applies a specified language to the selected text. If the language you wish to
apply is not listed in the submenu, choose More... to open the Character dialog.

* For Paragraph applies the specified language to the paragraph where the cursor is
located. If the language you wish to apply is not listed in the submenu, choose More...

* For all Text applies the specified language to all of the document, including text inserted

after making the change. If the language you wish to apply is not listed in the submenu,
choose More...

* More... opens the Character dialog, where you can select the required language on the

Font tab. After a language has been applied to a selection or paragraph in the document,
that language appears on the submenus for selections, paragraphs, and all text.

Tools Window Help

Spelling and Grammar... G5204-WorkingWithText_2_JHW_20160925.odt
Automatic Spell Checking = . o8
Thesaurus... TWENENA.
Language For Selection English (UK)
Word Count For Paragraph + English {(USA)
For all Text French (France)
German {Switzerland)
None (Do not check spelling)

AutoCorrect
AutoText... Hyphena

Outline Numbering... : 55 . i Reset to Default Language

Line Numbering... - : - ik More...
Footnotes and Endnotes... More Dictionaries Online...
Forms

The Reset to Default Language option on the submenu is the fastest way to return a selection,
paragraph, or all text to the default language set in Tools > Options (described below).

Using language settings in Options

Another way to change the language of a whole document is to use Tools > Options > Language
Settings > Languages. In the Default languages for documents section (Figure 2), you can
choose a different language for all the text that is not explicitly marked as a different language.

Using built-in language tools | 5



A Caution

A change in the default language from the Options dialog is a general change of
settings of LibreOffice and will therefore apply to all the documents created in the
future. If you want to change the language for the current document only, be sure to
select the For the current document only option (see Figure 2).

Default languages for documents
Western *& English (USA) v
[ ] Asian Default - Chinese (simplified]

omplex text layou Default - Hind
[] complex text layout (CTL) O

[D For the current document Dnly]

Enhanced language support
|:| Ignore system input language

Figure 2: Options available in the Languages settings

Z Note

The spelling checker works only for those languages in the list that have a checkmark
symbol next to them. If you do not see this symbol next to your preferred language,
you can install the dictionary using Tools > Language > More dictionaries online.

Using the status bar

The language used for checking spelling is also shown in the status bar, next to the page style in
use. You can change the language for the paragraph or the entire document; click the language in
the status bar to pop up a menu of choices.

an on the men English (LK) tastest way to
o the default i ane
* [English (USA) | English (UK)
Mone (Do not chedk spelling) Engiish (USA)
Reset to Default Language None (Do not check speling)
iesaurus | More. Reset to Default Language

Set Language for Paragraph  » Mare, ..

English (LISA)

Figure 3: Language choices on the status bar

The Reset to Default Language option on the menu and submenu is the fastest way to return a
paragraph or the entire document to the default language set in Tools > Options (described
above).

Advanced find and replace techniques

In addition to finding and replacing words and phrases (described in Chapter 2), you can use
Writer’s Find & Replace dialog to find and replace text attributes, formatting, and paragraph styles.
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Find and replace text attributes and formatting

A powerful use of Find & Replace takes advantage of the Attributes and Format options. For
example, you might want to replace underlined words with italics.

To find specific text attributes such as alignment, background, font color, line spacing that have
been changed from the default:
1) On the Find & Replace dialog (with Other Options displayed), click the Attributes button.

2) Select the attribute you wish to search for from the list in the Attributes dialog and click OK.
The names of the selected attributes appear under the Find: box. For example, to search
for text that has been changed from the default font color, select the Font Color attribute.

3) Click Find Next or Find All to search the document.

To find specific formatting such as bold, italic, font size:

1) Open the Find & Replace dialog with Other Options displayed.

2) To find text with specific formatting, enter the text in the Find: box. To search for specific
formatting only, delete any text in the Find: box.

3) Click Format to display the Text Format (Search) dialog. The tabs on this dialog are similar
to those on the Paragraph and Paragraph Style dialogs.

4) Choose the formats you want to search for and then click OK. The names of the selected
formats appear under the Find: box. For example, you might search for all text in 14-point
bold Times New Roman. The option Paragraph Styles changes to Including Styles.

5) To replace the format, click in the Replace: box, choose the format to use, and then click
OK. The format selected will be displayed below this text box. To replace text as well as
formatting, type the replacement text in the Replace: box.

To remove specific character formatting, click Format, select the Font tab, then select the
opposite format (for example, No Bold). The No Format button on the Find & Replace
dialog clears all previously selected formats.

6) Click Find Next, Find All, Replace, or Replace All.

A Caution

Unless you plan to search for other text using those same attributes, click No Format
to remove the attributes after completing your search. Without this, the next search
may fail to find words you know are in the document.

Search for

W

| bald, Times Mew Roman, 14pt |

Find and replace paragraph styles

Combining material from several sources may result in unwanted paragraph styles in your
document. To quickly change all the paragraphs from one (unwanted) style to another (preferred)
style:

1) On the expanded Find & Replace dialog, select Paragraph Styles. The Find: and Replace:
boxes now contain a list of styles in use in the document.

If you have attributes specified, this option is labeled Including Styles. Select No Format to
remove any attributes and return the option to Paragraph Styles.

Advanced find and replace techniques | 7



2) Select the styles you want to search for and replace.
3) Click Find, Find All, Replace, or Replace All.
Repeat steps 2 and 3 for each style that you want to replace.

Use similarity search

Find terms that are similar to the Find: text. For example, a similarity search can find words that
differ from the Find: text by two characters.

Select Similarity search and click the Similarities button to open a dialog in which you can modify
the text search by length and number of characters different from the search term (see Figure 4).

Exchange characters
Enter the number of characters in the search term that can be exchanged. For example, if
you specify 2 exchanged characters, "black” and "crack" are considered similar.

Add characters
Enter the maximum number of characters by which a word can exceed the number of
characters in the search term.

Remove characters
Enter the number of characters by which a word can be shorter than the search term.

Combine
Searches for a term that matches any combination of the similarity search settings.

Find: Once
@ Similarity Search

Exchange characters: 2 2]
Replace: Add characters: 2 |=]

Remove characters: 2 |

Find All _ | Replace Replace All
| [ Combine I P P
Cther optior
Help oK Cancel

nt S§ : Backwards

ar expressions [ 1"Paragraph
Similarity search Similarities...

Comments

Figure 4: Similarity search dialog

Use wildcards and regular expressions

A wildcard is a special character that represents one or more unspecified characters. Wildcards
make text searches more powerful but often less specific. LibreOffice enables you to use
combinations of characters known as regular expressions which are more specific than simple
wildcards but less so than a literal string. Regular expressions are very powerful but not very
intuitive. They can save time and effort by combining multiple finds into one.

Table 1 shows a few of the regular expressions used by LibreOffice.
0 Tip

The online help describes many more regular expressions and their uses.
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To use wildcards and regular expressions when searching and replacing:

1)

2)

3)

On the Find & Replace dialog, click Other Options to see more choices. On this expanded
dialog, select the Regular expressions option.

Type the search text, including the wildcards, in the Search for box and the replacement
text (if any) in the Replace with box. Not all regular expressions work as replacement
characters; the line break (\n) is one that does work.

Click Find, Find All, Replace, or Replace All (not recommended).

Note

To search for a character that is defined as a wildcard, type a backslash (\) before the
character to indicate that you are using it literally. For example, to find the text $5. 00,
you would conduct a search using \$5\ . 00.

Table 1: Examples of search wildcards (regular expressions)

To find o th'S. Examples and comments
expression
Any single character . (a period or b.d finds bad, bud, bid, and bed.
full stop)
One of the specified [xyz] bliu]n finds bin and bun.
characters
Any single character in [X-y] [r-tleed finds reed, seed, and teed; ranges must be in
this range alphabetically ascending order.
Any single character ["X] p[ta]st finds post and pest, but not past.
except the characters
inside the brackets
The beginning of a word \<start \<log finds logbook and logistics, but not catalog.
The end of a word end\> log\> finds catalog, but not logistics.
A paragraph marker $ Does not work as a replacement character. Use \n
instead.
A line break \n Finds a line break that was inserted with Shift+Enter.
When used as a replacement character, it inserts a
paragraph marker.

Tracking changes to a document

You can use several methods to keep track of changes made to a document.

Make your changes to a copy of the document (stored in a different folder, under a different
name, or both), then use Writer to compare the two files and show the changes you made.

This technique is particularly useful if you are the only person working on the document, as
it avoids the increase in file size and complexity caused by the other methods.

Save versions that are stored as part of the original file. However, this method can cause
problems with large or complex documents, especially if you save a lot of versions. Avoid
this method if you can.

Use Writer’'s change marks (often called “redlines” or “revision marks”) to show added or
deleted material or changed formatting. Later, you or another person can review and accept
or reject each change.

Tracking changes to a document | 9




£7] Note

Not all changes are recorded. For example, changing a tab stop from align left to align
right and changes in formulas (equations) or linked graphics are not recorded.

Preparing a document for review

When you send a document to someone else to review or edit, you may want to prepare it first so
that the editor or reviewer does not have to remember to turn on the revision marks. After you have
protected the document, any subsequent user must enter the correct password in order to turn off
protection or accept or reject changes.

1) Open the document. Check whether it contains multiple versions by clicking File >
Versions. If multiple versions are listed, save the current version as a separate document
with a different name and use this new document as the review copy.

2) With the review copy open, make sure that change recording is turned on. The Edit >
Track Changes > Record Changes menu item has a check mark next to it when recording
is turned on.

3) Click Edit > Track Changes > Protect Changes. On the Enter Password dialog, type a
password (twice) and click OK.

An alternative to steps 2 and 3 above is to choose File > Properties > Security tab,
select the Record changes option, then click Protect and enter the password.

Recording changes

See Chapter 20, Setting up Writer, for instructions on setting up how changes will be displayed, if
you don't like the default settings.

1) To begin tracking (recording) changes, click Edit > Track Changes > Record Changes. To
show or hide the display of changes, click Edit > Track Changes > Show Changes.

':@:‘ Tip

Hold the mouse pointer over a marked change; you will see a Help Tip showing the
type of change, the author, date, and time of day for the change. If Extended Tips are
enabled, you will also see any comments recorded for this change.

2) To enter a comment on a marked change, place the cursor in the area of the change and
then click Edit > Track Changes > Comment on Change.

In addition to being displayed as an extended tip, the comment is also shown in the list in
the Manage Changes dialog (Figure 6).

To move from one marked change to the next, use the arrow buttons. If no comment has
been recorded for a change, the Text field is blank.

3) To stop recording changes, click Edit > Track Changes > Record Changes again.
) Tip

See also “Adding other comments” on page 13 for a way to annotate text that is not
associated with a recorded change.
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Comment: Insertion

Contents
Author  John Smith, 02/21/2014 20:22
Text

A comment on the inserted text, ”

Figure 5: Inserting a comment during change recording

Accepting or rejecting changes
To accept or reject recorded changes, use any of these tools:
* Changes toolbar
* Right-click (context) menu
* Manage Changes dialog
* Manage Changes pane in the Sidebar (experimental)
The results of accepting or rejecting a change are as follows:

* Accept: incorporates the alteration into the document and removes the change indication
marking.

* Reject: reverts the document to its original state and removes the change indication
marking.

Changes toolbar

For quick and easy accepting and rejecting of changes, you can use the Changes toolbar, which
includes buttons for the same functions as appear on the Edit > Track Changes submenu. To
enable the Changes toolbar, click View > Toolbars > Changes on the Menu bar. You can dock
this toolbar in a convenient place or leave it floating.

Right-click (context) menu
1) |If recorded changes are not showing, click Edit > Track Changes > Show Changes.

2) Hover the mouse pointer over a recorded change. A box appears with information about the
type of change, who made it, and the date and time.

3) Right-click the changed text. In the context menu, choose Accept Change or Reject
Change.

Manage Changes dialog
1) Click Edit > Track Changes > Manage Changes. The Manage Changes dialog (Figure 6)
opens, showing changes that have not yet been accepted or rejected.

2) When you select a change in the dialog, the change itself is highlighted in the document, so
you can see what the editor changed.

3) Click Accept or Reject to accept or reject the selected change. You can also click Accept
All or Reject All if you do not want to review the changes individually.

To show only the changes of certain people or only the changes on specific days or various other
restrictions, use the Filter page (Figure 7) on the Accept or Reject Changes dialog. After specifying
the filter criteria, return to the List page to see those changes that meet your criteria.

Tracking changes to a document | 11



List Filter
Action Author |Date Comment

Deletion John Smith 02/21/2014 20:22

Insertion John Smith 02/21/2014 20:22 A comment on the inserted text.
Insertion John Smith 02/21/2014 20:55

Deletion John Smith 02/21/2014 21:03

Insertion John Smith 02/21/2014 21:03  Another comment,

Deletion John Smith 02/21/2014 21:23

Insertion John Smith 02/21/2014 21:23

ﬁccept l I Beject ] I Accept Al ] [ Reject Al ] I Close

Figure 6: The List tab of the Manage Changes dialog

List |Filter
[#] Date between w| |oz/z1/2014 = |19:59 =
w w
— —
and (0272002014 (3 2258 (3]

Authar John Smith V
Action Insertion v
Comment

Accept ] [ Reject ] I Accept all ] I Reject all l [ Close

Figure 7: The Filter page of the Manage Changes dialog

Manage Changes pane in the Sidebar
The Manage Changes pane in the Sidebar shows the same information as in the Manage Changes
dialog described above.

Comparing documents

Sometimes reviewers may forget to record the changes they make. You can find the changes if you
compare the original document and the one that is edited. To compare them:

1) Open the edited document. Select Edit > Track Changes > Compare Document.
2) The Insert dialog appears. Select the original document and click Insert.

Writer finds and marks the changes and displays the Manage Changes dialog. From this point, you
can go through and accept or reject changes procedure as described earlier.

Merging modified documents

The processes discussed to this point are effective when you have one reviewer at a time.
Sometimes, however, multiple reviewers all return edited versions of a document. In this case, it
may be quicker to review all of these changes at once, rather than one review at a time. For this
purpose, you can merge documents in Writer.
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To merge documents, all of the edited documents need to have recorded changes in them.

1) Open one copy.

2) Click Edit > Track Changes > Merge Document and select and insert another copy of the
document to be merged with the first.

3) After the documents merge, the Manage Changes dialog opens, as in Figure 6, showing
changes by more than one reviewer. If you want to merge more documents, close the
dialog and then repeat step 2.

4) Repeat until all copies are merged.
All recorded changes are now included in the open copy. Save this file under another name.

Adding other comments

Writer provides another type of comments, which authors and reviewers use to exchange ideas,
ask for suggestions, or mark items needing attention.

You can select a block of text, including multiple paragraphs, to be highlighted for a comment, or
you can insert a comment at a single point. To insert a comment, select the text, or place the
cursor in the place the comment refers to, and choose Insert > Comment or press Cirl+Alt+C.

The anchor point of the comment is connected by a dotted line to a box on the right-hand side of
the page where you can type the text of the comment. A Comments button is also added to the
right of the horizontal ruler (see Figure 8); you can click this button to toggle the display of the
comments.

Writer automatically adds the author’s name and a time stamp indicating when the comment was
created. Select Tools > Options > LibreOffice > User Data to configure the name you want to
appear in the Author field of the comment, or to change it.

Click somewhere on the page to finish your comment. Otherwise, you will not be able to move
away from this location.

This comment is nested due to
overlapping text selection.

multiple paragraphs, or a single point may be selected

‘a comment select the text, or place ffie cursor in the Comment on selected text.
» Comment or press Cirl+Ali+C. The anchor point of

box on the right-hand side of the page where you can

ly adds at the bottom of the comment the author's Joe Soap

nment was created. Today, 20:27
A single point comment.

Figure 8: Comments in LibreOffice

If more than one person edits the document, each author is automatically allocated a different
background color. Figure 8 shows an example of text with comments from two different authors. If
an author selects text that overlaps another author's comments, then the comments from the
second author are nested with those of the first author.
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Right-click a comment to open a context menu where you can delete the current comment, all the
comments from the same author, or all the comments in the document. From this menu, you can
also open a dialog to apply some basic formatting to the text of the comment. You can also change
font type, size, and alignment from the Menu bar.

To navigate from one comment to another, open the Navigator (F5), expand the Comments
section, and click the comment text to move the cursor to the anchor point of the comment in the
document. Right-click the comment to quickly edit or delete it.

You can also navigate the comments using the keyboard. Use Ctrl+Alt+Page Down to move to the
next comment and Ctr/+Alt+Page Up to move to the previous comment.

Comments can be printed next to the text in the right margin as they appear on screen. Each page
is scaled down in order to make space for the comments to fit on the underlying paper size.

Using footnotes and endnotes

Footnotes appear at the bottom of the page on which they are referenced. Endnotes are collected
at the end of a document.

To work effectively with footnotes and endnotes, you need to:
* Insert footnotes and define their format

» Define the location of footnotes on the page, and the color and line styles for separator
lines, if the defaults do not meet your needs (see Chapter 5, Formatting Pages: Basics).

Inserting footnotes and endnotes

To insert a footnote or an endnote, put the cursor where you want the footnote or endnote marker
to appear. Then select Insert > Footnote and Endnote from the Menu bar and choose Footnote
or Endnote, or click the Insert Footnote or Insert Endnote button on the Standard toolbar.

A footnote or endnote marker is inserted in the text and, depending on your choice, the cursor is
relocated either to the footnote area at the bottom of the page or to the endnote area at the end of
the document. Type the footnote or endnote content in this area.

You can also choose use Insert > Footnhote and Endnote > Footnote or Endnote to open the
Insert Footnote/Endnote dialog (Figure 9), where you can choose whether to use the automatic
numbering sequence specified in the footnote settings and whether to insert the item as a footnote
or an endnote.

-

Insert Footnote/Endnote

Humbering

Type
G} Footnote
(") Endnote

o[ o

Figure 9: Inserting a footnote/endnote

If you use Insert Footnote or Insert Endnote, the footnote or endnote automatically takes on the
attributes previously defined in the Footnote Settings dialog.
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You can edit an existing footnote or endnote the same way you edit any other text.

To delete a footnote or endnote, delete the footnote marker. The contents of the footnote or
endnote are deleted automatically, and the numbering of other footnotes or endnotes is adjusted
automatically.

Defining the format of footnotes/endnotes

To format the footnotes themselves, click Tools > Foothotes and Endnotes. On the
Footnotes/Endnotes Settings dialog (Figure 10), choose settings as required.

P 1

Footnotes/Endnotes Settings

Footnotes Endnotes

Autonumbering

Numbering &y 2, 3, s v | startat (1 &
Counting  |Per document v
Before After

Position (%) End of page
() End of document

Styles Character styles
Paragraph |Footnote V Text area Footnote Anchor V
Page Footnote Footnote area |Footnote Characters ™

Continuation notice

End of footmaote

Start of next page

| K | | Cancel | | Help

Figure 10: Defining footnote formatting

Linking to another part of a document

If you type in cross-references to other parts of the document, those references can easily get out
of date if you reorganize the order of topics, add or remove material, or reword a heading. Writer
provides two ways to ensure that references are up to date, by inserting links to other parts of the
same document or to a different document: hyperlinks and cross-references.

The two methods have the same result: if you Ctrl+click the link when the document is open in
Writer, you are taken directly to the cross-referenced item. However, they also have major
differences:

* The textin a hyperlink does not automatically update if you change the text of the linked
item (although you can change it manually), but changed text does automatically update in
a cross-reference.
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* When using a hyperlink, you do not have a choice of the content of the link (for example
text or page number), but when using a cross-reference, you have several choices,
including bookmarks.

* To hyperlink to an object such as a graphic, and have the hyperlink show useful text such
as Figure 6, either give such an object a useful name instead of leaving it as the default
name (“Graphics6”) or use the Hyperlink dialog to modify the visible text. In contrast, cross-
references to figures with captions automatically show useful text, and you have a choice of
several variations of the name.

* If you save a Writer document to HTML, hyperlinks remain active but cross-references do
not. (Both remain active when the document is exported to PDF.)

Using cross-references

To ensure that references update if you reword a heading, caption, or other linked item, use
automatic cross-references. For details, see “Using automatic cross-references” in Chapter 17,
Fields.

Using bookmarks

Bookmarks are listed in the Navigator and can be accessed directly from there with a single mouse
click. In HTML documents, bookmarks are converted to anchors that you can jump to by hyperlink.
For more about bookmarks, see “Using bookmarks” in Chapter 17, Fields.

Using hyperlinks

When you type text (such as website addresses or URL) that can be used as a hyperlink, and then
press the spacebar or the Enter key, Writer automatically creates the hyperlink and applies
formatting to the text (usually a color and underlining).

If this does not happen, you can enable this feature using Tools > AutoCorrect Options >
Options and selecting the URL Recognition option.

If you do not want Writer to convert a specific URL to a hyperlink, choose Edit > Undo Insert from
the Menu bar or press Ctrl+Z immediately after the formatting has been applied.

You can also insert hyperlinks using the Navigator and the Hyperlink dialog, and you can modify all
hyperlinks using the Hyperlink dialog, as described in this section.

g Note

Hyperlinks between documents can be set as relative or absolute, using the Save
URLSs relative to option in Tools > Options > Load/Save > General.

Relative linking is only possible when the document you are working on and the link
destination are on the same drive, and you need to create the same directory structure
on your hard disk as will apply on the destination website.

LibreOffice uses absolute path names internally, so when you move your mouse
cursor over a hyperlink, the tooltip displays the absolute reference even when it is set
to be a relative link.

Inserting hyperlinks using the Navigator

The easiest way to insert a hyperlink to another part of the same document is by using the
Navigator:

1) Open the document containing the items you want to cross-reference.
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2) Open the Navigator (by clicking its icon, choosing View > Navigator, pressing F5, or
selecting the Navigator Tab on the open Sidebar).

3) Click the arrow next to the Drag Mode icon, and select Insert as Hyperlink.

4) In the list at the bottom of the Navigator, select the document containing the item that you
want to cross-reference.

5) In the Navigator list, select the item that you want to insert as a hyperlink.
6) Drag the item to where you want to insert the hyperlink in the document. The name of the
item is inserted in the document as an active hyperlink.

£
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Insert as Link

Insert as Copy

Mote for Mac users
Introduction
+  Selecting text
Cutting, copying, and pasting text
#  Finding and replacing text and formatting ||
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WE4003-WorkingWithText (active) v

Figure 11: Inserting a hyperlink using the Navigator

Inserting hyperlinks using a dialog

To display the Hyperlink dialog (Figure 12), click the Hyperlink icon on the Standard Toolbar or
choose Insert > Hyperlink from the Menu bar. To turn existing text into a link, select it before
opening the dialog.

[ ] [ ] Hyperlink

| T Hyperlink Type

i O Web A7
Internet

URL: www.libreoffice.org| -
| Mail

i
] Document  Further Settings

Frame: & Form: | Text | <]

New Text: www.libreoffice.org
Document

Name:

Help ook Apply Close Reset

Figure 12: Hyperlink dialog showing details for Internet links

On the left hand side, select one of the four types of hyperlink:
* Internet: a web address, normally starting with http://
* Mail: an email address.
* Document: another document or to another place in the presentation.
* New document: the hyperlink creates a new document.www.libreoffice.org
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The top right part of the dialog changes according to your choice for the hyperlink type. A full
description of all the choices, and their interactions, is beyond the scope of this chapter. The most
common choices used in Writer documents are as follows.

For an Internet hyperlink, choose the type of hyperlink (choose between Web, FTP or Telnet), and
enter the required web address (URL).

For a Mail hyperlink, specify the receiver address and the subject.

For a Document hyperlink, specify the document path (the Open File button opens a file browser);
leave this blank if you want to link to a target in the same presentation. Optionally specify the target
in the document (for example a specific slide). Click the Target icon to open the Navigator where
you can select the target, or if you know the name of the target, you can type it into the box.

For a New Document hyperlink, specify whether to edit the newly created document immediately or
just create it (Edit later) and the type of document to create (text, spreadsheet, and so on). For a
text document, Edit now is the more likely choice. The Select Path button opens a folder picker.

The Further settings section in the bottom right part of the dialog is common to all the hyperlink
types, although some choices are more relevant to some types of links.

* Set the value of Frame to determine how the hyperlink will open. This applies to documents
that open in a Web browser.

* Form specifies if the link is to be presented as text or as a button.
* Text specifies the text that will be visible to the user.

* Name is applicable to HTML documents. It specifies text that will be added as a NAME
attribute in the HTML code behind the hyperlink.

» Event button: this button will be activated to allow LibreOffice to react to events for which
the user has written some code (macro). This function is not covered in this book.

Editing hyperlinks

To edit a hyperlink, click anywhere in the link text and then open the Hyperlink dialog by clicking
the Hyperlink icon on the Standard Toolbar or choosing Edit > Hyperlink from the Menu bar.
Make your changes and click Apply. If you need to edit several hyperlinks, you can leave the
Hyperlink dialog open until you have edited all of them. Be sure to click Apply after each one.
When you are finished, click Close.

The standard (default) behavior for activating hyperlinks within LibreOffice is to use Ctrl+click. This
behavior can be changed in Tools > Options > LibreOffice > Security > Options, by deselecting
the option Ctrl-click required to follow hyperlinks. If clicking in your links activates them, check

that page to see if the option has been deselected.

To change the color of hyperlinks, go to Tools > Options > LibreOffice > Appearance, scroll to
Unvisited links and/or Visited links, select those options, pick the new colors and click OK. Caution:
this will change the color for all hyperlinks in all components of LibreOffice—this may not be what
you want.

In Writer and Calc (but not Draw or Impress), you can also change the Internet link character style
or define and apply new styles to selected links.

Line numbering

Line numbering puts line numbers in the margin. It is often used in legal documents, poetry, and
lists of programming code. Writer can insert line numbers in an entire document or in selected
paragraphs. Line numbers are included when you print the document. You can also add a
separator between line numbers. Figure 13 shows an example with numbering on every line.
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You can choose how many lines are numbered (for example, every line or every tenth line), the
numbering type, and whether numbers restart on each page. In addition, a text separator (any text
you choose) can be set on a different numbering scheme (one every 12 lines, for example).

Line humbering

Line numbering puts line numbers in the ma
also printed. Figure 1 shows an example wit

Click Toels = Line Numbering and select tr
Line Numbering dialog (Figure 2). Then click

You can choose how many lines are number
numbering type, and whether numbers resta
choose) can be set on a different numbering

Figure 13: Line numbering example
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To add line numbers to an entire document:

1) Click Tools > Line Numbering and select the Show numbering option in the top left
corner of the Line Numbering dialog (Figure 14).

2) Then select any options you want and click OK.
® ® Line Mumbering
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Format: 1,23 . <]
Position: Left .J
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Separatar Count
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= Include header and footer
Restart every new page
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Figure 14: The Line Numbering dialog

To add line numbers to specific paragraphs, first disable the feature for the document and then
enable it for specific paragraphs or paragraph styles.

To disable line numbering for the document, edit the Default Style paragraph style (because all
paragraph styles are based on the Default Style):

1) Inthe Sidebar, go to the Styles and Formatting pane and click the Paragraph Styles icon.

2) Right-click the Default Style paragraph style and choose Modify.
3) Click the Outline & Numbering tab (see Figure 15).
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4) Inthe Line Numbering area, clear the Include this paragraph in line numbering

checkbox.
5) Click OK.
[ ] Paragraph Style: Default Style
Organizer  Indents & Spacing  Alignment  TextFlow  Font  FontEffects  Position
Highlighting | Outline & Numbering | Tabs  DropCaps  Area  Transparency  Borders
Outline
Outline level: Body text | < |
Numbering |
Numbering style: None <

Line Numbering
./ Include this paragraph in line numbering

Restart at this paragraph

(2]
.

Figure 15: Disabling line numbering for a document

To enable line numbering for specific paragraphs:
1) Select the paragraphs where you want to add the line numbers.
2) Choose Format > Paragraph, and then click the Outline & Numbering tab.
3) Select Include this paragraph in line humbering.
4) Click OK.

You can also create a paragraph style that includes line numbering, and apply it to the paragraphs
that you want to add line numbers to. For example, to number the lines of example code in a
document, you will probably want to use a font or indentation that is different from normal text.

To specify the starting line number:

1) Click in the paragraph and choose Format > Paragraph.

2) On the Outline & Numbering tab, make sure Include this paragraph in line numbering is
selected.

3) Select Restart at this paragraph and enter a line number in the Start with box.
4) Click OK.
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