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Introduction

This chapter describes some common customizations that you may wish to do, in addition to the 
options described in Chapter 20, Setting up Writer. You can customize menus, toolbars, and 
keyboard shortcuts in LibreOffice, add new menus and toolbars, and assign macros to events.

Other customizations are made easy by extensions that you can install from the LibreOffice 
website or from other providers.

Note

Customizations to menus and toolbars can be saved in a template. To do so, first save
them in a document and then save the document as a template as described in 
Chapter 10, Working with Templates. If you work on more than one project, you may 
find that having different menus and toolbars can be useful.

Customizing menus

You can add to and rearrange menus on the Menu bar, add commands to menus, and make other 
changes. You can also modify context (right-click) menus in a similar way.

To customize a menu, choose Tools > Customize. On the Customize dialog, go to the Menus tab 
(Figure 1) or the Context Menus tab.

Figure 1: The Menus tab of the Customize dialog
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Modifying an existing menu
 1) In the Scope drop-down list in the upper right of the Customize dialog, choose whether to 

apply the customized menu to all of LibreOffice Writer or only to a specific document.

 2) In the Target drop-down list, select the menu that you want to customize. The list includes 
the main menus and submenus. The commands on the selected menu are shown in the 
Assigned commands list.

 3) To add a command to the selected menu, click on a command in the Available Commands 
list and then click the large right arrow. You can narrow the search by using the Search box 
on the top left or selecting the Category in the drop-down list. Use the up and down arrows 
on the right-hand side to move the command into the position where you want it in the list.

 4) To remove a command from the selected menu, click on it in the Assigned Commands list 
and then click the large left arrow.

 5) To insert a separator or submenu, select the item directly before where you want the 
inserted item to appear, and use the commands in the Insert drop-down.

Figure 2: Insert drop-down

 6) To rename a menu item, select it in the Assigned Commands list and choose Rename from
the Modify drop-down.

Figure 3: Modify drop-down

 7) When you have finished making all your changes, click OK to save them.

Creating a new menu
You might find a “Favorites” menu useful, or a menu collecting tools for a specific project. To create
a new menu:

 1) On the Menus tab of the Customize dialog, click the symbol next to Target and select Add 
from the drop-down list (Figure 4) to display the New Menu dialog (Figure 5).

Figure 4: Location of command to add a new menu
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Figure 5: Adding a new menu

 2) Type a name for the new menu in the Menu name box.

 3) Use the up and down arrow buttons to move the new menu into the required position on the
Menu bar.

 4) Click OK to save and return to the Customize dialog.

The new menu now appears on the list of menus in the Customize dialog. It will appear on the 
Menu bar itself after you save your customizations.

After creating a new menu, you need to add some commands to it, as described above for 
modifying a menu.

Customizing toolbars

You can customize toolbars in several ways, including choosing which icons are visible and locking
the position of a docked toolbar (as described in Chapter 1, Introducing Writer), and adding or 
deleting icons (commands) in the list of those available on a toolbar. You can also create new 
toolbars.
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Figure 6: The Toolbars tab of the Customize dialog

Modifying existing toolbars
The procedures for creating and modifying a toolbar are similar to those for menus.

 1) In the Scope drop-down list on the upper right of the Customize dialog, choose whether to 
save this changed toolbar for Writer or for a selected document.

 2) In the Target drop-down list, select the toolbar that you want to customize. The current 
toolbar content is displayed in the Assigned Commands list.

 3) Select a command in the Available Commands list on the left. You can narrow your search 
by using the Search box on the top left or choosing a category in the drop-down list just 
below.

 4) Click on the large right arrow to add the selected command to the Assigned Commands list 
for the toolbar (on the right). Use the up and down arrows in the far right to position the 
command in the toolbar.

 5) To remove a command from a toolbar, select it in the Assigned Commands list on the right 
and click the large left arrow.

 6) To show or hide a command assigned to a toolbar, select or clear the checkbox by its icon 
in the Assigned Commands list on the right.

 7) To insert a separator, select the item directly before where you want the separator to 
appear, and use the command in the Insert drop-down.

 8) To rename a toolbar item, select it in the Assigned Commands list and choose Rename 
from the Modify drop-down.

 9) When you have finished making all your changes, click OK to save them.
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Creating a new toolbar
To create a new toolbar:

 1) Choose Tools > Customize on the Menu bar.

 2) On the Toolbars tab of the Customize dialog, click the symbol next to Target and select Add
from the list, to display the Name dialog (Figure 7).

 3) On the Name dialog, type the new toolbar's name and choose from the Save In drop-down 
list where to save this new toolbar: for Writer or for a selected document.

The new toolbar now appears on the list of toolbars in the Customize dialog. After creating a new 
toolbar, you need to add some commands to it, as described above.

Figure 7: Naming a new toolbar

Choosing icons for toolbar commands
Toolbar buttons usually have icons, not words, on them, but not all of the commands have 
associated icons. If the command does not have an icon, you can choose an icon for it. To choose 
an icon, select the command in the list on the right, and click Modify > Change Icon. On the 
Change Icon dialog (Figure 8), scroll through the available icons, select one, and click OK to 
assign it to the command.

To use a custom icon, create it in a graphics program and import it into LibreOffice by clicking the 
Import button on the Change Icon dialog. Custom icons should be 16×16 pixels in size to achieve 
the best quality and should not contain more than 256 colors.

Figure 8: Change Icon dialog
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Customizing the notebook bar

By default, LibreOffice Writer’s commands are grouped in cascading menus and in toolbars filled 
with icons. The Notebook bar provides a different way to organize controls and icons, displaying 
contextual groups of commands and contents. You can find more information about the Notebook 
bar in the Help system, by searching for “notebook bar” in the index.

One of the available Notebook bar modes is Tabbed – in this mode, the bar is divided into tabs, 
where each tab displays a set of icons grouped by context. The context can also change 
depending on the object selected in the document, for example a table or an image.

Checkboxes are provided on the Notebookbar tab of the Customize dialog (Figure 9) to show and 
hide the individual options on the various tabs that are provided in the Tabbed mode user interface.

Figure 9: The Notebookbar tab of the Customize dialog

Use the Reset button to reset the Tabbed mode of the notebook bar configuration to the default 
settings.

Note

LibreOffice 6.4 has three notebook bar modes that can be selected through the View >
User Interface menu – Tabbed, Tabbed Compact, and Groupedbar Compact. 
However, only the first of these can be modified using the Notebookbar tab of the 
Customize dialog.

Customizing the notebook bar | 9



Assigning shortcut keys

In addition to using the built-in keyboard shortcuts, you can define others. You can assign shortcuts
to standard LibreOffice functions or your own macros and save them for use with Writer or with the 
entire LibreOffice suite.

To adapt shortcut keys to your needs, use the Keyboard tab of the Customize dialog (Figure 10).

Figure 10: Defining keyboard shortcuts for applying styles

 1) Choose whether to have the shortcut key assignment available in all components of 
LibreOffice or only in Writer.

 2) Select the desired shortcut key in the Shortcut Keys list at the top of the page.

 3) Select the required function from the Category and Function lists.

 4) Click the Modify button. The selection now appears in the Keys list on the lower right.

 5) Click OK to accept the change.

Repeat as required.

Caution

Avoid reassigning your operating system’s predefined shortcut keys.

Note

Shortcut keys that are grayed-out in the listing on the Customize dialog, such as F1 
and F10, are not available for reassignment.
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Saving changes to a file
Changes to the shortcut key assignments can be saved in a keyboard configuration file for use at a
later time, so you can create and apply different configurations as needed. To save keyboard 
shortcuts to a file:

 1) After making keyboard shortcut assignments, click the Save button at the right of the 
Customize dialog (Figure 10).

 2) In the Save Keyboard Configuration dialog, type a name for the keyboard configuration file 
in the File name box, or select an existing file from the list. Browse to the location where 
you want to save the file. (The file extension is .cfg for Configuration.)

 3) Click Save. A confirmation dialog appears if you are about to overwrite an existing file, 
otherwise there will be no feedback and the file will be saved.

Loading a saved keyboard configuration
To load a saved keyboard configuration file and replace your existing configuration, click the Load 
button on the Customize dialog, and then select the configuration file from the Load Keyboard 
Configuration dialog.

Resetting the shortcut keys
To reset all of the keyboard shortcuts to their default values, click the Reset button on the 
Customize dialog. Use this feature with care; no confirmation dialog will be displayed.

Assigning macros to events

In LibreOffice, when something happens, we say that an event occurred. For example, a document
is opened, a key is pressed, or the mouse moved. You can associate a macro with an event, so the
macro is run when the event occurs. For example, a common use is to assign the “open document”
event to run a macro that performs certain setup tasks for the document.

To associate a macro with an event, use the Events tab of the Customize dialog. For more 
information, see Chapter 13, Getting Started with Macros, in the Getting Started Guide.

Adding functionality with extensions

An extension is a package that can be installed into LibreOffice to add new functionality. Template 
sets, spelling dictionaries, clipart galleries, macros, and dialog libraries can be packaged as 
LibreOffice extensions. They can add new top-level menus, submenus or toolbar icons. Extensions
may also have their own settings, available from the extension manager.

Several extensions are shipped bundled with LibreOffice and are installed with the program. These
can only be removed by changing the installation options. Others can be downloaded from various 
websites. The official extension repository is located at http://extensions.libreoffice.org/. These 
extensions are free of charge.

Some extensions from other sources are free of charge; others are available for a fee. Check the 
descriptions to see what licenses and fees apply to the ones that interest you.

Download the extension to your computer in any folder that you want (usually folder Download).

Installing extensions
To install an extension that is listed in the repository, follow these steps:

 1) In LibreOffice, select Tools > Extension Manager on the Menu bar.

 2) In the Extension Manager dialog (Figure 11), click Get more extensions online.
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 3) A browser window opens. Find and select the extension you want to install and click Open.

 4) Users with administrator or root privileges will see a dialog where they can choose to install 
extensions "for all users" (shared) or "only for me" (user). Users without those privileges 
can install, remove, or modify extensions only for their own use.

 5) The extension begins installing. You may be asked to accept a license agreement.

 6) When the installation is complete, the extension is listed in the Extension Manager dialog.

To install an extension that is not listed in the repository, download the extension, then continue 
with step 3 above.

Figure 11: Using the Extension Manager

Removing and disabling extensions
To remove (uninstall) an extension that you installed, select the extension in the main window of 
the Extension Manager dialog and click the Remove button.

To disable an extension without removing (uninstalling) it, select the extension in the main window 
of the Extension Manager dialog and click the Disable button, which then changes to Enable.

Adding fonts

LibreOffice supports PostScript (.pfb), TrueType (.ttf), and OpenType (.otf) font file formats. Other 
font formats exist, and may be supported by your operating system, but these formats may be 
limited in selection and quality.

If you have administration privileges, you can install additional fonts through your operating 
system; they will then be available for use by LibreOffice and will appear in Writer’s font lists.
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Finding free-licensed fonts
In addition to proprietary fonts from sources like Adobe, hundreds of free-licensed fonts are 
available. You can use, share, and edit free-licensed fonts as you please. Most are available at no 
cost. Many are clones or near-variations of classic fonts, but some are original fonts.

Many Linux distributions include a few free-licensed fonts in their package repositories. Other 
places where you can find free-licensed fonts include The League of Moveable Type 
(https://www.theleagueofmoveabletype.com/) and Open Font Library (http://openfontlibrary.org/).

Adding custom colors

To add custom colors to a color palette, for example to exactly match a corporate color scheme, 
follow this procedure:

 1) Insert any drawing object, such as a square, into any document.

 2) Right-click on the object and choose Area on the context menu.

 3) Go to the Color tab (Figure 12). Under Colors > Palette, choose which palette you wish to 
add the new color to. Under New, define the new color using RGB or Hex notation, or click 
the Pick button to select the color on the Pick a Color dialog (Figure 13).

Figure 12: Defining a new color

 4) Click Add in the lower left corner, enter a name for the new color in the pop-up dialog, and 
click OK to save.

 5) Delete the drawing object from the document, if it is not needed.
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Figure 13: Defining a color by picking it from a color chart

14 | Chapter 21  Customizing Writer


	Copyright
	Contributors
	To this edition
	To previous editions

	Feedback
	Publication date and software version
	Note for macOS users

	Introduction
	Customizing menus
	Modifying an existing menu
	Creating a new menu

	Customizing toolbars
	Modifying existing toolbars
	Creating a new toolbar
	Choosing icons for toolbar commands

	Customizing the notebook bar
	Assigning shortcut keys
	Saving changes to a file
	Loading a saved keyboard configuration
	Resetting the shortcut keys

	Assigning macros to events
	Adding functionality with extensions
	Installing extensions
	Removing and disabling extensions

	Adding fonts
	Finding free-licensed fonts

	Adding custom colors

