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What is Calc?

Calc is the spreadsheet component of LibreOffice. You can enter data (usually numerical) in a 
spreadsheet and then manipulate this data to produce certain results.

Alternatively, you can enter data and then use Calc in a “What if...” manner by changing some of 
the data and observing the results without having to retype the entire spreadsheet or sheet.

Other features provided by Calc include:

• Functions, which can be used to create formulas to perform complex calculations on data.

• Database functions, to arrange, store, and filter data.

• Dynamic charts; a wide range of 2D and 3D charts.

• Macros, for recording and executing repetitive tasks; scripting languages supported include 
LibreOffice Basic, Python, BeanShell, and JavaScript.

• Ability to open, edit, and save Microsoft Excel spreadsheets.

• Import and export of spreadsheets in multiple formats, including HTML, CSV, PDF, and 
PostScript.

Compatibility with other spreadsheet applications

Wildcards
Simple wildcards such as the asterisk (*), question mark (?), and tilde (~) from other spreadsheet 
applications are recognized by LibreOffice. Wildcards are more widespread in other spreadsheet 
applications and adopting a similar option in LibreOffice allows for better compatibility and a better 
experience for users who may not be familiar with the use of regular expressions.

Formula syntax
By default, LibreOffice Calc uses its own formula syntax, referred to as Calc R1 rather than the 
Excel R1 syntax that is used by Microsoft Excel. LibreOffice will translate seamlessly between the 
two. However, if you are familiar with Excel you may wish to change the default syntax in Calc by 
going to Tools > Options > LibreOffice Calc > Formula > Formula Syntax and choosing Excel 
R1 from the drop-down menu provided.

For more information on formula syntax, see the Calc Guide Chapter 7 Formulas and Functions.

Macros
Microsoft Office uses Visual Basic for applications (VBA) code, and LibreOffice uses Basic code 
based on the LibreOffice API. Although the programming languages are the same, the objects and 
methods are different and therefore not entirely compatible.

LibreOffice can however run some Excel Visual Basic Scripts if you enable this feature at Tools > 
Options > Load/Save > VBA Properties.

For more information on macros, refer to the Calc Guide Chapter 12 Calc Macros.

Spreadsheets, sheets, and cells

Calc works with documents called spreadsheets. Spreadsheets consist of a number of individual
sheets, each sheet containing cells arranged in rows and columns. A particular cell is identified by 
its row number and column letter.

Cells hold the individual elements – text, numbers, formulas, and so on – that make up the data to 
display and manipulate.
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Each spreadsheet can have several sheets, and each sheet can have many individual cells. In 
Calc, each sheet can have a maximum of 1,048,576 rows and a maximum of 1024 columns. 
LibreOffice Calc can hold up to 32,000 sheets.

Calc main window

When Calc is started, the main window opens (Figure 1). The parts of this window are described 
below.

Title bar
The Title bar, located at the top, shows the name of the current spreadsheet. When a spreadsheet 
is newly created from a template or a blank document, its name is Untitled X, where X is a number.
When you save a spreadsheet for the first time, you are prompted to enter a name of your choice.

Figure 1: Calc main window

Menu bar
When you select an item on the Menu bar, a sub-menu drops down to show commands. You can 
also customize the Menu bar; see Chapter 14 Customizing LibreOffice for more information.

• File – contains commands that apply to the entire document; for example, Open, Save, 
Wizards, Export as PDF, Print, Digital Signatures, and Templates.

• Edit – contains commands for editing the document; for example, Undo, Copy, Paste, 
Track Changes, Find and Replace, Compare and Merge Documents.

• View – contains commands for modifying how the Calc user interface looks; for example, 
Toolbars, Grids, Column & Row Headers, Full Screen, Zoom.

• Insert – contains commands for inserting elements into a spreadsheet; for example, 
Pictures, Media, Objects, Formula Design, Frames, Special Characters, Charts, Functions, 
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Shapes, Pivot Tables, Named Ranges, Comments, Hyperlinks, Headers and Footers, Form
Controls.

• Format – contains commands for modifying the layout of a spreadsheet; for example, 
Cells, Page, Styles, Alignment, Merge Cells, Print Range, Conditional Formatting, 
Spreadsheet Themes, Image, Chart, Object.

• Styles – contains commands to apply standard styles to cell, group of cells or sheets 
contents.

• Sheet – contains the most often used commands for handling sheets, such as Insert and 
Delete Cells, Columns, Rows and Sheets, Sheets from File, Cell Reference Type, Link to 
External Data, as well as Comments and Fill cells.

• Data – contains commands for manipulating data in the spreadsheet; for example, Define 
Database Range, Sort, Filters, Statistics, Pivot Tables, Consolidate, Forms, Groups and 
Outlines.

• Tools – contains various functions to help you check and customize the spreadsheet; for 
example, Spelling, Share Document, Gallery, Macros, Goal Seek, Solver, Detective, 
Protect Sheet, XML Filter Settings, Extension Manager.

• Window – contains commands to open a New window or Close an open window.

• Help – contains links to the LibreOffice help system and other miscellaneous functions; for 
example, Help, License Information, User Guides, Check for Updates, Send Feedback, and
Donate.

Toolbars
The default setting when Calc opens is for the Standard and Formatting toolbars to be docked at 
the top of the workspace (Figure 1).

Calc toolbars can be either docked and fixed in place, or floating; you can move a toolbar into a 
more convenient position on the workspace. Docked toolbars can be undocked and either moved 
to different docked position on the workspace, or left as a floating toolbar. Toolbars that are floating
when opened can be docked into a fixed position on the workspace.

You can choose the single-toolbar alternative to the default double toolbar arrangement. It contains
the most-used commands. To activate it, enable View > Toolbars > Standard (Single Mode) and 
disable View > Toolbars > Standard and View > Toolbars > Formatting.

The default set of icons (sometimes called buttons) on toolbars provides a wide range of common 
commands and functions. You can also remove or add icons to toolbars; see Chapter 14 
Customizing LibreOffice for more information. When hovering the toolbar with the mouse, a tool tip 
shows the action performed by each icon in the toolbar.

Formula bar
The Formula Bar (Figure 2) is located at the top of the sheet in the Calc workspace. The Formula 
Bar is permanently docked in this position and cannot be used as a floating toolbar. If the Formula 
Bar is not visible, go to View on the Menu bar and select Formula Bar.

Figure 2: Formula bar

From left to right, the Formula Bar consists of the following:

• Name Box – gives the current active cell reference using a combination of a letter and 
number, for example A1. The letter indicates the column and the number indicates the row 
of the selected cell. If you have selected a range of cells that is also a named range, the 
name of the range is shown in this box. You can also type a cell reference in the Name Box 
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to jump to the referenced cell. If you type the name of a named range and press the Enter 
key, the named range is selected and displayed.

• Function Wizard  – opens a dialog from which you can search through a list of 
available functions. This can be very useful because it also shows how the functions are 
formatted.

• Sum  – clicking on the Sum icon totals the numbers in the cells above the selected cell 
and then places the total in the selected cell. If there are no numbers above the selected 
cell, then the cells to the left are totaled. When the Sum icon is used, Calc suggest the 
range to sum with a colored box, but does not insert the formula. You need to confirm the 
suggested range by typing Enter, or reject pressing Esc. You can also adjust the range with
the mouse by dragging the colored box or its edges to adjust the range. The icons  in 
the formula bar are equivalent to the Enter and Esc commands.

• Function  – clicking on the Function icon inserts an equals (=) sign into the selected cell 
and the Input line, allowing a formula to be entered. The Name box now displays the most 
frequently used functions, for a quick access to the function name and syntax.

• Input line – displays the contents of the selected cell (data, formula, or function) and allows
you to edit the cell contents. To turn the Input line into a multiline input area for very long 
formulas, click the drop down button on the right.

You can also edit the contents of a cell directly in the cell itself by double-clicking on the cell. When
you enter new data into a cell, the Sum and Function icons change to Cancel and Accept 
icons.

Note

In a spreadsheet the term “function” covers much more than just mathematical 
functions. See the Calc Guide Chapter 7 Using Formulas and Functions for more 
information.

Status bar
The Calc status bar (Figure 3) provides information about the spreadsheet as well as quick and 
convenient ways to change some of its features. Most of the fields are similar to those in other 
components of LibreOffice; see Chapter 1 Introducing LibreOffice in this guide and the Calc Guide 
Chapter 1 Introducing Calc for more information.

Figure 3: Calc status bar

The status bar has a quick way to do some math operations on selected cells in the spreadsheet. 
You can calculate average and sum, count elements, and more on the selection by right-clicking 
over the cell information area of the status bar and selecting the operations you want to display in 
the status bar (Figure 10).

Sidebar
The Calc Sidebar (View > Sidebar) is located on the right side of the window. It is a mixture of 
toolbar and dialog. It is similar to the sidebar in Writer (shown in Chapter 1 and Chapter 4 of this 
book) and consists of five decks: Properties, Styles, Gallery, Navigator, and Functions. Each deck 
has a corresponding icon on the Tab panel to the right of the sidebar, allowing you to switch 
between them. The decks are described below.
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• Properties: This deck includes five content panels.

– Styles: Access to the available cell styles, update cell styles, and new cell styles.

– Character: Controls for formatting the text, such as font family, size, and color. Some 
controls, such as superscript, only become active when the text cursor is active in the 
Input line of the Formula bar or the cell. 

– Number Format: Quickly change the format of numbers including decimals, currency, 
dates, or numeric text. Numerical and label field controls for Forms are also available.

– Alignment: Controls to align the text in various ways, including horizontal and vertical 
alignment, wrapping, indenting, merging, text orientation, and vertical stacking.

– Cell Appearance: Controls to set the appearance options, including cell background 
color, cell border formats including line color and style, and grid lines.

Each of these panels has a More Options button, which opens a dialog giving a greater 
number of options. These dialogs lock the document for editing until they are closed.

• Styles: This deck contains a single panel, which is the same as that opened by selecting 
the Styles button (F11) from the Text Formatting toolbar.

• Gallery: This deck contains a single panel, which is the same as that opened by selecting 
Gallery from the Standard toolbar or Tools > Gallery from the Menu bar.

• Navigator: This deck contains a single panel, which is essentially the same as the 
Navigator window opened by clicking the Navigator button on the Standard toolbar or 
selecting View > Navigator (F5) from the Menu bar. Only the Contents button is absent in 
the Sidebar’s Navigator panel.

• Functions: This deck contains a single panel, which is the same as the window opened by 
selecting Insert > Function... from the Menu bar.

To the right side of the title bar of each open deck is a Close button (X), which closes the deck to 
leave only the Tab bar open. Clicking on any Tab button reopens the deck.

To hide the Sidebar, or reveal it if already hidden, click on the edge Hide/Show button. To adjust 
the deck width, drag on the left edge of the sidebar.

Spreadsheet layout

Individual cells
The main section of the workspace in Calc displays the cells in the form of a grid. Each cell is 
formed by the intersection of one column and one row in the spreadsheet.

At the top of the columns and the left end of the rows are a series of header boxes containing 
letters and numbers. The column headers use an alpha character starting at A and go on to the 
right. The row headers use a numerical character starting at 1 and go down.

These column and row headers form the cell references that appear in the Name Box on the 
Formula Bar (Figure 2). If the headers are not visible on the spreadsheet, go to View on the Menu 
bar and select Column & Row Headers.

Sheet tabs
In Calc, you can have more than one sheet in a spreadsheet. At the bottom of the grid of cells in a 
spreadsheet are sheet tabs indicating how many sheets there are in the spreadsheet. Clicking on a
tab enables access to each individual sheet and displays that sheet. An active sheet is indicated 
with a white tab (default Calc setup). You can also select multiple sheets by holding down the Ctrl 
key while clicking on the sheet tabs.
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To change the default name for a sheet (Sheet1, Sheet2, and so on), right-click on a sheet tab and 
select Rename Sheet from the context menu or double click on the sheet tab to open a dialog to 
let you type a new name for the sheet. Click OK when finished to close the dialog.

To change the color of a sheet tab, right-click on the tab and select Tab Color from the context 
menu to open the Tab Color dialog. Select a color and click OK when finished to close the dialog. 
To add new colors to this color palette, see Chapter 14 Customizing LibreOffice.

Opening a CSV file

Comma-separated-values (CSV) files are spreadsheet files in a text format where cell contents are
separated by a character, for example a comma or semicolon. Each line in a CSV text file 
represents a row in a spreadsheet. Text is entered between quotation marks; numbers are entered 
without quotation marks.

Note

Most CSV files come from databases tables, queries, or reports, where further 
calculations and charting are required. On Microsoft Windows, CSV files often have 
the XLS file name extension to look like an Excel file, but they are still CSV files 
internally.

To open a CSV file in Calc:

 1) Choose File > Open on the Menu bar and locate the CSV file that you want to open.

 2) Select the file and click Open. By default, a CSV file has the extension .csv. However, 
some CSV files may have a .txt extension.

 3) The Text Import dialog (Figure 5) opens. Here you can select the various options available 
when importing a CSV file into a Calc spreadsheet.

 4) Click OK to open and import the file.

Figure 4: Text Import dialog
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The options for importing CSV files into a Calc spreadsheet are as follows:

• Import

– Character Set – specifies the character set to be used in the imported file.

– Language – determines how the number strings are imported.

If Language is set to Default for CSV import, Calc will use the globally set language. If 
Language is set to a specific language, that language will be used when importing 
numbers.

– From Row – specifies the row where you want to start the import. The rows are visible 
in the preview window at the bottom of the dialog.

• Separator Options – specifies whether the data uses separators or fixed widths as 
delimiters.

– Fixed width – separates fixed-width data (equal number of characters) into columns. 
Click on the ruler in the preview window to set the width.

– Separated by – select the separator used in the data to delimit the data into columns. If 
you select Other, specify the character used to separate data into columns. This custom
separator must also be contained in the data.

– Merge delimiters – combines consecutive delimiters and removes blank data fields.

– Text delimiter – select a character to delimit text data.

• Other Options

– Quoted fields as text – when this option is enabled, fields or cells whose values are 
quoted in their entirety (the first and last characters of the value equal the text delimiter) 
are imported as text.

– Detect special numbers – when this option is enabled, Calc will automatically detect all 
number formats, including special number formats such as dates, time, and scientific 
notation. The selected language also influences how such special numbers are 
detected, since different languages and regions many have different conventions for 
such special numbers.

When this option is disabled, Calc will detect and convert only decimal numbers. The 
rest, including numbers formatted in scientific notation, will be imported as text. A 
decimal number string can have digits 0-9, thousands separators, and a decimal 
separator. Thousands separators and decimal separators may vary with the selected 
language and region.

• Fields – shows how the data will look when it is separated into columns.

– Column type – select a column in the preview window and select the data type to be 
applied the imported data.

– Standard – Calc determines the type of data.

– Text – imported data are treated as text.

– US English – numbers formatted in US English are searched for and included 
regardless of the system language. A number format is not applied. If there are no US 
English entries, the Standard format is applied.

– Hide – the data in the column are not imported.
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Saving spreadsheets

To save a spreadsheet, see Chapter 1 Introducing LibreOffice for more details on how to save files 
manually or automatically. Calc can also save spreadsheets in a range of formats and also export 
spreadsheets to PDF, HTML, XHTML file formats and JPEG and PNG images formats; see the 
Calc Guide Chapter 6 Printing, Exporting, and E-mailing for more information.

Saving in other spreadsheet formats
If you need to exchange files with users who are unable to receive spreadsheet files in Open 
Document Format (ODF) (*.ods), which Calc uses as default format, you can save a spreadsheet
in another format.

 1) Save the spreadsheet in Calc spreadsheet file format (*.ods).

 2) Select File > Save As on the Menu bar to open the Save As dialog (Figure 5).

 3) In File name, you can enter a new file name for the spreadsheet.

 4) In the File type drop-down menu, select the type of spreadsheet format you want to use.

 5) If Automatic file name extension is selected, the correct file extension for the 
spreadsheet format you have selected will be added to the file name.

 6) Click Save.

Figure 5: Save As dialog

 7) When saving in a non default file format, the Confirm File Format dialog opens (Figure 6). 
Click Use [xxx] Format to continue saving in your selected spreadsheet format or click 
Use ODF Format to save the spreadsheet in Calc ODS format.

Figure 6: File Format dialog
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 8) If you select Text CSV format (*.csv) for your spreadsheet, the Export Text File dialog 
(Figure 7) may open. Here you can select the character set, field delimiter, text delimiter, 
and so on to be used for the CSV file.

Figure 7: Export Text File dialog for CSV files

Tip

To have Calc save documents by default in a file format other than the default ODF 
format, go to Tools > Options > Load/Save > General. In Default file format and 
ODF settings > Document type, select Spreadsheet, then in Always save as, select
your preferred file format.

Exporting contents as image
If you want to send a fragment of your spreadsheet to a colleague, business partner or publish it in 
the internet, Calc can export a range selection or a selected group of shapes (images) to a PNG or
JPG graphics format:

 1) Select the range or the group of shapes in your spreadsheet.

 2) Select File – Export... to open the Export dialog.

 3) Enter a name for your image in the File name box.

 4) Select the graphics file format in the Type list

 5) Mark the Selection checkbox in the Export dialog.

 6) Click Export...

Navigating within spreadsheets

Calc provides many ways to navigate within a spreadsheet from cell to cell and sheet to sheet. You
can generally use the method you prefer.

Cell navigation
When a cell is selected or in focus, the cell borders are emphasized. When a group of cells is 
selected, the cell area is colored. The color of the cell border emphasis and the color of a group of 
selected cells depends on the operating system being used and how you have set up LibreOffice.

• Using the mouse – place the mouse pointer over the cell and click the left mouse button. 
To move the focus to another cell using the mouse, simply move the mouse pointer to the 
cell where you want the focus to be and click the left mouse button.

• Using a cell reference – highlight or delete the existing cell reference in the Name Box on 
the Formula Bar (Figure 2 on page 9). Type the new cell reference of the cell you want to 
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move to and press Enter key. Cell references are case-insensitive: for example, typing 
either a3 or A3 will move the focus to cell A3.

• Using the Navigator – press the F5 key to open the Navigator dialog (Figure 11) or click 
the Navigator button in the open Sidebar. Type the cell reference into the Column and Row
fields and press the Enter key.

Figure 8: Navigator in Calc

• Using the Enter key – pressing Enter moves the cell focus down in a column to the next 
row. Pressing Shift+Enter moves the focus up in a column to the previous row.

• Using the Tab key – pressing Tab moves the cell focus right in a row to the next column. 
Pressing Shift+Tab moves the focus to the left in a row to the previous column.

• Using the arrow keys – pressing the arrow keys on the keyboard moves the cell focus in 
the direction of the arrow pressed.

• Using Home, End, Page Up and Page Down

– Home moves the cell focus to the start of a row.

– End moves the cell focus to the last cell on the right in the row in the right-most column 
that contains data.

– Page Down moves the cell focus down one complete screen display.

– Page Up moves the cell focus up one complete screen display.

Sheet navigation
Each sheet in a spreadsheet is independent of the other sheets, though references can be linked 
from one sheet to another. There are three ways to navigate between sheets in a spreadsheet:

• Using the Navigator – when the Navigator is open (Figure 11), double-click on any of the 
listed sheets to select the sheet.

• Using the keyboard – use key combinations Ctrl+Page Down to move one sheet to the 
right and Ctrl+Page Up to move one sheet to the left.

• Using the mouse – click on one of the sheet tabs at the bottom of the spreadsheet to 
select that sheet.

If your spreadsheet contains a lot of sheets, then some of the sheet tabs may be hidden. If this is 
the case:

• Using the four buttons to the left of the sheet tabs can move the tabs into view (Figure 9).

• Right-clicking on any of the arrows opens a context menu where you can select a sheet 
(see Figure 10).
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Note

When you insert a new sheet into a spreadsheet, Calc automatically uses the next 
number in the numeric sequence as a name. Depending on which sheet is open when 
you insert a new sheet, and the insertion method you use, the new sheet may not be 
in its correct numerical position. It is recommended to rename sheets in a spreadsheet
to make them more recognizable.

Figure 9: Navigating sheet tabs

Figure 10: Right-click any arrow button

Keyboard navigation
To navigate a spreadsheet using the keyboard, pressing a key or a combination of keys. For a key 
combination, press more than one key at the same time. Table 1 lists the keys and key 
combinations you can use for spreadsheet navigation in Calc.

Table 1. Keyboard cell navigation

Keyboard 
shortcut

Cell navigation

→ Moves cell focus right one cell.

← Moves cell focus left one cell.

↑ Moves cell focus up one cell.

↓ Moves cell focus down one cell

Ctrl+→ Moves cell focus to the first column on the right containing data in that row if cell 
focus is on a blank cell.
Moves cell focus to the last column on the right in the same range of occupied cells
in that row if cell focus is on a cell containing data.
Moves cell focus to the last column on the right in the spreadsheet if there are no 
more cells containing data.
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Ctrl+← Moves cell focus to the last column on the left containing data in that row if cell 
focus is on a blank cell.
Moves cell focus to the first column on the left in the same range of occupied cells 
in that row if cell focus is on a cell containing data.
Moves cell focus to the first column in that row if there are no more cells containing
data.

Ctrl+↑ Moves cell focus from a blank cell to the first cell above containing data in the 
same column.
Moves cell focus to the first row in the same range of occupied cells if cell focus is 
on a cell containing data.
Moves cell focus from the last cell containing data to the cell in the same column in
the first row of the spreadsheet.

Ctrl+↓ Moves cell focus from a blank cell to the first cell below containing data in the 
same column.
Moves cell focus to the last row in the same range of occupied cells in that column 
if cell focus is on a cell containing data.
Moves cell focus from the last cell containing data to the cell in the same column in
the last row of the spreadsheet.

Ctrl+Home Moves cell focus from anywhere on the spreadsheet to Cell A1 on the same sheet.

Ctrl+End Moves cell focus from anywhere on the spreadsheet to the last cell in the lower 
right-hand corner of the rectangular area of cells containing data on the same 
sheet.

Alt+Page Down Moves cell focus one screen to the right (if possible).

Alt+Page Up Moves cell focus one screen to the left (if possible).

Ctrl+Page Down Moves cell focus to the cell on the next sheet to the right in sheet tabs where the 
focus was there before; if the spreadsheet has more than one sheet.

Ctrl+Page Up Moves cell focus to the cell on the next sheet to the left in sheet tabs where the 
focus was there before; if the spreadsheet has more than on sheet.

Tab Moves cell focus to the next cell on the right.

Shift+Tab Moves cell focus to the next cell on the left.

Enter Moves cell focus down one cell (unless changed by user). See the next topic.

Shift+Enter Moves cell focus up one cell (unless changed by user).

Customizing the Enter key
You can customize the direction in which the Enter key moves the cell focus by going to Tools > 
Options > LibreOffice Calc > General. Select the direction cell focus moves from the drop-down 
list. Depending on the file being used or the type of data being entered, setting a different direction 
can be useful. The Enter key can also be used to switch into and out of editing mode. Use the first 
two options under Input settings in Figure 11 to change the Enter key settings.

Figure 11: Customizing the Enter key
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Selecting items in a spreadsheet

Selecting cells

Single cell
Left-click in the cell. You can verify your selection by looking in the Name Box on the Formula Bar 
(Figure 2 on page 9).

Range of contiguous cells
A range of cells can be selected using the keyboard or the mouse.

To select a range of cells by dragging the mouse cursor:

 1) Click in a cell.

 2) Press and hold down the left mouse button.

 3) Move the mouse around the screen.

 4) Once the desired block of cells is highlighted, release the left mouse button.

To select a range of cells without dragging the mouse:

 1) Click in the cell which is to be one corner of the range of cells.

 2) Move the mouse to the opposite corner of the range of cells.

 3) Hold down the Shift key and click.

Tip

You can also select a contiguous range of cells by first clicking in the Selection mode 
field on the Status Bar (Figure 3 on page 10) and selecting Extending selection 
before clicking in the opposite corner of the range of cells. Make sure to change back 
to Standard selection or you may extend a cell selection unintentionally.

To select a range of cells without using the mouse:

 1) Select the cell that will be one of the corners in the range of cells.

 2) While holding down the Shift key, use the cursor arrows to select the rest of the range.

Tip

You can also directly select a range of cells using the Name Box. Click into the Name 
Box on the Formula Bar (Figure 2 on page 9). To select a range of cells, enter the cell 
reference for the upper left-hand cell, followed by a colon (:), and then the lower right-
hand cell reference. For example, to select the range that would go from A3 to C6, you
would enter A3:C6.

Range of non-contiguous cells
 1) Select the cell or range of cells using one of the methods above.

 2) Move the mouse pointer to the start of the next range or single cell.

 3) Hold down the Ctrl key and click or click-and-drag to select another range of cells to add to 
the first range.

 4) Repeat as necessary.
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Note:

Some Calc operations cannot be used with non-contiguous cells. For example, you 
cannot copy a non-contiguous range.

Selecting columns and rows

Single column or row
To select a single column, click on the column header (Figure 1 on page 8).

To select a single row, click on the row header.

Multiple columns or rows
To select multiple columns or rows that are contiguous:

 1) Click on the first column or row in the group.

 2) Hold down the Shift key.

 3) Click the last column or row in the group.

To select multiple columns or rows that are not contiguous:

 1) Click on the first column or row in the group.

 2) Hold down the Ctrl key.

 3) Click on all of the subsequent columns or rows while holding down the Ctrl key.

Entire sheet
To select the entire sheet, click on the corner box between the column header A and the row 
header 1 (Figure 12), or use the key combination Ctrl+A to select the entire sheet, or go to Edit on 
the Menu bar and select Select All.

Figure 12: Select All box

Selecting sheets
You can select one or multiple sheets in Calc. It can be advantageous to select multiple sheets, 
especially when you want to make changes to many sheets at once.

Single sheet
Click on the sheet tab for the sheet you want to select. The tab for the selected sheet becomes 
white (default Calc setup).

Multiple contiguous sheets
To select multiple contiguous sheets:

 1) Click on the sheet tab for the first desired sheet.

 2) Move the mouse pointer over the sheet tab for the last desired sheet.

 3) Hold down the Shift key and click on the sheet tab.

 4) All tabs between these two selections will turn white (default Calc setup). Any actions that 
you perform will now affect all highlighted sheets.
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Multiple non-contiguous sheets
To select multiple non-contiguous sheets:

 1) Click on the sheet tab for the first desired sheet.

 2) Move the mouse pointer over the sheet tab for the second desired sheet.

 3) Hold down the Ctrl key and click on the sheet tab.

 4) Repeat as necessary.

 5) The selected tabs will turn white (default Calc setup). Any actions that you perform will now 
affect all highlighted sheets.

All sheets
Right-click a sheet tab and choose Select All Sheets from the context menu.

Hiding and showing sheets
Sometimes you may want to hide the contents of a sheet to preserve data from accidental editing 
or because its contents are not important to display. To hide a sheet or many sheets, select the 
sheet or sheets as above, right-click to open the context menu, and select Hide Sheet. To show 
hidden sheets, right-click any sheet tab and select Show Sheet on the context menu. A dialog will 
appear with all hidden sheets listed. Click on the desired sheet and then click OK.

Tip

LibreOffice Calc does not let you hide the last visible sheet.

Working with columns and rows

Inserting columns and rows

Single column or row
Using the Sheet menu:

 1) Select a cell, column, or row where you want the new column or row inserted.

 2) Go to Sheet on the Menu bar and select either Insert > Columns > Columns Left or > 
Columns Right or Insert > Rows > Rows Above or > Rows Below.

Using the mouse:

 1) Select a column or row where you want the new column or row inserted.

 2) Right-click the column or row header.

 3) Select Insert Columns Left, Insert Columns Right, Insert Rows Above, or Insert Rows 
Below from the context menu.

Multiple columns or rows
Multiple columns or rows can be inserted at once rather than inserting them one at a time.

 1) Highlight the required number of columns or rows by holding down the left mouse button on
the first one and then dragging across the required number of identifiers.

 2) Proceed as for inserting a single column or row above.
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Deleting columns and rows

Single column or row
To delete a single column or row:

 1) Select a cell in the column or row you want to delete.

 2) Go to Sheet on the Menu bar and select Delete Cells or right-click and select Delete from 
the context menu.

 3) Select the option you require from the Delete Cells dialog (Figure 13).

Figure 13: Delete Cells dialog

Alternatively:

 1) Click in the column or header to select the column or row.

 2) Go to Sheet on the Menu bar and select Delete Cells or right-click and select Delete 
Columns or Delete Rows from the context menu.

Multiple columns or rows
To delete multiple columns or rows:

 1) Select the columns or rows, see “Multiple columns or rows” on page 20 for more 
information.

 2) Go to Sheet on the Menu bar and select Delete Cells, or right-click and select Delete 
Columns or Delete Rows from the context menu.

Working with sheets

Inserting new sheets

Click on the Add Sheet icon  on the bottom of the screen to insert a new sheet after the last 
sheet in the spreadsheet without opening the Insert Sheet dialog. The following methods open the
Insert Sheet dialog (Figure 14), where you can position the new sheet, create more than one 
sheet, name the new sheet, or select a sheet from a file.

 1) Select the sheet where you want to insert a new sheet, then go to Sheet > Insert Sheet... 
on the Menu bar.

 2) Right-click on the sheet tab where you want to insert a new sheet and select Insert Sheet 
from the context menu.

 3) Click in the empty space at the end of the sheet tabs.

 4) Right-click in the empty space at the end of the sheet tabs and select Insert Sheet from the
context menu.

You can insert several sheets by specifying the number of sheets to insert.
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Figure 14: Insert Sheet dialog

Moving and copying sheets
You can move or copy sheets within the same spreadsheet by dragging and dropping, or by using 
the Move/Copy Sheet dialog. To move or copy a sheet into a different spreadsheet, you have to 
use the Move/Copy Sheet dialog.

Dragging and dropping
To move a sheet to a different position within the same spreadsheet, click and hold on the sheet 
tab and drag it to its new position before releasing the mouse button.

To copy a sheet within the same spreadsheet, hold down the Ctrl key (Option key on Mac) then 
click on the sheet tab and drag it to its new position before releasing the mouse button. The mouse
pointer may change to include a plus sign depending on the setup of your operating system.

Using a dialog
Use the Move/Copy Sheet dialog (Figure 15) to specify exactly whether you want the sheet in the 
same or a different spreadsheet, its position within the spreadsheet, and the sheet name when you
move or copy the sheet.

 1) In the current document, right-click on the sheet tab you wish to move or copy and select 
Move/Copy Sheet from the context menu or go to Sheet > Move or Copy Sheet... on the 
Menu bar.

 2) Select Move to move the sheet or Copy to copy the sheet in the Action area.

 3) Select the spreadsheet where you want the sheet to be placed from the drop-down list in 
To document. This can be the same spreadsheet, another spreadsheet already open, or a 
new spreadsheet.

 4) Select the position in Insert before where you want to place the sheet.

 5) Type a name in the New name text box if you want to rename the sheet when it is moved 
or copied. If you do not enter a name, Calc creates a default name (Sheet 2, Sheet 3, and 
so on).

 6) Click OK to confirm the move or copy and close the dialog.

Caution

When you move or copy to another spreadsheet or a new spreadsheet, a conflict may 
occur with formulas linked to other sheets in the previous location.
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Figure 15: Move/Copy 
Sheet dialog

Deleting sheets
To delete a single sheet, right-click on the sheet tab you want to delete and select Delete Sheet 
from the context menu, or go to Sheet > Delete Sheet... on the Menu bar. Click Yes to confirm the 
deletion.

To delete multiple sheets, select the sheets (see “Selecting sheets” on page 20), then right-click 
one of the sheet tabs and select Delete Sheet from the context menu, or go to Sheet > Delete 
Sheet... from on the Menu bar. Click Yes to confirm the deletion.

Renaming sheets
By default, the name for each new sheet added is SheetX, where X is the number of the next sheet
to be added. While this works for a small spreadsheet with only a few sheets, it can become 
difficult to identify sheets when a spreadsheet contains many sheets.

You can rename a sheet using one of the following methods:

• Enter the name in the Name text box when you create the sheet using the Insert Sheet 
dialog (Figure 15 on page 24).

• Right-click on a sheet tab and select Rename Sheet from the context menu to replace the 
existing name with a different one.

• Double-click on a sheet tab to open the Rename Sheet dialog.

Note

Sheet names must start with either a letter or a number; other characters, including 
spaces, are not allowed. Apart from the first character of the sheet name, permitted 
characters are letters, numbers, spaces, and the underscore character. Attempting to 
rename a sheet with an invalid name will produce an error message.

Viewing Calc

Changing document view
Use the zoom function to show more or fewer cells in the window when you are working on a 
spreadsheet. For more about zoom, see Chapter 1 Introducing LibreOffice in this guide.
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Freezing rows and columns
Freezing locks a number of rows at the top of a spreadsheet or a number of columns on the left of 
a spreadsheet or both rows and columns. Then, when moving around within a sheet, the cells in 
frozen rows and columns always remain in view.

Figure 16 shows some frozen rows and columns. The heavier horizontal line between rows 3 and 
23 and the heavier vertical line between columns F and Q indicate that rows 1 to 3 and columns A 
to F are frozen. The rows between 3 and 23 and the columns between F and Q have been scrolled
off the page.

Figure 16: Frozen rows and columns

Freezing rows or columns
 1) Click into the cell that is immediately below the rows you want to freeze and immediately to 

the right of the columns you want frozen.

 2) Click on the Freeze Rows and Columns icon in the main toolbar or go to View on the
Menu bar and select Freeze Cells > Freeze Rows and Columns. A heavier line appears 
between the rows or columns indicating where the freeze has been placed.

Unfreezing
To unfreeze rows or columns, either go to View on the Menu bar and select Freeze Cells > Freeze
Rows and Columns or click on the Freeze Rows and Columns icon in the main toolbar. The 
heavier lines indicating freezing will disappear.

Splitting the screen
Another way to change the view is by splitting the screen your spreadsheet is displayed in (also 
known as splitting the window). The screen can be split horizontally, vertically, or both, giving you 
up to four portions of the spreadsheet in view at any one time. An example of splitting the screen is
shown in Figure 17 where a split is indicated by additional window borders within the sheet.

Why would you want to do this? For example, consider a large spreadsheet in which one cell 
contains a number that is used by three formulas in other cells. Using the split-screen technique, 
you can position the cell containing the number in one section and each of the cells with formulas 
in the other sections. You can then change the number in one cell and watch how it affects each of 
the formulas.

Figure 17: Split screen example
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Splitting horizontally or vertically
 1) Click on the row header below the rows where you want to split the screen horizontally or 

click on the column header to the right of the columns where you want to split the screen 
vertically.

 2) Go to View on the Menu bar and select Split Window. Window borders appear between 
the rows or columns indicating where the split has been placed, as shown in Figure 18.

Alternatively:

• For a horizontal split, drag the new horizontal window border beneath the row where you 
want the horizontal split positioned.

• For a vertical split, drag the new vertical window border across to the right of the column 
where you want the vertical split positioned.

Figure 18: Split screen window borders

Removing split views
To remove a split view, do one of the following:

• Drag the split window borders back to their places at the ends of the scroll bars.

• Go to View on the Menu bar and deselect Split Window.

Using the keyboard

Most data entry in Calc can be accomplished using the keyboard.

Numbers
Click in the cell and type in a number using the number keys on either the main keyboard or 
numeric keypad. By default, numbers are right aligned in a cell.

Minus numbers
To enter a negative number, either type a minus (–) sign in front of the number or enclose the 
number in parentheses (), for example (1234). The result for both methods of entry will be the 
same, for example -1234.

Leading zeroes
To retain a minimum number of integer characters in a cell when entering numbers in order to 
retain the number format, for example 1234 and 0012, leading zeros have to be added using one 
of the following methods.
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Method 1

 1) With the cell selected, right-click on the cell, select Format Cells from the context menu or 
go to Format > Cells on the Menu bar or use the keyboard shortcut Ctrl+1 to open the 
Format Cells dialog (Figure 19).

 2) Make sure the Numbers tab is selected then select Number in the Category list.

 3) In Options > Leading Zeros, enter the minimum number of characters required. For 
example, for four characters, enter 4. Any number less than four characters will have 
leading zeros added, for example 12 becomes 0012.

 4) Click OK. The number entered retains its number format and any formula used in the 
spreadsheet will treat the entry as a number in formula functions.

Figure 19: Format Cells dialog – Numbers page

Method 2

 1) Select the cell.

 2) Open the Sidebar (View > Sidebar) and click the Open Panel (+) icon on the Number 
Format panel to open it.

 3) Select Number in the Category list box.

 4) Set the Leading zeroes value box to 4. Formatting is applied immediately.

Figure 20: Set Leading zeroes

If a number is entered with leading zeroes, for example 01481, without first setting the Leading 
zeros parameter, then by default Calc will automatically drop the leading 0. To preserve leading 
zeros in a number:

 1) Type an apostrophe (') before the number, for example '01481.
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 2) Move the cell focus to another cell. The apostrophe is automatically removed, the leading 
zeros are retained and the number is converted to text left aligned.

Numbers as text
Numbers can also be entered as text using one of the following methods.

Method 1
 1) With the cell selected, right-click on the cell and select Format Cells from the context menu

or go to Format > Cells on the Menu bar or use the keyboard shortcut Ctrl+1 to open the 
Format Cells dialog (Figure 19).

 2) Make sure the Numbers page is selected, then select Text from the Category list.

 3) Click OK and the number, when entered, is converted to text and, by default, left aligned.

Method 2
 1) Select the cell.

 2) Open the Sidebar (View > Sidebar) and click the Open Panel (+) icon on the Number 
Format panel.

 3) Select Text in the Category list box. Formatting is applied to the cell immediately.

 4) Click back on the cell. Enter the number and move focus from the cell to have the data 
formatted.

Note

By default, any numbers that have been formatted as text in a spreadsheet will be 
treated as a zero by any formulas used in the spreadsheet. Formula functions will 
ignore text entries. You can change this feature in Tools – Options – LibreOffice – 
Calc – Formula, in Detailed Calculation Settings, select Custom (conversion of 
text to numbers and more) and then select the proper treatment in the Convert from
text to numbers drop down list.

Text
Click in the cell and type the text. By default, text is left-aligned in a cell.

Date and time
Select the cell and type the date or time.

You can separate the date elements with a slash (/) or a hyphen (–) or use text, for example 10 Oct
2012. The date format automatically changes to the selected format used by Calc.

When entering a time, separate time elements with colons, for example 10:43:45. The time format 
automatically changes to the selected format used by Calc.

To change the date or time format used by Calc, use one of the following methods.

Method 1
 1) With the cell selected, right-click on the cell and select Format Cells from the context 

menu, or go to Format > Cells on the Menu bar, or use the keyboard shortcut Ctrl+1, to 
open the Format Cells dialog (Figure 19).

 2) Make sure the Numbers page is selected, then select Date or Time from the Category list.

 3) Select the date or time format you want to use from the Format list. Click OK.

Method 2
 1) With the cell selected, open the Sidebar (View > Sidebar) and (if necessary) click the 

Open Panel (+) icon on the Number Format panel.

 2) Select Date in the Category list box.
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 3) Click the More Options button in the panel title bar to open the Format Cells dialog.

 4) Select the date or time format you want to use from the Format list. Click OK.

AutoCorrection options
Calc automatically applies many changes during data input using autocorrection, unless you have 
deactivated any autocorrect changes. You can also undo any autocorrection changes by using the 
keyboard shortcut Ctrl+Z or manually by going back to the change and replacing the autocorrection
with what you want to actually see.

To change the autocorrect options, go to Tools > AutoCorrect Options on the Menu bar to open 
the AutoCorrect dialog (Figure 21).

Replace
Edits the replacement table for automatically correcting or replacing words or abbreviations in the 
document.

Exceptions
Specify the abbreviations or letter combinations that you do not want LibreOffice to correct 
automatically.

Options
Select the options for automatically correcting errors as you type and then click OK.

Localized options
Specify the AutoCorrect options for quotation marks and for options that are specific to the 
language of the text.

Reset
Resets modified values back to the LibreOffice default values.

Figure 21: AutoCorrect dialog

Deactivating automatic changes
Some AutoCorrect settings are applied when you press the spacebar after you enter data. To turn 
off or on Calc AutoCorrect, go to Tools on the Menu bar and deselect or select AutoInput.
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Speeding up data entry

Entering data into a spreadsheet can be very labor-intensive, but Calc provides several tools for 
removing some of the drudgery from input.

The most basic ability is to drag and drop the contents of one cell to another with a mouse. Many 
people also find AutoInput helpful. Calc also includes several other tools for automating input, 
especially of repetitive material. They include the fill tool, selection lists, and the ability to input 
information into multiple sheets of the same document.

Using the Fill tool
The Calc Fill tool is used to duplicate existing content or create a series in a range of cells in your 
spreadsheet (Figure 22).

 1) Select the cell containing the contents you want to copy or start the series from.

 2) Drag the mouse in any direction or hold down the Shift key and click in the last cell you 
want to fill.

 3) Go to Sheet > Fill Cells on the Menu bar and select the direction in which you want to copy
or create data (Up, Down, Left or Right) or Series and Random Number... from the 
submenu.

Alternatively, you can use a shortcut to fill cells.

 1) Select the cell containing the contents you want to copy or start the series from.

 2) Move the cursor over the small square in the bottom right corner of the selected cell. The 
cursor will change shape.

 3) Click and drag in the direction you want the cells to be filled. If the original cell contained 
text, then the text will automatically be copied. If the original cell contained a number, a 
series will be created.

Figure 22: Using the Fill tool

Using a fill series
When you select a series fill from Sheet > Fill Cells > Series..., the Fill Series dialog (Figure 23) 
opens. Here you can select the type of series you want.

30 | Speeding up data entry



Figure 23: Fill Series dialog

• Direction – determines the direction of series creation.

– Down – creates a downward series in the selected cell range for the column using the 
defined increment to the end value.

– Right – creates a series running from left to right within the selected cell range using the
defined increment to the end value.

– Up – creates an upward series in the cell range of the column using the defined 
increment to the end value.

– Left – creates a series running from right to left in the selected cell range using the 
defined increment to the end value.

• Series Type – defines the series type.

– Linear – creates a linear number series using the defined increment and end value.

– Growth – creates a growth series using the defined increment and end value.

– Date – creates a date series using the defined increment and end date.

– AutoFill – forms a series directly in the sheet. The AutoFill function takes account of 
customized lists. For example, by entering January in the first cell, the series is 
completed using the list defined in Tools > Options > LibreOffice Calc > Sort Lists. 
AutoFill tries to complete a value series by using a defined pattern. For example, a 
numerical series using 1,3,5 is automatically completed with 7,9,11,13; a date and time 
series using 01.01.99 and 15.01.99, an interval of fourteen days is used.

• Unit of Time – in this area you specify the desired unit of time. This area is only active if 
the Date option has been chosen in the Series type area.

– Day – use the Date series type and this option to create a series using seven days.

– Weekday – use the Date series type and this option to create a series of five day sets.

– Month – use the Date series type and this option to form a series from the names or 
abbreviations of the months.

– Year – use the Date series type and this option to create a series of years.

• Start Value – determines the start value for the series. Use numbers, dates or times.

• End Value – determines the end value for the series. Use numbers, dates or times.

• Increment – determines the value by which the series of the selected type increases by 
each step. Entries can only be made if the linear, growth or date series types have been 
selected.
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Figure 24: Sort Lists dialog

Defining a fill series
To define your own fill series:

 1) Go to Tools > Options > LibreOffice Calc > Sort Lists to open the Sort Lists dialog 
(Figure 24). This dialog shows the previously-defined series in the Lists box on the left and 
the contents of the highlighted list in the Entries box.

 2) Click New and the Entries box is cleared.

 3) Type the series for the new list in the Entries box (one entry per line).

 4) Click Add and the new list will now appear in the Lists box.

 5) Click OK to save the new list.

Defining a fill series from a range in a sheet
You can define a range of text values as a fill series.

 1) Select the range containing the text values that you want to use as a fill series.

 2) Go to Tools > Options > LibreOffice Calc > Sort Lists to open the Sort List dialog (Figure
24).

 3) The selected range is in the box Copy list from. Click Copy to add the range to the sort 
list.

Using selection lists
Selection lists are available only for text and are limited to using only text that has already been 
entered in the same column.

 1) Select a blank cell in a column that contains cells with text entries.

 2) Right-click and select Selection Lists from the context menu. A drop-down list appears 
listing any cell in the same column that either has at least one text character or whose 
format is defined as text.

 3) Click on the text entry you require and it is entered into the selected cell.
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Sharing content between sheets

You might want to enter the same information in the same cell on multiple sheets, for example to 
set up standard listings for a group of individuals or organizations. Instead of entering the list on 
each sheet individually, you can enter the information in several sheets at the same time.

 1) Go to Edit > Select > Select Sheets... on the Menu bar to open the Select Sheets dialog.

Figure 25: Select 
Sheets dialog

 2) Select the individual sheets where you want the information to be repeated. Use the Shift 
and Ctrl (Options on Mac) keys to select multiple sheets.

 3) Click OK to select the sheets and the sheet tabs will change color.

 4) Enter the information in the cells on the first sheet where you want it to appear and it will be
repeated in all the selected sheets.

Note

This technique automatically overwrites, without any warning, any information that is 
already in the cells on the selected sheets. Make sure you deselect the additional 
sheets when you are finished entering information that is going to be repeated before 
continuing to enter data into your spreadsheet.

Validating cell contents

When creating spreadsheets for other people to use, validating cell contents ensures that they 
enter data that is valid and appropriate for the cell. You can also use validation in your own work as
a guide to entering data that is either complex or rarely used.

Fill series and selection lists can handle some types of data, but are limited to predefined 
information. To validate new data entered by a user, select a cell and go to Data > Validity on the 
Menu bar to define the type of contents that can be entered in that cell. For example, a cell may 
require a date or a whole number with no alphabetic characters or decimal points, or a cell may not
be left empty.

Depending on how validation is set up, validation can also define the range of contents that can be 
entered, provide help messages explaining the content rules set up for the cell and what users 
should do when they enter invalid content. You can also set the cell to refuse invalid content, 
accept it with a warning, or start a macro when an error is entered. See the Calc Guide Chapter 2 
Entering, Editing, and Formatting Data for more information on validating cell contents.
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Editing data

Deleting data

Deleting data only
Data can be deleted from a cell without deleting any of the cell formatting. Click in the cell to select 
it and then press the Delete key.

Deleting data and formatting
Data and cell formatting can be deleted from a cell at the same time.

 1) Click in the cell to select it.

 2) Press the Backspace key, or right-click in the cell and select Delete Contents from the 
context menu, or go to Edit > Delete Contents) on the Menu bar to open the Delete 
Contents dialog (Figure 27). Here you can delete the different aspects of the data in the 
cell or to delete everything in the cell.

Figure 26: Delete 
Contents dialog

Replacing data
To completely replace data in a cell and insert new data, select the cell and type in the new data. 
The new data will replace the data already contained in the cell but will retain the original 
formatting used in the cell.

Alternatively, select the cell and click in the Input Line on the Formula Bar (Figure 2 on page 9), 
then double-click on the data to highlight it completely and type the new data.

Changing data
Sometimes it is necessary to edit the contents of cell without removing all of the data from the cell. 
For example, changing the phrase “Sales in Qtr. 2” to “Sales rose in Qtr” can be done as follows.

Using the keyboard
 1) Click in the cell to select it.

 2) Press the F2 key and the cursor is placed at the end of the cell.

 3) Use the keyboard arrow keys to reposition the cursor where you want to start entering the 
new data in the cell.

 4) When you have finished, press the Enter key and your editing changes are saved.

Using the mouse
 1) Double-click on the cell to select it and place the cursor in the cell for editing.

 2) Either:

• Reposition the cursor to where you want to start entering the new data in the cell.
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• Single-click to select the cell.

• Move the cursor to the Input Line on the Formula Bar (Figure 2 on page 9) and click at 
the position where you want to start entering the new data in the cell.

 3) When you have finished, click away from the cell to deselect it and your editing changes 
are saved.

Formatting data

Note

All the settings discussed in this section can also be set as a part of the cell style. See 
the Calc Guide Chapter 4 Using Styles and Templates in Calc for more information.

Multiple lines of text
Multiple lines of text can be entered into a single cell using automatic wrapping or manual line 
breaks. Each method is useful for different situations.

Automatic wrapping
To automatically wrap multiple lines of text in a cell, use one of the following methods.

Method 1
 1) Right-click on the cell and select Format Cells from the context menu, or go to Format > 

Cells on the Menu bar, or press Ctrl+1, to open the Format Cells dialog.

 2) Click on the Alignment tab (Figure 27).

 3) Under Properties, select Wrap text automatically and click OK.

Figure 27: Format Cells dialog – Alignment page

Method 2
 1) Select the cell.

 2) Open the Sidebar (View > Sidebar) and click the Open Panel (+) icon on the Alignment 
panel.

 3) Select the Wrap text option to apply the formatting immediately.
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Figure 28: Wrap text formatting

Manual line breaks
To insert a manual line break while typing in a cell, press Ctrl+Enter. When editing text, double-
click the cell, then reposition the cursor to where you want the line break. In the input line of the 
formula bar, press Shift+Enter.

When a manual line break is entered in a cell, the cell row height changes to display all the lines in 
the cell.

Shrinking text to fit the cell
The font size of the data in a cell can automatically adjust to fit inside cell borders. To do this, 
select the Shrink to fit cell size option under Properties in the Format Cells dialog (Figure 27) on 
the Alignment page. This dialog is also available by clicking the More Options button in the 
Character title bar of the Properties deck on the opened Sidebar, with text in the cell selected.

Formatting numbers
Several different number formats can be applied to cells by using icons on the Formatting toolbar 
(highlighted in Figure 29). Select the cell, then click the relevant icon to change the number format.

Figure 29: Number icons on Formatting toolbar

For more control or to select other number formats, use the Numbers page of the Format Cells 
dialog (Figure 20 on page 27):

• Apply any of the data types in the Category list to the data.

• Control the number of decimal places and leading zeros in Options.

• Enter a custom format code.

• The Language setting controls the local settings for the different formats such as the date 
format and currency symbol.

Some number formats are available from the Sidebar’s Number Format panel in the Properties 
deck. Click the More Options button to open the Format Cells dialog described above.

Formatting fonts and text in cells
To quickly select a font and format text for use in a cell:

 1) Select the cell.

 2) Click the small triangle on the right of the Font Name box on the Formatting toolbar 
(highlighted in Figure 30) and select a font from the drop-down list.
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 3) Click on the small triangle on the right of the Font Size on the Formatting toolbar and select 
a font size from the drop down list.

Figure 30: Font Name and Size on Formatting toolbar

 4) To change the character format, click on the Bold, Italic, or Underline icons.

 5) To change the horizontal paragraph alignment, click on one of the four alignment icons 

(Left, Center, Right, Justified) . For more options go to menu Format – 
Cells – Alignment, and select one of the options in the Horizontal drop down list.

 6) To change the vertical alignment of the text in the cell, go to menu Format – Cells – 
Alignment and select one of the options in the Vertical drop down list.

 7) To change the font color, click the arrow next to the Font Color icon  to display the color 
palette, then select the desired color.

 8) The Format menu also contains a quick access to direct text formatting in cells (Figure 31).

Figure 31: Direct formatting through Format menu

The Properties deck of the Sidebar has five panels, Styles, Character, Number Format, 
Alignment and Cell Appearance, which between them contain all the formatting controls from the 
Formatting toolbar and more.

To specify the language used in the cell, open the Font page on the Format Cells dialog. You can 
also select the More Options button on the Character panel of the Sidebar to open the Format 
Cells dialog. Changing language in a cell allows different languages to be used within the same 
document.

Use the Font Effects tab on the Format Cells dialog to set other font characteristics. See the Calc 
Guide Chapter 4 Using Styles and Templates in Calc for more information.
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Formatting cell borders

To format the borders of a cell or a group of selected cells, click on the Borders icon  on the 
Formatting toolbar, and select one of the border options displayed in the palette.

To format the border line style, click on the line style icon  and select the type from the palette. 
For the color of the borders lines of a cell, select the Border Color icon. A color palette is displayed.

The Cell Appearance panel of the Properties deck in the Sidebar contains Cell border, Line 
style and Line color controls.

For more control, including the spacing between cell borders and any data in the cell, use the 
Borders page of the Format Cells dialog (Figure 20 on page 27), where you can also define a 
shadow style. Clicking the More Options button on the Cell Appearance title bar, or clicking More
in the panel’s line style drop-down list, opens the Format Cells dialog at the Borders page. 

See the Calc Guide Chapter 4 Using Styles and Templates in Calc for more information.

Note

Cell border properties apply only to the selected cells and can be changed only when 
you are editing those cells. For example, if cell C3 has a top border, that border can 
only be removed by selecting C3. It cannot be removed in C2 despite also appearing 
to be the bottom border for cell C2.

Formatting cell background
To format the background color for a cell or a group of cells, click the small arrow next to the 

Background Color icon  on the Formatting toolbar. A color palette, similar to the Font Color 
palette, is displayed. You can also use the Background tab of the Format Cells dialog (Figure 20 on
page 27). The Cell Appearance panel of the Properties deck in the Sidebar contains a Cell 
background control with a color palette. See the Calc Guide Chapter 4 Using Styles and 
Templates in Calc for more information.

Formatting default cell styles
To add default styles for a cell or a group of cells, click Format > Styles. A menu displays the 
default styles. The default styles can be applied, deleted, or modified through the Styles and 
Formatting deck. You can create and use custom default cell styles for a cell by clicking Format > 
Styles > New Styles… Enter in a new name for the style or click an existing style name to update 
that style. Apply, delete, or modify the custom default style in the Styles and Formatting deck. 

AutoFormatting of cells

Using AutoFormat
You can use Calc’s AutoFormat feature to format a table (range of cells) quickly and easily. It also 
let you format different tables of the sheet with the same look and feel very easily. All formatting 
applied are direct formatting.

 1) Select the cells in at least three columns and rows, including column and row headers, that 
you want to format.

 2) Go to Format > AutoFormat Styles on the Menu bar to open the AutoFormat dialog 
(Figure 32).

 3) Select the type of format and format color from the list.
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 4) Select the formatting properties to be included in the AutoFormat function. When selecting 
or deselecting a formatting property, the AutoFormat dialog displays the change instantly.

 5) Click OK.

Figure 32: AutoFormat dialog

Defining a new AutoFormat
You can define a new AutoFormat so that it becomes available for use in all spreadsheets.

 1) Format the data type, font, font size, cell borders, cell background, and so on for a range of 
cells.

 2) Select the range.

 3) Go to Format > AutoFormat to open the AutoFormat dialog. The Add button is now active.

 4) Click Add.

 5) In the Name box of the Add AutoFormat dialog that opens, type a meaningful name for the 
new format.

 6) Click OK to save. The new AutoFormat is now available in the Format list in the AutoFormat
dialog.

Note

The new AutoFormat is stored in your computer user profile and is not available to 
other users. However, other users can import the new AutoFormat selecting the table 
range in the spreadsheet document and defining it as new AutoFormat.

Using themes

Calc comes with a predefined set of formatting themes (set of styles) that you can apply to your 
spreadsheet. While It is not possible to add new themes in Calc, you can modify the theme styles 
once the theme is applied to the spreadsheet. The modified styles become available for use in the 
whole spreadsheet.

To apply a theme to a spreadsheet:

 1) Click the Choose Themes icon  in the Tools toolbar. If this toolbar is not visible, go to 
View > Toolbars on the Menu bar and select Tools, and the Theme Selection dialog 
(Figure 33) opens. This dialog lists the available themes for the whole spreadsheet.

 2) Select the theme that you want to apply. As soon as you select a theme, the theme styles 
are applied to the spreadsheet and are immediately visible.

 3) Click OK.
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 4) If you wish, you can now open the Styles window to modify specific styles. These changes 
do not modify the theme; they only change the appearance of the style in the specific 
spreadsheet you are creating.

Caution

Applying a new theme over an existing one will override all existing theme styles 
customization with the new theme styles.

Figure 33: Theme Selection dialog

The applied spreadsheet themes works with cell styles. Some themes even change the Default cell
style. A new set of styles, including one named Card is added to your document. Figure 34 shows 
the styles added by the Pastel theme.

Figure 34: Cell styles of 
theme "Pastel"
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Using conditional formatting

You can set up cell formats to change depending on conditions that you specify. For example, in a 
table of numbers, you can show all the values above the average in green and all those below the 
average in red. Multiple formatting options can be entered and arranged using assigned priority 
rules to order the importance of the conditions, allowing certain formatting options to take place 
before others, for example.

Conditional formatting depends upon the use of styles and the AutoCalculate feature must be 
enabled. Go to Tools > Cell Contents > AutoCalculate on the Menu bar to enable this feature. 
See the Calc Guide Chapter 2 Entering, Editing, and Formatting Data for more information.

Hiding and showing data

In Calc you can hide elements so that they are neither visible on a computer display nor printed 
when a spreadsheet is printed. However, hidden elements can still be selected for copying if you 
select the elements around them. For example, if column B is hidden, it is copied when you select 
columns A and C.

For more information on how to hide and show data, including how to use outline groups and 
filtering, see the Calc Guide Chapter 2 Entering, Editing, and Formatting Data.

Note

When data in cells are hidden, the blank cells remain visible in the spreadsheet.

Hiding data
To hide sheets, select them, then go to Sheet > Hide Sheets on the Menu bar, or right-click and 
choose Hide Sheets on the context menu. You cannot hide all the sheets in a spreadsheet; at 
least one sheet must remain visible.

To hide rows or columns:

 1) Select the row or column you want to hide.

 2) Go to Format on the Menu bar and select Rows or Columns.

 3) Select Hide from the submenu and the row or column can no longer viewed or printed.

Alternatively, right-click on the row header or column header and select Hide Rows or Hide 
Columns from the context menu.

Showing data
To show hidden sheets, rows, and columns:

 1) Select the sheets, rows or columns each side of the hidden sheet, row or column.

 2) Go to Format on the Menu bar and select Sheet, Row or Column.

 3) Select Show from the menu and the sheet, row or column will be displayed and can be 
printed.

Alternatively, right-click on the sheet tabs, row headers or column headers and select Show from 
the context menu.

Note

If the first column (A) or first row (1) is hidden, you must select the whole sheet to 
access the show command for this row or column.
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Cell protection

All or some of the cells in a spreadsheet can be password protected to prevent changes being 
made by unauthorized users. This can be handy when multiple people have access to the 
spreadsheet itself, but for various reasons only a few can be allowed to modify the data it contains.

By default, all cells will be flagged as Protected (Figure 36).

Before protecting the sheet, you may wish to select certain cells that will be unprotected that can 
be changed by any users without the password.

To do this:

 1) Using any of the methods previously discussed, select the cells that you wish to unprotect.

 2) Open the Format Cells dialog by right-clicking and selecting Format Cells or by selecting 
Format > Cells from the Menu bar.

 3) From the Cell Protection tab of the Format Cells dialog, the Protected status of individual or
groups of cells can be toggled on or off.

In the Cell Protection tab of the Format Cells dialog is also the option to Hide all data contained in 
protected cells.

To toggle the hidden status of protected cells:

 1) Go to Tools > Protect Sheet.

 2) Enter the password to unprotect the sheet and click OK.

 3) Go to Format > Cells on the Menu bar, or right-click and select Format Cells from the 
context menu, or use the keyboard shortcut Ctrl+1 to open the Format Cells dialog.

 4) Click the Cell Protection tab (Figure 35) and deselect the hide options for the cells.

 5) Click OK.

Figure 35: Cell Protection page in Format Cells dialog

When all desired cells have been flagged with either a protected or unprotected status:

 1) Go to Tools > Protect Sheet. The Protect Sheet dialog will open (Figure 36).

 2) Select Protect this sheet and the contents of protected cells.

 3) Type a password and then confirm the password.

 4) Select or deselect the user selection options for cells.

 5) Click OK.

Any cells that had been toggled as protected will no longer be editable by anyone that does not 
have the password.
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Figure 36: Protect Sheet dialog

Alternatively, you can choose to protect the entire spreadsheet rather than individual cells on 
individual sheets by selecting Tools > Protect Spreadsheet from the Menu bar. The protected 
sheets has a lock icon in its tab, as shown in Figure 37.

Figure 37: The lock icon in
a protected sheet

Sorting records

Sorting within Calc arranges the cells in a sheet using the sort criteria that you specify. Several 
criteria can be used and a sort applies each criteria consecutively. Sorts are useful when you are 
searching for a particular item and become even more useful after you have filtered data.

Also, sorting is useful when you add new information to your spreadsheet. When a spreadsheet is 
long, it is usually easier to add new information at the bottom of the sheet, rather than adding rows 
in their correct place. After you have added information, you then carry out a sort to update the 
spreadsheet.

For more information on how to sort records and the sorting options available, see the Calc Guide 
Chapter 2 Entering, Editing, and Formatting Data.

Figure 38: Sort Criteria dialog
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To sort cells in a spreadsheet:

 1) Select the cells to be sorted.

 2) Go to Data > Sort on the Menu bar to open the Sort dialog (Figure 38).

 3) Select the sort criteria from the drop down lists. The selected lists are populated from the 
selected cells.

 4) Select either ascending order (A-Z, 1-9) or descending order (Z-A, 9-1).

 5) Click OK and the sort is carried out on your spreadsheet.

Cell comments

Comments are small notes and text that can serve as a reminder or an aside to the user. A 
comment is not considered a part of the spreadsheet for calculation or printing purposes, and will 
only appear when hovering the mouse over the particular cell that has been ‘commented’.

The easiest way to insert a comment is by right-clicking on the desired cell and selecting Insert 
Comment from the Context Menu that appears. Alternatively, a comment can be inserted by 
selecting Insert > Comment from the Menu bar, by pressing the keyboard shortcut (Ctrl+Alt+C), or
by clicking the icon in the Standard Toolbar.

By default, comments will remain hidden and only appear when hovering the mouse. Cells that 
contain comments are marked with a red square in the upper right corner. To toggle the visibility of 
comments, select View > Comments from the Menu bar.

Using formulas and functions

You may need more than numbers and text on your spreadsheet. Often the contents of one cell 
depend on the contents of other cells. Formulas are equations that use numbers and variables to 
produce a result. Variables are placed in cells to hold data required by equations.

A function is a predefined calculation entered in a cell to help you analyze or manipulate data. All 
you have to do is enter the arguments and the calculation is made automatically. Functions help 
you create the formulas required to get the results that you are looking for.

The Function Wizard and Function Search
Functions and formulas can be entered directly into the formula bar or by accessing the function 
wizard. To launch the function wizard, click the Function Wizard icon to the right of the Name box.

Inside the function wizard, you can search, list, and narrow down the many Calc functions 
available. You can also choose to complete functions from within the wizard rather than having to 
type full formulas into the formula bar.

Each function, when selected, will display a brief explanation of its use and acceptable syntax. It 
will also display dialog boxes where you can enter the information required by that function and a 
result window showing the expected calculation from the data entered.

Note

A fast alternative to the function wizard, the Calc Sidebar contains a Functions tab 
which allows you to quickly list and narrow down functions and provides brief 
explanations on their use and syntax, but does not provide the search or data entry 
functionalities of the full wizard.

For a more in-depth introduction to formulas and the function wizard, see the Calc Guide Chapter 
7 Formulas and Functions.
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Figure 39: Function Wizard with Search Bar

Analyzing data

Calc includes several tools to help you analyze the information in your spreadsheets, ranging from 
features for copying and reusing data, to creating subtotals automatically, to varying information to 
help you find the answers you need. These tools are divided between the Tools and Data menus.

Calc also includes many tools for statistical analysis of data, where you can obtain important 
numerical information on data obtained from physical measurements, polls, or even business 
transactions such as sales, stock quotations, and so on. These statistical data analyses are 
available in the menu Data > Statistics.

See the Calc Guide Chapter 9 Data Analysis for more information on the tools available in Calc to 
analyze your data.

Pivot tables and pivot charts

One of the most useful tools for analyzing data is the Pivot Table.

A pivot table is a way to organize, manipulate, and summarize large amounts of data to make it 
much easier to read and understand while also allowing you to answer different questions about 
your spreadsheet by rearranging --or pivoting-- the data you enter into it.

For example, let’s say that you have a spreadsheet containing a list of donations to various 
charities by a group of recruiters in various months, but you are only interested in how much 
money each recruiter has collected in total. To determine your solution, you could manually 
calculate that amount by using the sorting and formatting options provided by Calc.

Alternatively, you could arrange a pivot table as shown below to make that data easier to organize 
and read.
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Figure 40: Pivot Table dialog with raw data and results

To access the pivot table creation dialog, choose Insert > Pivot Table or Data > Pivot Table > 
Create from the Menu bar. The Pivot Table Layout dialog will intelligently guess the column 
headings from the provided raw data and insert them into the Available Fields selection box. From 
there, you can drag and drop your desired information into column, row, or page fields to organize 
accordingly and press OK to view the results.

To choose new information to display, or to alter the layout of the existing information, right-click 
anywhere in the existing pivot table to bring up the context menu and choose Edit Layout.

For a more in-depth explanation of pivot tables, see the Calc Guide Chapter 8 Pivot Tables.

Pivot charts
To get a quick visual representation of the data contained in a pivot table, a Pivot Chart can be 
generated.

Functionally, pivot charts are nearly identical to regular charts except in two key areas. First, as the
data in the pivot table is altered, the pivot chart will adjust itself automatically to follow suit. The 
second difference is the inclusion of Field Buttons; graphical elements that allow you to filter the 
content of the pivot table from within the pivot chart itself, which is a useful time-saver if your pivot 
table and pivot chart are contained on different sheets.

For more information on Pivot Charts and Charts in general, see the Calc Guide Chapter 3 Charts 
and Graphs and the Calc Guide Chapter 8 Pivot Tables.

Printing

Printing from Calc is much the same as printing from other LibreOffice components (see Chapter 
10 Printing, Exporting, and Emailing in this guide). However, some details for printing in Calc are 
different, especially regarding preparation for printing.
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Print ranges
Print ranges have several uses, including printing only a specific part of the data or printing 
selected rows or columns on every page. For more information about using print ranges, see the 
Calc Guide Chapter 6 Printing, Exporting, and E-mailing.

Defining a print range
To define a new print range or modify an existing print range:

 1) Select the range of cells to be included in the print range.

 2) Go to Format > Print Ranges > Define on the Menu bar. Page break lines are displayed 
on screen.

 3) To check the print range, go to File > Print Preview on the Menu bar or click on the Print 
Preview icon. LibreOffice will display the cells in the print range.

Adding to a print range
After defining a print range, you can add more cells to it by creating another print range. This 
allows multiple, separate areas of the same sheet to be printed while not printing the whole sheet.

 1) After defining a print range, select an extra range of cells for adding to the print range.

 2) Go to Format > Print Ranges > Add on the Menu bar to add the extra cells to the print 
range. The page break lines are no longer displayed on the screen.

 3) To check the print ranges, go to File > Print Preview on the Menu bar or click on the Print 
Preview icon. LibreOffice will display the print ranges as separate pages.

Note

The additional print range will print as a separate page, even if both ranges are on the 
same sheet.

Removing a print range
It may become necessary to remove a defined print range, for example, if the whole sheet needs to
be printed later.

To remove all the defined print ranges, go to Format > Print Ranges > Remove on the Menu bar. 
After the print ranges have been removed, the default page break lines will appear on the screen.

Editing a print range
At any time, you can directly edit the print range, for example to remove or resize part of the print 
range. Go to Format > Print Ranges > Edit on the Menu bar to open the Edit Print Ranges 
dialog where you can define the print range.

Printing options
To select the printing options for page order, details, and scale to be used when printing a 
spreadsheet:

 1) Go to Format > Page on the Menu bar to open the Page Style dialog (Figure 41).

 2) Select the Sheet tab and make your selections from the available options.

 3) Click OK.

For more information on printing options, see the Calc Guide Chapter 6 Printing, Exporting, and 
E-mailing.
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Figure 41: Page Style dialog

Repeat printing of rows or columns
If a sheet is printed on multiple pages, you can set up certain rows or columns to repeat on each 
printed page. For example, if the top two rows of the sheet as well as column A need to be printed 
on all pages, do the following:

 1) Go to Format > Print Ranges > Edit on the Menu bar to open the Edit Print Ranges dialog
(Figure 42).

 2) Type the row identifiers in the Rows to repeat box. For example, to repeat rows 1 and 2, 
type $1:$2. This automatically changes Rows to repeat  from - none -  to - user defined -.

 3) Type the column identifiers in the Columns to repeat box. For example, to repeat column A, 
type $A. In the Columns to repeat list, - none - changes to - user defined -.

 4) Click OK.

For more information on editing print ranges, see the Calc Guide Chapter 6 Printing, Exporting, 
and E-mailing.

Figure 42: Edit Print Ranges dialog

Page breaks
While defining a print range can be a powerful tool, it may sometimes be necessary to manually 
adjust the Calc printout manually using a manual or page break. A page break helps to ensure that 
your data prints properly according to your page size and page orientation. You can insert a 
horizontal page break above or a vertical page break to the left of the active cell.
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For more information on manual breaks, see the Calc Guide Chapter 6 Printing, Exporting, and 
E-mailing.

Inserting a break
To insert a page break:

 1) Navigate to the cell where the page break will begin.

 2) Go to Insert > Page Break on the Menu bar.

 3) Select Row Break to create a page break above the selected cell.

Select Column Break to create a page break to the left of the selected cell.

Deleting a page break
To remove a page break:

 1) Navigate to a cell that is next to the break you want to remove.

 2) Go to Edit > Delete Page Break on the Menu bar.

 3) Select Row Break or Column Break as needed.

Note

Multiple manual row and column breaks can exist on the same page. When you want 
to remove them, you have to remove each break individually.

Headers and footers
Headers and footers are predefined pieces of text that are printed at the top or bottom of a page 
when a spreadsheet is printed. Headers and footers are set and defined using the same method. 
For more information on setting and defining headers and footers, see the Calc Guide Chapter 6 
Printing, Exporting, and E-mailing.

Headers and footers are also assigned to a page style. You can define more than one page style 
for a spreadsheet and assign different page styles to different sheets within a spreadsheet. For 
more information on page styles, see the Calc Guide Chapter 4 Using Styles and Templates.

Setting a header or footer
To set a header or footer:

 1) Navigate to the sheet that you want to set the header or footer for.

 2) Go to Format > Page on the Menu bar to open the Page Style dialog (Figure 43).

 3) On the Page Style dialog, select Header or Footer tab.

 4) Select the Header on or Footer on option.

 5) Select Same content left/right option if you want the same header or footer to appear on 
all the printed pages.

 6) Set the margins, spacing, and height for the header or footer. You can also select AutoFit 
height box to automatically adjust the height of the header or footer.

 7) To change the appearance of the header or footer, click on More to open the borders and 
background dialog.

 8) To set the contents, for example page number, date and so on, that appears in the header 
or footer, click on Edit to open the style dialog.
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Figure 43: Header page of Page Style dialog

50 | Printing


	Copyright
	Contributors
	To this edition
	To previous editions

	Feedback
	Publication date and software version

	Using LibreOffice on macOS
	What is Calc?
	Compatibility with other spreadsheet applications
	Wildcards
	Formula syntax
	Macros

	Spreadsheets, sheets, and cells
	Calc main window
	Title bar
	Menu bar
	Toolbars
	Formula bar
	Status bar
	Sidebar
	Spreadsheet layout
	Individual cells
	Sheet tabs


	Opening a CSV file
	Saving spreadsheets
	Saving in other spreadsheet formats
	Exporting contents as image

	Navigating within spreadsheets
	Cell navigation
	Sheet navigation
	Keyboard navigation
	Customizing the Enter key

	Selecting items in a spreadsheet
	Selecting cells
	Single cell
	Range of contiguous cells
	Range of non-contiguous cells

	Selecting columns and rows
	Single column or row
	Multiple columns or rows
	Entire sheet

	Selecting sheets
	Single sheet
	Multiple contiguous sheets
	Multiple non-contiguous sheets
	All sheets

	Hiding and showing sheets

	Working with columns and rows
	Inserting columns and rows
	Single column or row
	Multiple columns or rows

	Deleting columns and rows
	Single column or row
	Multiple columns or rows


	Working with sheets
	Inserting new sheets
	Moving and copying sheets
	Dragging and dropping
	Using a dialog

	Deleting sheets
	Renaming sheets

	Viewing Calc
	Changing document view
	Freezing rows and columns
	Freezing rows or columns
	Unfreezing

	Splitting the screen
	Splitting horizontally or vertically
	Removing split views


	Using the keyboard
	Numbers
	Minus numbers
	Leading zeroes
	Numbers as text

	Text
	Date and time
	AutoCorrection options
	Replace
	Exceptions
	Options
	Localized options
	Reset

	Deactivating automatic changes

	Speeding up data entry
	Using the Fill tool
	Using a fill series
	Defining a fill series
	Defining a fill series from a range in a sheet

	Using selection lists

	Sharing content between sheets
	Validating cell contents
	Editing data
	Deleting data
	Deleting data only
	Deleting data and formatting

	Replacing data
	Changing data
	Using the keyboard
	Using the mouse


	Formatting data
	Multiple lines of text
	Automatic wrapping
	Manual line breaks

	Shrinking text to fit the cell
	Formatting numbers
	Formatting fonts and text in cells
	Formatting cell borders
	Formatting cell background
	Formatting default cell styles

	AutoFormatting of cells
	Using AutoFormat
	Defining a new AutoFormat

	Using themes
	Using conditional formatting
	Hiding and showing data
	Hiding data
	Showing data

	Cell protection
	Sorting records
	Cell comments
	Using formulas and functions
	The Function Wizard and Function Search

	Analyzing data
	Pivot tables and pivot charts
	Pivot charts

	Printing
	Print ranges
	Defining a print range
	Adding to a print range
	Removing a print range
	Editing a print range

	Printing options
	Repeat printing of rows or columns
	Page breaks
	Inserting a break
	Deleting a page break

	Headers and footers
	Setting a header or footer



