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Introduction

You can create 2D and 3D objects in Draw. This chapter shows how to draw simple 2D objects. 
The following chapters describe how to work with and edit such objects. For more information on 
3D objects, see Chapter 7 Working with 3D Objects .

All shapes, whether they are lines, rectangles, or more complicated shapes, are called objects. 
This is common notation in vector drawing software.

The drawing tools are found on the Drawing toolbar (Figure 1). This toolbar is normally located at 
the bottom of the workspace. If you do not see it, you can activate it by going to View > Toolbars  
on the main menu bar.

As with all the components of LibreOffice, you can undock the Drawing toolbar and place it 
wherever you want to on the Draw workspace as a floating toolbar. You can also configure toolbars
by adding, moving, hiding, or deleting toolbar icons. See Chapter 1 Introducing Draw  for more 
information.

When you draw a shape, select one for editing or add text, the Information field in the status bar 
(Figure 2) changes to reflect the action taken or in progress. See Chapter 1 Introducing Draw  for 
more information on the status bar.

Figure 1: Drawing toolbar

Figure 2: Draw status bar

Custom shapes

Draw also offers the ability to create custom shapes , which are the equivalent of  AutoShapes in 
Microsoft Office. Custom shapes differ in their properties and are dealt with separately in the 
relevant chapters of this guide. The main differences relate to the behavior of 3D objects and text 
handling. Text frames in Draw have their own geometric format.

Drawing basic shapes

Basic shapes, including text, are treated as objects in Draw. The standard set of tools available for 
drawing basic shapes, from left to right on the Drawing toolbar, are shown in Figure 3.

The tools that are already placed on the Drawing toolbar are indicated by a darkened area around 
the icon, for example Select, Line and so on. The tools not on the Drawing toolbar do not have this
darkened area around the icon, for example To Curve, To Polygon , and so on.
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Figure 3: Tools available for Drawing toolbar

Please note that some of the icons on the Drawing toolbar will change shape according to the last 
tool used from the selection of available tools. The icons that have a small triangle to the right of 
the icon indicates that more tools are available. See “ Drawing geometric shapes ” on page 14 for 
information on the available shapes.

Note
When you draw a basic shape or select one for editing, the i nformation area at the 
left side in the status bar changes to reflect the present action: for example Line 
created, Text frame xxyy selected , and so on.

Figure 4: A straight line

Straight lines
A straight line is the simplest element or object in Draw to create.

1) Click on the Line icon  on the Drawing toolbar and place the cursor at the point where 
you want to start the line ( Figure 4).

2) Click and drag the cursor while keeping the mouse button pressed.
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3) Release the mouse button at the point where you want to end the line. A selection handle 
appears at each end of the line, showing that this object is the currently selected object. 
The selection handle at the starting point of the line is slightly larger than the ending 
selection handle.

4) Keep the Shift key pressed while you draw a line to restrict the drawing angle of the line to 
a multiple of 45 degrees (0, 45, 90, 135, and so on).

Note

This is the default behavior of the Shift key. However, if the option When creating or 
moving objects in the Snap position section of Tools > Options > LibreOffice Draw
> Grid has been selected, the action of the Shift key is the opposite. Lines will 
automatically be drawn at a multiple of 45 degrees unless the Shift key is pressed.

5) Keep the Ctrl key pressed while drawing a line to enable the end of the line to snap to the 
nearest grid point.

Note
This is the default behavior of the Ctrl key. However, if the Snap to Grid option on 
the View->Grid menu has been selected, the Ctrl deactivates the snap to grid 
activity.

6) Keep the Alt key pressed while drawing a line and the line extends outwards symmetrically 
in both directions from the start point. This lets you draw lines starting from the middle of 
the line.

7) When a line is drawn, it uses default attributes. To change any of these attributes, select 
the line by clicking on it, then use the tools on the Line and Filling toolbar to change line 
style, line width or line color.

8) Alternatively, go to Format > Line  on the main menu bar, or right-click and select Line from
the context menu to open the Line dialog ( Figure 5) to change line style, line width, line 
color or line transparency.

9) If necessary, go to Tools > Options > LibreOffice Draw > Grid  on the main menu bar to 
adjust the spacing (resolution) of the grid points. See Chapter 3 Working with Objects and 
Object Points  for more information.

Figure 5: Line dialog – Line page
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Figure 6: Information area in the Status bar

10) While you are working with a line (or any other element), use the information field on the 
Status bar to monitor your activity. A description of the current activity or selection is shown 
when you are working with elements and Figure 6 shows two examples.

Arrows
Arrows are drawn like lines because Draw classifies arrows as a subgroup of lines, that is lines 
with arrowheads. The information field on the status bar shows them only as lines. Click on the 

Line Ends with Arrow  icon  to draw an arrow. The arrow head is drawn at the end point of the 
arrow when you release the mouse button.

Figure 7: Arrows toolbar and available tools
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Different types of lines and arrows

Click on the small triangle to the right of the Lines and Arrows   icon on the Drawing toolbar to 
open a pop-up toolbar with tools for drawing lines and arrows . Alternatively, go to View > Toolbars 
> Arrows on the main menu bar to open the Arrows toolbar as a floating toolbar. The Lines and 
Arrows icon on the Drawing toolbar always indicates the last tool used and may not be the same 
as the Lines and Arrows  icon shown above. Figure 7 shows the tools that are available on the 
Arrows toolbar.

After drawing the line, you can change the arrow style by clicking on the Arrowheads  icon  in 
the Line and Filling toolbar and select the arrow start and end options. Start options are on the left 
and end options are on the right in Figure 8.

Figure 8: Available arrowheads

Rectangles or squares

Drawing a rectangle is similar to drawing a straight line. Click on the Rectangle icon  in the 
Drawing toolbar. As you draw the rectangle with the mouse cursor, the rectangle appears with the 
bottom right corner of the rectangle attached to the cursor. 

Squares are rectangles with all sides of equal length. To draw a square, click on the Rectangle 
icon  and hold down the Shift key while you draw a square.

Note

If the option When creating or moving objects  has been selected in Tools > 
Options > LibreOffice Draw > General , the action of the Shift key is reversed. 
When the Rectangle tool is selected, a square is drawn. To draw a rectangle you 
have to press the Shift key when drawing. This Shift key reversal also applies when 
drawing ellipses and circles in “ Ellipses and circles” on page 9.

To draw a rectangle or square from its center rather than the bottom right corner, position your 
cursor on the drawing, press the mouse button and then hold down the Alt key while dragging with 
the cursor. The rectangle or square uses the start point where you first clicked the mouse button as
the center.

With the rectangle or square selected, you can quickly change border style, line width, or color, and
the type of fill color or fill pattern using the tools on the Line and Filling toolbar. For more 
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information on changing the attributes of a rectangle or square, see Chapter 4 Changing Object 
Attributes.

Ellipses and circles

To draw an ellipse (also called an oval), click on the Ellipse icon  on the Drawing toolbar. A 
circle is an ellipse with both axes the same length. To draw a circle, click on the Ellipse icon and 
hold down the Shift key while you draw a circle.

To draw an ellipse or circle from its center, position your cursor on the drawing, press the mouse 
button and then hold down the Alt key while dragging with the cursor. The ellipse or circle uses the 
start point (where you first clicked the mouse button) as the center.

With the ellipse or circle selected, you can quickly change border style, line width, or color, and the 
type of fill color or fill pattern using the tools on the Line and Filling toolbar. For more information on
changing the attributes of an ellipse or circle, see Chapter 4 Changing Object Attributes .

Tip

To quickly insert a line, rectangle, ellipse, or text, press and hold the Ctrl key down 
and then click on one of the icons for line, rectangle, ellipse, or text. An object is 
drawn automatically in the center of the workspace area using default values. The 
object attributes can then be changed using the Line Fill toolbar or the information in
Chapter 4 Changing Object Attributes . This works only if the icon has no associated 
toolbar; that is, no triangle or arrow on the right side of the icon.

Adding arc and segment tools to the Drawing toolbar
If you regularly draw arcs or segments (partial circles or ellipses), then you can add the Circles and
Ovals toolbar (Figure 9) to the Drawing toolbar. The Circles and Ovals toolbar is an optional toolbar
and you have to customize the Drawing toolbar to add this optional toolbar.

Figure 9: Circles and Ovals toolbar

1) Go to View > Toolbars > Customize  on the main menu bar, or right-click in a blank area in
the Drawing toolbar and select Customize Toolbar  from the context menu to open the 
Customize dialog (Figure 10).

2) Select the Toolbars tab to open the Toolbars page of the Customize dialog.

3) Select Drawing from the Toolbar drop down list and click Add to open the Add Commands 
dialog (Figure 11).

4) Select Drawing in the Category list.

5) Scroll down and select the first Ellipse command in the Commands list. Check the 
Description  section at the bottom of the dialog as this will indicate that you have selected 
the command for the Circles and Ovals toolbar.

6) Click Add and then click Close.

7) In the Customize dialog, make sure the new Ellipse command is selected and checked.

8) For clarity, click Modify > Rename  and type in Circles and Ovals  as the new name for this 
command, then click OK.

9) Use the up and down arrow buttons to move the new Circles and Ovals  command to the 
desired position on the Drawing toolbar.

10) Click OK to save the customized Drawing toolbar and close the Customize dialog.
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Figure 10: Customize dialog

Figure 11: Add Commands dialog
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Note
The icon used to open the Circles and Ovals toolbar is still called Ellipse and is not 
to be confused with the Ellipse icon that is one of the default tools placed on the left
of the Drawing toolbar.

The new Circles and Ovals  (Ellipse) icon  appears on the Drawing toolbar with a small 
triangle to the right of it. Click on this triangle to open the Circles and Ovals toolbar ( Figure 9). To 
make this toolbar into a floating toolbar, drag the toolbar onto the workspace area. The Circles 
and Ovals  icon on the Drawing toolbar always indicates the last tool used and may not be the 
same as the Circles and Ovals  icon shown above.

To help prevent any confusion, you can remove the standard Ellipse icon  from the Drawing 
toolbar by opening the Customize dialog ( Figure 10) and deselecting the first Ellipse command in 
the Commands list. Alternatively, select the first Ellipse command, click Modify and select Delete 
from the context menu.

To return the Drawing toolbar to its default settings, open the Customize dialog, click Restore and 
then Yes to reset the Drawing toolbar to the default settings.

Arcs or segments
1) To draw an arc or segment, select the appropriate icon in the Circles and Ovals toolbar 

(Figure 9).

2) Click and drag with the cursor to create a guide circle or ellipse.

3) Move the cursor to the position where you want the arc or segment to start. The status bar 
indicates the angle in degrees.

4) Click to start drawing the arc or segment.

5) Move the cursor to create the arc or segment. The status bar shows the angle in degrees.

6) When you have drawn the arc or segment you require, click again to complete the arc or 
segment.

Curves or polygons

To draw a curve or polygon, click the Curve icon  on the Drawing toolbar. Click on the triangle 
to the right of the icon to open the toolbar ( Figure 12). The Curve icon on the Drawing toolbar 
always indicates the last tool used and may not be the same as the Curve icon shown above. 
Hovering the cursor over this icon gives a tooltip of Curve. If you open the floating toolbar, the 
toolbar title is Lines.

Figure 12: Curves (Lines) toolbar
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Curves
1) Click and hold the left mouse button to create the starting point of your curve, then drag 

from the starting point to draw a line.

2) Release the left mouse button and continue to drag the cursor to bend the line into a curve.

3) Click to set the end point of the curve and fix the curve on the page. Only the first section of
your curve is drawn as a curve.

4) To continue with your curve, click and drag the cursor to draw a straight line. Each mouse 
click sets a corner point and allows you to continue drawing another straight line from the 
last corner point.

5) Double click to end the drawing of your curve.

If you selected a filled curve, the last point is automatically joined to the first point to close off the 
curve and fills it with the current standard fill color. A curve without filling will not be closed when 
you end the drawing.

Polygons
1) Click and draw the first line from the start point while holding the left mouse button held 

down.

2) Release the mouse button when you have reached the second point of your polygon and a 
line between the first and second points is drawn.

3) Move the cursor to where you want the next point point in your polygon and click the 
mouse button to draw the next line.

4) Double-click to end the drawing of your polygon.

If you selected a filled polygon, the last point is automatically joined to the first point to close off the
polygon and fills it with the current standard fill color. A polygon without filling will not be closed 
when you end the drawing.

Polygons 45°
These polygons are drawn the same way as ordinary polygons above, but the angles between 
lines are restricted to 45 or 90 degrees when you create another point in your polygon.

Note
Holding down the Shift key when drawing lines with the Curve or Polygon tools will 
also restrict the angles between the lines to 45 or 90 degrees.

Freeform lines
Using the Freeform Line tools is similar to drawing with a pencil on paper.

1) Click and drag the cursor to the line shape you require.

2) Release the mouse button when you are satisfied with your freeform line and the drawing is
completed.

If you selected a filled freeform line, the last point is automatically joined to the first point to close 
off the freeform line and fills it with the current standard fill color. A freeform line without filling will 
not be closed when you end the drawing.
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Gluepoints and connectors

Gluepoints
All Draw objects have glue points, which normally are not displayed. Gluepoints become visible 

when the Connectors  icon  on the Drawing toolbar is selected .

Most objects have four gluepoints ( Figure 13). You can add more glue points and customize glue 
points using the Gluepoints  toolbar (Figure 14). Go to View > Toolbars > Gluepoints  on the main
menu bar to open the toolbar.

Gluepoints are not the same as the selection handles of an object. The handles are for moving or 
changing the shape of an object, as described in Chapter 3 Working with Objects and Object 
Points.

Gluepoints are used to fix or glue a connector to an object so that when the object moves, the 
connector stays fixed to the object. For a more detailed description on the use of gluepoints, see 
Chapter 8 Connections, Flowcharts and Organization Charts .

Figure 13: Gluepoints

Figure 14: Gluepoints toolbar

Connectors
Connectors are lines or arrows whose ends automatically snap to a gluepoint of an object. 
Connectors are useful in drawing organization charts, flow diagrams, and mind-maps. When 
objects are moved or reordered, the connectors remain attached to a gluepoint. Figure 15 shows 
an example of two objects and a connector.

Draw offers a range of different connectors and connector functions. Click on the triangle to the 

right of the Connector  icon  to open the Connectors toolbar ( Figure 16). The Connector  
icon on the Drawing toolbar always indicates the last tool used and may not be the same as the 
Connector  icon shown above.

For a more detailed description of the use of connectors, see Chapter 8 Connections, Flowcharts 
and Organization Charts .
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Figure 15: A connector between two objects

Figure 16: Connectors toolbar

Drawing geometric shapes

The icons for drawing geometric shapes are located on the Drawing toolbar and each geometric 
shape is explained in the following sections.  Clicking on the triangle to the right of the icon opens a 
floating toolbar giving access to the tools for that geometric shape.

The use of these tools for geometric shapes is similar to the tool used for drawing rectangles and 
squares. For more information, see “ Rectangles or squares ” on page 8.

The icons used on the Drawing toolbar for drawing geometric shapes always indicates the last tool 
used and may not be the same as the icons shown in the following sections.

Basic shapes

Click on the triangle to the right of the Basic Shapes  icon  to open the Basic Shapes toolbar 
(Figure 17) for drawing basic shapes. This toolbar also includes a rectangle tool identical to the 
one already displayed on the Drawing toolbar.
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Figure 17: Basic Shapes toolbar

Symbol shapes

Click on the triangle to the right of the  Symbol Shapes  icon  to open the Symbol Shapes 
toolbar for drawing symbols .

Figure 18: Symbol Shapes toolbar

Block arrows

Click on the triangle to the right of the Block Arrows  icon  to open the Block Arrows toolbar for 
drawing block arrows.

Figure 19: Block Arrows toolbar

Flowcharts

Click on the triangle to the right of the Flowcharts  icon  to open the Flowchart toolbar for 
symbols used in drawing flowcharts. The creation of flowcharts, organization charts, and similar 
planning tools are further described in Chapter 8 Connections, Flowcharts and Organization 
Charts.

Figure 20: Flowcharts toolbar

Callouts

Click on the triangle to the right of the  Callouts icon  to open the Callouts toolbar for drawing 
callouts.

Figure 21: Callouts toolbar
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Stars and banners

Click on the triangle to the right of the  Stars icon  to open the Stars and Banners toolbar for 
drawing stars and banners.

Figure 22: Stars and Banners toolbar

Adding text to drawings and objects

In Draw you can add, insert, and format text to a drawing, objects, and shapes as follows:

• As a dynamic text frame, which is an independent Draw object and expands as you add 
more text within the frame.

• Text within a previously drawn object. This integrates text within the object and is placed 
within the boundary rectangle that surrounds an object. This boundary rectangle is not 
dynamic and care must be taken so that your text does not go outside of the object 
boundaries.

For more information on how to add, insert, and format text in a drawing or drawing objects, see 
Chapter 9 Adding and Formatting Text .
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