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F11 #+T Opens the Styles and Formatting window
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What is Writer?

Writer is the word processor component of LibreOffice. In addition to the usual features of a word
processor (spelling check, thesaurus, hyphenation, autocorrect, find and replace, automatic
generation of tables of contents and indexes, mail merge and others), Writer provides these
important features:

* Templates and styles (see Chapter 3)

* Page layout methods, including frames, columns, and tables

* Embedding or linking of graphics, spreadsheets, and other objects

¢ Built-in drawing tools

* Master documents—to group a collection of documents into a single document
* Change tracking during revisions

¢ Database integration, including a bibliography database

e Export to PDF, including bookmarks (see Chapter 10)

* And many more

These features are covered in detail in the Writer Guide.

The Writer interface

The main Writer workspace is shown in Figure 1. The menus and toolbars are described in
Chapter 1, Introducing LibreOffice.

Some other features of the Writer interface are covered in this chapter.

File Edit View g Insert Format Table Tools Window Help

TREEE IEEEREY £-¢ B¢ @z -v MPma@a
E] |Defauit l E] |'1imes Mevl Roman EJ 12 EIB I & i
L R R _.‘]-_ e boa :-? I 5 ‘-_1 el ‘-4 i ‘-5* 4“;.”464 vren b -
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| standard toolbar | | Formatting toolbar
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Page 1 /1 Default English (LUSA) INSAT | 51D | * 0 = .
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Figure 1: The main Writer workspace in Print Layout view
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Status bar

The Writer status bar provides information about the document and convenient ways to quickly
change some document features.

1/1 Default English (USA) INSRT |STD | L
Page Page Language Insert  Selection Unsaved
number style mode  mode changes

Figure 2: Left end of status bar

Page number
Shows the current page number, the sequence number of the current page (if different), and
the total number of pages in the document. For example, if you restarted page numbering at 1
on the third page, its page number is 1 and its sequence number is 3.

If any bookmarks have been defined in the document, a right-click on this field pops up a list of
bookmarks; click on the required one.
To jump to a specific page in the document, double-click on this field. The Navigator opens.

Click in the Page Number field, type the sequence number of the required page, and press
Enter.

Page style
Shows the style of the current page. To change the page style, right-click on this field. A list of
page styles pops up; choose a different style by clicking on it.

To edit the current page style, double-click on this field. The Page Style dialog opens.

Language
Shows the language for the selected text.
Click to open a menu where you can choose another language for the selected text or for the

paragraph where the cursor is located. You can also choose None (Do not check spelling) to
exclude the text from a spelling check or choose More... to open the Character dialog.

Insert mode
Click to toggle between Insert and Overwrite modes when typing.

Selection mode
Click to toggle between STD (Standard), EXT (Extend), ADD (Add) and BLK (Block) selection.
EXT is an alternative to Shift+click when selecting text. See “Working with text” on page 10 for
more information about ADD and BLK.

Unsaved changes

This icon [=] replaces the default icon here if changes to the document have not been saved.

Bullets 1: Level 1 GOGEG e — Ié @ 100% ‘
[l i
Digital Object View Zoom Zoom
signature  jpformation layout slider percent

Figure 3: Right end of status bar
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Digital signature
If the document has been digitally signed, an icon shows here. You can double-click the icon to

view the certificate.

Section or object information
When the cursor is on a section, heading, or list item, or when an object (such as a picture or
table) is selected, information about that item appears in this field. Double-clicking in this area
opens a relevant dialog. For details, consult the Help or the Writer Guide.

View layout
Click an icon to change between single page, side-by-side, and book layout views. The effect
varies with the combination of window width and zoom factor in use. You can edit the document

in any view.
B OE O BB (5 OO0 3
- & i
1 1 2 1
2 3 4 213
3 5 6 45

Figure 4: View layouts: single, side-by-side, book.

Zoom
To change the view magnification, drag the Zoom slider, or click on the + and — signs, or right-
click on the zoom level percent to pop up a list of magnification values from which to choose.
Zoom interacts with the selected view layout to determine how many pages are visible in the
document window.

Sk o ® 100%

Changing document views

Writer has several ways to view a document: Print Layout, Web Layout, and Full Screen. To access
these and other choices, go to the View menu and click on the required view. (When in Full Screen
view, press the Esc key to return to either Print or Web Layout view.)

When in Print Layout, you can use both the Zoom slider and the View Layout icons on the status
bar. In Web Layout, you can use only the Zoom slider.

Changing document views 7



You can also choose View > Zoom from the menu bar to display the Zoom & View Layout dialog,

where you can set the same options as on the Status bar. In Web Layout view, most of the choices
are not available.

Zoom & View Layout 2
Zoom factor View layout
) Optimal () Automatic
() Fit width and height i@ Single page
(71 Fit width (") Columns |
@ 100 % Book mode
() Variable 100
oK ] ’ Cancel ] ’ Help
Figure 5: Choosing Zoom and View Layout options.

Moving quickly through a document

In addition to the navigation features of the Status bar (described above), you can use the main
Navigator window and the Navigation toolbar as described in Chapter 1, Introducing LibreOffice

In Writer, you can also display the Navigation toolbar by clicking on the small Navigation icon near
the lower right-hand corner of the window below the vertical scroll bar, as shown in Figure 6

Prevmua—@

"\
Ne}d_@ avigatinni

GOG O (|@—&—— @ || 100%

Figure 6. Navigation icons

The Navigation toolbar (Figure 7) shows icons for all the object types shown in the Navigator, plus
some extras (for example, the results of a Find command).

Mavigation @
EHoO@R b =& w0 2
semEpfeEE s

Repeat search

Figure 7: Navigation toolbar

Click an icon to select that object type. Now all the Previous and Next icons (in the Navigator
itself, in the Navigation Toolbar, and on the scroll bar) will jump to the next object of the selected
type. This is particularly helpful for finding items like index entries, which can be difficult to see in
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the text. The names of the icons (shown in the tooltips) change to match the selected category; for
example, Next Graphic, Next Bookmark, or Continue search forward.

For more uses of the Navigator in Writer, see the Writer Guide.

Working with documents

Chapter 1, Introducing LibreOffice, includes instructions on starting new documents, opening
existing documents, saving documents, and password-protecting documents. Chapter 3, Using
Styles and Templates, covers how to create a document from a template.

Saving as a Microsoft Word file

If you need to exchange documents with users of Microsoft Word who are unwilling or unable to
receive *.odt files, you can save a document as a Microsoft Word file.

1) Important—First save your document in the file format used by LibreOffice Writer (.odt). If
you do not, any changes you made since the last time you saved will appear only in the
Microsoft Word version of the document.

2) Then choose File > Save As. On the Save As dialog, in the File type (or Save as type)
drop-down menu, select the type of Word format you need. Click Save.

I8 Save as + x|
/home/jeanweber/Documents i M
Places Title [Type Size |Date modified
[0 Default Directo |5 aa-examples Folder 03/08/2011, 22:03:16

37 aaaa Folder 25/08/2011, 07:19:19

3 Apache00o0 Folder 29/08/2011, 22:44:41

3 artatshirts Folder 21/11/2009, 09:50:14

3 awa Folder 18/08/2011, 15:03:06

3 carlyle-gardens Folder 29/07/2011, 09:05:35

3 cyclones2010 Folder 11/04/2010, 18:51:18

3 cyclones2011 Folder 02/02/2011, 20:58:45

3 e-books Folder 16/08/2011, 10:57:44

+ | |- 1 epub-testfiles Folder 18/09/2010. 21:31:29
File name: IntroducingWriter . Save
File type: ODF Text Document (.odt) v cancel

ODF Text Document (.odk)

ODF Text Document Template (.ott)
OpenOffice.org 1.0 Text Documentk (.sxw)
OpenOffice.org 1.0 Text Document Template (.stw)
OpenDocument Text (Flat XML) (.Fodk)

~I Edit filter settin(Unified Office Format text (.uot)

Microsoft Word 2007/2010 XML (.docx)

Microsoft Word 2003 XML (.xml)

Microsoft Word 97/2000/XP/2003 (.doc)

Microsoft Word 95 (.doc)
Figure 8. Saving a file in Microsoft Word format

Help

~| Save with passw

From this point on, all changes you make to the document will occur only in the new document.
You have changed the name and file type of your document. If you want to go back to working with
the .odt version of your document, you must open it again.
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Caution It is recommended that if you use a Microsoft Word format, you use the .doc and

not the .docx format. Saving first in .odt format gives you the option to redo the
A document if the recipient of your document experiences trouble with the Microsoft
format.
To have Writer save documents by default in the Microsoft Word file format, go to
Tip Tools > Options > Load/Save > General. In the section named Default file

format and ODF settings, under Document type, select Text document, then
under Always save as, select your preferred file format.

Working with text

Working with text (selecting, copying, pasting, moving) in Writer is similar to working with text in
any other program. LibreOffice also has some convenient ways to select items that are not next to
each other, select a vertical block of text, and paste unformatted text.

Selecting items that are not consecutive

To select nonconsecutive items (as shown in Figure 9) using the mouse:
1) Select the first piece of text.
2) Hold down the Ctrl key and use the mouse to select the next piece of text.
3) Repeat as often as needed.

Now you can work with the selected text (copy it, delete it, change the style, or whatever).

Macintosh users: substitute the Command key when instructions in this chapter

Note say to use the Ctrl key.

Around the World in 80 Days - Jules Verne

overspread Passepartout's round face; clearly he had not comprehended his

master.
"Monsieur is going to leave home?"

"Yes," returned Phileas Fogg. "We are goinground the world."

Passepartout jppened wide his eyes, raised his eyebrows, held up his hands, and seemed about
to collapse, so overcome was he with stupefied astonishment.

"Round the world![' he mwmured.

"In eighty days," responded Mr. Fogg. "So we haven't a moment to lose."
"But the trunks?" gasped Passepartout, unconsciously swaying his head from right to left.

"We'll have no trunks; only a carpet—bag, with two shirts and three pairs of stockings for me|
and the same for youl We'll buy our clothes on the way. Bring down my mackintosh and
traveling—cloak and some stout shoes, though we shall do little walking. Make haste!"

Figure 9: Selecting items that are not next to each other

To select nonconsecutive items using the keyboard:

1) Select the first piece of text. (For more information about keyboard selection of text, see the
topic “Navigating and selecting with the keyboard” in the Help.)
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2) Press Shift+F8. This puts Writer in “Add” mode. The word ADD appears on the status bar,
replacing STD.

3) Use the arrow keys to move to the start of the next piece of text to be selected. Hold down
the Shift key and select the next piece of text.

4) Repeat as often as needed.
Now you can work with the selected text.
Press Esc to exit from this mode.

Selecting a vertical block of text

You can select a vertical block or “column” of text that is separated by spaces or tabs (as you might
see in text pasted from e-mails, program listings, or other sources), using LibreOffice’s block
selection mode. To change to block selection mode, use Edit > Selection Mode > Block Area, or
press Ctrl+F8, or click several times in the status bar on STD until it changes to BLK.

1/1 Default English (USA) 1N5RT®

o

Now highlight the selection, using mouse or keyboard, as shown below.

January March
April June

July September
October December

Figure 10: Selecting a vertical block of text

Cutting, copying, and pasting text

Cutting and copying text in Writer is similar to cutting and copying text in other applications. You
can use the mouse or the keyboard for these operations. You can copy or move text within a
document, or between documents, by dragging or by using menu selections, icons, or keyboard
shortcuts. You can also copy text from other sources such as Web pages and paste it into a Writer
document.

To move (drag and drop) selected text using the mouse, left-click it and drag it to the new location
and release it. To copy selected text, hold down the Ctrl key while dragging. The text retains the
formatting it had before dragging.

To move (cut and paste) selected text, use Ctr/+X to cut the text, insert the cursor at the paste-in
point and use Ctr/+V to paste. Alternatively, use the icons on the Standard toolbar.

When you paste text, the result depends on the source of the text and how you paste it. If you click
on the Paste icon, any formatting the text has (such as bold or italics) is retained. Text pasted from
Web sites and other sources may also be placed into frames or tables. If you do not like the
results, click the Undo icon or press Cirl+Z.

To make the pasted text take on the formatting of the surrounding text where it is being pasted:
* Choose Edit > Paste Special, or
* Click the triangle to the right of the Paste icon, or
* Click the Paste icon without releasing the left mouse button.

Then select Unformatted text from the resulting menu.

The range of choices on the Paste Special menu varies depending on the origin and formatting of
the text (or other object) to be pasted. See Figure 11 for an example with text on the clipboard.

Working with text 11



|| ¢ @ H -
LibreQffice Writer |
DDE link
HTML (HyperText Markup Language)
Formatted text [RTF]
Unformatted text

Figure 11: Paste Special menu

Finding and replacing text and formatting

Writer has two ways to find text within a document: the Find toolbar for fast searching and the Find
& Replace dialog. In the dialog, you can:

* Find and replace words and phrases

* Use wildcards and regular expressions to fine-tune a search
* Find and replace specific formatting

* Find and replace paragraph styles

Using the Find toolbar

If the Find toolbar is not visible, you can display it by choosing View > Toolbars > Find from the
menu bar or by pressing Ctrl+F. The Find toolbar is shown docked at the bottom of the LibreOffice
window (just above the Status Bar) in Figure 12, but you can float it or dock it in another location.
For more information on floating and docking toolbars, see Chapter 1, Introducing LibreOffice.

19 1 -

¢ %

Page 12 f 32 O0oPagestyle English {(U5A) INSRT

Figure 12: Docked position of Find toolbar

To use the Find toolbar, click in the box and type your search text, then press Enter to find the next
occurrence of that term. Click the Find Next or Find Previous buttons as needed.

Using the Find & Replace dialog
To display the Find & Replace dialog (Figure 13), use the keyboard shortcut Ctrl+H or choose Edit
> Find & Replace from the menu bar. Optionally, click the More Options button to expand the
dialog; the button changes to Fewer Options.
To use the Find & Replace dialog:

1) Type the text you want to find in the Search for box.

2) To replace the text with different text, type the new text in the Replace with box.

3) You can select various options such as matching the case, matching whole words only, or
doing a search for similar words.

4) When you have set up your search, click Find. To replace the found text, click Replace.

For more information on using Find & Replace, see the Writer Guide.
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If you click Find All, LibreOffice selects all instances of the search text in the

Tip document. Similarly, if you click Replace All, LibreOffice replaces all matches.

Caution Use Replace All with caution; otherwise, you may end up with some hilarious (and
highly embarrassing) mistakes. A mistake with Replace All might require a
manual, word-by-word, search to fix.

Find & Replace 2
Search for |E| ’ Find ]
and
[ Find Al ]
Repl ith
eplace wi |E| ’ P—m— ]
or
’ Replace All ]
[] Match case
[V] Whele words only
’ Fewer Options & l ’ Help ] ’ Close ]
Current selection only Attributes...
[7] Backwards ’ ]
Format...
[ Regular expressions —
[ Similarity search " Lo T
[ Search for Styles
[ Motes

Figure 13: Expanded Find & Replace dialog

Inserting special characters
A special character is one not found on a standard English keyboard. For example, © % & ¢ fi 0 @
¢ are all special characters. To insert a special character:

1) Place the cursor where you want the character to appear.

2) Choose Insert > Special Character to open the Special Characters dialog.

3) Select the characters (from any font or mixture of fonts) you wish to insert, in order, then
click OK. The selected characters are shown in the lower left of the dialog. As you select a
character, it is shown on the lower right, along with its numerical code.

Working with text 13



Not Different fonts include different special characters. If you do not find a particular
ote special character, try changing the Font selection.

Special Characters
Font Times Mew Roman % | Subset Basic Greek W
H|T[DO[(Y|Q|T|A|BIT|A|JE|Z|H|®|I|EK
AlM|N|Z|lo|OlP|E|T|Y|®|X|¥|Q|I|T¥ =
e |n|i|v|alB|v|a]e]c|nle]]|x]n
L|v|E&|lo|n|lplec|lo|lTt|lv|lo|y|w|o|i]|D
slo|la|E|B|T|e|S|I|I|T|B|B|R|K|V
N(A|B|B|T|O|E|&XE|3|H H|E|TI|M|H|O
NIP|C|T|V|2|X|0|9Y(M|I|[B || |2 |Hw

Figure 14: The Special Characters dialog, where you can insert special characters

Inserting dashes and non-breaking spaces and hyphens

To prevent two words from being separated at the end of a line, press Ctr/+Shift when you type the
space between the two words.

In cases where you do not want the hyphen to appear at the end of a line, for example in a number
such as 123-4567, you can press Shift+Ctrl+minus sign to insert a non-breaking hyphen.

To enter en and em dashes, you can use the Replace dashes option on the Options tab under
Tools > AutoCorrect Options. This option replaces two hyphens, under certain conditions, with
the corresponding dash.

— is an en-dash; that is, a dash the width of the letter “n” in the font you are using. Type at
least one character, a space, one or two hyphens, another space, and at least one more
letter. The one or two hyphens will be replaced by an en-dash.

— is an em-dash; that is, a dash the width of the letter “m” in the font you are using. Type at
least one character, two hyphens, and at least one more character. The two hyphens will be
replaced by an em-dash.

See the Help for more details. For other methods of inserting dashes, see the Writer Guide.

Setting tab stops and indents

The horizontal ruler shows both the default tab stops and any tab stops that you have defined. Tab
settings affect indentation of full paragraphs (using the Increase Indent and Decrease Indent
icons on the Formatting toolbar) as well as indentation of parts of a paragraph (by pressing the Tab
key on the keyboard).

Using the default tab spacing can cause formatting problems if you share documents with other
people. If you use the default tab spacing and then send the document to someone else who has
chosen a different default tab spacing, tabbed material will change to use the other person’s
settings. Instead of using the defaults, define your own tab settings, as described in this section.

To define indents and tab settings for one or more selected paragraphs, double-click on a part of
the ruler that is not between the left and right indent icons to open the Indents & Spacing page of
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the Paragraph dialog. Double-click anywhere between the left and right indent icons on the ruler to
open the Tabs page of the Paragraph dialog.

A better strategy is to define tabs for the paragraph style. See Chapters 6 and 7 in the Writer
Guide for more information.

Using tabs to space out material on a page is not recommended. Depending on

Tip what you are trying to accomplish, a table is usually a better choice.

Changing the default tab stop interval

Any changes to the default tab setting will affect the existing default tab stops in

Note any document you open afterward, as well as tab stops you insert after making the
change.

To set the measurement unit and the spacing of default tab stop intervals, go to Tools > Options >
LibreOffice Writer > General.

Settings
Measurement unit inch hd
Tab stops 0.50" >

Figure 15: Selecting a default tab stop interval

You can also set or change the measurement unit for rulers in the current document by right-
clicking on the ruler to open a list of units. Click on one of them to change the ruler to that unit. The
selected setting applies only to that ruler.

milimetre
+ |centimetre

inch

point

pica

Char

Figure 16: Changing the measurement unit for a ruler

Checking spelling and grammar

Writer provides a spelling checker, which can be used in two ways.

agc  AutoSpellcheck checks each word as it is typed and displays a wavy red line under any
= misspelled words. When the word is corrected, the line disappears.

ﬁgg, To perform a separate spelling and grammar check on the document (or a text selection)
click the Spelling and Grammar button. This checks the document or selection and opens
the Spelling and Grammar dialog if any unrecognized words are found. In order to use this,
the appropriate dictionaries must be installed. By default, four dictionaries are installed: a
spelling checker, a grammar checker, a hyphenation dictionary, and a thesaurus.

Working with text 15



Here are some more features of the spelling checker:

* You can right-click on a word with a wavy underline to open a context menu. If you select
from the suggested words on the menu, the selection will replace the misspelled word in
your text. Other menu options are discussed below.

* You can change the dictionary language (for example, Spanish, French or German) on the
Spelling and Grammar dialog.

* You can add a word to the dictionary. Click Add in the Spelling and Grammar dialog and
pick the dictionary to add it to.

* Click the Options button on the Spelling and Grammar dialog to open a dialog similar to
the one in Tools > Options > Language Settings > Writing Aids described in Chapter 2.
There you can choose whether to check uppercase words and words with numbers, and
you can manage custom dictionaries, that is, add or delete dictionaries and add or delete
words in a dictionary.

* Onthe Font tab of the Paragraph Styles dialog, you can set paragraphs to be checked in a
specific language (different from the rest of the document). See Chapter 7, Working with
Styles, in the Writer Guide for more information.

Writer includes a grammar checker (LightProof), which you can access from Tools > Spelling and
Grammar.

Using built-in language tools

Writer provides some tools that make your work easier if you mix multiple languages within the
same document or if you write documents in various languages.

The main advantage of changing the language for a text selection is that you can then use the
correct dictionaries to check spelling and apply the localized versions of Autocorrect replacement
tables, thesaurus, and hyphenation rules.

You can also set the language for a paragraph or a group of characters as None (Do not check
spelling). This option is especially useful when you insert text such as web addresses or
programming language snippets that you do not want to check for spelling.

Specifying the language in character and paragraph styles is the preferred method, because styles
allow a greater level of control and make changing the language much faster. On the Font tab of
the Paragraph Styles dialog, you can specify that certain paragraphs be checked in a language
that is different from the language of the rest of the document. See Chapter 7, Working with Styles,
in the Writer Guide for information on how to manage the language settings of a style.

You can also set the language for the whole document, for individual paragraphs, or even for
individual words and characters, from Tools > Language on the menu bar.

Another way to change the language of a whole document is to use Tools > Options > Language
Settings > Languages. In the Default languages for documents section, you can choose a

different language for all the text that is not explicitly marked as a different language.

&
The spelling checker works only for those languages in the list that have the symbol next to
them. If you do not see the symbol next to your preferred language, you can install the additional

dictionary using Tools > Languages > More dictionaries online.

The language used for checking spelling is also shown in the status bar, next to the page style in
use.
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Using AutoCorrect

Writer’s AutoCorrect function has a long list of common misspellings and typing errors, which it
corrects automatically. For example, “hte” will be changed to “the”.

AutoCorrect is turned on when Writer is installed. To turn it off, uncheck Format > AutoCorrect >
While Typing.

Choose Tools > AutoCorrect Options to open the AutoCorrect dialog. There you can define
which strings of text are corrected and how. In most cases, the defaults are fine.

To stop Writer replacing a specific spelling, go to the Replace tab, highlight the word pair, and click
Delete.

To add a new spelling to the list, type it into the Replace and With boxes on the Replace tab, and
click New.

See the different tabs of the dialog for the wide variety of other options available to fine-tune
AutoCorrect.

AutoCorrect can be used as a quick way to insert special characters. For example,

Tip (c) will be autocorrected to ©. You can add your own special characters.

Using word completion

If Word Completion is enabled, Writer tries to guess which word you are typing and offers to
complete the word for you. To accept the suggestion, press Enter. Otherwise, continue typing.

To turn off Word Completion, select Tools > AutoCorrect Options > Word Completion and
deselect Enable word completion.

You can customize word completion from the Word Completion page of the AutoCorrect dialog:
* Add (append) a space automatically after an accepted word

* Show the suggested word as a tip (hovering over the word) rather than completing the text
as you type

* Collect words when working on a document, and then either save them for later use in
other documents or select the option to remove them from the list when closing the
document

* Change the maximum number of words remembered for word completion and the length of
the smallest words to be remembered

* Delete specific entries from the word completion list

* Change the key that accepts a suggested entry—the options are Right arrow, End key,
Return (Enter), and Space bar

Automatic word completion only occurs after you type a word for the second time

Note in a document.

Using AutoText

Use AutoText to store text, tables, graphics and other items for reuse and assign them to a key
combination for easy retrieval. For example, rather than typing “Senior Management” every time
you use that phrase, you can set up an AutoText entry to insert those words when you type “sm”
and press F3.

AutoText is especially powerful when assigned to fields. See Chapter 14, Working with Fields, in
the Writer Guide for more information.
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Creating AutoText
To store some text as AutoText:
1) Type the text into your document.
2) Select the text.
3) Choose Edit > AutoText (or press Ctrl+F3).

4) In the AutoText dialog box, type a name for the AutoText in the Name box. Writer will
suggest a one-letter shortcut, which you can change.

5) In the large box to the left, choose the category for the AutoText entry, for example My
AutoText.

6) Click the AutoText button on the right and select New (text only) from the menu.
7) Click Close to return to your document.

If the only option under the AutoText button is Import, either you have not entered

Tip a name for your AutoText or there is no text selected in the document.

Inserting AutoText
To insert AutoText, type the shortcut and press F3.

Formatting text

Using styles is recommended

Styles are central to using Writer. Styles enable you to easily format your document consistently,
and to change the format with minimal effort. A style is a named set of formatting options. When
you apply a style, you apply a whole group of formats at the same time. In addition, styles are used
by LibreOffice for many processes, even if you are not aware of them. For example, Writer relies
on heading styles (or other styles you specify) when it compiles a table of contents.

aution : , : :
€ T Manual formatting (also called direct formatting) overrides styles, and you cannot get

rid of the manual formatting by applying a style to it.

Writer defines several types of styles, for different types of elements: characters, paragraphs,
pages, frames, and lists. See Chapter 3, Using Styles and Templates, in this book and Chapters 6
and 7 in the Writer Guide.

Formatting paragraphs

You can apply many formats to paragraphs using the buttons on the Formatting toolbar. Figure 17
shows the Formatting toolbar as a floating toolbar, customized to show only the icons for
paragraph formatting. The appearance of the icons may vary with your operating system and the
selection of icon size and style in Tools > Options > LibreOffice > View.
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Figure 17: Formatting toolbar, showing icons for paragraph formatting

You can apply many formats to characters using the buttons on the Formatting toolbar. Figure 18
shows the Formatting toolbar, customized to include only the icon for character formatting.

The appearance of the icons may vary with your operating system and the selection of icon size
and style in Tools > Options > LibreOffice > View.

‘| ‘Default | ‘Times Mew Rorman | |12 ‘ B7rUBREIRKIE A-»-8- & L
| | | | L ¥ 518 kL 3 &
1 i 3 4 5 6 7 8 9 10 11 12 13 14 15
1 Open Styles and Formatting 6 ltalic 12 Font Color
Window 7 Underline 13 Highlighting
2 Apply Style 8 Superscript 14 Background Color
3 Font Name 9 Subscript 15 Open Character Format Dialog
4 Font Size 10 Increase Font
5 Bold 11 Reduce Font

Figure 18: Formatting toolbar, showing icons for character formatting

To remove manual formatting, select the text and choose Format > Clear Direct

Tip

from the context menu, or use Ctrl+M from the keyboard.

Autoformatting

Formatting from the menu bar, or right-click and choose Clear Direct Formatting

You can set Writer to automatically format parts of a document according to the choices made on
the Options page of the AutoCorrect dialog (Tools > AutoCorrect Options).

Tip

If you notice unexpected formatting changes occurring in your document, this is
the first place to look for the cause.

The Help describes each of these choices and how to activate the autoformats. Some common
unwanted or unexpected formatting changes include:

* Horizontal lines. If you type three or more hyphens (---), underscores (___ ) or equal signs
===) on a line and then press Enter, the paragraph is replaced by a horizontal line as wide
as the page. The line is actually the lower border of the preceding paragraph.

Formatting text
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* Bulleted and numbered lists. A bulleted list is created when you type a hyphen (-), star (*),
or plus sign (+), followed by a space or tab at the beginning of a paragraph. A numbered list
is created when you type a number followed by a period (.), followed by a space or tab at
the beginning of a paragraph. Automatic numbering is only applied to paragraphs formatted
with the Default, Text body or Text body indent paragraph styles.

To turn autoformatting on or off, choose Format > AutoCorrect and select or deselect the items on
the list.

Creating numbered or bulleted lists

There are several ways to create numbered or bulleted lists:
* Use autoformatting, as described above.

* Use list (numbering) styles, as described in Chapter 6, Introduction to Styles, and Chapter
7, Working with Styles, in the Writer Guide.

* Use the Numbering and Bullets icons on the paragraph formatting toolbar (see Figure
17): select the paragraphs in the list, and then click the appropriate icon on the toolbar.

It is a matter of personal preference whether you type your information first, then

Note apply Numbering/Bullets, or apply them as you type.

Using the Bullets and Numbering toolbar

You can create nested lists (where one or more list items has a sub-list under it, as in an outline)
by using the buttons on the Bullets and Numbering toolbar (Figure 19). You can move items up or
down the list, or create sub-points, and even change the style of bullets. Use View > Toolbars >
Bullets and Numbering to see the toolbar.

The appearance of the icons may vary with your operating system and the selection of icon size
and style in Tools > Options > LibreOffice > View.

If numbering or bullets are being applied automatically in a way that you find
Note inappropriate, you can switch them off temporarily by unchecking Format >
AutoCorrect > While Typing.

Bullets and Numbering o
EISIE2®RPI=IT L RIS
| T

|!'! i||
1 2 3 4 5 6 7 8 9 10 11 12 13 14

1 Bullets On/Off 6 Promote One Level with 10 Move Down

2 Numbering On/Off Subpoints 11 Move Up with Subpoints

3 Numbering Off 7 Demote One Level with 12 Move Down with Subpoints
Subpoints

4 Promote One Level 8 Insert Unnumbered Entry 13 Restart Numbering

5 Demote One Level 9 Move Up 14 Bullets and Numbering

Figure 19: Bullets and Numbering toolbar

20 Getting Started with Writer



Hyphenating words

You have several choices regarding hyphenation: let Writer do it automatically (using its
hyphenation dictionaries), insert conditional hyphens manually where necessary, or don't

hyphenate at all.

Automatic hyphenation
To turn automatic hyphenation of words on or off:

1) Press F11 (38+T on Mac) to open the Styles
and Formatting window.

2) On the Paragraph Styles page (Figure 20),
right-click on Default and select Modify.

3) On the Paragraph Style dialog (Figure 21),
go to the Text Flow page.

4) Under Hyphenation, select or deselect the
Automatically option. Click OK to save.

Styles and Formatting

|_.av| = [ B3

\plimentary close
Defaulf

First lif___New...
Hangin  Modify...
Heading

Heading 1

Heading 10
Heading 2

Heading 3

Headinag 4

Automatic

Figure 20: Modifying a style

Faragraph Style: Default

Figure 21: Turning on automatic hyphenation

Murnbeting Tabs Drop Caps Background Borders
Qrganizer Indents & Spacing Alignment | Text Flow | Font | Fonk Effects Posikion
Hyphenation

Automatically:
2 % Characters at line end
z faa| Characters at line begin
0 84| Maxirmurm number of consecutive byphens

Turning on hyphenation for the Default paragraph style affects all other paragraph
styles that are based on Default. You can individually change other styles so that

Note

hyphenation is not active; for example, you might not want headings to be
hyphenated. Any styles that are not based on Default are not affected. See Writer

Guide Chapter 3, Styles and Templates, for more about styles based on other

styles.

You can also set hyphenation choices through Tools > Options > Language Settings > Writing
Aids. In Options, near the bottom of the dialog, scroll down to find the hyphenation settings.

Options

Characters before line break: 2
Characters after line break: 2
- Hyphenate without inguiry
v Hyphenate special regions

Figure 22: Setting hyphenation options
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To change the minimum number of characters for hyphenation, the minimum number of characters
before a line break, or the minimum number of characters after a line break, select the item, and
then click the Edit button in the Options section.

Hyphenation options set on the Writing Aids dialog are effective only if hyphenation is turned on
through paragraph styles.

Manual hyphenation

To manually hyphenate words, do not use a hormal hyphen, which will remain visible even if the
word is no longer at the end of a line when you add or delete text or change margins or font size.
Instead, use a conditional hyphen, which is visible only when required.

To insert a conditional hyphen inside a word, click where you want the hyphen to appear and press
Ctrl+hyphen. The word will be hyphenated at this position when it is at the end of the line, even if
automatic hyphenation for this paragraph is switched off.

Formatting pages

Writer provides several ways for you to control page layouts: page styles, columns, frames, tables,
and sections. For more information, see Chapter 4, Formatting Pages, in the Writer Guide.

Page layout is usually easier if you show text, object, table, and section
boundaries in Tools > Options > LibreOffice > Appearance, and paragraph
ends, tabs, breaks, and other items in Tools > Options > LibreOffice Writer >
Formatting Aids.

Tip

Which layout method to choose?

The best layout method depends on what the final document should look like and what sort of
information will be in the document. Here are some examples.

For a book similar to this user guide, with one
column of text, some figures without text beside
them, and some other figures with descriptive text,
use page styles for basic layout, and tables to place
figures beside descriptive text when necessary.

Items 1
formatted as :
d tﬂble [y whet dom-OpenCfceorgirciudeT)

\1.:,..::\..:'.-.\....._-.“. P
kmrin
L] e mTn s e, e
nal et e
h T e
-
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For an index or other document with two columns of
text, where the text continues from the left-hand
column to the right-hand column and then to the
next page, all in sequence (also known as “snaking
columns” of text), use page styles (with two
columns). If the title of the document (on the first
page) is full-page width, put it in a single-column
section.

For a newsletter with complex layout, two or three
columns on the page, and some articles that
continue from one page to some place several
pages later, use page styles for basic layout. Place
articles in linked frames and anchor graphics to
fixed positions on the page if necessary.

For a document with terms and translations to
appear side-by-side in what appear to be columns,
use a table to keep items lined up, and so you can
type in both “columns”.
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Creating headers and footers

A header is an area that appears at the top of a page. A footer appears at the bottom of the page.
Information such as page numbers inserted into a header or footer displays on every page of the
document with that page style.

Inserting a header or footer
To insert a header, you can either:
* Choose Insert > Header > Default (or the page style, if not Default), or

* Hover the mouse over the top of the text area until the Header marker appears (Figure 23),
and then click on the +.

What IS Writer?ﬂ [Header (OOoPageStyle) 'l']

Writer is the word processor component of LibreOffice. In addition to the usual features of a word
processor (spelling check, thesaurus, hyphenation, autocorrect, find and replace, automatic
generation of tables of contents and indexes, mail merge and others), Writer provides these

Figure 23: Header marker at top of text area

After a header has been created, a down-arrow appears on the header marker. Click on this arrow
to drop down a menu of choices for working with the header (Figure 19).

Creating headers and fﬂoterSﬂ Header (OOoPageStyle) w»
. Format Header...
A header is an area that appears at the top of a page. A footer appears at the  gorder and Background...

Information such as page numbers inserted into a header or footer displays @  Delete Header...
document with that page style.

Figure 24: Header menu

To format a header, you can use either the menu item shown in Figure 19 or Format > Page >
Header. Both methods take you to the same tab on the Page Style dialog.

Inserting header and footer contents

Other information such as document titles and chapter titles is often put into the header or footer.
These items are best added as fields. That way, if something changes, the headers and footers are
updated automatically. Here is one common example.

To insert the document title into the header:
1) Choose File > Properties > Description and type a title for your document.
2) Add a header (Insert > Header > Default).
3) Place the cursor in the header part of the page.

4) Choose Insert > Fields > Title. The title should appear on a gray background (which does
not show when printed and can be turned off).

5) To change the title for the whole document, go back to File > Properties > Description.
Fields are covered in detail in Chapter 14, Working with Fields, in the Writer Guide.

For more about headers and footers, see Chapter 4, Formatting Pages, and Chapter 6,
Introduction to Styles, in the Writer Guide.
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Numbering pages

Displaying page nhumbers
To automatically display page numbers:
1) Insert a header or footer, as described in “Creating headers and footers” above.

2) Place the cursor in the header or footer where you want the page number to appear and
choose Insert > Fields > Page Number.

Including the total number of pages
To include the total number of pages (as in “page 1 of 127):
1) Type the word “page” and a space, then insert the page humber as above.

2) Press the space bar once, type the word “of” and a space, then choose Insert > Fields >
Page Count.

The Page Count field inserts the total number of pages in the document, as shown
on the Statistics tab of the document’s Properties window (File > Properties). If

Note you restart page numbering anywhere in the document, then the total page count
may not be what you want. See Chapter 4, Formatting Pages, in the Writer Guide
for more information.

Restarting page nhumbering

Often you will want to restart the page numbering at 1, for example on the page following a title
page or a table of contents. In addition, many documents have the “front matter” (such as the table
of contents) numbered with Roman numerals and the main body of the document numbered in
Arabic numerals, starting with 1.

You can restart page numbering in two ways.

Method 1:
1) Place the cursor in the first paragraph of the new page.
2) Choose Format > Paragraph.
3) On the Text Flow tab of the Paragraph dialog (Figure 21 on page 21), select Breaks.
4) Select Insert and then With Page Style and specify the page style to use.
5) Specify the page number to start from, and then click OK.

Method 1 is also useful for numbering the first page of a document with a page
. number greater than 1. For example, you may be writing a book, with each chapter
Tip in a separate file. Chapter 1 may start with page 1, but Chapter 2 could begin with
page 25 and Chapter 3 with page 51.

Method 2:
1) Insert > Manual break.
2) By default, Page break is selected on the Insert Break dialog (Figure 25).
3) Choose the required page Style.
4) Select Change page number.
5) Specify the page number to start from, and then click OK.
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Figure 25: Restarting page numbering after a manual page break

Changing page margins
You can change page margins in two ways:
* Using the page rulers—quick and easy, but does not have fine control
* Using the Page Style dialog—can specify margins to two decimal places

If you change the margins using the rulers, the new margins affect the page style
and will be shown in the Page Style dialog the next time you open it.

Because the page style is affected, the changed margins apply to all pages using
that style.

Note

To change margins using the rulers:

1) The gray sections of the rulers are the margins. Put the mouse cursor over the line
between the gray and white sections. The pointer turns into a double-headed arrow.

2) Hold down the left mouse button and drag the mouse to move the margin.

S =S

g

Figure 26: Moving the margins

Caution The small arrowheads on the ruler are used for indenting paragraphs. They are often
in the same place as the page margins, so you need to be careful to move the margin
marker, not the arrows.

To change margins using the Page Style dialog:
1) Right-click anywhere in the text area on the page and select Page from the pop-up menu.
2) Onthe Page tab of the dialog, type the required distances in the Margins boxes.
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Adding comments to a document

Authors and reviewers often use comments (formerly called “notes”) to exchange ideas, ask for
suggestions, or mark items needing attention.

To insert a comment in the text, place the cursor in the place the comment refers to and choose
Insert > Comment or press Ctrl+Alt+C. The anchor point of the comment is connected by a dotted
line to a box on the right-hand side of the page where you can type the text of the comment. Writer
automatically adds at the bottom of the comment the author’s name and a time stamp indicating
when the comment was created. Figure 27 shows an example of text with comments from two
different authors.

Mote sample
riter document has been vastly improved in
000, notes are now displayed at the side of
: user who created them. To insert a note in >
1 the text the note refers to and select -
he anchor, point of the note is connected by _~~ Cello Suite #1
le of the page Where you can type yoar BWW1007
ttom the author of the note as well as a Prelude
created. <ref> shows an example of text Allemande
Minuets
-onfigure the name you want to appear in Sarabande
it. Courante
nt, each author will be ahtomaticalljr Gigue
Jahan Sebastian Bach
Taday, 23:37 =

Figure 27: Example of comments

Choose Tools > Options > User Data to configure the name you want to appear in the Author field
of the comment, or to change it.

If more than one person edits the document, each author is automatically allocated a different
background color.

Right-clicking on a comment pops up a menu where you can delete the current comment, all the
comments from the same author, or all the comments in the document. From this menu, you can
also apply some basic formatting to the text of the comment. You can also change the font type,
size, and alignment from the main menu.

To navigate from one comment to another, open the Navigator (F5), expand the Comments
section, and click on the comment text to move the cursor to the anchor point of the comment in
the document. Right-click on the comment to quickly edit or delete it.

You can also navigate through the comments using the keyboard. Use Ctrl+Alt+Page Down to
move to the next comment and Ctrl+Alt+Page Up to move to the previous comment.

Creating a table of contents

Writer’s table of contents feature lets you build an automated table of contents from the headings
in your document. Before you start, make sure that the headings are styled consistently. For
example, you can use the Heading 1 style for chapter titles and the Heading 2 and Heading 3
styles for chapter subheadings.
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Although tables of contents can be customized extensively in Writer, often the default settings are
all you need. Creating a quick table of contents is simple:

1) When you create your document, use the following paragraph styles for different heading
levels (such as chapter and section headings): Heading 1, Heading 2, Heading 3, and so
on. These are what will appear in your table of contents.

2) Place the cursor where you want the table of contents to be inserted.
3) Choose Insert > Indexes and Tables > Indexes and Tables.
4) Change nothing in the Insert Index/Table dialog. Click OK.

If you add or delete text (so that headings move to different pages) or you add, delete, or change
headings, you need to update the table of contents.

To do this:

1) Place the cursor within the table of contents.
2) Right-click and choose Update Index/Table from the pop-up menu.

If you cannot place your cursor in the table of contents, choose Tools > Options >
Note LibreOffice Writer > Formatting Aids, and then select Enable in the Cursor in
protected areas section.

You can customize an existing table of contents at any time. Right-click anywhere in it and choose
Edit Index/Table from the pop-up menu. Chapter 12, Creating Tables of Contents, Indexes and
Bibliographies, of the Writer Guide describes in detail all the customizations you can choose.

Creating indexes and bibliographies

Indexes and bibliographies work in a similar way to tables of contents. Chapter 12, Creating Tables
of Contents, Indexes and Bibliographies, in the Writer Guide describes the process in detail.

In addition to alphabetical indexes, other types of indexes supplied with Writer include those for
illustrations, tables, and objects, and you can even create a user-defined index. For example, you
might want an index containing only the scientific names of species mentioned in the text, and a
separate index containing only the common names of species. Before creating some types of
indexes, you first need to create index entries embedded in your Writer document.

Working with graphics

Graphics in Writer are of three basic types:

* Image files, including photos, drawings, scanned images, and others
¢ Diagrams created using LibreOffice’s drawing tools
* Charts created using LibreOffice’s Chart component

See Chapter 11, Graphics, the Gallery, and Fontwork, in this book and Chapter 8, Working with
Graphics, in the Writer Guide.

Printing

See Chapter 10, Printing, Exporting, and E-mailing, in this book and Chapter 5, Printing, Exporting,
Faxing, and E-mailing, in the Writer Guide for details on previewing pages before printing, selecting
print options, printing in black and white on a color printer, printing brochures, and other printing
features.
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Using mail merge

Writer provides very useful features to create and print:
* Multiple copies of a document to send to a list of different recipients (form letters)
* Mailing labels
* Envelopes

All these facilities use a registered data source (a spreadsheet or database containing the name
and address records and other information). Chapter 11, Using Mail Merge, in the Writer Guide
describes the process.

Tracking changes to a document

You can use several methods to keep track of changes made to a document.

1) Make your changes to a copy of the document (stored in a different folder, or under a
different name, or both), then use Writer to combine the two files and show the differences.
Choose Edit > Compare Document. This technique is particularly useful if you are the
only person working on the document, as it avoids the increase in file size and complexity
caused by the other methods.

2) Save versions that are stored as part of the original file. However, this method can cause
problems with documents of non-trivial size or complexity, especially if you save a lot of
versions. Avoid this method if you can.

3) Use Writer's change marks (often called “redlines” or “revision marks”) to show where you
have added or deleted material, or changed formatting. Choose Edit > Changes > Record
before starting to edit. Later, you or another person can review and accept or reject each
change. Choose Edit > Changes > Show. Right-click on an individual change and choose
Accept Change or Reject Change from the pop-up menu, or choose Edit > Changes >
Accept or Reject to view the list of changes and accept or reject them. Details are in the

Writer Guide.
Not all changes are recorded. For example, changing a tab stop from align left to
Tip align right, and changes in formulas (equations) or linked graphics are not
recorded.

Using fields

Fields are extremely useful features of Writer. They are used for data that changes in a document
(such as the current date or the total number of pages) and for inserting document properties such
as name, author, and date of last update. Fields are the basis of cross-referencing (see below);
automatic numbering of figures, tables, headings, and other elements; and a wide range of other
functions—far too many to describe here. See Chapter 14, Working with Fields, in the Writer Guide
for details.

Linking to another part of a document

If you type in cross-references to other parts of a document, those references can easily get out of
date if you reorganize the order of topics, add or remove material, or reword a heading. Writer
provides two ways to ensure that your references are up to date, by inserting links to other parts of
the same document or to a different document:

* Hyperlinks
* Cross-references
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The two methods have the same result if you Ctrl+click the link when the document is open in
Writer: you are taken directly to the cross-referenced item. However, they also have major
differences:

The text in a hyperlink does not automatically update if you change the text of the linked
item (although you can change it manually), but changed text does automatically update in
a cross-reference.

When using a hyperlink, you do not have a choice of the content of the link (for example
text or page number), but when using a cross-reference, you have several choices,
including bookmarks.

To hyperlink to an object such as a graphic, and have the hyperlink show useful text such
as Figure 6, you need to give such an object a useful name (instead of a default name like
Graphics6), or use the Hyperlink dialog to modify the visible text. In contrast, cross-
references to figures with captions automatically show useful text, and you have a choice of
several variations of the name.

If you save a Writer document to HTML, hyperlinks remain active but cross-references do
not. (Both remain active when the document is exported to PDF.)

Using hyperlinks

The easiest way to insert a hyperlink to another part of the same document is by using the
Navigator:

1)
2)
3)
4)

5)
6)

Open the document containing the items you want to cross-reference.
Open the Navigator by clicking its icon, choosing View > Navigator, or by pressing F5.
Click the arrow next to the Drag Mode icon, and choose Insert as Hyperlink.

In the list at the bottom of the Navigator, select the document containing the item that you
want to cross-reference.

In the Navigator list, select the item that you want to insert as a hyperlink.

Drag the item to where you want to insert the hyperlink in the document. The name of the
item is inserted in the document as an active hyperlink.
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Figure 28: Inserting a hyperlink using the Navigator

You can also use the Hyperlink dialog to insert and modify hyperlinks within and between
documents. See Chapter 12, Creating Web Pages.
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Using cross-references

If you type in references to other parts of the document, those references can easily get out of date
if you reword a heading, add or remove figures, or reorganize topics. Replace any typed cross-
references with automatic ones and, when you update fields, all the references will update
automatically to show the current wording or page numbers. The Cross-references tab of the
Fields dialog lists some items, such as headings, bookmarks, figures, tables, and numbered items
such as steps in a procedure. You can also create your own reference items; see “Setting
References” in Chapter 14, Working with Fields, in the Writer Guide for instructions.

To insert a cross-reference to a heading, figure, bookmark, or other item:

1) Inyour document, place the cursor where you want the cross-reference to appear.

2) If the Fields dialog is not open, click Insert > Cross-reference. On the Cross-references
tab (Figure 29), in the Type list, select the type of item to be referenced (for example,
Heading or Figure). You can leave this page open while you insert many cross-references.

3)

Click on the required item in the Selection list, which shows all the items of the selected

type. In the Insert reference to list, choose the format required. The list varies according to
the Type. The most commonly used options are Reference (to insert the full text of a
heading or caption), Category and Number (to insert a figure number preceded by the
word Figure or Table, but without the caption text), Numbering (to insert only the figure or
table number, without the word “Figure” or “Table”), or Page (to insert the number of the
page the referenced text is on). Click Insert.
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Figure 29: The Cross-references tab of the Fields dialog
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Using bookmarks

Bookmarks are listed in the Navigator and can be accessed directly from there with a single mouse
click. You can cross-reference to bookmarks and create hyperlinks to bookmarks, as described
above.

1) Select the text you want to bookmark. Click Insert > Bookmark.

2) On the Insert Bookmark dialog, the larger box lists any previously defined bookmarks. Type
a name for this bookmark in the top box, and then click OK.
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insertpagenun

usedocproperties Cancel

Figure 30: Inserting a bookmark

Using master documents

Master documents are typically used for producing long documents such as a book, a thesis, or a
long report; or when different people are writing different chapters or other parts of the full
document, so you don’t need to share files. A master document joins separate text documents into
one larger document, and unifies the formatting, table of contents (TOC), bibliography, index, and
other tables or lists.

Yes, master documents do work in Writer. However, until you become familiar with them, you may
think that master documents are unreliable or difficult to use. See Chapter 13, Working with Master
Documents, in the Writer Guide.

Creating fill-in forms

A standard text document displays information: a letter, report, or brochure, for example. Typically
the reader may either edit everything or nothing in any way. A form has sections that are not to be
edited, and other sections that are designed for the reader to make changes. For example, a
guestionnaire has an introduction and questions (which do not change) and spaces for the reader
to enter answers.

Forms are used in three ways:
* To create a simple document for the recipient to complete, such as a questionnaire sent out
to a group of people who fill it in and return it.

* To link into a database or data source and allow the user to enter information. Someone
taking orders might enter the information for each order into a database using a form.

* To view information held in a database or data source. A librarian might call up information
about books.

Writer offers several ways to fill information into a form, including check boxes, option buttons, text
boxes, pull-down lists and spinners. See Chapter 15, Using Forms in Writer, in the Writer Guide.
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