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Introduction

This chapter covers the more advanced tools for working with text in Writer:
* The built-in language tools
* Advanced find-and-replace techniques, including wildcards
* Track changes and insert comments
* Footnotes and endnotes
* Linking to other parts of a document
* Line numbering

This chapter assumes that you are familiar with the basic text techniques described in Chapter 2,
Working with Text: Basics. We recommend that you also display formatting aids, such as end-of-
paragraph marks, tabs, breaks, and other items in Tools > Options > LibreOffice Writer >
Formatting Aids.

For information on formatting text (characters, paragraphs, lists), see Chapter 4.

Using built-in language tools

Writer provides some tools that make your work easier if you mix multiple languages within the
same document or if you write documents in various languages:

» Paragraph and character styles

* The functions in Tools > Language

* Language settings in Options

* The functions available on the status bar

The main advantage of changing the language for a text selection is that you can then use the
correct dictionaries to check spelling and apply the localized versions of AutoCorrect replacement
tables, thesaurus, and hyphenation rules. A grammar checking dictionary may also be available for
the selected language.

You can also set the language for a paragraph or a group of characters as None (Do not check
spelling). This option is especially useful when you insert text such as web addresses or
programming language snippets that you do not want to check for spelling.

Using paragraph and character styles

Changing the language on the Font tab of the Paragraph Styles dialog (Figure 1) will change the
language for all paragraphs that use that paragraph style. If you will have whole paragraphs in
different languages in a single document, you can use a different paragraph style for each
language. For example, you might define Text Body-EN and Text Body-FR in a document
containing paragraphs in both English and French.

You can also set certain paragraphs to be checked in a language that is different from the
language of the rest of the document by putting the cursor in the paragraph and changing the
language on the Status Bar.

See Chapter 9, Working with Styles, for information on how to manage the language settings of a
style.
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] - Paragraph Style: Heading 2

Highlighting  Outline & Numbering ~ Tabs  DropCaps  Area  Transparency  Borders
Organizer  Indents & Spacing  Alignment  TextFlow | Font | Font Effects  Paosition

Family Typeface Size:

LLiberation Sans Bold 14 pt

Liberation Sans Regular 10 pt

Liberation Sans Narrow Bold 10.5 pt

| Liberation Serif halic 1 pt

Libian SC Bold Italic 12 pt

LiHei Pro 13 pt

Linux Biolinum G 14 pt

Linux Libertine Display G 15 pt

Linux Libertine G 16 pt

LiSang Pro 18 pt

Lucida Grande 20 pt

I iiminari 22 nt

Language: English (USA) H

Figure 1: Setting the language for a paragraph style

Using Tools > Language

You can set the language for the whole document, for individual paragraphs, or even for individual
words and characters, from Tools > Language on the Menu bar.

* For Selection applies a specified language to the selected text. If the language you wish to
apply is not listed in the submenu, choose More... to open the Character dialog.

* For Paragraph applies the specified language to the paragraph where the cursor is
located. If the language you wish to apply is not listed in the submenu, choose More...

* For all Text applies the specified language to all of the document, including text inserted
after making the change. If the language you wish to apply is not listed in the submenu,
choose More...

Window Help

Spelling... {+36; |rkingWithText 2 TRB_CW_JHW_20200614.o0dt
Automatic Spell Checking {F7 _ 5]

&)~ === - B
Thesaurus... Hr7 _ Q a] @ L" = @ \ @
Language > For Selection > English (Australia)
Word Count... For Paragraph |2 ' English (USA)

For All Text > None (Do not check spelling)

AutoCorrect X Reset to Default Language
Autngxt... Hr3 Hyphenation... Mo
Redact
Auto-Redact More Dictionaries Online...

Chapter Numbering...
Line Numbering...
Footnotes and Endnotes...

The Reset to Default Language option on the submenu is the fastest way to return a selection,
paragraph, or all text to the default language set in Tools > Options (described below).

Using language settings in Options

Another way to change the language of a whole document is to use Tools > Options > Language
Settings > Languages. In the Default languages for documents section (Figure 2), you can
choose a different language for all the text that is not explicitly marked as a different language.
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A Caution

A change in the default language from the Options dialog is a general change of
settings of LibreOffice and will therefore apply to all the documents created in the
future. If you want to change the language for the current document only, be sure to
select the For the current document only option (see Figure 2).

Default languages for documents

Western *& English (USA) v

Dgsian Default - Chinese (simplified)

O

[] Complex text layout {CTL) Default -

] For the current document only

Enhanced language support
[] 1gnore system input language

Figure 2: Options available in the Languages settings

g Note

The spelling checker works only for those languages in the list that have a checkmark
symbol next to them. If you do not see this symbol next to your preferred language,
you can install the dictionary using Tools > Language > More dictionaries online.

Using the status bar

The language used for checking spelling is also shown in the status bar, next to the page style in
use. You can change the language for the paragraph or the entire document; click the language in
the status bar to pop up a menu of choices.

an on the men English (LK) tastest way to
to the default i ane
* [English (USA) | English (UK)
Mone (Do not chedk spelling) English (USA)
Reset to Default Language None (Do not check speling)
iesaurus | Mere. Reset to Default Language

Set Language for Paragraph  » Mare. ..

English (LSA)

Figure 3: Language choices on the status bar

The Reset to Default Language option on the menu and submenu is the fastest way to return a
paragraph or the entire document to the default language set in Tools > Options (described
above).

Advanced find and replace techniques

In addition to finding and replacing words and phrases (described in Chapter 2), you can use
Writer's Find & Replace dialog to find and replace paragraph styles and text formatting..
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Find and replace paragraph styles

Combining material from several sources may result in unwanted paragraph styles in your
document. To quickly change all the paragraphs from one (unwanted) style to another (preferred)
style:

1) Onthe Find & Replace dialog with Other Options displayed, select Paragraph Styles. (If
you have text formats or attributes specified, this option is labeled Including Styles. Select
No Format to remove any attributes and return the option to Paragraph Styles.) The Find
and Replace boxes now contain a list of paragraph styles in use in the document.

2) Select the styles you want to search for and replace.
3) Click Find, Find All, Replace, or Replace All.
Repeat steps 2 and 3 for each style that you want to replace.

Find and replace text formatting

To clear any previous search criteria, place the cursor in the Find box and then click the No
Format button. To clear the selected Replace options, place the cursor in the Replace box and
click the No Format button.

Unlike Find & Replace > Paragraph Styles described above, the formats or attributes to be
searched do not appear inside the Find or Replace box. The formats or attributes to be found or
replaced appear below the Find and Replace boxes (see Figure 4). Further, clicking on the caret
does not bring up options.

Find & Replace X

Find: v
Arial, 14 pt, Italic Jjlb——— Selections appear below the Find: box
O Match case (] Whole words only

Replace: v

Find All Find Previous Find Next Replace Replace All

= Other options
t selection only O Replace backwards
O e R A T MR

[ Regular expressions L] Including Styles \
[ Similarity search Similarities...

Check here to include formats ip character
[[] Comments | and paragraph styles. Leave unchecked to
e only include direct (manual) for[matting.

Attributes... No Format

Help Close

Figure 4: Find & replace format

1) To find a type of formatting in the document, ensure Other options is selected.

2) Click the Format button. Select a format from any of the tabs (for example: bold, 14 pt,
Spacing above paragraph).
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3) To find this format that has only been applied by direct formatting, leave the Including
Styles box unchecked. To find this format also applied inside a character or paragraph
style, check the Including Styles box.

4) Choose Find All to have all formats found highlighted. Choose Find Previous or Find
Next to find one format instance at a time.

5) To replace the chosen format, click inside the Replace box, then choose Format and
choose a replacement from the tabbed options.

6) Replace the formats one at a time using Find Previous > Replace or Find Next >
Replace. Use Replace All to change all formats at once.

If you want to change the formatting for a specific word or phrase in a document:
1) Type the word or phrase in the Find box.

2) Inthe Replace box, type in the new text you want to use and choose the formats you would
like to change. However, if you want to keep the same word or phrase and only change its
format, ensure you also type the word or phrase in the Replace box. Otherwise, Writer will
remove the word or phrase from the document.

3) Replace the words and formats one at a time using Find Previous > Replace or Find Next
> Replace. Use Replace All to change all words and formats at once.

Similarity search

This option finds terms that are similar to the Find: text. For example, a similarity search can find
words that differ by two characters.

Select Similarity search and click the Similarities button to open a dialog in which you can modify
the text search by length and number of characters different from the search term (see Figure 5).

Exchange characters
Enter the number of characters in the search term that can be exchanged. For example, if
you specify 2 exchanged characters, "black™ and "crack” are considered similar.

Add characters
Enter the maximum number of characters by which a word can exceed the number of
characters in the search term.

Remove characters
Enter the number of characters by which a word can be shorter than the search term.

Combine
Searches for a term that matches any combination of the similarity search settings.

Find: Once
[ ] Similarity Search

Exchange characters: 2 <]
Replace: Add characters: 2 ()

Remove characters: |2 12

Find All . Replace Replace All
| 4 Combine P P
Other optior
Help e oK J Cancel
ent s§ ¢ Backwards
ar expressions [~ "Paragraph St
Similarity search Similarities...
Comments

Figure 5: Similarity search dialog
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Search with wildcards and regular expressions

A wildcard is a special character that represents one or more unspecified characters. Wildcards
make text searches more powerful but often less specific. LibreOffice enables you to use
combinations of characters known as regular expressions which are more specific than simple
wildcards but less so than a literal string. Regular expressions are very powerful but not very
intuitive. They can save time and effort by combining multiple finds into one.

Table 1 shows a few of the regular expressions used by LibreOffice.
0)- Tip

The online help describes many more regular expressions and their uses.

To use wildcards and regular expressions when searching and replacing:
1) On the Find & Replace dialog, click Other Options to see more choices. On this expanded
dialog, select the Regular expressions option.

2) Type the search text, including the wildcards, in the Search for box and the replacement
text (if any) in the Replace with box. Not all regular expressions work as replacement
characters; the line break (\n) is one that does work.

Click Find, Find All, Replace, or Replace All (not recommended).

3)
Z Note

To search for a character that is defined as a wildcard, type a backslash (\) before the
character to indicate that you are using it literally. For example, to find the text $5. 00,
you would conduct a search using \$5\ . 00.

Table 1: Examples of search wildcards (regular expressions)

To find e th'S. Examples and comments
expression
Any single character . (a period or b.d finds bad, bud, bid, and bed.
full stop)
One of the specified [xyz] bliu]n finds bin and bun.
characters
Any single character in [X-y] [r-tleed finds reed, seed, and teed; ranges must be in
this range alphabetically ascending order.
Any single character [*X] p[*a]st finds post and pest, but not past.
except the characters
inside the brackets
The beginning of a word \<start \<log finds logbook and logistics, but not catalog.
The end of a word end\> log\> finds catalog, but not logistics.
A paragraph marker $ Does not work as a replacement character. Use \n
instead.
A line break \n Finds a line break that was inserted with Shift+Enter.
When used as a replacement character, it inserts a
paragraph marker.
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Tracking changes to a document

You can use several methods to keep track of changes made to a document.

* Make your changes to a copy of the document (stored in a different folder, under a different
name, or both), then use Writer to compare the two files and show the changes you made.
This technique is particularly useful if you are the only person working on the document, as
it avoids the increase in file size and complexity caused by the other methods.

* Save versions that are stored as part of the original file. However, this method can cause
problems with large or complex documents, especially if you save a lot of versions. Avoid
this method if you can.

* Use Writer's change marks (often called “redlines” or “revision marks”) to show added or
deleted material or changed formatting. Later, you or another person can review and accept
or reject each change.

£7] Note

Not all changes are recorded. For example, changing a tab stop from align left to align
right and changes in formulas (equations) or linked graphics are not recorded.

Preparing a document for review

When you send a document to someone else to review or edit, you may want to prepare it first so
that the editor or reviewer does not have to remember to turn on the revision marks. After you have
protected the document, any subsequent user must enter the correct password in order to turn off
protection or accept or reject changes.

1) Open the document. Check whether it contains multiple versions by clicking File >
Versions. If multiple versions are listed, save the current version as a separate document
with a different name and use this new document as the review copy.

2) With the review copy open, make sure that change recording is turned on. The Edit >
Track Changes > Record menu item is highlighted when recording is turned on.

3) Click Edit > Track Changes > Protect. On the Enter Password dialog, type a password
(twice) and click OK.

An alternative to steps 2 and 3 above is to choose File > Properties > Security tab,
select the Record changes option, then click Protect and enter the password.

Track Changes menu and toolbar

In addition to the Track Changes menu (Figure 7), Writer provides a convenient toolbar (Figure 6)
that includes buttons for the same functions.

Track Changes v x
AR EERRFEBBRUE RBE
1 2 34 56 7 8 9 10 11 12 13 14 15 16

Figure 6: Track Changes toolbar

1 Show Track Changes 5 Accept Track Change 9 Accept & go to Next 13 Insert Track Change

Comment
2 Record Track Changes 6 Reject Track Change 10 Reject & go to Next 14 Protect Track Changes
3 Previous Track Change 7 Accept All 11 Manage Track Changes 15 Compare Documents
4 Next Track Change 8 Reject All 12 Insert Comment 16 Merge Documents
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%, Track Changes » | @ Record Ctrl+Shift+C |
Comment ¥ Q Show
S —| Manage...
Reference b Previous
e Mext

|_>fi—: Exchange Database... =
@f Accept All
Direct Cursor Mode . ¢

~  Edit Mode Ctrl+Shift+M o

‘= Protect...

Compare Document...

Merge Document... |

Figure 7: Track Changes menu

Recording changes

To modify the default settings, see Chapter 20, Setting up Writer, for instructions on setting up how
changes will be displayed.

1) To begin tracking (recording) changes, click Edit > Track Changes > Record. To show or
hide the display of changes, click Edit > Track Changes > Show.

‘:@:‘ Tip

Hold the mouse pointer over a marked change; you will see a Help Tip showing the
type of change, the author, date, and time of day for the change. If Extended Tips are
enabled, you will also see any comments recorded for this change.

2) To enter a comment on a marked change, place the cursor in the area of the change and
then click Edit > Track Changes > Comment.

In addition to being displayed as an extended tip, the comment is also shown in the list in
the Manage Changes dialog (Figure 9).

To move from one marked change to the next, use the arrow buttons. If no comment has
been recorded for a change, the Text field is blank.

3) To stop recording changes, click Edit > Track Changes > Record again.
00 Tip

See also “Adding other comments” on page 14 for a way to annotate text that is not
associated with a recorded change.

Tracking changes to a document | 11



O ® Comment: Deletion

: Contents i
Author Jean Hollis Weber, 14/06/2020 16:26:19 |‘
Text
A comment on the change.

Help - Cancel [LOK
|

i:igure 8: Inserting a comment dUrTng change recording

Accepting or rejecting changs
To accept or reject recorded changes, use any of these tools:

» Track Changes toolbar (Figure 6)
* Items on the Track Changes menu (Figure 7)
* Right-click (context) menu
* Manage Changes dialog
The results of accepting or rejecting a change are as follows:

e Accept: incorporates the alteration into the document and removes the change indication
marking.

* Reject: reverts the document to its original state and removes the change indication
marking.

Track Changes menu and toolbar
For quick and easy accepting and rejecting of changes, you can use the Track Changes
toolbar (Figure 6), which includes buttons for the same functions as appear on the Edit >
Track Changes submenu (Figure 7). To enable the Track Changes toolbar, click View >
Toolbars > Track Changes on the Menu bar. You can dock this toolbar in a convenient
place or leave it floating.

Right-click (context) menu
1) |If recorded changes are not showing, click Edit > Track Changes > Show Changes.

2) Hover the mouse pointer over a recorded change. A box appears with information about the
type of change, who made it, and the date and time.

3) Right-click the changed text. In the context menu, choose Accept Change or Reject
Change.

Manage Changes dialog
1) Click Edit > Track Changes > Manage. The Manage Changes dialog (Figure 9) opens,
showing changes that have not yet been accepted or rejected.

2) When you select a change in the dialog, the change itself is highlighted in the document, so
you can see what the editor changed.

3) Click Accept or Reject to accept or reject the selected change. You can also click Accept
All or Reject All if you do not want to review the changes individually.
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To show only the changes of certain people or only the changes on specific days or various other
restrictions, use the Filter tab (Figure 10) on the Manage Changes dialog. After specifying the filter
criteria, return to the List tab to see those changes that meet your criteria.

& [ ] Manage Changes
[ List | Filter
\Action |Author |Date Comment
& Jean Hollis Weber 15/06/2020 10:07:42
LH Jean Hollis Weber 15/06/2020 10:07:44
8 Jean Hollis Weber 15/06/2020 10:07:22 Tab no longer exists.
ir Jean Hollis Weber 31/05/2020 11:56:57

Figure 9: The List tab of the Manage Changes dialog

o ® Manage Changes
List | Filter
Date:
earlier than E
15/06/2020 +  10:05 BREC]
and 2]
| Author: .
Jean Hollis Weber E
Action:
Insertion E
Comment:
|
| S
Accept Reject Accept All Reject Al . Close

Figure 10: The Filter page of the Manage Changes dialog

Comparing documents

Sometimes reviewers may forget to record the changes they make. You can find the changes if you
compare the original document and the one that is edited. To compare them:

1) Open the edited document. Select Edit > Track Changes > Compare Document.
2) Afile browser dialog opens. Select the original document and click Open.

Writer finds and marks the changes and displays the Manage Changes dialog. From this point, you
can go through and accept or reject changes procedure as described earlier.

Tracking changes to a document | 13



Merging modified documents

The processes discussed to this point are effective when you have one reviewer at a time.
Sometimes, however, multiple reviewers all return edited versions of a document. Writer provides a
facility to merge documents containing tracked changes into the original document, but the
condition for making this work is very specific: the edited documents may differ only and
exclusively in the recorded changes — all other original text must be identical.

To merge documents, all of the edited documents (but not the original document) need to have
recorded changes in them.

1) Open the original document into which you want to merge all copies.
2) Click Edit > Track Changes > Merge Document. A file selection dialog opens.

3) Select the edited copy of the document to be merged with the first. If there have been no
subsequent changes to the original document, the copy is merged into the original.

If any changes have been made to the original document, an error dialog appears that
informs you that the merge is unsuccessful.

4) After the documents merge, you will see the recorded changes from the copy in the original
document.

5) Repeat until all copies are merged.
All recorded changes are now included in the open copy. Save this file under another name.

Adding other comments

Writer provides another type of comment, which authors and reviewers use to exchange ideas, ask
for suggestions, or mark items needing attention.

You can select a block of text, including multiple paragraphs, to be highlighted for a comment, or
you can insert a comment at a single point. To insert a comment, select the text, or place the
cursor in the place the comment refers to. Right-click and choose Insert > Comment or press
Ctrl+Alt+C.

The anchor point of the comment is connected by a dotted line to a box on the right-hand side of
the page where you can type the text of the comment. A Comments button is also added to the
right of the horizontal ruler (see Figure 11); you can click this button to toggle the display of the
comments on and off.

Writer automatically adds the author’s name and a time stamp indicating when the comment was
created. Select Tools > Options > LibreOffice > User Data to enter or change the name you
want to appear in the Author field of the comment.

When you are finished with your comment, click somewhere else on a page of your document.
Otherwise, you will not be able to move away from the comment box.

If more than one person edits the document, each author is automatically allocated a different
background color. Figure 11 shows an example of text with comments from two different authors. If
an author selects text that overlaps another author’'s comments, then the comments from the
second author are nested with those of the first author.
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[This comment is nested due to
[ overlapping text selection.

multiple paragraphs, or a single point may be selected

a comment select the text, or p:ﬂ‘at:e & CUrsor in the Comment on selected text.

> Comment or press Cir+AM+C. The anchnr‘pnint of

box on the right-hand side of the page where you can

lly adds at the boftom of the comment the author's Joe Soap -

nment was created.

' Today, 20:27

A single point comment.

Figure 11: Comments in LibreOffice

Right-click a comment to open a context menu where you can delete the current comment, all the
comments from the same author, or all the comments in the document. From this menu, you can
also choose Format all comments to open a dialog to apply some basic formatting to the text of
the comment. You can also change font type, size, and alignment from the Menu bar.

To navigate from one comment to another, open the Navigator (F5), scroll to find and expand the
Comments section. Double-click the comment text to move the cursor to the anchor point of the
comment in the document. Right-click the comment to quickly edit or delete it.

You can also navigate the comments using the keyboard. Use Ctrl+Alt+Page Down to move to the

next comment and Ctrl+Alt+Page Up to move to the previous comment.

To print the comments in a document, choose one of the options below from the print dialog (File >

Print > LibreOffice Writer tab).

General LibreOffice Writer

Contents
Page background
Images and other graphic chjects
[ ] Hidden text
(] Text placeholders
Form controls

Comments;

Color Meone (document only)
Comments only
Place at end of document
Place at end of page
Place in margins

L] Print text i
Pages:
L] Print auto

=

Figure 12: Options for printing comments
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Using footnotes and endnotes

Footnotes appear at the bottom of the page on which they are referenced. Endnotes are collected
at the end of a document.

To work effectively with footnotes and endnotes, you need to:

* Insert footnotes and define their format

» Define the location of footnotes on the page. (To change the default values such as color
and line style, see Chapter 5, Formatting Pages: Basics).

Inserting footnotes and endnotes

To insert a footnote or an endnote, put the cursor where you want the footnote or endnote marker
to appear. Then select Insert > Footnote and Endnote from the Menu bar and choose Footnote
or Endnote, or click the Insert Footnote or Insert Endnote button on the Standard toolbar.

A footnote or endnote marker is inserted in the text and, depending on your choice, the cursor is
relocated either to the footnote area at the bottom of the page or to the endnote area at the end of
the document. Type the footnote or endnote content in this area.

To change the default Footnote/Endnote settings, go to Tools > Footnotes and Endnotes.

To bring up the Insert Footnote/Endnote dialog, choose Insert > Footnote and Endnote >
Footnote or Endnote (Figure 13). Here you can choose whether to use the automatic numbering
sequence specified in the footnote settings or choose a custom number.

L S

Insert Footnote/Endnote

Humbering

Type
{;_} Footnote
") Endnote

o[ o

Figure 13: Inserting a footnote/endnote

You can edit an existing footnote or endnote in the same way you edit any other text.

To delete a footnote or endnote, delete the footnote marker. The contents of the footnote or
endnote are deleted automatically, and the numbering of other footnotes or endnotes is adjusted
automatically.

Defining the format of footnotes/endnotes

To format the footnotes themselves, click Tools > Footnhotes and Endnotes. On the
Footnotes/Endnotes Settings dialog (Figure 14), choose preferred settings.
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}:igure 14: Defining footnote formatting

Linking to another part of a document

Cross-references to other parts of the document can easily get out of date if you reorganize the
order of topics, add or remove material, or reword a heading. Writer provides two ways to ensure
that references are up to date:

Hyperlinks: a link to another document
Cross-references: a link to other parts of the same document

The two methods have the same result: if you Ctrl+click the link when the document is open in
Writer, you are taken directly to the cross-referenced item. However, they also have major
differences:

* The text in a hyperlink does not automatically update if you change the text of the linked
item (although you can change it manually), but changed text does automatically update in
a cross-reference.

* When using a hyperlink, you do not have a choice of the content of the link (for example
text or page number), but when using a cross-reference, you have several choices,
including bookmarks.

* To hyperlink to an object such as a graphic, and have the hyperlink show useful text such
as Figure 6, either give such an object a useful name instead of leaving it as the default
name (“Graphics6”) or use the Hyperlink dialog to modify the visible text. In contrast, cross-
references to figures with captions automatically show useful text, and you have a choice of
several variations of the name.

* If you save a Writer document to HTML, hyperlinks remain active but cross-references do
not. (Both remain active when the document is exported to PDF.)

Using cross-references

To ensure that references update if you reword a heading, caption, or other linked item, use
automatic cross-references. For details, see “Using automatic cross-references” in Chapter 17,
Fields.
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Using bookmarks

Bookmarks are listed in the Navigator and can be accessed directly from there with a single mouse
click. In HTML documents, bookmarks are converted to anchors that you can jump to by hyperlink.
For more about bookmarks, see “Using bookmarks” in Chapter 17, Fields.

Using hyperlinks

When you type text (such as website addresses or URL) that can be used as a hyperlink, and then
press the spacebar or the Enter key, Writer automatically creates the hyperlink and applies
formatting to the text (usually a color and underlining).

If this does not happen, you can enable this feature using Tools > AutoCorrect > AutoCorrect
Options. Select the Options tab and check the URL Recognition option.

You can also insert hyperlinks using the Navigator and the Hyperlink dialog, and you can modify all
hyperlinks using the Hyperlink dialog, as described in this section.

Z Note

Hyperlinks between documents can be set as relative or absolute, using the Save
URLSs relative to option in Tools > Options > Load/Save > General.

Relative linking is only possible when the document you are working on and the link
destination are on the same drive, and you need to create the same directory structure
on your hard disk as will apply on the destination website.

LibreOffice uses absolute path names internally, so when you move your mouse
cursor over a hyperlink, the tooltip displays the absolute reference even when it is set
to be a relative link.

Inserting hyperlinks using the Navigator

The easiest way to insert a hyperlink to another part of the same document is by using the
Navigator:

1) Open the document containing the items you want to cross-reference.

2) Open the Navigator (Figure 15) by clicking its icon in the Standard toolbar, choosing View
> Navigator, pressing F5, or selecting the Navigator Tab on the open Sidebar.

3) Click the arrow next to the Drag Mode icon, and ensure Insert as Hyperlink is chosen.

4) Inthe list at the bottom of the Navigator, select the document containing the item that you
want to cross-reference.

5) Inthe Navigator list, select the item that you want to insert as a hyperlink.

6) Drag the item to where you want to insert the hyperlink in the document. The name of the
item is inserted in the document as an active hyperlink.
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Figure 15: Inserting a hyperlink using the Navigator

Inserting hyperlinks using a dialog

To display the Hyperlink dialog (Figure 16), click the Hyperlink icon on the Standard Toolbar or
choose Insert > Hyperlink from the Menu bar. To turn existing text into a link, select it before
opening the dialog.

[ JoN ] Hyperlink
| @ Hyperlink Type
© Web () FTP
Internet
URL: www.libreoffice.org| E
Mail
Document Further Settings
@ Frame: a Form;  Text B e
New Text: www.libreoffice.org
Document
Name:
Help ok Apoy Close Reset

Figure 16: Hyperlink dialog showing details for Internet links
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On the left hand side, select one of the four types of hyperlink:

* Internet: a web address, normally starting with http://

* Mail: an email address.

* Document: another document or to another place in the presentation.
* New document: the hyperlink creates a new document.

The top right part of the dialog changes according to your choice for the hyperlink type. A full
description of all the choices, and their interactions, is beyond the scope of this chapter. The most
common choices used in Writer documents are as follows.

For an Internet hyperlink, choose the type of hyperlink (Web or FTP) and enter the required web
address (URL).

For a Mail hyperlink, specify the receiver address and the subject.

For a Document hyperlink, specify the document path (the Open File button opens a file browser);
leave this blank if you want to link to a target in the same document. Specify the target in the
document (for example a figure or table). Click the Target icon to open the Navigator where you
can select the target, or if you know the name of the target, you can type it into the box.

For a New Document hyperlink, specify whether to edit the newly created document immediately or
just create it (Edit later) and the type of document to create (text, spreadsheet, and so on). For a
text document, Edit now is the more likely choice. The Select Path button opens a folder picker.

The Further settings section in the bottom right part of the dialog is common to all the hyperlink
types, although some choices are more relevant to some types of links.

* Set the value of Frame to determine how the hyperlink will open. This applies to documents
that open in a Web browser.

* Form specifies if the link is to be presented as text or as a button.
» Text specifies the text that will be visible to the user.

* Name is applicable to HTML documents. It specifies text that will be added as a NAME
attribute in the HTML code behind the hyperlink.

« Events button: this button will be activated to allow LibreOffice to react to events for which
the user has written some code (macro). This function is not covered in this book.

Editing hyperlinks

To edit a hyperlink, click anywhere in the link text and then open the Hyperlink dialog by clicking
the Hyperlink icon on the Standard Toolbar or choosing Edit > Hyperlink from the Menu bar.
Make your changes and click Apply. If you need to edit several hyperlinks, you can leave the
Hyperlink dialog open until you have edited all of them. Be sure to click Apply after each one.
When you are finished, click Close.

The standard (default) behavior for activating hyperlinks within LibreOffice is to use Ctrl+click. This
behavior can be changed in Tools > Options > LibreOffice > Security > Options by deselecting
the option Ctrl-click required to follow hyperlinks. If clicking in your links activates them, check
that page to see if the option has been deselected.

To change the color of hyperlinks, go to Tools > Options > LibreOffice > Application Colors,
scroll to Unvisited links and/or Visited links, select those options, pick the new colors and click
OK. Caution: this will change the color for all hyperlinks in all components of LibreOffice—this may
not be what you want.

The default character style for hyperlinks is Internet Link. In Writer and Calc (but not Draw or
Impress), you can change the Internet link character style or define and apply new styles to
selected links.
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Line numbering

Line numbering puts line numbers in the margin. It is often used in legal documents, poetry, and
lists of programming code. Writer can insert line numbers in an entire document or in selected
paragraphs. Line numbers are included when you print the document. You can also add a
separator between line numbers. Figure 17 shows an example with numbering on every line.

CoO=ln M Lard =

Line numbering

Line numbering puts line numbers in the ma
also printed. Figure 1 shows an example wit

Click Toels = Line Numbering and select tt
Line Numbering dialog (Figure 2). Then click

You can choose how many lines are numbet
numbering type, and whether numbers resta
choose) can be set on a different numbering

Figure 17: Line numbering example

You can choose how many lines are numbered (for example, every line or every tenth line), the
numbering type, and whether numbers restart on each page. In addition, a text separator (any text
you choose) can be set on a different numbering scheme (one every 12 lines, for example).

To add line numbers to an entire document:

1) Click Tools > Line Numbering and select the Show numbering option in the top left
corner of the Line Numbering dialog (Figure 18).

2) Then select any options you want and click OK.

[ ] Line Numbering
4 Show numbering
View
Character style:  Line Numbering 7]
Format: 123, .. ‘J
Position: Left d
Spacing: 0.50 cm I_i,l
Interval: 5 IE_I lines
Separator Count
I Text: 2 Blank lines
IAI Lines in text frames
= Include header and footer
Restart every new page
Help oK Cancel

Figure 18: The Line Numbering dialog

To add line numbers to specific paragraphs, first disable the feature for the document and then
enable it for specific paragraphs or paragraph styles.
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To disable line numbering for the document, edit the Default Style paragraph style (because all
paragraph styles are based on the Default Style):

1)
2)
3)
4)

5)

In the Sidebar, go to the Styles pane and click the Paragraph Styles icon.
Right-click the Default Style paragraph style and choose Modify.
Click the Outline & Numbering tab (see Figure 19).

In the Line Numbering area, clear the Include this paragraph in line numbering
checkbox.

Click OK.
@ Paragraph Style: Default Style

Organizer  Indents & Spacing ~ Alignment  TextFlow  Font  FontEffects  Position
Highlighting | Outline & Numbering | Tabs DropCaps  Area  Transparency  Borders

Outline |
Qutline level: Body text | &

Numbering |
Numbering style: Naone | &

Line Numbering
- Include this paragraph in line numbering

Restart at this paragraph

Figure 19: Disabling line numbering for a document

To enable line numbering for specific paragraphs:

1)
2)
3)
4)

Select the paragraphs where you want to add the line numbers.

Choose Format > Paragraph, and then click the Outline & Numbering tab.
Select Include this paragraph in line numbering.

Click OK.

You can also create a paragraph style that includes line numbering, and apply it to the paragraphs
that you want to add line numbers to. For example, to number the lines of example code in a
document, you will probably want to use a font or indentation that is different from normal text.

To specify the starting line number:

1)
2)

3)
4)

Click in the paragraph and choose Format > Paragraph.

On the Outline & Numbering tab, make sure Include this paragraph in line numbering is
selected.

Select Restart at this paragraph and enter a line number in the Start with box.
Click OK.
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