
Calc Guide

Chapter 1
Introducing Calc
Using spreadsheets in LibreOffice



Copyright

This document is Copyright © 2019 by the LibreOffice Documentation Team. Contributors are listed
below. You may distribute it and/or modify it under the terms of either the GNU General Public 
License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons 
Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors
This book is adapted and updated from OpenOffice.org 3.3 Calc Guide.

To this edition
Cathy Crumbley Kees Kriek Jean Hollis Weber

To previous editions
Barbara Duprey Gabriel Godoy Jean Hollis Weber
John A Smith Christian Chenal Laurent Balland-Poirier
Philippe Clément Pierre-Yves Samyn Shelagh Manton
Peter Schofield

Feedback
Please direct any comments or suggestions about this document to the Documentation Team’s 
mailing list: documentation@global.libreoffice.org

Note

Everything you send to a mailing list, including your email address and any other 
personal information that is written in the message, is publicly archived and cannot be 
deleted.

Publication date and software version
Published June 2019. Based on LibreOffice 6.2.

Note for macOS users
Some keystrokes and menu items are different on macOS from those used in Windows and Linux. 
The table below gives some common substitutions for the instructions in this book. For a more 
detailed list, see the application Help.

Windows or Linux macOS equivalent Effect

Tools > Options 
menu selection

LibreOffice > Preferences Access setup options

Right-click Control+click and/or right-click 
depending on computer setup

Open a context menu

Ctrl (Control)  (Command)⌘ Used with other keys

F5 Shift+ +F5⌘ Open the Navigator

F11 +T⌘ Open the sidebar Styles deck

Documentation for LibreOffice is available at https://documentation.libreoffice.org/en/

https://documentation.libreoffice.org/en/
mailto:documentation@global.libreoffice.org
http://creativecommons.org/licenses/by/4.0/
http://www.gnu.org/licenses/gpl.html


Contents
Copyright..............................................................................................................................2

Contributors.................................................................................................................................2
To this edition..........................................................................................................................2
To previous editions................................................................................................................2

Feedback.....................................................................................................................................2

Publication date and software version.........................................................................................2

Note for macOS users.................................................................................................................2

What is Calc?........................................................................................................................5

Spreadsheets, sheets, and cells.........................................................................................5

Calc main window................................................................................................................5
Title bar........................................................................................................................................ 5

Menu bar.....................................................................................................................................6

Toolbars.......................................................................................................................................7
Formula Bar............................................................................................................................7
Status Bar...............................................................................................................................8

Sidebar........................................................................................................................................9

Spreadsheet layout....................................................................................................................10
Individual cells.......................................................................................................................10
Sheet tabs.............................................................................................................................11

Creating, opening, and saving spreadsheets.................................................................11
Creating and opening.................................................................................................................11

Using templates.........................................................................................................................11

Opening a CSV file.....................................................................................................................11

Saving spreadsheets.................................................................................................................13

Saving in other formats..............................................................................................................13

Password protection..........................................................................................................15

Navigating within spreadsheets.......................................................................................15
Cell navigation...........................................................................................................................15

Sheet navigation........................................................................................................................16

Keyboard navigation..................................................................................................................17
Customizing the Enter key....................................................................................................18

Selecting items in a spreadsheet.....................................................................................18
Selecting cells............................................................................................................................18

Single cell..............................................................................................................................18
Range of contiguous cells.....................................................................................................18
Range of non-contiguous cells..............................................................................................19

Selecting columns and rows......................................................................................................19
Single column or row.............................................................................................................19
Multiple columns or rows.......................................................................................................19
Entire sheet...........................................................................................................................20

Selecting sheets........................................................................................................................20
Single sheet..........................................................................................................................20
Multiple contiguous sheets....................................................................................................20
Multiple non-contiguous sheets.............................................................................................20

Chapter 1 Introducing Calc | 3



All sheets..............................................................................................................................20

Working with columns and rows......................................................................................20
Inserting columns and rows.......................................................................................................20

Single column or row.............................................................................................................20
Multiple columns or rows.......................................................................................................21

Deleting columns and rows........................................................................................................21
Single column or row.............................................................................................................21
Multiple columns or rows.......................................................................................................21

Deleting cells.............................................................................................................................21

Working with sheets..........................................................................................................22
Inserting new sheets..................................................................................................................22

Moving and copying sheets...................................................................................................22
Dragging and dropping..........................................................................................................23
Using Move/Copy Sheet dialog.............................................................................................23

Deleting sheets..........................................................................................................................24

Renaming sheets.......................................................................................................................24

Viewing Calc.......................................................................................................................24
Changing document view...........................................................................................................24

Freezing rows and columns.......................................................................................................24

Unfreezing.................................................................................................................................25

Splitting the screen....................................................................................................................25
Splitting horizontally or vertically...........................................................................................25
Splitting both horizontally and vertically.................................................................................26

Removing split views.................................................................................................................26

Using the Navigator...........................................................................................................26

Using document properties..............................................................................................28
General......................................................................................................................................28

Description.................................................................................................................................28

Custom Properties.....................................................................................................................29

CMIS Properties........................................................................................................................29

Security......................................................................................................................................29

Font........................................................................................................................................... 29

Statistics....................................................................................................................................29

4| Chapter 1 Introducing Calc



What is Calc?

Calc is the spreadsheet component of LibreOffice. You can enter data (usually numerical) in a 
spreadsheet and then manipulate this data to produce certain results.

Alternatively, you can enter data and then use Calc in a ‘What if...’ manner by changing some of 
the data and observing the results without having to retype the entire spreadsheet or sheet.

Other features provided by Calc include:

• Functions, which can be used to create formulas to perform complex calculations on data.

• Database functions to arrange, store, and filter data.

• Dynamic charts, including a wide range of 2D and 3D charts.

• Macros for recording and executing repetitive tasks; scripting languages supported include 
LibreOffice Basic, Python, BeanShell, and JavaScript.

• Ability to open, edit, and save Microsoft Excel spreadsheets.

• Import and export of spreadsheets in multiple formats, including HTML, CSV, PDF, and 
PostScript.

Note

If you want to use macros written in Microsoft Excel using the VBA macro code in 
LibreOffice, you must first edit the code in the LibreOffice Basic IDE editor. For more 
information, see Chapter 12, Calc Macros, in this guide or Chapter 13, Getting Started 
with Macros, in the Getting Started Guide.

Spreadsheets, sheets, and cells

Calc works with documents called spreadsheets. Spreadsheets consist of a number of individual
sheets, each sheet containing cells arranged in rows and columns. A particular cell is identified by 
its row number and column letter.

Cells hold the individual elements – text, numbers, formulas, and so on – that make up the data to 
display and manipulate.

Each spreadsheet can have up to 10,000 sheets and each sheet can have  a maximum of 
1,048,576 rows and 1,024 columns. The maximum number of characters in one cell is 32,767.

Calc main window

When Calc is started, the main window opens (Figure 1). The various parts of this display are 
explained below.

Note

If any part of the Calc window in Figure 1 is not shown, you can display it using the 
View menu. For example, View > Status Bar on the Menu bar will toggle (show or 
hide) the Status Bar. It is not always necessary to display all of the parts shown; you 
can show or hide any of them as desired.

Title bar
The Title bar, located at the top, shows the name of the current spreadsheet. When the 
spreadsheet is newly created, its name is Untitled X, where X is a number. When you save a 
spreadsheet for the first time, you are prompted to enter a name of your choice.
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Figure 1: Calc main window

Menu bar
Under the Title bar is the Menu bar. When you choose one of the menus, a list of options appears. 
You can also modify the Menu bar, as explained in Chapter 14, Setting Up and Customizing Calc.

• File – contains commands that apply to the entire document, such as Open, Save, 
Wizards, Export as PDF, Print, Digital Signatures, Templates.

• Edit – contains commands for editing the document, such as Undo, Copy, Find & 
Replace, Track Changes.

• View – contains commands for modifying how the Calc user interface looks, such as 
Toolbars, View Headers, Full Screen, Zoom.

• Insert – contains commands for inserting elements into a spreadsheet, such as Image, 
Textbox, Headers and Footers.

• Format – contains commands for modifying the layout of a spreadsheet, such as Cells, 
Page, AutoFormat Styles, Align.

• Styles – contains options for applying and managing styles, such as Heading 1, Footnote,
Manage Styles.

• Sheet – contains comands for inserting and deleting elements and modifying the entire 
sheet, such as Delete Rows, Insert Sheet, Rename Sheet, Navigate.

• Data – contains commands for manipulating data in your spreadsheet, such as Define 
Range, Sort, AutoFiilter, Consolidate.

• Tools – contains functions to help check and customize a spreadsheet, for example 
Spelling, Share Spreadsheet, Macros, Options.

• Window – contains two commands; New Window and Close Window. Also shows all 
open windows in other LibreOffice applications.
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• Help – contains links to LibreOffice Help (included with the software), User Guides, and 
other miscellaneous functions; for example Restart in Safe Mode, License Information, 
Check for Updates.

Toolbars
The default setting when Calc opens is for the Standard and Formatting toolbars to be docked at 
the top of the workspace (Figure 1).

Calc toolbars can be either docked (fixed in place), or floating, allowing you to move a toolbar to a 
more convenient location on your workspace. Docked toolbars can be undocked and moved to a 
different docked location or become floating toolbars. Likewise, floating toolbars can be docked.

You can choose the single-toolbar alternative to the default double toolbar arrangement. It contains
the most-used commands. To activate it, enable View > Toolbars > Standard (Single Mode) and 
disable View > Toolbars > Standard and View > Toolbars > Formatting.

For additional information on toolbars, see Chapter 1, Introducing LibreOffice, of the Getting 
Started Guide.

The default set of icons (sometimes called buttons) on toolbars provides a wide range of common 
commands and functions. You can also remove or add icons to toolbars. See Chapter 14, Setting 
Up and Customizing Calc, for more information.

Placing the mouse cursor over an icon, text box, or menu command displays a small box called a 
tooltip that shows the name of the item’s function. To close a tooltip, click once away from the icon 
or press the Esc key.

To see a more detailed explanation of an icon, textbox, or menu command, do one of the following 
to open extended tips:

• To activate extended tips just once: press Shift+F1. 

• To activate extended tips from the Menu bar: go to Help > What’s This? and hover the 
mouse pointer over the icon.

• To turn extended tips on or off: go to from Tools > Options > LibreOffice > General on the
Menu bar.

Formula Bar
The Formula Bar is located at the top of the  Calc workspace. It is permanently docked in this 
position and cannot be used as a floating toolbar. However, it can be hidden or made visible by 
going to View > Formula Bar on the Menu bar.

Figure 2: Formula bar

From left to right in Figure 2, the Formula Bar consists of the following:

• Name Box – gives the current active cell reference using a combination of a letter and 
number, for example A1. The letter indicates the column and the number indicates the row 
of the selected cell. If you have selected a range of cells that is also a named range, the 
name of the range is shown in this box. You can also type a cell reference in the Name Box 
to jump to the referenced cell. If you type the name of a named range and press the Enter 
key, the named range is selected and displayed.

• Function Wizard  – opens a dialog from which you can search through lists of available 
functions and formulas. This can be very useful because it also shows how the functions 
are formatted.
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• Sum  – totals the numbers in the cells above the selected cell and then places the total 
in the selected cell. If there are no numbers above the selected cell, then the cells to the left
are totaled.

• Formula  – inserts an equals (=) sign in the selected cell and the Input line, allowing a 
formula to be entered.

• Input line – displays the contents of the selected cell (data, formula, or function) and allows
you to edit the cell contents. To turn the Input line into a multiline input area for very long 
formulas, click the drop down button on the right. To edit inside the Input line area, click in 
the area, then type your changes.

You can also directly edit inside the cell by double-clicking on the cell. When you enter new data 
into a cell, the Sum and Formula icons change to Cancel and Accept icons .

Note

In a spreadsheet, the term “function” covers much more than just mathematical 
functions. See Chapter 7, Using Formulas and Functions, for more information.

Status Bar
The Calc status bar at the bottom of the workspace (Figure 3) provides information about the 
spreadsheet and convenient ways to quickly change some of its features. Most of the fields are 
similar to those in other components of LibreOffice. See Chapter 1, Introducing LibreOffice, in the 
Getting Started Guide for more information.

Figure 3: Calc status bar

The fields on the Status Bar, from left to right, are as follows.

Sheet number
Shows the sequence number of the current sheet and the total number of sheets in the 
spreadsheet. The sequence number may not be the same as the name on the sheet tab if 
sheets have been moved. Double-click on this zone to open the Navigator.

Number of selected rows and columns
Shows how many rows and how many columns are selected.

Page style
Shows the page style of the current sheet. To edit the page style, double-click on this field 
and the Page Style dialog opens.

Language
Shows current default language as selected at Tools > Options > Language Settings > 
Language. 

Insert mode
This field is blank if the program is in insert mode. Press the Ins key to change modes.  
Overwrite shows when in overwrite mode.

Selection mode
Right-click to open a context menu and select Standard selection, Extending selection, 
Adding selection or Block selection. The icon does not change when different selection 
modes are selected, but the tooltip shows the current status. See Chapter 1, Introducing 
LibreOffice, in the Getting Started Guide for more information.
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Unsaved changes
This icon indicates the spreadsheet contains unsaved changes. Double-click this icon or use 
File > Save to save the spreadsheet.

Digital signature
If the document has been digitally signed, an icon shows here. You can double-click the icon 
to view the certificate. See Chapter 6, Printing, Exporting, E-mailing, and Signing for more 
information about digital signatures.

Cell or object information
Displays information related to the position of the cursor or the selected element of the 
spreadsheet. When a group of cells is selected, the sum of the contents is displayed by 
default. Right-click in this field to select other functions, such as the average value, maximum
value, minimum value, or count (number of items selected).

Zoom slider
Drag the zoom slider, or click the + and – signs to change the view magnification.

Zoom percentage
Indicates the magnification level of the document. Right-click on the percentage to open a list
of magnification values from which to choose. Double-click on the percentage to open the 
Zoom & View Layout dialog.

Sidebar
The Calc Sidebar (Figure 4) is a mixture of toolbar and dialog. When opened (View > Sidebar or 
Ctrl+F5), it appears on the right side of the window and consists of five decks: Properties, Styles, 
Gallery, Navigator, and Functions. Each deck has a corresponding icon on the Tab panel to the 
right of the sidebar, allowing you to switch between them. The decks are described below.

Properties
This deck includes five content panels. These panels, with the exception of the Style panel, 
have More Options buttons that open dialogs with additional options. These dialogs lock the 
document for editing until they are closed.

Style: Options for applying, updating, or creating cell and page styles.

Character: Options for formatting the text, such as font family, size, and color. Some 
controls, such as superscript, only become active when the text cursor is active in the Input 
line of the Formula bar or the cell. 

Number Format: Options for formatting numbers, including decimals, currency, dates, or 
numeric text. 

Alignment: Options for arranging the text in various ways, including horizontal and vertical 
alignment, wrapping, indenting, merging, text orientation, and vertical stacking.

Cell Appearance: Options include background color, border formats including line color and 
style, and grid lines.

Styles
This deck is the same as the dialog opened by selecting Styles > Manage Styles from the 
Menu bar or F11.

Gallery
This deck is the same as the dialog opened by selecting View > Gallery from the Menu bar.

Navigator
This deck is the same as the Navigator window opened by selecting View > Navigator from 
the Menu bar or F5. See “Using the Navigator” on page 26.
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Figure 4: Sidebar

Functions
This deck contains a list of functions organized by category. It is a simpler version of the 
Function Wizard, which is opened by selecting Insert > Function... from the Menu bar or 
Ctrl+F2.

To the right side of the title bar of each open deck is a Close button (X), which closes the deck to 
leave only the Tab bar open. Clicking on any Tab button reopens the deck.

To hide the Sidebar, or reveal it if already hidden, click on the edge Hide/Show button. To adjust 
the deck width, drag on the left edge of the sidebar.

Spreadsheet layout

Individual cells
The main section of the screen displays the cells in the form of a grid, with each cell located at the 
intersection of a column and a row.

At the tops of the columns and the left ends of the rows are a series of header boxes containing 
letters and numbers. The column headers use alpha characters that start with A and increase to 
the right. The row headers use numerical characters that start at 1 and increase down.

These column and row headers form the cell references that appear in the Name Box on the 
Formula Bar (Figure 2). If the headers are not visible on the spreadsheet, go to View > Column & 
Row Headers on the Menu bar.
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Sheet tabs
A spreadsheet file can contain many individual sheets. At the bottom of the grid of cells in a 
spreadsheet are sheet tabs (Figure 1). Each tab represents a sheet in a spreadsheet. Create a 
new sheet by clicking on the plus sign to the left of the sheet tabs. 

Clicking on a tab enables access to an individual sheet. When a sheet is active, the tab is 
highlighted. Select multiple sheets by holding down the Ctrl key while clicking on the sheet tabs.

To change the default name for a sheet (Sheet1, Sheet2, and so on):

 1) Right-click on the sheet tab and select Rename Sheet from the context menu. A dialog 
opens allowing you to type in a new name for the sheet.

 2) Click OK when finished to close the dialog.

To change the color of a sheet tab:

 1) Right-click on the sheet tab and select Tab Color from the context menu to open the Tab 
Color dialog (Figure 5).

 2) Select a color and click OK when finished to close the dialog.

Figure 5: Tab Color dialog

To add new colors to this color palette, see “Adding Custom colors” in Chapter 14, Setting up and 
Customizing Calc.

Creating, opening, and saving spreadsheets

Creating and opening
Creating and opening spreadsheets is identical to creating and opening documents in the other 
LibreOffice modules. For more information on creating and opening spreadsheets, see Chapter 1, 
Introducing LibreOffice, in the Getting Started Guide.

Using templates
Calc documents can also be created from templates. For information on how to create and use 
templates, see Chapter 4, Using Styles and Templates, in this guide.

Opening a CSV file
Comma-separated-values (CSV) files are spreadsheet files in a text format where cell contents are
separated by a character such as a comma or semi-colon. Each line in a CSV text file represents a
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row in a spreadsheet. Text is entered between quotation marks; numbers are entered without 
quotation marks.

To open a CSV file in Calc:

 1) Choose File > Open on the Menu bar and locate the CSV file that you want to open.

 2) Select the file and click Open. By default, a CSV file has the extension .csv. However, 
some CSV files may have a .txt extension.

 3) The Text Import dialog (Figure 6) opens. Here you can select options for importing a CSV 
file into a Calc spreadsheet.

 4) Click OK to open and import the file.

Figure 6: Text Import dialog

The options for importing CSV files into a Calc spreadsheet are as follows:

Import
• Character Set – specifies the character set to be used in the imported file.

• Language – determines how the number strings are imported. If Language is set to Default,
Calc will use the language selected at Tools > Options > Language Settings > 
Languages > Default Languages for Document. If another language is selected, that 
language will determine how numbers are treated.

• From Row – specifies which row the import starts with. The initial rows are visible in the 
preview window at the bottom of the dialog.

Separator Options
• Fixed width – separates data into columns by a set number of characters. Click on the ruler 

that appears in the preview window to set the width.

• Separated by – separates data into columns based on the separator defined here. Select 
other to specify another character used to separate data into columns. This custom 
separator must also be contained in the data.

• Merge delimiters – combines consecutive delimiters and removes blank data fields.
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• Trim spaces – removes starting and trailing spaces from within fields.

• String delimiter – select a character to delimit text data.

Other options
• Format quoted field as text – when this option is enabled, fields or cells whose values are 

entirely within quotes are imported as text.

• Detect special numbers – when this option is enabled, Calc will automatically detect all 
number formats, including special number formats such as dates, time, and scientific 
notation. The selected language influences how such special numbers are detected, since 
different languages and regions many have different conventions for such special numbers.

When this option is disabled, Calc will detect and convert only decimal numbers. The rest, 
including numbers formatted in scientific notation, will be imported as text. A decimal 
number string can have digits 0–9, thousands separators, and a decimal separator. 
Thousands separators and decimal separators may vary with the selected language and 
region.

Fields – shows how your data will look when it is separated into columns.

Column type – select a column in the preview window and select the data type to be applied 
to the imported data.

– Standard – Calc determines the type of data.

– Text – imported data are treated as text.

– Date – imported data are treated as dates.

– US English – numbers formatted in US English are searched for and included 
regardless of the system language. A number format is not applied. If there are no US 
English entries, the Standard format is applied.

– Hide – the data in the column are not imported.

Saving spreadsheets
For information on how to save files manually or automatically, see Chapter 1, Introducing 
LibreOffice, in the Getting Started Guide. Calc can save spreadsheets in a range of formats and 
also export spreadsheets to PDF, HTML and XHTML file formats; see Chapter 6 Printing, 
Exporting, Emailing, and Signing, for more information.

Saving in other formats
If you need to send files to users who are unable to receive spreadsheet files in Open Document 
Format (ODF) (*.ods), which Calc uses as default format, you can save a spreadsheet in another 
format.

 1) Select File > Save As on the Menu bar or Alt+F,A to open the Save As dialog (Figure 7).

 2) In File name, if you wish, enter a new file name for the spreadsheet and select the folder 
where you want to save the file.

 3) In the Save as type field, select from the drop-down menu the type of spreadsheet format 
you want to use. If Automatic file name extension is selected, the correct file extension for 
the spreadsheet format you have selected will be added to the file name.

 4) Click Save.
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Figure 7: Save dialog

Each time a file is saved in a format other than ODF format, the Confirm File Format dialog opens 
(Figure 8). Click Use [xxx] Format to continue saving in the selected spreadsheet format or click 
Use ODF Format to save the spreadsheet in Calc ODS format.

Figure 8: Confirm File Format dialog

If you select Text CSV format (*.csv), the Export Text File dialog (Figure 9) opens. Here you can 
select the character set, field delimiter, text delimiter and so on to be used for the CSV file.

Figure 9: Export Text File dialog

14 | Chapter 1 Introducing Calc



Note

Once you have saved a spreadsheet in another format, all changes you make to the 
spreadsheet will now occur only in the format you are using because you have 
changed the name and file type of your document. If you want to go back to working 
with an *.ods version, you must save the file as an *.ods file.

Tip

To have Calc save documents by default in a file format other than the default ODF 
format, go to Tools > Options > Load/Save > General. In the section named Default 
file format and ODF settings, next to Document type, select Spreadsheet, then next to
Always save as, select your preferred file format, for example Microsoft Excel.

Password protection

To protect a spreadsheet and restrict who can open, read, and make changes to it, you have to use
password protection. Password protection is common to all LibreOffice modules; for more 
information, see Chapter 1, Introducing LibreOffice, in the Getting Started Guide.

Navigating within spreadsheets

Calc provides many ways to navigate within a spreadsheet from cell to cell and sheet to sheet. You
can generally use the method you prefer.

Cell navigation
When a cell is selected or in focus, the cell borders are emphasized. When a group of cells is 
selected, the cell area is colored. The color of the cell border emphasis and the color of a group of 
selected cells depends on the operating system being used and how you have set up LibreOffice.

• Using the mouse – place the mouse pointer over the cell and click the left mouse button. To
move the focus to another cell using the mouse, move the mouse pointer to the cell and 
click the left mouse button.

• Using a cell reference – highlight or delete the existing cell reference in the Name Box on 
the Formula Bar (Figure 2 on page 7). Type the new cell reference of the cell you want to 
move to and press the Enter key. Cell references are case insensitive. Thus, typing a3 or 
A3 will move the focus to cell A3.

• Using the Navigator – go to View > Navigator or press the F5 key to open the Navigator 
dialog (Figure 10). Type the cell references into the Column and Row fields and press the 
Enter key.

• Using the Enter key – pressing Enter moves the cell focus down one cell. Pressing 
Shift+Enter moves the focus up one cell.

• Using the Tab key – pressing Tab moves the cell focus one cell to the right. Pressing 
Shift+Tab moves the focus one cell to the left.

• Using the arrow keys – pressing the arrow keys on the keyboard moves the cell focus in the
direction of the arrow pressed.
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Figure 10: Navigator dialog 

• Using Home, End, Page Up, and Page Down

– Home moves the cell focus to the start of a row. Ctrl+Home moves the cell focus to the 
first cell in the sheet, A1.

– End moves the cell focus to the last cell in the same row that contains data. Ctrl+End 
moves the cell focus to the last cell in the sheet that contains data.

– Page Down moves the cell focus down one complete screen display.

– Page Up moves the cell focus up one complete screen display.

Sheet navigation
Each sheet in a spreadsheet is independent of the other sheets, though references can be linked 
from one sheet to another. There are three ways to navigate between different sheets in a 
spreadsheet.

• Using the Navigator – when the Navigator is open (Figure 10), double-clicking on any of the
listed sheets selects the sheet.

• Using the keyboard – using key combinations Ctrl+Page Down moves one sheet to the 
right and Ctrl+Page Up moves one sheet to the left.

• Using the mouse – clicking on one of the sheet tabs at the bottom of the spreadsheet 
selects that sheet.

If there are many sheets in the spreadsheet, some of the sheet tabs may be hidden. If this is the 
case, use the four buttons to the left of the sheet tabs to move the tabs into view (Figure 11).

Note

The sheet tab arrows that appear on the left in Figure 11 are only active if there are 
sheet tabs that cannot be seen.

16 | Chapter 1 Introducing Calc



Figure 11. Navigating sheet tabs

Note

When you insert a new sheet into a spreadsheet, Calc automatically uses the next 
number in the numeric sequence as a name. Depending on which sheet is open when 
you insert a new sheet, your new sheet may not be in numerical order. It is 
recommended to rename sheets in a spreadsheet to make them more recognizable.

Keyboard navigation
You can navigate a spreadsheet using the keyboard, by pressing a key or a combination of keys at
the same time. For example, Ctrl+Home moves the focus to cell A1. Table 1 lists the keys and key 
combinations you can use for spreadsheet navigation in Calc.

Table 1. Keyboard cell navigation
Keyboard 
shortcut

Cell navigation

→/← Moves cell focus right/left one cell.

↑/↓ Moves cell focus up/down one cell.

Ctrl+→ /
Ctrl+←

If focus is on a blank cell, moves focus to the first cell on the right/left that
contains data.
If focus is on a cell containing data, moves focus to the last/first cell on 
the right/left containing data.
If there are no more cells containing data, moves focus to the last/first 
cell on the right/left in the spreadsheet.

Ctrl+↑ /
Ctrl+↓

If focus is on a blank cell, moves focus to the first cell above/below that 
contains data.
If focus is on a cell containing data, moves focus to the cell in Row 1/last 
cell containing data in the same column.
If there are no more cells below containing data in that column, moves 
focus to the cell in the same column in the last row of the spreadsheet.

Ctrl+Home / 
Ctrl+End

Moves focus from anywhere on the spreadsheet to Cell A1/the last cell in 
the lower right-hand corner of the rectangular area of cells containing 
data on the same sheet.

Alt+Page Down /
Alt+Page Up

Moves focus one screen to the right/left (if possible).

Ctrl+Page Down /
Ctrl+Page Up

Moves focus to the same cell on the next sheet to the right/left in sheet 
tabs if there are more sheets in that direction.
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Keyboard 
shortcut

Cell navigation

Tab /
Shift+Tab

Moves focus to the next cell on the right/left.

Enter/
Shift+Enter

Moves focus down/up one cell (unless changed by user).

Customizing the Enter key
You can choose the direction in which the Enter key moves the cell focus by going to Tools > 
Options > LibreOffice Calc > General. Use the first two options under Input settings (Figure 12) 
to change the Enter key settings. Select the direction cell focus moves from the drop-down list. 
Depending on the file being used or the type of data being entered, setting a different direction can 
be useful. The Enter key can also be used to switch into and out of editing mode.

Figure 12: Customizing the Enter key

Selecting items in a spreadsheet

Selecting cells

Single cell
Left-click in the cell. You can verify the selection by looking in the Name Box on the Formula Bar 
(Figure 2).

Range of contiguous cells
A range of cells can be selected using the keyboard or the mouse.

To select a range of cells by dragging the mouse cursor:

 1) Click in a cell.

 2) Press and hold down the left mouse button.

 3) Move the mouse around the screen.

 4) Once the desired block of cells is highlighted, release the left mouse button.

To select a range of cells without dragging the mouse:

 1) Click in the cell which is to be one corner of the range of cells.

 2) Move the mouse to the opposite corner of the range of cells.

 3) Hold down the Shift key and click.

To select a range of cells using Extending selection mode:

 1) Click in the cell which is to be one corner of the range of cells.
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 2) Click in the Selection mode field on the Status Bar (Figure 3 on page 8) and select 
Extending selection.

 3) Click in the cell in the opposite corner of the range of cells.

Tip

Make sure to change back to Standard selection or you may find yourself extending a 
cell selection unintentionally.

To select a range of cells without using the mouse:

 1) Select the cell that will be one of the corners in the range of cells.

 2) While holding down the Shift key, use the cursor arrows to select the rest of the range.

To select a range of cells using the Name Box:

 1) Click in the Name Box on the Formula Bar (Figure 2 on page 7). 

 2) Enter the cell reference for the upper left-hand cell, followed by a colon (:), and then the 
lower right-hand cell reference, then press the Enter key. For example, to select the range 
that would go from A3 to C6, enter A3:C6.

Range of non-contiguous cells
To select a range of non-contiguous cells using the mouse:

 1) Select the first cell or range of cells using one of the methods above.

 2) Move the mouse pointer to the start of the next range or single cell.

 3) Hold down the Ctrl key and click or click-and-drag to select another range of cells to add to 
the first range.

 4) Repeat as necessary.

 5) To select a range of non-contiguous cells using Adding selection mode:

 6)  To select a range of cells using Adding selection mode: 

 7) Click in the cell which is to be one corner of the range of cells.

 8) Click in the Selection mode field on the Status Bar (Figure 3 on page 8) and select 
Extending selection before clicking in the opposite corner of the range of cells.

Selecting columns and rows

Single column or row
To select a single column, click on the column header (Figure 1 on page 6). To select a single row, 
click on the row header.

Multiple columns or rows
To select multiple columns or rows that are contiguous:

 1) Click on the first column or row in the group.

 2) Hold down the Shift key.

 3) Click the last column or row in the group.

To select multiple columns or rows that are not contiguous:

 1) Click on the first column or row in the group.

 2) Hold down the Ctrl key.

 3) Click on all of the subsequent columns or rows while holding down the Ctrl key.
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Entire sheet
To select the entire sheet, click on the small box between the column headers and the row headers
(Figure 13), or use the key combination Ctrl+A to select the entire sheet, or go to Edit on the Menu
bar and select Select All.

Figure 13. Select All box

Selecting sheets
You can select either one or multiple sheets in Calc. It can be advantageous to select multiple 
sheets, especially when you want to make changes to many sheets at once.

Single sheet
Click on the sheet tab for the sheet you want to select. The tab for the selected sheet becomes 
white (default Calc setup) or is otherwise highlighted.

Multiple contiguous sheets
To select multiple contiguous sheets:

 1) Click on the sheet tab for the first desired sheet.

 2) While holding down the Shift key, click on the sheet tab for the last desired sheet.

 3) All tabs between these two selections will turn white (default Calc setup). Any actions that 
you perform will now affect all highlighted sheets.

Multiple non-contiguous sheets
To select multiple non-contiguous sheets:

 1) Click on the sheet tab for the first desired sheet.

 2) While holding down the Ctrl key, click on the sheet tabs for other desired sheets.

 3) The selected tabs will turn white (default Calc setup). Any actions that you perform will now 
affect all highlighted sheets.

All sheets
Right-click a sheet tab and choose Select All Sheets from the context menu.

Working with columns and rows

Inserting columns and rows
When you insert columns or rows, the cells take the formatting of the corresponding cells in the 
column to the left or the row above.

Single column or row
Using the Sheet menu:

 1) Select a cell, column, or row where you want the new column or row inserted.

 2) Go to Sheet on the Menu bar. For columns, select Sheet > Insert Columns and then 
select Columns Before or Columns After.  For rows, select Sheet > Insert Rows and 
then select Rows Above or Rows Below.
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Using the context menu:

 1) Select a column or row where you want the new column or row inserted.

 2) Right-click the column or row header.

 3) Select Insert Columns Before / After or Insert Rows Above / Below from the context 
menu.

Multiple columns or rows
Multiple columns or rows can be inserted at once rather than inserting them one at a time.

 1) Highlight the required number of columns or rows by holding down the left mouse button on
the first one and then dragging across the required number of identifiers.

 2) Proceed as for inserting a single column or row above. The number of columns or rows 
highlighted will be inserted.

Deleting columns and rows

Single column or row
To delete a single column or row:

 1) Select a cell in the column or row you want to delete.

 2) Go to Sheet on the Menu bar and select Delete Columns. Right-click and select Delete 
Columns from the context menu.

 3) Select the option you require from the Delete Cells dialog (Figure 14).

Multiple columns or rows
To delete multiple columns or rows:

 1) Select the columns or rows. See “Multiple columns or rows” on page 19.

 2) Go to Sheet on the Menu bar and select Delete Cells, or right-click and select Delete from 
the context menu, or right-click in the column or row header and select Delete Columns or 
Delete Rows from the context menu.

Deleting cells
 1) Select the cell or cells you want to delete.

 2) Go to Sheet > Delete Cells. Or, right-click on the cell and select Delete from the context 
menu.

 3) Select the option you require from the Delete Cells dialog (Figure 14).

Alternatively:

 1) Click in the column or header to select the column or row.

 2) Go to Sheet on the Menu bar and select Delete Cells or right-click and select Delete 
Columns or Delete Rows from the context menu.
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Figure 14: Delete Cells dialog

Working with sheets

Inserting new sheets

Click on the Add Sheet icon  next to the sheet tabs to insert a new sheet after the last sheet in 
the spreadsheet without opening the Insert Sheet dialog. The following methods open the Insert 
Sheet dialog (Figure 15) where you can position the new sheet, create more than one sheet, name
the new sheet, or select a sheet from a file.

• Select the sheet where you want to insert a new sheet, then go to Sheet > Insert Sheet on 
the Menu bar or click Alt+S+S.

• Right-click on the sheet tab where you want to insert a new sheet and select Insert Sheet 
from the context menu.

• Click in the empty space at the end of the sheet tabs.

• Right-click in the empty space at the end of the sheet tabs and select Insert Sheet from the
context menu.

Figure 15: Insert Sheet dialog

Moving and copying sheets
You can move or copy sheets within the same spreadsheet by dragging and dropping or using the 
Move/Copy Sheet dialog (Figure 16). To move or copy a sheet into a different spreadsheet, use the
Move/Copy Sheet dialog.

22 | Chapter 1 Introducing Calc



Dragging and dropping
To move a sheet to a different position within the same spreadsheet, click on the sheet tab and 
drag it to its new position before releasing the mouse button.

To copy a sheet within the same spreadsheet, hold down the Ctrl key (Option key on Mac) then 
click on the sheet tab and drag it to its new position before releasing the mouse button. The mouse
pointer may change to include a plus sign depending on the setup of your operating system.

Using Move/Copy Sheet dialog
The Move/Copy Sheet dialog allows you to specify exactly whether you want the sheet in the same
or a different spreadsheet, its position within the spreadsheet, and the sheet name when it is 
moved or copied.

Figure 16: Move/Copy Sheet dialog

 1) In the current document, right-click on the sheet tab you wish to move or copy and select 
Move or Copy Sheet from the context menu or go to Sheet > Move or Copy Sheet on the 
Menu bar.

 2) Select Move to move the sheet or Copy to copy the sheet.

 3) Select the spreadsheet where you want the sheet to be placed from the drop-down list in To
document. This can be the same spreadsheet, another spreadsheet already open, or you 
can create a new spreadsheet.

 4) Select the position in Insert before where you want to place the sheet.

 5) Type a name in the New name text box if you want to rename the sheet when it is moved or
copied. If you do not enter a name, Calc creates a default name (Sheet 2, Sheet 3, and so 
on).

 6) Click OK to confirm the move or copy and close the dialog.

Warning

When you move or copy to another spreadsheet or to a new one, a conflict may occur 
if formulas are linked to sheets in the previous location.
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Deleting sheets
To delete a single sheet, right-click on the sheet tab you want to delete and select Delete Sheet 
from the context menu, or go to Sheet > Delete Sheet on the Menu bar. Click Yes to confirm the 
deletion.

To delete multiple sheets, select the sheets (see “Selecting sheets” on page 20), then right-click 
one of the sheet tabs and select Delete Sheet from the context menu, or go to Sheet > Delete 
Sheet on the Menu bar. Click Yes to confirm the deletion.

Renaming sheets
By default, the name for each new sheet added is SheetX, where X is the number of the next sheet
to be added. While this works for a spreadsheet with only a few sheets, it can become difficult to 
identify sheets when a spreadsheet contains many sheets..

You can rename a sheet using one of the following methods:

• Enter the name in the Name text box when you create the sheet using the Insert Sheet 
dialog (Figure 15 on page 22).

• Right-click on a sheet tab and select Rename Sheet from the context menu to replace the 
existing name with a different one.

• Double-click on a sheet tab to open the Rename Sheet dialog.

Note

Sheet names must start with either a letter or a number. Other characters, including 
spaces, are not allowed. Apart from the first character of the sheet name, permitted 
characters are letters, numbers, spaces, and the underscore character. Attempting to 
rename a sheet with an invalid name will produce an error message.

Viewing Calc

Changing document view
Use the zoom function to show more or fewer cells in the window when you are working on a 
spreadsheet. For more about zoom, see Chapter 1, Introducing LibreOffice, in the Getting Started 
Guide.

Freezing rows and columns
Freezing is used to lock rows across the top of a spreadsheet or to lock columns on the left of a 
spreadsheet. Then, when moving around within a sheet, the cells in frozen rows and columns 
always remain in view.

Figure 17 shows some frozen rows and columns. The heavier horizontal line between rows 3 and 
23 and the heavier vertical line between columns F and Q indicate that rows 1 to 3 and columns A 
to F are frozen. The rows between 3 and 23 and the columns between F and Q have been scrolled
off the page. To freeze rows or columns:

 1) Click on the row header below the rows you want the freeze or click on the column header 
to the right of the columns where you want the freeze. To freeze both rows and columns, 
select the cell (not a row or column) that is below the row and to the right of the column that
you want to freeze

 2) Go to View on the Menu bar and select Freeze Rows and Columns. Shortcut: Alt V+R. A 
heavier line appears between the rows or columns indicating where the freeze has been 
place.

24 | Chapter 1 Introducing Calc



Figure 17. Frozen rows and columns

Unfreezing
To unfreeze rows or columns, go to View on the Menu bar and click Freeze Rows and Columns 
to toggle it off. The heavier lines indicating freezing will disappear.

Splitting the screen
Another way to change the view is by splitting the screen displayed (also known as splitting the 
window). The screen can be split horizontally, vertically, or both, displaying up to four portions of 
the spreadsheet at any one time. An example of splitting the screen is shown in Figure 18 where a 
split is indicated by a gray line.

This could be useful for example, when a large spreadsheet has one cell with a number that is 
used by three formulas in other cells. Using the split-screen technique, the cell containing the 
number can be positioned in one section of the view and the cells with formulas can be seen in the 
other sections. This makes it easy to see how changing the number in one cell affects each of the 
formulas.

Figure 18. Split screen example

Splitting horizontally or vertically
There are two ways to split a screen horizontally or vertically:

Method One:

 1) Click on the row header below the rows where you want to split the screen horizontally or 
click on the column header to the right of the columns where you want to split the screen 
vertically.

 2) Go to View on the Menu bar and select Split Window. A thick line appears between the 
rows or columns indicating where the split has been placed. An example of a split line is 
shown below Row 2 in Figure 18.

Method Two:

For a horizontal split, click on the thick black line at the top of the vertical scroll bar (Figure 19) and 
drag the split line below the row where you want the horizontal split positioned.

Similarly, for a vertical split, click on the thick black line at the right of the horizontal scroll bar 
(Figure 19) and drag the split line to the right of the column where you want the vertical split 
positioned.
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Figure 19. Split screen bars

Splitting both horizontally and vertically

Method One:

Position both the black horizontal and the black vertical lines as described above and as shown in 
Figure 19.

Method Two:

 1) Click the cell that is immediately below the rows where you want to split the screen 
horizontally and immediately to the right of the columns where you want to split the screen 
vertically.

 2) Go to View on the Menu bar and select Split Window. Thick lines appear between the 
rows and columns indicating where the splits have been placed.

Removing split views
To remove a split view, do any of the following:

• Double-click on each split line.

• Click on and drag the split lines back to their places at the ends of the scroll bars.

• Go to View on the Menu bar and click Split Window to toggle it off.

Using the Navigator

The Navigator (Figure 20) is available in all LibreOffice modules. It provides tools and methods to 
move quickly through a spreadsheet and find specific items.

Figure 20: Navigator dialog in Calc

The Navigator categorizes and groups spreadsheet objects which you can click on to move quickly
to that object. If an indicator (plus sign or triangle, dependent on computer setup) appears next to a
category, at least one object in this category exists. To open a category and see the list of items, 
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click on the indicator. When a category is showing the list of objects in it, double-click on an object 
to jump directly to that object’s location in the spreadsheet.

To open the Navigator, do one of the following:

• Press the F5 key.

• Go to View > Navigator on the Menu bar.

• Click the Navigator icon in the Sidebar.

By default, the Navigator opens in the Sidebar.

The controls and tools available in the Navigator are as follows:

• Column – type a column letter and press the Enter key to reposition the cell cursor to the 
specified column in the same row.

• Row –  ttype a row number and press the Enter key to reposition the cell cursor to the 
specified row in the same column.

• Data Range  – specifies the current data range denoted by the position of the cell 
cursor.

• Start  – moves the cursor to the cell at the beginning of the current data range, which 
you can highlight using the Data Range icon.

• End  – moves the cursor to the cell at the end of the current data range, which you can
highlight using the Data Range icon.

• Toggle  – toggles the contents view. Only the selected category and its objects are 
displayed. Click the icon again to restore all elements for viewing.

• Scenarios  – displays all available scenarios. See Chapter 9, Data Analysis, for more 
information about scenarios. Double-click a name to apply that scenario and the result is 
shown in the sheet. If the Navigator displays scenarios, you can access the following 
commands when you right-click a scenario entry:

– Delete – deletes the selected scenario.

– Properties – opens the Edit scenario dialog, where you can edit the scenario properties.

• Drag Mode  – opens a submenu for selecting which action is performed when 
dragging and dropping an object from the Navigator into a document. Depending on the 
mode you select, the icon indicates whether a hyperlink, a link, or a copy is created.

– Insert as Hyperlink – hyperlinks the entire item.

– Insert as Link – links the copied item to the original item so that when the original item is
changed, that change will be reflected in the current document. 

– Insert as Copy – inserts a copy of the selected item.

Tip

Ranges, scenarios, pictures, and other objects are much easier to find if you have 
given them informative names when creating them, instead of keeping the default Calc
names, for example Scenario 1, Image 1, Image 2, Object 1, and so on. These default 
names may not correspond to the position of the object in the document.
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Using document properties

To open the Properties dialog for a document, go to File > Properties on the Menu bar. The 
Properties dialog provides information about the spreadsheet and allows you to set some of its 
properties. The dialog and its tabs are described below.

General
Contains basic information about the current file.

• The text box at the top of the dialog displays the file name.

• Change Password – opens a dialog to change the password. It is only active if a password
has been set for the file.

• Type – displays the file type of the current document.

• Location – displays the path and the name of the directory where the file is stored.

• Size – displays the size of the current document in bytes.

• Created – displays the date, time, and author when the file was first saved.

• Modified – displays the date, time, and author when the file was last saved in a LibreOffice 
file format.

• Template – displays the template that was used to create the file.

• Digitally signed – displays the date and time when the file was last signed as well as the 
name of the author who signed the document.

• Digital Signatures – opens the Digital Signatures dialog where you can manage digital 
signatures for the current document.

• Last printed – displays the date, time, and user name when the file was last printed.

• Total editing time – displays the amount of time that the file has been open for editing 
since the file was created. The editing time is updated when you save the file.

• Revision number – displays the number of times that the file has been saved.

• Apply user data – saves the full name of the user with the file. You can edit the name by 
going to Tools > Options > LibreOffice > User Data on the Menu bar.

• Save preview image with this document – saves a thumbnail.png inside the document. 
These images may be used by a file manager under certain conditions.

• Reset Properties – resets the editing time to zero, the creation date to the current date and
time, and the version number to 1. The modification and printing dates are also deleted.

Description
Contains optional editable descriptive information about the spreadsheet.

• Title – enter a title for the spreadsheet.

• Subject – enter a subject for the spreadsheet. You can use a subject to group documents 
with similar contents.

• Keywords – enter the words that you want to use to index the content of the spreadsheet. 
Keywords must be separated by commas. A keyword can contain white space characters or
semicolons.

• Comments – enter comments to help identify the spreadsheet.
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Custom Properties
Use this page to assign custom information fields to the spreadsheet. In a new spreadsheet, this 
page may be blank. If the new spreadsheet is based on a template, this page may contain 
fields.You can change the name, type, and contents of each row. The information in the fields will 
be exported as metadata to other file formats.

Click Add Property to add a new custom property. Click Reset to delete all custom properties.

CMIS Properties
Used for spreadsheets stored on remote servers. See the Help or the Getting Started Guide for 
more information.

Security
Enables two password-protected security options.

• Open file read-only – select to allow this document to be opened only in read-only mode. 
This file sharing option protects the document against accidental changes. It is still possible
to edit a copy of the document and save that copy with the same name as the original.

• Record changes – select to require that all changes be recorded. To protect the recording 
state with a password, click Protect and enter a password. This is similar to Edit > Track 
Changes > Record on the Menu bar. However, while other users of this document can 
apply their changes, they cannot disable change recording without knowing the password.

• Protect or Unprotect – protects the change recording state with a password. If change 
recording is protected for the current document, the button is named Unprotect. Click 
Unprotect and type the correct password to disable the protection.

Font
When Embed fonts in the document is selected, any fonts used in the spreadsheet will be 
embedded into the document when it is saved. This may be useful if you are creating a PDF of the 
spreadsheet and want to control how it will look on other computer systems.

Only embed fonts that are used in documents – If fonts have been defined for the spreadsheet 
(for example, in the template), but have not been used, select this option to not embed them.

Font scripts to embed – You can choose which types of fonts are embedded: Latin, Asian, 
Complex. See the Getting Started Guide for more information.

Statistics
Displays statistics for the current file: the number of sheets, cells, pages, and formula groups.
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