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Introduction

You can use Calc without a pointing device, such as a mouse or touchpad, by using keyboard
shortcuts. This appendix provides a comprehensive reference list of the available built-in
shortcuts, which you can browse to find ones that may be useful in your daily work.

When you first install LibreOffice, a default set of Calc keyboard shortcuts is available. These are
described in this chapter, assuming no customization. When using Calc, you can discover
shortcuts for common interactions by observing the key sequences identified on the menu
options and in the tooltips of toolbar icons. You can also explore a more comprehensive list of
shortcuts by viewing the Keyboard tab of the Customize dialog (Tools > Customize).

Further information about many individual key combinations can be found throughout the
chapters of this guide and in the Help system.

You can define your own shortcuts or change existing shortcuts by going to Tools > Customize
> Keyboard on the Menu bar. See Chapter 15, Setting up and Customizing, for further
instructions. Some shortcuts cannot be re-assigned; these are identified in the “Keyboard
shortcuts that cannot be modified” sections on pages 12 (Windows / Linux) and 20 (macOS).

Caution

Be careful when reassigning predefined shortcuts. Although you can reset
shortcut keys back to LibreOffice defaults, changing common hotkeys, such as
F1 for Help, can cause confusion and frustration, especially if other users share
your computer.

Note

Different operating systems may allocate particular keys to operating system
functions and, in such cases, those keys may not perform the Calc functions
described in this appendix.

For example, the F1 function key may be used to put your Windows computer
into a sleep / hibernation mode and so cannot be used to access the Calc Help
system. For some macOS versions, the Cmd+F5 key sequence is used by macOS
to display its VoiceOver dialog and so cannot be used to control the display of
Calc’s Sidebar. Similarly the Shift+F11 key sequence may be used by macOS
to show its desktop and so cannot be used to access Calc’s Save as Template
dialog.

Check your computer system’s documentation to determine which key presses
are used by the operating system and hence cannot carry out Calc functions.

The remainder of this chapter is in two main sections, one listing the keyboard shortcuts available
in the Windows and Linux environments, and the other listing the macOS keyboard shortcuts.

Windows / Linux keyboard shortcuts

Note

Many of the keyboard shortcuts in this section use the Ctr1 key. Some
keyboards have two Ctr1 keys and in that case you may need to experiment to
identify which of the two keys to use.
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Keyboard shortcuts for Menu bar options and toolbars

Tables 1 to 4 list Calc keyboard shortcuts that can be used instead of the options on the Menu
bar, the Standard toolbar, or the Formatting toolbar. The toolbars are assumed to contain the
initial default set of icons, without any user customization.

Table 1: Function key shortcuts for menu and toolbar options

Windows / Linux

Equivalent Menu bar / toolbar option

F1

Help > LibreOffice Help.

F2 Edit > Cell Edit Mode.
Ctrl+F2 Insert > Function.
Ctrl+F3 Sheet > Named Ranges and Expressions > Manage.
Shift+F3 Format > Text > Cycle Case.
F4 Sheet > Cycle Cell Reference Types.
Ctrl+Shift+F4 View > Data Sources.
F5 View > Navigator.
Ctrl+F5 View > Sidebar.
Shift+F5 Tools > Detective > Trace Dependents.
£7 Tools > Spelling.
Spelling icon on the Standard toolbar.
Ctrl+F7 Tools > Thesaurus.
Tools > Language > Hangul/Hanja Conversion. The availability of
Ctrl+Shift+F7 this menu option depends on selections on Tools > Options >
Language Setting > Languages.
Shift+F7 Tools > Automatic Spell Checking.
Ctrl+F8 View > Value Highlighting.
F9 Data > Calculate > Recalculate.
Shift+F9 Tools > Detective > Trace Precedents.
Ctrl+Shift+F9 Data > Calculate > Recalculate Hard.
F11 \Shtf/‘ll:: >S Bllltensa;ge Styles.
Shift+Fil \lj:;edic;tﬁoz:/ar‘lu:e: uS z:eSZ\Sn;r ?C'L‘rl? I:rtwet-he Standard toolbar.
F12 Data > Group and Outline > Group.
Ctrl+F12 Data > Group and Outline > Ungroup.
Alt+F12 Tools > Options.
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Table 2: Number key shortcuts for menu and toolbar options

Windows / Linux

Equivalent Menu bar / toolbar option

Ctril+1

Format > Cells.

Ctrl+Shift+1

Format > Number Format > Number (use the “1” key on the main
keyboard).

Format as Number icon on the Formatting toolbar.

Ctrl+Shift+2

Format > Number Format > Scientific (use the “2” key on the main
keyboard).

Ctrl+Shift+3

Format > Number Format > Date (use the “3” key on the main
keyboard).

Format as Date icon on the Formatting toolbar.

Ctrl+Shift+4

Format > Number Format > Currency (use the “4” key on the main
keyboard).

Format as Currency icon on the Formatting toolbar.

Ctrl+Shift+5

Format > Number Format > Percent (use the “5” key on the main
keyboard).

Format as Percent icon on the Formatting toolbar.

Ctrl+Shift+6

Format > Number Format > General (use the “6” key on the main
keyboard).

Table 3: Letter key shortcuts for menu and toolbar options

Windows / Linux

Equivalent Menu bar / toolbar option

Format > Text > Bold.

Ctrl+B _ _
Bold icon on the Formatting toolbar.
Ctrl+Shift+B Format > Text > Subscript.
s _
Ctrisc Edit .Copy
Copy icon on the Standard toolbar.
Insert > Comment.
Ctri+Alt+C Sheet > Cell Comments > Edit Comment.
Insert Comment icon on the Standard toolbar.
> Fi > Fi .
CtrisD Sheet Fill Cells > Fill Down |
Via drop-down menus on Row or Column icons on the Standard toolbar.
Ctri+E Fo.rmat > Alig.n > Centered. .
Align Center icon on the Formatting toolbar.
Ctrl+Alt+E Tools > Extension Manager.
Ctrl+F Edit > Find.
Ctri+H E.dit > Find and Re.place.
Find and Replace icon on the Standard toolbar.
CtrisI For_m«j;tt > Text > Italic. .
Italic icon on the Formatting toolbar.
Ctri+J Format > Align > Justified.
Ctrl+Shift+J View > Full Screen.
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Windows / Linux

Equivalent Menu bar / toolbar option

Insert > Hyperlink.

Ctrl+K o
Insert Hyperlink icon on the Standard toolbar.
Ctrisl Fo_rmat > Allgn > Left. _
Align Left icon on the Formatting toolbar.
> ilter.
Ctrl+Shift+L Data _Aut9F|Iter
AutoFilter icon on the Standard toolbar.
> i ing.
Ctr1+M Format. Clear Dlrec-t qumattlng
Clear Direct Formatting icon on the Standard toolbar.
Ctrl+Shift+m Edit > Edit Mode.
ile> > .
CErisN File . New > Spreadsheet
New icon on the Standard toolbar.
File > New > Templates.
Ctrl+Shift+N File > Templates > Manage Templates.
Via drop-down menu on New icon on the Standard toolbar.
e _
Ctris+0 File Qpen
Open icon on the Standard toolbar.
; File > Print Preview.
Ctri+Shift+0 re = Frint Freview. -
Toggle Print Preview icon on the Standard toolbar.
Ctrlsp F|I.e >.Pr|nt.
Print icon on the Standard toolbar.
Ctr1+Shift+P Format > Text > Superscript.
Ctri+Q File > Exit LibreOffice.
> Align > Right.
Ctri+r Fo-rmat- Alllgn Right .
Align Right icon on the Formatting toolbar.
e _
Ctriss File .Save
Save icon on the Standard toolbar.
, File>S As.
Ctri+Shift+S e = save As |
Via drop-down menu on Save icon on the Standard toolbar.
Ctri+U Underline icon on the Formatting toolbar.
CtrisV Edit > .Paste.
Paste icon on the Standard toolbar.
Ctrl+Shift+Vv Edit > Paste Special > Paste Special.
Ctrl+Alt+Shift+V Edit > Paste Special > Paste Unformatted Text.
Ctri+iw Window > Close Window.
s .
CEriex Edlt. Cut
Cut icon on the Standard toolbar.
s _
Ctrisy Edit _Redo
Redo icon on the Standard toolbar.
Ctrl+Shift+Y Edit > Repeat.
s _
Ctrisz Edit > Undo

Undo icon on the Standard toolbar.
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Table 4: Other shortcuts for menu and toolbar options

Windows / Linux Equivalent Menu bar / toolbar option

Ctrl+Shift+Pg up Edit> Select > Select to Previous Sheet.

Zg;ﬁr‘ghi Ft+Pg Edit > Select > Select to Next Sheet.

Backspace Sheet > Clear Cells.

Ctrl+Tab Sheet > Navigate > To Next Sheet.

Ctrl+Shift+Tab Sheet > Navigate > To Previous Sheet.

Ctrl+Space Edit > Select > Select Column.

Shift+Space Edit > Select > Select Row.

Ctrl+Shift+Space Edit> Select All.

Ctri++ Sheet > Insert Cells (use the + key on the numeric keypad).

Ctril+- Sheet > Delete Cells.

Ctri+* Edit > Select > Select Data Area (use the * key on the numeric keypad).

Ctri+; Insert > Date.

Ctrl+Shift+; Insert > Time.

Ctrl+Alt+= Insert > Object > Formula Object.

Ctri+’ Vie\{y > Show Formula. The grave (°) character can be found to the left of
the “1” key on many English keyboards.

Shift+Esc Help > Search Commands.

Other Calc keyboard shortcuts

Tables 5 to 10 provide lists of additional Calc keyboard shortcuts that may be less obvious to
users because they are not indicated on Menu bar items or in tooltips associated with icons on
the Standard and Formatting toolbars.

Table 5: Other function key shortcuts

Windows / Linux Description

Shift+F1 Display context sensitive help.

Ctrl+F1 Display the comment attached to the current cell.

Ctr1+Shift+E2 I(\:/Iu?\r/:r?ttsglf:ursor to the Input line where you can enter a formula for the
CtrisShift+Fs Moves the cursor to the Name Box field on the Formula bar.
Ctrl+Shift+T

Table 6: Other letter key shortcuts

Windows / Linux Description

Ctrl+A Selects all cells in the current sheet.
Ctrl+Shift+R Redraws the document view.

Ctrl+Shift+z Reverses the action of the last undo command.

8 | Appendix A Keyboard Shortcuts



Table 7: Arrow key shortcuts

Windows / Linux

Description

1 Moves the cell focus up.
Moves the cursor in the up direction to the edge of the current data range
Ctri+t (if the cell adjacent to the cursor is empty, the cursor moves to the next cell
that contains data).
Shift+1 Selects the adjacent cell or cells located in the up direction.
Selects in the up direction to the edge of the current data range (if the cell
Ctrl+Shift+1 adjacent to the cursor is empty, the cursor moves to the next cell that
contains data).
Alt+Shift+1 Optimizes the row height based on the current cell.
N Moves the cell focus right.
Moves the cursor in the right direction to the edge of the current data
Ctril+- range (if the cell adjacent to the cursor is empty, the cursor moves to the
next cell that contains data).
Shift+- Selects the adjacent cell or cells located in the right direction.
Selects in the right direction to the edge of the current data range (if the
Ctrl+Shift+— cell adjacent to the cursor is empty, the cursor moves to the next cell that
contains data).
Alt+- Increases the width of the current column.
Alt+Shift+- Optimizes the column width based on the current cell.
l Moves the cell focus down.
Moves the cursor in the down direction to the edge of the current data
Ctri+l range (if the cell adjacent to the cursor is empty, the cursor moves to the
next cell that contains data).
Opens a drop-down selection list of text items that have been previously
Alt+l i . :
yped into other cells in the same column.
Shift+] Selects the adjacent cell or cells located in the down direction.
Selects in the down direction to the edge of the current data range (if the
Ctrl+Shift+! cell adjacent to the cursor is empty, the cursor moves to the next cell that
contains data).
Alt+Shift+! Optimizes the row height based on the current cell.
- Moves the cell focus left.
Moves the cursor in the left direction to the edge of the current data range
Ctri+« (if the cell adjacent to the cursor is empty, the cursor moves to the next cell
that contains data).
Shift+« Selects the adjacent cell or cells located in the left direction.
Selects in the left direction to the edge of the current data range (if the cell
Ctrl1+Shift+« adjacent to the cursor is empty, the cursor moves to the next cell that
contains data).
Alt+« Decreases the width of the current column.
Alt+Shift+« Optimizes the column width based on the current cell.
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Table 8: Home and End key shortcuts

Windows / Linux Description

Home Moves the cursor to the first cell of the current row.

Ctrl+Home Moves the cursor to the first cell (Al) in the current sheet.

Shift+Home Selects cells from the cursor to the first cell of the current row.

Ctrl+Shift+Home Selects all cells from the cursor to the first cell (A1) in the current sheet.
Moves the cursor along the current row to the cell in the last column

End > ,
containing data in the sheet.

Ctrl+End Moves the cursor to the cell in the last column and row that contain data in
the current sheet.

Shift+End Selects cells alqng the qurrent row from the cursor to the cell in the last
column containing data in the sheet.

Ctr1+Shift+End Selects all cells from the cursor to the cell in the last column and row that

contain data in the current sheet.

Table 9: Other Page Up and Down key shortcuts

Windows / Linux Description

Pg up Moves up one screen page.

Ctrl+Pg up Moves to the previous sheet.

Shift+Pg up Selects cells from the cursor to the row one page up.
Alt+Pg up Moves one screen page to the left.

Alt+Shift+Pg up

Selects cells from the cursor to the column one page to the left.

Pg down

Moves down one screen page.

Ctrl+Pg down

Moves to the next sheet.

Shift+Pg down

Selects cells from the cursor to the row one page down.

Alt+Pg down

Moves one screen page to the right.

Alt+Shift+Pg
down

Selects cells from the cursor to the column one page to the right.

Table 10: Other miscellaneous key shortcuts

Windows / Linux Description

Escape Cancels the current cell edit.

Insert After making a selection, opens the Paste Special dialog.
Ctrl+tInsert g?epriepsag: sg‘leer(;féjnc.:ell or cell range to the clipboard in preparation for a
Shift+Insert Pastes the contents of the clipboard into the selected cells.

Delete Deletes cell contents without a dialog (does not remove formatting).
Shift+Delete Removes and copies the selection to the clipboard.

Ctrl+Backspace Refocuses the view back on the cursor if it is not currently in view.
Shift+Backspace Deselects the current cell selection without deleting contents.
Alt+Backspace Reverses the last command or the last entry you typed.
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Windows / Linux Description

Ctri+[ Selects the cells on which the current cell is dependent.
Ctri+] Selects the cells that are dependent on the current cell.
Ctri+/ Selects the cells in the matrix formula range that contains the cursor.

Copies the contents of the cell above the cursor into the current cell, but
Ctri+’ remains in cell edit mode so that you can make further changes.

Use the single apostrophe key.

Moves the cursor to the next cell in the selected range, from top to bottom,
Enter then left to right. To specify in which direction the cursor moves, go to
Tools > Options > LibreOffice Calc > General on the Menu bar.

Ctrl+Enter Inserts a manual line break in the current cell while editing a cell.

Ctrl+Shift+Enter Creatgs a matrix in the current range using the information entered on the
input line.

Alt+Enter :I:rl]I(I;s the selected cell range with the formula that you entered on the input

Alt+= Equivalent to selecting Select Function > Sum on the Formula bar.

Chart keyboard shortcuts

Table 11 lists some shortcuts that are available within a Calc chatrt.

eTip

You can use the Alt key with the arrow keys and plus (+) and minus (-) keys to
move elements with a finer degree of movement for more accuracy.

Table 11: Chart shortcuts

Windows / Linux Effect

Tab Selects the next chart element.

Shift+Tab Selects the previous chart element.

Home Selects the first chart element.

End Selects the last chart element.

Esc Cancels selection.

Arrow keys Moves the element in the direction of the arrow.

Arrow keys in pie

charts Moves the selected pie segment in the direction of the arrow.

F2 in titles Enters text input mode.

F3in legends and data
series

Ctr 1+F3inlegends
and data series

Opens groups so that you can edit the individual components.

Exits groups.

+/- Enlarges or shrinks the chart (use the +/ - keys in the numeric keypad).

Moves the selected pie segment off or into the pie chart (use the +/ -

N o
/- in pie charts keys in the numeric keypad).
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Outline keyboard shortcuts

Table 12 lists shortcuts that are available in an outline window. To use these shortcuts, press F6
or Shift+F6 until the vertical or horizontal outline window has the focus.

Table 12: Outline shortcuts

Windows / Linux Effect
Tab Cycles through each outline indicator from top to bottom or left to right.
Shift+Tab Cycles through each outline indicator in the opposite direction.

Show all levels up to the specified number while hiding all higher-

Ctri+ltoCtri+g numbered levels in the outline.

Shows (+) or hides (-) the focused outline group (use the + / - keysin

+/- :
the numeric keypad).
Enter Activates the focused indicator button.
Arrow keys Cycles through indicator buttons in the direction of the arrow.

Keyboard shortcuts that cannot be modified

Table 13 identifies the key combinations that are grayed out (not available for modification) in the
Shortcut Keys list on the Keyboard tab of the Tools > Customize dialog with Calc selected.

Table 13: Grayed key combinations in Tools > Customize > Keyboard

Operating system Key combinations grayed in Customize dialog
F1,Ctrl+F1,Shift+F1
Shift+F2

Windows 10 Ctrl+F4,Alt+F4,Ctr1+Alt+F4
F6,Ctrl+F6,Shift+F6, Ctrl+Shift+F6
F10

F1,Ctrl+F1,Shift+F1

Shift+F2
Ctrl+F4,Alt+F4,Ctrl+Alt+F4
F6,Ctrl+F6, Shift+F6, Ctrl+Shift+F6
F10

Ctr1+Shift+0, Ctr1+Shift+1, Ctr1+Shift+2, Ctr 1+Shift+3,
Ctr1+Shift+4,Ctr1+Shift+5, Ctr1+Shift+6, Ctr1+Shift+7,
Ctr1+Shift+8, Ctrl+Shift+9

Linux

macOS keyboard shortcuts

macOS keyboard symbols

Keys on many macOS keyboards use symbols rather than text labels. Table 14 identifies some
common macOS keyboard symbols with their meanings. In the tables that follow, the key names
are used rather than symbols, since the latter may not appear on all macOS keyboards.
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Table 14: Common macOS keyboard symbols

Key name Symbol
Command (shortened to “Cmd” in the tables that follow) a:g
Control (shorted to “Ctrl” in the tables that follow) A\
Option "\
Shift T
Page Up (shortened to “Pg Up” in the tables that follow) $
Page Down (shortened to “Pg Dn” in the tables that follow) $
Home I\
End N\
Delete <
Forward Delete (shortened to “Fwd Del” in the tables that follow) |X>

Keyboard shortcuts for Menu bar options and toolbars

Tables 15 to 18 list Calc keyboard shortcuts that can be used instead of the options on the Menu
bar, the Standard toolbar, or the Formatting toolbar. The toolbars are assumed to contain the
initial default set of icons, without any user customizations.

Table 15: Function key shortcuts for menu and toolbar options

macOS Equivalent Menu bar / toolbar option

F1 Help > LibreOffice Help.

F2 Edit > Cell Edit Mode.

Cmd+F2 Insert > Function.

Cmd+F3 Sheet > Named Ranges and Expressions > Manage.

Shift+F3 Format > Text > Cycle Case.

F4 Sheet > Cycle Cell Reference Types.

Shift+Cmd+F4 View > Data Sources.

F5 View > Navigator.

Cmd+F5 View > Sidebar.

Shift+F5 Tools > Detective > Trace Dependents.

Cmd+F7 Tools > Thesaurus.
Tools > Language > Hangul/Hanja Conversion. The availability of this

Shift+Cmd+F7 menu option depends on selections in LibreOffice > Preferences >
Language Setting > Languages.

Shift+F7 Tools > Automatic Spell Checking.

Cmd+F8 View > Value Highlighting.

F9 Data > Calculate > Recalculate.

Shift+F9 Tools > Detective > Trace Precedents.
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macOS

Equivalent Menu bar / toolbar option

Shift+Cmd+F9 Data > Calculate > Recalculate Hard.
Shift+F11 File > Templates > Save as Tgmplate.
Via drop-down menu on Save icon on Standard toolbar.
F12 Data > Group and Outline > Group.
Cmd+F12 Data > Group and Outline > Ungroup.

Table 16: Number key shortcuts for menu and toolbar options

macOS Equivalent Menu bar / toolbar option
Cmd+1 Format > Cells.
Format > Number Format > Number (use the “1” key on the main
Ctrl+Shift+1 keyboard).
Format as Number icon on Formatting toolbar.
Ctr1+Shift+2 Format > Number Format > Scientific (use the “2" key on the main
keyboard).
. > > “3” i .
Ctril+Shift+3 Format Numb(.ar Format Da?e (use the “3” key on the main keyboard)
Format as Date icon on Formatting toolbar.
Format > Number Format > Currency (use the “4” key on the main
Ctrl+Shift+4 keyboard).
Format as Currency icon on Formatting toolbar.
Format > Number Format > Percent (use the “5” key on the main
Ctrl+Shift+5 keyboard).
Format as Percent icon on Formatting toolbar.
Ctr1+Shift+6 Format > Number Format > General (use the “6” key on the main

keyboard).

Table 17: Letter key shortcuts for menu and toolbar options

macOS Equivalent Menu bar / toolbar option
Cmd+B Formf';lt > Text > Bold. .
Bold icon on the Formatting toolbar.
Shift+Cmd+B Format > Text > Subscript.
Edit > .
cmd+C dit .Copy
Copy icon on the Standard toolbar.
Insert > Comment.
Option+Cmd+C Sheets > Cell Comments > Edit Comment.
Insert Comment icon on the Standard toolbar.
Ccmd+D Sheet > Fill Cells > Fill Down.
Cmd+E Fo.rmat > Alig.n > Centered. .
Align Center icon on the Formatting toolbar.
Option+Cmd+E Tools > Extension Manager.
Cmd+F Edit > Find.
, Edit > Find and Replace.
Option+Cmd+F ' ihd and Repla

Find and Replace icon on the Standard toolbar.
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macOS Equivalent Menu bar / toolbar option

Ctrl+Cmd+F View > Full Screen.
Cmd+H LibreOffice > Hide LibreOffice.
cmd+I For_mgt > Text > ltalic. _
Italic icon on the Formatting toolbar.
Cmd+J Format > Align > Justified.
>H link.
cmd+K Insert ype_r |n'
Insert Hyperlink icon on the Standard toolbar.
Cmd+L Fo_rmat > Align > Left. '
Align Left icon on the Formatting toolbar.
Data > AutoFilter.
Shift+Cmd+L
AutoFilter icon on the Standard toolbar.
CErieM Format _> Clear Direc_t qumatting.
Clear Direct Formatting icon on the Standard toolbar.
Shift+Cmd+M Edit > Edit Mode.
File > New > Spreadsheet.
Cmd+N P

New icon on the Standard toolbar.

File > New > Templates.
Shift+Cmd+N File > Templates > Manage Templates.
Via drop-down menu on New icon on the Standard toolbar.

File > .
cmd+0 lle > Open

Open icon on the Standard toolbar.

. File > Print Preview.

Shift+Cmd+0 re = Fnn o

Toggle Print Preview icon on the Standard toolbar.

ile > Print.

Cmd+P FI|-€‘ _Prmt

Print icon on the Standard toolbar.
Shift+Cmd+P Format > Text > Superscript.
Ccmd+Q LibreOffice > Quit LibreOffice.
Cmd+R Fo_rmat _> AIi_gn > Right. _

Align Right icon on the Formatting toolbar.

File > .
Cmd+S ile .Save

Save icon on the Standard toolbar.
Shift+Cmd+S File > Save As.

o > _

cmd+T View > Styles

Styles > Manage Styles.
Cmd+U Underline icon on the Formatting toolbar.
cmd+V Edit > .Paste.

Paste icon on the Standard toolbar.
Shift+Cmd+V Edit > Paste Special > Paste Special.
S€t10n+3h1ft+0md Edit > Paste Special > Paste Unformatted Text.
Cmd+W Window > Close Window.
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macOS Equivalent Menu bar / toolbar option
s -
Cmd+X Edlt- Cut
Cut icon on the Standard toolbar.
s .
cmd+y Edit .Redo
Redo icon on the Standard toolbar.
Shift+Cmd+Y Edit > Repeat.
s _
cmd+z Edit > Undo

Undo icon on the Standard toolbar.

Table 18: Other shortcuts for menu and toolbar options

macOS Equivalent Menu bar / toolbar option
Shift+Cmd+Pg Up  Edit > Select > Select to Previous Sheet.
Shift+Cmd+Pg Dn Edit > Select > Select to Next Sheet.
Delete Sheet > Clear Cells.

Ctrl+Space Edit > Select > Select Column.
Shift+Space Edit > Select > Select Row.
CtritShifts+Space Edit > Select All.

Cmd+A

Cmd++ Sheet > Insert Cells (use the + key on the numeric keypad).
Cmd+- Sheet > Delete Cells.

Cmd+* Edit > Select > Select Data Area.

Ccmd+; Insert > Date.

Option+Cmd+= Insert > Object > Formula Object.
Shift+Cmd+, :;))lelsi:gsicp::I:r? :che Standard toolbar.
Cmd+, LibreOffice > Preferences.

Other Calc keyboard shortcuts

Tables 19 to 24 provide lists of additional Calc keyboard shortcuts that may be less obvious to
users because they are not indicated on Menu bar items or in tooltips associated with icons on
the Standard and Formatting toolbars.

Table 19: Other function key shortcuts

macOS Description

Shift+F1 Display context sensitive help.

Cmd+F1 Display the comment attached to the current cell.

Shift+Cmd+F2 (I\:/Iu(:\r/:r?ttgee:"f:ursor to the Input line where you can enter a formula for the
Shift+Cmd+FS Moves the cursor to the Name Box field on the Formula bar.
Shift+Cmd+T

F8 Toggles between the standard and extending selection modes.
Shift+F8 Toggles between the standard and adding selection modes.
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Table 20: Other letter key shortcuts

macOS Description

Cmd+G Repeat search forwards.

Shift+Cmd+R Redraws the document view.

Shift+Cmd+Z Reverses the action of the last undo command.

Table 21: Arrow key shortcuts

macOS Description
1 Moves the cell focus up.
Moves the cursor in the up direction to the edge of the current data range
Cmd+1 (if the cell adjacent to the cursor is empty, the cursor moves to the next cell
that contains data).
Shift+1 Selects the adjacent cell or cells located in the up direction.
Selects in the up direction to the edge of the current data range (if the cell
Shift+Cmd+1 adjacent to the cursor is empty, the cursor moves to the next cell that
contains data).
Option+Shift+1 Optimizes the row height based on the current cell.
- Moves the cell focus right.
Moves the cursor in the right direction to the edge of the current data
Cmd+— range (if the cell adjacent to the cursor is empty, the cursor moves to the
next cell that contains data).
Shift+ — Selects the adjacent cell or cells located in the right direction.
Selects in the right direction to the edge of the current data range (if the
Shift+Cmd+ - cell adjacent to the cursor is empty, the cursor moves to the next cell that
contains data).
Option+— Increases the width of the current column.
Option+Shift+— Optimizes the column width based on the current cell.
1 Moves the cell focus down.
Moves the cursor in the down direction to the edge of the current data
Cmd+\ range (if the cell adjacent to the cursor is empty, the cursor moves to the
next cell that contains data).
Option+. Opens a drop-down selection list of text items that have been previously
P typed into other cells in the same column.
Shift+l Selects the adjacent cell or cells located in the down direction.
Selects in the down direction to the edge of the current data range (if the
Shift+Cmd+! cell adjacent to the cursor is empty, the cursor moves to the next cell that
contains data).
Option+Shift+| Optimizes the row height based on the current cell.
- Moves the cell focus left.
Moves the cursor in the left direction the edge of the current data range (if
cmd+ < the cell adjacent to the cursor is empty, the cursor moves to the next cell
that contains data).
Shift+« Selects the adjacent cell or cells located in the left direction.
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macOS Description
Selects in the left direction to the edge of the current data range (if the cell
Shift+Cmd+ < adjacent to the cursor is empty, the cursor moves to the next cell that
contains data).
Option+« Decreases the width of the current column.
Option+Shift+<  Optimizes the column width based on the current cell.

Table 22: Home and End key shortcuts

macOS Description

Home Moves the cursor to the first cell of the current row.

Cmd+Home Moves the cursor to the first cell in the current sheet (Al).

Shift+Home Selects cells from the cursor to the first cell of the current row.

Shift+Cmd+Home Selects all cells from the cursor to the first cell in the current sheet (Al).
Moves the cursor along the current row to the cell in the last column

End . :
containing data in the sheet.

cmd+End Moves the cursor to the cell in the last column and row that contain data
in the current sheet.

Shift+End Selects cells gl(_)ng the current row from the cursor to the cell in the last
column containing data in the sheet.

Shift+Cmd+End Selects all cells from the cursor to the cell in the last column and row that

contain data in the current sheet.

Table 23: Other Page Up and Down key shortcuts

macOS Description

Pg Up Moves up one screen page.

Cmd+Pg Up Moves to the previous sheet.

Shift+Pg Dn Selects cells from the cursor to the row one page up.
Option+Pg Dn Moves one screen page to the left.

gg tion+Shift+Pg Selects cells from the cursor to the column one page to the left.
Pg Dn Moves down one screen page.

Cmd+Pg Dn Moves to the next sheet.

Shift+Pg Dn Selects cells from the cursor to the row one page down.
Option+Pg Up Moves one screen page to the right.

8g tion+Shift+pg Selects cells from the cursor to the column one page to the right.

Table 24: Other miscellaneous key shortcuts

macOS Description

Esc Cancels the current cell edit.

Fwd Del Deletes cell contents without a dialog (does not remove formatting).
Cmd+Delete Refocuses the view back on the cursor if it is not currently in view.
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macOS Description

Option+Delete Reverses the last command or the last entry you typed.
Cmd+[ Selects the cells on which the current cell is dependent.
Cmd+] Selects the cells that are dependent on the current cell.
cmd+/ Selects the cells in the matrix formula range that contains the cursor.

Use the forward slash key on the main keyboard or the numeric keypad.

Copies the contents of the cell above the cursor into the current cell, but
cmd+’ remains in cell edit mode so that you can make further changes.

Use the single apostrophe key.

Moves the cursor to the next cell in the selected range, from top to bottom,
then left to right. To specify in which direction the cursor moves, go to

Enter LibreOffice > Preferences > LibreOffice Calc > General on the Menu
bar.
Cmd+Enter Inserts a manual line break in the current cell while editing a cell.

Shift+Cmd+Enter ﬁrpeue:tﬁrs]ea matrix in the current range using the information entered on the

Fills the selected cell range with the formula that you entered on the input

Option+Enter .
line.

Chart keyboard shortcuts

Table 25 lists some shortcuts that are available within a Calc chart.

ﬂTip

You can use the Option key with the arrow keys and plus (+) and minus (-)
keys to move elements with a finer degree of movement for more accuracy.

Table 25: Chart shortcuts

macOS Effect

-1 Selects the next chart element.

Shift+~ Selects the previous chart element.

Home Selects the first chart element.

End Selects the last chart element.

Esc Cancels selection.

Arrow keys Moves the element in the direction of the arrow.

Arrow keys in pie

charts Moves the selected pie segment in the direction of the arrow.

F2 in titles Enters text input mode.

F3 in legends and data

series Opens groups so that you can edit the individual components.

Cmd+F3 in legends

and data series Exits groups.
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Outline keyboard shortcuts

Table 26 lists shortcuts that are available in an outline window. To use these shortcuts, press F6
or Shift+F6 until the vertical or horizontal outline window has the focus.

Table 26: Outline shortcuts

macOS Effect

-1 Cycles through each outline indicator from top to bottom or left to right.
Shift+- Cycles through each outline indicator in the opposite direction.

Cmd+1 to Cmd+8 Show all levels up to the specified number while hiding all higher-

numbered levels in the outline.

Shows (+) or hides (-) the focused outline group (use the +/ - keys in the

+/- .
numeric keypad).
Enter Activates the focused indicator button.
Arrow keys Cycles through indicator buttons in the direction of the arrow.

Keyboard shortcuts that cannot be modified

Table 27 identifies the key combinations that are grayed out (not available for modification) in the
Shortcut Keys list on the Tools > Customize > Keyboard dialog with Calc selected.

Table 27: Grayed key combinations in Tools > Customize > Keyboard

Operating system Key combinations grayed in Customize dialog
F1,Cmd+F1,Shift+F1

Shift+F2

Cmd+F4, Option+F4, Cmd+Option+F4

F6, Cmd+F6, Shift+F6, Shift+Cmd+F6
F10

Shift+Cmd+0, Shift+Cmd+1, Shift+Cmd+2, Shift+Cmd+3,
Shift+Cmd+4, Shift+Cmd+5, Shift+Cmd+6, Shift+Cmd+7,
Shift+Cmd+8, Shift+Cmd+9

macOS
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