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Windows or Linux macOS equivalent Effect
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Introduction

This chapter describes some common customizations that you may wish to do, in addition to the
options described in Chapter 20, Setting up Writer.

You can customize menus, toolbars, and keyboard shortcuts in LibreOffice, add new menus and
toolbars, and assign macros to events.

Other customizations are made easy by extensions that you can install from the LibreOffice
website or from other providers.

Z Note

Customizations to menus and toolbars can be saved in a template. To do so, first save
them in a document and then save the document as a template as described in
Chapter 10, Working with Templates. If you work on more than one project, you may
find that having different menus and toolbars can be useful.

Customizing menu content

You can add to and rearrange menus on the Menu bar, add commands to menus, and make other
changes. You can also modify context (right-click) menus in a similar way.

To customize menus:

1) Choose Tools > Customize.
2) On the Customize dialog, go to the Menus page (Figure 1) or the Context Menus page.

Customize

Menus | Toolbars | Context Menus | Keyboard | Events

Search [h-,-pe to search l AILibrEOI’ﬁce Writer > |
Categor_vD All commands - B File - Lol
| | | |
E 150% C 5 Open.
200% =
Open Remote...
3D Color ;I v
500 Recent Documents
750 ® Close
About LibreOffice F
Absolute Record (3, Wizards G
Accept \»I Templates
Accept All +
Activation Order = ¥
Add Field | |© reload &
Add Text Box — Versions...
Address Book Source
Aging | save
i:‘gnB s [E] Save Remote...
ign Bottom to Anchor —
Align Left Z|eEeies
Align Middle to Anchor Save a Copy...
Align Right Save All
Align to Bottom of Character Check Out
Align to Bottom of Line Cancel Checkor...
A e kb
Description |Displays the document atits actual size.
Insert v Modify ~ Defaults
Help | | OK || Cancel | Reset

Figure 1: The Menus page of the Customize dialog

3) On the right-hand side, select from the first drop-down list (A in the illustration) whether to
apply the customized menu to all of LibreOffice Writer or only to a specific document.
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4)

5)

6)
7)
8)

9)

Select from the next drop-down list (B) the menu that you want to customize. The list
includes the main menus and submenus. The commands contained in the selected menu
are shown in the box (C) below.

To add a command to the selected menu:
a) Optionally select a command in box C under which the new item will be placed.

b) Optionally filter the Function list by selecting a category (D) on the left, then select the
required item from the Function list (E) and click the right-pointing arrow (F) between
the lists.

c) If necessary, use the up and down arrows on the far right (G) to move the selected
command to a different position.

To remove a menu item from the left-hand list, select it and click the left-pointing arrow
between the lists.

To add a separator line after the highlighted entry, click the Insert button and choose Insert
Separator.

To add a submenu after the highlighted entry, click the Insert button and choose Insert
Submenu. In the pop-up dialog, type a name for the new submenu.

When you have finished making all your changes, click OK to save them.

Creating a new menu

You might find a “Favorites” menu useful, or a menu collecting tools for a specific project. To create
a new menu:

1)

2)
3)

4)

On the Menus page of the Customize dialog, click the + sign next to the list of menus (B) to
display the New Menu dialog (Figure 2). (Not available for context menus.)

Type a hame for the new menu in the Menu name box.

Use the up and down arrow buttons to move the new menu into the required position on the
Menu bar.

Click OK to save.

The new menu now appears on the list of menus in the Customize dialog. (It will appear on the
Menu bar itself after you save your customizations.)

After creating a new menu, you need to add some commands to it, as described above.

[ ) [ ] New Menu
Menu name:

New Menu 1

| Menu position:

File

Edit

View

Insert
| Format

Styles 1+
Table
Tools +
Window
| Help

New Menu 1

Help Gk Cancel

Figure 2: Adding a new menu
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Z Note

Changes to the menus are not immediately displayed. Changes saved to LibreOffice
Writer's menu are displayed the next time Writer is opened. Changes saved to a
document's menu are displayed the next time the document is opened.

Customizing toolbars

You can customize toolbars in several ways, including choosing which icons are visible, locking the
position of a docked toolbar (as described in Chapter 1, Introducing Writer), and adding or deleting
icons (commands) in the list of those available on a toolbar. You can also create new toolbars. The
controls on the Toolbars page of the Customize dialog (Figure 3) are similar to those on the Menus

page.

Customize
Menus | Toolbars | Context Menus | Keyboard | Events
Search Type to search l ILil::re[.‘rl’ﬁce Writer v |
Category  |All commands - éStandard - 4
Function B 3 LoadURL
1500
200% B [ New
3D Color [] Templates
50% A
75% B [ Open
About LibreOffice I;I Open Remote
Absolute Record
Accept ,», B | save 1+
Accept.AII 2] save As —=J
Activation Order ¥
Add Field « (=] E-mail =
Add Text Box —
Address Book Source
Aging Edit Mode
Align
Align Bottom to Anchor
Align Left B ki poF
Align Middle to Anchor
Align Right [ epue
Align to Bottom of Character =] g Print
Align to Bottom of Line o
i P 3 Print Directiv
Description |Displays the document at its actual size.
Insert « Modify « Defaults
Help | | OK || Cancel | Reset

Figure 3: The Toolbars page of the Customize dialog

Choosing icons for toolbar commands

Toolbar buttons usually have icons, not words, on them, but not all of the commands have
associated icons. If the command does not have an icon, you can choose an icon for it. To choose
an icon, select the command in the list on the right (marked A in Figure 3), and click Modify >
Change icon. On the Change Icon dialog, scroll through the available icons, select one, and click
OK to assign it to the command.

To use a custom icon, create it in a graphics program and import it into LibreOffice by clicking the
Import button on the Change Icon dialog (Figure 4). Custom icons should be 16x16 pixels in size.
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st Change Icon X

Icons Import...
WMEFABO AV @

QeI IGCE S
Enl B ZBEL Y
FawSFYFOBREIAEGO
QoE /DeiBE0 D

i
U

Delete...

lii
z
3

4 2l
= @

I
@]

Note:
The size of an icon should be 16x16 pixel to achieve best quality.
Different sized icons will be scaled automatically.

Help [ 0K ] l Cancel

Figure 4: Change Icon dialog

Assigning shortcut keys

In addition to using the built-in keyboard shortcuts, you can define others. You can assign shortcuts
to standard LibreOffice functions or your own macros and save them for use with Writer or with the
entire LibreOffice suite.

To adapt shortcut keys to your needs, use the Keyboard page of the Customize dialog (Figure 5).

N Customize X

|Menus| Toolbars‘ Context Menus || Keyboard| Events|

Shortcut Keys () LibreOffice
| ;

F2 Formula |_| © Writer

F3 Run AutoText Entry Modify

F4

F5 Navigator

6 Delete

F7 Spelling

F8 Extended Selection On Load...

F9 Fields

F10 Save..

F11 Styles

F12 MNumbering I Reset ‘
n Ta lina Dal

Functions

[T;.fpe to search

Category Function Keys
: . | = J
Application 150% L
Templates 200%

Options 3D Color

BASIC U 509

Special Functions 75%

View About LibreOffice

Insert Absolute Record

Documents Accept

Format Accept All

Edit At

Help I OK I I Cancel ‘ I Reset

Figure 5: Defining keyboard shortcuts for applying styles

1) Choose whether to have the shortcut key assignment available in all components of
LibreOffice or only in Writer.

2) Select the desired shortcut key in the Shortcut keys list at the top of the page.
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3) Select the required function from the Category and Function lists.
4) Click the Modify button. The selection now appears in the Keys list on the lower right.
5) Click OK to accept the change.

Repeat as required.

£7 Note

Shortcut keys that are grayed-out in the listing on the Customize dialog, such as F1
and F10, are not available for reassignment.

Saving changes to a file

Changes to the shortcut key assignments can be saved in a keyboard configuration file for use at a
later time, so you can create and apply different configurations as needed. To save keyboard
shortcuts to a file:

1) After making keyboard shortcut assignments, click the Save button on the Keyboard page
of the Customize dialog (Figure 5).

2) Inthe Save Keyboard Configuration dialog, type a name for the keyboard configuration file
in the File name box, or select an existing file from the list. Browse to the location where
you want to save the file.

3) Click Save. A confirmation dialog appears if you are about to overwrite an existing file,
otherwise there will be no feedback and the file will be saved.
Loading a saved keyboard configuration

To load a saved keyboard configuration file and replace your existing configuration, click the Load
button on the Customize dialog, and then select the configuration file from the Load Keyboard
Configuration dialog.

Assigning macros to events

An “event” can be something like a document is opened, a key is pressed, or the mouse moved.
You can associate a macro with an event, so the macro is run when the event occurs. For
example, a common use is to assign the “open document” event to run a macro that performs
certain setup tasks for the document.

To associate a macro with an event, use the Events page of the Customize dialog. For more
information, see Chapter 13, Getting Started with Macros, in the Getting Started Guide.

Adding functionality with extensions

An extension is a package that can be installed into LibreOffice to add new functionality. They can
add new top-level menus, submenus or toolbar icons. Extensions may also have their own
settings, available from the extension manager.

Several extensions are shipped bundled with LibreOffice and are installed with the program.
Others can be downloaded from various websites. The official extension repository is located at
http://extensions.libreoffice.org/. These extensions are free of charge.

Some extensions from other sources are free of charge; others are available for a fee. Check the
descriptions to see what licenses and fees apply to the ones that interest you.
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Installing extensions
Extensions can be installed in these ways:
* From the *.oxt file in your system's file browser. Double-click the file.

* From the Extension Manager, as follows:

1) In LibreOffice, select Tools > Extension Manager from the Menu bar.

2) Inthe Extension Manager dialog (Figure 6), click Add.

3) Afile browser window opens. Find and select the extension you want to install and click
Open.

4) Users with administrator or root privileges will see a dialog where they can choose to
install extensions "for all users" (shared) or "only for me" (user). Users without those
privileges can install, remove, or modify extensions only for their own use.

5) The extension begins installing.

In each case, during the process you may be asked to accept a license agreement. When the
installation is complete, the extension is listed in the Extension Manager dialog.

‘:Q:‘ Tip

To get extensions that are listed in the repository, you can open the Extension
Manager and click the Get more extensions online link. You do not need to

download them separately.

® 0@ Extension Manager

x English spelling dictionaries, hyphenation rules, th... 2017.05.01 [

French spelling dictionary, hyphenation rules, ... 6.0.3 Dicollecte (=
fl" Dictionnaire «Classique» 6.0.3 « Synonymes 2.4 « Césures 3.0 Pour signa...

Solver for Nonlinear Programming 0.9 The Document Foundation [
VE This extension integrates into Calc and offers new Solver engines to use fo...

Spanish spelling dictionary, hyphenation rules, and t... 2.1 rla-es [
VE Crtografia 2.1 - Separacion 0.2 - Sindnimos 24/02/2013 Para notificar erro...

 Check for Updates  Add

Display Extensions
) Bundled with LibreOffice [ Installed for all users ¥ Installed for current user

Get more extensions online...

Help Close

Figure 6: Using the Extension Manager

Adding functionality with extensions | 9



Adding custom colors

Versions of LibreOffice before 5.3 had a Colors page in Tools > Options, where you could add
custom colors to a color palette, for example to exactly match a corporate color scheme. This page
has been removed. The method for defining a custom color is now as follows:

1)
2)
3)

Insert any drawing object, such as a square, into any document.
Right-click on the object and choose Area from the context menu.
Go to the Color tab (Figure 7). Under Colors > Palette, choose which palette you wish to

add the new color to. Under New, define the new color using RGB or Hex notation, or click
the Pick button to select the color on the Pick a Color page (Figure 8).

Area | Shadow | Transparency

| MNone | Color

[ Gradient ||

Bitmap

Pattern || Hatch |

Colors

Palette: |standard

-

-

|
Cm
| | |
[
]

EREECICCC
EREEOCCN
ERRREECC
ERRREEOC
EEEEEECO .
ENEEEECEE
EREERREECEE
EEEEEREEEC
EEEEEEECE
ERRRREACEC
 HAEERRECOCIEC]
EEEEECOCOCE

Active

G |159

B |207

Hex

729fcf

New

-l
[
ra

(]

m
(5]
(5]

=
Aap| ap ap

Hex [166f37

4

Name

Please enter a name for the new color:

Pick & |

w |

ooz

Recent Colors

Help

Lo«

)

Cancel |

Custom Palette

[ Add | Delete

1
g | Help |
i

Figure 7: Defining a new color

oK Cancel Reset |

4) Click Add in the lower left corner, enter a name for the new color in the pop-up dialog, and

click OK to save.

5) Delete the drawing object from the document, if it is not needed.
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o Pick a Color X

RGB
) Red: b :
) Green: |&:
) Blue: 70 -
Hex #:

HSB
© Hue: hase |3

() Saturation: |9?'}ﬁ v

) Brightness: |E4% v

CMYK
Cyan: |:9?'}'b :
Magenta: [(J'}'b :
l vellow: 57% |3

— B

Help | DK H Cancel J

Figure 8: Defining a color by picking it from a color chart

Adding fonts

LibreOffice supports PostScript (.pfb), TrueType (.ttf), and OpenType (.otf) font file formats. Other
font formats exist, and may be supported by your operating system, but these formats may be
limited in selection and quality.

If you have administration privileges, you can install additional fonts through your operating
system; they will then be available for use by LibreOffice and will appear in Writer’s font lists.

Finding free-licensed fonts

In addition to proprietary fonts from sources like Adobe, hundreds of free-licensed fonts are
available. You can use, share, and edit free-licensed fonts as you please. Most are available at no
cost. Many are clones or near-variations of classic fonts, but some are original fonts.

Many Linux distributions include a few free-licensed fonts in their package repositories. Other
places where you can find free-licensed fonts include The League of Moveable Type
(https://lwww.theleagueofmoveabletype.com/), Open Font Library (http://openfontlibrary.org/).
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