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Direct formatting

The key idea to use computers in document production is to split a document in the combination of 
contents and formatting. While contents is originated in human intellectual activity, formatting is a 
task computers can perform easily and is often repetitive.

Formatting a document can be manual or automated. The manual formatting or direct formatting is 
performed when user format each element of the document individually, as it was done at times 
when typewriters were used in offices, page by page. Direct formatting is a repetitive activity 
where, for example, you apply bold characters to several words, set individual margins for each 
paragraph, or change font size of a heading.

In contrast, style formatting is a modern way to let computers format documents much more 
efficiently and reduce the time spent in direct formatting.

What are styles?

Style are a set of formats that you can apply to selected pages, text, frames, and other elements in
your document to quickly change their appearance. Applying a style often means applying a whole 
group of formats at the same time.

Many people manually format paragraphs, words, tables, page layouts, and other parts of their 
documents without paying any attention to styles. They are accustomed to writing documents 
according to physical attributes. For example, you might specify the font family, font size, and any 
formatting such as bold or italic, like a typewriter described above.

Styles are logical attributes. Using styles means that you stop saying “font size 14pt, Times New 
Roman, bold, centered” and you start saying “Title” because you have defined the “Title” style to 
have those characteristics. In other words, using styles means that you shift the emphasis from 
what the text (or page, or other element) looks like, to what the text is.

Styles help improve consistency in a document. They also make major formatting changes easy. 
For example, you may decide to change the indentation of all paragraphs, or change the font of all 
titles. Doing this manually for a long document may require making individual changes in dozens of
places. By contrast, when you use styles, you only need to make a single change.

In addition, styles are used by LibreOffice for many processes, even if you are not aware of them. 
For example, Writer relies on heading styles (or other styles you specify) when it compiles a table 
of contents. Some common examples of style use are given in “Examples of style use” on page 21.

LibreOffice supports the following types of styles:

• Page styles include margins, headers and footers, borders and backgrounds. In Calc, page 
styles also include the sequence for printing sheets.

• Paragraph styles control all aspects of a paragraph’s appearance, such as text alignment, 
tab stops, line spacing, and borders, and can include character formatting.

• Character styles affect selected text within a paragraph, such as the font and size of text, or
bold and italic formats.

• Table Styles applies predefined formats to tables and tables elements in a text document.

• Frame styles are used to format graphic and text frames, including text wrap, borders, 
backgrounds, and columns.

• List styles allow you to select, format, and position numbers or bullets in lists.

• Cell styles include fonts, alignment, borders, background, number formats (for example, 
currency, date, number), and cell protection.

• Graphics styles in drawings and presentations include line, area, shadowing, transparency, 
font, connectors, dimensioning, and other attributes.
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• Presentation styles include attributes for font, indents, spacing, alignment, and tabs.

Different styles are available in the various components of LibreOffice, as listed in Table 1.

LibreOffice comes with many predefined styles. You can use the styles as provided, modify them, 
or create new styles, as described in this chapter.

Table 1. Styles available in LibreOffice components

Style Type Writer Calc Draw Impress

Page X X

Paragraph X

Character X

Frame X

Numbering X

Table X

Cell X

Presentation X X

Graphics (included in 
Frame styles)

X X

Applying styles

LibreOffice provides several ways for you to select styles to apply:

• The Styles menu in Writer

• The Styles deck in the Sidebar

• Fill Format Mode

• Apply Style List in the Formatting toolbar

• Keyboard shortcuts

Using the Styles menu in Writer
The Styles menu has the most important paragraph, character, and list styles for almost every text 
document, with an extra entry for custom style management options listed in the bottom of the 
menu. The Styles menu does not have styles for frames, pages, or tables.

To apply a paragraph style, position the cursor anywhere in the paragraph, and then select one of 
the paragraph styles in the Styles menu. To apply a character style to several characters or more 
than one word, select the characters first and apply the character style from the menu.

Note

You cannot add custom styles to the Styles menu.

Using the sidebar Styles deck
The Styles deck (called Styles and Formatting in some installations) includes the most complete 
set of tools for styles. To use it for applying styles:

 1) Select View > Styles or Styles > Manage Styles from the Menu bar, or press F11 ( +T ⌘
on a Mac), or click the Styles tab in the Sidebar (View > Sidebar to open it).

The Styles deck shows previews of the styles available. Figure 1 shows the panel for 
Writer, with Paragraph Styles visible.
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 2) Select one of the buttons at the top left of the Styles deck to display a list of styles in that 
category.

 3) To apply an existing style, position the insertion point in the paragraph, frame, page, or 
word, and then double-click the name of the style in one of these lists. To apply a character 
style to more than one word, select the characters first.

Tip

At the bottom of the Styles deck is a drop-down list. In Figure 1 the panel might show 
Applied Styles, meaning the list includes only the styles used in the document. You 
can choose to show all styles or other groups of styles, for example only custom 
styles.

Figure 1: The Styles deck for Writer, showing paragraph styles

Using Fill Format Mode
Use Fill Format to apply a style to many different areas quickly without having to go back to the 
Styles deck and double-click every time. This method is quite useful when you need to format 
many scattered paragraphs, cells, or other items with the same style:

 1) Open the Styles deck and select the style you want to apply.

 2) Select the Fill Format Mode button.

 3) To apply a paragraph, page, or frame style, hover the mouse over the paragraph, page, or 
frame and click. To apply a character style, hold down the mouse button while selecting the 
characters. Clicking a word applies the character style for that word.

 4) Repeat step 3 until you have made all the changes for that style.

 5) To quit Fill Format mode, click the Fill Format Mode button again or press the Esc key.

Caution

When this mode is active, a right-click anywhere in the document undoes the last Fill 
Format action. Be careful not to accidentally right-click and undo actions you want to keep.

Using the Set Paragraph Style list
After you have used a paragraph style at least once in a document, the style name appears in the 
Set Paragraph Style list at the left-hand end of the Formatting toolbar.
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You can open this list and click the style you want, or you can use the up and down arrow keys to 
move through the list and then press Enter to apply the highlighted style.

Tip

Select More at the bottom of the Apply Style list to open the Styles deck.

Figure 2: The Set Paragraph Style list 
on the Formatting toolbar

Using keyboard shortcuts
Some keyboard shortcuts for applying styles are predefined. For example, in Writer Ctrl+0 applies 
the Text body style, Ctrl+1 applies the Heading 1 style, and Ctrl+2 applies the Heading 2 style. You
can modify these shortcuts and create your own; see Chapter 14, Customizing LibreOffice, for 
instructions.

Direct formatting and Style formatting
Direct formatting (also called manual formatting ) overrides styles, and you cannot remove the 
direct formatting by applying a style to it.

To remove manual formatting, select the text, right-click, and choose Styles > Clear Direct 
Formatting from the context menu, or select the text and press Ctrl+M.

Creating and modifying styles

LibreOffice includes some predefined styles, but you can also create custom styles. You can 
modify both  in several ways:

• Change a style using the Styles deck

• Update a style from a selection

• Use AutoUpdate (paragraph and frame styles only)

• Load styles from another document or template
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Note

Any changes you make to a style are effective only in the current document. To 
change styles in more than one document, you need to change the template or copy 
the styles into the other documents as described on page 10.

Changing a style using the Styles deck
To change an existing style using the Styles deck, open the Sidebar Styles deck, then right-click on
the required style and select Modify from the pop-up menu.

The Style dialog displayed depends on the type of style selected. Each Style dialog has several 
tabs. See the chapters on styles in the user guides for details.

Updating a style from a selection
To update a style from a selection:

 1) Open the Styles deck in the Sidebar.

 2) In the document, select an item that has the format you want to adopt as a style.

Caution

When updating a paragraph style, make sure that the selected paragraph contains 
unique properties. If it mixes font sizes or font styles, those mixed properties will 
remain the same as before.

 3) In the Styles deck, select the style to update, then click on the arrow next to the New Style 
from Selection icon and click Update Style.

Figure 3: Updating a style from a selection

Tip

You can also modify styles using the submenu on each style in the Set Paragraph 
Style list on the Formatting toolbar (see Figure 4).
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Figure 4: Modifying a style from the Set Paragraph Style list

Using AutoUpdate
AutoUpdate applies to paragraph and frame styles only. If the AutoUpdate option is selected on the
Organizer page of the Paragraph Style or Frame Style dialog, applying direct formatting to a 
paragraph or frame using this style in your document automatically updates the style itself.

Tip

If you are in the habit of manually overriding styles in your document, be sure that 
AutoUpdate is not enabled.

Updating styles from a document or template
You can update styles by copying (loading) them from a template or another document. See 
“Copying styles from a template or document” on page 12.

Creating new (custom) styles

You may want to add some new styles. You can do this by using either the New Style dialog or the 
New Style from Selection tool.

Creating a new style using the New Style dialog
To create a new style using the New Style dialog, open the sidebar Styles deck and select the 
category of style (eg. paragraph, character, etc.) wish to create by clicking one of the icons at the 
top of the deck, then click the arrowhead on the right hand icon and select New from the pop-up 
menu.

If you want your new style to be linked with an existing style, first select that style from the list of 
styles shown in the deck, then right-click on the selected style and select New.

If you link styles and you later change the base style (for example, by changing the font from Times
to Helvetica), all the linked styles will change as well. Sometimes this is exactly what you want; 
other times you do not want the changes to apply to all the linked styles. It pays to plan ahead.

The dialogs and choices are the same for defining new styles and for modifying existing styles. 
See the chapters on styles in the user guides for details.
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Tip

If a document needs custom styles derived from base styles, consider prefixing the 
name of the custom styles with a few characters to highlight them among other styles 
in the list. For example, you might name a modified Heading 1 style for an annual 
report AR Heading 1.

Creating a new style from a selection
You can create a new style by copying an existing manual format. This new style applies only to 
this document; it will not be saved in the template.

 1) Open the Styles deck and choose the category of style you want to create.

 2) In the document, select the item you want to save as a style.

 3) In the Styles deck, select on the New Style from Selection icon.

 4) In the Create Style dialog, type a name for the new style. The list shows the names of 
existing custom styles of the selected category. Click OK to save the new style.

Figure 5: Naming a new style created from a selection

Dragging and dropping to create a style
You can drag and drop a selection into the Styles deck to create a new style. The element to drag 
depends upon the LibreOffice application.

Writer
Select some text and drag it to the Styles deck. If Paragraph Styles are active, the paragraph
style will be added to the list. If Character Styles are active, the character style will be added 
to the list.

Calc
Drag a cell selection to the Styles deck to create a cell style.

Draw/Impress
Select and drag a drawing object to the Styles deck to create a graphic style.

Adding table styles in Writer
Table styles are stored in the LibreOffice user profile, and are available to all Writer documents. 
You can define new table styles following these steps:

 1) Create a table and apply formatting for cells, backgrounds, borders and more.

 2) Select the whole table.
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 3) Drag the table and drop in the Table Styles category of the Styles deck in the sidebar.

Alternatively, 

 1) Open menu Table > AutoFormat Styles and click the Add button (Figure 6).

 2) Enter a name for the new table style, click OK

 3) The new table style is listed in the left pane of the dialog. Click OK again to close the 
AutoFormat dialog.

Figure 6: Table autoformat styles

The new table style can be applied to tables as described in Applying styles on page 6.

Copying styles from a template or document

You can copy styles into a document by loading them from a template or from another document:

 1) Open the document you want to copy styles into.

 2) In the Styles deck, click the arrow next to the New Style from Selection icon, and then 
select Load Styles (see Figure 3).

 3) On the Load Styles dialog (Figure 7), find either a template or an ordinary document from 
which to copy styles. Click the From File button to open a window from which to select the 
required document.

 4) Select the categories of styles to copy from the checkboxes at the bottom of the dialog.

 5) Select Overwrite if you want to replace styles in the original document that have the same 
name as styles in the document from which you are importing styles. If this box is not 
selected, you will only copy styles whose names are not used in the original document.

 6) Click OK to copy the styles.

Figure 7: Copying styles from a template into the open document
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Caution

If your document has a table of contents, and if you have used custom styles for 
headings, the heading levels associated with outline levels in Tools > Outline 
Numbering will revert to the defaults of Heading 1, Heading 2, and so on when you 
load Text Styles from a file that does not use the same custom styles. You will need to 
change these back to your custom heading styles.

Note: 

You cannot copy character style into a document. Table styles, including custom table 
styles are stored in your computer and are available to all Writer documents.

Deleting styles

You cannot remove (delete) any of LibreOffice’s predefined styles from a document or template, 
even if they are not in use.

You can remove any user-defined (custom) styles; but before you do, you should make sure the 
styles are not in use in the current document. 

To delete any unwanted styles, in the Styles deck select each one to be deleted (hold Ctrl while 
selecting multiple styles), and then right-click on a selected style and select Delete on the context 
menu.

If the style is not in use, it is deleted immediately without confirmation. If the style is in use, you 
receive a warning message asking you to confirm deletion.

Caution

If you delete a style that is in use, all objects with that style will return to the default 
style.

What is a template?

A template is a model document that you use to create other documents. For example, you can 
create a template for business reports that has your company’s logo on the first page. New 
documents created from this template will always have your company’s logo on the first page.

Templates can contain anything that regular documents can contain, such as text, graphics, a set 
of styles, and user-specific setup information such as measurement units, language, the default 
printer, and toolbar and menu customization.

All documents in LibreOffice are based on templates. You can create a specific template for any 
document type (text, spreadsheet, drawing, presentation). If you do not specify a template when 
you start a new document, then the document is based on the default template for that type of 
document. If you have not specified a default template, LibreOffice uses the blank template for that
type of document that is installed with LibreOffice. See “Setting a default template” on page 18 for 
more information.

You can create templates for Master Documents as well as for ordinary documents.
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Using a template to create a document

Creating a document from the Templates dialog
To use a template to create a document:

 1) From the Menu bar, choose File > New > Templates. You can also click on the small arrow
next to the New icon and select Templates. The Templates dialog opens.

 2) From the listbox at the top of the dialog, select the category of template you want to use. All
the templates contained in that folder are listed on the page (as shown in Figure 8).

 3) Select the required template and click OK, or double-click on the selected template. A new 
document based on the template opens in LibreOffice.

The template the document is based upon is listed in File > Properties > General. The connection
between the template and the document remains until the template is modified and, the next time 
that the document is opened, you choose not to update it to match the template.

Figure 8: Templates dialog, showing a selected template

Creating a document from a template in the Start Center
You can create a document from the template view of the Start Center. The Start Center is visible 
when no other document is open.

To open the Templates dialog from the Start Center, click on the Templates button in the left pane. 
The button is also a drop-down list to select the templates of a given type of document. The 
Manage Templates option on the list opens the Templates dialog (Figure 8).

Creating a template

You can create templates in two ways: by saving a document as a template or by using a wizard.

Creating a template from a document
In addition to formatting, any settings that can be added to or modified in a document can be saved
within a template. For example, you can also save printer settings, and general behaviors set from 
Tools > Options, such as Paths and Colors.

Templates can also contain predefined text, saving you from having to type it every time you create
a new document. For example, a letter template may contain your name, address, and salutation.
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You can also save menu and toolbar customization in templates; see Chapter 14, Customizing 
LibreOffice, for more information.

To create a template from a document and save it to My Templates:

 1) Open a new or existing document of the type you want to make into a template (text 
document, spreadsheet, drawing, or presentation).

 2) Add any content that you want to appear in any document you create from the new 
template, for example company logo, copyright statement, and so on.

 3) Create or modify any styles that you want to use in the new template.

 4) From the Menu bar, choose File > Templates > Save as Template. The Save as Template 
dialog (Figure 9) opens, displaying the existing categories and a textbox to enter a name for
the new template.

 5) Select the My Templates folder.

 6) Click Save. The template is saved and the dialog closes.

Figure 9: Save as Template dialog

Note

Although the Save as Template dialog shows no document type when saving a new 
template of any type, the template will appear on the correct tab (Documents, 
Spreadsheets, Presentations, Drawings) when you return to the Templates dialog.

Creating a template using a wizard
You can use wizards to create templates for letters, faxes, and agendas.

For example, the Fax Wizard guides you through the following choices:

• Type of fax (business or personal)

• Document elements like the date, subject line (business fax), salutation, and complimentary
close

• Options for sender and recipient information (business fax)

• Text to include in the footer (business fax)

To create a template using a wizard:

 1) From the Menu bar, choose File > Wizards > [type of template required] (see Figure 10).

 2) Follow the instructions on the pages of the wizard. This process is slightly different for each 
type of template, but the format is very similar.
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 3) In the last section of the wizard, you can specify the template name which will show in the 
Templates dialog, and also the name and location for saving the template. The two names 
can be different but this may later cause confusion. The default location is your user 
templates directory, but you can choose a different location.

 4) To set the file name or change the directory, select the Path button (the three dots to the 
right of the location). The Save As dialog opens. Make your selections and click Save to 
close the dialog.

Figure 10: Creating a template using a wizard

 5) Finally, you can choose whether to create a new document from the template immediately, 
or manually change the template, and then click Finish to save the template. For future 
documents, you can re-use the template created by the wizard, just like any other template.

You may need to open the Templates dialog and click Refresh on the Settings menu to have any 
new templates appear in the listings.

Editing a template

You can edit a template’s styles and content, and then, if you wish, you can reapply the template’s 
styles to documents that were created from that template. You cannot reapply content.

To edit a template:

 1) From the Menu bar, choose File > Templates > Manage Templates or press Ctrl+Shift+N. 
The Templates dialog opens. You can also open the Templates dialog from the Start Center.

 2) Navigate to the template that you want to edit. Click once on it to activate the file handling 
controls (see Figure 8). Right-click to open the context menu click Edit. The template opens
in LibreOffice.

 3) Edit the template as you would edit any other document. To save your changes, choose 
File > Save from the Menu bar.

Updating a document from a changed template
If you make any changes to a template and its styles, the next time you open a document that was 
created from the template before the changes, a confirmation message is displayed.

To update the document:

 1) Click Update Styles to apply the changed styles in the template to the document.

 2) Select Keep Old Styles if you do not want to apply the changed styles in the template to 
the document (but see the Caution notice below).
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Caution

If you choose Keep Old Styles, the document is no longer connected to the template, 
even though the template is still listed under File > Properties > General. You can still
import styles manually from the template, but to reconnect it to the template, you will 
have to copy it into an empty document based on the template. 

Adding templates obtained from other sources

LibreOffice refers to sources for templates as repositories. A repository can be local (a directory on 
your computer to which you have downloaded templates) or remote (a URL from which you can 
download templates).

You can get to the official template repository by using the Browse Online Templates button at 
the lower left-hand end of the Templates dialog, as shown in Figure 11, or by typing 
https://extensions.libreoffice.org/templates in your browser’s address bar.

On other websites you may find collections of templates that have been packaged into extension 
(OXT) files. These are installed a little differently, as described below.

Figure 11: Getting more templates for LibreOffice

Installing individual templates
To install individual templates:

 1) Download the template and save it anywhere on your computer.

 2) Import the template into a template folder by following the instructions in “Importing a 
template” on page 20.

Tip

You can manually copy new templates into the template folders. The location varies 
with your computer’s operating system. To learn where the template folders are stored 
on your computer, go to Tools > Options > LibreOffice > Paths.

Installing collections of templates
The Extension Manager provides an easy way to install collections of templates that have been 
packaged as extensions. Follow these steps:

 1) Download the extension package (OXT file) and save it anywhere on your computer.

 2) In LibreOffice, select Tools > Extension Manager from the Menu bar. In the Extension 
Manager dialog, click Add to open a file browser window.

 3) Find and select the package of templates you want to install and click Open. The package 
begins installing. You may be asked to accept a license agreement.

 4) When the package installation is complete, restart LibreOffice. The templates are available 
for use through File > Templates > Manage Templates and File > New > Templates and 
the extension is listed in the Extension Manager.
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See Chapter 14, Customizing LibreOffice, for more about the Extension Manager.

Setting a default template

If you create a document by choosing File > New > Text Document (or Spreadsheet, 
Presentation, or Drawing) from the Menu bar, LibreOffice creates the document from the default 
template for that type of document. You can, however, change the default whenever you choose.

Note for Microsoft Word users

You may know that Microsoft Word employs a normal.dot or normal.dotx file for 
its default template and how to regenerate it.

LibreOffice does not have a similar default template file; the “factory defaults” are 
embedded within the software.

Setting a template as the default
Most default settings, such as page size and page margins, can be changed in Tools > Options, 
but those changes apply only to the document you are working on. To make those changes the 
default settings for that document type, you need to replace the default template with a new one.

You can set any template displayed in the Templates dialog to be the default for that document 
type:

 1) From the Menu bar, choose File > Templates > Manage Templates.

 2) In the Templates dialog, open the category containing the template that you want to set as 
the default, then select the template.

 3) Right-click on the selected template and click the Set as default button (see Figure 8).

The next time that you create a document of that type by choosing File > New, the document will 
be created from this template.

Resetting the default template
To re-enable LibreOffice’s original default template for a document type as the default for that type:

 1) In the Templates dialog, click the Action Menu icon on the bottom left (Figure 12).

 2) Point to Reset Default Template on the drop-down menu, and click Text Document (or 
other template type).

These choices do not appear unless a custom template has been set as the default, as described 
in the previous section.

The next time that you create a document by choosing File > New, the document will be created 
from the original default template for the document type.

Figure 12: Resetting the default template for text documents
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Organizing templates

LibreOffice can manage only those templates that are in its template folders or categories. You can
create new template categories and use them to organize your templates. For example, you might 
have one template category for report templates and another for letter templates. You can also 
import and export templates.

To begin, choose File > Templates > Manage Templates to open the Templates dialog.

Creating a template category
To create a template category:

 1) Click the Action button of the Templates dialog.

 2) Click New category on the context menu (see Figure 13).

 3) In the pop-up dialog, type a name for the new category and click OK.

Figure 13: Creating a new category

Note

You cannot create a sub-category inside a template category in LibreOffice.

Deleting a template category
You cannot delete template categories supplied with LibreOffice. Nor can you delete any 
categories added by the Extension Manager unless you first remove the extension that installed 
them.

However, you can delete a category that you created. Open the Templates dialog, choose the 
category from the Filters drop-down lists at the top of the dialog. Then click the Settings button 
and select Delete from the pop-up menu (See Figure 13). When a message box appears asking 
you to confirm the deletion, click Yes.

Moving a template
To move a template from one template category to another, select it in the Templates dialog, and 
click the Move button in the bottom center of the dialog. In the popup dialog (Figure 14), select the 
destination category and click OK.
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Figure 14: Moving templates to another category

Deleting a template
You cannot delete templates supplied with LibreOffice. Nor can you delete any templates installed 
by the Extension Manager except by removing the extension that installed them.

However, you can delete templates that you have created or imported:

 1) From the Filters drop-down lists at the top of the Templates dialog, select the category  that
contains the template you want to delete.

 2) Select the template to delete.

 3) Right-click on the template to open the context menu and click Delete (Figure 8).

 4) A message box appears and asks you to confirm the deletion. Click Yes.

Importing a template
While it not essential to store templates in one of the folders listed for the Template path in Tools > 
Options > LibreOffice > Paths before you can use a template in LibreOffice, but it is the easiest 
and most convenient way of managing templates. To import a template:

 1) In the Templates dialog, click the Import button on the bottom right. The Select Category 
dialog appears.

 2) Find and select the category where you want to import the template and click OK. A 
standard file browser window opens.

 3) Find and select the template that you want to import and click Open. The file browser 
window closes and the template appears in the selected category.

Exporting a template
To export a template from a template category to another location in your computer or network:

 1) In the Templates dialog, locate the category that contains the template to export.

 2) Select the template that you want to export.

 3) Click the Export button in the bottom right of the dialog. The Save As window opens.

 4) Find the folder into which you want to export the template and select Save.
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Examples of style use

The following examples of common use of page and paragraph styles are taken from Writer. There
are many other ways to use styles; see the guides for the various components for details.

Defining a different first page for a document
Many documents, such as letters and reports, have a first page that is different from the other 
pages in the document. For example, the first page of a letterhead typically has a different header, 
or the first page of a report might have no header or footer, while the other pages do. With 
LibreOffice, you can define the page style for the first page and specify the style for the following 
pages to be applied automatically.

As an example, we can use the First Page and Default page styles that come with LibreOffice. 
Figure 15 shows what we want to happen: the first page is to be followed by the default page, and 
all the following pages are to be in the Default page style. Details are in Chapter 4, Formatting 
Pages, in the Writer Guide.

Figure 15: Flow of page styles

Dividing a document into chapters
In a similar way, you can divide a document into chapters. Each chapter might start with the First 
Page style, with the following pages using the Default page style, as above. At the end of the 
chapter, insert a manual page break and specify the next page to have the First Page style to start 
the next chapter, as shown in Figure 16.

Figure 16: Dividing a document into chapters using page styles

Changing page orientation within a document
A Writer document can contain pages in more than one orientation. A common scenario is to have
a landscape page in the middle of a document, whereas the other pages are in a portrait 
orientation. This setup can also be created with page breaks and page styles.

To insert a landscape page in the middle of your document, insert a page break and select a page 
style with the landscape orientation on. LibreOffice default landscape page style is Landscape. You
may have to adjust the other page properties such as headers, footers, and page numbering of the
landscape style. To go back to the portrait page style, insert another page break and select the 
default portrait page style of your document.
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Displaying different headers on right and left pages
Page styles can be set up to have the facing left and right pages mirrored or only right (first pages 
of chapters are often defined to be right-page only) or only left. When you insert a header on a 
page style set up for mirrored pages or right-and-left pages, you can have the contents of the 
header be the same on all pages or be different on the right and left pages. For example, you can 
put the page number on the left-hand edge of the left pages and on the right-hand edge of the right
pages, put the document title on the right-hand page only, or make other changes.

Controlling page breaks automatically
Writer automatically flows text from one page to the next. If you do not like the default settings, you
can change them. For example, you can require a paragraph to start on a new page or column and
specify the style of the new page. A typical use is for chapter titles to always start on a new right-
hand (odd-numbered) page.

Compiling an automatic table of contents
To compile an automatic table of contents, first apply styles to the headings you want to appear in 
the contents list, then use Tools > Outline Numbering to tell Writer which styles go with which 
level in the table of contents. By default, tables of contents use Heading styles, but you can use 
whatever combination of styles you prefer. See Chapter 4 for more information.

Defining a sequence of paragraph styles
You can set up one paragraph style so that when you press Enter at the end of that paragraph, the 
following paragraph automatically has the style you wish applied to it. For example, you could 
define a Heading 1 paragraph to be followed by a Text Body paragraph. A more complex example 
would be: Title followed by Author followed by Abstract followed by Heading 1 followed by Text 
Body. By setting up these sequences, you can usually avoid having to apply styles manually.

Formatting a table in Writer
Tables in a Writer document can have a predefined set of formatting attributes applied, including 
cell background, font, emphasis, and number formatting (Figure 17). To apply table styles, position 
the cursor in the table to be formatted and choose Table > AutoFormat Styles in the main menu 
and select a style from the dialog that appears.  Or, alternatively, position the cursor in the table to 
be formatted and double click on a style listed in the Table Styles tab of the Styles menu or the 
sidebar. 

Figure 17: Some table styles in LibreOffice

For more information refer to the LibreOffice Writer guide, Chapter 13: Tables of Data.
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