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Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.

Windows or Linux Mac equivalent Effect

Tools > Options menu  LibreOffice > Preferences Access setup options
selection

Right-click Control+click Opens a context menu

Ctrl (Control) 3 (Command) Used with other keys

F5 Shift+¥+F5 Opens the Navigator

F11 #B+T Opens the Styles and Formatting window
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Introduction

This chapter describes how to do the following in Writer, Calc, Draw, and Impress:

* Create hyperlinks within a document and to other documents such as web pages, PDFs,
and other files.

¢ Save documents as web pages (HTML documents).
When creating a document that you plan to deliver as a web page, you need to consider the
following:

* Inan HTML document, hyperlinks are active (clickable) but other cross-references inserted
by LibreOffice are not active links.

* An object such as a image is saved as a separate file. However, if that object has been
placed in a frame (for example, with an associated caption), it is not saved and does not
appear in the HTML document; instead, the name of the frame appears.

Relative and absolute hyperlinks

Hyperlinks stored within a file can be either relative or absolute.

Arelative hyperlink says, Here is how to get there starting from where you are now (meaning from
the folder in which your current document is saved) while an absolute hyperlink says, Here is how
to get there no matter where you start from.

An absolute link will stop working if the target is moved. A relative link will stop working if the start
and target locations change relative to each other. For instance, if you have two spreadsheets in
the same folder linked to each other and you move the entire folder to a new location, an absolute
hyperlink will break but a relative one will not.

To change the way that LibreOffice stores the hyperlinks in your file, select Tools > Options >
Load/Save > General and choose if you want URLs saved relatively when referencing the File
System, or the Internet, or both.

Calc will always display an absolute hyperlink. Don’t be alarmed when it does this even when you
have saved a relative hyperlink—this ‘absolute’ target address will be updated if you move the file.

Make sure that the folder structure on your computer is the same as the file structure
Note on your web server if you save your links as relative to the file system and you are
going to upload pages to the Internet.

When you rest the mouse pointer on a hyperlink, a help tip displays the absolute
reference, since LibreOffice uses absolute path names internally. The complete path

Tip and address can only be seen when you view the result of the HTML export (saving
the spreadsheet as an HTML file), by loading the HTML file as Text, or by opening it
with a text editor.

Creating hyperlinks

When you type text (such as a website addresses or URL) that can be used as a hyperlink, and
then press the spacebar or the Enter key, LibreOffice automatically creates the hyperlink and
applies formatting to the text (usually a color and underlining). If this does not happen, you can
enable this feature using Tools > AutoCorrect Options > Options and selecting the URL
Recognition option.
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If you do not want LibreOffice to convert a specific URL to a hyperlink, choose Edit > Undo Insert
from the menu bar or press Control+Z immediately after the formatting has been applied. You can
also place the cursor in the hyperlink, right-click, and choose Remove Hyperlink.

To change the color of hyperlinks, go to Tools > Options > LibreOffice >
Appearance, scroll to Unvisited links and/or Visited links, pick the new colors and
) click OK. Caution: this will change the color for all hyperlinks in all components of
Tip LibreOffice; this may not be what you want.

In Writer and Calc (but not Draw or Impress), you can also change the Internet link
character style or define and apply new styles to selected links.

You can also insert hyperlinks using the Navigator and the Hyperlink dialog, and you can modify all
hyperlinks using the Hyperlink dialog as described in this section.

Using the Navigator
The easiest way to insert a hyperlink to another part of the same document is by using the
Navigator:

1) Open the documents containing the items you want to cross-reference.

2) Open the Navigator by clicking its icon £ , by choosing View > Navigator, or by pressing
F5.

3) Click the arrow next to the Drag Mode icon, and choose Insert as Hyperlink. (See
Figure 1.)

4) In the list at the bottom of the Navigator, select the document containing the item that you
want to cross-reference.

5) In the Navigator list, select the item that you want to insert as a hyperlink.

6) Drag the item to where you want to insert the hyperlink in the document. The name of the
item is inserted in the document as an active hyperlink.

Navigator

O-EEp |J|=- 5
E‘a @ = E E | v Insert as Hyperlink
Insert as Link
Insert as Copy

T

- = Headings
Copyright
Introduction
Relative and absolute hyperli
Creating hyperlinks:

Saving Calc spreadsheets as
Saving Impress presentationsv
£ ¥

0112GS3-CreatingWebPages |S |+

Figure 1: Inserting a hyperlink using the Navigator

When using the Navigator to hyperlink to an object such as a graphic, to have the hyperlink show
useful text such as 2009 Sales Graph, you need to give such objects useful names instead of
leaving them as the default names (“Graphics6”), or you need to edit the resulting link text using
the Hyperlink dialog, as described below.

You can also use the Navigator to insert a hyperlink from one document (the source) to a specific
place in another document (the target). Open the Navigator in the target document and drag the
item to the spot in the source document where you want the hyperlink to appear.
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Using the Hyperlink dialog

To display the dialog, click the Hyperlink icon on the Standard toolbar or choose Insert >

Hyperlink from the menu bar. To turn existing text into a link, highlight it before opening the dialog.

Hyperlink
l Hypetlink tvpe
. (#) Weh {JETP () Telnet
Internet Target o
2 o]
Mail & News
i
=] Further settings
= F F --
Docurment Lame Ml Torm Text ¥
Texk
e T
(= Marne
—
Mewy Docurent
[ Apply l [ Close ] [ Help ] [ Back

Figure 2. Hyperlink dialog showing details for Internet links

On the left side, select one of the four categories of hyperlink:
* Internet: the hyperlink points to a web address, normally starting with http://

* Mail & News: the hyperlink opens an email message that is pre-addressed to a particular
recipient

* Document: the hyperlink points to another document or to another place in the current
document

* New document: the hyperlink creates a new document

The top right part of the dialog changes according to the choice made for the hyperlink category in
the left panel. A full description of all the choices and their interactions is beyond the scope of this
chapter. Here is a summary of the most common choices.

For an Internet hyperlink, choose the type of hyperlink (Web, FTP, or Telnet), and enter the
required web address (URL).

For a Mail and News hyperlink, specify whether it is a mail or news link, the receiver’s address,
and for email, also the subject.

For a Document hyperlink, specify the document path (the Open File button opens a file browser)
or leave this blank if you want to link to a target in the same document. Optionally specify the target
in the document (for example a specific slide). Click on the Target in Document icon to open the
Navigator where you can select the target; or if you know the name of the target, you can type it
into the box.

For a New Document hyperlink, specify whether to edit the newly created document immediately
(Edit now) or just create it (Edit later), enter the file name, and select the type of document to
create (text, spreadsheet, and so on). Click the Select Path button to open a file browser and
choose where to store the file.
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The Further settings section in the bottom right part of the dialog is common to all the hyperlink
categories, although some choices are more relevant to some types of links.

* Set the value of Frame to determine how the hyperlink will open. This applies to documents
that open in a Web browser.

* Form specifies if the link is to be presented as text or as a button. Figure 3 shows a link
formatted as a button. A hyperlink button is a type of form control. See Chapter 15 of the
Writer Guide for more information.

BS v fmw = = |
4 | B | C | D
L
_Z |
3 Authors |
4
3|

Figure 3: Authors hyperlink as button (in Calc)

* Text specifies the text that will be visible to the user. If you do not enter anything here,
LibreOffice uses the full URL or path as the link text. Note that if the link is relative and you
move the file, this text will not change, though the target will.

* Name is applicable to HTML documents. It specifies text that will be added as a NAME
attribute in the HTML code behind the hyperlink.

* Events button : click this button to open the Assign Macro dialog and choose a macro
to run when the link is clicked. See Chapter 13, Getting Started with Macros, for more
information.

Editing hyperlinks

To edit an existing link, click anywhere in the link text and then click the Hyperlink icon & | on the
Standard toolbar or choose Edit > Hyperlink from the menu bar or right-click and choose Edit
Hyperlink from the context menu. The Hyperlink dialog opens. Make your changes and click
Apply. If you need to edit several hyperlinks, you can leave the Hyperlink dialog open until you
have edited all of them. Be sure to click Apply after each one. When you are finished, click Close.

The standard (default) behavior for activating hyperlinks within LibreOffice is to use Ctrl+click. This
behavior can be changed in Tools > Options > LibreOffice > Security > Options, by deselecting
the option Ctrl-click required to follow hyperlinks. If clicking in your links activates them, check
that page to see if the option has been deselected.

Removing hyperlinks

You can remove the clickable link from hyperlink text—leaving just the text—Dby right-clicking on the
link and selecting Remove Hyperlink. You may then need to re-apply some formatting in order for
the text to match the rest of your document.

To erase the link text or button from the document completely, select it and press the Backspace or
Delete key.
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Saving Writer documents as web pages

Writer's HTML capabilities include saving existing documents in HTML format, creating new
documents as HTML (not described here), and creating several different types of web pages using

a wizard.

The easiest way to create HTML documents is to start with an existing Writer document. You can
get a good idea of how it will appear as a web page by using View > Web Layout. However, web
layout view will not show you which features will or will not save correctly to HTML. Some

considerations are described in the introduction to this chapter.

Saving a document as a single web page

To save a document as a single web page (HTML format), choose File > Save As and specify

HTML Document as the file type.

Writer does not replace multiple spaces in the original document with the HTML code

Note

Saving a document as a series of web pages

Writer can save a large document as a series of web pages (HTML files) with a table of contents

page. To do this:

for non-breaking spaces. If you want to have extra spaces in your HTML file or web
page, you need to insert non-breaking spaces in LibreOffice. To do this, press
Control+Spacebar instead of just Spacebar.

1) Decide which headings in the document should start on a new page and make sure all
those headings have the same style (for example, Heading 1).

2) Choose File > Send > Create HTML Document.

3) Inthe Name and Path of the HTML Document dialog, type the file name to save the pages
under. Also specify which style indicates a new page (as decided in step 1).

-

Mame and Path of the HTML Document
Save in: |_,'r 001.9.100 testdocs j &5 Ef-
- | ,il webpage, html
ky Recent
Documents
— L —_—
(&
Dezktop
-
kA y etk
Pl
A= File narne: |wel:upagn32 ﬂ Save |
Save as type: |HTML Docurnent ﬂ Cancel
Styles: |Heading 1 |
Default
Figure
Heading 1

Figure 4. Creating a series of web pages from one document
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4) Click Save to create the multi-page HTML document. The resulting HTML files conform to

the HTML 4 Transitional.

Creating web pages using a Wizard

LibreOffice’s Web wizard allows you to create several types of standard web pages. To use it:

1) Choose File > Wizards > Web Page. On the first page of the Wizard, choose settings and
click Next >. If this is your first web page, the only choice is <default>.

Web Wizard

Steps

2. Documnents

Introduction

Zhoose settings For the Web Wizard

<default=

This Web \Wizard is bo aid you in publishing documents on the Internet,

It will conwert the documents so that they can be viewed by 3 web browser, In addition, it
will generate a Table of Contents page with links For easy access to the documents. The
Web Wizard will also allow vwiou to cuskomize the design and layout of your web sike,

You will be able to keep the documents you have published on the web up-to-date and add
or remove documents at any time,

Zancel

2) Choose or browse to the document you would like to format. The Title, Summary and

Author information is picked up from the document’s properties; if necessary, edit it. Click

Next >.

Steps

1. Introduction

&, Documents

3. Main layout

4, Layouk details

5. Skyle

&. Web site information

7. Preview

Select the documents you want to publish

Web site content
0117G5-CreatingWebPages. sxw

add. || Remove

Export ko File Format:
HTML

Diocurnent infFarmation

Title:

Creating Web Pages
SUmmary:

Fields to edit:

Chapter Title : Description

kab = Title
“hanter Suhbtitle 1 lzer Defined

Author:

Creating web pages using a Wizard



3) Chose a layout for the web site by clicking on the layout boxes. Click Next >.

Steps Choose a layout for the table of contents of your web site
1. Inkroduckion Layouts:
2. Documents

o= o= 0o
3. Main lawouk 0= o= 0=

o= o= 0o
4, Layout details —

o=

o=
5. Skyle o=
&, Web site information 5=
7. Preview

Simple

4) Chose the information to be listed and the screen resolution. Click Next >.

Steps Customize the selected layout
1. Introduction Include the Fallowing inFormation For each docurment in the kable of conkents:
2. Documents

_ [ Ele name [ File Format
3. Main layout Description File Format icon
4, [ authar [] Mumber of pages

[] creation date Size in KB

5. Style [] Last change date

&, ‘Web site information

7. Preview Optimize the lavout For screen resolution:

) 640480
(%) 800600
) 1024x768

5) Select a style for the page. Use the drop-down list to choose different styles and color
combinations. You can browse to select a background image and icon set from the Gallery.
Click Next >.

Steps select a style for the table of contents page

1. Inktraduction Shyle: “Waker ™

Background image: <no background image =
3. Main layout -

4, Lawout details

2. Documents

The icon set is used For presentations in HTML Format,

&. Wweb site information

7. Preview

Document
Creation Date
Last Change Date
Filename
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6) Enter general information such as Title and HTML Metadata information. Click Next >.

Steps Enter general information for your web site
1. Inktraduckion Title: Test Website
Z. Dacuments

3. Main lavout HTML Metadata

4. Layout details Description: Test Data

5. Style E-rnail:

6. Web site information
Copyright notice;

7. Preview
Created: 26/05/05 hd|

Madified: 26,/05/05 hd|

7) Chose where to save the file and preview the page if you wish. Click Finish.

Steps Where do you want to publish your web site?
1. Intraduction Click. 'Preview' to see a preview in vour browser:
3. Main layout Publish the new web site:

To a |ocal Folder
CihDocuments and Settings|Jean Hollis \WeberMy Docurnentsifty Websites

L]

4, Layout details
5. Skwle

[] To a ZIP archive
6. Web site information

7. Preview

Publishing via FTP Prosxy is not supported.

Save setkings (recommended)
Save as: Web Wizard Settings1 2

.

To edit or view the document’s underlying HTML code, open the document, and then choose
View > HTML Source or click the HTML Source icon on the Main toolbar.

Saving Calc spreadsheets as web pages

Calc can save files as HTML documents. As for Writer, choose File > Save As and select HTML
Document, or choose File > Wizards > Web Page.

If the file contains more than one sheet, the additional sheets will follow one another in the HTML
file. Links to each sheet will be placed at the top of the document. Calc also allows the insertion of
links directly into the spreadsheet using the Hyperlink dialog.

Saving Calc spreadsheets as web pages 11



Saving Impress presentations as web pages

You can export presentations as Macromedia Flash files: choose File > Export and select
Macromedia Flash for the file type.

You can also convert presentations into a series of web pages, as described below.

Note

Saving as web pages (HTML format) does not retain animation and slide transitions.

1) To begin, choose File > Export and select HTML Document as the file type.

2) Create a folder for the files, supply a name for the resulting HTML file, and click Save. The
HTML Export Wizard opens.

Note

Depending on the size of your presentation and the number of graphics it contains,
the HTML export function may create many HTML, JPG, and GIF files. If you simply
save to your desktop (not in a specific folder), these separate HTML and graphics
files will be all over your desktop. So be sure to create a folder to hold all the files.

3) Choose the design for all of the pages, either from an existing design or by creating a new
one. If you have not previously saved a design, the Existing Design choice is not available.

HTML Export

Assign design
{*) Mew design
{:} Existing Design

Select an existing design or create a new one

Samnle Mecian

gt

ﬂelp l [ Cancel Mext == ] [ Create

4) Click Next to select the type of web pages to create.

Standard HTML: one page for each slide, with navigation links to move from slide to
slide.

Standard HTML with frames: one page with a navigation bar on the left-hand side; uses
slide title as navigation links. Click on links to display pages in right-hand side.

Automatic: one page for each slide, with each page set with the Refresh meta tag so a
browser automatically cycles from one page to the next.

WebCast: generates an ASP or Perl application to display the slides. Unfortunately
LibreOffice has no direct support for PHP yet.

12
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HTML Export

Publication type

{:} Automatic
() webCast

LIS

{(*) Standard HTML format
{7 standard HTML with frames

Options
Create title page

[ e |

[ Cancel ] [

<< Back ] [ Mext == ] [ Create

5) Decide how the images will be saved (PNG, GIF, or JPG) and what resolution to use.
When choosing a resolution, consider what the majority of your viewers might be using. If
you specify a high resolution, then a viewer with a medium-resolution monitor will have to
scroll sideways to see the entire slide, which isprobably not desirable.

HTML Export

Save graphics as -
@ PNG

C gk
O PG

LIS

[75% Quality

Manitor resolution
® Low resolution (640x480 pixels)

 High resclution (1024x768 pixe

& Medium resolution (B00x800 pixels)

|s)

Effects

Export sounds when slide advances

| Hep

|| cence ||

<< Back

Create

6) If Create title page was chosen in step 4, supply the information for it on the next page. The
title contains an author name, e-mail address and home page, along with any additional
information you want to include.

This page of the Wizard does not display if Create title page was not chosen.

Saving Impress presentations as web pages
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HTML Export

Infarmation for the title page
Author Peter Hilier Brook

E-mail address
Your homepage

Additional information ::A_

[ ] Link to a copy of the original presentation

[ Help ] [ Cancel ] [ < < Back ] [ Mext == l [ Create

7) Choose the navigation button style to use to move from one page to another. If you do not
choose any, LibreOffice will create a text navigator.

HTML Export <)
[ IS S S
Select button style -
[ Text only
(e ﬂ EEEEEE
i'i‘/ ».. »l %HAAH .. A/n
elelslalals]e e
€& = I
l Help l [ Cancel l [ << Back l MNext == Create

8) Select the color scheme for the web pages. Available schemes include the document’s
existing scheme, one based upon browser colors, and a completely user-defined scheme.
You can save a new scheme so that it will appear on the first page of the HTML export
wizard.

14
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HTML Export

LIS

Select color scheme —

(=) Apply color scheme from document
{3 Use browser colors

{1 Use custom color scheme

[ Text ] - - [ e
[ fipeick ] Hyperlink
[ Active Link | Active link
[ Visited Link || visited link
| Help J[ concel || <<Back

9) Click Create to generate the HTML files. If this is a new design, a small dialog pops up. If
you might want to reuse this design, you can give it a name and save it. Otherwise, click
Do Not Save.

-,

Mame HTML Design

[ Do Mot Save ]

Saving Draw documents as web pages

Exporting drawings from LibreOffice’s Draw application is similar to exporting a presentation from
Impress. Choose File > Export and select HTML Document as the file type.

When using the wizard, you can choose to create the web page at any time by clicking the Create
button.

Saving Draw documents as web pages 15
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