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Designing a presentation

In addition to careful planning of the content, as discussed in Chapter 1 Introducing Impress, you 
need to plan the appearance of the presentation. It is best to do this after you have developed an 
outline, because the outline will determine some of the requirements for the appearance of the 
slides. For example:

• What color combinations (background and text) will look good and also be easy for your 
audience to read?

• Would a picture help your audience understand the contents better?

• Do you want particular text and a picture to appear on all the slides? For example a 
company name and logo.

• Would the audience benefit from having the slides numbered so that they can quickly refer 
to one of them?

• Do you want a background graphic or gradient? If so, you need to pick something that does 
not interfere or clash with content such as the colors used in charts.

• Will you need one slide master or more than one? Will one slide design suit all of the 
content?

You can change the appearance of slides as you develop the presentation, but planning ahead will 
save you time in the long run.

What are slide masters?

A slide master is a slide that is used as the starting point for other slides. It is similar to a page style 
in Writer: it controls the basic formatting of all slides based on it. A slide show can have more than 
one slide master.

Note
LibreOffice uses three terms for one concept: slide master, master slide, and master 
page. All refer to a slide which is used to create other slides. This book uses the term
slide master, except when describing the user interface.

A slide master has a defined set of characteristics, including the background color, graphic, or 
gradient; objects (such as logos, decorative lines, and other graphics) in the background; headers 
and footers; placement and size of text frames; and the formatting of text.

All of the characteristics of slide masters are controlled by styles. The styles of any new slide you 
create are inherited from the slide master from which it was created. In other words, the styles of 
the slide master are available and applied to all slides created from that slide master. Changing a 
style in a slide master results in changes to all the slides based on that slide master. It is, however, 
possible to modify each individual slide without affecting the slide master.

Note
Although it is highly recommended to use the slide masters whenever possible, there 
are occasions where manual changes are needed for a particular slide, for example 
to enlarge the chart area when the text and chart layout is used. 

Slide masters have two types of styles associated with them: presentation styles and graphic 
styles. The prepackaged presentation styles can be modified, but new presentation styles cannot 
be created. For graphic styles, you can modify the prepackaged styles and also create new styles.

Presentation styles are discussed in detail in Chapter 3, Working with Text. The use of graphic 
styles is covered in Chapter 6, Formatting Graphic Objects. See also “Working with styles in 
Impress” on page 14.
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Working with slide masters

Impress comes with a collection of slide masters. These slide masters are shown in the Master 
Pages section of the Tasks pane (Figure 1). This section has three subsections: Used in This 
Presentation, Recently Used, and Available for Use. Click the expand marker (usually a downward-
pointing triangle or + sign) next to the name of a subsection to expand it and show thumbnails of 
the slides, or click the collapse marker (usually an upward-pointing triangle or a – sign) to collapse 
the subsection to hide the thumbnails.

Each of the slide masters shown in the Available for Use list is from a template of the same name. 
If you have created your own templates, or added templates from other sources, slide masters 
from those templates will also appear in this list. See “Working with templates” on page 15 for more
information about templates.

Figure 1: Slide (page) masters in Tasks Pane

Figure 2: Master View toolbar

Creating slide masters
You can create a new slide master which is similar to modifying the default slide master.

1) Enable editing of slide masters by selecting View > Master > Slide Master on the main 
menu bar and the Master View toolbar opens (Figure 2). If the Master View toolbar does 
not appear, go to View > Toolbars and select Master View.

2) Alternatively, right-click on a slide master in the Master Pages section of the tasks pane 
that you want to use and select Edit Master to open the Master View toolbar.

3) On the Master View toolbar, click the New Master icon .
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4) A new slide master appears in the Slides pane. Modify this slide master to suit your 
requirements.

5) It is also recommended that you rename this new slide master. Right-click on the slide in 
the Slides pane and select Rename master from the context menu.

6) When finished creating a slide master, click Close Master View on the Master View toolbar
and return to normal slide editing mode.

Applying a slide master
To apply a slide master to all the slides in your presentation:

1) In the Tasks Pane, make sure the Master Pages section is showing (Figure 1).

2) To apply one of the slide masters to all slides in your presentation, right-click on it from the 
available selection and select Apply to All Slides on the context menu.

To apply a different slide master to one or more selected slides:

1) In the Slide Pane, select the slide or slides where you want to use a new slide master.

2) In the Tasks Pane, right-click on the slide master you want to apply to the selected slides, 
and select Apply to Selected Slides on the context menu.

Loading additional slide masters
Sometimes, in the same set of slides, you may need to mix multiple slide masters that may belong 
to different templates (the use of templates is explained in “Working with templates” on page 15). 
For example, you may need a completely different layout for the first slide of the presentation, or 
you may want to add a slide from a different presentation to your current presentation (based on a 
template available on the hard disk).

1) Go to Format > Slide Design on the main menu bar or right-click on a slide in the Slides 
Pane and select Slide Design from the context menu to open the Slide Design dialog 
(Figure 3). This dialog shows the slide masters already available for use.

Figure 3: Slide Design
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2) To add more slide masters, click the Load button to open the Load Slide Design dialog 
(Figure 4).

Figure 4: Load Slide Design dialog

3) Select in the Load Slide Design dialog the template from which to load the slide master and 
click OK.

4) Click OK again to close the Slide Design dialog.

5) The slide masters in the template you selected to use are now shown in the Available for 
use subsection of Master Pages.

Note

The slide masters you have loaded will also be available the next time you load the 
presentation. If you want to delete the unused slide masters, click the corresponding 
checkbox in the Slide Design dialog. If the slide master was not used in the 
presentation, it is removed from the list of available slide masters.

Tip
To limit the size of the presentation file, you may want to minimize the number of 
slide masters used.

Modifying a slide master
The following items can be changed on a slide master:

• Background (color, gradient, hatching, or bitmap)

• Background objects (for example, adding a logo or decorative graphics)

• Text attributes for the main text area and notes

• Size, placement, and contents of header and footer elements to appear on every slide

• Size and placement of default frames for slide titles and content

To select the slide master for modification:

1) Select View > Master > Slide Master from the main menu bar. This unlocks the properties 
of a slide master so you can edit it as shown in Figure 5.

2) Select a slide master in Master Pages in the Tasks pane.

3) Right-click on the slide master you want to modify and select Edit Master from the context 
menu.

4) Make changes as required to the slide master, then click the Close Master View icon on 
the Master View toolbar or go to View > Normal on the main menu bar to exit from editing 
slide masters.

5) Save your presentation file before continuing.

Working with slide masters 7



Figure 5: Example master view

Caution
Any changes made to one slide when in Master View mode will appear on all slides 
using this slide master. Always make sure you close Master View and return to 
Normal view before working on any of the presentation slides. Select View > 
Normal from the menu bar, or clicking Close Master View in the Master View 
toolbar to return to the normal slide view.

The changes made to one of the slides in Normal view (for example, changes to the bullet point 
style, the color of the title area, and so on) will not be overridden by subsequent changes to the 
slide master. There are cases, however, where it is desirable to revert a manually modified element 
of the slide to the style defined in the slide master: to do that, select that element and choose 
Format > Default Formatting from the main menu bar.

It is also possible to modify the default layout of the slide master, for example by moving the title to 
the side; however, you are restricted to modifications to the “Title, Text” layout (that is, the layout 
containing a title box and a text box).

Sometimes, depending on the contents of the slide, you may want to apply a different layout. The 
title and text boxes will inherit the properties of the slide master, but if you have changed the 
position of these text boxes in the slide master, the layout may appear corrupted and you may 
need to re-position some of the layout elements manually.

Selecting and applying backgrounds
Backgrounds can be applied to a number of elements in Impress: the page, a default text area, a 
graphic object and so on. The procedures to apply a background are always the same and the 
following procedure is used to apply a background to the page.

1) Select Format > Page on the main menu bar. On the Page Setup dialog, select the 
Background tab (Figure 6).

2) Alternatively, select Format > Styles and Formatting from the main menu bar, or press 

F11, or click the Styles and Formatting icon  on the Line and Filling toolbar to open the 
Styles and Formatting dialog (Figure 7).
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Figure 6: Background options in Page Setup dialog

Figure 7: Presentation Styles

Figure 8: Selecting a background color in the Page Setup dialog
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3) Select the Presentation Styles icon  and right-click Background and select Modify from 
the context menu. This opens the Background dialog, which has one tab (Area) and offers 
the same options as the Background tab in the Page Setup dialog.

4) Select the type of fill you want for your background from the five options in the drop-down 
menu: None, Color, Gradient, Hatching, or Bitmap.

5) A list of options for the selected fill type then appears. Figure 8 shows an example of 
background colors.

6) Select one of the options on the Fill list and click OK. The option you have selected is 
added to the slide master, replacing any previously selected fill.

Tip

You can make custom additions to each type of background, with the obvious 
exception of None. After you create new fills, they are listed in the Background dialog 
along with the fills provided with LibreOffice, see Chapter 6 Formatting Graphic 
Objects for more information.

Adding background objects
This section describes how to add background objects and graphic elements (such as a logo, 
decorative lines, and so on). LibreOffice supports a large number of graphic formats.

When you want the same graphic to appear on every slide of your presentation, the easiest and 
quickest solution is to use the slide master. It saves time while creating the presentation and when 
you want to modify or reposition the graphic on all the slides. If the same graphic is added to each 
slide manually, these operations have to be performed on each individual slide in the presentation.

For example, one of the most common actions in preparing a presentation is to add a picture to the 
slide master. To insert a picture already available on the computer, follow these steps:

1) Select View > Master > Slide Master on the main menu bar to open the master view.

2) Select Insert > Picture > From File on the main menu bar to open the file browser.

3) Navigate to the directory where your picture is located and select it. If you want to see a 
preview, select the Preview checkbox in the file browser dialog.

4) Click Open and the picture is placed into your slide.

Once the picture is inserted onto your slide, you need to move it to the background as follows:

1) With the picture selected, right-click on the picture and select Arrange > Send to Back 
from the context menu.

2) Reposition the picture and, if necessary,  modify its size. See Chapter 4 Adding and 
Formatting Pictures for more information.

In addition to pictures you can add a number of other background objects, for example decorative 
lines, text and shapes.

Caution

LibreOffice offers the option to insert a picture as a link to the file rather than 
embedding it in the document. This can be useful when a presentation is not intended 
for distribution onto other computers, but where it will remain in the same computer 
and directory structure. For example, it could be created on a notebook computer, 
which is to be used to give the presentation to a group of clients.

However, if the presentation file is to be distributed onto other computers, the picture 
must be embedded to avoid the “missing picture” syndrome when the presentation is 
given on a different computer.
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Tip

If you want the image to blend with the background, you can set the background color 
of the picture as transparent. Select the picture, then Tools > Color Replacer from 
the main menu bar. Select the first checkbox, move the mouse cursor onto the picture 
and click on the color you want to make transparent. This color appears next to the 
checkbox. Make sure that Replace with... is set to Transparent and click Replace.

Tip

An easy way to make the picture lighter so that the text stands out better against its 
background, is to increase the transparency of the picture or change the gamma 
luminance of the picture. Both these adjustments can be quickly made from the 
Picture toolbar.

Slide master styles
Within the slide master you can define a complete set of styles for the default appearance of text 
and graphic objects inserted in slides based on that background. If for example your slide master 
has a dark background, you may want to set the font color of the title and text areas to be light. 
Rather than manually changing the font color for every new slide you create, a time-consuming 
operation prone to errors and omissions, simply modify the style in the slide master. Changes 
made to styles in the slide master only apply to the slides based on that particular slide master.

To work on the slide master styles,  press F11, or select Format > Styles and Formatting from the 

main menu, or click the Styles and Formatting icon  on the Line and Filling toolbar to open the 
Styles and Formatting dialog (Figure 7 for Presentation styles and Figure 9 for Graphic styles).

The Styles and Formatting dialog is a floating dialog. Press F11 to close the Styles and Formatting 
dialog when you do not need it. LibreOffice will remember its position the next time you open the 
Styles and Formatting dialog.

Styles in Impress are sub-divided into two main categories: Presentation styles and Graphics 
styles.

Figure 9: Graphic Styles and Formatting dialog

Working with slide masters 11



Presentation styles
Presentation styles (Figure 7) affect three elements of a slide master: the background, background 
objects (such as icons, decorative lines, and text frames), and the text placed on the slide. Text 
styles are further divided into Notes, Outline 1 through Outline 9, Subtitle, and Title. The outline 
styles are used for the different levels of the outline to which they belong. For example, Outline 2 is 
used for the sub-points of Outline 1, and Outline 3 is used for the sub-points of Outline 2.

The presentation styles can be modified, but new presentation styles cannot be created.

Graphics styles
Graphics styles (Figure 9) apply to lines, shapes and text boxes created using the Impress drawing 
tools and define the formatting of such objects. You can create additional styles or modify the 
included styles.

Note

The presence of text and title styles both in the Presentation and Graphics styles may 
seem confusing. This apparent duplication is because Impress uses special text 
boxes when adding structured text to slides where Presentation styles apply 
(AutoLayout boxes). The title and other text styles in Graphics styles continue to apply 
to other text boxes you may want to add, or to text associated with shapes or lines.

Tip
At the bottom of the Styles and Formatting dialog is a drop-down list where you can 
choose to show either Hierarchical, All Styles, Hidden Styles, Applied Styles or 
Custom Styles in the dialog window.

Modifying default text areas
When a slide master is opened for editing, it contains five areas, as shown in Figure 5 on page 8.

• Title area for AutoLayouts

• Object area for AutoLayouts

• Date area

• Footer area

• Slide number area

Position and size
Click with the left mouse button on any of these areas to display the selection handles around the 
rectangle. Use these handles to modify the size and position of the area.

• To change the position, move the mouse towards one of the edges, not on a selection 
handle, and click the left mouse button. The cursor changes shape which is dependent on 
your computer setup (normally a clenched hand).

• To modify the shape and size of one of the rectangular areas, use one of the selection 
handles. The corner handles modify the height and width of the rectangle simultaneously 
while the side handles modify only one dimension at a time. The shape of the mouse cursor 
usually changes shape when over a handle, giving a clear visual indication of how it will 
affect the shape of the rectangular area.

Tip

To keep the shape of the rectangular area constant, move the mouse to one of the 
four corner handles and keep the Shift key pressed while dragging the handle with 
the mouse. The rectangle maintains the ratio between the width and height 
dimensions of the rectangle.
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To accurately control the shape and size as well as the position of the default text area, it is better 
to use the Position and Size dialog than the mouse.

1) Select the rectangular area by clicking on the border.

2) Press F4, or go to Format > Position and Size on the main menu bar, or right-click on the 
border and select Position and Size from the context menu to open the Position and Size 
dialog (Figure 10).

Figure 10: Position and Size dialog

The functions of this dialog are explained in the Draw Guide, so only short descriptions of the most 
important fields are provided in this chapter.

• Use the Position section to specify the X (horizontal) and Y (vertical) position of the 
rectangular area. The values represent the distance of the selected base point and the 
default position is the top left corner of the slide.

• Use the Size section to specify the width and height of the rectangular area. In the Base 
point section, select a point on the rectangular area that you do not want to move while 
resizing. The default setting of top left corner means that the position of the top left corner 
of the area will not change after resizing.

• Use the Rotation page of the dialog to rotate the default text area. For example, you can 
place the footer area on the side by rotating each text area by 90 degrees and obtain a 
more modern-looking layout. In general it is preferable to use only right angles for ease of 
editing, although the program does not impose restrictions on the values that can be used.

Background, border, arrangement and alignment
Besides the shape, size and position, it is also possible to modify other aspects of the editable 
areas on the slide master, such as the background, border, alignment relative to the slide, and 
position relative to other objects.

While the background style and line style of an area can be accessed from the Format menu, to 

access the Alignment and Arrange menus you need either to click on the Arrange  and 

Alignment  icons on the Line and Filling toolbar or right-click on the border to open the context 
menu.
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Date and slide number
The date area and slide number area do not automatically appear on every slide, even if you have 
defined them. To show them on every slide:

1) Close the Master View.

2) Select the desired field from the main menu: Insert > Page number or Insert > Date and 
time. See Chapter 8 Adding and Formatting Slides, Notes, and Handouts for more 
information.

Adding text to all slides
Some of the supplied slide masters have text objects in the footer. You can add other text objects 
to the master page for your slides to act as a header or a footer.

1) Go to View > Master > Slide Master from the main menu bar to open Master View.

2) On the Drawing toolbar, select the Text icon  or press F2.

3) Click once in the master page and drag to draw a text object.

4) Type or paste your text into the text object or add fields as described below.

5) Click Close Master View on the Master View toolbar or go to View > Normal on the main 
menu bar when you are finished.

To add a field, such as the date or page number (slide number), to a text object in the header or 
footer, select Insert > Fields. and select the required field from the submenu. If you want to edit a 
field in your slide, see Chapter 3 Adding and Formatting Text for more information.

The fields you can use in Impress are:

• Date (fixed)

• Date (variable): updates automatically when you reload the file

• Time (fixed)

• Time (variable): updates automatically when you reload the file

• Author: first and last names listed in the LibreOffice user data

• Page number (slide number)

• File name

Tip

To change the number format (1,2,3 or a,b,c or i,ii,iii, etc.) for the page number field, 
go to Format > Page on the main menu bar and select a format from the list in the 
Layout Settings area.

To change the author information, go to Tools > Options > LibreOffice > User Data 
on the main menu bar.

Working with styles in Impress

If you are familiar with styles in Writer, you will find both similarities and differences in Impress. The 
presentation styles are comparable to paragraph styles in Writer and are used in a similar fashion. 
You cannot create new presentation styles but you can fully configure the existing ones. Note that, 
as with the Heading styles in Writer, the Outline styles are hierarchically linked, so that a change in 
the Outline 1 will cascade through all the other Outline levels.

In Impress you will also find the graphics styles very useful. They define the characteristics of a 
graphic object (including a text object). For example, ifyou need to create an organization chart 
diagram in one of the slides of your presentation, you will probably want all of the objects to have a 
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consistent appearance, such as line style, font type, shadow, and so on. The easiest way to 
achieve this result with the minimum effort is to create a graphics style for the objects and apply it 
to each object. The major benefit is that if you decide to change, say, the background color of 
objects, all you need to do is modify the style rather than each individual object.

Presentation styles are discussed in detail in Chapter 3 Working with Text and graphics styles are 
discussed in detail in Chapter 6 Formatting Graphic Objects. More information on styles can also 
be found in the Getting Started Guide Chapter 3 Using Styles and Templates.

Working with templates

A template is a document model that you use to create other documents. For example, you can 
create a template for business presentations that has your company logo on the first slide so that 
new presentations created using this template will have your company logo on the first slide.

Templates can contain anything that regular documents can contain, such as text, graphics, a set 
of styles, and user-specific setup information such as measurement units, language, the default 
printer, and toolbar and menu customization.

All documents created using LibreOffice are based on templates. You can create a specific 
template for any document type (text, spreadsheet, drawing, presentation). If you do not specify a 
template when you start a new document, then the document is based on the default template for 
that type of document. If you have not specified a default template, LibreOffice uses the blank 
template for that type of document that is installed with LibreOffice. This default template can be 
changed, see “Setting default template” on page 18 for more information.

However, Impress is a little different from other LibreOffice components, in that it starts with the 
Presentation Wizard, unless you have decided to turn off this wizard. When you choose File > 
New > Presentation from the menu bar and, if the wizard is active, it opens offering several 
choices for a new presentation, one of which is From template.

If you have turned off the Presentation Wizard, when you start a new presentation by choosing File 
> New > Presentation from the menu bar, LibreOffice uses the default presentation template. If 
you have not defined your own default template, LibreOffice uses the blank template supplied with 
Impress.

For more information on templates, see the Getting Started Guide Chapter 3 Using Styles and 
Templates.

Templates supplied with LibreOffice
Impress comes with a set of predefined templates and these are located in the Presentation 
backgrounds folder. These templates only contain backgrounds and background objects providing 
you with a starting point to create your own templates. Any templates that you create from this 
default set will be located in the My Templates folder when you save your presentation as a 
template.

Create a new presentation from a presentation template as follows:

1) Go to File > New > Templates on the main menu bar to open the Template Manager dialog
(Figure 11).

2) Click on the Presentations tab.

3) Navigate to the selection of presentation templates you want to use.

4) Double-click the name of the template in the list and a new presentation will be created 
using the selected template,
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Figure 11: Template Manager dialog for presentations

Templates from other sources
You can download templates for LibreOffice from many sources, including the official template 
repository at http://templates.libreoffice.org/, and install them on your computer. On other websites 
you may find collections of templates that have been packaged into extension (.OXT) files. These 
are installed a bit differently (using the Extension Manager), as described below.

Some of these templates are free of charge; others are available for a fee. Check the descriptions 
to see what licenses and fees apply to the ones that interest you.

If you have created your own templates, they are stored in the My Templates folder. To import 
individual templates, see “Importing a template” on page 21 for more information and to import a 
template collection, see “Importing template collections” on page 22 for more information.

The slide masters created by newly created or imported templates will appear in Available for Use 
in the Master Pages section of the Tasks Pane.

Creating your own templates
To create a template from a presentation and save it to My Templates folder :

1) Open the presentation that you want to use for a template.

2) Add any extra content and styles to your presentation.

3) Go to File > Save As Template on the main menu bar to open the Template Manager 
dialog (Figure 12).

4) Select the My Templates folder to activate the Save icon , then click the Save icon. If 
the My Templates folder is not visible, see “Saving templates to a hidden folder” on page 17
for more information.

5) Type a name for the new template in the Enter template name text box.

6) Click Accept to save the new template in the My Templates folder.

7) Close the Template Manager dialog.
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Figure 12: Saving new template in Template Manager dialog

Saving templates to a hidden folder
This procedure is for a LibreOffice installation that has yet to have any user created or imported 
templates for use in Impress. Any empty template folders are hidden in the Template Manager and 
a work-around is necessary to save the first template into the My Templates folder.

1) Go to File > Save As Template on the main menu bar to open the Template Manager 
dialog. By default the Template Manager opens at the Documents page.

2) Double click on the MediaWiki folder to select it and activate the Save icon , then click 
the Save icon.

3) Specify the template name in the pop-up dialog and click Accept. The template is saved 
into the MediaWiki folder. This appears in the MediaWiki folder on the dialog page of the 
file type being saved, which is Presentations.

4) Close the Template Manager dialog.

5) Go to File > New > Templates on the main menu bar to open the Template Manager dialog
again.

Note
Closing and opening the Template Manager is necessary so that the following steps 
can be carried out to move your template into the My Templates folder.

6) Select the Presentations tab to open the dialog page for presentations (Figure 13).

7) Double-click the MediaWiki folder to open it.

8) Select the template you have just added and the file handling controls are displayed.

9) Click the Move to folder icon  and select My Templates from the drop list that 
appears. Your template will be moved from the MediaWiki folder to the My Templates 
folder.

10) Close the Template Manager dialog.
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Figure 13: Moving templates to My Templates folder

Setting default template
If you create a presentation by using File > New > Presentation on the main menu bar and do not 
select a template, LibreOffice creates the presentation from the default Impress template, which is 
normally a blank template. However, you can set any presentation template to be the default 
template, even a template that you have created, so long as it is located in a folder displayed in the 
Template Manager dialog. You can always reset to the default template back to the blank template 
later if you choose.

Setting a custom template as default
To set a template that you have created or imported as default instead of using the Impress default 
template:

1) Go to File > New > Templates to open the Template Manager dialog and select the 
Presentations tab (Figure 13).

2) Double click on the My Templates folder to open it.

3) Select the template you want to use as the default template.

4) Click the Set as default icon  and your chosen template becomes the default template.

Resetting default template
To reset the default template for a new presentation to use the Impress default template:

1) Go to File > New > Templates to open the Template Manager dialog.

2) Select the Action Menu icon  and choose Reset Default Template from the drop-
down menu (Figure 14). This command does not appear unless the default template has 
been previously changed to a template of your choosing.

3) Select Presentation from the drop down list to reset the default template. If other modules 
in LibreOffice have had their default template changed, then the modules will also appear in 
this drop down list.

4) The next time that you create a new presentation using Impress, the presentation will be 
created from the default Impress template.
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Figure 14: Resetting default template

Editing a template
You can edit template styles and content, and then, if you wish, you can reapply the template 
styles to presentations that were created from that template. 

Note You can only reapply styles. You cannot reapply content.

Editing
1) Go to File > New > Templates to open the Template Manager dialog.

2) Navigate to the template that you want to edit and click once on it to activate the file 
handling controls (Figure 13).

3) Select the Edit icon  and the template opens in Impress.

4) Edit the template just as you would any other presentation. To save your changes, go to 
File > Save on the main menu bar.

Updating a document from a changed template
The next time that you open a presentation that was created from the changed template, the 
following message appears (Figure 15).

Click Update Styles to update any styles in the template that have been changed in the document. 
Click Keep Old Styles if you do not want to update any styles in the template that have been 
changed in the document. Whichever option you choose, the message box closes and the 
presentation opens in Impress.

Figure 15. Update styles message

Caution 
If you choose Keep Old Styles in the message box shown in Figure 15, that 
message will not appear again the next time you open the document after 
changing the template it is based on. You will not get another chance to update the 
styles from the template, although you can use the macro given in the Note below 
to re-enable this feature.
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Note

To re-enable updating from a template:

1) Use Tools > Macros > Organize Macros > LibreOffice Basic. Select the 
document from the list, click the expansion symbol (+ or triangle), and select 
Standard. If Standard has an expansion symbol beside it, click that and select a 
module.

2) If the Edit button is active, click it. If the Edit button is not active, click New.

3) In the Basic window, enter the following:
Sub FixDocV3 
' set UpdateFromTemplate 
 oDocSettings = ThisComponent.createInstance( _ 
  "com.sun.star.document.Settings" ) 
 oDocSettings.UpdateFromTemplate = True 
End Sub 'FixDocV3

4) Click the Run BASIC icon, then close the Basic window.

5) Save the document.

The next time you open this document, you will be prompted to update the styles 
from the modified template.

Organizing templates
LibreOffice can only use templates that are in LibreOffice template folders. You can create new 
LibreOffice template folders and use them to organize your templates. For example, you might 
have separate template folders for different purposes or projects. You can also import and export 
templates.

Note
All the actions available from the Commands button in the Template Management 
dialog can also be carried out by right-clicking on the templates or the folders.

Tip
The location of LibreOffice template folders varies with your computer’s operating 
system. To learn where the template folders are stored on your computer, go to 
Tools > Options > LibreOffice > Paths.

Creating a template folder
To create a template folder:

1) Go to File > New > Templates on the main menu bar to open the Template Management 
dialog.

2) Select the Presentations tab to open the dialog page for presentations (Figure 13 on page
18).

3) Click on the template you want to move to a new folder and the file handling controls are 
displayed.

4) Click the Move to folder icon  and select New folder from the drop list that appears.

5) In the pop-up dialog, type a name for the new folder and click Accept.

6) The selected template is then moved to the new folder you have just created.

Deleting a template folder
You cannot delete the template folders supplied with LibreOffice or installed using the Extension 
Manager. You can only delete folders that you have created.
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To delete a template folder that you have created:

1) In the Template Management dialog select the folder that you want to delete.

2) Select the Delete icon  and a message box appears and asks you to confirm the 
deletion. Click Yes.

Caution Folders which contain no files are hidden. If the folder is visible, ensure that you 
want to delete the files that are inside. You may have to put a dummy template into 
an empty folder to delete it. Just select File > Save As Template for any file you 
have opened, move it into the folder to be deleted, and then delete the folder.

Moving a template
To move a template from one template folder to another template folder:

1) In the Template Manager dialog, double-click the folder that contains the template you want 
to move (Figure 13 on page 18).

2) Select the template that you want to move.

3) Click the Move to folder icon  and select the folder from the drop down list to move 
your selected template.

Deleting a template
You cannot delete the templates supplied with LibreOffice or installed using the Extension 
Manager. You can only delete templates that you have created or imported.

To delete a template:

1) In the Template Manager dialog, double-click the folder that contains the template you want 
to delete.

2) Select the template that you want to delete.

3) Select the Delete icon  and a message box appears and asks you to confirm the 
deletion. Click Yes.

Importing a template
If the template that you want to use is in a different location, you must import it into an LibreOffice 
template folder.

To import a template into a template folder:

1) In the Template Manager dialog, select the folder into which you want to import the 
template.

2) Select the Import icon  and a standard file browser dialog opens.

3) Navigate to the template that you want to import, select it and click Open. The file browser 
window closes and the template appears in the selected folder.
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Importing template collections
The Extension Manager provides an easy way to install collections of templates that have been 
packaged as extensions. For more about the Extension Manager, see the Getting Started Guide 
Chapter 14 Customizing LibreOffice.

Figure 16: Extension Manager

1) Download the extension package (.OXT file) and save it anywhere on your computer. You 
can find several templates at http://templates.libreoffice.org/template-center that have been 
developed for use with LibreOffice.

2) Go to Tools > Extension Manager on the main menu bar to open the Extension Manager 
dialog (Figure 16).

3) Click Add to open a file browser window.

4) Find and select the template package you want to install and click Open. The package 
begins installing. You may be asked to accept a license agreement.

5) When the package installation is complete, the templates are available for use through File 
> New > Templates and the extension is listed in the Extension Manager.

Exporting a template
To export a template from a template folder to another location:

1) In the Template Manager dialog, double-click the folder that contains the template you want 
to export.

2) Select the template that you want to export.

3) Click the Export icon  and a standard file browser dialog opens.

4) Navigate to the folder into which you want to export the template and click OK.

22 Using Slide Masters, Styles, and Templates

http://templates.libreoffice.org/template-center

	Copyright
	Contributors
	Feedback
	Acknowledgments
	Publication date and software version

	Note for Mac users
	Designing a presentation
	What are slide masters?
	Working with slide masters
	Creating slide masters
	Applying a slide master
	Loading additional slide masters
	Modifying a slide master
	Selecting and applying backgrounds
	Adding background objects
	Slide master styles
	Presentation styles
	Graphics styles

	Modifying default text areas
	Position and size
	Background, border, arrangement and alignment
	Date and slide number

	Adding text to all slides

	Working with styles in Impress
	Working with templates
	Templates supplied with LibreOffice
	Templates from other sources
	Creating your own templates
	Saving templates to a hidden folder
	Setting default template
	Setting a custom template as default
	Resetting default template

	Editing a template
	Editing
	Updating a document from a changed template

	Organizing templates
	Creating a template folder
	Deleting a template folder
	Moving a template
	Deleting a template
	Importing a template
	Importing template collections
	Exporting a template



