
Writer 6.0 Guide

Chapter 13  
Tables of Data



Copyright

This document is Copyright © 2018 by the LibreOffice Documentation Team. Contributors are listed
below. You may distribute it and/or modify it under the terms of either the GNU General Public 
License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons 
Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors
Jean Hollis Weber Bruce Byfield Gillian Pollack

Acknowledgments
This chapter is updated from previous versions of the LibreOffice Writer Guide. Contributors to 
earlier versions are:

John A Smith Jean Hollis Weber Ron Faile Jr.
Barbara Duprey

An earlier version appeared in the OpenOffice 3.3 Writer Guide. The contributors were:

Peter Hillier-Brook John Kane Stefan A. Keel
Iain Roberts Gary Schnabl Janet Swisher
Barbara M. Tobias Jean Hollis Weber Bob Wickham
Michele Zarri Magnus Adielsson

Feedback
Please direct any comments or suggestions about this document to the Documentation Team’s 
mailing list: documentation@global.libreoffice.org

Note

Everything you send to a mailing list, including your email address and any other 
personal information that is written in the message, is publicly archived and cannot be 
deleted.

Publication date and software version
Published July 2018. Based on LibreOffice 6.0.

Note for macOS users
Some keystrokes and menu items are different on macOS from those used in Windows and Linux. 
The table below gives some common substitutions for the instructions in this book. For a more 
detailed list, see the application Help.

Windows or Linux macOS equivalent Effect

Tools > Options 
menu selection

LibreOffice > Preferences Access setup options

Right-click Control+click and/or right-click 
depending on computer setup

Open a context menu

Ctrl (Control)  (⌘ ( Command) Used with other keys

F5 Shift+ +⌘ ( F5 Open the Navigator

F11 +⌘ ( T Open the sidebar Styles and Formatting deck

Documentation for LibreOffice is available at http://documentation.libreoffice.org/en/

http://documentation.libreoffice.org/en/
mailto:documentation@global.libreoffice.org
http://creativecommons.org/licenses/by/4.0/
http://www.gnu.org/licenses/gpl.html


Contents
Copyright..............................................................................................................................2

Contributors.................................................................................................................................2

Acknowledgments........................................................................................................................2

Feedback.....................................................................................................................................2

Publication date and software version.........................................................................................2

Note for macOS users.................................................................................................................2

Introduction..........................................................................................................................5

Creating a table....................................................................................................................5
Inserting a new table....................................................................................................................5

Creating nested tables.................................................................................................................6

Using AutoCorrect to create a table.............................................................................................7
Create a table from formatted text...........................................................................................7
Example..................................................................................................................................8

Formatting the table layout.................................................................................................8
Default parameters......................................................................................................................8

Resizing and positioning the table...............................................................................................9

Resizing rows and columns.......................................................................................................10

Resizing individual cells.............................................................................................................11

Inserting rows and columns........................................................................................................11

Deleting rows and columns........................................................................................................12

Merging and splitting cells..........................................................................................................12

Specifying table borders............................................................................................................13

Selecting background colors and graphics.................................................................................14

Displaying or hiding table boundaries........................................................................................16

Creating and applying table styles..................................................................................16
Applying a table style.................................................................................................................16

Creating a table style.................................................................................................................16

Formatting the table text...................................................................................................17
Specifying text flow....................................................................................................................18

Vertical alignment......................................................................................................................19

Number formats.........................................................................................................................19

Rotating text in a table cell.........................................................................................................20

Data entry and manipulation in tables.............................................................................20
Moving between cells.................................................................................................................20

Sorting data in a table................................................................................................................21

Using spreadsheet functions in a table......................................................................................22

Additional table operations...............................................................................................23
Protecting cells in a table...........................................................................................................23

Adding a caption........................................................................................................................23

Cross-referencing to a table.......................................................................................................24

Creating a heading row in an existing table...............................................................................24

Merging and splitting tables.......................................................................................................24

Chapter 13  Tables of Data | 3



Deleting a table..........................................................................................................................25

Copying a table..........................................................................................................................25

Moving a table...........................................................................................................................25

Inserting a paragraph before or after a table..............................................................................25

Using tables as a page layout tool.............................................................................................25

The Table menu and Table toolbar...................................................................................26

4| Chapter 13  Tables of Data



Introduction

Tables are a useful way to organize and present large amounts of information, for example:

• Technical, financial, or statistical reports.

• Product catalogs showing descriptions, prices, characteristics, and photographs of 
products.

• Bills or invoices.

• Lists of names with address, age, profession, and other information.

Tables can often be used as an alternative to spreadsheets to organize materials. A well-designed 
table can help readers understand better what you are saying. While you would normally use 
tables for text or numbers, you could put other objects, such as pictures, in cells. Writer’s tables 
provide limited spreadsheet functions; see “Using spreadsheet functions in a table” on page 22.

Tables can also be used as a page-layout tool to position text in areas of a document instead of 
using several Tab characters. Another example is in headers and footers to support independent 
positioning of different elements, such as page number, document title, and so on. This use of 
tables is described in Chapter 6, Formatting Pages: Advanced.

Creating a table

Before you insert a table into a document, it helps to have an idea of the visual result you want to 
obtain as well as an estimate of the number of rows and columns required. Every parameter can 
be changed at a later stage; however, thinking ahead can save a large amount of time as changes 
to fully formatted tables often require a significant effort.

Inserting a new table
To directly insert a table with the default properties, click the Table icon on the
Standard toolbar. On the drop-down graphic, choose the size of the table (up to
fifteen rows and up to ten columns). To create the table, click the cell that you
want to be on the last row of the last column. Holding down the mouse button
over the Table icon will also display the graphic.

To insert a new table using the Insert Table dialog, where you can specify the
properties for the table, position the cursor where you want the table to appear,
then use any of the following methods to open the dialog:

• Choose Table > Insert Table from the Menu bar.

• Press Ctrl+F12.

• On the Standard toolbar, click the Insert Table icon and select More Options at the bottom
of the drop-down graphic.

In the General section of the Insert Table dialog (Figure 1), in the Name box, you can enter a 
different name from the Writer-generated default for the table. This might come in handy when 
using the Navigator to jump quickly to a table.

In the Columns and Rows boxes, specify the number of columns and rows for the new table. You 
can change the size of the table later, if necessary.
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Figure 1: The Insert Table dialog

Under Options, set up the initial table characteristics:

• Heading — Enables a heading to be used in the table and defines the number of rows to 
be used as headings. A second (and, occasionally, third) heading row can be useful for sub-
headings in a complex table.

The default Table Heading paragraph style is applied to the heading rows. You can edit the 
Table Heading paragraph style in the Styles and Formatting window to change these 
default settings.

• Repeat Heading Rows on new pages — Enables the heading rows to be repeated at the 
top of subsequent pages if the table spans more than one page.

Heading Rows — Specifies the number of rows to be used for the heading. Default is 1.

• Don’t split table over pages — Prevents the table from spanning more than one page. 
This can be useful if the table starts near the end of a page, and would look better if it were 
completely located on the following page. If the table starts earlier on the page, this setting 
can lead to awkward page breaks. If the table becomes longer than would fit on one page, 
either deselect this option or manually split the table.

• Border — Surrounds each cell of the table with a border. This border can be modified or 
deleted later.

The AutoFormat button opens a dialog from which you can select one of several predefined table 
layouts, also known as table styles. See “Creating and applying table styles” on page 16 for more 
information. Click OK after selecting your table layout.

After making your choices, click Insert. Writer creates a table as wide as the text area (from the left
page margin to the right page margin), with all columns the same width and all rows the same 
height. You can adjust the columns and rows later to suit your needs.

Creating nested tables
You can create tables within tables, nested to a depth limited only by imagination and practicality. 
Nested tables are especially useful for page layout. Figure 2 demonstrates a simple, two-level 
example. The shaded table is inside a cell of the larger table. To achieve this, simply click in a cell 
of an existing table and use any of the methods mentioned in “Inserting a new table” above.
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Figure 2: Nested table example

Using AutoCorrect to create a table
You can also create a table by typing a series of hyphens (-) or tabs separated by plus signs. Use 
the plus signs to indicate column dividers, while hyphens and tabs are used to indicate the width of
a column. When using tabs, the default tab setting determines the width; this setting can be 
changed in Tools > Options > LibreOffice Writer > General.

For example, this character sequence:

+-----------------+---------------+------+

creates a table like this:

Note

This function can be disabled or enabled in Tools > AutoCorrect Options. On the 
Options page, deselect or select Create table.

Create a table from formatted text
You can create a table from plain text by using Table > Convert > Text to Table on the Menu bar. 
The text to be converted must contain characters to indicate column separators. Paragraph marks 
indicate an end of a table row.

Start by editing the text, if necessary, to ensure the column separator character is in place where 
you want it. Select the text you want to convert and choose Table > Convert > Text to Table to 
open the dialog shown in Figure 3.

Figure 3: Dialog for the text to table conversion
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The Separate text at section has four options for the separator for the columns of text. Select Other
to choose the default comma (useful if you are importing a .csv file) or type any character in the 
box. The other options are the same as those in the Insert Table dialog shown in Figure 1.

Click OK to convert the text.

Example
In this example we will convert the following text into a table.

Row 1 Column 1; Row 1 Column 2; Row 1 Column 3

Row 2 Column 1; Row 2 Column 2; Row 2 Column 3

In this case, the separator between elements is a semicolon. Select the text and choose Table > 
Convert > Text to Table. We obtain the following result.

Row 1 Column 1  Row 1 Column 2  Row 1 Column 3

Row 2 Column 1  Row 2 Column 2  Row 2 Column 3

Tip

Unlike the creation of a table by other methods, conversion from text to table 
preserves the paragraph style and character style applied to the original text.

You can also use the Convert menu to perform the opposite operation, to transform a table into 
plain text. This may be useful when you want to export the table contents into a different program.

To transform a table into text, place the cursor anywhere in the table, choose Table > Convert > 
Table to Text in the Menu bar, pick the preferred row separator, and click OK to finish.

Formatting the table layout

Formatting a table is, generally speaking, a two-step process: formatting the table layout (the 
subject of this section) and formatting the table text (the subject of the next section).

Tip

If you apply similar formatting of table layout and table text to multiple tables, using 
table styles can speed up your work and provide consistency. See “Creating and 
applying table styles” on page 16.

Formatting the layout normally involves one or more of the following operations: adjusting the size 
of the table and its position on the page, adjusting sizes of rows and columns, adding or removing 
rows or columns, merging and splitting individual cells, changing borders and background.

Default parameters
If you create a table using the Insert Table dialog or the Table icon on the Standard toolbar, the 
following defaults are set:

• The cells use the Table Contents paragraph style, which, in the default template, is identical
to the Default Style paragraph style.

• The default table occupies all the space from margin to margin (text area).

• The default table has thin black borders around each cell (grid).

• If you activate the Heading option, the cells in the heading row (or rows) use the Table 
Heading paragraph style.
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Resizing and positioning the table
Using the default settings, any newly created table will occupy the entire width of the text area. 
This is sometimes what you want, or you may prefer a smaller table. To quickly resize a table, first 
move the mouse to either the left or right edge. When the cursor changes shape into a double 
arrow, drag the border to the new position. This operation only changes the size of the first or last 
column; it does not change the alignment of the table on the page.

For more precise control over the size and position of the table on the page, open the Table 
Properties dialog by choosing Table > Properties or by right-clicking anywhere in the table and 
choosing Table Properties from the context menu.

Figure 4: The Table page of the Table Properties dialog

On the Table page of the dialog (Figure 4), you can set the alignment of the table, choosing among
the following options:

• Automatic: the default setting for a table, fills the width of the text area.

• Left: aligns the table with the left margin.

• Right: aligns the table with the right margin.

• From Left: lets you specify under Spacing exactly how far from the left margin the table is 
placed.

• Center: aligns the table in the middle between the left and right margins. If the table width 
is greater than the margin, the table will extend outside of the margins.

• Manual: lets you specify the distances from both left and right margins under Spacing.

Selecting an alignment option other than Automatic activates the Width field in the Properties 
section, where you can enter the desired size of the table. Select Relative to see the width as 
percentage of the text area.

In the Spacing section, use the Above and Below boxes to modify the separation between the text 
and the table. 

When the size of the table is less than the size of the text area, Writer will insert some values in the
Left and Right boxes. You can enter values:

• In both the Left and Right boxes if you select Manual alignment.

• In the Left box when you select the From Left, Right or Center alignment.

• In the Right box if you select Left alignment.

Otherwise these values are not available.
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Resizing rows and columns
You can adjust the height of rows and the width of columns in a table in several ways.

• Move the mouse next to the edge of the cell and when a double-headed arrow appears, 
click and hold the left mouse button, drag the border to the desired position, and release 
the mouse button.

• On the horizontal ruler, column dividers are marked by a pair of thin gray lines; the vertical 
ruler indicates row dividers in the same way. You can resize a row or column by holding the 
mouse button down on the appropriate divider and dragging it to the desired location.

• Use the keyboard as described below.

Selecting Table > Size from the Menu bar also offers some resizing options:

• Select Column Width or Row Height to enter a dimension into the size box for each 
selectable column or row of the table.

• The Optimal Column Width or Optimal Row Height options make the selected columns or 
rows as narrow as possible while still fitting their contents. This option is only available if the
table is selected and has content.

• Distribute Columns/Rows Evenly to quickly bring them back to all being the same width or 
height. This option is only available if the table is selected.

For greater control over the width of each column, use the Columns page of the Table Properties 
dialog.

Figure 5: Table Properties dialog: Columns page

Right-click the table and choose Table Properties from the context menu or choose Table > 
Properties from the Menu bar. On the Table Properties dialog, select the Columns tab.

• Adapt table width: If a table already stretches to the page margins, it cannot stretch any 
wider and the Adapt table width option can only be used to reduce the column width. If the 
table is narrower, increasing the width of a column will increase the width of the whole 
table. This option is not available if Automatic has been selected in the Alignment area of 
the Table page.

If the table width already extends past the margins, with the Adapt table width option 
checked, attempting to change a column width will automatically decrease that column’s 
size so that the table will now shrink to the page margins while keeping the size of any 
other column intact.

• Adjust columns proportionally results in all columns changing their widths by the same 
percentage when one is changed. For example, if you reduce by half the size of a column, 
the sizes of all the other columns will be halved. This option is not available if Automatic has
been selected in the Alignment area of the Table page.
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• Remaining space shows how much further the table can expand before hitting the limit of 
the margins. This value cannot be edited and will not be negative in the event that the table 
width is already larger than the space between the left and right margins.

• Under Column width, each individual column can be adjusted. If you have more than six 
columns, use the arrows at the right and left to view them all. With no options selected, the 
column to the right of the one being adjusted will automatically adjust to keep the table 
width constant. Adjusting the most right hand column causes the first column to adjust.

Tip

Rather than start from the Table Properties dialog, it is often more efficient to make 
rough adjustments to a new table using the mouse, and then fine tune the layout using
the Columns page in conjunction with the Table page of the Table Properties dialog.

It is also possible to resize a table using only the keyboard. This is sometimes easier than using 
the mouse.

 1) Place the cursor in the cell where you want to make changes.

 2) Press and hold the Alt key while using the arrow keys.

– The left and right arrow keys adjust the column width by moving the border on the right 
edge of the cell, but not past the margin.

– The up and down arrows adjust the row height (when possible) by moving the border on
the lower edge of the cell.

 3) Press and hold the Shift+Alt keys while using the left/right arrow keys.

– Adjusts the column width by moving the border on the left edge of the cell, but not past 
the margin.

To adjust the resizing parameters and behavior for keyboard handling, choose Tools > Options > 
LibreOffice Writer > Table.

Use the Row and Column values in the Move cells section to determine the amount of change 
produced by a single keystroke while resizing. In the Behavior of rows/columns section you can 
choose one of the following three strategies when resizing:

• Fixed: select this if you want the resizing to affect only the adjacent cell and not the entire 
table. The width of the table does not change when resizing its cells.

• Fixed, proportional: when resizing a cell with this option selected, all the other cells are also
resized proportionally, but in the opposite direction so as to maintain the width of the table.

• Variable: this is the default option. Resizing a cell affects the table size. For example, when 
you widen a cell, the width of the table increases.

Resizing individual cells
Place the cursor in the cell you wish to change.

 1) Press and hold the Ctrl+Alt keys while using the left/right arrow keys.

Resizes the current cell on its right edge, but not past the margin.

 2) Press and hold the Ctrl+Shift+Alt keys while using the left/right arrow keys.

Resizes the current cell on its left edge, but not past the margin.

See also “Merging and splitting cells” on page  13.
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Inserting rows and columns
To quickly insert one row or column, do one of the following:

• Click the Rows Above or Rows Below icons on the Table toolbar to insert one row above 
or below the selected one. Click the Columns Left or Columns Right icon on the Table 
toolbar to insert a column to the left or right of the selected one.

• Place the cursor in the row or column before or after which you want to add new rows or 
columns and choose Table > Insert > Rows Above/Below or Table > Insert > Columns 
Above/Below from the Menu bar.

• Place the cursor in the row or column before or after which you want to add new rows or 
columns, right-click, and choose Table > Insert > Rows Above/Below or Table > Insert > 
Columns Above/Below.

To insert any number of rows or columns:

 1) Place the cursor in the row or column where you want to add new rows or columns and 
right-click.

 2) In the context menu, choose Insert > Rows to display a dialog where you can select the 
number of rows or columns to add, and whether they appear before or after the one 
selected.

 3) Set Number to the number of rows or columns to insert, and Position to Before or After.

 4) Click OK to close the dialog.

The Table > Insert > Rows and Table > Insert > Columns choices from the Menu bar provide the
same options.

Note

Regardless of how they are inserted, new rows or columns have the same formatting 
as the row or column where the cursor was when the insert command was issued.

You can also quickly insert a row or a column using the keyboard:

 1) Place the cursor in the row or column next to the row or column you want to insert.

 2) Press Alt+Insert to activate keyboard handling.

 3) Use the arrow keys as desired to add a row or column:

– Left to insert a new column to the left of the cell where the cursor is located.

– Right to insert a new column to the right of the cell where the cursor is.

– Down to insert a new row below the cell where the cursor is.

– Up to insert a new row above the cell where the cursor is.

Deleting rows and columns
To quickly delete one or more rows or columns, place the cursor in the row or column you want to 
delete and do one of the following:

• Click the Rows or Columns icons on the Table toolbar

• Right-click and choose Delete > Rows or Delete > Columns.

• Press Alt+Delete on the keyboard and use the arrow keys to delete rows or columns as 
described above for inserting.
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Merging and splitting cells
A common use for merging cells is to make a heading row that takes up the wntire width of the 
table, or a subheading row over more than one column.

To merge a cell or group of cells into one cell:

 1) Select the cells to merge.

 2) Right-click and choose Merge Cells in the context menu, or choose Table > Merge Cells 
from the Menu bar. Any content of the cells appears in the merged cell.

To merge a single cell into an adjacent cell, you can also place the cursor in the cell (origin),
press Alt+Delete, release, then hold down Ctrl, and then press the left or the right arrow 
key. Any contents in the origin cell are lost.

To split a cell into multiple cells:

 1) Position the cursor inside the cell.

 2) Right-click and choose Split Cells in the context menu, or choose Table > Split Cells from 
the Menu bar.

 3) Select how to split the cell. A cell can be split either horizontally (create more rows) or 
vertically (create more columns), and you can specify the total number of cells to create.

To split a single cell, you can also place the cursor in an adjacent cell, press Alt+Insert, 
release, then hold down Ctrl, and then press the left or the right arrow key to split the cell to
the left/right.

It is generally a good rule to merge and split cells after completing other layout formatting. This is 
because some operations such as deleting a column or a row may produce a result difficult to 
predict when applied to a table with merged or split cells.

Specifying table borders
On the Table Properties dialog, select the Borders tab. Here you can set borders for a whole table 
or groups of cells within a table. In addition, you can set a shadow for the whole table.

Figure 6: Table Properties dialog: Borders page
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Borders have three components: where they go, what they look like, and how much space is left 
around them.

• Line arrangement specifies where the borders go. If a group of cells is selected, the 
border will be applied only to those cells. You can specify individually the style of the border
for the outside edges of the selected cells as well as for the cell divisions. Writer provides 
five default arrangements, but you can click the line you want to customize in the User-
defined area to get exactly what you want. When multiple cells are selected, the User-
defined area allows you to select the edges of the selection as well as the cell dividers.

Note

When the selected cells have different styles of border the User-defined area shows 
the border as a gray line. You can click the gray line to choose a new border style (first
click), leave the border as it is (second click) or delete the border (third click).

• Line specifies what the border looks like: the style, width, and color. There are a number of 
different styles and colors to choose from. Style, Width, and Color selections apply to those 
borders highlighted by a pair of black arrows in the User-defined map on the left-hand side 
of the dialog.

• Spacing to contents specifies how much space to leave between the border and the cell 
contents. Spacing can be specified for the left, right, above, and below. Choose 
Synchronize to have the same spacing on all four sides. This spacing is not factored in 
when calculating the text measurements.

• Shadow Style properties always apply to the whole table. A shadow has three 
components: where it is (position), how far from the table it is cast (distance), and what 
color it is.

• If Merge adjacent line styles is checked, two cells sharing a common border will have 
their borders merged, rather than being side by side or above/below each other.

Tip

To reset everything if you are having problems with borders, right-click in the table and 
choose Table Properties or choose Table > Properties from the Menu bar. On the 
Borders tab, select the Set No Borders icon under Line arrangement Presets (the box
on the left).

Selecting background colors and graphics
A table background can greatly improve the readability of data, visually highlight important parts of 
the table (such as the heading or a specific cell), or just make the table more appealing. You can 
choose between two types of background: solid color or image. The background can be applied to 
the whole table, to a single cell, or to a row. 

Tip

You need to consider the color contrast between the background and foreground 
(usually text). Background colors and images can also have transparency applied to 
help make the text more readable.

The row background option is quite handy when you want to create alternate color 
rows or assign a different background to the heading of the table.
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Note

The background selected for a cell will be in front of the row background which in turn 
will be in front of (and hide) the table background.

To set the background for a cell, row, or table:

 1) Place the cursor anywhere inside the cell, row, or table you want to work with. If you want to
apply a background to a group of cells, select the group.

 2) Right-click and choose Table Properties from the context menu, or choose Table > 
Properties from the Menu bar.

 3) In the Table Properties dialog, select the Background tab (see Figure 7).

 4) In the For section, chose whether to apply the settings to cell, row, or table.

– Cell: changes apply only to the selected cells, or the cell where the cursor currently 
resides. Even when selecting a group of cells, the background settings are applied to 
each cell individually.

– Row: changes affect the entire row where the cursor resides.

– Table: changes will set the background for the entire table, regardless of the cursor 
position or selected cells.

 5) In the As selection box, choose whether the background is a color or an image.

To apply a color, select the color and click OK. 

To apply an image:

a) Use the Browse button to select the image from your computer’s file system.

b) If you choose the Link option, changes to the image (for example, if you edit it in a 
different software package) are reflected in your document. However, you also need to 
keep the linked image file with the document file. If, for example, you email the 
document without the image file, the image will no longer be visible.

c) Under Type, select the type of placement for the image.

Position: select in the position map where the image will be displayed.

Area: the image will be stretched to fill the whole area.

Tile: the image will be tiled (repeated horizontally and vertically) to fill the area.

d) Select the Preview option to display the image in the pane on the right.

e) To apply the image, click OK.
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Figure 7: Table Properties dialog: inserting a graphic background

Figure 8 shows an example of a table set with a background image, and the first row background 
colored. As you can see, the row background covers the table background.

Figure 8: Example of table with different row and table backgrounds

Displaying or hiding table boundaries
A table boundary is a set of pale (usually gray) lines around the cells when viewed on-screen in 
LibreOffice with no borders enabled. These boundaries are not printed; their only function is to help
you see where the table cells are. They are particularly useful when using tables for page layout.

To display tables the same way on the screen as on the printed page, with no boundary lines, go to
Tools > Options > LibreOffice > Application Colors. On that page, you can display or hide 
boundaries around text, pages headers and footers, figures, and other parts of a document, and 
you can choose the color of boundary lines.

Note

Turning boundaries off does not hide any borders that the table may have.

Creating and applying table styles

Using table styles, you can apply an elaborate format to your table with just a few clicks. Like other 
styles, table styles enable you to produce consistent looking tables in a document.
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Applying a table style
To apply a table style, go to the Table Styles page of the Styles and Formatting deck in the Sidebar.
Then place the cursor anywhere in the table and double-click the name of a style.

Creating a table style
Versions of LibreOffice prior to 5.3 did not include table styles, but they did have AutoFormats for 
tables. Now, although the Styles and Formatting window includes a quick way to apply table styles,
they are still created by using the AutoFormat feature. Follow these steps:

 1) Create a table. Format it as you wish: font, alignment, borders, background, number format.

 2) Put the cursor anywhere in the table. Select Table > AutoFormat Styles on the Menu bar.

 3) On the AutoFormat dialog (Figure 9), choose which features you wish to include in the new 
table style, and then click Add. 

 4) In the pop-up dialog, type a name for the new style and click OK. The new style is added to
the list of formats in the AutoFormat dialog and to the list of table styles in the Styles and 
Formatting window.

You can rename the selected table format as well as decide which parts of the predefined 
formatting you want to apply to your table. You can selectively apply the number format, the font, 
the alignment, the border, or the pattern.

Figure 9: Table AutoFormat dialog

Note

You cannot rename or delete the Default Style.

Table styles also include the following table-level properties:

• Break

• Keep with next paragraph

• Repeat heading

• Allow table to split across pages 

• Allow rows to break across pages

• Merge adjacent line styles

• Table shadow
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Tip

These styles do not include table and column widths in the table format. To insert a 
table with predefined full formatting, save it as AutoText. See “Using AutoText” in 
Chapter 2, Working with Text: Basics, for instructions.

Formatting the table text

Once the table layout is satisfactory, you can move on to formatting the text in the individual cells. 
You can apply manual formatting as with any other paragraph in the text, but it is highly 
recommended, for the sake of consistency and ease of maintenance, that you use paragraph and 
character styles.

In addition to paragraph and character styles, other aspects to consider when placing text in a 
table cell include text flow, alignment, and orientation.

You can format each cell independently of other cells, or you can simultaneously format a group of 
cells by selecting them before applying the desired formatting.

Tip

You can apply basic table text formatting by choosing a table style and then modify 
only those cells that you wish to be different.

Specifying text flow
On the Text Flow page of the Table Properties dialog (Figure 10), you can:

• Insert a page or column break either before or after the table. Use the Text Flow: Break 
option, combined with the Page or Column and the Before or After buttons. If you insert a 
page break before the table (that is, start the table on a new page), you can also change 
the page style that will go with it by selecting the With Page Style option and a new page 
style. As with any page break, you can also reset the page numbers using the Page 
number box.

• Keep a table on one page by deselecting the Allow table to split across pages and 
columns option. If this item is deselected, the next item is not active.

• Keep each row on one page by deselecting the Allow row to break across pages and 
columns option.

• Use the Keep with next paragraph option to keep the table and an immediately following 
paragraph together if you insert a page break.

• Use the Repeat heading option, and its associated numbers box, to select the number of 
table heading rows that will be repeated on each page. A complicated table may need two 
or three heading rows to be easily read and understood.

• Use the Text orientation list to select the direction for the text in the cells. Select either 
Horizontal, Vertical, or Use superordinate object settings (meaning use the default text 
flow settings for the page).

• Select the vertical alignment of the text in the table or the selected cells; the choices are to 
align with the top of the cell, the center of the cell, or the bottom of the cell. This alignment 
is in addition to the Left-Right alignment options available on the Table page of the Table 
Properties dialog.
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Figure 10: Table Properties dialog: Text Flow page

Note

A table heading row cannot span two pages, but any other row can. A one-row table 
(often used for page layout purposes), if set up with the default of including a heading, 
will not break across pages. The cure is to make sure the table is defined without a 
heading row.

Vertical alignment
By default, text entered into a table is aligned to the top-left of the cell. You can change the default 
for the entire table, as described above, or for individually selected cells.

To vertically align the text in specific cells:

 1) Place the cursor in the cell you wish to change, or click and drag to select multiple cells.

 2) Right-click in the selected area and click an icon on the Table toolbar: Align Top, Center 
Vertically, or Align Bottom.

Number formats
The number format can be set for a whole table or group of cells. For example, cells can be set to 
display in a particular currency, to four decimal places, or in a particular date format.

Number recognition specifies that numbers in a text table are recognized and formatted as 
numbers. If Number recognition is not selected, numbers are saved in text format and are 
automatically left-aligned. To enable Number recognition, go to Tools > Options > LibreOffice 
Writer > Table and select the option in the Input in Tables section.

To set the number format for one or more cells, select the cells, then either click the icon for one of 
the popular formats from the Table toolbar, or right-click and choose Number Format from the 
context menu. On the Format Number dialog (Figure 11), set options for various categories of 
numerical data.

• In the Category list, select the category you want, such as currency, date, or text.

• In the Format list, choose a format for the category you just selected.
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• For some categories, such as Date, you may wish to change the language using the 
Language list, while for other numerical categories you can use the Options section of the 
dialog to customize the appearance.

Figure 11: The Format Number dialog

Tip

Writer displays the formatting code for the category and format selected in Format 
Code section at the bottom of the dialog. For example, if you select a date format such
as 31 Dec 1999 the corresponding code is D MMM YYYY. Advanced users can easily 
customize this formatting code as well as create new user-defined codes.

Rotating text in a table cell
You can rotate text in a table cell by 90 or 270 degrees. Text rotation can be useful when you have 
long headings for narrow columns.

• Select the text to be rotated and then choose Format > Character, or right-click and select 
Character from the context menu.

• On the Position page, in the Rotation / Scaling section, choose the rotation angle and click 
OK.

Figure 12 shows a sample table with rotated headings.

Figure 12: A table with rotated headings  
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Note

Text rotation within table cells can also be achieved with the use of paragraph styles, 
discussed in detail in Chapter 9, Working with Styles.

Data entry and manipulation in tables

Moving between cells
Within a table, you can use the mouse, the cursor (arrow) keys, or the Tab key to move between 
cells.

The cursor keys move the cursor one text character left or right at a time. If a cell is empty, 
pressing the cursor key will move the cursor to the adjacent cell.

The Tab key moves directly to the next cell and, if the cursor is in the last cell in the table, creates a
new row. Pressing Shift+Tab moves the cursor back a cell.

Tip

To enter a Tab character as part of the text of the cell, press the Ctrl and Tab keys at 
the same time.

To move to the beginning of the table, press Ctrl+Home. If the active cell is empty, the move is to 
the beginning of the table. If the cell has content, the first press goes to the beginning of the cell 
and the next press goes to the beginning of the table. (Pressing again takes you to the beginning 
of the document.)

To move to the end of the table, press Ctrl+End. If the active cell is empty, the move is to the end 
of the table. If the cell has content, the first press goes to the end of the cell and the next press 
goes to the end of the table. (Pressing again takes you to the end of the document.)

Sorting data in a table
Just as in a spreadsheet, Writer allows data in a table to be sorted. Up to three levels of sorting 
can be specified (for example, sort first by age numerically, then alphabetically by name within 
each age).

To sort data in a table:

 1) Select the table (or part of the table) to be sorted.

 2) From the Menu bar, choose Table > Sort, or select the Sort icon from the Table toolbar.

 3) In the Sort dialog (Figure 13):

a) Decide whether you want to sort in the direction of rows or columns. The default sorting 
direction is by rows, which results in sorting the data in a column.

b) Select up to three keys to sort on, in the correct order.

c) For each key, select which column or row to sort on, whether the sort is Numeric or 
Alphanumeric and whether it is Ascending or Descending.

d) Click OK to perform the sort.

Note

You have to select all cells that might be affected by the sorting. For example, if you 
select only the cells of one column, the sort affects that column only, while the others 
remain unchanged. In such a case, you risk mixing the data of the rows.
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Figure 13: Selecting criteria for sorting

Using spreadsheet functions in a table
For many simple mathematical functions, Writer tables can be used as basic spreadsheets. Just as
in a spreadsheet, each table cell is identified by a letter (for the column) and a number (for the 
row). For example, cell C4 is the cell in the third column from the left and fourth row from the top. 
When the cursor is in a cell, the table name and this cell reference is displayed on the status bar.

Tip

Basic spreadsheet functions in tables are much the same as in LibreOffice Calc.  The 
main difference is that cell references are formatted differently. Cell A2 (first column, 
second row) is referred to in Calc as A2 (or $A$2 for an absolute reference). In Writer 
tables, it is referred to as <A2>.

For example, suppose you had two numbers in cells <B1> and <C2> and wanted to display the 
sum of the two in cell <A1>, as shown in Figure 14.

Do the following:

1) Click in cell <A1> and press the = key, or choose Table > Formula from the Menu bar, or 
press F2. The Formula bar appears automatically, near the top of the screen. In the 
leftmost side of the bar, you can see the coordinates of the selected cell.

2) Click in cell <B1>. The identifiers of this cell are automatically displayed in the Formula bar 
and inserted into cell <A1>.

3) Press the + key.

4) Click in cell <C2>. You can see the final formula = <B1>+<C2> displayed both in the 
selected cell and in the Object bar.

5) Press the Enter key, or click the green tick (check mark) on the Formula Bar, to replace the 
formula in the cell with the result of the calculation.
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Figure 14: Using spreadsheet functions in a table \

Tip

To display a cell's formula and make it available for editing, choose Table > Formula 
from the Menu bar, or press F2.

To display the list of the mathematical functions available for use in a table, display the
Formula toolbar by pressing F2 or by selecting a blank cell and pressing the =  key, 
and then click the Formula f(x) icon.

In our example, this gives the result 9 in the top left cell. For summing contiguous cells, you can 
simply select the cells in the row, column, or the rectangle of rows and columns. Thus, for example,
to add a column of numbers, do this:

 1) Type an equals sign = in an empty cell.

 2) Select the cells to be added together, in this case the cells from A2 to A5. The formula 
should be something like =<A2:A5>.

 3) Press the Enter key or click the green check mark on the Formula Bar.

 4) The result appears in the cell you have selected.

When using a function, you can type the cell references manually or select them. Thus, to add up 
the four numbers that we added above (A2, A3, A4, A5), do this:

 1) Type an equals sign = in an empty cell.

 2) Type sum or select it from the function list f(x).

 3) Select the contiguous cells to be added together. The formula should be something like 
=sum<A2:A5>.

 4) Press the Enter key or click the green tick (check mark) on the Formula Bar.

 5) The answer appears in the cell you have selected.

Caution 

Unlike in Calc, formulas are not updated automatically when inserting or deleting rows 
or columns of the table, although the results do update when you change a value in a 
cell. If you plan to use complex formulas, consider embedding a Calc spreadsheet in 
the Writer document. See Chapter 19, Spreadsheets, Charts, other Objects.
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Additional table operations

Protecting cells in a table
You can protect the contents of individual cells of a text table from changes.

Note

This protection is not intended for secure protection. It protects the cells against 
accidental changes.

To turn on cell protection, place the cursor in a cell or select cells, then slick the Protect Cells icon 
on the Table toolbar or choose Table > Protect Cells from the Menu bar.

To tun off cell protection, place the cursor in the cell or select the cells. First, if necessary, choose 
Tools > Options > LibreOffice Writer > Formatting Aids and mark Enable cursor in the 
Protected Areas section. Then click the Unprotect Cells icon on the Table toolbar or choose Table
> Unprotect Cells from the Menu bar.

To remove protection for the entire current table or all selected tables, press Shift+Ctrl+T.

Adding a caption
You can easily add a caption to any table. Writer will keep track of all your captioned tables, 
automatically number them, and update any links to them. The procedure is the same as for 
adding captions to images, described in Chapter 11.

Cross-referencing to a table
You can insert a cross-reference to a captioned table. Clicking on the cross-reference takes the 
reader directly to the table. For details, see “Using automatic cross-references” in Chapter 17, 
Fields.

Creating a heading row in an existing table
To create a heading row in an existing table that does not have one:

 1) Select the first row in the table and from the Menu bar select Table > Insert > Rows. 

 2) In the dialog that opens, ensure the Before option is selected and click OK. 

 3) Select the new first row and then from the Styles and Formatting window, double-click the 
Table Heading paragraph style to apply it to the heading row. 

As an alternative, you could apply a table style that does have a heading defined. (Here is where 
having some personalized table styles could come in very handy.) Place the cursor anywhere in 
the table, go to Table Styles in the Sidebar, and choose a style.

Merging and splitting tables
One table can be split into two tables, and two tables can be merged into a single table. Tables are 
split horizontally: the rows above the split point are put into one table, and the rows below into 
another.

To split a table:

 1) Place the cursor in a cell that will be in the top row of the second table after the split (the 
table splits immediately above the cursor).

 2) Choose Table > Split Table from the Menu bar.

 3) A Split Table dialog opens. You can select No heading or an alternative formatting for the 
heading of the new table.
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 4) Click OK. The table is then split into two tables separated by a blank paragraph.

Note

If cells in one table include formulas using data from the other table, those cells will 
contain an error message: **Expression is faulty**.

To merge two tables:

 1) Delete the blank paragraph between the tables. You must use the Delete key (not the 
Backspace key) to do this.

 2) Select any cell in one of the tables.

 3) Right-click and choose Merge Tables in the context menu. You can also use Table > Merge
Table from the Menu bar.

Tip

To see clearly where the paragraphs are and to delete them easily, choose View > 
Formatting Marks (Ctrl+F10) or click the ¶ button in the Standard toolbar.

Deleting a table
To delete a table, do either of the following:

• Click anywhere in the table and choose Table > Delete > Table from the Menu bar.

• Select from the end of the paragraph before the table to the start of the paragraph after the 
table, and then press the Delete key or the Backspace key.

Note

The second method also merges the paragraph after the table with the paragraph 
before the table, which may not be what you want.

Copying a table
To copy a table from one part of the document and paste it into another part:

 1) Click anywhere in the table.

 2) From the Menu bar choose Table > Select > Table.

 3) Press Ctrl+C or click the Copy icon on the Standard toolbar.

 4) Move the cursor to the target position and click to fix the insertion point.

 5) Press Ctrl+V or click the Paste icon in the Standard toolbar.

Moving a table
To move a table from one part of a document to another part:

 1) Click anywhere in the table.

 2) From the Menu bar, choose Table > Select > Table.

 3) Press Ctrl+X or click the Cut icon in the Standard toolbar. (This step removes the contents 
of the cells but leaves the empty cells, which must be removed in step 6.)

 4) Move the cursor to the target position and click to fix the insertion point.

 5) Press Ctrl+V or click the Paste icon in the Standard toolbar. (This pastes the cells and their 
contents and formatting.)
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 6) Return to the original table, click somewhere in it and then choose Table > Delete > Table 
from the Menu bar.

Inserting a paragraph before or after a table
To insert a paragraph before a table, position the cursor before any text or other contents in the 
first (upper left-hand) cell and press Enter or Alt+Enter. To insert a paragraph after a table, position
the cursor after any text in the last (lower right-hand) cell and press Alt+Enter.

Note

Captions are paragraphs separate from the table itself. If there is a caption below a 
table, for example, just position the cursor at the end of the caption and press Enter.

Using tables as a page layout tool
Tables may be used as a page layout tool to position text in a document instead of using tabs or 
spaces. For more information and tips about using tables in page layout, see Chapter 6, 
Formatting Pages: Advanced.

Tip

When inserting a table used for layout, you may wish to deselect the Heading and 
Border options (see “Inserting a new table” on page 5).

To remove the borders from an existing table, right-click the table, choose Table 
Properties from the context menu, select the Borders tab, and select the icon for no 
borders.

The Table menu and Table toolbar

All of the table commands described in this chapter are conveniently located on the Menu bar 
under Table and on the Table toolbar. When you create a table or select an existing table, the Table
toolbar is displayed automatically. You can manually display it at any time by clicking View > 
Toolbars > Table. The toolbar can float over the main Writer window, or it can be docked along 
any edge of the main window. See Chapter 1, Introducing Writer, for more about docking and 
floating toolbars, and how to hide and display specific tools on a toolbar.

Figure 15: The Table toolbar
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Figure 16: The Table menu
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