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Formatting objects

This chapter describes how to format the graphic objects created with the available drawing tools.

The format of each graphic object, in addition to its size, rotation and position on the slide, is 
determined by a number of attributes that define the line, text and area fill of each object. These 
attributes (among others) also contribute to a graphics style. Although this chapter discusses 
mainly the manual formatting of objects, it concludes by showing how to create, apply, modify and 
delete graphics styles.

Formatting lines
In LibreOffice the term line indicates both a freestanding segment and the outer edge of a shape. 
In most cases the properties of the line you can modify are its style (solid, dashed, invisible, and so
on), its width and its color. Select the line you need to format and then use the controls on the Line 
and Filling toolbar to select your desired options (highlighted in Figure 1).

Figure 1: Common line options on the Line and Filling toolbar

For more control when changing the appearance of a line, go to Format > Line on the main menu 

bar, or right-click on the line and select Line from the context menu, or select the Line icon  on 
the Line and Filling toolbar to open the Line dialog (Figure 2) where you can set line properties. 
This dialog consists of four pages: Line, Shadow, Line Styles, and Arrow Styles.

You can also use the Line section on the Sidebar to change the appearance of a line. See “Sidebar
Line section” on page 10 for more information.

Figure 2: Line dialog – Line page
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Line page
The Line page on the Line dialog is where you can set the basic parameters of the line. The page 
is divided into four sections: Line properties, Arrow styles, Width, and Corner and cap styles. At the
bottom of the page is a preview of the applied styles for a line and two different corners, so you can
evaluate the corner and cap style selections.

Line properties
The Line Properties section on the left side allows you to set the following parameters:

• Line style – several line styles are available from the drop-down list, but more line styles 
can be defined if necessary.

• Color – choose from the predefined colors in the drop down list or refer to “Custom colors” 
on page 14 to create a new color.

• Width – specifies the thickness of the line.

• Transparency – sets the transparency of a line. Figure 3 illustrates the effects of different 
percentages of transparency to lines when placed over an object.

Figure 3: Line transparency effect

Arrow styles
The Arrow styles section is only applicable to individual lines and is not used for lines that form the 
borders of an object. To create a new arrow style, see “Arrow styles page” on page 8.

• Style – sets the style of the two ends of a line. The left drop down menu is for where you 
start the line and the right drop down menu is for where you end the line.

• Width – specifies the thickness of the arrow endings

• Center – moves the center of the arrow endings to the end point of the line. Figure 4 shows
the effects of selecting this option.

• Synchronize ends – makes the two line ends identical.

Figure 4: Line arrow endings
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Arrowheads

A quick way to set the arrowheads for a selected line is to click on the Arrow Style icon  in the 
Line and Filling toolbar (Figure 1) to open the Arrowheads toolbar (Figure 5). Use this toolbar to 
select one of the many predefined arrowhead styles for the start and ending of a selected line.

Figure 5: Arrowheads menu

Corner and cap styles
Corner and cap styles determine how the connection between two segments of a line looks. There 
are four available options for corner styles (none, Rounded, Mitered, Beveled) and three cap styles
(Flat, Round, Square). To appreciate the difference between corner and cap styles, choose a thick 
line style and observe how the preview changes as you select each option.

Shadow page
Use the Shadow page of the Line dialog to add and format the line shadow. The settings on this 
page are the same as those for shadows applied to other objects and are described in Formatting 
shadows on page 22.

A quicker way to apply a shadow to a line is using the Shadow icon  on the Line and Filling 
toolbar (Figure 1). The main disadvantage of using the Shadow icon is that the shadow 
appearance will be constrained by the shadow settings of the default graphics style.

Line styles page
Use the Line Styles page (Figure 6) of the Line dialog to create new line styles as well as loading 
previously saved line styles. It is recommended to create new styles when necessary than to 
modify the predefined styles.

To create a new line style:

1) Choose Format > Line from the menu bar, or right-click on the line and select Line from 

the context menu, or select the Line icon  from the Line and Filling toolbar.
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Figure 6: Line dialog – Line Styles page

2) Click on the Line Styles tab.

3) Select from the Line style drop-down menu a style similar to the style you want to create.

4) Click Add. On the pop-up dialog, type a name for the new line style and click OK.

5) Now define the new style. Start by selecting the line type for the new style. To alternate two 
line types (for example, dashes and dots) within a single line, select different types in the 
two Type boxes.

6) Specify the Number and Length (not available for dot style) of each of the types of line 
selected.

7) Set the Spacing between the various elements

8) If necessary, select Fit to line width so that the new style fits the width of the selected line.

9) The new line style created is available only in the current document. If you want to use the 

line style in other presentations, click the Save Line Styles icon  and type a unique 
filename in the Save as dialog that opens. Saved styles have the file extension of .sod.

10) To use previously saved line styles, click the Load Line Styles icon  and select a style 
from the list of saved styles. Click Open to load the style into your presentation.

11) If necessary, click on the Modify button to change the name of the style.

Arrow styles page
Use the Arrow Styles page (Figure 7) of the Line dialog to create new arrow styles, or modify 
existing arrow styles, or load previously saved arrow styles.

Note
The arrowhead created must be convertible to a curve. A curve is something you can 

draw without lifting a pencil. For example,  can be converted to a curve, but  
cannot.
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Figure 7: Line dialog – Arrow Styles page

1) First draw a curve in the shape you want to use for the arrowhead or create a shape and 
convert to a curve. The top of the shape must face upward, as shown in Figure 8, because 
this becomes the point of the arrow.

Note
The arrowhead created must be convertible to a curve. A curve is something you can 

draw without lifting a pencil. For example,  can be converted to a curve, but  
cannot.

Figure 8: Using a pentagon shape for arrow styles

2) Select the shape and, if necessary, right click and choose Convert > To Curve from the 
context menu to convert the shape to a curve. If the shape is already a curve, To Curve will
not be available.

3) With the selection handles showing, select Format > Line from the menu bar, or right-click 
and choose Line from the context menu.

4) Go to the Arrow Styles page (Figure 7), click the Add button, type a name for the new 
arrow style and click OK. The new arrowhead style will be shown in the preview.

5) Now you can access the new style from the Arrow style list. When you select the name of 
the new style, it is shown at the bottom of the dialog.
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6) The new arrowhead style created is available only in the current document. If you want to 

use this arrowhead style in other presentations, click the Save Line Styles icon  and 
type a unique filename in the Save as dialog that opens. Saved styles have the file 
extension of .sod.

7) To use previously saved arrowhead styles, click the Load Line Styles icon  and select 
the style from the saved list of styles. Click Open to load the style into your presentation.

8) If necessary. click on the Modify button to change the name of the style.

Sidebar Line section
The Line section (Figure 9) on the Sidebar allows you to quickly change the appearance of a line 
and this section only becomes active when a graphical object is selected. You can change the 
Width, Color, Transparency, Style, Arrow, Corner style and Cap style of a selected graphical object
and these options are described in “Line page”, “Line styles page” and “Arrow styles page” above.

Clicking on the More Options icon in the right corner of the title bar will open the Line dialog 
(Figure 6) giving you more control over the appearance of lines.

Figure 9: Sidebar Line section

Formatting area fills

The term area fill refers to the inside of an object that has an unbroken border, for example a 
rectangle, circle, star, pentagon and so on. An area fill can be a uniform color, gradient, hatching 
pattern, or bitmap (Figure 10). An area fill can also be made partly or wholly transparent and can 
throw a shadow.

The Line and Filling toolbar has several tools normally used to quickly format graphic objects. If 
this toolbar is not visible, go to View > Toolbars > Line and Filling on the menu bar. You can also 
use the Area dialog to quickly format objects, see "Using Area dialog" on page 11 for more 
information.

Once you have decided on a predefined or custom fill, you can further refine it by adding a shadow
or transparency. See "Formatting shadows" on page 22 and "Formatting transparencies" on page
23 for more information.
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Figure 10: Different types of area fill

Using Line and Filling toolbar

Figure 11: Common area fill options highlighted

To quickly format an area fill of an object using the Line and Filling toolbar (Figure 11):

1) Select the object you wish to edit.

2) On the Line and Filling toolbar, click the left Area Style/Filling button and select the type of
area fill (Invisible, Color, Gradient, Hatching or Bitmap) you want to use from the options 
listed in the drop-down list.

3) On the Line and Filling toolbar, click the right Area Style/Filling button and select the color 
or type of area fill you want to use from the options listed in the drop-down list. The 
available options change depending on the type of area fill selected. This button is not 
available when None is selected for the area fill.

Note
If you do not require an area fill for an object, select None from the options available 
when you click the left Area Style/Filling button on the Line and Filling toolbar.

Using Area dialog
To quickly format an area fill of an object using the Area dialog, use the following procedure. You 
can also use the Area dialog to create your own area fill.

1) Select the object you wish to edit.

2) Go to Format > Area on the menu bar, or click the Area icon  on the Line and Filling 
toolbar, or right-click on the object and select Area from the context menu to open the Area 
dialog.

Note
If you do not require a fill for an object when using the Area dialog, select None from 
the options available.

3) For color area fills, select Color from the drop down list and then select your required color 
from the list of available colors (Figure 12).

4) Click OK and the color will appear as an area fill in the selected object.
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Figure 12: Area color dialog

5) For gradient area fills, select Gradient from the drop down list and then select your 
required gradient from the list of available gradients (Figure 13).

6) To override the number of steps (increments) that are applied to the gradient transition in a 
gradient fill, deselect Automatic in Increments and then enter the number of steps required
in the text box.

7) Click OK and the gradient will appear as an area fill in the selected object.

Figure 13: Area gradient dialog

8) For hatching area fills, select Hatching from the drop down list and then select your 
required hatching from the list of available hatchings (Figure 14).

9) Select Background color and select a background color for the hatching from the drop 
down list.

10) Click OK and the hatching will appear as an area fill in the selected object.

Figure 14: Area hatching dialog

11) For bitmap area fills, select Bitmaps from the drop down list and then select your required 
bitmap from the list of available bitmaps (Figure 15).

12) Set the Size, Position and Offset options as necessary. See Table 1 for more information 
on bitmap options.

13) Click OK and the bitmap will appear as an area fill in the selected object.
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Figure 15: Area bitmap dialog

Table 1: Bitmap options

Option Meaning

Size – Original Retains the original size of the bitmap when filling the selected object. To 
resize the bitmap, clear this checkbox

Size – Relative When selected, Relative rescales the bitmap relative to the size of the bitmap
by percentage values entered in the Width and Height boxes. Clear this 
checkbox to resize the bitmap using the linear measurements entered in the 
Width and Height boxes.

Size – Width Enter a width for the bitmap. When Relative is selected 100% means that the 
original bitmap width will be resized to occupy the whole fill area width; 50% 
means that the width of the bitmap will be half that of the fill area.

Size – Height Enter a height for the bitmap. When Relative is selected 100% means that 
the original bitmap height will be resized to occupy the whole fill area height; 
50% means that the height of the bitmap will be half that of the fill area.

Position – Anchor 
Point

Click in the position grid to specify an anchor point for the offset for tiling the 
bitmap.

Position – X offset When Tile is selected, enter a horizontal offset from the anchor point for the 
bitmap in percentage values.

Position – Y offset When Tile is selected, enter a vertical offset from the anchor point for the 
bitmap in percentage values.

Position – Tile Tiles the bitmap to fill the selected object. The size of the bitmap used for the 
tiling is determined by the Size options.
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Option Meaning

Position – Autofit Stretches the bitmap to fill the selected object. To use Autofit, uncheck the 
Tile option. Selecting Autofit disables all size settings.

Offset – Row When Tile is selected, offsets the rows of tiled bitmaps by the entered 
percentage value so that each row is offset from the previous row.

Offset – Column When Tile is selected, offsets the columns of tiled bitmaps by the entered 
percentage value so that each column is offset from the previous column.

Sidebar Area section
The Area section (Figure 16) on the Sidebar allows you to quickly change the appearance of the fill
in an object and this section only becomes active when a graphical object is selected. You can 
change the Fill and Transparency of a selected graphical object and these options are described in
“Using Area dialog” above.

Clicking on the More Options icon in the right corner of the title bar will open the Area dialog giving
you more control over the appearance of the object fill.

Figure 16: Sidebar Area section

Creating new area fills

The following sections describe how to create new fills and how to apply them.

Although you can change the characteristics of an existing fill and then click the Modify button, it is
recommended that you create new fills or modify custom fills rather than the predefined area fills, 
as these predefined area fills may be reset when updating LibreOffice.

Custom colors
On the Colors page of the Area dialog (Figure 17), you can modify existing colors or create your 
own. You can specify a new color either as a combination of the three primary colors Red (R), 
Green (G), and Blue (B), (RGB notation) or by percentages of Cyan (C), Magenta (M), Yellow (Y) 
and Black (K) (CMYK notation).

Creating new colors
1) Enter a name for the color you want to create in the Name box.

2) Select whether to define the color in RGB or CMYK. For RGB, specify the RGB 
components on a 0 to 255 scale. For CMYK, specify the CMYK components from 0% to 
100%.

3) Click the Add button. The color is now added to the Color drop down list.
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Figure 17: Area dialog – Colors page

Figure 18: Color Picker dialog
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Modifying colors
1) Select the color you want to modify from the Color drop down list.

2) Select either RGB or CMYK and enter the new values to define the color.

3) If necessary, type a new name in the Name box.

4) Click Modify and the modified color is saved.

Editing colors
1) Click Edit to open the Color Picker dialog (Figure 18).

2) Modify the color components as required using either RGB, CMYK or HSB (Hue, 
Saturation, Brightness) values.

3) Click OK to close the Color Picker dialog.

4) Click the Modify button on the Color dialog.

5) Click OK to save the changes and close the Area dialog.

Saving and using custom colors
Any new color created or modified is available only in the current document. If you want to use this 

color in other presentations, click the Save Color List icon  and type a unique filename in the 
Save as dialog that opens. The file created for a list of saved colors has the file extension of .soc.

To use a previously saved color list , click the Load Color List icon  and select the file used for
a custom color list from the file open dialog. Click Open to load the saved color list into Impress.

Tip
You can also add custom colors using Tools > Options > LibreOffice > Colors. This
method makes the color available to all components of LibreOffice. Colors created 
using the above procedures are only available for Impress.

Custom gradients
On the Gradients page of the Area dialog (Figure 19), you can modify existing gradients or create 
your own gradient. Several types of gradients are predefined in LibreOffice and changing the From 
and To colors could be sufficient to obtain a satisfactory result.

Creating or modifying gradients
1) Select a gradient type from the Type drop down list: Linear, Axial, Radial, Ellipsoid, or 

Square.

2) Alternatively, select one of the predefined gradient types shown in the preview box.

3) Adjust the option settings as necessary. The options used to create a gradient are 
summarized in Table 2. Depending on the gradient type selected, some options will not be 
available.

4) Click Add to add the newly created gradient to the list.

5) It is recommended to type a memorable name for the new gradient instead of using the 
default name of Gradient 1, Gradient 2 and so on.

6) Click OK to save the new gradient.

7) Click OK to close the Area dialog.
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Figure 19: Area dialog – Gradients page

Table 2: Gradient options

Option Meaning

Center X
For Radial, Ellipsoid, Square and Rectangular gradients, modify these values to 
set the horizontal offset of the gradient center.

Center Y
For Radial, Ellipsoid, Square and Rectangular gradients, modify these values to 
set the vertical offset of the gradient center.

Angle For all the gradient types, specifies the angle of the gradient axis.

Border
Increase this value to make the gradient start further away from the border of the 
object.

From
The start color for the gradient. In the edit box below enter the intensity of the 
color: 0% corresponds to black, 100% to the full color.

To
The end color for the gradient. In the edit box below enter the intensity of the color:
0% corresponds to black, 100% to the full color.

Saving and using custom gradients
Any new gradient created or modified is available only in the current document. If you want to use 

this gradient in other presentations, click the Save Gradients List icon  and type a unique 
filename in the Save as dialog that opens. The file created for a list of saved gradients has the file 
extension of .sog.

To use a previously saved gradients list, click the Load Gradients List icon  and select the file 
used a custom gradient list from the file open dialog. Click Open to load the saved gradients list 
into Impress.
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Advanced gradient controls
Gradient properties can be configured using the options given in Figure 19 and Table 2. Impress 
provides a graphical interface for modifying these gradient options using only the mouse as 
follows.

1) Select an object that has a gradient and open the Mode toolbar by going to View > 
Toolbars > Mode (Figure 20).

Figure 20: Mode toolbar

2) Open the Gradients page of the Area dialog, see “Creating or modifying gradients” above.

3) Click on the Gradient icon  in the Mode toolbar to display a dashed line connected to 
squares at each end of the dashed line. The colors displayed in the two squares show the 
From and To colors used for the selected gradient (Figure 21).

Figure 21: Using mouse to change gradient options

4) The gradient used for area fill in the object is adjusted as follows depending on the type of 
gradient:

Linear gradients – move the square corresponding to the From color to change where the 
gradient starts (border value). Move the square corresponding to the To color to change the
orientation (angle value).

Axial gradients – only the To color can be moved to change both the angle and border 
properties of the gradient.

Radial gradients – move the From color to modify the border property to set the width of 
the gradient circle. Move the To color to change the point where the gradient ends (Center 
X and Center Y values).

Ellipsoid gradients – move the From color to modify the border property to set the size of 
the gradient ellipsoid. Move the To color to change the angle of the ellipsoid axis and the 
axis itself.

Square gradients – move the From color to modify the border to set the size of the 
gradient square and the angle of the gradient shape. Move the To color to change the 
center of the gradient.
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5) When you are satisfied with the changes, click anywhere outside the selected object to 
deselect it.

Note
Moving the squares will have different effects depending on the type of gradient. For 
example, for a linear gradient, the start and end squares of the gradient will always 
be situated to either side of the center point of the object.

Custom hatching patterns
To create new hatching patterns or modify existing hatching patterns, select the Hatching tab of the
Area dialog (Figure 22). The options that can be set for a hatching pattern are explained in Table 3.

Creating or modifying hatching patterns
1) Select one of the predefined gradient types shown in the preview box

2) Modify the options of the lines forming the pattern. A preview is displayed in the window 
below the available patterns.

3) Click Add to add the newly created hatching pattern to the list.

4) It is recommended to type a memorable name for the new gradient instead of using the 
default name of Hatching 1, Hatching 2 and so on.

5) Click OK to save the new hatching pattern.

6) Click OK to close the Area dialog.

Figure 22: Area dialog – Hatching page
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Table 3: Hatching pattern options

Option Meaning

Spacing Determines the spacing between two lines of the pattern. As the value is 
changed the preview window is updated.

Angle Use the mini map below the numerical value to quickly set the angle formed 
by the line to multiples of 45 degrees. If the required angle is not a multiple of 
45 degrees, just enter the desired value in the edit box.

Line type Set single, double or triple line for the style of the pattern.

Line color Use the list to select the color of the lines that will form the pattern.

Saving and using custom hatching patterns
Any new hatching pattern created or modified is available only in the current document. If you want

to use this hatching pattern in other presentations, click the Save Hatches List icon  and type 
a unique filename in the Save as dialog that opens. The file created for a list of saved hatching 
patterns has the file extension of .soh.

To use a previously saved hatching patterns list, click the Load Hatches List icon  and select 
the file used for a custom hatching patterns list from the file open dialog. Click Open to load the 
saved hatching patterns list into Impress.

Figure 23: Area dialog – Bitmaps page
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Custom bitmap fills

Creating bitmap fills
1) Select Blank as the bitmap type from the preview list on the Bitmap page of the Area 

dialog to activate the Pattern Editor (Figure 23).

2) Select the Foreground and Background colors you want to use for your bitmap from the 
drop down lists.

3) Start creating the pattern by clicking in the squares (pixels) that you want in the foreground 
color. The background color will automatically fill the grid used for the Pattern Editor when 
you select the color.

4) Check the preview window to see the effect being achieved as you click the mouse button 
in a square.

5) When satisfied with your bitmap, click Add to save the bitmap.

6) Enter a memorable name for your bitmap in the Name dialog that opens. It is 
recommended not to use the default names of Bitmap 1, Bitmap 2 and so on if you want to 
reuse the bitmap you have just created.

7) Click OK and your bitmap is added to the preview list and is used as an area fill for your 
selected object.

Modifying bitmaps
Modifying a bitmap that you created creates a copy of the bitmap so that you can edit the bitmap 
pattern.

1) Select a bitmap pattern that you created from the preview list on the Bitmap page of the 
Area dialog (Figure 23).

1) Click Modify and type a new name for the bitmap in the Name dialog that opens.

2) Click OK.

3) Select the newly named bitmap from the preview list and modify the pattern. See "Creating 
bitmap fills" above for more information.

Importing bitmaps
1) Click Import on the Bitmap page of the Area dialog (Figure 23).

2) Browse to the directory containing the bitmap file you want to import and select it.

3) Click Open and type a name for the imported bitmap.

4) Click OK and your imported bitmap is added to the preview list and is used as an area fill 
for your selected object.

Note
Bitmaps generally have an extension .bmp or .png. If you create a bitmap image with 
Draw, select File > Export, choose PNG from the pull-down list of file formats, give 
the file a name and save it.

Saving and using custom bitmaps
Any new bitmap created or modified is available only in the current document. If you want to use a 

custom bitmap in other presentations, click the Save Bitmap List icon  and type a unique 
filename in the Save as dialog that opens. The file created for a list of saved bitmaps has the file 
extension of .sob.
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To use a previously saved hatching patterns list, click the Load Bitmap List icon  and select 
the file used for a bitmaps list from the file open dialog. Click Open to load the saved bitmap list 
into Impress.

Formatting shadows
Shadows can be applied to objects such as lines, shapes and text. In Impress you can quickly 
apply a default shadow or apply a customized shadow.

Default shadows
Default shadows use the Impress default settings and cannot be customized.

1) Select the object.

2) Click on the Shadow icon  in the Line and Filling toolbar and a shadow is applied to the
object.

Customizing shadows
To apply a customized shadow to an object, you have to use the Shadow on the Area dialog.

An alternative method for using customized shadows is to apply a style that uses a shadow See 
“Working with image styles” on page 27 for additional information on using styles.

1) Select the object and then select Format > Area on the main menu bar, or right click on the
object and select Area from the context menu to open the Area dialog.

2) Click on the Shadow tab to open the Shadow page (Figure 24).

Figure 24: Area dialog – Shadow page

3) Select Use shadow and set the shadow options fas follows:

Position – selects the point determining the direction in which the shadow is cast.

Distance – determines the offset distance between the object and the shadow.

Color – sets the color used for the shadow.

Transparency – determines the amount of transparency for the shadow: 0% opaque 
shadow, 100% transparent shadow.

4) Click OK and the customized shadow is applied to the object.
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Formatting transparencies
Transparencies can be applied to objects and to any shadow that has been applied to an object. In
Impress two types of transparencies can be applied to an object – uniform transparency and 
gradient transparency. For more information on gradient transparencies, including an example of 
combining a color gradient with a gradient transparency, see “Advanced gradient controls” on page
18.

To apply transparencies to lines, refer to “Formatting lines” on page 5 for more information. To 
apply transparencies to shadows, refer to “Formatting shadows” on page 22 for more information.

1) Select the object and then select Format > Area on the main menu bar, or right click on the
object and select Area from the context menu to open the Area dialog.

2) Click on the Transparency tab to open the Transparency page (Figure 25).

3) To create a uniform transparency, select Transparency and then select the percentage of 
transparency required.

4) To create a gradient transparency so that the area becomes gradually transparent, select 
Gradient and then set the options for the gradient. Refer to Table 4 for a description of the 
options available for gradient transparencies.

5) Click OK and the transparency is applied to the object.

Figure 25: Area dialog – Transparency page

Table 4: Gradient transparency options

Option Meaning

Type Select the type of transparency gradient you want to apply.

Center X
Radial, Ellipsoid, Quadratic and Square gradients – modify this value to set the 
horizontal offset of the gradient center.

Center Y
Radial, Ellipsoid, Quadratic and Square gradients – modify this value to set the 
vertical offset of the gradient center.

Angle
Linear, Axial, Ellipsoid, Quadratic and Square gradient – specifies the angle of 
the gradient axis.
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Option Meaning

Border
Increase this value to make the gradient start further away from the border of the 
object.

Start value
Value for the starting transparency gradient. 0% is fully opaque, 100% is fully 
transparent.

End value
Value for the ending transparency gradient. 0% is fully opaque, 100% is fully 
transparent.

Formatting text in objects

Impress provides two dialogs related to text formatting on the main menu bar: Format > Character 
for individual characters and Format > Paragraph for paragraphs. However, this section only 
covers the formatting the appearance of any text which has been added to an object. For more 
information on formatting text that is used separately on a slide, see Chapter 3 Adding and 
Formatting Text.

Adding text to objects
To add text to an object:

1) Select the object to which text will be added so that the selection handles are showing.

2) Double-click on the object and the cursor becomes an I-beam to indicate text mode.

3) Type your text.

4) When finished, click outside of the object or press Esc.

Formatting and editing text in objects
To format text that has been placed into an object:

1) Select the object which contains text.

2) Select the object and go to Format > Text on the main menu bar or right-click on the object
and select Text from the context menu to open the Text dialog (Figure 26).

Figure 26: Text dialog
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3) Format and edit the text using the available options. Some options will not be available 
depending on the type of object to which the text has been added.

Fit width to text – expands the width of the object if the text is too long.

Word wrap text in shape – starts a new line automatically when the edge of the object is 
reached.

Fit height to text – expands the object height whenever it is smaller than the text (set by 
default for lines).

Resize shape to fit text – expands an object when the text inserted in the object is too 
large.

Fit to frame – expands the text so that it fills all the available space.

Adjust to contour – makes the text follow a curved line.

Spacing to borders – specify the amount of space to be left between the borders of the 
object and the text. This is similar to setting indentation and spacing for paragraphs.

Text anchor – used to anchor the text to a particular point within the object.

Full width – when selected, anchors the text in the center of the object and uses the full 
width of the object before wrapping text.

4) Click OK to close the dialog and save the changes to the text.

Text animation
To animate text that has been placed into an object:

1) Select the object which contains text.

2) Select the object and go to Format > Text on the main menu bar or right-click on the object
and select Text from the context menu to open the Text dialog (Figure 26).

3) Click the Text Animation tab to open the Text Animation dialog (Figure 27).

Figure 27: Text animation dialog
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4) Select the type of animation required from the Effects drop down list as follows:

No animation – default setting.

Blink – the text will blink on the screen.

Scroll through – the text will move into the object and then out following the selected 
direction.

Scroll back and forth – the text will move first in the selected direction, but will bounce 
back at the object border.

Scroll in – the text will scroll in towards the given direction starting from the edge of the 
object and stop in the center.

5) Set the properties for the animation effect as follows:

Direction – use one of the four arrows to set the scroll direction for the text.

Start inside – animation starts from inside the object.

Text visible when editing select to see the text while editing.

Animation cycles – select Continuous and the text animates continuously or set a specific
number of cycles for the animation.

Increment – sets the amount the animation moves in either Pixels or a specific distance. 
Units of measurement depend on the settings in Tools > Options > LibreOffice Impress >
General.

Delay – sets the delay time either Automatically or a specific length of time before the 
animation starts.

6) Click OK to close the dialog and save the animation effect.

Formatting connectors

Connectors are lines that join two shapes and always start from or finish at a glue point on an 
object. Refer to Chapter 5 Managing Graphic Objects for a description and use of the connectors.

Figure 28: Connector dialog

Connectors are formatted as follows:

1) Right-click on a connector and select Connector from the context menu to open the 
context dialog (Figure 28).

2) Set the type of connector from the Type drop down list.

26 Formatting Graphic Objects



3) Set the Line skew for the connector. Line skew is used to set the distance between lines 
where multiple connectors overlap. You can customize the distance between three different
lines.

4) Set the Line spacing for the connector. Line spacing is used to set the horizontal and 
vertical space between the connector and the object at each end of the connector.

5) Click OK to close the dialog and save the changes.

Working with image styles

To achieve consistency in styles in slides, or a presentation, or to apply the same formatting to a 
large number of objects, it is recommended to use image styles.

Image styles are similar to paragraph styles that are used for text. An image style groups all the 
formatting properties applicable to a graphical object and then associates this group of properties 
with a name allowing it to be used for other graphical objects. If n image style is modified (for 
example, changing an area transparency), the changes are automatically applied to all objects that
use the same image style.

If you use Impress frequently, a library of well-defined image styles is an invaluable tool for 
speeding up the process of formatting your work according to any style guidelines you may need to
follow (company colors, fonts and so on).

Linked image styles
Image styles support inheritance which allows a style to be linked to another (parent) style so that it
inherits all the formatting settings of the parent. This inheritance creates families of styles.

For example, if you require multiple boxes that differ in color, but are otherwise identically 
formatted, the best way to proceed is to define an image style for the box including borders, area 
fill, font, and so on and a number of image styles that are hierarchically dependent which differ only
in the fill color attribute. If you need to change the font size or the thickness of the border, you only 
have to change the parent style and all the other styles will change accordingly.

Creating image styles
You can create a new image style either by using the Style and Formatting dialog or from a 
selection.

Using the Styles and Formatting dialog
1) Select a graphical object.

2) Press the F11 key, or click on the Styles and Formatting icon  on the Line and Filling 
toolbar, or select Format > Styles and Formatting on the main menu bar to open the 
Styles and Formatting dialog (Figure 29).

3) Click on the Image Styles icon  on the title bar of the Styles and Formatting dialog to 
access image styles.

4) Select the style similar to the one you want to use in the Styles and Formatting dialog.

5) Right click and select New from the context menu to open the Image Styles dialog (Figure 
30). By default, this will link the selected image style with the new image style.

6) To create a image style without linking, select None from the Linked with drop down menu 
on the Organizer page.

7) Give your new image style a memorable name.
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Figure 29: Image Styles and Formatting

Figure 30: Image Styles dialog

8) Use the various tabs and text boxes in the Image Styles dialog to format and categorize 
your new style as follows:

Organizer – contains a summary of the style and its hierarchical position.

Font, Font Effects, Indents & Spacing, Alignment, Tabs and Asian Typography – set 
the properties of the text inserted in a graphical object.

Dimensioning – used to set the style of dimension lines.

Text, Text Animation, Connector, Line, Area, Shadowing, and Transparency – 
determine the formatting of a graphical object and are discussed elsewhere in this chapter.

9) Click OK when finished to save your new image style.

Note
When styles are linked, changing the font for example will change the font in all linked 
styles. Sometimes this is exactly what you want; at other times you do not want the 
changes to apply to all linked styles. It pays to plan ahead.
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From a selected object
You can create a new style from an object that has already been formatted. This can be text or 
graphics:

1) Select the object you want to use to create your new style, then carry out any changes to 
the object appearance, for example border thickness, fill color and so on.

2) Open the Styles and Formatting dialog and click the New Style from Selection icon .

3) In the Create Style dialog (Figure 31) that opens type a name for the new style. The list 
shows existing custom styles of that are available.

4) Click OK to save the new style.

Figure 31: Create Style dialog

Modifying image styles
1) Open the Styles and Formatting dialog.

2) Right-click on the style you want to modify and select Modify from the context menu to 
open the Image Style dialog (Figure 30).

3) Make the required changes to the style and then click OK to save the changes.

Updating an image style from a selection
To update a style from changes you have made to a selected object:

1) Select an object that uses the format you want to adopt as a style.

2) Open the Styles and Formatting dialog and select the style you want to update.

3) Click the Update Style icon  and the style is updated with your changes.

Tip

Any changes you make to a style are effective only in the document on which you are
working and do not into change the styles used in the associated template. If you 
want the changes to apply to more than one document, you need to change the 
template (see Chapter 2 Using Slide Masters, Styles, and Templates for more 
information).
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Applying image styles
Use the following steps to apply an image style to an object.

1) Open the Styles and Formatting dialog (Figure 29) and click on the Image Styles icon  
on the to access image styles.

2) Select the object to which you want to apply an image style.

3) Double-click on the name of the image style you want to apply.

4) Alternatively, click on the Fill Format Mode icon  and the cursor changes to this icon.

5) Position the icon on the graphic object to be styled and click the mouse button. This mode 
remains active until you turn it off, so you can apply the same style to several objects.

6) To quit Fill Format mode, click the Fill Format Mode icon again or press the Esc key.

Note
When Fill Format Mode is active, a right-click anywhere in the document cancels the 
last Fill Format action. Take care not to accidentally right-click and undo any actions you
want to keep.

Tip
At the bottom of the Styles and Formatting window is a drop-down list. You can choose 
to show all styles or groups of styles such as applied styles or (in the case of image 
styles) custom styles.

Deleting image styles
You cannot delete any of the predefined styles in Impress, even if you are not using them. You can 
only delete user-defined (custom) styles. However, before you delete a custom style, make sure 
the style is not in use. If an unwanted style is in use, replace it with a substitute style.

1) Open the Styles and Formatting dialog (Figure 29) and click on the Image Styles icon  
on the to access image styles.

2) Right-click on a custom graphic style and click Delete on the context menu. You can only 
delete one custom image style at a time.

3) Click Yes to confirm the deletion of the image style.

Assigning styles to shortcut keys
LibreOffice provides a set of predefined keyboard shortcuts which allow you to quickly apply styles 
while working with a document. You can redefine these shortcuts or define your own, as described 
in Appendix A Keyboard Shortcuts.
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