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Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. 
The table below gives some common substitutions for the instructions in this chapter. For a more 
detailed list, see the application Help.

Windows/Linux Mac equivalent Effect

Tools → Options menu 
selection

LibreOffice → Preferences Access setup options

Right-click Control+click Open context menu

Ctrl (Control) z (Command) Used with other keys

F5 Shift+z+F5 Open the Navigator

F11 z+T Open Styles & Formatting window
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Introduction

A template is a model that you use to create other documents. For example, you can create a 
template for business reports that has your company’s logo on the first page. New documents 
created from this template will all have your company’s logo on the first page.

Templates can contain anything that regular documents can contain, such as text, graphics, a set 
of styles, and user-specific setup information such as measurement units, language, the default 
printer, and toolbar and menu customization.

All documents in LibreOffice (LibreOffice) are based on templates. If you do not specify a template 
when you start a new Writer document, the document is based on the default template for text 
documents. If you have not specified a default template, Writer uses the blank template for text 
documents that is installed with LibreOffice. See “Error: Reference source not found” on page 
Error: Reference source not found for more information.

Using a template to create a document

To use a template to create a document:

1) From the menu bar, choose File → New → Templates and Documents. The Templates and 
Documents dialog box opens.

Figure 1. Templates and Documents dialog box

2) In the box on the left, click the Templates icon if it is not already selected. A list of template 
folders appears in the center box.

3) Double-click the folder that contains the template that you want to use. A list of all the 
templates contained in that folder appears in the center box.

4) Select the template that you want to use. You can preview the selected template or view 
the template’s properties:

• To preview the template, click the Preview icon . A preview of the template 
appears in the box on the right.

• To view the template’s properties, click the Document Properties icon . The 
template’s properties appear in the box on the right.
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5) Click Open. The Templates and Documents dialog box closes and a new document based 
on the selected template opens in Writer. You can then edit and save the new document 
just as you would any other document.

Creating a template

You can create your own templates in two ways: from a document, and using a wizard.

Creating a template from a document
To create a template from a document:

1) Open a new or existing document you want to make into a template.

2) Add the content and styles that you want.

3) From the menu bar, choose File → Templates → Save. The Templates dialog box opens 
(see Figure 2).

4) In the New template field, type a name for the new template.

5) In the Categories list, select the category to which you want to assign the template. The 
category is simply the template folder in which you want to save the template. For example, 
to save the template in the “My Templates” folder, click the My Templates category.

To learn more about template folders, see “Organizing templates” on page 10.

6) Click OK to save the new template.

Figure 2. Saving a new template

Any settings that can be added to or modified in a document can be saved in a template. For 
example, below are some of the settings (although not a full list) that can be included in a Writer 
document and then saved as a template for later use:

• Printer settings: which printer, single-sided or double-sided printing, paper size, and so on.

• Styles to be used, including character, page, frame, numbering, and paragraph styles.

• Format and settings regarding indexes, tables, bibliographies, table of contents.

Templates can also contain predefined text, saving you from having to type it every time you create 
a new document. For example, a letter template may contain your name, address and salutation.

You can also save menu and toolbar customizations in templates; see Chapter 14, Customizing 
LibreOffice, for more information.
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Creating a template using a wizard
You can use wizards to create Writer templates for letters, faxes, and agendas.

For example, the Fax Wizard steps you through the following choices:

• Type of fax (business or personal)

• Document elements like the date, subject line (business fax), salutation, and 
complimentary close

• Options for sender and recipient information (business fax)

• Text to include in the footer (business fax)

To create a template using a wizard:

1) From the menu bar, choose File → Wizards → [type of template required].

Figure 3: Creating a template using a wizard

2) Follow the instructions on the pages of the wizard. This process is slightly different for each 
type of template, but the format is similar for all of them.

3) In the last section of the wizard, you can specify the name and location for saving the 
template. The default location is your user templates directory, but you can choose a 
different location if you prefer.

4) Finally, you have the option of creating a new document from your template immediately, or 
manually changing the template. For future documents, you can re-use the template 
created by the wizard, just as you would use any other template.

Editing a template

You can edit a template’s styles and content, and then, if you wish, you can reapply the template’s 
styles to documents that were created from that template. (Note that you can only reapply styles. 
You cannot reapply content, except for content in headers and footers.)

To edit a template:

1) From the menu bar, choose File → Templates → Organize. The Template Management 
dialog box opens (see Figure 4).

2) In the box on the left, double-click the folder containing the template that you want to edit. A 
list of all the templates contained in that folder appears underneath the folder name.
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3) Select the template that you want to edit.

4) Click the Commands button and choose Edit from the drop-down menu. 

5) Edit the template just as you would any other document. To save your changes, choose 
File → Save from the menu bar.

Figure 4. Template management dialog box

Updating a document from a changed template
The next time that you open a document that was created from the changed template, the following 
message appears.

Figure 5. Update styles message

Click Update Styles to apply the template’s changed styles to the document. Click Keep Old 
Styles if you do not want to apply the template’s changed styles to the document (but see Caution 
notice below).

Caution 

If you choose Keep Old Styles in the message box shown in Figure 5, that message 
will not appear again the next time you open the document after changing the 
template it is based on. You will not get another chance to update the styles from the 
template, although you can use the macro given in the Note below to re-enable this 
feature.

You can also use the Template Changer extension (see page 10) to reactivate the 
template.
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Note

To re-enable updating from a template:

1) Use Tools → Macros → Organize Macros → LibreOffice Basic. Select the 
document from the list, click the expansion symbol (+ or triangle), and select 
Standard. If Standard has an expansion symbol beside it, click that and select a 
module.

2) If the Edit button is active, click it. If the Edit button is not active, click New.

3) In the Basic window, enter the following:
Sub FixDocV3 
' set UpdateFromTemplate 
 oDocSettings = ThisComponent.createInstance( _ 
  "com.sun.star.document.Settings" ) 
 oDocSettings.UpdateFromTemplate = True 
End Sub 'FixDocV3

4) Click the Run BASIC icon, then close the Basic window.

5) Save the document.

Next time when you open this document you will have the update from template 
feature back.

Adding templates with Extension Manager

The Extension Manager provides an easy way to install collections of templates, graphics, macros, 
or other add-ins that have been “packaged” into files with a .OXT extension. See Chapter 16, 
Customizing Writer, for more about the Extension Manager.

This Web page lists many of the available extensions: http://extensions.libreoffice.org/.

To install an extension, follow these steps:

1) Download the extension package and save it anywhere on your computer.

2) In Writer, select Tools → Extension Manager from the menu bar. In the Extension Manager 
dialog box (Figure 6), click Add.

3) A file browser window opens. Find and select the package of templates you want to install 
and click Open.The package begins installing. You may be asked to accept a license 
agreement.

4) When the package installation is complete, the templates are available for use through File 
→ New → Templates and Documents and the extension is listed in the Extension Manager.

Setting a default template

If you create a document by choosing File → New → Text Document from the menu bar, Writer 
creates the document from the Default template for text documents. You can, however, set a 
custom template to be the default. You can reset the default later if you choose.

Setting a custom template as the default
You can set any template to be the default, as long as it is in one of the folders displayed in the 
Template Management window. If necessary, you can add the template to a folder as described in 
“Importing a template” on page 11.
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Figure 6: Newly-added package of templates

To set a custom template as the default:

1) From the menu bar, choose File → Templates → Organize. The Template Management 
dialog box (Figure 4) opens.

2) In the box on the left, select the folder that contains the template that you want to set as the 
default, then select the template.

3) Click the Commands button and choose Set as Default Template from the drop-down 
menu.

The next time that you create a document by choosing File → New → Text Document, the 
document will be created from this template.

Although many important settings can be changed in the Options dialog (see Chapter 2, Setting up 
Writer), for example default fonts and page size, more advanced settings (such as page margins) 
can only be changed by replacing the default template with a new one.

Resetting Writer’s Default template as the default
To re-enable Writer’s Default template as the default:

1) In the Template Management dialog box (Figure 4), select any folder in the box on the left.

2) Click the Commands button and choose Reset Default Template → Text Document from 
the drop-down menu.

The next time that you create a document by choosing File → New → Text Document, the 
document will be created from Writer’s Default template.
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Associating a document with a different template

At times you might want to associate a document with a different template, or perhaps you’re 
working with a document that did not start from a template.

One of the major advantages of using templates is the ease of updating styles in more than one 
document, as described in Chapter 7, Working with Styles. If you update styles by loading a new 
set of styles from a different template (as described in Chapter 7), the document has no 
association with the template from which the styles were loaded—so you cannot use this method. 
What you need to do is associate the document with the different template.

You can do this in two ways. In both cases, for best results the names of styles should be the same 
in the existing document and the new template. If they are not, you will need to use Search and 
Replace to replace old styles with new ones. See Chapter 3, Working with Text, for more about 
replacing styles using Search and Replace.

Method 1
This method includes any graphics and wording (such as legal notices) that exists in the new 
template, as well as including styles. If you don’t want this material, you need to delete it.

1) Use File → New → Templates and Documents. Choose the template you want. A new file 
is created from the template. If the template has unwanted text or graphics in it, delete 
them from this new file.

2) Open the document you want to change. (It opens in a new window.) Press Control+A to 
select everything in the document. Paste into the blank document created in step 1.

3) Update the table of contents, if there is one. Save the file.

Method 2
This method does not include any graphics or text from the new template, except material in 
headers and footers; it simply includes styles from the new template and establishes an 
association between the template and the document.

1) Download the Template Changer extension from http://extensions.libreoffice.org/ and install 
it as described on page 8.

2) Close and reopen LibreOffice. Now the File → Templates menu has two new choices: 
Assign Template (current document) and Assign Template (folder).

3) Open the document whose template you want to change. Choose File → Templates → 
Assign Template (current document).

4) In the Select Template window, find and select the required template and click Open.

5) Save the document. If you now look in File → Properties, you will see the new template 
listed at the bottom of the General page.

Organizing templates

Writer can only use templates that are in LibreOffice template folders. You can, however, create 
new LibreOffice template folders and use them to organize your templates. For example, you might 
have one template folder for report templates and another for letter templates. You can also import 
and export templates.

To begin, choose File → Templates → Organize from the menu bar. The Template Management 
dialog box (Figure 4) opens.

Note
All the actions made by the Commands button in the Template Management dialog 
box can be made as well by simply right-clicking on the templates or the folders.
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Creating a template folder
To create a template folder:

1) In the Template Management dialog box, select any folder.

2) Click the Commands button and choose New from the drop-down menu. A new folder 
called Untitled appears.

3) Type a name for the new folder, and then press Enter. Writer saves the folder with the 
name that you entered.

Deleting a template folder
You cannot delete template folders supplied with LibreOffice or installed using the Extension 
Manager; you can only delete template folders that you have created. (If you have administrator 
privileges, you can delete any folder.)

To delete a template folder:

1) In the Template Management dialog box, select the folder that you want to delete.

2) Click the Commands button and choose Delete from the drop-down menu. A message box 
appears and asks you to confirm the deletion. Click Yes.

Moving a template
To move a template from one template folder to another template folder:

1) In the Template Management dialog box, double-click the folder that contains the template 
that you want to move. A list of all the templates contained in that folder appears 
underneath the folder name.

2) Click the template that you want to move and drag it to the desired folder. If you do not 
have the authority to delete templates from the source folder, this action copies the 
template instead of moving it.

Deleting a template
You cannot delete templates supplied with LibreOffice or installed using the Extension Manager; 
you can only delete templates that you have created. (If you have administrator privileges, you can 
delete any template.)

To delete a template:

1) In the Template Management dialog box, double-click the folder that contains the template 
that you want to delete. A list of all the templates contained in that folder appears 
underneath the folder name.

2) Click the template that you want to delete.

3) Click the Commands button and choose Delete from the drop-down menu. A message box 
appears and asks you to confirm the deletion. Click Yes.

Importing a template
If the template that you want to use is in a different location, you must import it into an LibreOffice 
template folder.

To import a template into a template folder:

1) In the Template Management dialog box, select the folder into which you want to import the 
template.

2) Click the Commands button and choose Import Template from the drop-down menu. A 
standard file browser window opens.
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3) Find and select the template that you want to import, and then click Open. The file browser 
window closes and the template appears in the selected folder. 

4) If you want, type a new name for the template, and then press Enter.

Exporting a template
To export a template from a template folder to another location:

1) In the Template Management dialog box, double-click the folder that contains the template 
that you want to export. A list of all the templates contained in that folder appears 
underneath the folder name.

2) Select the template that you want to export.

3) Click the Commands button and choose Export Template from the drop-down menu. The 
Save As window opens.

4) Find the folder into which you want to export the template and click Save.
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