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Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. 
The table below gives some common substitutions for the instructions in this chapter. For a more 
detailed list, see the application Help.

Windows or Linux Mac equivalent Effect

Tools > Options 
menu selection

LibreOffice > Preferences Access setup options

Right-click Control+click and/or right-click 
depending on system setup

Open a context menu

Ctrl (Control) z (Command) Used with other keys

F5 Shift+z+F5 Open the Navigator

F11 z+T Open the Styles and Formatting window

Documentation for LibreOffice is available at http://www.libreoffice.org/get-help/documentation
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Connectors and glue points

Connectors and glue points were briefly introduced in Chapter 2 Drawing Basic Shapes. This 
section describes them in more detail and how to use them.

Connectors are lines or arrows whose ends automatically dock to a connection or glue point on an 
object. Connectors are useful when drawing, for example, flowcharts and organization charts. The 
connecting lines between objects remain intact even when objects are moved or rearranged. Also, 
if you copy an object with a connector, the connector is also copied.

Connectors
Draw has a comprehensive selection of connectors on a Connectors toolbar (Figure 1) to help you 
connect objects in, for example, a flowchart or organization chart. To open this toolbar, click on the 

small triangle to the right of the Connector icon  on the Drawing toolbar. Note that this icon 
changes shape depending on the last connector tool used. This toolbar can become a floating 
toolbar by clicking on the bottom of the pop-up toolbar and dragging it into your workspace.

Figure 1: Connector toolbar

Types of connectors
Connectors fall into four type groups:

• Standard connectors – the line segments run vertically and horizontally. All angles are right 
angles when the connector bends around objects (Figure 2).

• Line connectors – consist of a line segment with two smaller segments at the ends (Figure 
3).

• Straight connectors – consist of a single line (Figure 4).

• Curved connectors – are based on Bézier curves and curve around objects (Figure 5).

Figure 2: Standard connectors     Figure 3: Line connectors
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Figure 4: Straight connectors     Figure 5: Curved connectors

Adding connectors
When you click a connector and move the mouse pointer over a filled object or the edge of an 
unfilled object, glue points appear. A glue point is a fixed point where you can attach a connector 
line. You can also add custom glue points to an object. See “Glue points” on page 6 for more 
information.

To draw a connector, select the connector type and click on a glue point on an object. Drag the 
cursor to a glue point on another object and then release. Draw creates the connector, avoiding 
any objects in its path (Figure 6).

You can also drag a connector to an empty part of your document. When you release the mouse 
button, the unattached end of the connector is locked into place until you drag the end to a different 
location.

Figure 6: Connector between two objects

Figure 7: Connector dialog
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Modifying connectors
To detach or reposition a connector, drag either end of the connector line to a different location.

To change the connector route or shape between objects, click on a control handle in the middle of 
a section on the connector line and drag it to a new position. Remember not to drag the connector 
so that it overlaps or touches any objects and creates a confusing drawing.

To modify a connector, right-click on the connector and select Connector from the context menu. A 
Connector dialog (Figure 7) opens where you can change connector type and its properties (Line 
skew and Line spacing). You cannot change the ends of the connector using this dialog. To change 
the ends, you have to draw a new connector.

Glue points
Glue points are not the same as the selection handles of an object. The handles are for moving or 
changing the shape of an object; see Chapter 3 Working with Objects and Object Points for more 
information. Glue points are used to fix or glue a connector to an object so that when the object 
moves, the connector stays fixed to the object.

All Draw objects have glue points, which normally are not displayed. Glue points only become 

visible when the Connectors icon  on the Drawing toolbar is selected. Note that the 
Connectors icon changes shape depending on the last connector tool used.

To add, customize or delete glue points to an object, go to View > Toolbars > Gluepoints on the 
main menu bar to open this toolbar (Figure 8). This toolbar only becomes active after you click on 

the Glue Points icon  or select Edit > Glue Points on the main menu bar. Figure 6 on page 5 
shows an example of active glue points.

Figure 8: Gluepoints toolbar

Types of glue points
When the Gluepoints toolbar opens, only the six tools on the left of the toolbar are active. The 
remaining six tools on the right of the toolbar only become active when the Glue Point Relative 
icon is deselected.

With reference to Figure 9, the following briefly describes the function of each tool on the 
Gluepoint toolbar.

• Insert Glue Point – inserts a glue point where you click in an object.

• Exit Direction Left – connector attaches to the left edge of the selected glue point.

• Exit Direction Top – connector attaches to the top edge of the selected glue point.

• Exit Direction Right – connector attaches to the right edge of the selected glue point.

• Exit Direction Bottom – connector attaches to the bottom edge of the selected glue point.

• Glue Point Relative – maintains the relative position of a selected glue point when you 
resize an object. This tool is selected by default when the Gluepoint toolbar opens. The 
following six tools only become active when this tool is deselected.

• Glue Point Horizontal Left – when the object is resized, the current glue point remains 
fixed to the left edge of the object.

• Glue Point Horizontal Center – when the object is resized, the current glue point remains 
fixed to the center of the object.
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Figure 9: Glue point tools

• Glue Point Horizontal Right – when the object is resized, the current glue point remains 
fixed to the right edge of the object.

• Glue Point Vertical Top – when the object is resized, the current glue point remains fixed 
to the top edge of the object.

• Glue Point Vertical Center – when the object is resized, the current glue point remains 
fixed to the vertical center of the object.

• Glue Point Vertical Bottom – when the object is resized, the current glue point remains 
fixed to the bottom edge of the object.

Note
Each glue point you have added can have only one horizontal position and one 
vertical position. Only one of the horizontal position tools and one of the vertical 
position tools can be selected and used at any one time.

Adding glue points
By default, most objects normally have four glue points. To add extra glue points to an object or to 
an object that does not have glue points, proceed as follows:

1) Make sure no objects are selected and click on the Glue Points icon  or select Edit > 
Glue Points on the main menu bar. Glue points will appear as small crosses on objects 
(Figure 6 on page 5).

2) If the Gluepoints toolbar (Figure 8 on page 6) does not open, go to View > Toolbars > 
Gluepoints on the main menu bar.

3) Select the object and then the Insert Glue Point icon .

4) Move your cursor to a position where you want the glue point on an object and double-click 
to insert the glue point.

5) To move a glue point to another position, click on the glue point and drag it to its new 
position. Guide lines automatically appear when moving glue points.

Tip
When adding, moving or customizing glue points, it is recommended to use the 
zoom function to make it easier to work with glue points. See Chapter 3 Working 
with Objects and Object Points for more information.
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Customizing glue points
Only glue points that have added to an object can be customized. The default glue points included 
with an object cannot be customized.

1) Make sure no objects are selected and click on the Glue Points icon  or select Edit > 
Glue Points on the main menu bar. Glue points will appear as small crosses on objects 
(Figure 6 on page 5).

2) If the Gluepoints toolbar (Figure 8 on page 6) does not open, go to View > Toolbars > 
Gluepoints on the main menu bar.

3) Make sure the object is not selected and double-click on a glue point that you have added 
to select the glue point.

4) Select the exit directions you want to use for connectors and double-click again on the glue 
point to customize the glue point.

5) To use horizontal and vertical positioning, click on the Glue Point Relative icon or right-
click on the glue point and select Adapt Position to Object from the context menu to 
deselect this tool.

6) Select the horizontal and vertical positioning tools you want to use and double-click on the 
glue point to customize the glue point. Only one horizontal positioning tool and one vertical 
positioning tool can be used at any one time.

Deleting glue points
Only glue points that have added to an object can be deleted. The default glue points included with 
an object cannot be deleted.

1) Make sure no objects are selected and click on the Glue Points icon  or select Edit > 
Glue Points on the main menu bar. Glue points will appear as small crosses on objects 
(Figure 6 on page 5).

2) Make sure the object is not selected and double-click on a glue point that you have added 
to select the glue point.

3) Right-click on the glue point and select Cut from the context menu, or press the Delete key 
on the keyboard, or got to Edit > Cut on the main menu bar.

Connector text
Text can be easily added to connectors, then formatted or edited to make, for example, your 
flowchart or organization chart easier to follow. See Chapter 2 Drawing Basic Shapes and Chapter 
9 Adding and Formatting Text for more information on working with text.

Adding text
1) Double-click on the connector. The control points become active and the familiar flashing 

text cursor appears (the cursor position is determined by the last used setting). The Text 
Formatting toolbar replaces the Line and Filling toolbar under the menu bar.

2) Use the Text Formatting toolbar or Format and Tools on the main menu bar to change 
the default format of the text.

3) Type the text and, when you have finished typing the text and using the text tools, move the 
cursor away from the objects and connector and click to end the text mode. The Line and 
Filling toolbar then replaces the Text Formatting toolbar.
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Figure 10: Text dialog

Formatting and editing text
1) Click on the text to enter text editing mode. The Text Formatting toolbar replaces the Line 

and Filling toolbar under the menu bar.

2) Perform any changes to the text using the text tools provided on the Text Formatting 
toolbar or Format and Tools on the main menu bar. You can also right-click on the text and 
select text tools from the context menu.

3) Right-click on the text and select Text from the context menu or go to Format > Text to 
open the Text dialog (Figure 10) where you can change the Text anchor and Spacing to 
borders.

Note
A connector has an invisible rectangle around it. Text anchor will position the text 
within this invisible rectangle and Spacing to borders will create margins between 
the text and the borders. These options are in addition to the standard text tools.

4) Click on the Text Animation tab where you can animate the text. However, this is not 
recommended unless you are going to display the drawing as part of a presentation. See 
the Impress Guide for more information on text animation.

5) When you have finished formatting and editing your text, move the cursor away from the 
objects and connector and click to end the text mode. The Line and Filling toolbar then 
replaces the Text Formatting toolbar.

Flowcharts

For drawing flowcharts (also known as flow diagrams), Draw has a Flowchart toolbar that includes 
a large selection of flowchart tools to help you to easily draw a flowchart.(Figure 11 and Figure 12). 

Click on the small triangle to the right of the Flowchart icon  on the Drawing toolbar to open the 
Flowchart toolbar. Note that this icon changes shape depending on the last flowchart tool used. 
This toolbar can become a floating toolbar by clicking on the bottom of the pop-up toolbar and 
dragging it into your workspace.
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Figure 11: Flowchart toolbar

Figure 12: Flowchart tools

1) When adding objects to your flowchart, see Chapter 2 Drawing Basic Shapes for 
information on how to draw and resize object shapes.

2) Add text to each flowchart shape to make it easily identified in the flowchart. See Chapter 2 
Drawing Basic Shapes and Chapter 9 Advanced Draw Techniques for more information.

3) Use connections lines in your flowchart. This allows repositioning of an object in your chart 
while maintaining connections with the other objects in the chart. See “Connectors and glue 
points” on page 4 for more information.

4) Use the zoom, grid and snap functions to help in positioning objects in your flowchart. See 
Chapter 3 Working with Objects and Object Points for more information.
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5) Use the alignment and distribution functions to give your flowchart a more professional 
look. See Chapter 5 Combining Multiple Objects for more information.

6) Duplicate objects when you require more than one of the same shape and size. See 
Chapter 5 Combining Multiple Objects for more information.

Organization charts

Draw does not have a toolbar for organization charts, but these charts are easily created using 
basic shapes, flowchart shapes, connection points and connector lines. Hierarchy in an 
organization is easily indicated using shading and/or color. When using shading and color in an 
organization chart, make sure that your choices provide a good contrast between the text and the 
shading or color to make the chart easy to read on a computer display or in a printed document.

An example of an organization chart is shown in Figure 13. This was drawn using the process 
shape from the Flowchart toolbar and connection lines.

1) When adding objects to your chart, see Chapter 2 Drawing Basic Shapes for information on 
how to draw and resize object shapes.

2) Add text to each object in the organization chart to make it easily identified in the chart. See 
Chapter 2 Drawing Basic Shapes and Chapter 9 Adding and Formatting Text for more 
information.

3) Use connections lines in your organization chart. This allows repositioning of an object in 
your chart while maintaining connections with the other objects in the chart. See 
“Connectors and glue points” on page 4 for more information.

4) Use the zoom, grid and snap functions to help in positioning objects in your chart. See 
Chapter 3 Working with Objects and Object Points for more information.

5) Use the alignment and distribution functions to give your organization chart a more 
professional look. See Chapter 5 Combining Multiple Objects for more information.

6) Duplicate objects when you require more than one of the same shape and size. See 
Chapter 5 Combining Multiple Objects for more information.

Figure 13: Example organization chart
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